スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

MSFC を搭載した Catalyst 6500/6000 スイッチでの IP MLS の設定とトラブルシューティング

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2011 年 1 月 18 日) | 英語版 (2015 年 9 月 19 日) | フィードバック


目次


概要

このドキュメントでは、Catalyst 6500/6000 での MultiLayer Switching(MLS; マルチレイヤ スイッチング)コマンドの確認項目と、読み込み方法について説明します。 また、MLS 内容に関する非常に簡単な説明と、MLS の使用例も記載しています。 これらの例を元にして、MLS の動作を確認する方法と、MLS の設定に関する簡単なトラブルシューティングのヒントも記します。

このドキュメントでは、次のハードウェアを搭載した Catalyst 6500/6000 シリーズ スイッチだけを対象としています。

  • Catalyst OS(CatOS)ソフトウェアを実行しているスーパーバイザ エンジン 1A

  • Policy Feature Card(PFC; ポリシー フィーチャ カード)

  • Multilayer Switch Feature Card(MSFC; マルチレイヤ スイッチ フィーチャ カード)

注: このドキュメントは、スーパーバイザ エンジン 2 または Multilayer Switch Module(MSM; マルチレイヤ スイッチ モジュール)などの他のハードウェア構成には適用されません。 それは Cisco IOS を実行するときまた無効ですか。 Supervisor Engine 1A および MSFC 両方のソフトウェア。

CatOS ソフトウェアを実行し、スーパーバイザ エンジン 2 を搭載する Catalyst 6500/6000 シリーズ スイッチでのユニキャスト ルーティングのトラブルシューティングに関する類似の情報については、『ハイブリッド モードの Supervisor 2 を搭載する Catalyst 6000 スイッチでのユニキャスト IP ルーティング CEF のトラブルシューティング』を参照してください。

MLS 用語およびオペレーションのより多くの完全な記述に関しては、「関連情報」セクションを参照して下さい。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • MSFC を搭載する Catalyst 6500/6000

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

MSFC での MLS の概要

MSFC(MultiLayer Switch Feature Card)は、Catalyst 6000 内の第 2 世代のルーティング エンジンで、毎秒 1500 万パケットをルーティングできます。 MSFC は、PFC を装着したスーパーバイザ エンジン上でのみ動作します。 MSFC は、PFC を使用して内部 MLS を実行し、Catalyst 5000 では NetFlow Feature Card(NFFC; NetFlow フィーチャ カード)として動作します。 この内部 MLS は外部には現れず、完全にこのスイッチに限定されています。 ユーザによる設定を一切必要とせずに動作し、IP、IPX、および IP マルチキャストに対するハードウェア ショートカットをサポートしています。 MSFC の設定は、VLAN インターフェイスを使用する RSM や RSFC の設定と似ています。 MSFC にアクセスするには、セッション 15(スーパーバイザのスロット 1 の MSFC)またはセッション 16(スーパーバイザのスロット 2 の MSFC)を使用します。

この原則は、Catalyst 5000 の Multilayer Switching Protocol(MLSP; マルチレイヤ スイッチング プロトコル)に似ています。 最初のパケットは MSFC によってルーティングされ、その後、PFC によって同じフローの後続のパケットに使用されるショートカットが作成されます。 ただし、Catalyst 5000 の MLSP とは異なり、MLS-SE と MLS-RP との間の IP 通信が必要となります。Catalyst 6000 上の MLS は、MSFC と PFC をシリアル チャネル(SCP)上で通信させることによって機能します。

PFC は、Catalyst 5000 MLS 環境の MLS-SE になることはできませんが、 ただし、MSFC はネットワーク内の他の Catalyst 5000 に対する MLS-RP になることができます。 その場合、MLS RP として使用される Cisco IOS ルータに実行したコマンドと同じ mls rp ip コマンドを使用して MSFC を設定します。

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6000-series-switches/10566-mls.gif

例 1: 2 つの VLAN 間での MSFC ルーティング

Catalyst 6000 上のユニキャスト IP 用 MLS はプラグアンドプレイです。 設定を行う必要はありません。 次のサンプル設定では、Catalyst 6000 が tamer として示され、それが搭載する MSFC は tamer-msfc として示されています。 VLAN 11 と 12 の間のルーティングは、MLS に関連するコマンドを使用せずに MSFC 上で設定されています。 また、スーパーバイザ エンジンでも MLS 専用の設定はありません。

tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
! 
router eigrp 1 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
no ip http server 
! 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end

show mls エントリの読み方と基本的なチェック

スーパーバイザ エンジンで show mls コマンドを発行すると、次の出力が表示されます。

tamer (enable) show mls 
Total packets switched = 8      

!--- Number of packet shortcuted by MLS.

Total Active MLS entries = 0      

!--- Number of flows currently existing.

MSFC 11.1.1.2 (Module 15) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Destination flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 

IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11      

!--- MSFC recognized by the switch.

show mls コマンド出力には常に IP MSFC ID があります。 show mls コマンドを発行しても IP MSFC ID が表示されない場合は、次の項目を確認してください。

  • MSFC が起動および実行されていること(ROMmon モードのままになっていないか、など)。

  • MSFC で MLS がイネーブルになっていること。

これを確認するには、MSFC 上で次のコマンドを発行します。

tamer-msfc#show mls status 
MLS global configuration status: 
global mls ip:                     enabled     

!--- Should be enabled for unicast IP.

global mls ipx:                    enabled 
global mls ip multicast:           disabled 
current ip flowmask for unicast:   destination only 
current ipx flowmask for unicast:  destination only 

show mls status コマンドを発行すると、MLS が IP、IPX、IP マルチキャストでイネーブルになっているかどうかを調べることができます。 これらの機能は、通常はデフォルトでイネーブルにされていますが、 ただし、次のコマンドを設定モードで実行することによってディセーブルにすることもできます。

no mls ip

no mls ip コマンドはデバッグ目的のみで使用してください。 このコマンドはグローバル コンフィギュレーション モードで隠しコマンドとして使用することもできます。 また、インターフェイス コンフィギュレーション モードで no mls ip コマンドを発行すると、VLAN インターフェイス単位で MLS をディセーブルにできます。

注: MSFC では show mls rp コマンドを発行しないでください。 次のコマンド出力では、MLS がディセーブルになっていることが示されていますが、 スーパーバイザ エンジンで発行した上記の show mls コマンド出力では、MLS が正常に動作していることが示されています。 この矛盾が生じる原因は、Catalyst 5000 スイッチで MLS-RP を実行している場合には、show mls rp コマンドを使用する必要があるためです。

tamer-msfc#show mls rp 
ip multilayer switching is globally disabled 
ipx multilayer switching is globally disabled 
ipx mls inbound acl override is globally disabled 
mls id is 00d0.d39c.9e04 
mls ip address 0.0.0.0 
mls ip flow mask is unknown 
mls ipx flow mask is unknown 
number of domains configured for mls 0

候補パケットとは、MLS ショートカットのセットアップを起動できる可能性のあるパケットのことです。 この宛先 MAC アドレスは、MLS を実行しているルータの MAC アドレスと同じです。 この場合、MSFC の MAC アドレスは 00-d0-d3-9c-9e-3c です。これは、show mls コマンドを発行して表示されます。 次のように show cam mac_address コマンドを発行すると、この MAC アドレスがルータの MAC アドレスであることをスイッチが認識していることを確認できます。

tamer (enable) show cam 00-d0-d3-9c-9e-3c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 
VLAN  Dest MAC/Route Des    [CoS]  Destination Ports or VCs / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-d0-d3-9c-9e-3c R#          15/1 
12    00-d0-d3-9c-9e-3c R#          15/1 
Total Matching CAM Entries Displayed = 2

この出力では、この MAC アドレスがポート 15/1(スロット 1 にある MSFC ポート)にリンクされているルータ エントリであることを、スイッチが認識していることを確認できます。

スイッチのスーパーバイザ エンジンで show mls コマンドを発行しても MSFC が表示されない場合は、次のコマンドを発行します。

tamer (enable) show mls rlog l2 
SWLOG at 815d0c50: magic 1008, size 51200, cur 815d4170, end 815dd460 
Current time is: 08/08/00,17:13:25 

118 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 12 Earl AL =0 
117 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 12, i/f 1, proto 0, LC 3 
116 08/08/00,17:13:16:(RouterConfig)Router_cfg: router_add_MAC_to_earl 00-d0-d3-
9c-9e-3c  added for mod 15/1 Vlan 11 Earl AL =0 
115 08/08/00,17:13:16:(RouterConfig)Router_Cfg: Process add mls entry for mod 15
/1 vlan 11, i/f 1, proto 0, LC 3

このコマンドを実行すると、スイッチが MSFC から受信しているメッセージが表示され、ルータ エントリが追加されているかどうかを確認できます。

show mls 出力テーブルの読み込み

show mls entry コマンドを発行すると、すべてのショートカットに関する完全な MLS テーブルを表示します。 次の出力では、すべてのフローを受信していることが示されています。

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
10.68.5.1       -               -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        -               -     -      -      00-00-0c-09-50-66 11   ARPA 
ESrc DPort  SPort  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 1/3    7/3    4          400         00:00:02 00:00:02 
ARPA 7/4    7/3    4          400         00:00:08 00:00:08 
ARPA 7/3    7/4    9          900         00:00:08 00:00:08 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 2 
tamer (enable)

注: 宛先ごとに 1 つのフローが作成されます。 上記の出力の最後の 2 行に示されているように、12.1.1.1 ~ 11.1.1.1 に ping を実行すると、2 つのフロー(各宛先に 1 つ)が作成されます。

このテーブルに表示されている情報を次で説明します。

  • Destination IP、Source IP、Prot、DstPrt、SrcPrt は、ショートカットを作成するために使用されるフィールドです。 この場合は、「destination only」のフローを使用しているため、 フローの宛先 IP アドレスだけがキャッシュされています。 これはフローマスクを修正することにより変更できます。フローマスクについては、このドキュメントで後ほど説明します。

  • 宛先 MAC は、パケットの宛先 MAC アドレスを書き換えるために使用される MAC アドレスです。 送信元 MAC アドレスは、MSFC の MAC アドレスで書き換えられます。

  • VLAN は、この IP アドレスに到達するために必要な宛先の VLAN を示しています。 宛先 VLAN は、トランクでパケットを送信する場合などで重要です。

  • DPort および Sport は、フローの宛先および送信元のポートです。

  • Stat-Pkts および Stat-Bytes は、フローが生成されてからこのショートカットを使用したパケットの数の統計情報です。

  • Uptime は、フローが作成されてからの経過時間です。

  • Age は、このフローを最後に使用してからの経過時間です。

フローを destination-source に変更します。 show mls entry コマンド出力には、送信元 IP アドレスと宛先 IP アドレスの両方がキャッシュされていることが示されています。 次のように、同じ宛先 IP アドレスに対して通信を行う送信元 IP アドレスごとに異なるフローが作成されました。

tamer (enable) set mls flow destination-source 
Configured IP flowmask is set to destination-source flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
tamer (enable) 2000 Aug 09 17:05:12 %MLS-5-FLOWMASKCHANGE:IP flowmask changed 
 from DEST to DEST-SRC 

tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        -     -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        10.68.5.1       -     -      -      00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        -     -      -      00-d0-00-3f-a3-ff 8    ARPA 
12.1.1.1        11.1.1.1        -     -      -      00-00-0c-8c-70-88 12   ARPA 
MSFC 0.0.0.0 (Module 16): 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:02 00:00:02 
ARPA 7/3    1/3    4          400         00:00:32 00:00:32 
ARPA 1/3    7/3    4          400         00:00:32 00:00:32 
ARPA 7/4    7/3    4          400         00:00:02 00:00:02 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Pkts  Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 0.0.0.0 (Module 16): 


Total entries displayed: 4
tamer (enable)

3 つめの選択肢では、MLS に full-flow を設定します。 TCP ポートごとに異なるフローが作成される方法を確認するには、いくつかの ping と Telnet セッションを実行します。 次に示すのは、ping と Telnet セッションをいくつか実行した場合の MLS テーブルです。 full flow を使用すると、作成されるフローの数が急速に増加します。 TCP ポート情報が MLS テーブルにキャッシュおよび表示されます。

tamer (enable) set mls flow full 
Configured IP flowmask is set to full flow. 
Warning: Configuring more specific flow mask may increase the number of MLS 
 entries dramatically. 
Tamer (enable) 2000 Aug 09 17:30:01 %MLS-5-FLOWMASKCHANGE:IP flowmask changed
 from DEST to FULL 

tamer (enable) 
tamer (enable) show mls entry 
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        12.1.1.1        TCP   11001  Telnet 00-00-0c-09-50-66 11   ARPA 
12.1.1.1        11.1.1.1        TCP*  Telnet 11001  00-00-0c-8c-70-88 12   ARPA 
11.1.1.1        10.68.5.1       TCP   11002  Telnet 00-00-0c-09-50-66 11   ARPA 
10.68.5.1       11.1.1.1        ICMP  -      -      00-d0-00-3f-a3-ff 8    ARPA 
10.68.5.1       11.1.1.1        TCP*  Telnet 11002  00-d0-00-3f-a3-ff 8    ARPA 
11.1.1.1        10.68.5.1       ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
ARPA 7/3    7/4    16         688         00:00:26 00:00:24 
ARPA 7/4    7/3    18         757         00:00:26 00:00:24 
ARPA 7/3    1/3    61         4968        00:00:16 00:00:06 
ARPA 1/3    7/3    4          400         00:00:33 00:00:33 
ARPA 1/3    7/3    69         2845        00:00:17 00:00:06 
ARPA 7/3    1/3    4          400         00:00:33 00:00:33 
ARPA 7/3    7/4    4          400         00:00:32 00:00:31 

  
Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 

Total entries displayed: 8

注意事項

  • 実稼働ネットワークでは、作成されるフローの数は数千に上ります。 show mls entry ip [宛先を発行して下さい|source] コマンドを発行します。

    tamer (enable) show mls entry ip destination 12.1.1.1 
    
    Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
    --------------- --------------- ----- ------ ------ ----------------- ---- ---- 
    
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        -               -     -      -      00-00-0c-8c-70-88 12   ARPA 
    
    
    ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
    ---- ------ ------ ---------- ----------- -------- -------- 
    ARPA 7/4    7/3    4          400         00:00:30 00:00:30 
    
  • show mls statistics コマンドを発行すると、次のようにフローの統計情報を確認できます。

    tamer (enable) show mls statistics entry ip 15 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      9          900 
    11.1.1.1        10.68.5.1       TCP  11005  Telnet 20         913 
    11.1.1.1        10.68.5.1       TCP  11004  Telnet 0          0 
    10.68.5.1       11.1.1.1        ICMP -      -      4          400 
    10.68.5.1       12.1.1.1        ICMP -      -      9          900 
    12.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        10.68.5.1       ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      9          900

特定の接続のトラブルシューティング

特定の IP アドレスや特定の 2 台のホスト間で接続に問題がある場合は、次のトラブルシューティングを実行してください。

  • show mls entry ip [宛先を発行して下さい|source] コマンドを発行して、フローが作成されているかどうかを調べます。

  • show mls statistics entry [source|destination] コマンドを何度か続けて発行し、そのショートカットに対する stat-pakts のカウンタが増えているかどうかを調べます。

  • 関連するフローを確認します。

たとえば、TFTP サーバ 12.1.1.1 と TFTP クライアント 11.1.1.1 の間での、大きなファイルの FTP セッションの場合、次の 2 つのフローをチェックする必要があります。

  • 1 つは 12.1.1.1 を宛先とするもので、TFTP 確認応答(小さなパケット)でだけヒットします(destination-source フローが使用されている場合は、12.1.1.1 のフローの発信元)。

  • もう 1 つは 11.1.1.1 を宛先とするもので、多数の大きなパケット(実際のファイル転送)でヒットします(目的地ソースフローが使用されている場合は、11.1.1.1 のフローの送信元)。

    この例では、12.1.1.1. と 11.1.1.1 との間で約 7.6 MB のファイルを TFTP 転送します。 TFTP を開始する前の MLS stat テーブルを次に示します。

    tamer (enable) show mls statistics entry 
                                      Last    Used 
    Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
    --------------- --------------- ---- ------ ------ ---------- --------------- 
    MSFC 11.1.1.2 (Module 15): 
    12.1.1.1        11.1.1.1        ICMP -      -      4          400 
    11.1.1.1        12.1.1.1        ICMP -      -      4          400 
    12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894
    

TFTP が始まりました。 TFTP トラフィックに対応するフローが 2 つ追加作成されているのが確認できます(udp ポート 69)。

tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  343        10997 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     343        186592 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

TFTP 転送が終了しました。 約 8.1 MB のデータを 14903 個のパケットでサーバからクライアントへ転送し、パケット 1 つあたりの平均サイズは 544 バイトになることが確認できます。 反対方向については、同量のパケットが受信され、平均サイズは 476949÷14904 で 33 バイトになることが確認できます。

Tamer (enable) show mls statistics entry 
                                  Last    Used 
Destination IP  Source IP       Prot DstPrt SrcPrt Stat-Pkts  Stat-Bytes 
--------------- --------------- ---- ------ ------ ---------- --------------- 
MSFC 11.1.1.2 (Module 15): 
12.1.1.1        11.1.1.1        ICMP -      -      4          400 
12.1.1.1        11.1.1.1        UDP  69     50532  14904      476949 
11.1.1.1        12.1.1.1        ICMP -      -      4          400 
11.1.1.1        12.1.1.1        UDP  50532  69     14903      8107224 
12.1.1.1        11.1.1.1        TCP  11000  Telnet 20         894

これらのテーブルは、使用しているネットワークのトラフィック パターンを把握するのに役立ちます。

例 2: HSRP として設定されている同じシャーシ内の 2 つの MSFC

次に HSRP に設定されている 2 つの MSFC の実行コンフィギュレーションと show standby コマンドの出力を示します。 スロット 15 の MSFC は VLAN 12 に対してアクティブになっており、スロット 16 の MSFC は VLAN 11 に対してアクティブになっています。

スロット 15 Slot 16
tamer-msfc#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc 
! 
boot system flash bootflash:
  c6msfc-ds-mz.121-1.E2.bin 
! 
ip subnet-zero 
ip cef 
! 
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.120 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.2 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.2 255.255.255.0 
 no ip redirects 
 standby 11 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.2 255.255.255.0 
 no ip redirects 
 standby 12 priority 105 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless 
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end
tamer-msfc-2#wr t 
Building configuration... 

Current configuration: 
! 
version 12.1 
no service pad 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname tamer-msfc-2 
! 
boot system flash
  bootflash:c6msfc-jsv-mz.121-2.E.bin 
! 
ip subnet-zero 
!
! 
! 
! 
interface Vlan1 
 ip address 10.200.11.121 255.255.252.0 
! 
interface Vlan8 
 ip address 10.68.5.4 255.255.252.0 
! 
interface Vlan11 
 ip address 11.1.1.4 255.255.255.0 
 no ip redirects 
 standby 11 priority 105 preempt 
 standby 11 ip 11.1.1.3 
! 
interface Vlan12 
 ip address 12.1.1.4 255.255.255.0 
 no ip redirects 
 standby 12 preempt 
 standby 12 ip 12.1.1.3 
! 
router eigrp 1 
 network 10.0.0.0 
 network 11.0.0.0 
 network 12.0.0.0 
 no auto-summary 
! 
ip classless!  
! 
line con 0 
 transport input none 
line vty 0 4 
 login 
! 
end


tamer-msfc>show standby 
Vlan11 - Group 11 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:00.814 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is 11.1.1.4 expires in 00:00:09 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0b 
  4 state changes, last state change 00:06:36 
Vlan12 - Group 12 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.380 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is local 
  Standby router is 12.1.1.4 expires in 00:00:09 
  Standby virtual MAC address is 0000.0c07.ac0c 
  2 state changes, last state change 00:12:22
tamer-msfc-2#show standby 
Vlan11 - Group 11 
  Local state is Active, priority 105,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.846 
  Hot standby IP address is 11.1.1.3 configured 
  Active router is local 
  Standby router is 11.1.1.2 expires in 00:00:08 
  Standby virtual MAC address is 0000.0c07.ac0b 
  2 state changes, last state change 00:07:02 
Vlan12 - Group 12 
  Local state is Standby, priority 100,
    may preempt 
  Hellotime 3 holdtime 10 
  Next hello sent in 00:00:02.518 
  Hot standby IP address is 12.1.1.3 configured 
  Active router is 12.1.1.2 expires in 00:00:07,
   priority 105 
  Standby router is local 
  Standby virtual MAC address is 0000.0c07.ac0c 
  4 state changes, last state change 00:04:08

前述の例の情報は、引き続きすべて有効です。 HSRP 設定後の変更内容を確認するには、次のような MLS コマンドの出力を表示します。

show mls コマンドの発行

tamer (enable) show mls 
Total packets switched = 29894 
Total Active MLS entries = 0 
  MSFC 11.1.1.2 (Module 15) entries = 0 
  MSFC 10.200.11.121 (Module 16) entries = 0 
IP Multilayer switching aging time = 256 seconds 
IP Multilayer switching fast aging time = 0 seconds, packet threshold = 0 
IP Current flow mask is Full flow 
Active IP MLS entries = 0 
Netflow Data Export version: 7 
Netflow Data Export disabled 
Netflow Data Export port/host is not configured. 
Total packets exported = 0 
IP MSFC ID      Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    00-d0-d3-9c-9e-3c 12,11,8,1 
                            00-00-0c-07-ac-0c 12 

10.200.11.121   16     2    00-d0-bc-f0-07-b0 1,8,11,12 
                            00-00-0c-07-ac-0b 11 
  

IPX Multilayer switching aging time = 256 seconds 
IPX flow mask is Destination flow 
IPX max hop is 15 
Active IPX MLS entries = 0 

IPX MSFC ID     Module XTAG MAC               Vlans 
--------------- ------ ---- ----------------- ---------------- 
11.1.1.2        15     1    -                 - 

10.200.11.121   16     2    -                 -
  • PFC から確認できる MLS ルータが 2 台あります。

  • 確認できる各ルータでは、HSRP グループが使用する MAC アドレスは 00-00-0c-07-ac-xx です。 これらの MAC アドレスは、HSRP によって使用される仮想 MAC アドレスです。 ここでは、このグループでアクティブになっているルータにリンクされている、グループ 11 の MAC アドレスのみを確認できます(VLAN 12 の場合はスロット 15、VLAN 11 の場合はスロット 16)。 そこで、宛先 MAC アドレスが MSFC MAC アドレスになっているパケットだけでなく、宛先 MAC が HSRP アドレスになっている候補パケットについても確認してみましょう。

  • 最初の例で説明したように、MSFC を指すレイヤ 2 の CAM テーブルにあるこれらの HSRP アドレスを調べる必要もあります。

tamer (enable) show cam 00-00-0c-07-ac-0c 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
12    00-00-0c-07-ac-0c R#          15/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable) 

tamer (enable) show cam 00-00-0c-07-ac-0b 
* = Static Entry. + = Permanent Entry. # = System Entry. R = Router Entry. 
X = Port Security Entry 

VLAN  Dest MAC/Route Des    [COs]  Destination Ports or VCS / [Protocol Type] 
----  ------------------    -----  ------------------------------------------- 
11    00-00-0c-07-ac-0b R#          16/1 
Total Matching CAM Entries Displayed = 1 
tamer (enable)

show mls entry コマンドの発行

tamer (enable) show mls entry
Destination-IP  Source-IP       Prot  DstPrt SrcPrt Destination-MAC   Vlan EDst 
--------------- --------------- ----- ------ ------ ----------------- ---- ---- 
MSFC 11.1.1.2 (Module 15): 
11.1.1.1        12.1.1.1        ICMP  -      -      00-00-0c-09-50-66 11   ARPA 
MSFC 10.200.11.121 (Module 16): 
12.1.1.1        11.1.1.1        ICMP  -      -      00-10-7b-3b-af-3b 12   ARPA 

ESrc DPort  Sport  Stat-Pkts  Stat-Bytes  Uptime   Age 
---- ------ ------ ---------- ----------- -------- -------- 
ARPA 7/3    7/4    4          400         00:00:03 00:00:03 
ARPA 7/4    7/3    4          400         00:00:04 00:00:03 


Destination-IPX           Destination-MAC   Vlan EDst ESrc  Port  Stat-Pkts  
------------------------- ----------------- ---- ---- ---- ----- ---------- 
Stat-Bytes  Uptime   Age 
----------- -------- -------- 

MSFC 11.1.1.2 (Module 15): 
MSFC 10.200.11.121 (Module 16):

  • ここでは、2 つのショートカット テーブルがあります。 1 つは最初の MSFC によって作成されたフロー用で、もう 1 つは 2 番目の MSFC によって作成されたフロー用です。

  • デフォルト ゲートウェイとして HSRP アドレスが設定されている 2 台の PC である 11.1.1.1 と 12.1.1.1 の間で ping を実行することにより、スイッチの VLAN 12 に着信する 12.1.1.1 から 11.1.1.1 へのパケットは、スロット 15 の MSFC によってショートカットされ(VLAN 12 に対するアクティブな HSRP ルータであるため)、宛先 11.1.1.1 へのショートカットがスロット 15 の MSFC によって作成されます。 11.1.1.1 から 12.1.1.1 へのパケットのためのショートカットは、スロット 16 の MSFC によって反対側で作成されています。

トラブルシューティングのヒント

フローの作成

フローが作成されない場合は、次のトラブルシューティングのヒントを確認してください。

  • show mls を実行すると、スーパーバイザが MSFC とそれに対応するすべての MAC アドレスを認識しますか。

    • YES の場合は次のステップに進んでください。

    • 問題がある場合は、MSFC が ROMmon モードのままになっていないかどうか確認します。 show mls status コマンドを発行して、MSFC 上で MLS が有効にされているかどうかを確認してください。

  • show cam コマンドを発行すると、MSFC の MACアドレスが表示されますか。 また、それはルータの cam エントリ(R#)として表示されますか。

  • MLS を無効にする機能を MSFC 上で設定していないかどうかを確認してください。

    • MLS に影響を与える機能については、実行しているソフトウェア バージョンのリリース ノートで確認できます。

    • 制限の例を次の表に示します。

      IP ルータ コマンドの制限

      コマンド 動作
      clear ip route この MSFC に対してレイヤ 3 スイッチングを実行しているすべてのスイッチの MLS キャッシュ エントリをすべてクリアします。
      IP ルーティング no 形式では、MSFC 上のすべての MLS キャッシュ エントリが削除され、IP MLS がディセーブルになります。
      ip security(このコマンドの全形式) インターフェイス上の IP MLS を無効にします。
      ip tcp compression-connections インターフェイス上の IP MLS を無効にします。
      ip tcp header-compression インターフェイス上の IP MLS を無効にします。

  • ハードウェア ショートカットによる処理ではなく、ソフトウェアによる処理を要求するアクセスリストを有効にしていないかどうかを確認します。 詳細は、「IOS ACL のハードウェアおよびソフトウェア処理」を参照してください。

上記の事項をすべて確認しても問題が解消しない場合は、MSFC が現在も多数のパケットによってヒットされているかどうかを確認してください。

  • 何らかの原因で、エントリが絶えず消去されている可能性があります。 フロー テーブルが消去される原因として、次のようなものがあります。

    • ルート フラッピングまたはレイヤ 3 の不安定な状態

    • MSFC 上の ARP キャッシュが変更されます。

    • スーパーバイザ エンジンでのフローマスクの変更

    • 宛先 VLAN の削除

    • MSFC 内の VLAN インターフェイスがシャットダウンする

  • ハードウェア ショートカットではなく、ソフトウェアによる転送が起きる(パケットが MSFC をヒット)原因には、次のようなものがあります。

    • IP オプション セットを持つパケット

    • パケットの TTL が 1 以下である

    • 断片化が必要なパケット

  • 最大 128 K までのフローを扱うことができますが、ハッシュ アルゴリズムが使用されます。 フローが 32 K を超える場合はハッシュ コリジョンが始まり、パケットがソフトウェアによってルーティングされるようになる場合があります。

    • フローの過度な増加を回避するには、MLS フローに対してファスト エージングを設定する方法があります。

  • MLS は、IP、IPX、IP マルチキャストのみを対象としている点に注意してください。 他のタイプのトラフィック(AppleTalk など)を使用している場合、ソフトウェア ルーティングが行われ、MSFC の CPU の使用量がピークに達したり、過剰な数のパケットが MSFC にヒットしたりすることがあります。

  • 先述したように、IP MLS と IPX MLS はデフォルトでイネーブルにされていますが、IP マルチキャスト MLS はデフォルトではイネーブルにされていません。 IP マルチキャストを使用している場合は、設定ガイドに従い、必ず MLS をマルチキャストに対してイネーブルにしてください。

注: Catalyst 5000 スイッチでの MLS のように、スパニング ツリーの Topology Change Notification(TCN; トポロジ変更通知)や、Catalyst 6500/6000 シリーズ スイッチでのポートのフラッピングによって、MLS フロー テーブルはクリアされません。

IP アカウンティングで MLS トラフィックが除外される

Cisco Catalyst 6500 シリーズには Multiple Layer Switching(MLS; マルチ レイヤ スイッチング)が導入されているため、フローが確立されると、トラフィックが直接 PFC でスイッチングされて(ハードウェア スイッチング)、MSFC では処理されず、連続してアカウンティングを実行できません。 IP アカウンティングをイネーブルにすると、新しいフローまたはプロセス スイッチング フロー(ソフトウェア スイッチング)だけが記録されます。その場合でも、エントリがデータベースに入力されて初めて記録されます。 そのため、それらのプラットフォームで IP アカウンティングをイネーブルにすると、通常、警告メッセージが表示されます。

6500(config)#int fa8/40
6500(config-if)#ip accounting
Accounting will exclude mls traffic when mls is enabled.

NetFlow アカウンティングを使用することを推奨します。 NetFlow の詳細については、「NetFlow の設定」を参照してください。

インターフェイス フル フローマスクを設定できない

C6500#mls flow ip interface-full
%  Unable to configure flow mask for ip protocol: interface-full. Reset
to the default flow mask type: none

show fm fie flowmask detail コマンドを発行して、NAT がイネーブルになっているかどうかと Intf Full Flow マスクを使用しているかどうかを確認します。

C6500#show fm fie flowmask detail

!--- Part of the output not shown

Primary Flowmasks registered by Features
----------------------------+------------------------+------------------
---
          Feature                   Flowmask             Flowmask Status
----------------------------+------------------------+------------------
---
 IP_ACCESS_INGRESS               Intf Full Flow		Disabled/Unused
 IP_ACCESS_EGRESS                Intf Full Flow		Disabled/Unused
 NAT_INGRESS                     Intf Full Flow            Enabled
 NAT_EGRESS                      Intf Full Flow            Enabled

!--- Remaining part of the output not shown

NAT が Intf Full Flow マスクを使用し、Netflow に interface-full を設定する場合、フローマスクの競合があるため問題が生じます。 Netflow stat を使用する場合、interface-destination-sourcemls flow ip interface-destination-source コマンド)を使用すると、Netflow マスクの使用との競合は発生しません。

NDE はすべてのフローが同じフロー マスクで作成されていると想定します。 この制限により、NDE をイネーブルにしても、フロー マスクの競合が発生する特定の機能は使用できません。 使用できない機能の例として、ハードウェアアクセラレーション NAT が挙げられます。 NDE とハードウェアアクセラレーション NAT は相互に排他的です。

次のいずれかのイベントが発生すると、NDE は失敗します。

  • ハードウェアアクセラレーション NAT がイネーブルになっている。

  • フロー マスクが競合する 2 つ以上の機能がスイッチで設定されている。

逆に、NDE を正常に設定した後では、NAT をハードウェアで動作するように設定することはできません。また、フロー マスクが競合する 2 つの異なる機能をスイッチで設定することもできません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10566