スイッチ : Cisco Catalyst 6500 シリーズ スイッチ

『PortFast と他のコマンドを使用したワークステーションの接続始動遅延の修復』

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 4 月 26 日) | 英語版 (2015 年 10 月 20 日) | フィードバック


目次


概要

このドキュメントでは、スイッチに接続されているワークステーションで次の 2 つの問題のうち 1 つが発生している場合に生じる初期接続の遅延について説明します。

  • ネットワーク ドメイン(Microsoft Windows NT または Novell のいずれか)にログインできない

  • DHCP アドレスを取得できない

この資料の手順の実装は容易で、ワークステーションの初期化/起動段階で生じるワークステーション接続遅延の最も一般的な原因に対処しています。

前提条件

要件

多くの顧客がデスクトップにスイッチングを導入し、共有ハブをスイッチに置き換える状況では、クライアント/サーバ環境で初期接続の遅延が発生することがよくあります。 Windows 95/98/NT、Novell、Banyan Virtual Integrated Network Service(VINES)、IBM NetworkStation/IBM Thin Clients、および AppleTalk クライアントからサーバに接続できない状況が最もよく発生しています。 これらのクライアントのソフトウェアが起動処理中に持続しないと、スイッチによってトラフィックのパス スルーが許可される前に、クライアントはサーバとの接続の試行を停止します。

この初期接続の遅延は、初めてワークステーションをブートするときにエラーとして示されることがよくあります。 表示される可能性のあるエラー メッセージおよびエラーの例は、次のとおりです。

  • Microsoft ネットワーキング クライアントで「No Domain Controllers Available」と表示される。

  • DHCP で「No DHCP Servers Available」と報告される。

  • Novell Internetwork Packet Exchange(IPX)ネットワーキング ワークステーションで、起動時に Novell Login 画面が表示されない。

  • AppleTalk ネットワーキング クライアントで「Access to your AppleTalk network has been interrupted. To re-establish your connection, open and close the AppleTalk control panel」と表示される。 AppleTalk クライアントのセレクタ アプリケーションにゾーン リストが表示されないか、不完全なゾーン リストが表示される場合もある。

  • IBM ネットワーク ステーションに次のいずれかのメッセージが表示される。

    • NSB83619--Address resolution failed

    • NSB83589--Failed to boot after 1 attempt

    • NSB70519--Failed to connect to a server

    IBM はこの問題に対処するためのフィックスを作成しました。 このフィックスは V2R1 コードの PTF 7 に含まれています。 このドキュメントに記載されているスイッチへの接続を試行する前に、顧客のネットワーク ステーション ファームウェア レベルが B305250(2000 年 5 月 25 日現在)である必要があります。

また、初期接続の遅延は、スイッチド環境でネットワーク管理者がソフトウェアまたはドライバをアップデートした場合に頻繁に発生します。 このような場合、クライアントの始動プロセスのより早い時点(パケットを処理する準備ができる前)でネットワーク初期化手順が行われるようにするため、ベンダーがドライバを最適化することがよくあります。

一部のスイッチには現在さまざまな機能が組み込まれているため、新たに接続したワークステーションに対しスイッチが処理を開始するまでにかかる時間は、約 1 分ほどです。 この遅延は、ワークステーションをオンにするかまたはリブートするたびにワークステーションに影響します。 この遅延の原因となる 4 つの機能は、次のとおりです。

  • スパニング ツリー プロトコル(STP)

  • EtherChannel ネゴシエーション

  • トランキング ネゴシエーション

  • スイッチとワークステーションとの間でのリンク速度およびデュプレックスのネゴシエーション

この 4 つの機能は、発生する遅延の順に示されています。 STP が原因で発生する遅延が最長であり、速度/デュプレックス ネゴシエーションが原因で発生する遅延が最短です。 通常、スイッチに接続するワークステーションが原因でスパニング ツリー がループすることはなく、EtherChannel は不要であり、トランキング方式をネゴシエートする必要はありません。 始動時間を可能な限り最適化する必要がある場合は、リンク速度および検出のネゴシエーションをディセーブルにして、ポートの遅延を低減することもできます。

このドキュメントでは、3 つの Cisco Catalyst スイッチ プラットフォームで始動速度最適化コマンドを実装する方法について説明します。 タイミングのセクションでは、スイッチ ポート遅延がどのように、またどれだけ削減されるかが示されます。

使用するコンポーネント

このドキュメントの例では、次の機器が使用されます。

  • スイッチ内のスーパーバイザ エンジンに適合したコンソール ケーブル

    Catalyst スイッチのコンソール ポートに端末を接続する方法」を参照してください。

  • Catalyst OS(CatOS)ソフトウェア バージョン 4.5(1) が稼働する Catalyst 5505

  • Catalyst 6000 スイッチ Cisco IOS を実行するか。 ソフトウェア リリース 12.1(6)E

  • Cisco IOS ソフトウェア リリース 12.1(11b)EW が稼働する Catalyst 4000 スイッチ

  • Catalyst 2948G-L3 スイッチ

  • Cisco IOS ソフトウェア リリース 11.2(8.2)SA6 が稼働する Catalyst 2900XL スイッチ

  • Enterprise Edition ソフトウェア バージョン 8 が稼働する Catalyst 1900 スイッチ

  • Port Aggregation Protocol(PAgP)およびトランキングが可能なファスト イーサネット モジュール

  • スイッチに接続する RJ-45 イーサネット クロスオーバー ケーブル

  • スイッチに接続する PC

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

このドキュメントでは、「ワークステーション」、「エンド ステーション」、「サーバ」という用語を同じ意味で使用します。 これらの用語は、1 枚のネットワーク インターフェイス カード(NIC)によってスイッチに直接接続されているあらゆるデバイスを指しています。 これらの用語は、複数の NIC を装着したデバイスを指すこともあります(この場合 NIC は冗長性を確保する目的でのみ使用されています)。 つまり、ワークステーションまたはサーバはブリッジとして機能するようには設定されていませんが、ワークステーション/サーバには冗長性のために複数の NIC が装着されています。

サーバ NIC の中には、トランキングと EtherChannel の両方、あるいはそのどちらかをサポートするものがあります。 サーバが複数の VLAN 上で同時に実稼動中である必要があったり(トランキング)、サーバをスイッチに接続しているリンク上により広い帯域幅を必要とする場合があります(EtherChannel)。 この場合、PAgP を off にしたり、トランキングを off にすることはありません。 これらのデバイスを off にしたりリセットすることもほとんどありません。 このドキュメントの手順は、これらのタイプのデバイスには適用されません。

背景説明

ここでは、一部のスイッチに装備されており、デバイスをスイッチに接続する際の初期遅延の原因となる 4 つの機能について説明します。 通常、ワークステーションが原因でスパニング ツリーの問題(ループ)が発生したり、ワークステーションに機能(通常は PAgP、Dynamic Trunking Protocol(DTP))が必要になることはありません。このため、ワークステーションの場合は、遅延に関する問題は関係ありません。

Spanning Tree

ハブ環境からスイッチ環境への移行を最近開始した場合、ハブとスイッチでは動作がかなり異なるため、接続開始時の遅延が発生する可能性があります。 スイッチによる接続は、物理層ではなくデータリンク層で行われます。 スイッチはブリッジング アルゴリズムを使用して、ポートで受信されたパケットを別のポートに送り出す必要があるかどうかを判断します。 ブリッジ アルゴリズムでは、ネットワーク トポロジ内で物理ループが作成されやすくなります。 ループが生成されやすいため、スイッチでは、STP プロトコルを実行してトポロジ内のループを除去します。 STP を実行すると、STP によるループの検出とブロックが行われるため、スパニング ツリー プロセスに関与するすべてのポートがアクティブになるまでの時間が、そうでない場合よりも長くかかります。 物理ループのあるブリッジ型ネットワークは、STP を実行しないと破損します。 このプロセスにかかる時間に関わらず、STP は有用です。 Catalyst スイッチで稼動する STP は、業界標準の仕様です(IEEE 802.1D)。

スイッチ ポートにリンクが接続され、このポートがブリッジ グループに参加すると、このポート上で STP が実行されます。 STP を実行するポートは、次の 5 種類のステートのいずれかになります。

  • ブロッキング

  • リスニング

  • ラーニング

  • フォワーディング

  • disabled

STP は、ポートが ブロッキングで開始し、その後すぐに リスニング フェーズと ラーニング フェーズに進むように指示します。 デフォルトでは、ポートは、リスニング フェーズで約 15 秒、ラーニング フェーズで約 15 秒を費やします。 リスニング ステートでは、スイッチによって、ポートがスパニング ツリー トポロジのどこに適合するのかが判別されます。 スイッチは特に、このポートが物理ループの一部かどうかを調べようとします。 ポートがループの一部である場合、このポートを ブロッキング モードにすることを選択できます。 ブロッキング モードでは、ループを解消するためにポートがユーザ データを送受信しません。 ポートがループの一部ではない場合、このポートはラーニング ステートになります。ラーニング ステートでは、ポートはこのポートを使用している MAC アドレスを確認できます。 この STP 初期化プロセス全体では、約 30 秒かかります。

ワークステーションまたはサーバが 1 枚の NIC カードまたは IP フォンを使用してスイッチ ポートに接続されている場合、この接続によって物理ループが発生することはありません。 このような接続は、リーフノードとみなされます。 ワークステーションが原因でループが発生することがないため、スイッチによるループの検出のためにワークステーションを 30 秒間待機する必要はありません。 シスコにより PortFast または fast-start 機能が追加されました。 この機能により、このポートの STP は、ポートがループの一部でないと想定し、即時にフォワーディング ステートに移行します。ブロッキング ステート、リスニング ステート、またはラーニング ステートには進みません。 このコマンドは、STP をオフにはしません。 このコマンドを使用すると、STP が、選択したポートで最初のいくつかのステップ(この状況では不要なステップ)をスキップします。

注意 注意:  他のスイッチやハブ、あるいはルータに接続されているスイッチ ポートで PortFast 機能を使用しないでください。 これらの接続が原因で物理ループが発生することがあり、物理ループが発生した場合はスパニング ツリーで初期化手順を最初から最後まで実行する必要があります。 スパニング ツリー ループがあると、ネットワークがダウンする可能性があります。 物理ループの一部であるポートの PortFast を on にすると、ある時間帯において、パケットが継続的に転送され(多重化されることもあります)、ネットワークが復元できなくなる可能性があります。

EtherChannel

スイッチでイネーブルにできるその他の機能には、EtherChannel、Fast EtherChannel(FEC)、または Gigabit EtherChannel(GEC)があります。 これらの機能により、2 台の同一デバイス間の複数リンクが 1 つの高速リンクのように機能し、リンク間でトラフィックのロード バランシングが行われるようになります。 スイッチは、PAgP を使用してネイバーとのバンドルを自動的に作成できます。 PAgP を実行できるスイッチ ポートは通常デフォルトで auto モードと呼ばれるパッシブ モードになります。 auto モードでは、リンク上のネイバー デバイスがバンドルの作成を要求すると、スイッチがバンドルを作成します。 auto モードでプロトコルを実行すると、コントロールがスパニングツリー アルゴリズム(STA)に渡される前に、最大 15 秒のポート遅延が発生することがあります。 PAgP は、STP よりも前にポートで実行されます。 ワークステーションに接続されているポート上で PAgP を実行する必要はありません。 スイッチ ポートの PAgP モードを off に設定すると、この遅延が解消されます。

トランキング

スイッチの別の機能として、ポートによるトランク作成機能があります。 トランクは、2 台のデバイスが複数の VLAN からのトラフィックを伝送する必要がある場合に、これらのデバイスの間に設定されます。 VLAN は、ワークステーションのグループがそれ自体のセグメントまたはブロードキャスト ドメイン上に存在していると見せかけるために、スイッチによって作成されます。 単一の VLAN で全体がカバーされるように、トランク ポートによってこれらの VLAN が複数のスイッチに拡張されます。 VLAN をこのように拡張するために、トランク ポートにより、パケットが属する VLAN を示すタグがパケットに追加されます。

トランキング プロトコルにはさまざまなタイプがあります。 ポートをトランクにできる場合、ポートが自動的にトランクできる可能性があります。 場合によっては、そのポートで使用するトランキングのタイプをネゴシエートできることもあります。 DTP は、他のデバイスとの間でトランキング方式をネゴシエートする機能を提供します。 DTP の原型は、Dynamic Inter-Switch Link Protocol(ISL)(DISL)という名前のプロトコルです。 これらのプロトコルが実行されている場合、スイッチのポートがアクティブになる時点で遅延が発生することがあります。

通常、ワークステーションに接続されているポートは 1 つの VLAN だけに属しています。 したがって、ポートはトランクする必要はありません。 ポートがトランクの作成をネゴシエートできる場合、このポートは通常、デフォルトで auto モードになっています。 ポート トランキング モードを off に変更すると、スイッチ ポートがアクティブになる時点での遅延をさらに短縮できます。

速度およびデュプレックス ネゴシエーション

通常、PortFast を on にし、PAgP を off ni する(PAgP が存在する場合)と、初期接続の遅延を解決できます。 ただし、1 秒でも時間を節約する必要がある場合には、スイッチ上でポートの速度とデュプレックスを手動で設定することもできます(ポートがマルチスピード ポート(10/100 Mbps)の場合)。 自動ネゴシエーションは便利な機能ですが、Catalyst 5500/5000 で自動ネゴシエーション機能をオフにすると 2 秒間短縮できます。 自動ネゴシエーションは、Catalyst 2800 または Catalyst 2900XL ではそれほど有用ではありません。

スイッチで自動ネゴシエーションをオフにしても、ワークステーションで自動ネゴシエーションをアクティブなままにすると、スイッチはクライアントとネゴシエートしません。 場合によっては、スイッチが使用しているデュプレックス設定をクライアントが選択しないことがあります。 オート ネゴシエーションに関する注意の詳細については、『イーサネット 10/100/1000Mb 半二重/全二重オート ネゴシエーションの設定およびトラブルシューティング』を参照してください。

CatOS が稼働する Catalyst 4500/4000、5500/5000、および 6500/6000 スイッチ

この項のコマンドは、PortFast を on にし、PAgP ネゴシエーションを off にし、トランキング ネゴシエーション(DISL、DTP)を off にする方法を示します。 たとえば、set spantree portfast 2/1-12 enable を発行する場合、一定範囲のポートに対して set spantree portfast コマンドを発行できます。 通常、 set port channel コマンドをオフにするためには、有効なチャネル対応ポートからなる有効なグループを使用する必要があります。 この項の例では、モジュール 2 はポート 2/1-2 またはポート 2/1-4 とのチャネルを形成できます。 これらのポート グループのいずれかを使用できます。

Catalyst 4500/4000 および 5500/5000 用スイッチ ソフトウェア バージョン 5.2 には、新しいコマンドがあります。 set port host コマンドは、「設定」の項に示すコマンドを 1 つのコマンドにまとめて、使いやすくするマクロです。 パケット転送開始に必要な時間を短縮するため、set port host コマンドを発行します。 ポート設定を最適化するため、set port host コマンドは、チャネル モードをオフに設定し、スパニングツリー PortFast をイネーブルにし、トランク モードをオフに設定し、さらに IEEE 802.1Q(dot1q)トンネル機能をディセーブルにします。 スパニングツリー PortFast がイネーブルの場合、単一ホストに接続されたポートだけに対して set port host コマンドを発行します。 ハブ、コンセントレータ、スイッチ、およびブリッジを fast-start ポートに接続すると、一時的にスパニングツリー ループが発生することがあります。

設定

Switch -A> (enable) set spantree portfast 2/1 enable

Warning: Spantree port fast start should only be enabled on ports connected to
a single host. Connecting hubs, concentrators, switches, bridges, etc. to a
fast start port can cause temporary spanning tree loops. Use with caution.
		
Spantree port 2/1 fast start enabled.
Switch-A> (enable) set port channel 2/1-2 off
Port(s) 2/1-2 channel mode set to off.

Switch-A> (enable) set trunk 2/1 off
Port(s) 2/1 trunk mode set to off.

設定の変更は、自動的に NVRAM に保存されます。

確認

このドキュメントで使用するスイッチ ソフトウェアのバージョンは 4.5(1) です。 show version コマンドshow module コマンド の完全な出力については、このドキュメントの「 DTP、PAgP、および PortFast を使用した/使用しない、Catalyst 5500 でのタイミング テスト」の項を参照してください。

Switch-A> (enable) show version
WS-C5505 Software, Version McpSW: 4.5(1) NmpSW: 4.5(1)

show port spantree コマンドは、STP に関するポートの現在のステートを表示する方法を示します。 現在、ポートは STP フォワーディング ステート(パケットの送受信)であり、Fast-Start カラムに、PortFast が現在ディセーブルになっていることが示されています。 ポートの初期化時には常に、フォワーディング ステートへ進むのに少なくとも 30 秒かかります。

Switch-A> (enable) show port spantree 2/1

Port      Vlan  Port-State     Cost   Priority  Fast-Start  Group-Method
--------  ----  -------------  -----  --------  ----------  ------------
 2/1      1     forwarding        19        32  disabled

このスイッチ ポートで PortFast をイネーブルにします。 このコマンドを単一ホスト(ワークステーション、サーバなど)に接続されているポートだけで使用し、他のハブやスイッチに接続されているポートでは使用しないように、スイッチから警告が発せられます。 単一ホストでは PortFast がイネーブルになり、ポートはただちに転送を開始します。 ワークステーションまたはサーバが原因でネットワーク ループが発生することはありません。

Switch-A> (enable) set spantree portfast 2/1 enable

Warning: Spantree port fast start should only be enabled on ports connected
to a single host.  Connecting hubs, concentrators, switches, bridges, etc. to
a fast start port can cause temporary spanning tree loops.  Use with caution.

Spantree port 2/1 fast start enabled.

PortFast がこのポートでイネーブルになっていることを検証するには、次のコマンドを発行します。

Switch-A> (enable) show port spantree 2/1

Port      Vlan  Port-State     Cost   Priority  Fast-Start  Group-Method
--------  ----  -------------  -----  --------  ----------  ------------
 2/1      1     forwarding        19        32  enabled

1 つまたは複数のポートの PortFast 設定を表示するには、特定の VLAN の STP 情報を表示する方法もあります。 このドキュメントの「DTP、PAgP、および PortFast を使用した/使用しない、Catalyst 5500 でのタイミング テスト」で、STP が進む各ステージをリアルタイムで報告するようにスイッチを設定する方法を説明します。 次の show spantree コマンド出力にも、転送遅延時間(15 秒)が示されます。 これは、STP がリスニング ステートである時間と、VLAN の各ポートで STP がラーニング ステートである時間です。

Switch-A> (enable) show spantree 1
VLAN 1
Spanning tree enabled
Spanning tree type          ieee

Designated Root             00-e0-4f-94-b5-00
Designated Root Priority    8189
Designated Root Cost        19
Designated Root Port        2/24
Root Max Age   20 sec    Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-90-92-b0-84-00
Bridge ID Priority          32768
Bridge Max Age 20 sec    Hello Time 2  sec   Forward Delay 15 sec

Port      Vlan  Port-State     Cost   Priority  Fast-Start  Group-Method
--------- ----  -------------  -----  --------  ----------  ------------

 2/1      1     forwarding        19        32   enabled              

!--- Output suppressed.

PAgP が off になっているかどうかを確認するには、次の show port channel コマンドを使用します。 チャネルが作成されていない場合でもコマンドによってチャネル モードが表示されるように、モジュール番号を指定してください。 チャネルが作成されていない場合に show port channel を実行すると、出力に、チャネリングしているポートがないことが示されます。 さらに進み、現在のチャネル モードを表示する必要があります。

次に show port channel コマンドの例を示します。 この例ではモジュール番号 2 が指定されます。

Switch-A> (enable) show port channel
No ports channeling
Switch-A> (enable) show port channel 2
Port  Status     Channel   Channel     Neighbor                  Neighbor
                 mode      status      device                    port
----- ---------- --------- ----------- ------------------------- ----------
 2/1  notconnect auto      not channel
 2/2  notconnect auto      not channel

!--- Output suppressed.

Switch-A> (enable) set port channel 2/1-2 off
Port(s) 2/1-2 channel mode set to off.

Switch-A> (enable) show port channel 2
Port  Status     Channel   Channel     Neighbor                  Neighbor
                 mode      status      device                    port
----- ---------- --------- ----------- ------------------------- ----------
 2/1  connected  off       not channel
 2/2  connected  off       not channel

!--- Output suppressed.

トランキング ネゴシエーションが off であることを検証するには、set trunk off コマンドを発行します。 この項の set trunk off コマンドの出力例には、次の情報が示されています。

  • デフォルトの状態

  • トランキングが off であること

  • 結果の状態

例ではモジュール番号 2 を指定して、このモジュールにあるポートの現在のチャネル モードを表示できるようにします。

Switch-A> (enable) show trunk 2
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 2/1      auto         negotiate      not-trunking  1
 2/2      auto         negotiate      not-trunking  1

!--- Output suppressed.

 
Switch-A> (enable) set trunk 2/1-2 off
Port(s) 2/1-2 trunk mode set to off.

Switch-A> (enable) show trunk 2
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 2/1      off          negotiate      not-trunking  1
 2/2      off          negotiate      not-trunking  1 

!--- Output suppressed.

このドキュメントでは、スイッチで速度とデュプレックスを手動設定することで、速度/デュプレックス自動ネゴシエーションをオフにする例は示しません。 非常に稀な状況を除いて、この手順は不要です。

DTP、PAgP、および PortFast を使用した/使用しない、Catalyst 5500 でのタイミング テスト

ここでは、各種コマンドを適用した場合にスイッチ ポート初期化のタイミングがどのようになるかを示すテストについて説明します。 ベンチマークを確立するため、最初にポートのデフォルト設定を使用します。 複製するのは次の設定です。

  • PortFast はディセーブルです。

  • PAgP(EtherChannel)モードは auto に設定されます。

    チャネリングするよう求められる場合、ポートはチャネリングします。

  • トランキング モード(DTP)は auto に設定されます。

    トランキングするよう求められる場合、ポートはトランキングします。

テストは次のように進行します。

  1. PortFast を on にし、時間を測定します。

  2. PAgP を off にし、時間を測定します。

  3. トランキングを off にし、時間を測定します。

  4. 自動ネゴシエーションを off にし、時間を測定します。

これらのテストはすべて、DTP および PAgP をサポートする 10/100 Mbps ファースト イーサネット カードが装着された Catalyst 5500 で実行します。

PortFast を on にする操作は、このドキュメントの「スパニング ツリー」の項で説明する STP を off にする方法とは異なります。 PortFast を on にすると、STP は引き続きポートで実行されます。 ブロッキング ステート、リスニング ステート、およびラーニング ステートがスキップされ、ポートは直ちにフォワーディング ステートに進みます。 STP を off にしないでください。この操作は VLAN 全体に影響し、ネットワークが物理的なトポロジ ループに対して脆弱になる可能性があります。 重大なネットワークの問題が発生する可能性があります。

次の手順を実行します。

  1. スイッチ ソフトウェアのバージョンと構成を表示するため、show version コマンドshow module コマンドを実行します。

    Switch-A> (enable) show version
    WS-C5505 Software, Version McpSW: 4.5(1) NmpSW: 4.5(1)
    Copyright (c) 1995-1999 by Cisco Systems
    NMP S/W compiled on Mar 29 1999, 16:09:01
    MCP S/W compiled on Mar 29 1999, 16:06:50
    
    System Bootstrap Version: 3.1.2
    
    Hardware Version: 1.0  Model: WS-C5505  Serial #: 066507453
    
    Mod Port Model      Serial #  Versions
    --- ---- ---------- --------- ----------------------------------------
    1   0    WS-X5530   006841805 Hw : 1.3
                                  Fw : 3.1.2
    
                                  Fw1: 3.1(2)
                                  Sw : 4.5(1)
    2   24   WS-X5225R  012785227 Hw : 3.2
                                  Fw : 4.3(1)
                                  Sw : 4.5(1)
    
           DRAM                    FLASH                   NVRAM
    Module Total   Used    Free    Total   Used    Free    Total Used  Free
    ------ ------- ------- ------- ------- ------- ------- ----- ----- -----
    1       32640K  13648K  18992K   8192K   4118K   4074K  512K  119K  393K
    
    Uptime is 28 days, 18 hours, 54 minutes
    
    Switch-A> (enable) show module
    Mod Module-Name         Ports Module-Type           Model    Serial-Num Status
    --- ------------------- ----- --------------------- --------- --------- -------
    1                       0     Supervisor III        WS-X5530  006841805 ok
    2                       24    10/100BaseTX Ethernet WS-X5225R 012785227 ok
    
    Mod MAC-Address(es)                        Hw     Fw         Sw
    --- -------------------------------------- ------ ---------- -----------------
    1   00-90-92-b0-84-00 to 00-90-92-b0-87-ff 1.3    3.1.2      4.5(1)
    2   00-50-0f-b2-e2-60 to 00-50-0f-b2-e2-77 3.2    4.3(1)     4.5(1)
    
    Mod Sub-Type Sub-Model Sub-Serial Sub-Hw
    --- -------- --------- ---------- ------
    1   NFFC     WS-F5521  0008728786 1.0
  2. STP のロギングを最も冗長なレベルに設定するため、 set logging level spantree 7 コマンドを発行します。

    この例では、STP のデフォルト ログ レベルが (2) であり、重大な状況だけが報告されます。

    Switch-A> (enable) show logging
    
    Logging buffer size:          500
            timestamp option:     enabled
    Logging history size:         1
    Logging console:              enabled
    Logging server:               disabled
            server facility:      LOCAL7
            server severity:      warnings(4)
    
    Facility            Default Severity         Current Session Severity
    -------------       -----------------------  ------------------------
    
    !--- Output suppressed.
    
    spantree            2                        2                    
    
    !--- Output suppressed.
    
    0(emergencies)        1(alerts)             2(critical)           
    3(errors)             4(warnings)           5(notifications)      
    6(information)        7(debugging)

    ポートでの STP ステートの変更を確認するため、STP のレベルを 7(デバッグ)に変更します。 この設定変更は、現在のターミナル セッションだけ継続します。

    Switch-A> (enable) set logging level spantree 7
    System logging facility <spantree> for this session set to severity 7(debugging)
    
    Switch-A> (enable) show logging
    
    !--- Output suppressed.
    
    
    Facility            Default Severity         Current Session Severity
    -------------       -----------------------  ------------------------
    
    !--- Output suppressed.
    
    spantree            2                        7                    
    
    !--- Output suppressed.
    
    
  3. set port disable コマンドを発行してポートをシャットダウンします。

    Switch-A> (enable) set port disable 2/1
    Port 2/1 disabled.
  4. スイッチが各ステートであった時間を判別するため、時間を確認してポートをイネーブルにします。

    次の例では、show time コマンドset port enable 2/1 コマンドを使用します。 最も正確なタイミング情報を得るため、次のコマンドをできるだけ迅速に入力します。 このためには、テキスト ファイルで各コマンドを 1 行ずつ入力し、コマンドをクリップボードにコピーし、スイッチに貼り付ける方法があります。

    Switch-A> (enable) show time
    Fri Feb 25 2000, 12:20:17
    Switch-A> (enable) set port enable 2/1
    Port 2/1 enabled.
    Switch-A> (enable)
    2000 Feb 25 12:20:39 %PAGP-5-PORTTOSTP:
       Port 2/1 joined bridge port 2/1
    2000 Feb 25 12:20:39 %SPANTREE-6-PORTBLK: 
       port 2/1 state in vlan 1 changed to blocking.
    2000 Feb 25 12:20:39 %SPANTREE-6-PORTLISTEN: 
       port 2/1 state in vlan 1 changed to Listening.
    2000 Feb 25 12:20:53 %SPANTREE-6-PORTLEARN: 
       port 2/1 state in vlan 1 changed to Learning.
    2000 Feb 25 12:21:08 %SPANTREE-6-PORTFWD: 
       port 2/1 state in vlan 1 changed to forwarding.

    この例では、ポートが STP ブロッキング ステージになるまでに約 22 秒( 20:17 ~ 20:39)が経過しています。 この時間内にポートはブリッジ グループに参加し、DTP および PAgP ネゴシエーションを完了しました。 ブロッキングの開始後、STP レルムに入ります。 STP はブロッキングの直後にリスニング ステート(20:39 ~ 20:39)に進みました。 リスニング ステートには約 14 秒(20:39 ~ 20:53)かかっています。 ラーニング ステート(フォワーディング ステート開始まで)には 15 秒(20:53 ~ 21:08)かかっています。 ポートがトラフィックに対して実際に動作可能になるまでの合計時間は、約 51 秒(20:17 ~ 21:08)です。

    技術的には、リスニング ステージとラーニング ステージはいずれも 15 秒であり、この VLAN に対して設定する転送遅延パラメータもこの値になります。 より正確に測定すれば、ラーニング ステージは(14 秒ではなく)15 秒です。 ここに示されている測定結果は、いずれも正確なものではありません。

  5. show port capabilities コマンドshow trunk コマンドを発行します。

    手順 4 の出力と show spantree コマンドの出力に示されるように、このポートでは STP がアクティブです。 ポートがフォワーディング ステートに達するのを遅らせる要因は他にもあります。 show port capabilities コマンドを実行すると、このポートでトランクおよび EtherChannel の作成を行うことができることが示されます。 show trunk コマンドでは、このポートが auto モードであり、使用するトランキングのタイプをネゴシエートするように設定されていることが示されます(ISL または 802.1Q)。 使用するトランキングのタイプは、DTP を介してネゴシエートされます。

    Switch-A> (enable) show port capabilities 2/1
    Model                    WS-X5225R
    Port                     2/1
    Type                     10/100BaseTX
    
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode   on,off,desirable,auto,nonegotiate
    Channel      2/1-2,2/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    Rewrite                  yes
    Switch-A> (enable) show trunk 2/1
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/1      auto         negotiate      not-trunking  1
    
    !--- Output suppressed.
    
    
  6. ポートで PortFast をイネーブルにします。

    トランキング ネゴシエーション(DTP)および EtherChannel(PAgP)は、auto モードのままになっています。

    Switch-A> (enable) set port disable 2/1
    Port 2/1 disabled.
    
    Switch-A> (enable) set spantree portfast 2/1 enable
    
    Warning: Port fast start should only be enabled on ports connected to a
    single host. Connecting hubs, concentrators, switches, bridges, etc. to a fast
    start port can cause temporary spanning tree loops. Use with caution. 
    			 
    Spantree port 2/1 fast start enabled.
    
    Switch-A> (enable) show time
    Fri Feb 25 2000, 13:45:23
    Switch-A> (enable) set port enable 2/1
    Port 2/1 enabled.
    Switch-A> (enable) 
    Switch-A> (enable)
    2000 Feb 25 13:45:43 %PAGP-5-PORTTOSTP:
       Port 2/1 joined bridgeport 2/1
    2000 Feb 25 13:45:44 %SPANTREE-6-PORTFWD: 
       port 2/1 state in vlan 1 change to forwarding.

    合計時間は 21 秒です。 ポートがブリッジ グループに参加するまでの経過時間は 20 秒(45:23 ~ 45:43)でした。 PortFast がイネーブルであるため、STP が転送を開始するまでの経過時間は(30 秒ではなく)1 秒でした。 PortFast をイネーブルにすることで、29 秒短縮できます。 次に、遅延をさらに縮小できるか試します。

  7. PAgP モードを off にします。

    show port channel コマンドを実行すると、PAgP モードが auto に設定されていることが示されます。これは、PAgP を実行するネイバーからポートに対しチャネリングするよう求められると、ポートがチャネリングすることを意味します。 2 つ以上のポートで構成されるグループに対して、チャネリングを off にする必要があります。 個々のポートに対して、チャネリングを off にすることはできません。

    Switch-A> (enable) show port channel 2/1
    Port  Status     Channel   Channel     Neighbor                  Neighbor
                     mode      status      device                    port
    ----- ---------- --------- ----------- ------------------------- ---------- 
     2/1  connected  auto      not channel
    
    Switch-A> (enable) set port channel 2/1-2 off
    Port(s) 2/1-2 channel mode set to off.
  8. ポートをシャットダウンして、テストを繰り返します。

    Switch-A> (enable) set port disable 2/1
    Port 2/1 disabled.
    
    Switch-A> (enable) show time
    Fri Feb 25 2000, 13:56:23
    Switch-A> (enable) set port enable 2/1
    Port 2/1 enabled.
    Switch-A> (enable)
    2000 Feb 25 13:56:32 %PAGP-5-PORTTOSTP:
       Port 2/1 joined bridgeport 2/1
    2000 Feb 25 13:56:32 %SPANTREE-6-PORTFWD: 
       port 2/1 state in vlan 1 changed to forwarding.

    フォワーディング ステートに達するまでの所要時間は、手順 6 のテストでは 21 秒でしたが、今回は 9 秒(56:23 ~ 56:32)である点に注意してください。 このテストで PAgP を auto から off に変更することで、約 12 秒短縮できます。

  9. トランキングを(auto ではなく)off にして、ポートがフォワーディング ステートに達するまでにかかる時間に、この操作がどのように影響するかを確認します。

    ポートを off にしてから on にして、時間を記録します。

    Switch-A> (enable) set trunk 2/1 off
    Port(s) 2/1 trunk mode set to off.
    Switch-A> (enable) set port disable 2/1
    Port 2/1 disabled.

    トランキングを(auto ではなく)off に設定した状態でテストを開始します。

    Switch-A> (enable) show time
    Fri Feb 25 2000, 14:00:19
    Switch-A> (enable) set port enable 2/1
    Port 2/1 enabled.
    Switch-A> (enable)
    2000 Feb 25 14:00:22 %PAGP-5-PORTTOSTP:
       Port 2/1 joined bridge port 2/1
    2000 Feb 25 14:00:23 %SPANTREE-6-PORTFWD: 
       port 2/1 state in vlan 1 change for forwarding.

    ポートが STP フォワーディング ステートに達するまでにかかる時間が、わずか 4 秒(00:19 ~ 00:22)であることから、開始時点ですでに数秒短縮しています。 トランキング モードを auto から off に変更することで、およそ 5 秒短縮できました。

    スイッチ ポートの初期化時間が問題であった場合は、この時点でこの問題が解決されているはずです。 さらに数秒間短縮する必要がある場合は、手順 10 を実行します。

  10. ((オプション)時間をさらに数秒短縮するには、自動ネゴシエーションを使用する代わりに、ポートの速度とデュプレックスを手動で設定します。

    通常、この手順は始動遅延の問題の解決には必要ありません。

    一方の側で速度とデュプレックスを手動で設定する場合は、もう一方の側でも速度とデュプレックスを同様に設定する必要があります。 ポートの速度とデュプレックスを設定する場合は、そのポート上で自動ネゴシエーションをディセーブルにします。これで、接続デバイスは自動ネゴシエーション パラメータを認識しなくなります。 接続デバイスは半二重でのみ接続します。 このデュプレックス(二重)の不一致が原因で、パフォーマンスが低下し、ポート エラーが発生します。 このような問題を回避するため、両側で速度とデュプレックスを必ず設定してください。

    速度とデュプレックスを設定した後でポートのステータスを表示するには、show port コマンドを発行します。

    Switch-A> (enable) set port speed 2/1 100
    Port(s) 2/1 speed set to 100Mbps.
    Switch-A> (enable) set port duplex 2/1 full
    Port(s) 2/1 set to full-duplex.
    Switch-A> (enable) show port
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     2/1                     connected  1          normal   full   100 10/100BaseTX
    
    !--- Output suppressed.
    
    

    次の例は、タイミングの結果を示します。

    Switch-A> (enable) show time
    Fri Feb 25 2000, 140528 Eastern
    Switch-A> (enable) set port enable 2/1
    Port 2/1 enabled.
    Switch-A> (enable)
    2000 Feb 25 140529 Eastern -0500 %PAGP-5-PORTTOSTP:
       Port 2/1 joined bridgeport 2/1
    2000 Feb 25 140530 Eastern -0500 %SPANTREE-6-PORTFWD: 
       port 2/1 state in vlan 1 changed to forwarding.

    最終結果は 2 秒(0528 ~ 0530)です。

  11. (時計を使って)もう 1 つの視覚的なタイミング テストを実行するには、次の手順を実行します。

    1. スイッチに接続されている PC から、そのスイッチに対して連続 ping(ping -t)を発行します。

    2. スイッチからケーブルを外します。

      ping が失敗します。

    3. ケーブルをスイッチに再び接続して、PC からの ping に対してスイッチが応答するまでの経過時間を時計を見て確認します。

    速度とデュプレックスの自動ネゴシエーションを on にした状態では約 5 ~ 6 秒、off にした状態では約 4 秒です。 このテストには多数の可変条件(PC 初期化、PC ソフトウェア、要求に対するスイッチ コンソール ポートの応答など)が使用されます。 ただし、このテストでは、PC の側からみた応答を得るまでの所要時間がわかります。 この手順のその他のテストはすべて、スイッチの内部デバッグ メッセージの観点からのものです。

Cisco IOS ソフトウェアが稼働する Catalyst 6500/6000 スイッチ

ここでは、スパニング ツリー PortFast を on にして、トランキング ネゴシエーション(DISL、DTP)を off にするためのコマンドを示します。 このオペレーティング システムでは、ポートを EtherChannel に追加するまで PAgP はアクティブになりません。 PAgP を off にする必要はありません。 interface range コマンドを発行して、ポート グループにこれらのコマンドを一括で適用できます。 次の例の interface range コマンドでは、ポート 3/2 ~ 3/4 にコマンドを一括で適用できます。

interface range fastethernet 3/2 -4 コマンド2- の間にはスペースがあります。 このスペースは、構文エラーを回避するために必要です。

Native_IOS#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Native_IOS(config)#interface range fastethernet 3/2 -4
Native_IOS(config-if-range)#

この例で使用するポートは 1 つだけです。 Cisco IOS ソフトウェアのポートは、ルータで検出されるため、デフォルトではルーテッド ポート(レイヤ 3 [L3])です。 スイッチ ポート(レイヤ 2 [L2])として設定されるポートだけにコマンドを追加する必要があります。これは、これらのポートでは L2 プロトコル(スパニング ツリーと DTP)が実行され、その結果として始動時の遅延が発生する可能性があるためです。 ルーテッド ポートをスイッチ ポートにするため、インターフェイス モードで switchport コマンド(コマンドの後ろにパラメータを指定しない)を発行します。

設定

次の手順をデフォルト(L3)ステートのポートから開始します。

  1. ポートをスイッチ ポートとして設定するため、switchport コマンドを発行します。

    コマンドは 1 行に入力して発行します。

  2. DTP を off にするため、ポートをアクセス ポート(専用)として設定します。

  3. スパニング ツリー PortFast 機能を on にします。

  4. 設定を保存します。

次の例の show run interface fastethernet 3/13 コマンドは、このポートの現在の設定を出力します。

Native_IOS#show run interface fastethernet 3/13
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet3/13
 no ip address
 shutdown
end

Native_IOS#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Native_IOS(config)#interface fastethernet 3/13
Native_IOS(config-if)#switchport
Native_IOS(config-if)#switchport mode access
Native_IOS(config-if)#spanning-tree portfast 
%Warning: PortFast should only be enabled on ports connected to a single host.
 Connecting hubs, concentrators, switches,  bridges, etc.to this interface
 when PortFast is enabled, can cause temporary Spanning Tree loops.
 Use with CAUTION

%PortFast has been configured on FastEthernet3/13 but will only
 have effect when the interface is in a non-trunking mode.
Native_IOS(config-if)#no shutdown
Native_IOS(config-if)#^Z
Native_IOS#copy run start

確認

このドキュメントで使用されているスイッチ ソフトウェアのバージョンは、Cisco IOS ソフトウェア リリース 12.1(6)E です。 show version コマンドおよび show module コマンドの完全な出力については、「Cisco IOS システム ソフトウェアが稼動する Catalyst 6500/6000 でのタイミング テスト 」の項を参照してください。

Native_IOS#show version
Cisco Internetwork Operating System Software 
IOS (tm) c6sup1_rp Software (c6sup1_rp-JSV-M), Version 12.1(6)E, EARLY DEPLOYME)

次に、行った変更が反映された後の設定を示します。

Native_IOS#show run interface fastethernet 3/13
Building configuration...

Current configuration : 109 bytes
!
interface FastEthernet3/13
 no ip address
 switchport
 switchport mode access
 spanning-tree portfast
end

Native_IOS#show interfaces fastethernet 3/13 switchport 
Name: Fa3/13
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Native_IOS#show spanning-tree interface fastethernet 3/13
 Port 141 (FastEthernet3/13) of VLAN1 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 128.141.
   Designated root has priority 32768, address 00d0.024f.6001
   Designated bridge has priority 32768, address 00d0.024f.6001
   Designated port id is 128.141, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   BPDU: sent 8984, received 0
   The port is in the PortFast mode
Native_IOS#

Cisco IOS システム ソフトウェアが稼動する Catalyst 6500/6000 でのタイミング テスト

ここでは、各種コマンドを適用した場合にスイッチ ポート初期化のタイミングがどのようになるかを示すテストについて説明します。 ベンチマークを確立するため、最初にポートのデフォルト設定を使用します。 複製するのは次の設定です。

  • PortFast はディセーブルです。

  • トランキング モード(DTP)は auto に設定されます。

    トランキングするよう求められる場合、ポートはトランキングします。

このオペレーティング システムでは、PAgP はデフォルトではアクティブではありません。

テストは次のように進行します。

  1. PortFast を on にし、時間を測定します。

  2. トランキングを off にし、時間を測定します。

  3. 自動ネゴシエーションを off にし、時間を測定します。

PortFast を on にする操作は、このドキュメントの「スパニング ツリー」の項で説明する STP を off にする方法とは異なります。 PortFast を on にすると、STP は引き続きポートで実行されます。 ブロッキング ステート、リスニング ステート、およびラーニング ステートがスキップされ、ポートは直ちにフォワーディング ステートに進みます。 STP を off にしないでください。この操作は VLAN 全体に影響し、ネットワークが物理的なトポロジ ループに対して脆弱になる可能性があります。 重大なネットワークの問題が発生する可能性があります。

次の手順を実行します。

  1. スイッチ ソフトウェアのバージョンと構成を表示するため、show version コマンドshow module コマンドを実行します。

    Native_IOS#show version
    Cisco Internetwork Operating System Software 
    IOS (tm) c6sup1_rp Software (c6sup1_rp-JSV-M), Version 12.1(6)E, EARLY DEPLOYME)
    TAC Support: http://www.cisco.com/cgi-bin/ibld/view.pl?i=support
    Copyright (c) 1986-2001 by cisco Systems, Inc.
    Compiled Sat 17-Mar-01 00:14 by eaarmas
    Image text-base: 0x60020950, data-base: 0x6165E000
    
    ROM: System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE 
    BOOTFLASH: MSFC Software (C6MSFC-BOOT-M), Version 12.1(6)E, EARLY DEPLOYMENT RE)
    
    Native_IOS uptime is 12 hours, 36 minutes
    System returned to ROM by reload (SP by reload)
    System image file is "sup-bootflash:c6sup11-jsv-mz.121-6.E"
    
    cisco Catalyst 6000 (R5000) processor with 114688K/16384K bytes of memory.
    Processor board ID SAD04281AF6
    R5000 CPU at 200Mhz, Implementation 35, Rev 2.1, 512KB L2 Cache
    Last reset from power-on
    Bridging software.
    X.25 software, Version 3.0.0.
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    TN3270 Emulation software.
    24 Ethernet/IEEE 802.3 interface(s)
    1 Virtual Ethernet/IEEE 802.3  interface(s)
    48 FastEthernet/IEEE 802.3 interface(s)
    4 Gigabit Ethernet/IEEE 802.3 interface(s)
    381K bytes of non-volatile configuration memory.
    4096K bytes of packet SRAM memory.
    
    16384K bytes of Flash internal SIMM (Sector size 256K).
    Configuration register is 0x2102
    
    Native_IOS#show module
    Slot Ports Card Type                                 Model                 Serir
    ---- ----- ----------------------------------------- --------------------- -----
     1     2   Cat 6000 sup 1 Enhanced QoS (active)      WS-X6K-SUP1A-2GE      SAD0 
     2     2   Cat 6000 sup 1 Enhanced QoS (other)       WSSUP1A-2GE           SAD0 
     3    48   48 port 10/100 mb RJ45                    WS-X6348-RJ-45        SAD0 
     6    24   24 port 10baseFL                          WS-X6024-10FL-MT      SAD0 
    
    Slot MAC addresses                      Hw    Fw           Sw
    ---- ---------------------------------- ----- ------------ ----------
     1   00d0.c0d2.5540 to 00d0.c0d2.5541   3.2   unknown      6.1(0.105)OR
     2   00d0.bceb.8bb4 to 00d0.bceb.8bb5   5.0   unknown      unknown     
     3   0002.7ef1.36e0 to 0002.7ef1.370f   1.1   5.3(1) 1999- 6.1(0.105)OR
     6   00d0.9738.5338 to 00d0.9738.534f   0.206 5.3(1) 1999- 6.1(0.105)OR
  2. さまざまなスパニング ツリー ステートを確認し、ポートでデータの送受信ができる時点を判別するため、デバッグをオンにします。また表示されるメッセージのタイミング情報を確認するため、タイムスタンプをオンにします。

    Cisco IOS ソフトウェアでは、スイッチ プロセッサ(SP)とルート プロセッサ(RP)が連携して 1 つのコマンドライン インターフェイス(CLI)をユーザに対して提供します。この場合、RP が CLI を処理します。 各モジュールは、表面下でそれぞれ異なる機能を提供します。 スイッチ ポート(L2)として設定されているポートで実行するスパニング ツリーのデバッグを確認するには、SP でデバッグをオンにする必要があります。 次の手順を実行します。

    1. remote login コマンドを実行して SP にアクセスします。

      プロンプトが変わり、SP にログインしたことがわかります。

    2. RP に戻るには、exit コマンドを発行します。

      「^C^C^C」を入力するよう指示するメッセージが出力に示されますが、「^C^C^C」は入力しないでください。

    3. デバッグ情報を対象ポートだけに制限します。

      debug interface fastethernet 3/13 コマンドを発行します。

    4. SP でスパニングツリー デバッグをオンにします。

    5. RP に戻ってテストを続行します。

      スイッチは、デバッグ出力をコンソールに送信するようデフォルト設定されます。

    Native_IOS#configure terminal
    Native_IOS(config)#service timestamps debug datetime msec
    Native_IOS(config)#service timestamps log datetime msec
    
    !--- If you turn on timestamps, the time displays whenever debug and/or
    !--- log messages are produced. This allows you to measure the time
    !--- between various messages.
    
    Native_IOS(config)#exit
    Native_IOS#remote login
    Trying Switch ...
    Entering CONSOLE for Switch
    Type "^C^C^C" to end this session
    
    Switch-sp#debug interface fastethernet 3/13
    Condition 1 set
    Switch-sp#debug spanning-tree events
    spanning tree event debugging is on
    Switch-sp#exit
    
    [Connection to Switch closed by foreign host]
    Native_IOS#
  3. ポートをシャットダウンするには、次のコマンドを発行します:

    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#shutdown
    Native_IOS(config-if)#^Z                 
    Native_IOS#
  4. スイッチが各ステートであった時間を判別するため、時間を確認してポートをイネーブルにします。

    次の例では、show clock コマンドconfigure terminal コマンドinterface fastethernet 3/13 コマンド、および no shut コマンドを使用します。 最も正確なタイミング情報を得るため、次のコマンドをできるだけ迅速に入力します。 このためには、テキスト ファイルで各コマンドを 1 行ずつ入力し、コマンドをクリップボードにコピーし、スイッチに貼り付ける方法があります。

    Native_IOS#show run interface fastethernet 3/13 
    Building configuration...
    
    Current configuration : 71 bytes
    !
    interface FastEthernet3/13
     no ip address
     shutdown
     switchport
    end
    
    Native_IOS#show clock
    *08:35:55.059 UTC Sun Jan 2 2000
    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#no shut
    *Jan  2 08:36:00.847: SP: STP: VLAN1 Fa3/13 -> listening
    *Jan  2 08:36:15.847: SP: STP: VLAN1 Fa3/13 -> learning
    *Jan  2 08:36:30.847: SP: STP: VLAN1 Fa3/13 -> forwarding

    この例では、ポートが STP リスニング ステージになるまでに約 5.8 秒( 35:55 ~ 36:00)が経過しています。 この時間内にポートはブリッジ グループに参加し、DTP ネゴシエーションを完了します。 リスニング ステートには 15 秒(36:00 ~ 36:15)かかっています。 ラーニング ステート(フォワーディング ステート開始まで)には 15 秒(36:15 ~ 36:30)かかっています。 ポートがトラフィックに対して実際に動作可能になるまでの合計時間は、約 35 秒(35:55 ~ 36:30)です。

  5. show interfaces fastethernet 3/13 switchport コマンドを発行します。

    手順 4 の出力に示されるように、このポートでは STP がアクティブです。 ポートがフォワーディング ステートに達するのを遅らせる要因は他にもあります。 show interfaces fastethernet 3/13 switchport コマンドは、リンクの相手側がトランクになる場合、このポートは動的にトランクになることを示します。 その場合、管理モードは dynamic desirable です。 ただし現在の動作モードは static access です。これは、相手側がトランキングしないことを意味します。 トランキングのネゴシエーションが on であり、テスト期間中は on のままにしておく必要があることに注意してください。

    Native_IOS#show interfaces fastethernet 3/13 switchport
    Name: Fa3/13
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: static access
    Administrative Trunking Encapsulation: negotiate
    Operational Trunking Encapsulation: native
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
  6. ポートで PortFast をイネーブルにします。

    トランキング ネゴシエーション(DTP)は auto モードのままになっています。

    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#spanning-tree portfast 
    %Warning: PortFast should only be enabled on ports connected to a single host.
     Connecting hubs, concentrators, switches,  bridges, etc.to this interface
     when PortFast is enabled, can cause temporary spanning tree loops.
     Use with CAUTION
    
    %PortFast has been configured on FastEthernet3/13 but will only
     have effect when the interface is in a non-trunking mode.
    Native_IOS(config-if)#shutdown
    Native_IOS(config-if)#^Z
    Native_IOS#

    テストを実行します。

    Native_IOS#show clock
    *08:41:09.531 UTC Sun Jan 2 2000
    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#no shut
    *Jan  2 08:41:15.175: SP: STP: VLAN1 Fa3/13 ->jump to forwarding from blocking

    合計時間は、約 5.7 秒(41:09~41:15)です。 PortFast をイネーブルにすると約 30 秒短縮できます。 遅延をさらに縮小できるか試します。

  7. トランキングを(auto ではなく)off にして、ポートがフォワーディング ステートに達するまでにかかる時間に、この操作がどのように影響するかを確認します。

    ポートを off にしてから on にして、時間を記録します。 Cisco IOS ソフトウェアでトランキングを off にするには、switchport mode access コマンドを発行します。

    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#switchport mode access
    Native_IOS(config-if)#shutdown
    Native_IOS(config-if)#^Z
    Native_IOS#

    トランキングを(auto ではなく)off に設定した状態でテストを開始します。

    Native_IOS#show clock
    *08:42:01.767 UTC Sun Jan 2 2000
    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#no shut
    *Jan  2 08:42:04.363: SP: STP: 
       VLAN1 Fa3/13 ->jump to forwarding from blocking

    ポートが STP フォワーディング ステートに達するまでにかかる時間が約 3 秒(00:19 ~ 00:22)であることから、開始時点ですでに数秒短縮しています。 トランキング モードを auto から off に変更することで、およそ 2 秒短縮できました。

    スイッチ ポートの初期化時間が問題であった場合は、この時点でこの問題が解決されているはずです。 さらに数秒間短縮する必要がある場合は、手順 8 を実行します。

  8. ((オプション)時間をさらに数秒短縮するには、自動ネゴシエーションを使用する代わりに、ポートの速度とデュプレックスを手動で設定します。

    通常、この手順は始動遅延の問題の解決には必要ありません。 リンクの相手側が自動ネゴシエーションではなく、手動で同じ設定に設定されている場合、この手順はパフォーマンス問題につながる可能性があります。

    一方の側で速度とデュプレックスを手動で設定する場合は、もう一方の側でも速度とデュプレックスを同様に設定する必要があります。 ポートの速度とデュプレックスを設定する場合は、そのポート上で自動ネゴシエーションをディセーブルにします。これで、接続デバイスは自動ネゴシエーション パラメータを認識しなくなります。 接続デバイスは半二重でのみ接続します。 このデュプレックス(二重)の不一致が原因で、パフォーマンスが低下し、ポート エラーが発生します。 このような問題を回避するため、両側で速度とデュプレックスを必ず設定してください。

    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#speed 100  
    Native_IOS(config-if)#duplex full
    Native_IOS(config-if)#shutdown
    Native_IOS(config-if)#^Z
    Native_IOS#

    次の例は、タイミングの結果を示します。

    Native_IOS#show clock
    *08:43:47.367 UTC Sun Jan 2 2000
    Native_IOS#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Native_IOS(config)#interface fastethernet 3/13
    Native_IOS(config-if)#no shut
    *Jan  2 08:43:49.079: SP: STP: VLAN1 Fa3/13 ->jump to forwarding from blocking

    最終結果は約 2 秒(43:47~43:49)です。

  9. SP でデバッグをオフにするには、次の一連のコマンドを発行します。

    Native_IOS#remote login
    Trying Switch ...
    Entering CONSOLE for Switch
    Type "^C^C^C" to end this session
    
    
    Switch-sp#undebug all
    All possible debugging has been turned off
    Switch-sp#exit
    
    [Connection to Switch closed by foreign host]
    Native_IOS#

Cisco IOS ソフトウェアが稼働する Catalyst 4500/4000 スイッチ

この項のコマンドは、スパニング ツリー PortFast を on にして、トランキング ネゴシエーション(DISL、DTP)を off にする方法を示します。 このオペレーティング システムでは、ポートを EtherChannel に追加するまで PAgP はアクティブにはならないため、PAgP を off にする必要はありません。 interface range コマンドを発行して、ポート グループにこれらのコマンドを一括で適用できます。 次の例のコマンドでは、ポート 3/2 ~ 3/4 にこれらのコマンドを一括で適用できます。

interface range fastethernet 3/2 - 4 コマンド2- の間にスペースがあります。 このスペースは、構文エラーを回避するために必要です。

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#interface range fastethernet 3/2 -4
Switch(config-if-range)#

この例では、1 つのポートだけに焦点を当てます。 Cisco IOS ソフトウェアが稼働する Catalyst 4000 スイッチのポートは、デフォルトではスイッチ ポート(L2)です。 これらは L2 プロトコル(スパニング ツリーと DTP)が稼動しているポートであり、始動遅延が発生することがあります。

設定

次の手順をデフォルト(L2)ステートのポートから開始します。

  1. DTP を off にするため、ポートをアクセス ポート(専用)として設定します。

  2. スパニング ツリー PortFast 機能を on にします。

  3. 設定を保存します。

次の例の show run interface fastethernet 5/4 コマンドは、このポートの現在の設定を出力します。

SwitchB#show run interface fastethernet 5/4
Building configuration...

Current configuration : 59 bytes
!
interface FastEthernet5/4
 no snmp trap link-status
end

SwitchB#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
SwitchB(config)#interface fastethernet 5/4
SwitchB(config-if)#switchport mode access
SwitchB(config-if)#spanning-tree portfast
%Warning: PortFast should only be enabled on ports connected to a single host.
 Connecting hubs, concentrators, switches,  bridges, etc.to this interface
 when PortFast is enabled, can cause temporary spanning tree loops.
 Use with CAUTION

%PortFast has been configured on FastEthernet5/4 but will only
 have effect when the interface is in a non-trunking mode.
SwitchB(config-if)#^Z
SwitchB#
SwitchB#copy run start

確認

このドキュメントで使用されているスイッチ ソフトウェアのバージョンは、Cisco IOS ソフトウェア リリース 12.1(11b)EW です。 show version コマンドおよび show module コマンドの完全な出力については、「Cisco IOS システム ソフトウェアが稼動する Catalyst 4500/4000 でのタイミング テスト 」の項を参照してください。

Switch#show version
Cisco Internetwork Operating System Software 
IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), Version 12.1(11b)EW,

次に、変更後の設定がどのようになるかを示します。

SwitchB#show run interface fastethernet 5/4
Building configuration...
 
Current configuration : 107 bytes
!
interface FastEthernet5/4
 switchport mode access
 no snmp trap link-status
 spanning-tree portfast
end
 
SwitchB#show interfaces fastethernet 5/4 switchport 
Name: Fa5/4
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Appliance trust: none
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
 
SwitchB#show spanning-tree interface fastethernet 5/4
 Port 260 (FastEthernet5/4) of VLAN1 is forwarding
   Port path cost 19, Port priority 128, Port Identifier 129.4.
   Designated root has priority 1, address 0060.8355.7b00
   Designated bridge has priority 32768, address 0001.96d9.f300
   Designated port id is 129.4, designated path cost 38
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 109
   BPDU: sent 148, received 0
   The port is in the PortFast mode

Cisco IOS システム ソフトウェアが稼動する Catalyst 4500/4000 でのタイミング テスト

ここでは、各種コマンドを適用した場合にスイッチ ポート初期化のタイミングがどのようになるかを示すテストについて説明します。 ベンチマークを確立するため、最初にポートのデフォルト設定を使用します。 複製するのは次の設定です。

  • PortFast はディセーブルです。

  • トランキング モード(DTP)は auto に設定されます。

    トランキングするよう求められる場合、ポートはトランキングします。

このオペレーティング システムでは、PAgP はデフォルトではアクティブではありません。

テストは次のように進行します。

  1. PortFast を on にし、時間を測定します。

  2. トランキングを off にし、時間を測定します。

  3. 自動ネゴシエーションを off にし、時間を測定します。

PortFast を on にする操作は、このドキュメントの「スパニング ツリー」の項で説明する STP を off にする方法とは異なります。 PortFast を on にすると、STP は引き続きポートで実行されます。 ブロッキング ステート、リスニング ステート、およびラーニング ステートがスキップされ、ポートは直ちにフォワーディング ステートに進みます。 STP を off にしないでください。この操作は VLAN 全体に影響し、ネットワークが物理的なトポロジ ループに対して脆弱になる可能性があります。 重大なネットワークの問題が発生する可能性があります。

次の手順を実行します。

  1. スイッチ ソフトウェアのバージョンと構成を表示するため、show version コマンドshow module コマンドを実行します。

    次に例を示します。

    SwitchB#show version
    Cisco Internetwork Operating System Software 
    IOS (tm) Catalyst 4000 L3 Switch Software (cat4000-IS-M), Version 12.1(11b)EW,
       EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
    TAC Support: http://www.cisco.com/tac
    Copyright (c) 1986-2002 by cisco Systems, Inc.
    Compiled Tue 14-May-02 13:31 by hqluong
    Image text-base: 0x00000000, data-base: 0x00B1C1F8
     
    ROM: 12.1(11br)EW
    SwitchB uptime is 4 minutes
    System returned to ROM by reload
    System image file is "bootflash:cat4000-is-mz.121-11b.EW"
    
    cisco WS-C4006 (MPC8245) processor (revision 5) with 262144K bytes of memory.
    Processor board ID FOX04169082
    Last reset from Reload
    32 FastEthernet/IEEE 802.3 interface(s)
    4 Gigabit Ethernet/IEEE 802.3 interface(s)
    467K bytes of non-volatile configuration memory.
    
    Configuration register is 0x2102
    
    SwitchB#show module
    
    Mod  Ports Card Type                              Model             Serial No.
    ----+-----+--------------------------------------+-----------------+-----------
     1      2  1000BaseX (GBIC) Supervisor Module WS-X4014 JAB054109FE 
     5     34  10/100BaseTX (RJ45), 1000BaseX (GBIC)  WS-X4232          JAB0253010D 
    
     M MAC addresses                    Hw  Fw           Sw               Status
    --+--------------------------------+---+------------+----------------+---------
     1 0001.96d9.f300 to 0001.96d9.f6ff 0.5 12.1(11br)EW 12.1(11b)EW, EAR Ok       
     5 0050.730a.da18 to 0050.730a.da39 1.0                               Ok
  2. さまざまなスパニング ツリー ステートを確認し、ポートでデータの送受信ができる時点を判別するため、デバッグをオンにします。また表示されるメッセージのタイミング情報を確認するため、タイムスタンプをオンにします。

    debug interface fastethernet 5/4 コマンドを発行して、デバッグ情報を対象ポートだけに制限します。 スイッチは、デバッグ出力をコンソールに送信するようデフォルト設定されます。

    SwitchB#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#service timestamps debug datetime msec
    SwitchB(config)#service timestamps log datetime msec
    SwitchB(config)#end
    
    !--- If you turn on timestamps, the time displays whenever debug and/or
    !--- log messages are produced. This allows you to measure the time
    !--- between various messages.
    
    
    SwitchB#debug interface fastethernet 5/4
    Condition 1 set
    SwitchB#debug spanning-tree events 
    Spanning Tree event debugging is on
  3. ポートをシャットダウンするには、次のコマンドを発行します:

    SwitchB#configure terminal           
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#interface fastethernet 5/4
    SwitchB(config-if)#shutdown 
    SwitchB(config-if)#end
    SwitchB#
  4. スイッチが各ステートであった時間を判別するため、時間を確認してポートをイネーブルにします。

    次の例では、show clock コマンドconfigure terminal コマンドinterface fastethernet 5/4 コマンド、および no shut コマンドを使用します。 最も正確なタイミング情報を得るため、次のコマンドをできるだけ迅速に入力します。 このためには、テキスト ファイルで各コマンドを 1 行ずつ入力し、コマンドをクリップボードにコピーし、スイッチに貼り付ける方法があります。

    SwitchB#show running-config interface fastethernet 5/4
    Building configuration...
    
    Current configuration : 69 bytes
    !
    interface FastEthernet5/4
     shutdown
     no snmp trap link-status
    end
    
    SwitchB#show clock
    21:31:34.027 UTC Thu Jul 25 2002
     
    SwitchB#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#interface fastethernet 5/4
    SwitchB(config-if)#no shut
    Jul 25 21:31:38.187: set portid: VLAN1 Fa5/4: new port id 8104
    Jul 25 21:31:38.187: STP: VLAN1 Fa5/4 -> listening
    Jul 25 21:31:53.187: STP: VLAN1 Fa5/4 -> learning
    Jul 25 21:32:08.187: STP: VLAN1 sent Topology Change Notice on Fa5/34
    Jul 25 21:32:08.187: STP: VLAN1 Fa5/4 -> forwarding

    この例では、ポートが STP リスニング ステージになるまでに約 4.2 秒( 34.02 ~ 38.18)が経過しています。 この時間内にポートはブリッジ グループに参加し、DTP ネゴシエーションを完了します。 リスニング ステートには 15 秒(38.18 ~ 53.18)かかっています。 ラーニング ステート(フォワーディング ステート開始まで)には 15 秒(53.18 ~ 08:18)かかっています。 ポートがトラフィックに対して実際に動作可能になるまでの合計時間は、約 34 秒(34:02~08.18)です。

  5. show interfaces fastethernet 5/4 switchport コマンドを発行します。

    このポートでは STP はアクティブです。 ポートがフォワーディング ステートに達するのを遅らせる要因は他にもあります。 show interfaces fastethernet 5/4 switchport コマンドを実行すると、このポートがパッシブ ネゴシエート ステートであり、リンクの相手側がネゴシエーションを開始するとトランクになることが示されます。 管理モードは dynamic auto です。 現在の動作モードは static access です。これは、相手側がトランキングしないことを意味します。

    トランキングのネゴシエーションが on であり、テスト期間中も on になっている必要がある点に注意してください。

    SwitchB#show interfaces fastethernet 5/4 switchport
    Name: Fa5/4
    Switchport: Enabled
    Administrative Mode: dynamic auto
    Operational Mode: static access
    Administrative Trunking Encapsulation: negotiate
    Operational Trunking Encapsulation: native
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Voice VLAN: none
    Appliance trust: none
    Administrative private-vlan host-association: none 
    Administrative private-vlan mapping: none 
    Operational private-vlan: none 
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
  6. ポートで PortFast をイネーブルにします。

    トランキング ネゴシエーション(DTP)は auto モードのままになっています。

    SwitchB#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#interface fastethernet 5/4
    SwitchB(config-if)#spanning-tree portfast
    %Warning: PortFast should only be enabled on ports connected to a single host
     Connecting hubs, concentrators, switches,  bridges, etc.to this interface
     when PortFast is enabled, can cause temporary spanning tree loops.
     Use with CAUTION
    
    %PortFast has been configured on FastEthernet5/4 but will only
     have effect when the interface is in a non-trunking mode.
    SwitchB(config-if)#shutdown 
    SwitchB(config-if)#^Z
    SwitchB#

    合計時間は、約 4.7 秒でした(16.41 ~ 21:15)。 PortFast をイネーブルにすると約 30 秒短縮できます。 遅延をさらに縮小できるか試します。

  7. トランキングを(auto ではなく)off にして、ポートがフォワーディング ステートに達するまでにかかる時間に、この操作がどのように影響するかを確認します。

    ポートを off にしてから on にして、時間を記録します。 Cisco IOS システム ソフトウェアでトランキングを off にするには、switchport mode access コマンドを発行します。

    SwitchB#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#interface fastethernet 5/4
    SwitchB(config-if)#switchport mode access
    SwitchB(config-if)#shutdown
    SwitchB(config-if)#^Z
    SwitchB#

    トランキングを(auto ではなく)off に設定した状態でテストを開始します。 次に例を示します。

    SwitchB#show clock
    22:06:11.947 UTC Thu Jul 25 2002
    SwitchB#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#interface fastethernet 5/4
    SwitchB(config-if)#no shut
    Jul 25 22:06:16.143: set portid: VLAN1 Fa5/4: new port id 8104
    Jul 25 22:06:16.143: STP: VLAN1 Fa5/4 ->jump to forwarding from blocking

    ポートが STP フォワーディング ステートに達するまでの経過時間が約 4 秒(12.00~ 16.10)であることから、開始時点でわずかに時間を短縮できています。 トランキング モードを auto から off に変更することにより、およそ 0.5 秒短縮できました。

    スイッチ ポートの初期化時間が問題であった場合は、この時点でこの問題が解決されているはずです。 さらに数秒間短縮する必要がある場合は、手順 8 を実行します。

  8. ((オプション)時間をさらに数秒短縮するには、自動ネゴシエーションを使用する代わりに、ポートの速度とデュプレックスを手動で設定します。

    通常、この手順は始動遅延の問題の解決には必要ありません。 リンクの相手側が自動ネゴシエーションではなく、手動で同じ設定に設定されている場合、この手順はパフォーマンス問題につながる可能性があります。

    こちら側で速度とデュプレックスを手動で設定する場合は、相手側でも速度とデュプレックスを同様に設定する必要があります。 ポートの速度とデュプレックスを設定するときに、そのポート上で自動ネゴシエーションをディセーブルにします。これで、接続デバイスは自動ネゴシエーション パラメータを認識しなくなります。 接続デバイスは半二重でのみ接続します。 このデュプレックス(二重)の不一致が原因で、パフォーマンスが低下し、ポート エラーが発生します。 このような問題を回避するため、両側で速度とデュプレックスを必ず設定してください。

    SwitchB#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#interface fastethernet 5/4       
    SwitchB(config-if)#speed 100
    SwitchB(config-if)#duplex full
    SwitchB(config-if)#shutdown
    SwitchB(config-if)#^Z
    SwitchB#

    次の例は、タイミングの結果を示します。

    SwitchB#show clock
    22:14:49.219 UTC Thu Jul 25 2002
    SwitchB#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    SwitchB(config)#interface fastethernet 5/4
    SwitchB(config-if)#no shut
    Jul 25 22:14:53.135: set portid: VLAN1 Fa5/4: new port id 8104
    Jul 25 22:14:53.135: STP: VLAN1 Fa5/4 ->jump to forwarding 
    from blocking

    最終結果は約 3.9 秒(49.21~53.13)です。

  9. SP で(先にオンにしていた)デバッグをオフにするには、次の一連のコマンドを発行します。

    SwitchB#undebug all
    All possible debugging has been turned off
    SwitchB#exit
    

Catalyst 2948G-L3/4908G-L3/4840G スイッチ

2948G-L3/4908G-L3/4840G シリーズ スイッチは、Cisco IOS ソフトウェアが稼動するスイッチのもう 1 つのグループです。 これらのスイッチでは、Catalyst 6500/6000 の Cisco IOS ソフトウェアのように、ポートをスイッチ ポートにする機能はありません。 これらのスイッチに関しては次の事柄を理解する必要があります。

  • 設定という観点では、Catalyst 2948G-L3 はルータになります。 このスイッチでは、Cisco IOS コンフィギュレーション インターフェイスが使用されており、すべてのインターフェイスはデフォルトでルーテッド インターフェイスとなっています。

  • Catalyst 2948G-L3 は VLAN を拡張するものではありません。 このスイッチはルーテッド インターフェイスで終端します。 ただしブリッジ コマンドを使用すると VLAN の機能をある程度シミュレートできます。

  • Catalyst 2948G-L3 では、他の Catalyst スイッチに見られる VLAN Trunk Protocol(VTP)、DTP、PAgP などの L2 指向プロトコルはサポートされていません。

これらのデバイスでブリッジングを行うためにポートを設定する場合は、これらのポートでスパニング ツリーがアクティブであり、ポートがブロッキング ステージ、リスニング ステージ、およびラーニング ステージと進むために通常 30 秒間の始動遅延が発生します。 エンド ステーションだけがこれらのポートに接続されることが判明している場合は、始動遅延を短縮するためスパニング ツリーを off にできます。 この方法では、PortFast を使用するよりもリスクが増大します。 ただし、PortFast はこれらのデバイスでは使用できません。

ブリッジ ルータ インターフェイスのスパニングツリーをディセーブルにすることは、スイッチ ポートのスパニングツリー PortFast をイネーブルにすることとは異なります。 ブリッジ プロトコル データ ユニット(BPDU)がスイッチから受信される場合や、ブリッジがインターフェイスに誤って接続される場合、ルータはポートをブロックしません。 スパニングツリーをディセーブルにしたまま、ワークステーションまたはその他のエンドホストだけをインターフェイスに接続する際には注意してください。 ハブまたはスイッチを接続するポートではスパニングツリーをディセーブルにしないでください。

次の出力には、Catalyst 2948G-L3 をブリッジング用に設定する方法が示されています。 この設定では、エンド ステーション始動時のさまざまな問題を防ぐために、すべてのファスト イーサネット インターフェイスが 1 つのブリッジ グループに割り当てられ、スパニング ツリーがディセーブルにされます。

2948G-L3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
2948G-L3(config)#bridge irb
2948G-L3(config)#bridge 1 protocol ieee
2948G-L3(config)#bridge 1 route ip
2948G-L3(config)#interface bvi 1 
2948G-L3(config-if)#ip add 10.1.1.1 255.255.255.0
2948G-L3(config-if)#exit
2948G-L3(config)#interface fastethernet 1
2948G-L3(config-if)#no shutdown
2948G-L3(config-if)#bridge-group 1
2948G-L3(config-if)#bridge-group 1 spanning-disabled
2948G-L3(config-if)#exit
2948G-L3(config)#interface fastethernet 2
2948G-L3(config-if)#no shutdown
2948G-L3(config-if)#bridge-group 1
2948G-L3(config-if)#bridge-group 1 spanning-disabled
. . .

2948G-L3 スイッチの設定方法の詳細については、「 Catalyst 2948G-L3 設定例:単一 VLAN、複数 VLAN、およびネットワーク コアに接続する複数 VLAN ディストリビューション レイヤ」を参照してください。

Catalyst 2900XL/3500XL/2950/3550 スイッチ

Catalyst 2900XL/3500XL および Catalyst 2950/3550 モデルは、Web ブラウザから、Simple Network Management Protocol(SNMP)または CLI を使用して設定できます。 CLI を使用することをお勧めします。 ここでは、ポートの STP ステートを確認し、PortFast を on にし、PortFast が on になっていることを確認する例を示します。 2900XL/3500XL では、EtherChannel とトランキングはサポートされますが、ダイナミック EtherChannel 作成(PAgP)や DTP はサポートされません。 このテスト中、これらのプロトコルをオフにする必要はありません。 また、PortFast を on にしてからポートが起動するまでの経過時間は 1 秒未満です。 したがって、時間を短縮するために速度/デュプレックス ネゴシエーション設定を変更する必要はありません。 デフォルトでは、スイッチ ポート上で PortFast は off になっています。 2950/3550 では、PAgP と DTP 両方がサポートされています。 これらのスイッチでは、PAgP はデフォルトではアクティブではありませんが、DTP はアクティブです。 2950 では、Cisco IOS ソフトウェア リリース 12.0 が稼働している場合は DTP または PAgP はサポートされません。 「設定 」の項で、PortFast を on にするコマンドを示します。

設定

2900XL#configure terminal
2900XL(config)#interface fastethernet 0/1
2900XL(config-if)#spanning-tree portfast
2900XL(config-if)#exit
2900XL(config)#exit
2900XL#copy run start

Catalyst 2950 および 3550 では DTP がサポートされています。 switchport mode access コマンドも発行します。 このコマンドにより、DTP がオフになります。

このプラットフォームは、Cisco IOS ルータと似ています。 設定を永続的に保存するには、copy run start コマンドを発行する必要があります。

確認

PortFast がイネーブルになっていることを検証するには、次のコマンドを発行します。

2900XL#show spanning-tree interface fastethernet 0/1
Interface Fa0/1 (port 13) in Spanning tree 1 is FORWARDING
   Port path cost 19, Port priority 128
   Designated root has priority 8192, address 0010.0db1.7800
   Designated bridge has priority 32768, address 0050.8039.ec40
   Designated port is 13, path cost 19
   Timers: message age 0, forward delay 0, hold 0
   BPDU: sent 2105, received 1
   The port is in the PortFast mode

次のコマンドを発行すると、スイッチの設定を確認することもできます。

2900XL#show running-config
Building configuration...

Current configuration:
!
version 11.2

!--- Output suppressed.

!
interface VLAN1
 ip address 172.16.84.5 255.255.255.0
 no ip route-cache
!
interface FastEthernet0/1
 spanning-tree portfast
!
interface FastEthernet0/2
!

!--- Output suppressed.

Catalyst 2900XL でのタイミング テスト

Catalyst 2900XL 上でタイミング テストを実行するには、次の手順を実行します。

  1. show version コマンドを発行して、ソフトウェア バージョンを表示します。

    この例では、2900XL で Cisco IOS ソフトウェア リリース 11.2(8.2)SA6 が使用されています。

    Switch#show version
    Cisco Internetwork Operating System Software
    IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 11.2(8.2)SA6, 
    MAINTENANCE INTERIM SOFTWARE
    Copyright (c) 1986-1999 by cisco Systems, Inc.
    Compiled Wed 23-Jun-99 16:25 by boba
    Image text-base: 0x00003000, data-base: 0x00259AEC
    
    ROM: Bootstrap program is C2900XL boot loader
    
    Switch uptime is 1 week, 4 days, 22 hours, 5 minutes
    System restarted by power-on
    System image file is "flash:c2900XL-c3h2s-mz-112.8.2-SA6.bin", 
    booted via console
    
    cisco WS-C2924-XL (PowerPC403GA) processor (revision 0x11) with
    8192K/1024K bytes of memory.
    Processor board ID 0x0E, with hardware revision 0x01
    Last reset from power-on
    
    Processor is running Enterprise Edition Software
    Cluster command switch capable
    Cluster member switch capable
    24 Ethernet/IEEE 802.3 interface(s)
    
    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:50:80:39:EC:40
    Motherboard assembly number: 73-3382-04
    Power supply part number: 34-0834-01
    Motherboard serial number: FAA02499G7X
    Model number: WS-C2924-XL-EN
    System serial number: FAA0250U03P
    Configuration register is 0xF
  2. スイッチで発生している状況を把握するため、次のコマンドを発行します。

    2900XL(config)#service timestamps debug uptime
    2900XL(config)#service timestamps log uptime
    2900XL#debug spantree events
    Spanning Tree event debugging is on
    2900XL#show debug
    General spanning tree:
      Spanning Tree event debugging is on
  3. 該当のポートをシャット ダウンします。

    2900XL#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    2900XL(config)#interface fastethernet 0/1
    2900XL(config-if)#shut
    2900XL(config-if)#
    00:31:28: ST: sent Topology Change Notice on FastEthernet0/6
    00:31:28: ST: FastEthernet0/1 -> blocking
    00:31:28: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to 
    administratively down
    00:31:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, 
    changed state to down
    2900XL(config-if)#exit
    2900XL(config)#exit
    2900XL#
  4. 時刻を確認し、ポートを再度オンにし、スイッチが各ステートにあった時間を確認します。

    最も正確なタイミング情報を得るため、この手順に示すコマンドをできるだけ迅速に入力します。 このためには、テキスト ファイルで各コマンドを 1 行ずつ入力し、コマンドをクリップボードにコピーし、スイッチに貼り付ける方法があります。

    show clock
    configure terminal
    interface fastethernet 0/1
    no shut
    
  5. PortFast が off になっていることを確認します。

    PortFast は、デフォルトでは off になっています。

    次のいずれかの方法で、PortFast が off になっていることを確認できます。

    • show spanning-tree interface コマンドを発行する。 PortFast が off の場合、出力には PortFast が示されません。

      2900XL#show spanning-tree interface fastethernet 0/1
      Interface Fa0/1 (port 13) in Spanning tree 1 is FORWARDING
         Port path cost 19, Port priority 128
         Designated root has priority 8192, address 0010.0db1.7800
         Designated bridge has priority 32768, address 0050.8039.ec40
         Designated port is 13, path cost 19
         Timers: message age 0, forward delay 0, hold 0
         BPDU: sent 887, received 1

      この時点では、PortFast モードになっていることを示すメッセージがありません。

    • 実行コンフィギュレーションを確認する。 PortFast が off の場合、インターフェイスの下に spanning-tree portfast コマンドがありません。

      2900XL#show running-config
      Building configuration...
      
      !--- Output suppressed.
      
      !
      interface FastEthernet0/1
      
      !--- There is no spanning-tree portfast command under this interface.
      
      !
      
      !--- Output suppressed.
      
      
  6. PortFast が off の状態で最初のタイミング テストを実行します。

    2900XL#show clock
    *00:27:27.632 UTC Mon Mar 1 1993
    2900XL#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    2900XL(config)#interface fastethernet 0/1
    2900XL(config-if)#no shut
    2900XL(config-if)#
    00:27:27: ST: FastEthernet0/1 -> listening
    00:27:27: %LINK-3-UPDOWN: Interface FastEthernet0/1, 
    changed state to up
    00:27:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface 
    FastEthernet0/1, changed state to up
    00:27:42: ST: FastEthernet0/1 -> learning
    00:27:57: ST: sent Topology Change Notice on FastEthernet0/6
    00:27:57: ST: FastEthernet0/1 -> forwarding
    

    シャットダウンからポートが転送を開始するまでの合計時間は 30 秒(27:27~27:57)です。

  7. PortFast を on にするため、次のコマンドを発行します:

    2900XL#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    2900XL(config)#interface fastethernet 0/1
    2900XL(config-if)#spanning-tree portfast
    2900XL(config-if)#exit
    2900XL(config)#exit
    2900XL#

    PortFast がイネーブルであることを確認するため、show spanning tree interface コマンドを発行します。 コマンド出力の最後に、PortFast がイネーブルであることが示されます。

    2900XL#show spanning tree interface fastethernet 0/1
    Interface Fa0/1 (port 13) in Spanning tree 1 is FORWARDING
       Port path cost 19, Port priority 128
       Designated root has priority 8192, address 0010.0db1.7800
       Designated bridge has priority 32768, address 0050.8039.ec40
       Designated port is 13, path cost 19
       Timers: message age 0, forward delay 0, hold 0
       BPDU: sent 1001, received 1
       The port is in the PortFast mode.
    

    また、次のコンフィギュレーション出力でも PortFast がイネーブルであることが確認できます。

    2900XL#show run
    Building configuration...
    
    !--- Output suppressed.
    
    interface FastEthernet0/1
     spanning-tree portfast
    
    !--- Output suppressed.
    
    
  8. PortFast がイネーブルの状態で、タイミング テストを実行します。

    2900XL#show clock
    *00:23:45.139 UTC Mon Mar 1 1993
    2900XL#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    2900XL(config)#interface fastethernet 0/1
    2900XL(config-if)#no shut
    2900XL(config-if)#
    00:23:45: ST: FastEthernet0/1 ->jump to forwarding from blocking
    00:23:45: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
    00:23:45: %LINEPROTO-5-UPDOWN: 
       Line protocol on Interface FastEthernet0/1, changed state to up

    この場合、合計時間は 1 秒以下です。 スイッチ ポートの初期化遅延が問題であった場合は、PortFast を使用してこの問題を解決する必要があります。 スイッチは現在トランク ネゴシエーションや PAgP をサポートしていないため、これらをオフにする必要はありません。 スイッチでは速度とデュプレックスの自動ネゴシエーションがサポートされています。 ただし遅延はごくわずかであるため、off にする必要はありません。

  9. ワークステーションからスイッチに対して ping テストを実行します。

    ping テストについては、このドキュメントの「DTP、PAgP、および PortFast を使用した/使用しない、Catalyst 5500 でのタイミング テスト」の手順 11 を参照してください。

    応答がスイッチから戻るまでの所要時間は約 5~6 秒です。 この時間は、速度とデュプレックスの自動ネゴシエーションが on または off のいずれでも同じです。

Catalyst 1900/2800 スイッチ

Catalyst 1900 と Catalyst 2820 では、PortFast は「スパンツリー始動転送」と呼ばれます。 バージョン 8.01.05 のソフトウェアの場合、スイッチではデフォルトで、イーサネット(10 Mbps)ポートでは PortFast がイネーブルになり、FastEthernet(アップリンク)ポートでは PortFast がディセーブルになります。 show run コマンドを発行して設定を表示したときに、イーサネット ポートが PortFast についての情報を示さない場合、PortFast はイネーブルです。 設定で no spantree start-forwarding であることがポートから報告される場合、PortFast はディセーブルです。 ファスト イーサネット(100-Mbps)ポートでは、これとは反対の内容が報告されます。 ファスト イーサネット ポートでは、ポートの設定に「spantree start-forwarding」が示されている場合にだけ、PortFast が on になっています。

ここでは、ファスト イーサネット ポートで PortFast を設定する例を示します。 次の例では、Enterprise Edition ソフトウェア バージョン 8 を使用しています。 Catalyst 1900 では、設定が変更されると自動的に NVRAM に保存されます。 別のスイッチやハブに接続されているポートでは、PortFast をイネーブルにしないことに注意してください。 エンド ステーションに接続しているポートでのみ PortFast をイネーブルにします。

設定

1900#show version
Cisco Catalyst 1900/2820 Enterprise Edition Software
Version V8.01.05    
Copyright (c) Cisco Systems, Inc.  1993-1998
1900 uptime is 0day(s) 01hour(s) 10minute(s) 42second(s) 
cisco Catalyst 1900 (486sxl) processor with 2048K/1024K bytes of memory
Hardware board revision is 5
Upgrade Status: No upgrade currently in progress. 
Config File Status: No configuration upload/download is in progress 
27 Fixed Ethernet/IEEE 802.3 interface(s)
Base Ethernet Address: 00-50-50-E1-A4-80
1900#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z
1900(config)#interface fastethernet 0/26
1900(config-if)#spantree start-forwarding 
1900(config-if)#exit
1900(config)#exit
1900#

確認

PortFast が on であることを確認する唯一の方法は、設定を確認することです。 ファスト イーサネット ポートから、PortFast が on であることが示される必要があることに注意してください。 設定で PortFast が off であることが示される場合を除き、イーサネット ポートでは PortFast は on になっています。 次に例を示します。

1900#show running-config 
Building configuration...

!--- Output suppressed.

!
interface Ethernet 0/1

  no spantree start-forwarding
!
interface Ethernet 0/2

!

!--- Output suppressed.

!
interface FastEthernet 0/26
  spantree start-forwarding
!

この設定から次のことがわかります。

  • インターフェイス イーサネット 0/1 では PortFast が off になっています。 これを off にするコマンドを確認できます。

  • インターフェイス イーサネット 0/2 では PortFast が on になっています。 PortFast に関するステートメントがないため、PortFast は on になっています。

  • インターフェイス イーサネット 0/26(メニュー システムのポート A)では PortFast が on になっています。 これを on にするコマンドを確認できます。

PortFast のステータスを表示する最も簡単な方法は、メニュー システムの使用です。 メイン メニューからポート設定(P)を選択し、ポートを選択すると、Port Fast モードがイネーブルになっているかどうかが出力に示されます。 次の出力例は、ポート FastEthernet 0/26(このスイッチではポート A)の場合です。

Catalyst 1900 - Port A Configuration

        Built-in 100Base-FX
        802.1d STP State:  Blocking     Forward Transitions:  0

    ----------------------- Settings ---------------------------------------
     [D] Description/name of port                                        
     [S] Status of port                              Suspended-no-linkbeat
     [I] Port priority (spanning tree)               128 (80 hex)
     [C] Path cost (spanning tree)                   10
     [H] Port fast mode (spanning tree)              Enabled 
     [E] Enhanced congestion control                 Disabled             
     [F] Full duplex / Flow control                  Half duplex             

    ----------------------- Related Menus ----------------------------------
     [A] Port addressing           [V] View port statistics
     [N] Next port                 [G] Goto port
     [P] Previous port             [X] Exit to Main Menu

Enter Selection:

Catalyst 1900 でのタイミング テスト

デバッグ ツールがないため、Catalyst 1900/2820 でタイミングの値を検証するのは困難です。 次の手順を実行します。

  1. スイッチに接続された PC で、スイッチを対象とした ping を開始します。

  2. スイッチからケーブルを外します。

  3. ケーブルを再び接続して、スイッチが ping に対して応答するまでの経過時間を記録します。

PortFast を on にした状態と PortFast を off にした状態でこの手順を実行します。 PortFast が on になっている(デフォルトの状態)イーサネット ポートの場合、PC は 5 ~ 6 秒以内に応答を受信します。 PortFast を off にすると、PC は 34 ~ 35 秒で応答を受信します。

PortFast 機能にとってのさらなる利点

ネットワークで PortFast を使用すると、その他にも STP 関連のメリットがあります。 リンクがアクティブになり、STP でフォワーディング ステートに移行するたびに、トポロジ変更通知(TCN)という特殊な STP パケットがスイッチから送信されます。 TCN はスパニング ツリーのルートまで伝達され、VLAN 上のすべてのスイッチに伝搬されます。 これによりすべてのスイッチは、転送遅延パラメータを使用して MAC アドレスのテーブルをエージング アウトします。このパラメータは通常 15 秒に設定されます。 そのためワークステーションがブリッジ グループに加入するたびに、すべてのスイッチの MAC アドレスは通常の 300 秒ではなく 15 秒後にエージング アウトされます。

ワークステーションがアクティブになったとき、トポロジが大きく変更されることはありません。 VLAN 内のすべてのスイッチは、ファスト エージング TCN 期間を経過する必要はありません。 PortFast を on にすると、ポートがアクティブになってもスイッチから TCN パケットが送信されません。


関連情報


Document ID: 10553