非同期転送モード(ATM) : VP(Virtual Path)スイッチングとトンネル

整形 VP トンネルの LANE、CES、および VBR PVC

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、整形仮想パス(VP)トンネルにおける LAN エミュレーション(LANE)、回線エミュレーション サービス(CES)、および可変ビット レート(VBR)の相手先固定接続(PVC)の設定例を紹介します。 このドキュメントに示す設定では、LANE、CES、および可変ビット レート非リアルタイム(VBR-nrt)PVC が WAN 経由で転送されます。 これらの例では、整形 VP トンネルを使用してトラフィック コントラクトとの準拠が確保されます。 サービス プロバイダーと同一のトラフィック パラメータによる整形 VP トンネルを使用する場合、サービス プロバイダーの ATM ネットワークはセルを廃棄することはありません。

VPトンネルは固定ビット レート (CBR) サービス カテゴリ形づくことをである必要があります: Cisco が現在サポートするのは唯一の整形トンネルです。 LANE が未指定ビット レート (UBR) 相手先 選択 接続(SVC)を使用するので、CES 使用 CBR PVC 3 つの VP トンネルがなければなりません、VBR PVC があり、形づけられた VP トンネルを使用しています。 各サービス カテゴリのための 1 つがあります: CBR 仮想チャネル(VC)および UBR VC。 階層的 な VP トンネルの使用によって 1 トンネルを使用したかもしれません。

前提条件

要件

このドキュメントの読者は次のトピックについて理解している必要があります。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) LightStream 1010 (LS1010)のためのソフトウェア リリース 11.3(0.8)TWA4 ASP またはそれ以降

  • Cisco 8540-MSR のバージョン

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

この資料で示されている例はこれらのファクトを仮定します:

  • 整形トンネルは CBRサービスカテゴリである必要があります従ってこの例に CBR しか VC 含まれていない場合がある CBR VPトンネルがあります。 それは CES CBR PVC のために使用されます(ネットワークダイアグラムVPI1 と分類される)。 仮想パス識別子(VPI)数がスイッチポートにローカルで固有である、従って同じスイッチの同じ VPI 数、2 つの異なるスイッチポートがあることができますことに注目して下さい。

  • 整形 VP トンネルが同時に複数のサービスカテゴリの VC を転送できないので CBR VC に使用する最初の VPトンネルは LANE UBR VC か VBR-nrt PVC に使用することができません。 作成して下さい UBR サービス カテゴリ VC を使用する)のための別の VPトンネルを LANE (。 従って、第 2 VPトンネルは(ネットワークダイアグラムVPI2 と分類される) UBR だけ VC 許可される CBR シェイプド VPトンネルです。

  • 三番目整形VPトンネルは VBR-nrt PVC を転送します(ネットワークダイアグラムVPI3 と分類される)。

  • サービスプロバイダーからの 3 CBR VP を購入する必要があります。

  • 3 つ CBR VP に 10 Mbps の Peak Cell Rate (PCR; ピークセルレート)および 500 人のセルのセル遅延変動許容値 (CDVT)があることが仮定されます。 同じ物理インターフェイスで定義されるすべての VP トンネルの PCR の合計がより小さい必要があること物理インターフェイスの行比率の 95%注意して下さい(VP トンネルだけ物理インターフェイスで設定されると)仮定する。

  • VBR PVC に関しては、PVC の Sustained Cell Rate (SCR; 平均セルレート)は CBR シェイプド VPトンネルの PCR の 95%より小さい必要があります。 すなわち、PVC SCR は VBR-nrt のための 9.5 Mbps より小さい必要があります。 多重があれば CBR を通過する VBR PVC は、すべての VBR PVC の SCR の合計整形VPトンネルの PCR の 95%より小さい必要がありますトンネル伝送します。 残る 5%信号を送ることおよび他の必須プロトコルのために予約済みです。

  • デバイス 5500-asp-f は VP スイッチングのためです。 サービスプロバイダーは一般的にこの機能を行います。

  • LANE サービスは 8540 MSR で定義されます; LANエミュレーション クライアント(LEC)は 8540 MSR および 5500 非対称多重処理システムe で定義されます。

    この例では、LANE サービスは ATM スイッチに簡単にするために置かれます。 しかしそれは LANE サービスのための最適な位置ではないです。 LANエミュレーション サーバ(LES)またはブロードキャスト アンノウン サーバ(BUS)のための最もよいインポートは Catalyst 5500 の LANE モジュールにあります。 LEC のための理想的なインポートは Cisco 7500 シリーズ ルータにあります。

  • ダイアグラム使用中の 2 つの構内交換機(PBX) CES CBR 回線。 回線エミュレーションを設定する方法の詳細については回線エミュレーション サービスの設定を参照して下さい。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

設定 例を表示するためにこのダイアグラムのスイッチをクリックして下さい:

/image/gif/paws/10493/PVPshap.gif

設定

このドキュメントでは、次の設定を使用します。

5500 非対称多重処理システムe 設定 例

5500-asp-e
5500-asp-e# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-e
!
boot system flash slot0:LS1010-wp-mz.120-3c.W5.9.bin
!
ip host-routing
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0050.537e.1401.0050.537e.1401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface CBR10/0/0
 no ip address
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM11/0/1.6 vpi 6 vci 100
!
interface ATM11/0/1
 no atm signaling enable
 no ip address
 atm pvp 5 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 6 shaped rx-cttr 64000 tx-cttr 64000
 atm pvp 7 shaped rx-cttr 64000 tx-cttr 64000
!
interface ATM11/0/1.5 point-to-point
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM11/0/1.6 point-to-point
!
interface ATM11/0/1.7 point-to-point
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM10/1/0 0 100
!
interface ATM11/0/2
 no ip address
!
interface ATM11/0/3
 no ip address
!
interface ATM11/1/0
 no ip address
!
interface ATM11/1/1
 no ip address
!
interface ATM11/1/2
 no ip address
!
interface ATM11/1/3
 no ip address
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface ATM13/0/0.1 multipoint
 ip address 100.100.100.2 255.255.255.0
 lane client ethernet test
!
interface Ethernet13/0/0
 no ip address
!
no ip classless
logging buffered 16000 debugging
!
line con 0
line aux 0
line vty 0 4
 login
!
end

機能の表示

このセクションでデバイスのコンフィギュレーション機能を確認する show コマンドを使用できます。 特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

設定を確認する追加 show コマンドを使用できます; この資料にすべてが含まれていません。

すべての LANE VC が信号を送る正しい VPトンネルを渡って(すなわち、開始を通って防ぐためからメインインターフェイス信号を送ることを)行くようにすることは no atm signaling enable コマンドを使用してインターフェイス atm11/0/1 でディセーブルにされます。 同じオペレーションは 8540 MSR で実行された。

どの VC が 7 の VPI の VPトンネルを通っているか見るために、show atm vc interface interface-number コマンドを発行して下さい:

5500-asp-e# show atm vc interface atm11/0/1.7

Interface    VPI   VCI   Type    X-Interface  X-VPI X-VCI  Encap Status

ATM11/0/1.7  7     3      PVC     ATM13/0/0    0     181   SNAP   UP
ATM11/0/1.7  7     4      PVC     ATM13/0/0    0     182   SNAP   UP
ATM11/0/1.7  7     5      PVC     ATM13/0/0    0     180   QSAAL  UP
ATM11/0/1.7  7     16     PVC     ATM13/0/0    0     179   ILMI   UP
ATM11/0/1.7  7     18     PVC     ATM13/0/0    0     183   PNNI   UP
ATM11/0/1.7  7     100    PVC     ATM10/1/0    0     100          UP

5500-asp-e# show atm interface resource atm11/0/1.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

5500-asp-e# show atm interface resource atm11/0/1

Resource Management configuration:
    Service Classes:
        Service Category map: c1 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  4 svcs

5500-asp-f 設定 例

スイッチは VP スイッチングのために設定されます。

5500-asp-f
5500-asp-f# show running-config

Building configuration...
Current configuration:
!
version 11.3
no service padservice timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 5500-asp-f
!
!
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 64000 cbr pcr 10240  cdvt 500
atm address 47.0091.8100.0000.0050.5308.2401.0050.5308.2401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
!
interface ATM11/0/0
 no ip address
!
interface ATM11/0/1
 no ip address
 atm pvp 5  interface  ATM11/0/0 10
 atm pvp 6 rx-cttr 64000 tx-cttr 64000 interface ATM11/0/0 6 rx-cttr 64000 tx-cttr 64000
 atm pvp 7 rx-cttr 63997 tx-cttr 63997 interface ATM11/0/0 7 rx-cttr 63997 tx-cttr 63997
!
interface ATM13/0/0
 no ip address
 atm maxvp-number 0
!
interface Ethernet13/0/0
 no ip address
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

機能 ディスプレイ

VP が正常に動作していることを確認するために、show atm vp コマンドを発行して下さい:

5500-asp-f# show atm vp

Interface    VPI    Type  X-Interface     X-VPI     Status
ATM11/0/0    6       PVP     ATM11/0/1    6         UP
ATM11/0/0    7       PVP     ATM11/0/1    7         UP
ATM11/0/0    10      PVP     ATM11/0/1    5         UP
ATM11/0/1    5       PVP     ATM11/0/0    10        UP
ATM11/0/1    6       PVP     ATM11/0/0    6         UP
ATM11/0/1    7       PVP     ATM11/0/0    7         UP

8540 MSR 設定 例

8540-MSR
8540-MSR# show running-config

Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 8540-MSR
!
logging buffered 4096 debugging
!
redundancy
 main-cpu
  sync config startup
  sync config running
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
ip subnet-zero
!
atm connection-traffic-table-row index 63997 vbr-nrt pcr 20480 scr10 9000  mbs 100
atm connection-traffic-table-row index 63998 cbr pcr 10000
atm connection-traffic-table-row index 63999 cbr pcr 10240  cdvt 500
atm lecs-address-default 47.0091.8100.0000.0090.2144.8401.0090.2144.8405.00 1
atm address 47.0091.8100.0000.0090.2144.8401.0090.2144.8401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
!
lane database PVP
  name test server-atm-address 47.009181000000009021448401.009021448403.01
!
!
interface CBR1/0/0
 no ip address
 no ip directed-broadcast
 shutdown
 ces circuit 0 circuit-name test
 ces pvc 0 interface ATM2/1/0.6 vpi 6 vci 100
!
interface ATM2/1/0
 no atm signaling enable
 no ip address
 no ip directed-broadcast
 atm pvp 6 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 7 shaped rx-cttr 63999 tx-cttr 63999
 atm pvp 10 shaped rx-cttr 63999 tx-cttr 63999
!
interface ATM2/1/0.6 point-to-point
 no ip directed-broadcast
!
interface ATM2/1/0.7 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category vbr-nrt permit
 atm pvc 7 100 rx-cttr 63997 tx-cttr 63997  interface  ATM1/1/0 0 100
!
interface ATM2/1/0.10 point-to-point
 no ip directed-broadcast
 atm cac service-category cbr deny
 atm cac service-category ubr permit
!
interface ATM2/1/1
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/2
 no ip address
 no ip directed-broadcast
!
interface ATM2/1/3
 no ip address
 no ip directed-broadcast
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
 lane config auto-config-atm-address
 lane config database PVP
!
interface ATM0.1 multipoint
 ip address 100.100.100.1 255.255.255.0
 no ip directed-broadcast
 lane server-bus ethernet test
 lane client ethernet test
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

機能の表示

このセクションでデバイスのコンフィギュレーション機能を確認する show コマンドを使用できます。

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX
Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0

Resource Management configuration:
    Service Classes:
        Service Category map: c2 cbr, c2 vbr-rt, c3 vbr-nrt, c4 abr, c5 ubr
        Scheduling: RS c1 WRR c2, WRR c3, WRR c4, WRR c5
        WRR Weight: 8 c2, 1 c3, 1 c4, 1 c5
    Pacing: disabled   0 Kbps rate configured, 0 Kbps rate installed
    Service Categories supported: cbr,vbr-rt,vbr-nrt,abr,ubr
    Link Distance: 0 kilometers
    Controlled Link sharing:
        Max aggregate guaranteed services: none RX,  none TX
        Max bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
        Min bandwidth: none cbr RX, none cbr TX, none vbr RX, none vbr TX,
                       none abr RX, none abr TX, none ubr RX, none ubr TX
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr, none vbr, none abr, none ubr
        Peak-cell-rate TX: none cbr, none vbr, none abr, none ubr
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX: none abr, none ubr
        Minimum-cell-rate TX: none abr, none ubr
        CDVT RX: none cbr, none vbr, none abr, none ubr
        CDVT TX: none cbr, none vbr, none abr, none ubr
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        117023 cbr RX, 117023 cbr TX, 117023 vbr RX, 117023 vbr TX,
        117023 abr RX, 117023 abr TX, 117023 ubr RX, 117023 ubr TX
    Allocated bit rates:
        30720 cbr RX, 30720 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Best effort connections: 0 pvcs,  0 svcs

8540-MSR# show atm interface resource atm2/1/0.6

Resource Management configuration:
    Service Categories supported: cbr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none cbr,
        Peak-cell-rate TX: none cbr,
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none cbr,
        CDVT TX: none cbr,

Resource Management state:
    Available bit rates (in Kbps):
        9727 cbr RX, 9727 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        1741 cbr RX, 1741 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.7

Resource Management configuration:
    Service Categories supported: vbr-nrt
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none vbr,
        Peak-cell-rate TX: none vbr,
        Sustained-cell-rate: none vbr RX, none vbr TX
        Minimum-cell-rate RX:
        Minimum-cell-rate TX:
        CDVT RX: none vbr,
        CDVT TX: none vbr,
        MBS: none vbr RX, none vbr TX

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 613 vbr RX, 613 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 9114 vbr RX, 9114 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

8540-MSR# show atm interface resource atm2/1/0.10

Resource Management configuration:
    Service Categories supported: ubr
    Link Distance: 0 kilometers
    Best effort connection limit: disabled  0 max connections
    Max traffic parameters by service (rate in Kbps, tolerance in cell-times):
        Peak-cell-rate RX: none ubr
        Peak-cell-rate TX: none ubr
        Minimum-cell-rate RX: none ubr
        Minimum-cell-rate TX: none ubr
        CDVT RX: none ubr
        CDVT TX: none ubr

Resource Management state:
    Available bit rates (in Kbps):
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX
    Allocated bit rates:
        0 cbr RX, 0 cbr TX, 0 vbr RX, 0 vbr TX,
        0 abr RX, 0 abr TX, 0 ubr RX, 0 ubr TX

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報

5500 非対称多重処理システムe スイッチ設定を見るためにクリックして下さい。 5500-asp-f スイッチ設定を見るためにクリックして下さい。 8540 MSR スイッチ設定を見るためにクリックして下さい。


Document ID: 10493