マルチプロトコル ラベル スイッチング(MPLS) : Multiprotocol Label Switching over ATM(MPLS over ATM)

MSGS over VP トンネル

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

サービス プロバイダーは通常、ポイントツーポイント物理リンクの代わりに、デバイスをまとめて接続する 1 つ以上の仮想パス(VP)トンネルを提供します。 このドキュメントでは、VP トンネルを使用する場合に、マルチプロトコル ラベル スイッチング(MPLS)を設定するために必要な手順について説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10476/mpls_vptunnel-1.gif

このセットアップでは、サービスプロバイダーは 2 つの VP トンネルを供給しました:

  • イスキア島とカプリ島の間の 1 つとの VPI = 3 (仮想パス識別子)

  • Alcazaba とカプリ島の間の 1 つとの VPI = 4

イスキア島および Alcazaba は 2 つの Cisco 7200 ルータその実行 Cisco IOS ですか。 ソフトウェア リリース 12.1(3a)E。 カプリ島は Catalyst 8540 multiservice スイッチ ルータ(MSR)その実行リリース 12.0(10)W5(18c) です。 カプリ島は Alcazaba およびイスキア島のタグ配布プロトコル (TDP) ネイバーです。

注: リリース 12.0(3)T を実行するか、またはより高くこの機能を設定するなります。

ここでは使用されるコンフィギュレーションは Catalyst 8500 MSR のため、か LightStream 1010 およびルータです。

設定

このドキュメントでは、次の設定を使用します。

イスキア島
ip cef 
! 
interface Loopback0 
 ip address 1.1.1.1 255.255.255.0 
! 
interface ATM2/0.3 tag-switching 
 ip address 3.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 3 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 1.1.1.1 0.0.0.0 area 0 
 network 3.0.0.0 0.0.0.255 area 0 

Alcazaba
 ip cef 
! 
interface Loopback0 
 ip address 2.2.2.2 255.255.255.0 
! 
interface ATM4/0.4 tag-switching 
 ip address 4.0.0.1 255.255.255.0 
 tag-switching atm vp-tunnel 4 
 tag-switching ip 
! 
router ospf 6 
 log-adjacency-changes 
 network 2.2.2.2 0.0.0.0 area 0 
 network 4.0.0.0 0.0.0.255 area 0 

Capri
 interface ATM3/1/1 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 atm pvp 3 
 atm pvp 4 
! 
interface ATM3/1/1.3 point-to-point 
 ip address 3.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 
! 
interface ATM3/1/1.4 point-to-point 
 ip address 4.0.0.2 255.255.255.0 
 no ip directed-broadcast 
 no atm ilmi-keepalive 
 tag-switching ip 

注: この設定はここに見つけることができる標準ルータ設定に類似したです。 唯一の違いは VPトンネルを使用することルータに規定 しなければならないことです。 vpi がそのトンネルとこのルータの端関連付けられる VPI 値である tag-switching atm vp-tunnel vpi コマンドでこれをすることができます。

注: LightStream 1010 および Catalyst 8500 MSR に関しては、atm pvp vpi コマンドで各 VPトンネルのための 1つ以上の相手先固定パス(PVP)を設定する必要があります。 設定 例についてはここに参照して下さい。 サブインターフェイスはこれらのトンネルのそれぞれと関連付けられます。 たとえば、ATM 3/1/1.3 インターフェイスは PVP=3 と関連付けられます。 メインインターフェイスでするように Tagスイッチングでこのサブインターフェイスを設定して下さい。

確認

ネットワークが正しく動作することテストするこれらの Tagスイッチング show コマンドを使用して下さい:

  • show tag-switching tdp neighbor

  • show tag-switching atm-tdp bindings —これはダイナミック ATM タグ 情報を示します。

  • show tag-switching forwarding-table —これは Tag Forwarding Information Base (TFIB)を示します。

  • show tag-switching interfaces atm [int number] detail —これは各インターフェイスのための詳しい Tagスイッチング 情報を示します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

この出力はネットワークダイアグラムで示されているデバイスで入力されるこれらのコマンドの結果です。

Ischia#show tag-switching tdp neighbor
Peer TDP Ident: 10.200.10.57:1; Local TDP Ident 1.1.1.1:1
        TCP connection: 3.0.0.2.11001 - 3.0.0.1.711
        State: Oper; PIEs sent/rcvd: 92/93; ; Downstream on demand
        Up time: 01:16:52
        TDP discovery sources:
          ATM2/0.3
 
Ischia#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Headend Router ATM2/0.3 (1 hop) 3/33  Active, VCD=127
 Destination: 1.1.1.0/24
    Tailend Router ATM2/0.3 3/33 Active, VCD=127
 Destination: 2.2.2.2/32
    Headend Router ATM2/0.3 (2 hops) 3/34  Active, VCD=128
 
Ischia#show tag-switching forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
26     3/33        4.0.0.0/24        0          AT2/0.3    point2point  
27     3/34        2.2.2.2/32        0          AT2/0.3    point2point   
 
Ischia#show tag-switching interfaces detail 
Interface ATM2/0.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        Tagswitching turbo vector
        MTU = 4470
        ATM tagging:
                Tag VPI = 3 (VP Tunnel)
                Tag VCI range = 33 - 65535
                Control VC = 3/32
 
Capri#show tag-switching atm-tdp bindings 
 Destination: 4.0.0.0/24
    Tailend Switch ATM3/1/1.3 3/33 Active -> Terminating Active
 Destination: 1.1.1.1/32
    Transit ATM3/1/1.4 4/33 Active -> ATM3/1/1.3 3/33 Active
 Destination: 3.0.0.0/24
    Tailend Switch ATM3/1/1.4 4/34 Active -> Terminating Active
 Destination: 2.2.2.2/32
    Transit ATM3/1/1.3 3/34 Active -> ATM3/1/1.4 4/33 Active
 
Capri#show tag-switching tdp neighbor 
Peer TDP Ident: 1.1.1.1:1; Local TDP Ident 10.200.10.57:1
        TCP connection: 3.0.0.1.711 - 3.0.0.2.11001
        State: Oper; PIEs sent/rcvd: 95/94; ; Downstream on demand
        Up time: 01:18:49
        TDP discovery sources:
          ATM3/1/1.3
Peer TDP Ident: 2.2.2.2:1; Local TDP Ident 10.200.10.57:2
        TCP connection: 4.0.0.1.711 - 4.0.0.2.11002
        State: Oper; PIEs sent/rcvd: 93/95; ; Downstream on demand
        Up time: 01:18:22
        TDP discovery sources:
          ATM3/1/1.4
 
Capri#show tag-switching interfaces detail 
Interface ATM3/1/1.3:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 3, Control VC = 3/32
Interface ATM3/1/1.4:
        IP tagging enabled
        TSP Tunnel tagging not enabled
        Tagging operational
        MTU = 4470
        ATM tagging: Tag VPI = 4, Control VC = 4/32

この出力は標準 Tagスイッチング出力に類似したですが、1 つの重要な違いは VPトンネルインターフェイスを指すことです。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10476