マルチプロトコル ラベル スイッチング(MPLS) : Multiprotocol Label Switching over ATM(MPLS over ATM)

MPLS over ATM: VC マージ

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、仮想回線(VC)マージを使用したマルチプロトコル ラベル スイッチング(MPLS)over ATM の設定例を紹介します。

前提条件

要件

この設定を試みる前に、ATM、MPLS および Open Shortest Path First (OSPF)の基本的な知識があることを確認して下さい。

使用するコンポーネント

この設定を設定するためにこれらのルータの 1 人を使用して下さい:

  • エッジ ラベル スイッチ ルータ(LSR) — ATMルータ Cisco IOS を実行するか。 MPLS 機能が付いているソフトウェア リリース 12.0 または それ 以降。 この設定は Cisco IOS ソフトウェア リリース 12.1(3)T および Cisco 7200 ルータを実行するため Cisco 3600 シリーズ ルータを使用します Cisco IOS software release 12.0(8)S を実行する。

  • ATM LSR — LightStream 1010 または Catalyst 85xx MSR のような ATM スイッチ。 Cisco はソフトウェア バージョン WA4.8d またはそれ以降を使用することを推奨します。 LightStream 1010 は特殊機構カード PerFlow キューイングを必要とします(FC-PFQ)。

ATM のための MPLS の設計のサポートされているプラットフォームのより精密な説明を見つけることができます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

MPLS 設定および規定に関する詳細についてはこれらのリンクを参照して下さい:

  • VC マージ ファシリティはラベル配布プロトコル (LDP)および ATM VC スイッチング 文書を使用してインターネット技術特別調査委員会 (IETF) マルチプロトコルラベルスイッチングアーキテクチャおよび MPLS で標準化されます。 IETF MPLS チャーターから両方の文書にアクセスできますleavingcisco.com

  • MPLS over ATM ドキュメントのコンフィギュレーションに関する説明書きを見つけることができます。

  • MPLS ネットワークで使用される ATM のための MPLS の設計の Dimensioning MPLS Label VC Space セクションで VC の数の寸法記入はカバーされます。

背景説明

VC マージ ファシリティはスイッチが単一 発信 フローへの同じ宛先アドレスが付いている複数の着信フローを集約するようにします。 VC マージが行われるところはどこでも、複数の入ラベルは 1 つの単一 出ラベルにマッピング されます。 同じ宛先からセルはに行く異なる仮想チャネル識別子(VCI)マルチポイント ツー ポイント接続の使用の同じ発信 VC に送信されます。 ラベルのこの共有がラベル スイッチングに必要な VC の総数を減らします。 VC マージなし、各パス(と同じ入力ルータおよび同じ転送等価 クラス(FEC)) パスに沿う各インターフェイスの 1 ラベル VC を消費します。 VC マージは同じ宛先と異なるフローのためのラベルを、すなわち共有することによってラベル スペース不足を、同じ FEC 減らします。

この図は VC マージの例を示します。 この図では、ルータ A および B はルータ C の 171.69.0.0/16 の前に付けるためにトラフィックを送信 します。 中央の ATM スイッチは 171.69.0.0/16 の前に付けるために結合 される 単一 送信 VCI 50 で設定されます。 ルータ A および B からのデータフローは ATM スイッチで集まり、同じ発信 VC を共有します。 VCI 40 および VCI 70 から来るセルは ATM スイッチのインプットキューで完全な AAL5 帯が受信されるまでバッファリングされます。 完全なフレームは VCI 50 のルータ C にそれから転送されます。

/image/gif/paws/10475/mpls_vcmerge1.gif

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10475/mpls_vcmerge2.gif

設定

この例では、ATM仮想パス識別(VPI)は 2、3、か 4 使用されます。 しかし、仮想パス(VP)が MPLS のために使用される規定 することは必須ではないです。

ルータの IP Cisco Express Forwarding (CEF)を設定して下さい。 Cisco 7500 ルータを使用する場合、ip cef distributed コマンドが有効に なるようにして下さい。

このドキュメントでは、次の設定を使用します。

ルータ 1
!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!
interface Loopback1
 ip address 100.100.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 100.100.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 100.100.0.0 0.0.0.255 area 10
 network 100.100.1.0 0.0.0.255 area 10
 network 223.0.0.12 0.0.0.0 area 10
!

ルータ 2
!
ip cef
!
interface Loopback0
 ip address 223.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 100.100.0.1 255.255.255.0
!
interface ATM1/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
!
interface ATM1/0.1 label-switching
 ip address 10.0.0.2 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 100.100.0.0 0.0.0.255 area 10
 network 223.0.0.11 0.0.0.0 area 0
!

ルータ 3
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip address 200.200.0.1 255.255.255.255
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.6 255.255.255.252
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 redistribute static
 network 10.0.0.0 0.0.0.255 area 0
 network 200.200.0.0 0.0.0.255 area 20
 network 223.0.0.21 0.0.0.0 area 0
!
ip route 158.0.0.0 255.0.0.0 Null0
!

ルータ 4
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
 no ip directed-broadcast
! 
interface Loopback1
 ip address 150.150.1.1 255.255.255.0
 no ip directed-broadcast
!
interface ATM4/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 label-switching
 ip address 10.0.0.13 255.255.255.252
 no ip directed-broadcast
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.255.255 area 30
 network 223.0.0.3 0.0.0.0 area 0
!
ip route 150.150.150.0 255.255.255.0 Null0
!

ATM スイッチ 1
!
interface Loopback0
 ip address 223.0.0.1 255.255.255.255
 no ip directed-broadcast
!
interface ATM4/1/2
 ip address 10.0.0.1 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM4/1/3
 ip address 10.0.0.21 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.1 0.0.0.0 area 0
!

ATM スイッチ 2
!
interface Loopback0
 ip address 223.0.0.2 255.255.255.255
 no ip directed-broadcast
!
interface ATM0/1/0
 ip address 10.0.0.14 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!         
interface ATM0/1/2
 ip address 10.0.0.5 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
interface ATM0/1/3
 ip address 10.0.0.22 255.255.255.252
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 label-switching atm vpi 2-4
 label-switching ip
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.2 0.0.0.0 area 0
!

確認

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show tag-switching atm-tdp capability

  • show tag-switching atm-tdp bindings

  • show atm vc

VCマージの情報を得るために show tag atm-tdp コマンドを発行して下さい。 show tag-switching atm-tdp capability コマンドによって生成されるこの出力は VCマージがこれらのインターフェイスで有効に なることを示したものです:

ATMswitch2#show tag-switching atm-tdp capability 
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/0       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1023]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1023]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/2       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 1018]   UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 1018]   UNIDIR           -    -    
 
               VPI           VCI           Alloc   Odd/Even VC Merge     
ATM0/1/3       Range         Range         Scheme  Scheme   IN   OUT  
  Negotiated   [2 - 4]       [33 - 16383]  UNIDIR           -    -    
  Local        [2 - 4]       [33 - 16383]  UNIDIR           EN   EN   
  Peer         [2 - 4]       [33 - 16383]  UNIDIR           -    -

また 1 つの特定の FEC があるように–この出力に見られるように… VC マージを–たとえば、100.100.1.1/32 確認できます:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/47 Active -> ATM0/1/3 2/52 Active
    Transit ATM0/1/0 2/47 Active -> ATM0/1/3 2/52 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/2    2    47   TVC(I) ATM0/1/3          2   52           UP
ATM0/1/3    2    52   TVC(O) ATM0/1/2          2   47           UP
                             ATM0/1/0          2   47           UP

それが no tag-switching atm vc-merge コマンドでディセーブルにされる場合はたらかなければ VC 併合が(または)、このコマンド 出力がによって表示されます:

ATMswitch2#show tag atm-tdp bindings
Destination: 100.100.1.1/32
    Transit ATM0/1/2 2/38 Active -> ATM0/1/3 2/35 Active
    Transit ATM0/1/0 2/43 Active -> ATM0/1/3 2/43 Active

ATMswitch2#show atm vc
Interface  VPI  VCI   Type   X-Interface     X-VPI X-VCI Encap  Status
ATM0/1/0   2    43    TVC(I) ATM0/1/3          2   43           UP
ATM0/1/2   2    38    TVC(I) ATM0/1/3          2   35           UP
ATM0/1/3   2    35    TVC(O) ATM0/1/2          2   38           UP
ATM0/1/3   2    43    TVC(O) ATM0/1/0          2   43           UP

VC マージ機能をディセーブルにすることがもっとたくさんの VC を使用してシステムに導くことがこの出力からわかります。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10475