マルチプロトコル ラベル スイッチング(MPLS) : Multiprotocol Label Switching over ATM(MPLS over ATM)

MPLS VPN over ATM: カスタマー側のOSPF を使う場合 (領域0 を使用)

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Open Shortest Path First(OSPF)がカスタマー側にある場合(領域 0 を使用)、ATM を介したマルチプロトコル ラベル スイッチング(MPLS)バーチャル プライベート ネットワーク(VPN)の設定例を紹介しています。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

次の文字は、使用されるさまざまなタイプのルータとスイッチを表しています。

  • P: プロバイダーのコア ルータ

  • PE: プロバイダーのエッジ ルータ

  • CE : カスタマーのエッジ ルータ

  • C: 顧客のルータ

このダイアグラムはこれらの規定を使用して典型的なコンフィギュレーションを示します:

/image/gif/paws/10473/mplsvpn.gif

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • PE ルータ

  • CE ルータ: PE ルータとルーティング情報を交換することできるどのルータでも使用することができます。

  • P ルータおよびスイッチ: MPLS VPN 統合 機能は MPLS ネットワークの端にだけ備えられています、従ってどの MPLS対応スイッチでも使用することができます。 この設定 例では、MPLS クラウドは 8540 マルチサービスATMスイッチ ルータ(MSR)および LightStream 1010 で構成されます。 Cisco lightstream 1010 を使用している場合、ソフトウェア バージョン WA4.8d またはそれ以降を使用することを推奨します。 ATM コア ネットワークで、Cisco BPX 8650 や MGX 8850 など、ほかの ATM スイッチを使用することもできます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景理論

VPN 機能を MPLS と併用すると、サービス プロバイダーのネットワークを介して、複数のサイトを透過的に相互接続できます。 1 つのサービス プロバイダー ネットワークで複数の IP VPN をサポートできます。 各 VPN は、ユーザからは他のすべてのネットワークから切り離されたプライベート ネットワークのように見えます。 1 つの VPN を通じて、各サイトは同じ VPN 内にある他のサイトに IP パケットを送信できます。

各 VPN は 1 つ以上の VPN ルーティング/転送インスタンス(VRF)に関連付けられます。 VRF はインターフェイスの IPルーティングテーブル、得られた Cisco Express Forwarding (EF)表およびこのフォワーディングテーブルを使用する一組で構成されています。

ルータは各 VRF のための Cisco 別途のルーティングおよび EF 表を維持します。 そのため、情報が VPN の外部に送信されることがなく、さらに IP アドレスの重複問題を気にせずに複数の VPN で同じサブネットを使用できます。

ボーダーゲートウェイ プロトコル(BGP)を使用するルータは、BGP 拡張コミュニティを使用して、VPN ルーティング情報を分配します。

VPN を通じたアップデートの伝播に関する詳細については、次の URL を参照してください。

OSPF の使用

従来複雑な OSPF ネットワークは、バックボーン エリア(エリア 0)と、このバックボーンにエリア境界ルータ(ABR)を介して接続された多くのエリアから構成されます。

カスタマ・サイトの OSPF を使う場合 VPN のために MPLS バックボーンを使用することによって、OSPF モデルの階層の第 3 レベルをもたらすことができます。 この第 3 レベルは、MPLS VPN スーパーバックボーンと呼ばれます。

簡単な事例では、MPLS VPN スーパーバックボーンは従来のエリア 0 バックボーンと組み合わせられます。 これは MPLS VPN スーパーバックボーンが area 0 backbone と同じロールを担うのでカスタマーネットワークに area 0 backbone がないことを意味します。 これは下記の図で示されています:

/image/gif/paws/10473/mpls_ospf1.gif

このダイアグラムでは、

  • PE ルータは ABR および自律システム境界ルータ(ASBR)です。

  • CE ルータは簡単な OSPF ルータです。

  • VPN 情報は PE から他の PE への BGP拡張コミュニティを使用して転送され、OSPF エリアにサマリー ネットワーク(3)型 Link State Advertisement (LSA; リンクステート アドバタイズメント)として再挿入されます。

MPLS VPN スーパーバックボーンでも、カスタマーのサイトで複数のエリア 0 バックボーンを使用することができます。 MPLS VPN スーパーバックボーンに接続されているかぎり、各サイトは別のエリア 0 を設定できます。 結果は区分領域 0 バックボーンと同じです。 これは下記の図で示されています:

/image/gif/paws/10473/mpls_ospf2.gif

この場合:

  • PE ルータは ABR および ASBR ルータです。

  • CE ルータは ABR ルータです。

  • VPN 情報が含まれている LSA は PE から他の PE への BGP拡張コミュニティを使用して転送されます。 集約ネットワーク(タイプ 3)LSA で、PE と CE 間の情報が伝送されます。

この設定 例は上に表示される第 2 セットアップに基づいています。 MPLS VPN over ATM で第 1 を設定するのに使用する設定 例を見つけることができます: カスタマー サイドの OSPF を使う場合(エリア 0 なしで)

OSPF情報は BGP 拡張コミュニティーの属性と転送されます(OSPFネットワークを識別する)を含む 1。 各 VPN は固有の OSPF プロセスが必要です。 これを規定 するために、次のコマンドを発行して下さい:

router ospf <process ID > VRF <VPN ルーティングまたは forwarding instance name >

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/10473/mpls_ospf4.gif

設定手順

Cisco IOS ドキュメント(『MPLS バーチャル プライベート ネットワーク』)にも、この設定手順の説明があります。

パート I

ip cef がイネーブルであることを確認します。 Cisco 7500 ルータを使用している場合、ip cef distributed が有効に なるようにして下さい。 PE、MPLS が設定されれば:

  1. ip vrf <VPN routing/forwarding instance name> コマンドを使用して、接続された各 VPN に 1 つの VRF を作成します。 このときに、次のことを行います。

    • その VPN に使用する正しいルート区分を規定 するために下記のコマンドを発行して下さい。 これは IP アドレスを拡張するために使用されるため、これによって IP アドレスがどの VPN に所属するのかを特定できます。

      rd <VPN ルート区分 >

    • BGP 拡張コミュニティに対し、インポート プロパティとエクスポート プロパティをセットアップします。 これらのプロパティは、インポートおよびエクスポート プロセスをフィルタリングするために使用されます。

      ルート・ターゲット[エクスポート|インポート|両方] <target VPN extended community >

  2. このコマンドの発行によって個々のインターフェイスのためのフォワーディング詳細を設定して下さい:

    <table 名前を転送する IP VRF >

    上記作業の後、必ず IP アドレスをセットアップしてください。

  3. 使用している PE-CE ルーティング プロトコルに応じて、次の 1 つまたは複数の作業を実行する必要があります。

    • 次のようにスタティック ルートを設定します。

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}]

    • コマンドの発行によってルーティング情報プロトコル (RIP)を設定して下さい:

      address-family ipv4 vrf <VPN ルーティング/forwarding instance name >

      これがされたら、正常な Rip コンフィギュレーション コマンドを入力して下さい。

      次のことに注意してください。

      • 現在の VRF の転送インターフェイスにのみ適用されます。

      • RIP に正しい BGP を再配布することは必要です。 この場合、使用するメトリックを必ず指定してください。

    • BGP ネイバー情報を宣言します。

    • 新しい Cisco IOS コマンドの発行によって OSPF を設定して下さい:

      router ospf <process ID > VRF <VPN ルーティング/forwarding instance name >

    次のことに注意してください。

    • 現在の VRF の転送インターフェイスにのみ適用されます。

    • OSPF に正しい BGP を再配布することは必要です。 この場合、使用するメトリックを必ず指定してください。

    • OSPFプロセスが VRF に帰因すれば、このプロセス数はこの特定の VRF のために常に使用されます。 これは、コマンド ラインで VRF を指定しない場合にも当てはまります。

パート II

PE ルータ間で BGP を設定します。 BGP の設定には、ルート リフレクタやコンフェデレーション方式を使用するなど、いくつかの方法があります。 ここでは使用される方式は–ダイレクト隣接コンフィギュレーション–最も簡単および最も少なくスケーラブルです。

  1. それぞれの近接ルータを宣言します。

  2. PE ルータに存在する VPN ごとに、address-family ipv4 vrf <VPN routing/forwarding instance name> コマンドを入寮クします。 必要に応じて、次のステップを 1 回以上実行します。

    • スタティック ルーティング情報を再配信します。

    • RIP ルーティング情報を再配信します。

    • OSPF ルーティング情報を再配信します。

    • BGP による CE ルータとの近接関係をアクティブにします。

  3. address-family vpnv4 モードに移行し、

    • 近接ルータをアクティブにします。

    • 拡張コミュニティを使用する必要があることを指定します。 これは必須です。

設定

注: 次の出力の関連した部分だけここに含まれています。

Alcazaba
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!         
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.10 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 150.150.0.1 255.255.255.0
 no ip mroute-cache
!
interface ATM4/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 150.150.0.0 0.0.0.255 area 0
 network 222.0.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Kozel
!
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.30 255.255.255.255
!         
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 69.69.0.1 255.255.255.252
 no ip mroute-cache
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 tag-switching
 ip address 11.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 11.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 69.69.0.0 0.0.0.255 area 0
 network 222.0.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.11 remote-as 1
 neighbor 223.0.0.11 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.11 activate
 neighbor 223.0.0.11 send-community extended
 exit-address-family
!

Rapid
!
interface Loopback0
 ip address 222.0.0.1 255.255.255.255
!
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/0
 ip address 7.7.8.1 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 1
 network 150.150.0.0 0.0.0.255 area 0
 network 222.0.0.1 0.0.0.0 area 1
!

Pivrnec
!
interface Loopback0
 ip address 222.0.0.3 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 6.6.7.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 69.69.0.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 3
 network 69.69.0.0 0.0.0.255 area 0
 network 222.0.0.3 0.0.0.0 area 3
!

Guilder
!         
interface Loopback0
 ip address 222.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 7.7.8.2 255.255.255.0
!
router ospf 2
 network 7.7.8.0 0.0.0.255 area 1
 network 222.0.0.0 0.0.0.255 area 1
!

イスキア島
!
interface Loopback0
 ip address 222.0.0.22 255.255.255.255
!
interface Ethernet1/4
 ip address 6.6.7.2 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 6.6.7.0 0.0.0.255 area 3
 network 222.0.0.0 0.0.0.255 area 3
!

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip route vrf <VPN routing or forwarding instance name>

  • show ip bgp vpnv4 vrf <VPN routing or forwarding instance name> <A.B.C.D>

  • show ip ospf <process ID number>

  • show ip ospf <process ID number> interface

  • show ip ospf <process ID number> database

  • show tag-switching forwarding-table vrf <VPN routing or forwarding instance name>

PE ルータで特定の VPN のための VRF を示す上記の最初の 2 つのコマンドを発行して下さい。

OSPF 特有のコマンド

PE ルータ用コマンド

次のコマンドは対応する VRF のための OSPF情報を示します。 出力のほとんどの重要な部分は下記の太字のテキストで示されています。

注: これらのコマンドを発行するとき VRF を規定 する必要がありません。

Alcazaba#show ip ospf 2
 Routing Process "ospf 2" with ID 222.0.0.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN Superbackbone
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    bgp 1, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 13. Checksum Sum 0x715C5 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Alcazaba#show ip ospf 2 database
 
            OSPF Router with ID (222.0.0.10) (Process ID 2)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       272         0x80000009 0xCA39   1
222.0.0.10      222.0.0.10      197         0x80000003 0xFCFF   2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      197         0x80000002 0xEA6E  
 
                Summary Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      197         0x80000002 0x4768  
6.6.7.0         222.0.0.10      750         0x80000001 0xD4D7  
7.7.7.7         222.0.0.1       272         0x80000002 0x72CC  
7.7.8.0         222.0.0.1       1003        0x80000003 0x635   
69.69.0.0       222.0.0.10      197         0x80000002 0x2228  
222.0.0.1       222.0.0.1       272         0x80000002 0x5A21  
222.0.0.3       222.0.0.10      197         0x80000004 0xE8FA  
222.0.0.11      222.0.0.1       1010        0x80000001 0x5C0C  
222.0.0.22      222.0.0.10      752         0x80000001 0x9435  
222.0.0.30      222.0.0.10      199         0x80000002 0x795B  

Alcazaba#show ip ospf 2 interface
Loopback1 is up, line protocol is up 
  Internet Address 222.0.0.10/32, Area 0 
  Process ID 2, Router ID 222.0.0.10, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Ethernet1/1 is up, line protocol is up 
  Internet Address 150.150.0.1/24, Area 0 
  Process ID 2, Router ID 222.0.0.10, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 6, maximum is 6
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

CE ルータ用コマンド

この場合、CEルータはまた別のエリアに接続されるので ABR です。 このルータがエリア 0 のインターフェイスを持つことだった場合通常 の ルータ、ない ABR または ASBR です。

rapid#show ip ospf
 Routing Process "ospf 1" with ID 222.0.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 14 times
        Area ranges are
        Number of LSA 13. Checksum Sum 0x715C5 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 48 times
        Area ranges are
        Number of LSA 16. Checksum Sum 0x8CCBE 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

rapid#show ip ospf database
 
       OSPF Router with ID (222.0.0.1) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       331         0x80000009 0xCA39   1
222.0.0.10      222.0.0.10      259         0x80000003 0xFCFF   2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      259         0x80000002 0xEA6E  
 
                Summary Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      259         0x80000002 0x4768  
6.6.7.0         222.0.0.10      812         0x80000001 0xD4D7  
7.7.7.7         222.0.0.1       331         0x80000002 0x72CC  
7.7.8.0         222.0.0.1       1062        0x80000003 0x635   
69.69.0.0       222.0.0.10      259         0x80000002 0x2228  
222.0.0.1       222.0.0.1       331         0x80000002 0x5A21  
222.0.0.3       222.0.0.10      260         0x80000004 0xE8FA  
222.0.0.11      222.0.0.1       1069        0x80000001 0x5C0C  
222.0.0.22      222.0.0.10      813         0x80000001 0x9435  
222.0.0.30      222.0.0.10      260         0x80000002 0x795B  
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1078        0x80000029 0x658E   3
222.0.0.10      222.0.0.10      2962        0x80000003 0xFCFF   2
222.0.0.11      222.0.0.11      1080        0x80000003 0xA97F   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
7.7.8.2         222.0.0.11      1081        0x80000001 0x93DA  
150.150.0.1     222.0.0.10      2962        0x80000002 0xEA6E  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.1       332         0x80000002 0x69C5  
6.6.6.6         222.0.0.10      2720        0x80000002 0x4768  
6.6.7.0         222.0.0.1       820         0x80000001 0xF635  
69.69.0.0       222.0.0.1       341         0x80000002 0x4485  
150.150.0.0     222.0.0.1       341         0x80000004 0x57CB  
222.0.0.3       222.0.0.1       341         0x80000002 0xF56   
222.0.0.3       222.0.0.10      2727        0x80000002 0xECF8  
222.0.0.10      222.0.0.1       341         0x80000002 0x6404  
222.0.0.22      222.0.0.1       820         0x80000001 0xB692  
222.0.0.30      222.0.0.1       341         0x80000002 0x9BB8  
 
                Summary ASB Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
222.0.0.10      222.0.0.1       341         0x80000002 0x4C1C  

a.c.ルータのためのコマンド

IPルーティングテーブルを示すために次のコマンドを発行して下さい:

Guilder#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
O IA    69.69.0.0 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
     222.0.0.0/32 is subnetted, 6 subnets
O IA    222.0.0.30 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
O IA    222.0.0.22 [110/41] via 7.7.8.1, 00:06:33, Ethernet0/1
O IA    222.0.0.10 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
C       222.0.0.11 is directly connected, Loopback0
O IA    222.0.0.3 [110/31] via 7.7.8.1, 00:06:33, Ethernet0/1
O       222.0.0.1 [110/11] via 7.7.8.1, 00:06:33, Ethernet0/1
     6.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O IA    6.6.6.6/32 [110/31] via 7.7.8.1, 00:06:34, Ethernet0/1
O IA    6.6.7.0/24 [110/40] via 7.7.8.1, 00:06:34, Ethernet0/1
     7.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       7.7.7.7/32 [110/11] via 7.7.8.1, 00:06:35, Ethernet0/1
C       7.7.8.0/24 is directly connected, Ethernet0/1
     10.0.0.0/22 is subnetted, 1 subnets
C       10.200.8.0 is directly connected, Ethernet0/0
     150.150.0.0/24 is subnetted, 1 subnets
O IA    150.150.0.0 [110/20] via 7.7.8.1, 00:06:35, Ethernet0/1

MPLS ラベル

エントリ Label Switch Router (LSR)のラベルスタックに次の通り 2 つのラベルがあることを確認して下さい:

Alcazaba#show tag-switching forwarding-table vrf vpn1 6.6.7.2 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
None   2/41        6.6.7.0/24        0          AT4/0.1    point2point  
        MAC/Encaps=4/12, MTU=4466, Tag Stack{2/41(vcd=10) 29}
        000A8847 0000A0000001D000

それらが終了 LSR で現われることをこの場合、確認して下さい:

Kozel#show tag-switching forwarding-table vrf vpn1 6.6.7.2 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
29     Untagged    6.6.7.0/24[V]     1466       Et1/1      69.69.0.2    
        MAC/Encaps=0/0, MTU=1500, Tag Stack{}
        VPN route: vpn1
    Per-packet load-sharing

テストコマンド

今すべてがうまくあることテストする ping コマンドを発行できます:

Ischia#ping 222.0.0.11
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 222.0.0.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
Ischia#trac
Ischia#traceroute 222.0.0.11
 
Type escape sequence to abort.
Tracing the route to 222.0.0.11
 
  1 6.6.7.1 0 msec 0 msec 0 msec
  2 69.69.0.1 0 msec 0 msec 0 msec
  3 150.150.0.1 4 msec 4 msec 0 msec
  4 150.150.0.2 4 msec 0 msec 0 msec
  5 7.7.8.2 4 msec *  0 msec

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10473