マルチプロトコル ラベル スイッチング(MPLS) : Multiprotocol Label Switching over ATM(MPLS over ATM)

VC マージのないATM上のマルチプロトコル・ラベル・スイッチング (MPLS)

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、ATM を持つマルチプロトコル ラベル スイッチング(MPLS)ネットワークについて説明します。 VC マージは使用されないため、ルーティング テーブルのプレフィックスによって定義されたようにルートごとに 1 つの VC を割り当てます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.0 または それ 以降は Guilder および Damme の MPLS のためです。

  • Label Switch Router (LSR)として使用するこのセットアップは 1 ATM スイッチを使用します。 この例では、それは Catalyst 8540MSR です。 それはまた LS1010 である場合もあります。 Cisco はソフトウェア バージョン WA4.8d かあとで LS1010 を推奨します。 8540MSR のどのソフトウェアでも十分です。

  • Cisco Express Forwarding (CEF)は MPLS/Tag 切り替えを実行するルータで有効に なる必要があります。 この例では、Guilder およびダンメは Cisco 3600 です。 7500 が使用される場合、ip cef distributed は有効に する必要があります。

注: ない要件が、この資料 VPI 2 を使用するが、すべてのための 3 つ、か 4 つはこの例の VC をタグ付けします。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10467/mpls_basic2.gif

注: ループバックインターフェイスはすべてのルータ/LSR で設定 されました。 それらはネットワークダイアグラムで簡潔にするために示されていません。

設定

このドキュメントでは、次の設定を使用します。

ポンド
!         
interface Loopback0
 ip address 100.100.0.1 255.255.0.0
 no ip directed-broadcast
!         
interface Ethernet0/1
 ip address 123.123.0.2 255.255.0.0
 no ip directed-broadcast
!         
router ospf 1
 network 100.100.0.0 0.0.255.255 area 1.1.1.1
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
!

Guilder
!
ip cef
!
interface Loopback0
 ip address 102.102.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 123.123.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM1/0.1 tag-switching
 ip address 129.129.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 102.102.0.0 0.0.255.255 area 0.0.0.0
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

カプリ島(8540MSR)
!
interface Loopback0
 ip address 103.103.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM3/0/0
 ip address 128.128.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
interface ATM3/0/3
 ip address 129.129.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 103.103.0.0 0.0.255.255 area 0.0.0.0
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Damme
!
ip cef
!
interface Loopback0
 ip address 104.104.0.1 255.255.0.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 125.125.0.1 255.255.0.0
 no ip directed-broadcast
 duplex auto
 speed 10
 tag-switching ip
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 0/16 ilmi
 !        
 pvc 0/5 qsaal
 !
!
interface ATM1/0.2 tag-switching
 ip address 128.128.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 104.104.0.0 0.0.255.255 area 0.0.0.0
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
!

Lira
!
interface Loopback0
 ip address 101.101.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 125.125.0.2 255.255.0.0
 no ip directed-broadcast
!
router ospf 1
 network 101.101.0.0 0.0.255.255 area 2.2.2.2
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
!

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show tag-switching forwarding-table — Tag Forwarding Information Base (TFIB)を示します。

  • show tag-switching atm-tdp bindings — ダイナミック ATM タギング 情報を示します。

  • Tagスイッチング int ATM [int 番号] Shows によって詳述されるインターフェースごとの Tagスイッチング 情報を detail —示して下さい

この出力はルーティング テーブルが Guilder で完了したことを示したものです:

Guilder#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     102.0.0.0/16 is subnetted, 1 subnets

C       102.102.0.0 is directly connected, Loopback0

     103.0.0.0/32 is subnetted, 1 subnets

O       103.103.0.1 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

     100.0.0.0/32 is subnetted, 1 subnets

O       100.100.0.1 [110/11] via 123.123.0.2, 23:45:47, Ethernet0/1

     101.0.0.0/32 is subnetted, 1 subnets

O IA    101.101.0.1 [110/13] via 129.129.0.2, 23:13:01, ATM1/0.1

O    128.128.0.0/16 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

C    129.129.0.0/16 is directly connected, ATM1/0.1

     125.0.0.0/16 is subnetted, 1 subnets

O IA    125.125.0.0 [110/12] via 129.129.0.2, 23:13:08, ATM1/0.1

     123.0.0.0/16 is subnetted, 1 subnets

C       123.123.0.0 is directly connected, Ethernet0/1

     104.0.0.0/32 is subnetted, 1 subnets

O       104.104.0.1 [110/3] via 129.129.0.2, 23:14:32, ATM1/0.1

show tag-switching forwarding-table コマンドで label/VC マッピングにプレフィクスをチェックして下さい。

Guilder#show tag-switching forwarding-table 

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    

tag    tag or VC   or Tunnel Id      switched   interface              

26     Untagged    100.100.0.1/32    570        Et0/1      123.123.0.2  

27     2/33        103.103.0.1/32    0          AT1/0.1    point2point  

28     2/34        128.128.0.0/16    0          AT1/0.1    point2point  

29     2/35        104.104.0.1/32    0          AT1/0.1    point2point  

30     2/37        125.125.0.0/16    0          AT1/0.1    point2point  

31     2/38        101.101.0.1/32    0          AT1/0.1    point2point 

カプリ島(ATM LSR)で、show tag atm-tdp バインディング コマンドでバインディングをルーティングするために TVC をチェックできます。 1 TVC は各ルーティング テーブル エントリのために使用されます。

Capri#show tag atm-tdp bindings 

 Destination: 103.103.0.0/16

    Tailend Switch ATM3/0/0 2/34 Active -> Terminating Active

    Tailend Switch ATM3/0/3 2/34 Active -> Terminating Active

 Destination: 129.129.0.0/16

    Tailend Switch ATM3/0/0 2/35 Active -> Terminating Active

 Destination: 101.101.0.1/32

    Transit ATM3/0/3 2/33 Active -> ATM3/0/0 2/36 Active

 Destination: 104.104.0.1/32

    Transit ATM3/0/3 2/35 Active -> ATM3/0/0 2/37 Active

 Destination: 125.125.0.0/16

    Transit ATM3/0/3 2/36 Active -> ATM3/0/0 2/38 Active

 Destination: 128.128.0.0/16

    Tailend Switch ATM3/0/3 2/37 Active -> Terminating Active

 Destination: 102.102.0.1/32

    Transit ATM3/0/0 2/53 Active -> ATM3/0/3 2/33 Active

 Destination: 100.100.0.1/32

    Transit ATM3/0/0 2/54 Active -> ATM3/0/3 2/34 Active

 Destination: 123.123.0.0/16

    Transit ATM3/0/0 2/55 Active -> ATM3/0/3 2/35 Active

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10467