非同期転送モード(ATM) : LAN エミュレーション(LANE)

LAN エミュレーションの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この資料に Ciscoルータの LAN エミュレーション(LANE) サービスおよびクライアントを設定する方法を Catalyst スイッチ および ATM スイッチ説明されています。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10457/lane_config1.gif

そのセットアップ:

  • Router1 および Router2 Cisco 4500 ルータは Cisco IOS を実行していますか。 ソフトウェア リリース 12.1(4)。 両方とも LANエミュレーション クライアント(LEC)として機能します。

  • LightStream 1010 は Cisco IOS ソフトウェア リリース 12.0(10)W5(18b) を実行しています。 それは LANエミュレーション構成サーバ (LECS)として機能します。

  • イーサネット スイッチは slot4 の LANE ブレードが付いている Catalyst 5000 です。 この LANE ブレードは LEC と LANE ブロードキャスト アンノウン サーバ(LES/BUS)として機能します。

  • LANE サービスは LANE の 推奨設計に従って設定されました。

  • 2 エミュレートLAN (ELAN)は設定されました: テスト ELAN および test-elan2。

  • Router1 に各 ELAN で LEC があります。 イーサネット スイッチに test-elan2 で LEC があります。 Router2 におよび LightStream 1010 にテスト ELAN で LEC があります。

  • イーサネット スイッチで、バーチャルLAN は、VLAN2、test-elan2 に結合 されます。

  • Router1 は 2 ELAN 間のルーティングをすることを担当します。

これは論理的なセットアップです:

lane_config2.gif

設定

このドキュメントでは、次の設定を使用します。

注: LANE に関連している設定コマンドの部分だけ含まれています。

LightStream 1010

!--- Output suppressed.

atm lecs-address-default 47.0091.8100.0000.0060.705a.8f01.0060.705a.8f05.00

!

lane database test

  name test-elan server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.01
  name test-elan2 server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.02
!
interface atm2/0/0
 no ip address
 no ip directed-broadcast
 lane config auto-config-atm-address
 lane config database test
!
interface atm2/0/0.2 multipoint
 ip address 20.0.0.2 255.255.255.0
 no ip directed-broadcast
 lane client ethernet test-elan

!--- Output suppressed.

LANE データベース テストは各 ELAN のための LES/BUS のネットワーク サービス アクセス ポイント(NSAP)アドレスを定義します。 Ethernet スイッチ LANE Blade への LightStream 1010 設定ポイントのこれらのアドレス:

lane-blade# show lane default

interface atm0:
LANE Client:        47.0091810000000060705A8F01.00E0B00B7030.**
LANE Server:        47.0091810000000060705A8F01.00E0B00B7031.**
LANE Bus:           47.0091810000000060705A8F01.00E0B00B7032.**
LANE Config Server: 47.0091810000000060705A8F01.00E0B00B7033.00

注:  ** 16進フォーマットのサブインターフェイス バイト数を表します。

注: 特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

LANE データベースを定義したら、lane config database データベース名 コマンドを使用して LECS のメインインターフェイスでそれを加えて下さい。 これは LECS で設定される 3 つのコマンドの説明です:

  • atm lecs-address-default は nsap-address —定義しま当たる LECS NSAP 暫定ローカル管理インターフェイス(ILMI)によって接続装置へですとしてスイッチをアドバタイズする。 この場合、設定されるアドレスは LightStream 1010 の ATM0 インターフェイスに割り当てられる NSAP アドレスです。 このアドレスを得る show lane default コマンドを発行して下さい:

    LightStream 1010# show lane default
    
    interface ATM2/0/0:
    LANE Client:        47.0091810000000060705A8F01.0060705A8F02.**
    LANE Server:        47.0091810000000060705A8F01.0060705A8F03.**
    LANE Bus:           47.0091810000000060705A8F01.0060705A8F04.**
    LANE Config Server: 47.0091810000000060705A8F01.0060705A8F05.00
    

    注:  ** 16進フォーマットのサブインターフェイス バイト数を表します。

  • lane config auto-config-atm-address — LECS が実 NSAP アドレスになされるコールセットアップに応答するかどうか示します。

  • lane config database データベース名—定義します LANE データベースが LECS 使用する。

メインインターフェイスに上で設定を適用したら、LECS はアップし、アクティブになっています。

LECS ステータスのチェック

LECS ステータスをチェックする show lane config コマンドを発行して下さい:

LightStream 1010# show lane config

LE Config Server ATM2/0/0 config table: test
Admin: up State: operational
LECS Mastership State: active master
list of global LECS addresses (49 seconds to update):
47.0091810000000060705A8F01.0060705A8F05.00
ATM Address of this LECS: 47.0091810000000060705A8F01.0060705A8F05.00 (auto)
 vcd  rxCnt  txCnt  callingParty
  46      1      1  47.0091810000000060705A8F01.00E0B00B7031.01 LES test-elan 0 active
  62      1      1  47.0091810000000060705A8F01.00E0B00B7031.02 LES test-elan2 0 active
ATM Address of this LECS: 47.007900000000000000000000.00A03E000001.00 (well known)
cumulative total number of unrecognized packets received so far: 0
cumulative total number of config requests received so far: 608
cumulative total number of config failures so far: 601
    cause of last failure: no configuration
    culprit for the last failure: 47.009181000000FFFF705A8F01.0050E2030602.01
Router1

!--- Output suppressed.

interface ATM0

 no ip address
 pvc 0/5 qsaal
 !
 PVC 0/16 ilmi
 !
 no ATM ilmi-keepalive
!
interface ATM0.2 multipoint
 ip address 20.0.0.1 255.255.255.0
 lane client ethernet test-elan
!
interface ATM0.3 multipoint
 ip address 21.0.0.1 255.255.255.0
 lane client ethernet test-elan2
!
router rip
 network 20.0.0.0
 network 21.0.0.0

!--- Output suppressed.

LEC ステータスのチェック

LEC ステータスをチェックするこれらのコマンドを発行して下さい:

  • show lane client [インターフェイス ATM [.subinterface ]]

    router1# show lane client interface atm 0.2
    
    LE Client ATM0.2  ELAN name: test-elan  Admin: up  State: operational
    Client ID: 2                 LEC up for 18 hours 9 minutes 42 seconds
    ELAN ID: 0
    Join Attempt: 1
    Known LE Servers: 1
    HW Address: 0060.837b.b3a2   Type: ethernet             Max Frame Size: 1516
    ATM Address: 47.0091810000000060705A8F01.0060837BB3A2.02
     VCD  rxFrames  txFrames  Type       ATM Address
       0         0         0  configure  47.0091810000000060705A8F01.0060705A8F05.00
       5         1        47  direct     47.0091810000000060705A8F01.00E0B00B7031.01
       6       145         0  distribute 47.0091810000000060705A8F01.00E0B00B7031.01
       7         0      4567  send       47.0091810000000060705A8F01.00E0B00B7032.01
       8     10221         0  forward    47.0091810000000060705A8F01.00E0B00B7032.01
  • クライアントが ILMI によってきちんと NSAP アドレスを登録したかどうか show atm ilmi-status —確かめます。

    router1# show atm ilmi-status
    
    Interface : ATM0 Interface Type : Private UNI (User-side)
    ILMI VCC : (0, 16) ILMI Keepalive : Disabled
    ILMI State:       UpAndNormal
    Peer IP Addr:     10.200.10.47    Peer IF Name:     ATM0/0/0
    Peer MaxVPIbits:  8               Peer MaxVCIbits:  14
    Active Prefix(s) :
    47.0091.8100.0000.0060.705a.8f01
    End-System Registered Address(s) :
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.02(Confirmed)
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.03(Confirmed)

    show atm ilmi-status コマンドに関する詳細についてはこれらの文書を参照して下さい:

Router2

!--- Output suppressed.

interface ATM1

 no ip address
 PVC 0/16 ilmi
 !
 PVC 0/5 qsaal
 !
 no ATM ilmi-keepalive
!
interface ATM1.2 multipoint
 ip address 20.0.0.3 255.255.255.0
 lane client ethernet test-elan
!
router rip
 network 20.0.0.0

!--- Output suppressed.

Ethernet スイッチ LANE Blade

!--- Output suppressed.

interface ATM0

 ATM preferred phy A
 atm PVC 1 0 5 qsaal
 ATM PVC 2 0 16 ilmi
 no ATM ilmi-keepalive
!
interface ATM0.1 multipoint
 lane server-bus ethernet test-elan

!--- Configuration of the Bus.

!
interface ATM0.2 multipoint
 lane server-bus ethernet test-elan2
!
interface ATM0.3 multipoint
 lane client ethernet 2 test-elan2

!--- Output suppressed.

lane server-bus ethernet ELAN ネーム コマンドは ELAN によって指名される ELAN ネームのための LES/BUS でこのデバイスを設定したものです。

注: マルチポイント サブインターフェイス毎に 1 つの server-bus があるただ場合もあります。

追加コマンド

これらは LANE を設定するとき使用するいくつかの有用な コマンドです。 LANE を設定するためにこれらのコマンドを使用することは必要ではないです。

LECS上で

interface ATM2/0/0
  no ip address
  no ip directed-broadcast
  lane config fixed-config-atm-address
  lane config auto-config-atm-address
  lane config config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane config database test
  • LECS がよく知られたNSAPアドレスになされるコールセットアップに応答することを lane config fixed-config-atm-address —示します。 よく知られたNSAPアドレスは 47.007900000000000000000000.00A03E000001.00 です。

  • lane config config-atm-address は設定された NSAP アドレス 47.0091.8100.0000.0060.705a.8f01.0000.0000.0001.01 になされるコールセットアップに nsap —ことを LECS また返事示します。

LES上で

interface ATM0.1 multipoint
  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane bus-atm-address 47.0091810000000060705A8F01.000000000003.01
  lane server-bus ethernet test-elan
  • lane config-atm-address は ILMI から学習される LECS アドレスを使用するかわりに NSAP のアドレスと LECS に、接続するために nsap — LES/BUS を強制します。

  • lane server-atm-address NSAP およびレーン bus-atm-address は nsap — 静的にそれぞれ LES および BUS の NSAP アドレスを設定することを可能にします。

詳細については LES/LEC/BUS/LECS のための ATM アドレスをハードコードすることを参照して下さい。

LEC上で

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0
  lane fixed-config-atm-address
  lane client ethernet test-elan

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane client ethernet test-elan
  interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane client ethernet test-elan
  • lane fixed-config-atm-address — LEC を ILMI から学習される LECS NSAP アドレスを使用するかわりによく知られたNSAPアドレスを使用して LECS に、接続するために強制します。

  • lane config-atm-address は ILMI から学習される LECS アドレスを使用するかわりに NSAP のアドレスと LECS に、接続するために nsap — LEC を強制します。

  • lane server-atm-address は直接 LECS に最初に接続しないで NSAP のアドレスと LES に接続するために nsap — LEC を強制します。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10457