非同期転送モード(ATM) : ATM フレーム リレー間インターワーキング

ATM サービスインターワーキング (FRF.8) へのフレームリレーを使用するエンドツーエンド PVC の管理

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 2 月 14 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

FRF.8 実装 合意書では、ブロードバンド な フォーラムleavingcisco.com (以前フレームリレーフォーラム)はフレームリレー エンドポイントおよび 2 つのレイヤ2 プロトコルを相互に作用するか、または接続するルータを通した ATMエンドポイントまたはスイッチ間の通信を定義します。 この文書では、FRF.8 サービス インターワーキング(IWF)接続での Permanent Virtual Circuit(PVC; 相手先固定回線)の管理手順を説明します。また、ルータおよびスイッチを使用した設定例を示します。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

FRF.8 PVC 管理手順

FRF.8 のセクション 5.2 では、ATM とフレームリレー PVC の管理手順を説明します。 ATM 側の手順では、F5 Operations, Administration, and Maintenance(OAM; 操作、管理およびメンテナンス)セルおよび Interim Local Management Interface(ILMI; 暫定ローカル管理インターフェイス)Management Information Base(MIB; 管理情報ベース)の変数を使用します。 次に、ATM のステータス情報はインターワーキング デバイスによって、対応するフレームリレー ステータス インジケータにマッピングされます。

フレームリレー側は、ステータス情報の通信に Local Management Interface(LMI; ローカル管理インターフェイス)プロトコルを使用します。 規格では、フレームリレーのヘッダーの 2 バイトには、エンドポイントへの Virtual Circuit(VC; 仮想回線)のステータスを示すフィールドは含まれません。 このため LMI プロトコルは、Permanent Virtual Circuit(PVC; 相手先固定回線)が追加、削除または変更されたときにエンドポイントに通知するメカニズムによってフレームリレーを強化します。 また、リンクが依然として有効かどうかを検証するポーリング メカニズムも提供されます。 LMI プロトコルは、データ トラフィックに使用される Data Link Connection Identifier(DLCI; データリンク接続識別子)とは別の DLCI を使用して、LMI フレームを送信します。

LMI フレームのメッセージ タイプ フィールドの 8 ビットは、ステータス問い合せとステータス メッセージで構成されます。 数秒ごとに、フレームリレー エンドポイント(ユーザ)はネットワークにステータス問い合せメッセージを送信 します; このメッセージはリンク完全性を検証します。 ネットワークからは、要求された情報を含んだステータス メッセージが返されます。 定義された数のステータス問い合せが終ると、フレームリレー エンドポイントから、いわゆる完全ステータス応答が要求されます。 ネットワークからは、そのリンク上に構成されたすべての PVC に関する Information Element(IE; 情報要素)が含まれるステータス メッセージが返されます。

PVC ステータス IE は 5 バイトです。 PVC の DLCI に加えて、IE には次に示す 2 つの重要なステータス ビットが含まれます。

  • 新規ビット:PVC がスイッチに追加されると、ネットワークによって設定されます。 フレームリレー エンドポイント(ユーザ)から、ネットワークの現在の送信シーケンス番号と同じ受信シーケンス番号が含まれるメッセージを受信するまで、完全なステータス メッセージの IE にはネットワークによって新規ビットが設定され続けます。

  • アクティブ ビット:宛先までのパスがすべて存在することが確認され、エンドツーエンドの PVC が完全に確立されると設定されます。

フレームリレーのステータス メカニズムは、リアルタイムのプロセスではなく、スケジュールされたステータス メッセージが送信されるのを待つ必要があることに注意してください。 ネットワーク内で PVC の使用が可能になった後、アクティブ ビットに 1 が設定された完全なステータス メッセージが、2 つのエンドポイントで別々の時刻に受信されると、タイミングの問題が発生することがあります。 一方のエンドポイントでアクティブ ステータス メッセージが受信される前に、他方のエンドポイントからのデータ フレームが PVC を介して送られることがあります。

この弱点を克服するために、LMI プロトコルは非同期のステータス レポート タイプの IE を使用します。 非同期メッセージは、ステータスとステータス問い合せメッセージで構成されます。ステータス問い合せメッセージは、PVC のステータスが変更されるとすぐに、メッセージ タイマーが無効になるのを待たずに送信されます。 非同期ステータス メッセージの手順は、インターワーキングを実行するシスコのルータではサポートされません。

フレームリレー側では、ステータス ビットに基づいて、PVC に 4 つのうち 1 つのステータス値が割り当てられます。 IWF を実行するスイッチまたはシスコのルータは、一連の基準に従って、VC に割り当てるステータスを判断します。

ステータス インジケータとマッチングの基準
Added(追加) フレームリレー ネットワークは、IWF にレポートされる完全なステータス レポートに新規ビットを設定します。
Deleted(削除) IWF は、このステータスを、完全なステータス レポートによってフレームリレー ネットワークにレポートします。
非アクティブ IWF は、次の基準によって非アクティブ ステータスを判断します。
  • Alarm Indication Signal(AIS; アラーム表示信号)または Remote Defect Indicator(RDI; リモート障害表示)OAM F5 セルが、エンドツーエンド パスのどこかで ATM PVC がダウンしていることをはっきりと示す。
  • ILMI MIB は、変数 atmfVccOperStatus で localDown または end2EndDown をレポートする。
IWF は、アクティブ ビットに 0 が設定された完全なステータス レポートを送信します。
Active(アクティブ) IWF は、次の基準によってアクティブ ステータスを判断します。
  • OAM の仕様、IYU-I.610 に定義されたインターバルの間、ATM ネットワークから AIS OAM セルおよび RDI OAM セルを受信しない。
  • ILMI MIB は、変数 atmfVccOperStatus で localDown または end2EndDown をレポートしない。
両方の基準(両方を使用している場合)が満たされ、ATM 側の物理的なアラームが IWF によって検出されない場合、IWF ではフレームリレー側の VC をアクティブ ステータスにします。 IWF は、アクティブ ビットに 1 が設定された完全なステータス レポートを、フレームリレー ネットワークに送信します。

IWF スイッチとしてCatalyst 8540 MSR を使用する例

次に、Catalyst 8540 MSR を IFW スイッチとして使用した例を示します。

ネットワーク図

次にトポロジを示します。

/image/gif/paws/10440/frf8_pvc_manage1.gif

ATM ルータは VIP2-50 および runnning 12.1(13)E の PA-A3-OC3MM を使用して 7500 ルータです。 FR ルータは 12.1(17) を実行する 7200 ルータです。 ATM/FR-IWF-switch は、12.1(12c)EY を実行する Catalyst 8540MSR です。

設定

FR-router
controller E1 4/0
 channel-group 0 timeslots 1-31
!         
interface Serial4/0:0
 ip address 12.12.12.2 255.255.255.0
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay map ip 12.12.12.1 123 broadcast

ATM-FR/IWF-switch
controller E1 10/0/0
 channel-group 1  timeslots 1-31
!
interface Serial10/0/0:1
 no ip address
 encapsulation frame-relay IETF
 no arp frame-relay
 frame-relay intf-type dce
 frame-relay pvc 123 service translation  interface  ATM9/1/2 0 123 
 atm oam interface  ATM9/1/2 0 123

ATM-router
interface ATM2/1/0.1 point-to-point
 ip address 12.12.12.1 255.255.255.0
 pvc 0/123 
  oam-pvc manage
  encapsulation aal5snap 

show コマンド

ATM-router#show atm pvc 0/123
ATM2/1/0.1: VCD: 2, VPI: 0, VCI: 123
UBR, PeakRate: 149760
AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0
OAM frequency: 10 second(s), OAM retry frequency: 1 second(s), OAM retry frequen
cy: 1 second(s)
OAM up retry count: 3, OAM down retry count: 5
OAM Loopback status: OAM Received
OAM VC state: Verified
ILMI VC state: Not Managed
VC is managed by OAM.
InARP frequency: 15 minutes(s)
Transmit priority 4
InPkts: 5, OutPkts: 8, InBytes: 540, OutBytes: 624
InPRoc: 5, OutPRoc: 5
InFast: 0, OutFast: 0, InAS: 0, OutAS: 3
InPktDrops: 0, OutPktDrops: 0
CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0
OAM cells received: 124713
F5 InEndloop: 74872, F5 InSegloop: 49841, F5 InAIS: 0, F5 InRDI: 0
F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
OAM cells sent: 124756
F5 OutEndloop: 74915, F5 OutSegloop: 49841, F5 OutRDI: 0
F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
OAM cell drops: 0
Status: UP

FR-router#show frame-relay pvc

PVC Statistics for interface Serial4/0:0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial4/0:0

  input pkts 8             output pkts 5            in bytes 1633      
  out bytes 520            dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 0          out bcast bytes 0         
  pvc create time 00:02:44, last time pvc status changed 00:02:44

ATM-FR/IWF-switch#show frame-relay pvc 

PVC Statistics for interface Serial10/0/0:1 (Frame Relay DCE)

              Active     Inactive      Deleted       Static
  Local          0            0            0            0
  Switched       1            0            0            0
  Unused         0            0            0            0

DLCI = 123, DLCI USAGE = SWITCHED, PVC STATUS = ACTIVE, INTERFACE = Serial10/0/0:1

  input pkts 5             output pkts 6            in bytes 520       
  out bytes 550            dropped pkts 0           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 4151       out bcast bytes 1494481      Num Pkts Switched 0         
  pvc create time 2d21h, last time pvc status changed 2d21h

ATM-FR/IWF-switch#show atm vc interface atm 9/1/2 0 123

Interface: ATM9/1/2, Type: oc3suni 
VPI = 0  VCI = 123
Status: UP
Time-since-last-status-change: 2d21h
Connection-type: PVC 
Cast-type: point-to-point
Packet-discard-option: disabled
Usage-Parameter-Control (UPC): pass
Wrr weight: 2
Number of OAM-configured connections: 32
OAM-configuration: Seg-loopback-on End-to-end-loopback-on Ais-on Rdi-on
OAM-states:  OAM-Up
OAM-Loopback-Tx-Interval: 5
Cross-connect-interface: ATM-P10/0/0, Type: ATM-PSEUDO 
Cross-connect-VPI = 1 
Cross-connect-VCI = 155
Cross-connect-UPC: pass
Cross-connect OAM-configuration: Ais-on
Cross-connect OAM-state:  OAM-Up
OAM-Loopback-Tx-Interval: 5
Threshold Group: 3, Cells queued: 0
Rx cells: 16, Tx cells: 15
Tx Clp0:15,  Tx Clp1: 0
Rx Clp0:16,  Rx Clp1: 0
Rx Upc Violations:9, Rx cell drops:0
Rx Clp0 q full drops:0, Rx Clp1 qthresh drops:0
Rx connection-traffic-table-index: 100
Rx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
Rx pcr-clp01: 81
Rx scr-clp0 : 81
Rx mcr-clp01: none
Rx      cdvt: 1024 (from default for interface)
Rx       mbs: 50
Tx connection-traffic-table-index: 100
Tx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
Tx pcr-clp01: 81
Tx scr-clp0 : 81
Tx mcr-clp01: none
Tx      cdvt: none
Tx       mbs: 50

シナリオ 1

上記で紹介した設定を使用して、両方のルータがネットワークの障害にどのように対処するかを説明します。 最初のシナリオでは、ATM-router の ATM インターフェイスをシャット ダウンし、この障害が FR-router PVC に与える影響を見てみます。

  1. ATM-router の ATM サブインターフェイスをシャットダウンします。

       ATM-router#config terminal
       Enter configuration commands, one per line.? End with CNTL/Z.
       ATM-router(config)#interface atm 2/1/0.1
       ATM-router(config-subif)#shut
  2. ATM-FR/IWF-switch で PVC ステータスを確認します。

    ATM-FR/IWF-switch#show atm vc interface atm 9/1/2 0 123
    
    Interface: ATM9/1/2, Type: oc3suni 
    VPI = 0  VCI = 123
    Status: UP
    Time-since-last-status-change: 00:00:44
    Connection-type: PVC 
    Cast-type: point-to-point
    Packet-discard-option: disabled
    Usage-Parameter-Control (UPC): pass
    Wrr weight: 2
    Number of OAM-configured connections: 32
    OAM-configuration: Seg-loopback-on End-to-end-loopback-on Ais-on Rdi-on
    OAM-states:  OAM-Up Segment-loopback-failed End-to-end-loopback-failed
    OAM-Loopback-Tx-Interval: 5
    Cross-connect-interface: ATM-P10/0/0, Type: ATM-PSEUDO 
    Cross-connect-VPI = 1 
    Cross-connect-VCI = 155
    Cross-connect-UPC: pass
    Cross-connect OAM-configuration: Ais-on
    Cross-connect OAM-state:  OAM-Up
    OAM-Loopback-Tx-Interval: 5
    Threshold Group: 3, Cells queued: 0
    Rx cells: 1, Tx cells: 0
    Tx Clp0:0,  Tx Clp1: 0
    Rx Clp0:1,  Rx Clp1: 0
    Rx Upc Violations:0, Rx cell drops:0
    Rx Clp0 q full drops:0, Rx Clp1 qthresh drops:0
    Rx connection-traffic-table-index: 100
    Rx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Rx pcr-clp01: 81
    Rx scr-clp0 : 81
    Rx mcr-clp01: none
    Rx      cdvt: 1024 (from default for interface)
    Rx       mbs: 50
    Tx connection-traffic-table-index: 100
    Tx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Tx pcr-clp01: 81
    Tx scr-clp0 : 81
    Tx mcr-clp01: none
    Tx      cdvt: none
    Tx       mbs: 50
  3. FR-router で PVC ステータスを確認します。

    FR-router#show frame-relay pvc
    
    PVC Statistics for interface Serial4/0:0 (Frame Relay DTE)
    
                  Active     Inactive      Deleted       Static
      Local          0            1            0            0
      Switched       0            0            0            0
      Unused         0            0            0            0
    
    DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial4/0:0
    
      input pkts 18            output pkts 5            in bytes 4320      
      out bytes 520            dropped pkts 5           in FECN pkts 0         
      in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
      in DE pkts 0             out DE pkts 0         
      out bcast pkts 0          out bcast bytes 0         
      pvc create time 00:15:21, last time pvc status changed 00:03:50

上記の出力結果から、ATM 側の障害が FR 側にも影響していることがわかります。 実際に、FR の PVC が INACTIVE(非アクティブ)状態になります。

シナリオ 2

次に、FR クラウドに障害が発生したとき、ATM 側に何が起こるかを見てみましょう。 このような障害のシミュレーションを行うには、FR-router のシリアル インターフェイスをシャット ダウンして、ATM-router がどのように対処するかを見てみます。

  1. FR-router のシリアル インターフェイスをシャット ダウンして、ATM-router がどのように対処するかを見てみます。

       FR-router#config terminal
       Enter configuration commands, one per line.? End with CNTL/Z.
       FR-router(config)#int serial 4/0:0
       FR-router(config-if)#shut
  2. ATM-router では、debug atm oam が有効です。 障害が検出されることで、ATM-FR/IWF-switch が ATM ルータに AIS 信号を送信していることがわかります。

       3d12h: atm_oam_ais(ATM2/1/0): AIS signal, failure=0x6A, VC 0/123
       3d12h: atm_oam_setstate - VCD#3, VC 0/123: newstate = AIS/RDI
       3d12h: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM2/1/0.1, changed state    to down
       3d12h: atm_oam_ais_inline(ATM2/1/0): AIS signal, failure=0x6A, VC 0/123

    ATM-router で PVC ステータスを確認すると、PVC がダウンしていることがわかります。

    ATM-router#show atm pvc 0/123
    ATM2/1/0.1: VCD: 3, VPI: 0, VCI: 123
    UBR, PeakRate: 149760
    AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0
    OAM frequency: 10 second(s), OAM retry frequency: 1 second(s), OAM retry frequency: 1 second(s)
    OAM up retry count: 3, OAM down retry count: 5
    OAM Loopback status: OAM Received
    OAM VC state: AIS/RDI
    ILMI VC state: Not Managed
    VC is managed by OAM.
    InARP frequency: 15 minutes(s)
    Transmit priority 4
    InPkts: 0, OutPkts: 4, InBytes: 0, OutBytes: 112
    InPRoc: 0, OutPRoc: 0
    InFast: 0, OutFast: 0, InAS: 0, OutAS: 4
    InPktDrops: 0, OutPktDrops: 0
    CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0
    OAM cells received: 304
    F5 InEndloop: 114, F5 InSegloop: 69, F5 InAIS: 121, F5 InRDI: 0
    F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0
    OAM cells sent: 310
    F5 OutEndloop: 120, F5 OutSegloop: 69, F5 OutRDI: 121
    F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0
    OAM cell drops: 0
    Status: DOWN, State: NOT_VERIFIED
  3. ATM-FR/IWF-switch でステータスを確認します。

    ATM-FR/IWF-switch#show atm vc interface atm 9/1/2 0 123
    
    Interface: ATM9/1/2, Type: oc3suni 
    VPI = 0  VCI = 123
    Status: DOWN
    Time-since-last-status-change: 00:03:04
    Connection-type: PVC 
    Cast-type: point-to-point
    Packet-discard-option: disabled
    Usage-Parameter-Control (UPC): pass
    Wrr weight: 2
    Number of OAM-configured connections: 32
    OAM-configuration: Seg-loopback-on End-to-end-loopback-on Ais-on Rdi-on
    OAM-states:  OAM-Up
    OAM-Loopback-Tx-Interval: 5
    Cross-connect-interface: ATM-P10/0/0, Type: ATM-PSEUDO 
    Cross-connect-VPI = 1 
    Cross-connect-VCI = 155
    Cross-connect-UPC: pass
    Cross-connect OAM-configuration: Ais-on
    Cross-connect OAM-state:  OAM-Down
    OAM-Loopback-Tx-Interval: 5
    Threshold Group: 3, Cells queued: 0
    Rx cells: 3, Tx cells: 0
    Tx Clp0:0,  Tx Clp1: 0
    Rx Clp0:3,  Rx Clp1: 0
    Rx Upc Violations:0, Rx cell drops:0
    Rx Clp0 q full drops:0, Rx Clp1 qthresh drops:0
    Rx connection-traffic-table-index: 100
    Rx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Rx pcr-clp01: 81
    Rx scr-clp0 : 81
    Rx mcr-clp01: none
    Rx      cdvt: 1024 (from default for interface)
    Rx       mbs: 50
    Tx connection-traffic-table-index: 100
    Tx service-category: VBR-NRT (Non-Realtime Variable Bit Rate)
    Tx pcr-clp01: 81
    Tx scr-clp0 : 81
    Tx mcr-clp01: none
    Tx      cdvt: none
    Tx       mbs: 50

つまり、OAM の働きにより、ATM ルータは対応する ATM PVC をダウンさせることで、FR クラウドで発生した障害に対処します。

既知の警告

  • CSCdu78168 (CSCdt04356 の重複): ATM IWF への FR では、OAM 管理は MSR で動作しません。

Cisco 7200 ルータを IWF として使用した例

ネットワーク図

frf8_pvc_manage2.gif

設定

3620
interface Serial1/0 
 ip address 10.10.10.1 255.255.255.0 
 encapsulation frame-relay IETF 
 frame-relay interface-dlci 50 
 frame-relay lmi-type ansi

7206
frame-relay switching 
! 
interface Serial4/3 
 no ip address 
 encapsulation frame-relay IETF 
 frame-relay interface-dlci 50 switched 
 frame-relay lmi-type ansi 
 frame-relay intf-type dce 
 clockrate 115200 
! 
interface ATM5/0 
 no ip address 
 atm clock INTERNAL 
 no atm ilmi-keepalive 
 pvc 5/50 
  vbr-nrt 100 75 
  oam-pvc manage 
  encapsulation aal5mux fr-atm-srv 
! 
connect SIVA Serial4/3 50 ATM5/0 5/50 service-interworking

7500
interface atm 4/0/0.50 multi 
 ip address 10.10.10.2 255.255.255.0 
 pvc 5/50 
  vbr-nrt 100 75 30 
  protocol ip 10.10.10.1

シナリオ 1

次のシナリオでは、ATM エンドポイントと ATM インターフェイスが、IWF 上で oam-pvc manage コマンドによって設定されているものとします。 ATM エンドポイントから、PVC 設定文を削除します。 ATM PVC がダウンすると、フレームリレー PVC は非アクティブ ステータスに変わります。

  1. debug atm oam をイネーブルにし、カウンタをクリアします。

    1d09h: ATM OAM(ATM4/0/0.50): Timer: VCD#5 VC 5/50 Status:2 CTag:8586 Tries:0 
    1d09h: ATM OAM LOOP(ATM4/0/0.50) O: VCD#5 VC 5/50 CTag:218B 
    1d09h: ATM OAM LOOP(ATM4/0/0) I: VCD#5 VC 5/50 LoopInd:0 CTag:218B    
    1d09h: ATM OAM LOOP(ATM4/0/0) I: VCD#5 VC 5/50 LoopInd:1 CTag:4850    
    1d09h: ATM OAM LOOP(ATM4/0/0.50) O: VCD#5 VC 5/50 CTag:4850
    
  2. 新形式の pvc コマンド「no」形式を使用して、ATM エンドポイントから PVC を削除します。

    7500#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    7500(config)#interface atm 4/0/0.50
    7500(config-subif)#no pvc 5/50
    
  3. show atm vc コマンドを実行して、IWF 7200 での VC のステータスが「DOWN」であることを確認します。

    7200#show atm vc 
                  VCD /                                Peak Avg/Min Burst 
       Interface  Name  VPI   VCI   Type  Encaps   SC  Kbps Kbps    Cells   Sts 
       5/0.200    test   2    20    PVC   SNAP     UBR 149760                UP 
       5/0.100     2     3    300   PVC   SNAP     UBR 149760                UP 
       5/0         1     5    50    PVC   FRATMSRV VBR 100     75     95    DOWN
    
  4. show atm pvc {vpi/vci} コマンドを実行し、OAM VC 状態を確認して下さい: 「Not Verified」

    7200#show atm pvc 5/50 
       ATM5/0: VCD: 1, VPI: 5, VCI: 50 
       VBR-NRT, PeakRate: 100, Average Rate: 75, Burst Cells: 95 
       AAL5-FRATMSRV, etype:0x15, Flags: 0x23, VCmode: 0x0 
       OAM frequency: 10 second(s), OAM retry frequency: 1 second(s),    OAM retry frequency: 1 second(s) 
       OAM up retry count: 3, OAM down retry count: 5 
       OAM Loopback status: OAM Sent 
       OAM VC state: Not Verified 
       ILMI VC state: Not Managed 
       VC is managed by OAM. 
       InARP DISABLED 
       Transmit priority 2 
       InPkts: 0, OutPkts: 0, InBytes: 0, OutBytes: 0 
       InPRoc: 0, OutPRoc: 0, Broadcasts: 0 
       InFast: 0, OutFast: 0, InAS: 0, OutAS: 0 
       InPktDrops: 0, OutPktDrops: 0 
       CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0 
       Out CLP=1 Pkts: 0 
       OAM cells received: 19 
       F5 InEndloop: 19, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0    
       F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0 
       OAM cells sent: 82 
       F5 OutEndloop: 82, F5 OutSegloop: 0, F5 OutRDI: 0 
       F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0 
       OAM cell drops: 0 
       Status: DOWN, State: NOT_VERIFIED
    
  5. フレームリレー エンドポイントで をイネーブルにします。 ユーザとフレームリレー接続のネットワーク エンドの間で、ステータスおよびステータス問い合せ(StEnq)メッセージが交換されるようすを観察します。 VC のステータスが 0x2(アクティブ)から 0x0(非アクティブ)に変わることを確認します。

    *Apr 7 01:53:18.407: Serial1/0(in): Status, myseq 69    
       *Apr 7 01:53:18.407: RT IE 1, length 1, type 0 
       *Apr 7 01:53:18.407: KA IE 3, length 2, yourseq 67, myseq 69    
       *Apr 7 01:53:18.407: PVC IE 0x7 , length 0x3 , dlci 50, status 0x2 
       
    ! -- A value of 0x2 indicates active status.
        
       *Apr 7 01:53:28.403: Serial1/0(out): StEnq, myseq 70, yourseen 67, DTE up 
       *Apr 7 01:53:28.403: datagramstart = 0x3D53954, datagramsize = 14    
       *Apr 7 01:53:28.403: FR encap = 0x00010308 
       *Apr 7 01:53:28.403: 00 75 95 01 01 01 03 02 46 43 
       *Apr 7 01:53:28.403: 
       *Apr 7 01:53:28.407: Serial1/0(in): Status, myseq 70 
       *Apr 7 01:53:28.407: RT IE 1, length 1, type 1 
       *Apr 7 01:53:28.407: KA IE 3, length 2, yourseq 68, myseq 70    
       *Apr 7 01:53:38.403: Serial1/0(out): StEnq, myseq 71, yourseen 68, DTE up 
       *Apr 7 01:53:38.403: datagramstart = 0x3D53954, datagramsize = 14    
       *Apr 7 01:53:38.403: FR encap = 0x00010308 
       *Apr 7 01:53:38.403: 00 75 95 01 01 01 03 02 47 44 
       *Apr 7 01:53:38.403: 
       *Apr 7 01:53:38.407: Serial1/0(in): Status, myseq 71 
       *Apr 7 01:53:38.407: RT IE 1, length 1, type 0 
       *Apr 7 01:53:38.407: KA IE 3, length 2, yourseq 69, myseq 71    
       *Apr 7 01:53:38.407: PVC IE 0x7 , length 0x3 , dlci 50, status 0x0 
       
    ! -- A value of 0x0 indicates inactive status. 
    
    

    次に、このステータス フィールドに表示される値について説明します。

    • 0x0:追加され、非アクティブの状態です。 スイッチには DLCI がプログラムされていますが、使用できません。 もう一方の端の PVC がダウンしている可能性があります。

    • 0x2:追加され、アクティブの状態です。 スイッチには DLCI がプログラムされており、PVC は操作可能です。

    • 0x3:アクティブ ステータス(0x2)と、(0x1)に設定された Receiver Not Ready(RNR)(または r-bit)を兼ねた状態です。 0x3 の値は、スイッチまたはスイッチにあるこの PVC 用の特定のキューがバックアップされたため、フレームリレー インターフェイスではフレームが失われるのを避けるために送信が停止されたことを意味します。

    • 0x4:削除されました。 スイッチには DLCI がプログラムされていませんが、以前はプログラムされていました。 削除ステータスは、ルータ上で DLCI が反転した場合、またはフレームリレー クラウド内で PVC が電話会社によって削除された場合に、交互に発生することがあります。 フレームリレー エンドポイントに DLCI を設定し、スイッチの値を一致させなかった場合は、VC のステータス値が 0x4 になります。

  6. 実稼動ルータで debug frame-relay packet を実行できない場合は、単に show frame pvc を実行してフレームリレー エンドポイントに最低 1 つのローカル PVC がリストされることを確認します。

    3620#show frame pvc    
    PVC Statistics for interface Serial1/0 (Frame Relay DTE)    
                      Active     Inactive     Deleted     Static 
          Local         0           1            0           0      
          Switched      0           0            0           0 
          Unused        0           0            0           0    
    DLCI = 50, DLCI USAGE = LOCAL, PVC STATUS = INACTIVE, INTERFACE = Serial1/0    
          input pkts 0             output pkts 0            in bytes 0 
          out bytes 0              dropped pkts 0           in FECN pkts 0 
          in BECN pkts 0           out FECN pkts 0 out      BECN pkts 0 
          in DE pkts 0             out DE pkts 0 
          out bcast pkts 0         out bcast bytes 0 
          pvc create time 3d04h, last time pvc status changed 00:05:04      

シナリオ 2

次のシナリオは IWF 7200 から oam-pvc manage コマンドを単に削除すると仮定します。 ATM VC は「UP」の状態のまま、フレームリレー側でもアクティブ状態のまま変わりません。

  1. IWF 7200 の ATM インターフェイスで oam-pvc manage コマンドを削除します。

       7200(config)#int atm 5/0 
       7200(config-if)#pvc 5/50 
       7200(config-if-atm-vc)#no oam-pvc manage 
       7200(config-if-atm-vc)#end 
       7200#show atm vc 
       *May 31 01:20:01.499: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM5/0,    changed state to up 
                 VCD /                                    Peak   Avg/Min Burst 
       Interface Name   VPI   VCI   Type   Encaps   SC    Kbps   Kbps    Cells   Sts 
       5/0.100     2     3     300  PVC    SNAP      UBR  149760                  UP 
       5/0         1     5     50   PVC    FRATMSRV  VBR  100     75       95     UP
  2. pvc コマンドの「no」形式を使用して、ATM エンドポイントの PVC を削除します。

    7500(config)#int atm 4/0/0.50 
       7500(config-subif)#no pvc 5/50 
       7500(config-subif)#end
    
  3. show atm pvc vpi/vci コマンドを使用して、ATM 側のステータスが「UP」のまま変わらないことを確認します。

    7200-2.4#show atm pvc 5/50 
       ATM5/0: VCD: 1, VPI: 5, VCI: 50 
       VBR-NRT, PeakRate: 100, Average Rate: 75, Burst Cells: 95 
       AAL5-FRATMSRV, etype:0x15, Flags: 0x23, VCmode: 0x0 
       OAM frequency: 0 second(s), OAM retry frequency: 1 second(s),    OAM retry frequency: 1 second(s) 
       OAM up retry count: 3, OAM down retry count: 5 
       OAM Loopback status: OAM Disabled 
       OAM VC state: Not Managed 
       ILMI VC state: Not Managed 
       InARP DISABLED 
       Transmit priority 2 
       InPkts: 15, OutPkts: 19, InBytes: 1680, OutBytes: 1332 
       InPRoc: 0, OutPRoc: 0, Broadcasts: 0 
       InFast: 15, OutFast: 19, InAS: 0, OutAS: 0 
       InPktDrops: 0, OutPktDrops: 0 
       CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0 
       Out CLP=1 Pkts: 0 
       OAM cells received: 157 
       F5 InEndloop: 157, F5 InSegloop: 0, F5 InAIS: 0, F5 InRDI: 0 
       F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0 
       OAM cells sent: 214 
       F5 OutEndloop: 214, F5 OutSegloop: 0, F5 OutRDI: 0 
       F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0 
       OAM cell drops: 0 
       Status: UP
    
  4. フレームリレー側の PVC のステータスもアクティブのまま変わりません。

     *Apr 7 02:25:08.407: Serial1/0(in): Status, myseq 5    
       *Apr 7 02:25:08.407: RT IE 1, length 1, type 0 
       *Apr 7 02:25:08.407: KA IE 3, length 2, yourseq 3 , myseq 5 
       *Apr 7 02:25:08.407: PVC IE 0x7 , length 0x3 , dlci 50, status 0x2 
       
    ! -- The Frame Relay PVC retains an active status (0x2). 
    
       *Apr 7 02:25:18.403: Serial1/0(out): StEnq, myseq 6, yourseen 3, DTE up 
       *Apr 7 02:25:18.403: datagramstart = 0x3D53094, datagramsize = 14    
       *Apr 7 02:25:18.403: FR encap = 0x00010308 
       *Apr 7 02:25:18.403: 00 75 95 01 01 00 03 02 06 03
  5. show frame pvc コマンドを使用して、フレームリレー エンドポイントの PVC のアクティブ ステータスを確認します。

    3620#show frame pvc
    PVC Statistics for interface Serial1/0 (Frame Relay DTE)    
                   Active Inactive Deleted Static 
          Local      1      0       0        0      
          Switched   0      0       0        0 
          Unused     0      0       0        0    
    DLCI = 50, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0    
          input pkts 0        output pkts 0         in bytes 0 
          out bytes 0         dropped pkts 0        in FECN pkts 0 
          in BECN pkts 0      out FECN pkts 0 out   BECN pkts 0 
          in DE pkts 0        out DE pkts 0 
          out bcast pkts 0    out bcast bytes 0 
          pvc create time 3d04h, last time pvc status changed 00:02:45

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 10440