非同期転送モード(ATM) : 回線エミュレーション サービス(CES)

適応クロッキングとソフト PVC による T1 の非構造化 CES

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、適応クロッキングを使用した T1 非構造化回線エミュレーション サービス(CES)の設定例を紹介します。 非構造化サービスとは、PVC がすべての T1/E1 帯域幅を使用することを意味します。 ATM スイッチでは T1/E1 の内部までは確認されず、単に受信ポートから宛先ポートへのクロッキングでビット ストリームが再作成されるだけです。 適応クロッキングとは、平均受信データ レートの計算によって CES モジュールがデータ転送に適切なタイミングを推測することを意味します。 これによる主な利点は、ネットワーク クロックの同期が不要であることです。 CES サービスの詳細については、『An Introduction to Circuit Emulation Services』を参照してください。

前提条件

この資料の設定 例は次の想定に基づいています:

  • この例はアダプティブ クロッキング モードを使用します。 アダプティブ クロッキングを使用しているので、network-clock-selectステートメントを必要としません。 ただし、バッファオーバーフローおよびアンダーフローおよび、同時に、制御遅延を防ぐためにバッファ長を設定することを選択することができます(すばらしいバッファサイズはより大きい遅延を意味します)。 バッファ長は CES 回線 circuit id [cas] [CDV max-req]設定できる最大セル遅延変動許容量(CDV)に比例しています、コマンド。 デフォルト値は 2000 ミリ秒です。 測定値は show ces circuit コマンドの出力で表示する。

  • 両方の PBX でのフレーミング形式は、拡張スーパーフレーム(ESF)です。 LS1010 ではこれがデフォルトなので、明示的に設定される必要はありません。 ただし、デモのためにこの例でそれを設定します。

  • 両方の PBX での回線コードは Binary 8-zero Substitution(B8ZS)です。 LS1010 ではこれがデフォルトなので、明示的に設定される必要はありません。 ただし、デモのためにこの例でそれを設定します。

  • LS1010 はソフトPVC のアクティブ な 側面です; 8540 MSR は受動側です。

  • PBX と ATM スイッチ間の距離は CES PAM の 110 フィートより小さいです。 この長さはデフォルト回線 構築(lbo)です従って明示的に設定される必要はありません。 ただし、デモのためにこの例でそれを設定します。

  • LS1010 は並べるロックし、クロック ソース選択されるトラッキングすることができる Phase Lock Loop (PLL)を使用するフィーチャ カード フロー単位が(FC-PFQ)装備されています。 この良質はネットワーククロックインターフェイスに、ロックされた クロックそれからインターフェイス タイミングを提供するために入れられます。 8540 MSR には Network Clock Module(NetClkMod)が装備されており、これにより、Stratum 3 クロック ソースの付加的な長所が提供されます。

  • 回線が定義されると、ATM 擬似インターフェイス(ATM-Px/y/z)が作成されます。 回線エミュレーション サービスを詳細については設定する資料を参照して下さい。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/asynchronous-transfer-mode-atm/circuit-emulation-services-ces/10428-cessample4-1.gif

設定

このドキュメントでは次に示す設定を使用しています。

8540-MSR
8540-MSR#show running-config

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname 8540-MSR
!
boot system flash bootflash:cat8540m-wp-mz.120-1a.W5.7.bin
logging buffered 4096 debugging
!
redundancy
 main-cpu
  no sync config startup
  sync config running
facility-alarm core-temperature major 53
facility-alarm core-temperature minor 45
network-clock-select 1 system
ip subnet-zero
atm address 47.0091.8100.0000.0090.2144.8401.0090.2144.8401.00
atm router pnni
 no aesa embedded-number left-justified
 node 1 level 56 lowest
  redistribute atm-static
!
interface ATM3/0/0
 no ip address
 no ip directed-broadcast
!
interface ATM3/0/1
 no ip address no
 ip directed-broadcast
!

interface CBR3/1/0
 no ip address no 
 ip directed-broadcast
 ces aal1 clock adaptive
 ces circuit 0 circuit-name example
 ces dsx1 linecode b8zs
 ces dsx1 framing esf
 ces dsx1 lbo 0_110
!
interface ATM0
 no ip address
 no ip directed-broadcast
 atm maxvp-number 0
!
interface Ethernet0
 no ip directed-broadcast
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end

ソフトPVC (この例の LS1010)のアクティブ な 側面を設定することを必要とする VPI/VCI ペアおよびアドレスを得るのにソフトPVC の受動側の show ces address を使用して下さい。 下記のように出力例を参照して下さい:

8540-MSR#show ces address
 
CES-IWF ATM Address(es):47.0091.8100.0000.0090.2144.8401.4000.0c81.9030.10 CBR3/1/0:0 
vpi 0 vci 16
LS1010-A
ls1010#show running-config

Building configuration...

Current configuration:
!
version 11.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname ls1010
!
atm address 47.0091.8100.0000.0090.92b8.6401.0090.92b8.6401.00
atm router pnni
?no aesa embedded-number left-justified
?node 1 level 56 lowest
? redistribute atm-static
!
no ip address
!
interface CBR12/1/0
?no ip address
?ces aal1 clock adaptive
?ces circuit 0 circuit-name example
?ces dsx1 linecode b8zs
?ces dsx1 framing esf
?ces dsx1 lbo 0_110
?ces pvc 0 dest-address 47.0091.8100.0000.0090.2144.8401.4000.0c81.9030.10 
 vpi 0 vci 16
!
interface CBR12/1/1
?no ip address
!
interface CBR12/1/2
?no ip address
!
interface CBR12/1/3
?no ip address
!
interface ATM13/0/0
?no ip address
?atm maxvp-number 0
!
interface Ethernet13/0/0
ip classless
!
line con 0
line aux 0
line vty 0 4
login
!
end

CES 回線が両側に稼働していることを確認する show ces interface コマンドを使用して下さい。 下記のように出力例を参照して下さい:

ls1010#show ces interface cbr 12/1/0
 
Interface: CBR12/1/0 Port-type:T1-DCU
IF Status: UP Admin Status: UP
Channels in use on this port: 1-24
LineType: ESF LineCoding: B8ZS LoopConfig: NoLoop?
SignalMode: NoSignalling XmtClockSrc: network-derived
DataFormat: UnStructured AAL1 Clocking Mode: Adaptive LineLength: 0_110
LineState: NoAlarm<
Errors in the Current Interval:
PCVs 514 LCVs 2 ESs 0 SESs 1 SEFSs 0
UASs 0 CSSs 0 LESs 0 BESs 0 DMs 0
Errors in the last 24Hrs:
PCVs 2057 LCVs 10 ESs 0 SESs 4 SEFSs 0
UASs 19 CSSs 0 LESs 0 BESs 0 DMs 0
Input Counters: 1054405 cells, 49557035 bytes
Output Counters: 1054405 cells, 49557035 bytes

ソフトPVC が 2 ATM スイッチの間で確立されたことを確認する show atm vc コマンドを使用して下さい。 下記のように出力例を参照して下さい:

8540-MSR#show atm vc interface ATM-P3/1/3
 
Interface?? VPI?? VCI?? Type?? X-Interface?? X-VPI?? X-VCI?? Encap Status
 
ATM-P3/1/3??? 0??? 16 SoftVC????? ATM3/0/0?????? 0?????? 39??????????? UP
 
 
LS1010#show atm vc interface ATM-P12/1/3
 
Interface?? VPI?? VCI?? Type?? X-Interface?? X-VPI?? X-VCI?? Encap Status
 
ATM-P12/1/3?? 0??? 16 SoftVC??? ATM12/0/0??????? 0????? 39???????????? UP

クロックスリップがアンダーフローかオーバーフローが増加しているかどうか見るためにないことを確認する show ces circuit cbr x/y/z 0 コマンドを使用すれば。 8540 MSR 側のこのコマンドを同様に使用するために確かめて下さい。 下記のように出力例を参照して下さい:

ls1010#show ces circuit cbr 12/1/0 0
 
Circuit: Name sil, Circuit-state ADMIN_UP / Interface CBR12/1/0,
Circuit_id 0, Port-Type T1, Port-State UP?
Port Clocking network-derived, aal1 Clocking Method CESIWF_AAL1_CLOCK_ADAPT
Channel in use on this port: 1-24
Channels used by this circuit: 1-24
Cell-Rate: 4107, Bit-Rate 1544000
cas OFF, cell_header 0x100 (vci = 16)
Configured CDV 2000 usecs, Measured CDV 373 usecs
De-jitter: UnderFlow 1, OverFlow 0
ErrTolerance 8, idleCircuitdetect OFF, onHookIdleCode 0x0
state: VcActive, maxQueueDepth 823, startDequeueDepth 435
Partial Fill: 47, Structured Data Transfer 0
Active SoftVC
Src: atm addr 47.0091.8100.0000.0090.92b8.6401.4000.0c86.1030.10 vpi 0, vci 16
Dst: atm addr 47.0091.8100.0000.0090.2144.8401.4000.0c81.9030.10

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10428