非同期転送モード(ATM) : ATM フレーム リレー間インターワーキング

フレームリレー/ATM 間のサービス インターワーキング(FRF.8 - 変換モード)

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 2 月 14 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Frame Relay(FR; フレームリレー)/ ATM 間のサービス のインターワーキング機能を使用すると、FR エンド ユーザと ATM エンド ユーザ間で通信が可能です。 この機能は、フレーム リレー フォーラム(FRF.8)の実装協定に基づいています。この協定は、FR エンド ステーションと ATM エンド ステーションが通信できる条件は、これら 2 つのエンド ステーション間のソフトウェアにおいて、FRF.8 の仕様を実行しているルータが存在することである、と指定しています。leavingcisco.com

この文書では、LightStream 1010 で FRF.8(変換モード)を使用した、フレームリレー / ATM 間のサービス インターワーキングの設定例を説明します。 この設定は、Catalyst 8510 MSR または 8540 MSR でも動作します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この文書に記載されている情報は Cisco IOS に基づいていますか。 リリース 12.0(3c)W5(9)。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10409/frf8.gif

この設定例のルータ 1 で使用する FR トラフィック シェーピング パラメータは、次のようになります。

  • Committed Information Rate(CIR; 設定情報レート)= 64 kbps

  • Committed burst(Bc)= 8000

  • Excess burst(Be)= 8000

注: フレーム リレー トラフィック シェーピング接続を解決する方法の詳細な説明に関してはフレームリレートラフィックシェーピング用 show コマンドを参照して下さい。

設定

このドキュメントでは、次の設定を使用します。

注: これらのコンフィギュレーションは ATM Service Interworking にフレーム リレーのためにだけ関連した情報が含まれています。

ルータ 1
controller E1 5/0 
 channel-group 30 timeslots 1-31 
! 
interface Serial5/0:30 
 ip address 12.12.12.2 255.255.255.0 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF. It should match the switch.
 
 no fair-queue 
 frame-relay traffic-shaping

!--- Enabling FR traffic shaping on this interface.
          
 frame-relay class test-iwf 
 frame-relay map ip 12.12.12.1 123 broadcast 
! 
map-class frame-relay test-iwf 
 no frame-relay adaptive-shaping

!--- Traffic shaping parameters configured.

 frame-relay cir 64000 
 frame-relay bc 8000 
 frame-relay be 8000

ATM スイッチ
frame-relay connection-traffic-table-row index 123 64000 
8000 128000 8000 vbr-nrt 123 
! 
controller E1 4/0/0 
 clock source free-running 
 channel-group 30  timeslots 1-31 
! 
interface Serial4/0/0:30 
 no ip address 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF.

 no arp frame-relay 
 frame-relay intf-type dce

!--- Interface type is dce, because it is providing clocking.

 frame-relay pvc 123 rx-cttr 123 tx-cttr 123 service translation 
 interface  ATM0/0/0 0 123 

!--- This command makes the translation from          
!--- Frame Relay to ATM PVC 123.

ルータ 2
interface ATM2/0.123 point-to-point 
 ip address 12.12.12.1 255.255.255.0 
 no ip directed-broadcast 
 pvc 0/123

!--- Configured ATM PVC 0/123 with traffic shaping and          
!--- oam-pvc management enabled.
 
 vbr-nrt 163 81 49 
 broadcast 
 oam-pvc manage 
 encapsulation aal5snap

ルータ 2 のトラフィック形成パラメータは ATM スイッチのフレームリレー 接続 トラフィック 表から受け取ることができます(セクションを参照して下さい)。

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show frame-relay lmi

  • show frame-relay map

  • show frame-relay pvc

  • show atm vc interface atm 0/0/0

  • show frame-relay connection-traffic-table-row

  • show atm connection-traffic-table

  • show frame-relay interface resource serial 4/0/0:30 all-information

下記に示されている出力はネットワークダイアグラムで示されているデバイスの上記のコマンドを入力した結果です。 この出力結果は、ネットワークが正常に稼動していることを示しています。

ルータ 1

注: シスコ ルータをサードパーティの通信に接続する場合は、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)の Local Management Interface(LMI; ローカル管理インターフェイス)を使用することをお勧めします。 LMI は Cisco で、フレーム リレーは、スイッチからクロッキングを受信しているため、DTE になります。

Router1# show frame-relay lmi 
 
LMI Statistics for interface Serial5/0:30 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1222             Num Status msgs Rcvd 1222
  Num Update Status Rcvd 0              Num Status Timeouts 2

dlci が up で、対応する IP アドレスにマップされていることを確認するには、 show frame-relay map コマンドを使用します。

Router1# show frame-relay map 

Serial5/0:30 (up): ip 12.12.12.1 dlci 123(0x7B,0x1CB0), static,
              broadcast,
              IETF, status defined, active

フレームリレー PVC のステータスをチェックするために、show frame-relay pvc コマンドを使用して下さい。 下記の出力で、ステータスがアクティブであることが確認できます。

Router1# show frame-relay pvc 
 
PVC Statistics for interface Serial5/0:30 (Frame Relay DTE)
 
              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
 
DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0:30
 
  input pkts 786           output pkts 549          in bytes 742312    
  out bytes 684503         dropped pkts 6           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 1          out bcast bytes 608       
  pvc create time 03:25:16, last time pvc status changed 03:09:30

ATM スイッチ

注: ATM-PX/Y/Z という用語は、擬似インターフェイスを意味します。

ATMswitch# show atm vc interface atm 0/0/0
Interface         VPI  VCI   Type   X-Interface      X-VPI X-VCI Encap  Status 
ATM0/0/0          0    5     PVC    ATM2/0/0          0    43    QSAAL  UP
ATM0/0/0          0    16    PVC    ATM2/0/0          0    35    ILMI   UP
ATM0/0/0          0    101   PVC    ATM0/1/0          0    101          UP
ATM0/0/0          0    102   PVC    ATM0/1/0          0    102          UP
ATM0/0/0          0    123   PVC    ATM-P4/0/0        30   155          UP

フレーム リレーをスイッチの ATM 接続に表示するために、下記に示されているように show frame-relay connection-traffic-table-row コマンドを、使用して下さい:

ATMswitch# show frame-relay connection-traffic-table-row 
Row            cir      bc     be      pir      fr-atm Service-category    ATM Row
                                            
100           64000   32768   32768   64000            vbr-nrt              100       
123           64000   8000    8000    128000           vbr-nrt              123       


ATMswitch# show atm connection-traffic-table 
Row      Service-category    pcr        scr/mcr       mbs         cdvt
1            ubr          7113539        none                     none
2            cbr              424                                 none
3            vbr-rt           424         424          50         none
4            vbr-nrt          424         424          50         none
5            abr              424           0                     none
6            ubr              424        none                     none
10           cbr            50000                                 none
11           cbr             1000                                 none
12           cbr            11700                                 none
100          vbr-nrt           81          81-0        50         none
123          vbr-nrt          163          81-0        49         none 
<-- (*)

2147483645*  ubr                0        none                     none
2147483646*  ubr                1        none                     none
2147483647*  ubr          7113539        none                     none

(*)frame-relay connection-traffic-table-row を作成する場合は、ATM テーブル行インデックスを関連付けます。ATM テーブル行インデックスでは、バージョン 2.0 の Broadband Inter-Carrier Interface(B-ICI)仕様を使用して、ATM トラフィック シェーピング パラメータが自動的に計算されます(公式を参照)。

ATMswitch# show frame-relay interface resource serial 4/0/0:30 all-information 
Encapsulation: FRAME-RELAY
Resource Management configuration:
    Input queues (PAM to switch fabric):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Output queues (PAM to line):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Overflow servicing for VBR: enabled
  Available bit rates (in bps):
     1920000 vbr-nrt RX, 1920000 vbr-nrt TX
     1920000 abr RX,     1920000 abr TX
     1920000 ubr RX,     1920000 ubr TX
    Overbooking: disabled
Resource Management state:  Allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX
  Actual allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10409