非同期転送モード(ATM) : IP-ATM 間サービス クラス

Cisco 7200、3600、および 2600 ルータでの、VC 単位、クラスベースの重み付け均等化キューイング(Per-VC CBWFQ)

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 12 月 10 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Weighted Fair Queuing(WFQ; 均等化キューイング)の実装目的は、(シリアル リンクなどの)低速リンクが、各タイプのトラフィックを公平に扱えるようにすることでした。 この作業を行うため、WFQ は、関連するレイヤ 3 およびレイヤ 4 の情報(IP アドレス、TCP のポートなど)に基づいて、トラフィックを異なるフローに分類します。 この機能のために、ユーザが access-list を定義する必要はありません。 WFQ を用いると、低帯域幅トラフィックは高帯域幅トラフィックよりも実際に優先順位が高くなります。 高帯域幅トラフィックは、割り当てられた重みに比例して、伝送メディアを共有します。

WFQ に次の制限があります:

  • トラフィック フローが大幅に増加した場合、WFQ はスケーラブルでないため適応できません。

  • WFQ は ATM のような高速インターフェイスで利用できません。

新機能である Class-Based Weighted Fair Queuing(CBWFQ; クラスベース均等化キューイング)は、WFQ の制限に対処するために開発されました。 WFQ とは違って、CBWFQ はトラフィック クラスを定義することを可能にします。 クラスが定義されたら、パラメータはそれから適用します。 これらのパラメータは帯域幅および queue-limit が含まれています。

CBWFQ を、規定 されるウエイトはクラス の 基準を満たすクラスのために使用するとき各パケットの重量になります。 この重みは、クラスに割り当てられた帯域幅から求められます。 WFQ はこれらのクラスにフロー自身に適用されるかわりにそれから適用されます。 クラスは複数のフローを含むことができます。

7200 人、3600 人、および 2600 人のルータの VC 単位の CBWFQ アベイラビリティの概略は下記にあります:

  • 7200: Cisco IOS(R) バージョン 12.0(5)T、12.0(5)XE、12.1(1)、12.1(1)T、PA-A3 を使用する 12.1(1)E およびそれ以降。

  • NSE との 7200: Cisco IOSバージョン 12.1(7)E およびそれ以降。

  • NSE-1 との 7200 はアクセラレータを保守します: Cisco IOSバージョン 12.2(4)B1。

  • Cisco IOSバージョン 12.1(5)T およびそれ以降の NM-1A-T3/E3 モジュールサポート LLQ/CBWFQ との 2600/3600。

  • DS3/E3 ネットワークモジュールとの 2600/3600: Cisco IOSバージョン 12.1(2)T。

注: Cisco Express Forwarding (CEF) 機能性は CBWFQ が CEF スイッチのパケットだけ監視するので使用する必要があります。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のハードウェアのバージョンに基づくものです。

  • Cisco 7200, 3600 および 2600 シリーズ ルータ

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10395/7200-1.gif

  • 1/130 は 7200 間の PVC およびルータ A.の両端で割り当てられる VPI/VCI 値です。

  • トラフィックジェネレータはインターフェイス ファースト イーサネット 3/0 に接続されます。

  • 7200 は Cisco IOSバージョン 12.0(5)T を実行しています。

  • ルータ A はテスト用にシンク デバイスとして使用されます。

  • 設定は 7200 で行われますが、2600/3600 で類似したです。

設定例

CBWFQ を設定するのに必要な 7200 設定は下記にあります:

7200
    class-map ixia
      match input-interface FastEthernet3/0
    class-map loopbacks
      match access-group 102
    !
    policy-map mypol
      class ixia
       bandwidth 40000
       queue-limit 40
      class loopbacks
       bandwidth 10000
      class class-default
       fair-queue
    !
    interface ATM2/0.130 point-to-point
     ip address 14.0.0.2 255.0.0.0
     no ip directed-broadcast
     pvc 1/130
      service-policy output mypol
      vbr-nrt 100000 75000
      broadcast
      encapsulation aal5mux ip
    !
    access-list 102 permit ip host 10.0.0.1 host 11.0.0.1

設定のいくつかのコメントは下記にあります:

  • クラスマップはトラフィックにウエイトを分類し、割り当てます。 分類パラメータとクラス マップは、同じ場所で定義します。 この場合、1 つのクラスは Fast-Ethernet 3/0 (トラフィックジェネレータからのトラフィック)のすべての着信トラフィックに適用されます。 他のクラスはループバック関連しています(7200 でとルータ A)間のトラフィックと定義される。

  • 分類 パラメータを定義した後、これらの分類されたフローにトラフィックパラメータを適用するのにポリシーマップを使用できます。 この場合、トラフィックジェネレータからのフローは帯域幅および 40 のパケットのキュー項目数 40 Mbps の「割り当てられます」。 ループバック間のトラフィックは帯域幅 10 Mbps の割り当てられます。

  • キュー項目数はドロップが行われる前に特定クラスのために保存することができるパケットの数です。 (また Maximum Queue Depth の)デフォルト値は 64 です。

  • トラフィックパラメータが各クラスのために定義された後、CBWFQ は次のコマンドを使用して VC ベースで適用されます: サービス ポリシー[入力|出力] policy-map-name

  • ポリシーマップで定義される定義されたクラス マップの 1 つと一致しないトラフィック デフォルト クラス マップ(クラス デフォルト)は割り当てられます。 すべての非分類 の トラフィックはこのデフォルト クラスの下で定義されたパラメータ加えられます。 この場合、正常な均等化キューイングは設定されます。

  • この設定 例に関しては、CBWFQ は VC で適用されます、PVC バンドルで同様に使用することができます。 さらに、CBWFQ は Weighted Random Early Discard (WRED)とドロップ メカニズムとして(queue-limit が達するとき)関連付けることができます。

重要:

このセクションでコンフィギュレーション タスクを行う前に、そして定義しますそれらを含むためにポリシーマップを最初に VC のトラフィックを分類するのに使用するクラスを作成して下さい。 ルータで定義される同様に多くのクラスのためのクラス ポリシーを設定できます -- 最大 64 まで。 ただし、(ポリシー マップに含まれるすべてのクラスに関して)割り当てられた VC 帯域幅の合計量は、VC の利用可能な帯域幅の 75 パーセントを超えることはできません。

CBWFQ が最小帯域幅保証を提供するので、UBR および UBR+ 以外しか CBWFQ にサービス クラスによって VC を適用できません。

両方のサービス クラスが最小帯域幅を保証しないベストエフォート クラスであるので VC 単位の WFQ および CBWFQ に UBR および UBR+ VC を適用できません。 CBWFQ が VC のために有効に なるとき、サービス ポリシーの一部分で設定されるすべてのクラスはフェアキューイング システムにインストールされています。

適用すれば ATM VC およびポリシーへのサービス ポリシーは Parallel Express Forwarding (PXF)ではない機能が含まれています-、パケットは次の低速スイッチングパスにパントされますイネーブルになった。 show pxf acc summ コマンドを実行し、探して下さい「出力 機能によるパントの増分する値を」。

router#show pxf acc sum      
            Pkts             Dropped   RP Processed             Ignored 
           Total                 242      328395045                   0 
10 second averages: PXF complex busy:       28%  PXF read pipeline full:   0% 
PXF Statistic: 
     Packets RP -> PXF: 
         switch ip:                       0 
         switch raw:              556612940 
         qos fastsend:                    0 
         qos enqueue:                     0 
     Total:                       556612940 
Packets PXF -> RP: 
         qos pkts:                        0 
         fast pkts:               228217649 
         drops: total                   242 
           "    no route               :         242 
         punts: total             328395045 
           "    not IP                 :         597 
           "    IP options             :         676 
           "    CEF no adjacency       :      186770 
           "    CEF receive            :      265306 
           "    output feature         :   327916956 

7200 ルータ拡張 CBWFQ 設定

Cisco IOSバージョン 12.1(5)E を、12.1(5)T およびそれ以降実行する、Cisco 7200 ルータでより複雑なクラスマップを形成するためにマップクラスをグループ化できます。 さらに、クラスマップ パラメータに論理操作を関連付けることができます(トラフィックがクラスと一致したかどうか)確認するため。

次のクラスマップをこの概念を明白にするために検知 しよう:

高度 な CBWFQ の 設定
class-map match-all ixia
  description traffic from Ixia 
  match input-interface FastEthernet1/0 
class-map match-all ftp1 
  description ftp traffic initiated by the traffic generator 
  match class-map ixia 
  match class-map ftp2 
class-map match-all ftp2 
  match access-group 103 
class-map match-any test 
  match access-group 102    
  match input-interface Ethernet0/0 
! 
access-list 103 permit tcp any any eq ftp    
! 
access-list 102 permit ip host 10.1.1.1 any

match-all と match-any の違いは次のようになります。

  • match-all: フローはクラスマップと関連する条件すべてが確認される場合関連付けられます。

  • match-any は意味します: フローは class-map と関連する条件の ANY が確認される場合関連付けられます(必ずしもすべての条件)。

クラスマップが他の構成されたクラス マップに対してテストを含むことができることがここにわかります。 この場合、フローは ftp1 とクラスマップ IXIA およびクラスマップ ftp2 の下で定義されるすべての条件と一致する場合関連付けられます。

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show policy-map interface atm x/y[.z] —このコマンドはドロップのようなキューごとの統計情報を、見ることを可能にします。 それは Cisco のモジュラー クオリティオブサービス(QoS) Command Line Interface (CLI) (MQC)で作成されるサービス ポリシーの結果を監視するために役立ちます。 このコマンドの出力を理解する方法に関する詳細な情報詳細については show policy-map interface 出力の知識パケットカウンタを参照して下さい。

            7200#show policy-map interface atm 2/0.130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0

    注: ドロップの 2 つの型に関する次の説明を参照して下さい:

    • 破棄: これからの総ドロップ キュー。

    • テール ドロップ: これからのドロップは別のキューに「より低い」WFQ シーケンス番号が付いている着信パケットがあり、WFQ システムがキューの最大限界量のパケットに連絡するときだけ並べます。

  • show policy-map interface atm x/y[.z] VC [VCD | VPI/VCI] —このコマンドは仕様 VC のためのより多くの細かさを与えたものです。

            7200#show policy-map interface atm 2/0.130 vc 1/130 
             ATM2/0.130: VC 1/130 - output : mypol 
              Weighted Fair Queueing 
                Class ixia 
                  Output Queue: Conversation 264 
                    Bandwidth 40000 (kbps) Packets Matched 0 Max Threshold 40(packets) 
                    (discards/tail drops) 0/0 
                Class loopbacks 
                  Output Queue: Conversation 265 
                    Bandwidth 10000 (kbps) Packets Matched 0 Max Threshold 64(packets) 
                    (discards/tail drops) 0/0 
                Class class-default 
                  Output Queue: Conversation 266 
                    Bandwidth 0 (kbps) Packets Matched 0 Max Threshold 64 (packets) 
                    (discards/tail drops) 0/0
    

またマップクラスに関する詳細な情報を得る show class-map または show policy-map class のような他のコマンドを使用できます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10395