WAN : ポイントツーポイント プロトコル(PPP)

複数のシリアル インターフェイスを備えたバックツーバックのルータでのマルチリンク PPP

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 5 月 29 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

環境によっては、複数のシリアル リンクを集束して、単一の集約帯域幅として機能させることが必要になる場合があります。 このドキュメントでは、次の 2 種類の方法で 2 つのシリアル インターフェイスを集束するように Cisco 2503 Access Server を設定する方法を説明しています。

これらの設定は、専用回線経由で接続されたルータまたはチャネル サービス ユニット/データ サービス ユニット(CSU/DSU)搭載のルータ、またはダイヤルを設定されたISDN ターミナル アダプタ(TA)に使用できます。 (電話番号にダイヤルするために Ciscoルータは設定されませんでした。) 必要に応じて、この設定にその他の機能を追加できます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco 2503 ルータ

  • Cisco IOS(R) ソフトウェア リリース 12.2(7b)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

関連製品

この設定は、それぞれに WAN シリアル インターフェイスを備えた任意の 2 つのルータに使用できます。 WIC-1T、WIC-2T、あるいは固定 WAN シリアル インターフェイスが使用できます。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10382/pppmultilink.gif

設定

この設定は、Cisco 2500 シリーズのルータで Cisco IOS ソフトウェア リリース 12.2(7b) を使用してテストされています。 これと同じ設定の概念は、類似のルータ トポロジや Cisco IOS のその他のリリースにも適用されます。

例 1: インターフェイス ダイヤラ

例 2: バーチャル テンプレート

例 1: インターフェイス ダイヤラ

Router1:Cisco 2503
Current configuration:
version 12.2
 
hostname Router1
!
username Router2 password 0 abc

!--- This local username and password pair is used for PPP Challenge
!--- Handshake Authentication Protocol (CHAP) authentication.

ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

!--- The loopback address is used by interface dialer 1.

!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1

 !--- Interface Serial0 is a member of rotary-group 1.
 !--- The rotary group configuration is in interface dialer 1. 

 no fair-queue
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 pulse-time 1
!
interface Dialer1

!--- This is the configuration for rotary-group 1.
!--- The dialer interface number must exactly match the rotary group number.

 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 300
 dialer map ip 192.168.20.1 name Router2 broadcast
 dialer load-threshold 2 either
 dialer-group 1

 !--- Apply interesting traffic definition from dialer-list 1.

 no fair-queue
 ppp authentication chap
 ppp direction callout  

 !--- This is a hidden command; see the Notes section for more information.

 ppp multilink

 !--- Allow multilink for the dialer profile.
 !--- Without this command, multilink is NOT negotiated.

!
ip classless
ip route 192.168.20.1 255.255.255.255 Dialer1
dialer-list 1 protocol ip permit

!--- The dialer-list defines the interesting traffic.

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2:Cisco 2503
Current configuration:
version 12.2
hostname Router2
!
!
username Router1 password 0 abc
ip subnet-zero
no ip domain-lookup
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Serial0
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
interface Serial1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 no fair-queue
 clockrate 56000
 pulse-time 1
!
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 999
 dialer map ip 192.168.10.2 name Router1 broadcast
 dialer load-threshold 2 either
 dialer-group 1
 no fair-queue
 no cdp enable
 ppp authentication chap
 ppp multilink
!
ip classless
ip route 192.168.10.2 255.255.255.255 Dialer1
!
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

例 1 の注記

ppp direction callout コマンドは隠しコマンドで、ダイヤル元とダイヤル先がルータで把握できない場合(バックツーバックで接続されているか専用回線で接続されていて、CSU/DSU や ISDN TA がダイヤルするように設定されている場合)に使用されます。 ppp direction callin コマンドも使用できます。 これらのコマンド のいずれかを使用します。

  • ローカル ルータの場合は、ppp direction callout を使用します。

  • リモート ルータの場合は、ppp direction callin を使用します。

このコマンドを使用しないと、ルータは一時的に接続されますが、すぐに接続解除されます。

上記の設定は Router1 と Router2 の 2 つのルータを説明しており、これらには、単一の集約帯域幅として機能するために集束する 2 つのシリアル インターフェイスがあります。 両方のルータで、interface loopback が設定されており、ip unnumbered loopback0 を使用して interface dialer に統合されています。 どちらのシリアル インターフェイスも IP アドレスなしで設定されています。 物理インターフェイス Serial0 と Serial1 は dialer rotary-group で設定されており、単一の論理インターフェイス ダイヤラに関連付けられています。

Dialer-list 1 で対象のトラフィックが定義されており、次にインターフェイス dialer 1 で dialer-group 1 コマンドがトリガーされて、リンクが起動されます。 両方のルータに定義された dialer map 文により、インターフェイス dialer 1 がピア ルータの IP アドレスにマッピングされており、定義されたホスト名が CHAP 認証に使用されます。 定義されたスタティック ルートにより、トラフィックが宛先にルーティングされます。

ppp authentication chap コマンドにより、PPP ネゴシエーションがイネーブルにされます。 dialer load-threshold コマンドでは、2 番目のシリアル ラインの起動をトリガーする負荷が設定されます。 ppp multilink コマンドと dialer rotary-group コマンドが設定されており、集約帯域幅を持つ単一のバーチャルアクセス インターフェイスに両方のシリアル インターフェイスを集束できます。 ppp direction callout コマンドでは、PPP ネゴシエーションと CHAP 認証でコールアウトを行う側が指定されます。

例 1 の確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

Router1# show ppp multilink 
Virtual-Access1, bundle name is Router2 
  Bundle up for 00:01:05 
  Dialer interface is Dialer1 
  0 lost fragments, 0 reordered, 0 unassigned 
  0 discarded, 0 lost received, 1/255 load 
  0x0 received sequence, 0x0 sent sequence 
  Member links: 2 (max not set, min not set) 
    Serial0, since 00:01:05, no frags rcvd 
    Serial1, since 00:01:05, no frags rcvd   

 Router2# show ppp multilink  

 Virtual-Access1, bundle name is Router1
  Bundle up for 00:03:25
  Dialer interface is Dialer1
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:03:25, no frags rcvd
    Serial0, since 00:03:25, no frags rcvd

例 1 のトラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

debug コマンド

Router1 では、debug ppp authentication コマンドにより CHAP の成功が表示されています。

May  8 17:52:19: Se1 PPP: Using configured call direction
May  8 17:52:19: Se1 PPP: Treating connection as a callout
May  8 17:52:19: Se0 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: O CHALLENGE id 135 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se1 CHAP: I CHALLENGE id 134 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O RESPONSE id 134 len 28 from "Router1"
May  8 17:52:19: Se0 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se0 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se0 CHAP: O SUCCESS id 135 len 4
May  8 17:52:19: Se1 CHAP: I SUCCESS id 134 len 4
May  8 17:52:19: Se1 CHAP: I RESPONSE id 135 len 28 from "Router2"
May  8 17:52:19: Se1 CHAP: O SUCCESS id 135 len 4
5d05h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
May  8 17:52:19: Vi1 PPP: Using configured call direction
May  8 17:52:19: Vi1 PPP: Treating connection as a callout
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
5d05h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to up

Router2 で、debug ppp authentication コマンドは示します「待っているピアを….「

5d02h: %LINK-3-UPDOWN: Interface Serial0, changed state to up
5d02h: Se0 PPP: Treating connection as a callin
5d02h: Se0 CHAP: O CHALLENGE id 132 len 28 from "Router2"
5d02h: Se0 CHAP: I CHALLENGE id 133 len 28 from "Router1"
5d02h: Se0 CHAP: Waiting for peer to authenticate first
5d02h: Se0 CHAP: I RESPONSE id 132 len 28 from "Router1"
5d02h: Se0 CHAP: O SUCCESS id 132 len 4
5d02h: Se0 CHAP: Processing saved Challenge, id 133
5d02h: Se0 CHAP: O RESPONSE id 133 len 28 from "Router2"
5d02h: Se0 CHAP: I SUCCESS id 133 len 4
5d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

例 2: バーチャル テンプレート

Router1:Cisco 2503
Current configuration
!
version 12.2
!
hostname Router1
!
!
username Router2 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
 
multilink virtual-template 1

!--- Applies the virtual interface template to the multilink bundle.

 
interface Loopback0
 ip address 192.168.10.2 255.255.255.0

 !--- The loopback address is used by virtual-template 1.

 
 
interface Virtual-Template1

!--- Interface virtual-template is a logical interface that creates
!--- virtual access interfaces dynamically and applies them to 
!--- physical serial interfaces.

 ip unnumbered Loopback0

!--- Always unnumber the virtual-template to an UP interface.
!--- Do not assign a static IP.

 ppp authentication chap
 ppp multilink 

 !--- Enables multilink PPP on the virtual-template interface.

 
interface Serial0
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 pulse-time 1
 ppp multilink
!
!
ip classless
!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

Router2:Cisco 2503
Current configuration :
!
version 12.2
!
hostname Router2
!
!
username Router1 password 0 abc
 
ip subnet-zero
no ip domain-lookup
!
multilink virtual-template 1
!
!
!
interface Loopback0
 ip address 192.168.20.1 255.255.255.0
!
!
interface Virtual-Template1
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
interface Serial0
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
interface Serial1
 no ip address
 encapsulation ppp
 no fair-queue
 clockrate 56000
 pulse-time 1
 ppp multilink
!
!
ip classless
!
!
line con 0
line aux 0
line vty 0 4
!
end

上記の設定では、Router1 と Router2 に設定されたバーチャル テンプレートが説明されています。 この例では、両方のルータを仮想テンプレートで設定します。 これらのルータはバックツーバックに接続されており、マルチリンク セッションはアイドル アウトしません。 静的ルートは不要です。 PPP ネゴシエーション後にホスト ルートをインストールします。

Cisco IOS® ソフトウェア リリース 11.3 以降を使用して、PPP マルチリンクに仮想テンプレートを使用します。

virtual template コマンドにより、バーチャル アクセス インターフェイスがダイナミックに作成され、multilink virtual-template コマンドにより、これらが物理シリアル インターフェイスに適用されます。 インターフェイスのバーチャル テンプレートに設定された ppp authentication chap などのパラメータは、両方のシリアル インターフェイスに適用されます。 帯域幅を集約するために、インターフェイスのバーチャルテンプレート内の ppp multilink コマンドにより物理シリアル インターフェイスが集束されて、バーチャルアクセスが形成されます。

例 2 の確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

Router2# show ppp multilink
 
Virtual-Access1, bundle name is Router1

!--- Virtual Access interface used for the bundle

  Bundle up for 00:20:38
  0 lost fragments, 0 reordered, 0 unassigned
  0 discarded, 0 lost received, 1/255 load
  0x0 received sequence, 0x0 sent sequence
  Member links: 2 (max not set, min not set)
    Serial1, since 00:20:39, no frags rcvd
    Serial0, since 00:20:39, no frags rcvd

!--- Note that there are two links (Se 0 and Se1) in the bundle

次のコマンドも有用です。

  • show ip route connected:バーチャルアクセスのための IP ルートが設置されているかを表示します。

  • show interface virtual-access x:特定のバーチャルアクセス インターフェイスのステータスを調べます。 上記の例では、バーチャルアクセス インターフェイスの番号は 1 になっています。

例 2 のトラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

グローバル コンフィギュレーションで、次のようにタイムスタンプを設定します。

service timestamps debug datetime msec
service timestamps log datetime msec

トラブルシューティングには、次のコマンドを使用します。

  • debug ppp negotiation:クライアントが PPP ネゴシエーションを通過しているかどうかを確認します。 ネゴシエート中のオプション(コールバック、マルチリンク PPP(MLP)など)およびプロトコル(IP、IPX など)も確認できます。

  • debug ppp authentication:クライアントが認証を通過しているかどうかを確認します。

  • debug vtemplate:どのバーチャルテンプレートの設定が使用されているかを確認します。

  • debug vprofile:バーチャルアクセス インターフェイスにどの設定オプションが適用されているかを確認します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10382