ダイヤルとアクセス : 非同期接続

AUX ポートを経由するルータのバックツーバック接続

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 3 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この設定例では、モデムまたはその他のデータ通信装置(DCE)デバイスを使用せずに 2 台のルータを直接接続する方法を示します。 AUX ポートまたはコンソール ポートでモデムを設定する方法の詳細については、「モデム - ルータ間接続ガイド」または「アクセスダイヤル テクノロジー サポート」を参照してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

この設定では、ヌルモデム ケーブル(ロールオーバー ケーブル)を使用した非同期 AUX ポートによって、2 台の Cisco ルータが Back-To-Back 接続されています。 2 台のルータの AUX ポートがリンク上でポイントツーポイント プロトコル(PPP)を使用して、ロールオーバー ケーブルで直接接続されています。 AUX ポートは Data Terminal Equipment(DTE; データ端末装置)デバイスです。 DTE デバイスを DTE デバイスに接続するにはヌルモデム ケーブル(ロールオーバー ケーブル)が必要です。

フラットサテン ロールオーバー(ヌルモデム)ケーブル(部品番号 CAB-500RJ=)は通常、すべての Cisco ルータに付属しており、RJ-45 コンソール接続に対応します。 AUX ポートが DB-25 の場合は、ヌルモデム ケーブル(ロールオーバー ケーブル)とともに "terminal" のラベルが付いた RJ-45-to-DB-25 アダプタを使用します。

注: EIA/TIA-232(旧 RS-232)制限があるため、ケーブルの長さは 50 フィート未満にしてください。

ケーブル接続の詳細については、「RJ-45 コンソールおよび AUX ポートのケーブル接続ガイド」と「RJ-45 ケーブル」を参照してください。

DB-25 AUX ポートを備えたルータ

DB-25 AUX ポートを備えたルータ(Cisco 4500、7200、7500 など)の場合、DB-25-to-DB-25 ヌルモデム ケーブルが必要です。 このケーブルは、ほとんどの電化製品販売店で購入できます。

注: 両端に RJ-45-to-DB-25 アダプタが付いているロール型 RJ-45-to-RJ-45 フラットサテン ケーブル(部品番号 CAB-25AS-MMOD)は、信号ペアが間違っているため使用できません。

DB-25-to-DB-25 ヌルモデム ケーブルに表 1 に示すピン接続があるかどうかを確認してください。

表 1 – DB-25-to-DB-25 ヌル モデム ケーブルのピン接続

DB-25 DB-25
RxD 2 3 TXD
TxD 3 2 RxD
CTS 4 5 RTS
RTS 5 4 CTS
DTR 6 20 CD
DSR 8
CD 20 6 DTR
8 DSR
GND 7 7 GND

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10365/auxback.gif

設定

このドキュメントでは、次の設定を使用します。

  • ルータ 1

  • ルータ 2

注: この接続は、固定接続をするために AUX ポート上の IP アドレスを使用して設定されています。

ルータ 1
version 11.1
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router1
 !
 interface Ethernet0
  no ip address
  shutdown
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX port.

  ip address 192.168.10.1 255.255.255.0

 !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

 !--- Set PPP as the encapsulation.

  async default routing 

 !--- This allows routing protocols on the link. 

  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Async1

 !--- The default route points to the Async1 (AUX port) interface.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

  !--- This allows all protocols to use the line.

  rxspeed 38400

  !--- Set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

  !--- Set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

ルータ 2
version 11.1

 service udp-small-servers
 service tcp-small-servers
 !
 hostname Router2
 !
 interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
 !
 interface Serial0
  no ip address
  shutdown
 !
 interface Serial1
  no ip address
  shutdown
 !         
 interface Async1

 !--- The async interface that corresponds to the AUX port.
 !--- Use the show line command to determine which async interface corresponds
 !--- to the AUX Port.

  ip address 192.168.10.2 255.255.255.0

  !--- The IP address on the AUX ports of both routers are in the same subnet.

  encapsulation ppp

  !--- Set PPP as encapsulation.

  async default routing 
  
!--- This allows routing protocols on the link.
 
  async mode dedicated
 !
 no ip classless
 ip route 0.0.0.0 0.0.0.0 Ethernet0
 
!--- This default route points to interface Ethernet0.

 logging buffered
 !
 line con 0
  exec-timeout 0 0
 line aux 0

 !--- Line configuration for the AUX port.

  modem InOut
  transport input all

 !--- This allows all protocols to use the line.

  rxspeed 38400

 !--- set the Rx speed (identical to the TX speed of the other router).

  txspeed 38400

 !--- set the Tx speed (identical to the RX speed of the other router).

  flowcontrol hardware
 line vty 0 4
  login
 !
 end

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティング手順

debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

次の手順を実行します。

  1. show line コマンドを使用して、AUX ポートの非同期インターフェイスを確認します。

    ほとんどのルータには、interface async 1 として AUX ポートがありますが、アクセス サーバには TTY 回線の後に AUX ポート インターフェイスがあります。 たとえば、ルータに 16 の非同期またはモデム回線がある場合、AUX ポートは回線 17 となります。 このような場合、interface async 17 に AUX ポートを設定する必要があります。 show line 出力に基づいて、AUX ポートを設定します。 AUX ポートの設定がルータの interface Async1 上にあることを確認する例を次に示します。

    Router1#show line
     Tty Typ     Tx/Rx    A Modem Roty AccO AccI Uses  Noise  Overruns
    *  0 CTY              -    -     -    -    -    0      0       0/0
    A  1 AUX  38400/38400 - inout    -    -    -    0      0       0/0
       2 VTY              -    -     -    -    -    0      0       0/0
       3 VTY              -    -     -    -    -    0      0       0/0
       4 VTY              -    -     -    -    -    0      0       0/0
       5 VTY              -    -     -    -    -    0      0       0/0
       6 VTY              -    -     -    -    -    0      0       0/0
  2. show line aux 0 コマンドを実行します。

  3. すべての信号が動作していることを確認します(Clear To Send(CTS)、Request To Send(RTS; 送信要求)、Data Terminal Ready(DTR; データ端末レディ)、および Carrier Detect(CD; キャリア検知)など)。

    これらの信号の横に何も表示されていなければ、信号は動作しています。 信号の隣に "No" が表示されている場合(No-CTS など)は、信号が停止していることを示します。 信号が停止している場合は、それぞれの側の設定を確認してください。 AUX ポートの非同期インターフェイスと回線が(上のように)設定されていることを確認します。

    注: show line コマンドの出力が、DSR が動作していないことを示している(noDSR)場合は、DB-25-to-DB-25 ヌルモデム ケーブルのそれぞれの側で、ピン 6 と 8 が反対側のピン 20 に物理的に接続されていることを確認する必要があります。 正しいピン割り当てについては、表 1 を参照してください。

    Router1#show line aux 0
     Tty Typ    Tx/Rx     A Modem Roty AccO AccI Uses  Noise  Overruns
    A  1 AUX 38400/38400  - inout    -    -    -    0      0       0/0
    
    Line 1, Location: "", Type: ""
    Length: 24 lines, Width: 80 columns
    Baud rate (TX/RX) is 38400/38400, no parity, 2 stopbits, 8 databits
    Status: Ready, Active, Async Interface Active
    Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out
      Modem Callout, Modem RI is CD, Line is permanent async interface
    Modem state: Ready
    Special Chars: Escape  Hold  Stop  Start  Disconnect  Activation
                    ^^x    none   -     -       none         
    Timeouts:  Idle EXEC  Idle Session  Modem Answer  Session  Dispatch
               00:10:00      never                       none   not set
    Modem type is unknown.
    Session limit is not set.
    Time since activation: 00:00:30
    Editing is enabled.
    History is enabled, history size is 10.
    Full user help is disabled
    Allowed transports are pad v120 telnet.  Preferred is telnet.
    No output characters are padded
    No special data dispatching characters
    Line is running PPP for address 192.168.10.2.
    0 output packets queued, 1 input packets.
     Async Escape map is 00000000000000000101000000000000
    Modem hardware state: CTS* DSR*  DTR RTS 
    
  4. 構成設定が正しいと思われる場合は、ルータ間のロールオーバー ケーブルを交換します。

  5. 非同期インターフェイスで shutdown コマンドと no shutdown コマンドを使用して接続をリセットします。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

リンクが正しく起動したことを確認するには、次の debug コマンドを使用します。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug ppp negotiation:Link Control Protocol(LCP)、認証、および Network Control Protocol(NCP)のネゴシエーション進行時の、PPP トラフィックや交換に関する情報を表示します。 PPP ネゴシエーションが正常に行われると、最初に LCP 状態が開放され、次に認証、最後に NCP をネゴシエートします。 CONFREQ が送信されたにもかかわらず、CONFACK を受信しない場合は、ケーブルが正しく接続されているかどうか、回線が正しく設定されているどうかをチェックしてください(interface async x コマンドを発行)。

  • debug ppp authentication:Challenge Handshake Authentication Protocol(CHAP)パケット交換や Password Authentication Protocol(PAP)交換を含む、PPP の認証プロトコル メッセージを表示します(認証が設定されている場合)。 この設定では認証は設定されていません。 したがって、この debug コマンドは必要ではありません。

  • debug ppp error:PPP 接続のネゴシエーションと接続操作に関するプロトコル エラーとエラー統計情報を表示します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10365