ダイヤルとアクセス : 非同期接続

NM-8AM またはNM-16AM アナログモデムモジュールを使用するダイヤルアウトの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、NM-AM アナログ モデム ネットワーク モジュールを接続したモデムを使用して dialout を設定する例を説明します。 このシナリオでは、NM-8AM モデムを接続したルータから、中央サイト ルータの Primary Rate Interface(PRI)にダイヤルします。

このドキュメントは、モデムの設定に関連するさまざまな事項を十分に理解していることを前提としています。 これらの問題に関する詳細については、『モデム-ルータ間接続ガイド』を参照してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

この設定では、次のソフトウェアおよびハードウェアのバージョンを使用して開発とテストを行いました。

  • Cisco IOS を実行する NM-8AM カードの Cisco 3640 ルータか。 ソフトウェア リリース 12.1(5)T。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/10316/dialout-nmam.gif

設定

このドキュメントでは次に示す設定を使用しています。

ルータ 1(Cisco 3640)
Current configuration : 1676 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
enable password ww
!
username router2 password 0 ww

!--- username for remote router (Router 2) and shared secret
!--- shared secret(used for CHAP authentication) must be the same on both sides

ip subnet-zero
!
chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \c

!--- chat script "async" used for the dialout connection

!
!
interface Ethernet2/0
 ip address 10.200.20.51 255.255.255.0
 half-duplex
!
interface Async104	

!--- async interface corresponding to the modem 
!--- This was determined using the show line command.

 ip address 10.10.0.2 255.255.255.252

!--- IP address of this async interface

 encapsulation ppp
 dialer in-band
 dialer wait-for-carrier-time 180
 dialer map ip 10.10.0.1 name router2 modem-script async 8214

!--- dialer map statements for the remote router 
!--- The name must match the one used by the remote router to identify itself.
!--- use modem chat script "async" for this connection

 dialer-group 1
!--- apply interesting traffic definition from dialer-list 1
 async mode dedicated

!--- Place the line into dedicated asynchronous network mode.
!--- This interface is now automatically configured for PPP connections.

 ppp authentication chap
!--- use chap authentication
!
ip classless
ip route 10.10.0.0 255.255.0.0 10.10.0.1

!--- Traffic for the 10.10.0.0/16 network uses a next hop of 10.10.0.1

ip route 10.10.0.1 255.255.255.255 Async104	

!--- the next hop for 10.10.0.1/32 (which is also the next hop for the 
!--- previous route) is interface Async104.

!
dialer-list 1 protocol ip permit

!--- All IP traffic is defined interesting.
!--- This is applied to Async104 using dialer-group 1.

!
!
line con 0
 exec-timeout 0 0
 password ww transport input none
line 33 38
line 97 103
 modem InOut transport input all
line 104		

!--- line interface configuration for Async 104

 modem InOut	

!--- allow incoming and outgoing modem calls on this line
	
 transport input all
 transport output lat pad v120 lapb-ta telnet rlogin udptn
 flowcontrol hardware
line aux 0
line vty 0 4
 password ww
 login
!
end

この 3600 シャーシでは、NM-8AM カードはスロット 3 にインストールされます。『Cisco 3600 Series Routers での非同期回線の番号設定』によると、スロット 3 には回線 97 から 128 が予約されています。 設定の必要がある特定非同インターフェイスを指定するには、show line コマンドで使用する回線を調べます。 この設定では、その範囲で使用可能なのは回線 97 ~ 104(8 回線)であることに注意してください。 したがって、最初のモデムをカードの設定回線 97(およびインターフェイス async97)に設定するには、最後のモデムは line/async104 になります。

確認

現在、この設定に使用できる確認手順はありません。

アナログ接続のトラブルシューティング

dialout 接続のトラブルシューティングには、次の手順を実行してください。

  1. モデムの設定を確認します。

    モデムの設定を確認します。 モデムに対応する回線とインターフェイス async を確認する必要があります。

  2. モデムにリバース Telnet し、dialout を開始します。

    ポートからモデムにリバース Telnet し、AT コマンド セットを使用してリモート デバイスにダイヤルおよび接続します。 これで、モデム ハードウェアおよび電話回線が機能していることが確認できます。 この例では、モデム ポートが回線 104 にあるので、ルータのポート 2104 にリバース Telnet します。 リバース Telnet についての詳細は、『モデムへのリバース Telnet セッションの確立』を参照してください。

    router1#telnet 10.200.20.51 2104 
    Trying 10.200.20.51, 2104  ... Open
    User Access Verification
    Username: admin
    Password: 
    
    !--- Authentication performed by local router for the reverse telnet
    
    at
    OK
    atdt 81690
    
    !--- The modem dials (81690) and connects.
    !--- This takes approximately 30-45 seconds.
    
    CONNECT 31200/ARQ/V34/LAPM/V42BIS
    
    !--- Connect speed and protocols that were negotiated
    
    User Access Verification
    Username: admin
    Password:
    
    !--- Authentication performed by remote router for the incoming call
     
    router2>
    
    !--- Remote router's prompt
    
    

    モデムの設定の確認には、その他の AT コマンドも適用できます。 アナログ モデム モジュールに使用できる AT コマンドの詳細については、『アナログ モデム ネットワーク モジュール用 AT コマンド セットとレジスタのサマリー』を参照してください。

  3. チャット スクリプトを手動で実行し、ダイヤルを開始します。

    チャット スクリプトを実行してダイヤルを開始するには、start-chat コマンドを使用します。 start-chat コマンドでは、実行するチャット スクリプトの名前、ダイヤルする電話番号、ダイヤル アウトをオンにするモデム インターフェイスを指定する必要があります。

  4. async インターフェイスへのルートの存在を確認します。

    async インターフェイスへのルートの存在を確認するには、show ip route コマンドを使用します。 ルートが存在しない場合は、スタティック ルートを作成します。 次に例を示します。

    ip route 10.10.0.1 255.255.255.255 Async104 
  5. ステップ 4 で指定された次のホップネットワークへの ping を生成します。

    ステップ 4 から次のホップネットワークを使用して指定したリモート ルータの ping によって、ルータはリモート デバイスにダイヤルします。

    router1#ping 10.10.0.1
    

接続のトラブルシューティング方法の詳細については、『発信コールのトラブルシューティング』を参照してください。

一般的なエラー

  • チャット スクリプト名が dialer map ステートメントで指定されたものと同じであることを確認します。 ダイヤルする電話番号が正しく指定されていることも確認します。

  • 対象トラフィックが正しく定義されていることを確認します。 対象トラフィックは dialer-list コマンドで指定します。

  • 対象トラフィック定義が async インターフェイスに適用されていることを確認します。 これは dialer-group コマンドを実行して行います。グループ番号は、dialer-list コマンドで指定された対象トラフィック定義と一致する必要があります。

  • PAP/CHAP 認証のユーザ名とパスワードが正しいことを確認します。

  • dialer map ステートメントの名前、IP アドレス、ダイヤルする電話番号が正しいことを確認します。

debug コマンド

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug dialer - dialer インターフェイスで受信されたパケットに関するデバッグ情報を表示します。 インターフェイスでダイヤルオンデマンド ルーティング(DDR)が有効になっている場合は、すべてのコールの原因(ダイヤリング原因といいます)に関する情報も表示されます。 詳細については、『Debug コマンド』ドキュメントの debug dialer 情報を参照してください。

  • debug modem - ルータのモデム回線のアクティビティ、モデム コントロール、プロセス起動メッセージを表示します。

  • debug chat - async/POTS ダイヤリングが開始された場合に、チャット スクリプトの実行を監視します。 『ダイヤルアップ テクノロジー: 詳細は、『トラブルシューティング テクニック』を参照してください。

  • debug ppp negotiation - リンク制御プロトコル(LCP)認証およびネットワーク制御プロトコル(NCP)を含む PPP コンポーネントをネゴシエートしている場合の PPP トラフィックに関する情報を表示します。 PPP ネゴシエーションが正常に行われると、最初に LCP 状態が開放され、次に認証、最後に NCP をネゴシエートします。

  • debug ppp authentication - チャレンジ ハンドシェイク認証プロトコル(CHAP)パケット交換およびパスワード認証プロトコル(PAP)交換などの PPP 認証プロトコル メッセージを表示します。

debug 出力例

router1#show debug
General OS:
  Modem control/process activation debugging is on
Dial on demand:
  Dial on demand events debugging is on
Generic IP:
  ICMP packet debugging is on
PPP:
  PPP protocol negotiation debugging is on
Chat Scripts:
  Chat scripts activity debugging is on
router1#
router1#ping 10.10.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.0.1, timeout is 2 seconds:
*Mar  1 00:22:58.663: As104 DDR: Dialing cause ip (s=10.10.0.2, d=10.10.0.1)

!--- Dialing reason is the ping for 10.10.10.1
!--- The dialout is using Async104.

*Mar  1 00:22:58.663: As104 DDR: Attempting to dial 8214

!--- Phone number to be dialed

*Mar  1 00:22:58.663: CHAT104: Attempting async line dialer script
*Mar  1 00:22:58.663: CHAT104: Dialing using Modem script: async & System script: none

!--- Use chat script named "async"

*Mar  1 00:22:58.663: CHAT104: process started
*Mar  1 00:22:58.667: CHAT104: Asserting DTR
*Mar  1 00:22:58.667: CHAT104: Chat script async started

!--- Chat-script "async" is started.

*Mar  1 00:22:58.667: CHAT104: Sending string: AT
*Mar  1 00:22:58.667: CHAT104: Expecting string: OK
*Mar  1 00:22:58.739: CHAT104: Completed match for expect: OK
*Mar  1 00:22:58.739: CHAT104: Sending string: ATDT\T<8214>
*Mar  1 00:22:58.739: CHAT104: Expecting string: CONNECT
*Mar  1 00:22:58.751: Modem 3/7 Mcom: in modem state 'Dialing/Answering'
*Mar  1 00:23:10.775: Modem 3/7 Mcom: in modem state 'Waiting for Carrier'
*Mar  1 00:23:21.903: Modem 3/7 Mcom: in modem state 'Connected'
*Mar  1 00:23:22.323: Modem 3/7 Mcom: CONNECT at 26400/24000(Tx/Rx), V34, LAPM, V42bis,
 Originate

!--- Connect speeds, protocols and so forth, and so on negotiated for the connection
!--- Note that the modem used is 3/7 which is equivalent to line 104.
!--- Refer to How Async Lines are Numbered in Cisco 3600 Series Routers.

*Mar  1 00:23:22.375: CHAT104: Completed match for expect: CONNECT
*Mar  1 00:23:22.375: CHAT104: Sending string: \c
*Mar  1 00:23:22.375: CHAT104: Chat script async finished, status = Success

!--- Chat script is successful. Notice the Expect/Send attributes and the time elapsed.

*Mar  1 00:23:22.375: Modem 3/7 Mcom: switching to PPP mode
*Mar  1 00:23:22.379: TTY104: no timer type 1 to destroy
*Mar  1 00:23:22.379: TTY104: no timer type 0 to destroy
*Mar  1 00:23:22.379: As104 IPCP: Install route to 10.10.0.1
*Mar  1 00:23:24.379: %LINK-3-UPDOWN: Interface Async104, changed state to up
*Mar  1 00:23:24.379: As104 DDR: Dialer statechange to up
*Mar  1 00:23:24.379: As104 DDR: Dialer call has been placed
*Mar  1 00:23:24.379: As104 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 00:23:24.379: As104 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
*Mar  1 00:23:24.379: Modem 3/7 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0
*Mar  1 00:23:24.379: As104 LCP: O CONFREQ [Closed] id 17 len 25
*Mar  1 00:23:24.379: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.379: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.379: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.379: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.379: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: I CONFREQ [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.543: As104 LCP: O CONFACK [REQsent] id 1 len 25
*Mar  1 00:23:24.543: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.543: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.543: As104 LCP:    MagicNumber 0x41B616FF (0x050641B616FF)
*Mar  1 00:23:24.543: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.543: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.555: As104 LCP: I CONFACK [ACKsent] id 17 len 25
*Mar  1 00:23:24.555: As104 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Mar  1 00:23:24.555: As104 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 00:23:24.559: As104 LCP:    MagicNumber 0x1090720F (0x05061090720F)
*Mar  1 00:23:24.559: As104 LCP:    PFC (0x0702)
*Mar  1 00:23:24.559: As104 LCP:    ACFC (0x0802)
*Mar  1 00:23:24.559: As104 LCP: State is Open

!--- LCP negotiation is complete.

*Mar  1 00:23:24.559: Modem 3/7 Mcom: PPP escape map: Tx map = A0000, Rx map = 0
*Mar  1 00:23:24.559: As104 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]

!--- Two-way PPP authentication begins.

*Mar  1 00:23:24.559: As104 CHAP: O CHALLENGE id 4 len 28 from "router1"
*Mar  1 00:23:24.691: As104 CHAP: I CHALLENGE id 1 len 28 from "router2"
*Mar  1 00:23:24.691: As104 CHAP: O RESPONSE id 1 len 28 from "router1"
*Mar  1 00:23:24.707: As104 CHAP: I RESPONSE id 4 len 28 from "router2"
*Mar  1 00:23:24.707: As104 CHAP: O SUCCESS id 4 len 4
*Mar  1 00:23:24.815: As104 CHAP: I SUCCESS id 1 len 4

!--- Incoming and outgoing CHAP authentication is successful.

*Mar  1 00:23:24.815: As104 PPP: Phase is UP [0 sess, 0 load]
*Mar  1 00:23:24.819: As104 IPCP: O CONFREQ [Closed] id 6 len 10
*Mar  1 00:23:24.819: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.835: As104 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 00:23:24.835: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.839: As104 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 00:23:24.839: As104 IPCP:    Address 10.10.0.1 (0x03060A0A0001)
*Mar  1 00:23:24.931: As104 IPCP: I CONFACK [ACKsent] id 6 len 10
*Mar  1 00:23:24.931: As104 IPCP:    Address 10.10.0.2 (0x03060A0A0002)
*Mar  1 00:23:24.931: As104 IPCP: State is Open

!--- IP Control Protocol (IPCP) negotiation is complete.

*Mar  1 00:23:24.931: As104 DDR: dialer protocol up
*Mar  1 00:23:25.379: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async104,
 changed state to up

!--- Interface is up.

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10316