ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

オーストラリアでのISDN BRI およびPRI 設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントは、オーストラリアに固有の ISDN の問題について説明します。 これは、Telco から入手できるさまざまな BRI および PRI サービスの設定例と情報が含まれています。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

関連製品

この設定は、BRI または PRI インターフェイスを搭載したルータで使用できます。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

BRI スイッチタイプの情報

オーストラリアの BRI にはサービス プロファイル識別子(SPID)は必要ありません。

2 つの ISDN スイッチタイプが使用できます。

  • basic-net3:現在最も一般的に使われています。

  • basic-ts013:MicroLink などの古い ISDN スイッチ用です。

PRI スイッチタイプとサービスの情報

オーストラリアでは 2 つのスイッチタイプを使用できます。

  • primary-net5:現在最も一般的に使われています(「Onramp」)。

  • primary-ts015:MacroLink などの古い ISDN スイッチ用です。

PRI ではさまざまなタイプのサービスも提供されます。

  • 10 の B チャネル(10 か。 一般に primary-net5 のオンランプ 10 として知られている 64 キロビット/秒) —。

    !
    controller E1 0
    pri-group timeslots 1-10,16
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !
  • 20 の B チャネル(20 か。 一般に primary-net5 のオンランプ 20 として知られている 64 キロビット/秒) —。

    !
    controller E1 0
    pri-group timeslots 1-21
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !
  • 30 の B チャネル(30 か。 一般に primary-net5 のオンランプ 30 として知られている 64 キロビット/秒) —。

    !
    controller E1 0
    pri-group timeslots 1-31
    !
    interface Serial0:15
    isdn switch-type primary-net5
    !

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/10227/isdn_australia.gif

設定

このドキュメントでは、オーストラリアの ISDN の設定を示します。 最初の設定は BRI 用で、次の 2 つが PRI 用です。

basic-net3 スイッチタイプによる BRI

!--- Configuration uses BRI0 linked to a dialer profile 1
!--- via dialer pool to dial out.

!
!
ip routing
!
isdn switch-type basic-net3 
! 
interface loopback0
ip address 10.10.10.1 255.255.255.0
!
interface BRI0 
 ip unnumbered loopback0
 encapsulation ppp 
 dialer pool-member 1    
 isdn switch-type basic-net3 
 ppp authentication chap pap
! 
interface Dialer1 
 ip address 192.168.12.1 255.255.255.0 
 encapsulation ppp 
 dialer remote-name AROP
 dialer string 0291191111 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap pap callin    
!
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer1    
! 
dialer-list 1 protocol ip permit 
!

primary-net5 スイッチタイプによる PRI

!--- Configuration uses PRI 30 x B-channels linked to a
!--- dialer profile 1 via dialer pool to dial out.

!
ip routing
! 
isdn switch-type primary-net5
! 
interface loopback0
 ip address 10.10.10.1 255.255.255.0
!
controller E1 0
 pri-group timeslots 1-31
!
interface Serial0:15
 ip unnumbered loopback0
 encapsulation ppp 
 dialer pool-member 1    
 isdn switch-type primary-net5
 ppp authentication chap pap 
! 
interface Dialer1 
 ip address 192.168.12.1 255.255.255.0 
 encapsulation ppp 
 dialer remote-name AROP
 dialer string 0291191111 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap pap callin    
!
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer1    
! 
dialer-list 1 protocol ip permit 
!

Cisco Mica モデムへのアナログ ダイヤルアップに使用される B チャネル 20 本の PRI

!--- Configuration uses PRI 20 x B-channels 
!--- to terminate up to 20 modem calls
!--- even though we have 30 modems. We are restricted 
!--- by the amount of B-channels.

!
!
ip routing
! 
isdn switch-type primary-net5 
! 
interface loopback0 
ip address 10.10.10.1 255.255.255.0 
! 
controller E1 0  
pri-group timeslots 1-21
!    
interface Serial0:15 
ip unnumbered loopback0 
encapsulation ppp 
isdn switch-type primary-net5 
isdn incoming voice-modem
ppp authentication chap pap 
! 
interface Group-Async 1
ip unnumbered loopback0
encapsulation ppp 
ppp authentication chap pap
async mode dedicated
peer default ip pool swim
group-range 1 30
!
ip local pool swim 192.168.1.1 192.168.1.20
!
line 1 30
modem inout
transport input all

確認

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

  • show isdn status:ルータが ISDN スイッチと正常に通信していることを確認します。 出力で、レイヤ 1 ステータスが ACTIVE、レイヤ 2 ステータスが state = MULTIPLE_FRAME_ESTABLISHED となっていることを検証します。 このコマンドは、通信中のコールの数も表示します。 詳細については、『show isdn status コマンドを使用した BRI のトラブルシューティング』を参照してください。

  • show dialer [interface type number]:ダイヤルオンデマンド ルーティング(DDR)に設定されたインターフェイスの一般的な診断情報を表示します。 ダイヤラが正常に始動すると、Dialer state is data link layer up というメッセージが表示されます。 physical layer up と表示される場合、回線プロトコルは立ち上がっていますが、Network Control Protocol(NCP)は立ち上がっていません。 ダイヤリングを開始したパケットのソース アドレスと宛先アドレスが、「Dial reason」の行に表示されます。 この show コマンドでは、タイマーの設定と、接続がタイムアウトするまでの時間も表示されます。

  • show caller user username detail:特定ユーザのパラメータ(割り当てられている IP アドレス、PPP および PPP バンドル パラメータなど)を表示します。 Cisco IOS のバージョンか。 ソフトウェアはこのコマンドを、使用します show user コマンドをサポートしません。

  • show dialer map:設定したダイナミックおよびスタティックのダイヤラ マップを表示します。 このコマンドは、ダイナミック ダイヤラ マップが作成済みかどうかを確認するときに使用できます。 ダイヤラ マップがないと、パケットを送信できません。

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

トラブルシューティング リソース

必要に応じて、次のトラブルシューティングのリソースを使用してください。

トラブルシューティングのためのコマンド

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug dialer:ダイヤラ インターフェイスで受信されたパケットに関する DDR デバッグ情報を表示します。 この情報により、ダイヤラ インターフェイスを使用できる対象トラフィックが存在することを確認できます。

  • debug isdn q931:ISDN ネットワーク接続(レイヤ 3)のコールの設定と切断を表示します。

  • debug modem:アクセス サーバ上のモデム回線動作を表示します。 モデム回線の状態が変化すると出力が表示されます。

  • debug modem csm:内部デジタル モデムを搭載するルータ上で発生した、コール スイッチング モジュール(CSM)の問題をトラブルシューティングする EXEC コマンドです。 このコマンドを使用すると、着信および発信のコールのスイッチングについて、完全なシーケンスをトレースできます。

  • debug ppp negotiation:Link Control Protocol(LCP)、認証、および NCP のネゴシエーション中の PPP トラフィックおよび交換に関する情報を表示します。 PPP ネゴシエーションが正常に行われると、最初に LCP 状態が開放され、次に認証、最後に NCP をネゴシエートします。 Maximum Receive Reconstructed Unit(MRRU)などのマルチリンク パラメータは、LCP ネゴシエーションの間に確立されます。

  • debug ppp authentication:Challenge Handshake Authentication Protocol(CHAP)パケット交換や Password Authentication Protocol(PAP)交換などの PPP 認証プロトコル メッセージを表示します。

  • debug ppp error:PPP 接続のネゴシエーションおよび動作に関するプロトコル エラーとエラー統計情報を表示します。


関連情報


Document ID: 10227