WAN : フレーム リレー

フローティング スタティック ルートを使用した WAN リンクのための ISDN バックアップ設定

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2009 年 7 月 17 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この設定例では、フローティング スタティック ルートと Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)を使用して、Integrated Services Digital Network(ISDN; サービス総合デジタルネットワーク)によるフレームリレー リンクのバックアップを設定する方法を示しています。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

この設定の作成とテストは、次のソフトウェアとハードウェアのバージョンで行われています。

  • Cisco 2503 ルータ

  • Cisco IOS(R) ソフトウェア リリース 12.2(7b) は両方のルータで動作していました

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

WAN リンクを実装する目的の 1 つは、リンクに障害が発生した場合にリンクをバックアップする手段を用意することです。 ISDN は、このバックアップ手段としてよく使用されます。 シスコは、同じ機能をさまざまな方法で実現するバックアップ戦略を提供します。 ルーティング情報がフレームリレー リンク経由で送信されている場合、フレームリレー リンクで情報の送信が停止した際には、フローティング スタティック ルートによりバックアップ リンクをアップ状態にすることができます。

次の例は、フローティング スタティック ルートを使用したフレームリレーのためのバックアップを示していますが、 この方法はあらゆる WAN リンクのバックアップに応用できます。

他のソリューションでは、バックアップ インターフェイス(『サブインターフェイスのためのバックアップ インターフェイスの設定』を参照)またはダイヤラ ウォッチの採用が可能です。 backup interface コマンドによる方法を使用する場合には、ポイントツーポイント サブインターフェイスを使用するのが有効です。これは、メイン インターフェイスまたはマルチポイント インターフェイスは、フレームリレーが原因で permanent virtual connection(PVC; 相手先固定接続)が停止した際にもアップ/アップ状態のまま残れるためです。

DDR バックアップの設定についての詳細は、『DDR バックアップの設定とトラブルシューティング』を参照してください。 また、さまざまな DDR バックアップ方法についての詳細は、『DDR バックアップのためのバックアップ インターフェイス、フローティング スタティック ルートおよびダイヤラ ウォッチの評価』も参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されるコマンドの詳細を調べるには、IOS 用の Command Lookup Tool を使用してください。

ネットワーク図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/10214/fr_isdn_backup.gif

設定

このドキュメントでは次に示す設定を使用しています。

この設定は、2500 シリーズのルータで Cisco IOS ソフトウェア リリース 12.2(7b) を使用してテストされています。 この設定概念は、この例と同様のルータ トポロジや Cisco IOS のその他のリリースにも適用されます。

Router1(Cisco 2503 ルータ)
Current configuration:

version 12.2
!
hostname Router1
!

!--- This username password pair is used for 
!--- PPP CHAP authentication

username Router2 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
!
interface Serial0

!--- Primary Link.
!--- The bandwidth is adjusted to allow for rapid backup of the link.


!--- This adjusts the EIGRP Hello interval and 
!--- Hold time for rapid convergence.
!--- The bandwidth command does not actually change the bandwidth of the link,
!--- it only adjusts the routing protocol bandwidth parameter.

 bandwidth 2048
 ip address 172.16.2.1 255.255.255.128
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0

! -- Backup link.

 ip address 172.16.3.1 255.255.255.0

! -- The backup link is in a different subnet.
! -- The BRI interface on the peer should also be in this subnet.

 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer map ip 172.16.3.2 name Router2 broadcast 5552000

! -- Dialer map for the peer. Note the IP address and name.
! -- The name must match the authenticated username of the peer.

 dialer load-threshold 5 either
 dialer-group 1

! -- Apply interesting traffic definition.
! -- Interesting traffic definition is defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink
!
router eigrp 100

!--- This example uses eigrp. 
!--- You can use any routing protocol instead.

 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.4.0 255.255.255.0 172.16.3.2 200

!--- The floating static route is defined.
!--- Note the administrative distance of the route is 200.
!--- Hence it is only used when all other routes for 172.16.4.0/24 
!--- are lost. Note that the next hop for the floating static route 
!--- matches the dialer map ip. If the nexthop is not the same as 
!--- in the dialer map then the router will no dial.

!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any

!--- EIGRP routing packets are denied in the dialer-list.


!--- This prevents eigrp packets from keeping the link up.
!--- Adjust the interesting traffic depending on your traffic definitions.

!
dialer-list 1 protocol ip list 100

!---  Interesting traffic defintion. Use access-list 100.
!---  The interesting traffic is applied to BRI interface 
!--- using dialer-group 1. 

!
line con 0
line aux 0
 transport input all
line vty 0 4
 login
!
end

ルータ 1 用にフローティング スタティック ルートが設定されました。 このフローティング スタティック ルートにはアドミニストレイティブ ディスタンス 200 が割り当てられています。 同じサブネットに対するルートは、Enhanced Interior Gateway Routing Protocol(EIGRP)を使用してフレームリレー リンク上で学習されます。EIGRP により、フローティング ルートの付加的機能や冗長性に関する機能が強化されます。 EIGRP で学習したルートは、ルーティング テーブルに組み込まれます。これは、このアドミニストレーティブ ディスタンスが 90 であり、スタティック ルートの 200 に比較して短いためです。 フレームリレー リンクに障害が発生した際には、EIGRP ルートがルーティング テーブルから消去され、フローティング スタティック ルートが組み込まれます。 ISDN 接続に送られる対象トラフィックによって、回線がアップ状態になります。 フレームリレー経由で接続が復旧すると、再びEIGRP を使用して経路が学習されます。 スタティック ルートがこのルートに切り替えられ、トラフィックが再びフレームリレー回線に転送されるようになります。

ルーティング プロトコルのトラフィックはダイヤラ リストでは対象外としてマークされるため、このトラフィックによって ISDN 回線が接続されたり、接続されたままになることはありません。 しかし、リンクがアップ状態になると、EIGRP パケットがリンクを通過できるようになり、2 台のルータがルーティング情報を交換できるようになります。 また、キーワード broadcast がダイヤラ マップの設定文に組み込まれているため、ルーティング プロトコル トラフィックは ISDN リンク上を通過できます。 ISDN リンクがアップ状態でも EIGRP によるルーティング情報の交換を行いたくない場合は、キーワード broadcast をダイヤラ マップの設定文に含めないでください。

dialer load-threshold コマンドにより、2 番目の B チャネルで同時にコールするための負荷が設定されます。 マルチリンク Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)が設定されているため(ppp multilink)、集約帯域幅を持つ 1 つのバーチャル アクセス インターフェイスとして両方の ISDN B チャネルを集束できます。

現在の設定では、Router1 だけがコールを発信するように設定されています。 ルータ 2 はルータ 1 からコールを受信します。 両側からリンクをアップ状態にする場合は、dialer map コマンドおよび dialer load-threshold コマンドを ルータ 2 の設定に追加します。

ルータ 2(Cisco 2503 ルータ)
Current configuration:

version 12.2
!
!
hostname Router2
!
username Router1 password 0 letmein
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
!
interface Ethernet0
 ip address 172.16.4.1 255.255.255.0
!
interface Serial0
 bandwidth 2048
 ip address 172.16.2.2 255.255.255.128
 encapsulation frame-relay
 clockrate 64000
!
interface Serial1
 no ip address
 shutdown
 clockrate 64000
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0

! -- IP address of backup interface.
! -- This router accepts the call. Note the IP address matches both the 
! -- dialer map floating static router nexthop on the peer.

 encapsulation ppp
 dialer-group 1
 isdn switch-type basic-5ess
 ppp authentication chap
 ppp multilink

!--- The missing dialer map command disables 
!--- this router from making the call.

!
router eigrp 100
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 172.16.1.0 255.255.255.0 172.16.3.1 200
!
access-list 100 deny   eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
line con 0
line aux 0
line vty 0 4
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

ルーティング テーブルの変化

特定の show コマンドは、アウトプットインタープリタでサポートされています。このツールを使用すると、show コマンドの出力を分析できます。

次の、ルータ 1 のルーティング テーブルを確認してください。 フレームリレー リンク上で Router2 が到達不可能になると、EIGRP で学習されたルートがフローティング スタティック ルートにより置き換えられます。

フレームリレー リンクがアップ状態での Router1 のルーティング テーブルは次のとおりです。

Router1#show ip route      
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS 
            inter area      
            * - candidate default, U - per-user static route, o - ODR 
            P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
      [D 172.16.4.0/2490/1787392] via 172.16.2.2, 00:06:56, Serial0
     
!---  EIGRP learned route over Frame Relay link 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

フレームリレー リンクでの接続が失われた場合には、次に示すように、Router1 が自身のルーティング テーブルにフローティング スタティック ルートを組み込みます。

Router1#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

     Gateway of last resort is not set 

     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks 
     S 172.16.4.0/24 [200/0] via 172.16.3.2 
     
!--- Floating static route. Administrative distance is 200 

     C 172.16.1.0/24 is directly connected, Ethernet0 
     C 172.16.2.0/25 is directly connected, Serial0 
     C 172.16.3.0/24 is directly connected, BRI0 
     Router1# 

ネットワーク 172.16.4.0/24 に送られる対象トラフィックによって、ISDN 接続が確立されます。 たとえば、Router1 から 172.16.4.1 に PING を送信すると、次に示すように ISDN リンクがアップ状態になります。

ルーティング プロトコルを対象にすると、散発的なトラフィックによってリンクが自動的にアップ状態になります。 この欠点は、リンクが無期限にアップ状態になり、通信料金が高額になる可能性があることです。

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
.!!!! 
Success rate is 80 percent (4/5), round-trip min/avg/max = 36/36/36 ms 
Router1# 
3d22h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
3d22h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
changed state to up 
3d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, 
changed state to up 
3d22h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552000 Router2 
Router1# 

ISDN リンクがアップ状態なので、EIGRP が ISDN 接続上でルーティング情報の交換を開始します。 これによって、Router1 が EIGRP ルートを自身のルーティング テーブルに組み込みます。このルートはネクストホップ 172.16.3.2 を指しています。

Router1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area 
       * - candidate default, U - per-user static route, o - ODR 
       P - periodic downloaded static route 

Gateway of last resort is not set 

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks 
D      172.16.4.0/24 [90/40537600] via 172.16.3.2, 00:00:17, BRI0

!--- EIGRP route learnt over the ISDN link 

C      172.16.3.2/32 is directly connected, BRI0 
C      172.16.1.0/24 is directly connected, Ethernet0 
C      172.16.2.0/25 is directly connected, Serial0 
C      172.16.3.0/24 is directly connected, BRI0 
Router1# 

対象トラフィックは、ISDN コールを開始するトラフィックで、dialer-list コマンドにより定義します。 上記の設定では、dialer-list は access-list 番号 100 を指しています。これにより EIGRP パケット以外のすべての IP パケットが許可されます。 これは、EIGRP パケット以外のすべての IP パケットによって、ISDN 接続をアップ状態にできることを意味します。 接続が確立されると、EIGRP を含むすべてのトラフィックがリンクを通過できるようになります。 ところが、dialer idle timer の間に ISDN リンクを通過する対象トラフィックがないと、リンクはダウン状態になり、EIGRP ルートは交換されなくなります。 この時点で、フローティング スタティック ルートが Router1 のルーティング テーブルに再び組み込まれます。

トラブルシューティング

フローティング スタティック ルートのトラブルシューティングについての詳細は、ドキュメント『DDR バックアップの設定とトラブルシューティング』を参照してください。 このドキュメントでは、次のような一般的な症状について説明しています。

  • プライマリ リンクがダウンした際にバックアップ リンクがダイヤルされない。

  • バックアップ リンクはダイヤルされるが、相手側に接続できない。

  • プライマリ リンクが回復したときにバックアップ リンクが非アクティブにならない。

  • プライマリ インターフェイスがダウンした際に、バックアップ リンクが不安定になる(フラップ状態になるなど)。

フレームリレー特有の問題のトラブルシューティングについては、『フレームリレー バックアップの設定』を参照してください。

バックアップ リンクのトラブルシューティングの際には、次のコマンドが役に立ちます。

  • debug dialer events:ダイヤルオンデマンド ルーティングの動作を確認します。

  • debug dialer packets:ダイヤラの対象トラフィック情報を表示します。

  • show ppp multilink:バックアップがアップ状態になった後にマルチリンクのステータスを確認します。

上記の debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

デバッグ出力

ルーティング プロトコルのトラフィック(EIGRP)は dialer list コマンドにより対象外としてマークされているため、このトラフィックによってリンクがアップしたり、アップ状態のままになったりすることはありません。 ただし、リンクがアクティブなときは、ルーティング更新が交換されます。 正常なトラフィックによってリンクをアップできるかどうかは、debug dialer packet コマンドによって確認できます。 出力を次に示します。

Router1#debug dialer packets 
Dial on demand packets debugging is on 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 -- failed, 
not connected 

!---  EIGRP packet does not bring up the link 

3d22h: BR0 DDR: cdp, 273 bytes, outgoing uninteresting (no list matched) 

次のように、対象トラフィック(このケースでは Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル))によってアイドル タイマーがリセットされ、リンクが維持されます。 非対象トラフィックは通過しますが、アイドル タイマーが時間切れになってもこのトラフィックによってリンクは維持されません。

Router1#ping 172.16.4.1 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 172.16.4.1, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/51/80 ms 
Router1# 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping) 

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=172.16.4.1), 100 bytes, 
outgoing interesting (list 100)

!--- ICMP packet (ping)

3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 
3d22h: BR0 DDR: ip (s=172.16.3.1, d=224.0.0.10), 60 bytes, 
outgoing uninteresting (list 100)

!--- EIGRP packet 

3d22h: BR0 DDR: sending broadcast to ip 172.16.3.2 

EIGRP パケットは対象外としてマークされていても ISDN リンクを通過します。これは対象 ICMP トラフィックによってすでに接続が確立されているためです。


関連情報


Document ID: 10214