ダイヤルとアクセス : ダイヤルオンデマンド ルーティング(DDR)

設定例: フローティング スタティック ルートとダイヤルオンデマンド ルーティングの使用

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2004 年 2 月 20 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントの目的は、フレーム リレー回線の障害に備え、リモート サイトにダイヤルしてトラフィックを搬送できるように、ISDN の基本速度インターフェイス(BRI)を設定することです。

BRI では Enhanced Interior Gateway Routing Protocol(EIGRP)は実行されません。 その代り、この資料の例は正常ならときだけ BRI 上のトラフィックをリダイレクトするのにフローティング スタティック ルートをルーティングしますフレームリレー 回線上の学習される直通 EIGRP を失われます使用します。

すべてのルータでは、ip classless が有効に なるようにして下さい。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

これらの設定は、設定の一部分です。

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

図 1:ネットワーク ダイアグラム

/image/gif/paws/10212/bri0-1.gif

設定

このドキュメントでは、次の設定を使用します。

  • ディストリビューション レイヤ ルータ 1

  • ディストリビューション レイヤ ルータ 2

  • アクセス レイヤ ルータ

  • リモート サイト ルータ

ルータ C194u は 2 台のディストリビューション レイヤ ルータのうちの 1 つです。 この例では、ルータ C194u はリモート サイトに対して BRI を使って接続します。 他方のディストリビューション レイヤ ルータ C194n は、シリアルインターフェースを使ったフレームリレー回線を使用しています。

ディストリビューション レイヤ ルータ 1
hostname c194u                                                    
!   

!--- Create a username for the router at the remote site. 

username c194s password 7 XXXXXXXX                                            
!                                                                               
ip subnet-zero                                                                  
isdn switch-type basic-dms100                                                   
!                                                                               
interface Loopback0                                                             
 ip address 192.168.11.141 255.255.255.252                                      
!                                                                               
interface Ethernet0                                                             
 ip address 163.241.222.93 255.255.255.0                                        
 media-type 10BaseT                                                             
!                                                                               
interface BRI0                                                                  
 description to Remote Site c194s, (this end 08358662 08358664)                 
 ip address 192.168.11.138 255.255.255.252                                      
 no ip mroute-cache                                                             
 encapsulation ppp                                                              
 no ip route-cache                                                              
 isdn spid1 0835866201                                                          
 isdn spid2 0835866401                                                          
 dialer idle-timeout 600                                                        
 dialer wait-for-carrier-time 10                                                
 dialer map ip 192.168.11.137 name c194s broadcast 8358661                      
 dialer map ip 192.168.11.137 name c194s broadcast 8358663                      
 dialer hold-queue 5                                                            
 dialer load-threshold 128  outbound                                            
 dialer-group 1                                                                 
 no fair-queue                                                                  
 ppp authentication chap                                                        
 ppp multilink                                                                  
!                                                                               
router eigrp 65535

!--- We redistribute the static routes listed below, so if the Frame Relay
!--- network fails, the other routers in this autonomous system (AS) will 
!--- begin to see the remote networks advertised from this router.  
!--- Normally these routes are learned through EIGRP across the Frame Relay link.
!--- Make the BRI interfaces passive. An alternative is to use a dialer-list 
!--- to identify EIGRP packets as "uninteresting" packets. 

redistribute static                                              
 passive-interface BRI0                                           
 network 192.168.11.0                                                           
 network 163.241.0.0                                                            
 default-metric 64 200 255 1 1500                                               
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless

!--- Both distribution layer routers have a default route to their Null 
!--- interfaces so that they advertise the 0/0 network to all other routers
!--- in the AS. 

ip route 0.0.0.0 0.0.0.0 Null0

!--- There must be a static route for each network behind the C194s 
!--- router at the remote site. Use the IP address of the BRI interface 
!--- of router C194s, and ensure that the administrative distance is 240.
!--- Note: Summarize these routes if your addressing scheme lends itself 
!--- to summarization. If the Frame Relay network fails, this will force 
!--- packets destined to the remote site out the BRI interface, and will cause 
!--- it to dial and restore connectivity.  

ip route 192.168.11.0 255.255.255.224 192.168.11.137 240          
ip route 192.168.11.32 255.255.255.224 192.168.11.137 240         
ip route 192.168.11.64 255.255.255.224 192.168.11.137 240         
ip route 192.168.11.132 255.255.255.252 192.168.11.137 240        
!                                                                               
access-list 100 deny   icmp any any                                             
access-list 100 permit ip any any                                            
dialer-list 1 protocol ip list 100                                              
!                                                                               
end

ルータ C194u のためのサンプル show dialer コマンド出力はここにあります:

ディストリビューション レイヤ ルータ 1
c194u#show dialer                                                                
                                                                                
BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last called   Last status
8358663                  4       1311    01:32:08           failed
8358661               1874       1315    00:02:07       successful
0 incoming call(s) have been screened. 
                                                                                
BRI0:1 - dialer type = ISDN
Idle timer (600 secs), Fast idle timer (20 secs)
Wait for carrier (5 secs), Re-enable (15 secs)
Dialer state is physical layer up
Dial reason: ip (s=192.168.11.138, d=192.168.11.137)

次のルータは、C194n、第 2 ディストリビューション レイヤルータのでです。 この実例では、それはフレームリンクルータです。 それは特別なコンフィギュレーションを持っていません。 それに EIGRP に再配布されるデフォルト ルートがありますただ。

ディストリビューション レイヤ ルータ 2
hostname c194n                                                    
!                                                                                
!                                                                               
interface Ethernet0                                                             
 ip address 163.241.222.98 255.255.255.0                                        
!                                                                               
interface Serial1                                                               
 no ip address                                                                  
 bandwidth 1544                                                                 
 no ip mroute-cache                                                             
 encapsulation frame-relay                                                      
 no fair-queue                                                                  
!                                                                               
interface Serial1.301 point-to-point                                            
 ip address 192.168.11.130 255.255.255.252                                      
 bandwidth 32                                                                   
 frame-relay interface-dlci 301                                                 
!                                                                               
router eigrp 65535                                                              
 redistribute static                                              
 network 192.168.11.0                                                           
 network 163.241.0.0                                                            
 default-metric 64 200 255 1 1500                                               
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless                                                                    
ip route 0.0.0.0 0.0.0.0 Null0                                    
!

次のルータ C194s はリモート サイト ルータで、アクセス レイヤ ルータです。 このルータは、ディストリビューション レイヤ ルータを経由してリモート ネットワークをバックボーンに接続します。

アクセス レイヤ ルータ
!                                                                               
hostname c194s                                                    
!

!--- Create a username for the distribution layer router.

username c194u password 7 XXXXXXXXX                                            
!                                                                               
isdn switch-type basic-dms100                                                   
!                                                                               
interface Loopback0                                                             
 ip address 192.168.11.133 255.255.255.252                                      
!                                                                               
interface Ethernet0                                                             
 ip address 192.168.11.2 255.255.255.224                                        
!                                                                               
interface Serial0                                                               
 no ip address                                                                  
 bandwidth 64                                                                   
 encapsulation frame-relay                                                      
!                                                                               
interface Serial0.300 point-to-point                                            
 ip address 192.168.11.129 255.255.255.252                                      
 bandwidth 32                                                                   
 frame-relay interface-dlci 300                                                 
!                                                                               
interface BRI0                                                                  
 description to Hub Site c194u, (this end 08358661 08358663)                    
 ip address 192.168.11.137 255.255.255.252                                      
 no ip mroute-cache                                                             
 encapsulation ppp                                                              
 no ip route-cache                                                              
 isdn spid1 0835866101                                                          
 isdn spid2 0835866301                                                          
 dialer idle-timeout 600                                                        
 dialer wait-for-carrier-time 10                                                
 dialer map ip 192.168.11.138 name c194u broadcast 8358662                      
 dialer map ip 192.168.11.138 name c194u broadcast 8358664                      
 dialer hold-queue 5                                                            
 dialer load-threshold 128                                                      
 dialer-group 1                                                                 
 no fair-queue                                                                  
 ppp multilink                                                                  
 ppp authentication chap                                                        
!                                                                               
router eigrp 65535

!--- Redistribute the static route, so any routers which you could have attached 
!--- to the Ethernet network 192.168.11.0/27 will see this router as their way 
!--- out to the remainder of the network. However, do not allow this default 
!--- route back into your distribution layer routers. Use a distribute list 
!--- to block the advertisement.

redistribute static                                              
 passive-interface BRI0                                           
 network 192.168.11.0                                                           
 default-metric 64 200 255 1 1500
 distribute-list 2 out Serial0.300                                              
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless

!--- Use the IP address of the BRI interface of the distribution layer router to 
!--- Add a default route. When the frame network goes down, this will 
!--- push your traffic out the BRI interface, and cause it to dial and
!--- restore connectivity. 

ip route 0.0.0.0 0.0.0.0 192.168.11.138 240                       
!                                                                               
access-list 1 permit any                                                        
!           
access-list 2 deny   0.0.0.0
access-list 2 permit any  
!                                                                    
dialer-list 1 protocol ip list 1                                                
!                                                                               
end                                                                             
!

次のルータはリモート サイト ネットワークを表しています。 ここでは、アクセス レイヤ ルータの IGP ダイナミック ルーティング プロトコルである EIGRP を動作させることを除いて、特別な設定は不要です。

リモート サイト ルータ
hostname c194ec                                                   
!                                                                                
!                                                                               
interface Loopback0                                                             
 ip address 192.168.11.65 255.255.255.224                                       
!                                                                               
interface Ethernet0                                                             
 ip address 192.168.11.1 255.255.255.224                                        
!                                                                               
interface Ethernet1                                                             
 ip address 192.168.11.33 255.255.255.224                                       
!                                                                               
!                                                                               
router eigrp 65535                                                              
 network 192.168.11.0                                                           
 default-metric 64 200 255 1 1500                                               
 no auto-summary                                                                
 eigrp log-neighbor-changes                                                     
!                                                                               
ip classless                                                                    
!                                                                               
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

フレームリレーネットワークによって、リモートサイトでネットワークからの traceroute を試みて下さい。 ネットワークダイアグラムに基づく(図を、ターゲットIP アドレスですハブサイトルータのループバックインターフェイス 1)参照して下さい。

c194ec#trace                                                                    
Target IP address: 192.168.11.141 
Source address: 192.168.11.65 
Tracing the route to 192.168.11.141 

  1 192.168.11.2 4 msec 4 msec 4 msec 
  2  *  *  * 
  3  *  *  
    192.168.11.138 24 msec

複数のパケットが BRI インターフェイスを得るようにどのように要求したか表記。 BRI が非アクティブ行き、パケットが失われる前に、traceroute コマンドを再度発行して下さい:

c194ec#traceroute 192.168.11.141 

Tracing the route to 192.168.11.141 

  1 192.168.11.2 4 msec 4 msec 4 msec 
  2 192.168.11.138 20 msec *  20 msec 

フレーム スイッチを再度始動して下さい。 操作上今フレームリレーネットワークによって ISDN を使用しません:

c194ec#traceroute 192.168.11.141
Tracing the route to 192.168.11.141 

  1 192.168.11.2 4 msec 4 msec 4 msec 
  2 192.168.11.130 36 msec 36 msec 32 msec 
  3 163.241.222.93 36 msec *  32 msec

稼働状態のフレームリレー ネットワークのルーティング テーブルを次に示します。 個々のルートがハブサイトでネットワークのための EIGRP によって学習されるどのようにか表記。 また学ばれる EIGRP によるデフォルト ルートがあります。

c194ec#show ip route  

Gateway of last resort is 192.168.11.2 to network 0.0.0.0 

     163.241.0.0 255.255.255.0 is subnetted, 1 subnets 
D       163.241.222.0 [90/2221056] via 192.168.11.2, 00:02:09, Ethernet0 
     192.168.11.0 is variably subnetted, 7 subnets, 2 masks 
C       192.168.11.64 255.255.255.224 is directly connected, Loopback0 
C       192.168.11.32 255.255.255.224 is directly connected, Ethernet1 
C       192.168.11.0 255.255.255.224 is directly connected, Ethernet0 
D       192.168.11.128 255.255.255.252 
           [90/2195456] via 192.168.11.2, 00:02:13, Ethernet0
D       192.168.11.132 255.255.255.252
           [90/409600] via 192.168.11.2, 01:23:14, Ethernet0 
D       192.168.11.136 255.255.255.252 
           [90/40537600] via 192.168.11.2, 01:23:14, Ethernet0 
D       192.168.11.140 255.255.255.252 
           [90/2349056] via 192.168.11.2, 00:02:10, Ethernet0 
D*EX 0.0.0.0 0.0.0.0 [170/40614400] via 192.168.11.2, 00:02:10, Ethernet

フレームリレー ネットワークがダウンしたときのルーティング テーブルを次に示します。 デフォルト ルートは依然として存在しますが、ハブ サイトの向こう側にあるネットワークの個々の経路がいくつか喪失しています。 しかし ip classless が有効に なる、およびあなたデフォルト ルートを、まだネットワークでどこでも得ることができますので持って下さい。

c194ec#show ip route 

Gateway of last resort is 192.168.11.2 to network 0.0.0.0 

     192.168.11.0 is variably subnetted, 5 subnets, 2 masks 
C       192.168.11.64 255.255.255.224 is directly connected, Loopback0 
C       192.168.11.32 255.255.255.224 is directly connected, Ethernet1 
C       192.168.11.0 255.255.255.224 is directly connected, Ethernet0  
D       192.168.11.132 255.255.255.252 
           [90/409600] via 192.168.11.2, 01:25:27, Ethernet0 
D       192.168.11.136 255.255.255.252
           [90/40537600] via 192.168.11.2, 01:25:27, Ethernet0
D*EX 0.0.0.0 0.0.0.0 [170/40076800] via 192.168.11.2, 00:00:15, Ethernet

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10212