サービス品質(QoS) : QoS ポリシング

イーサネット サブインターフェイスへの QoS 機能の適用

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 8 月 10 日) | 英語版 (2015 年 4 月 22 日) | フィードバック


目次


概要

この資料に Class-Based Weighted Fair Queueing (CBWFQ)および他の Cisco IOS を加える方法を記述されていますか。 イーサネット サブインターフェイスのソフトウェアベースの Quality of Service (QoS) 機能。 イーサネット サブインターフェイスは、Cisco IOSの論理インターフェイスです。 Modular QoS CLI(MQC; モジュラQoSコマンドライン インターフェイス)を使用して、サービス ポリシーを作成し、イーサネット サブインターフェイスに適用することができます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS ソフトウェア 12.2(2)T

  • ファスト イーサネット ネットワーク モジュールを搭載したCisco 2620 ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

サービスポリシーを適用する方法

一般的に、ポリシーをどこに適用するかは、ポリシーによってアクティブ化するQoS機能に応じて異なります。 イーサネット サブインターフェイスは、次の機能をサポートしています。

  • クラスベース ポリシング — police コマンドを使用してインターフェイスとサブインターフェイスの両方にポリシーを適用した場合、クラスと一致するトラフィックに対して、サブインターフェイスのポリサーだけがアクティブになります。 詳細については、『トラフィック ポリシング』を参照してください。

  • クラスベース マーキング:詳細については、『分類の概要』を参照してください。

  • クラスベース シェーピング:詳細については、『クラスベースのシェーピングの設定』を参照してください。

  • クラスベース キューイング:イーサネット サブインターフェイスの場合、キューイングは特殊なケースです。 詳細については、次の記述を参照してください。

インターフェイスから送出する必要があるパケットの数がそのインターフェイスの出力レートを超えると、ルータではパケットのキューイングが開始されます。 超過パケットはキューに保管されます。 送信待機パケットには、キューイング方式を適用できます。

Cisco IOS の論理インターフェイスでは、本質的な理由で輻輳状態をサポートせず、キューイング方法を適用するサービス ポリシーの直接的な適用もサポートしていません。 その代り、最初に Generic Traffic Shaping (GTS)かクラス ベース の シェーピングを使用してサブインターフェイスにシェーピングを適用する必要があります。 詳細については、『ポリシングとシェーピング』を参照してください。

キューイングを適用するサービス ポリシーをシェーピングを適用せずにイーサネット サブインターフェイスに設定すると、次のログメッセージがルータに表示されます。

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
 CBWFQ : Not supported on subinterfaces

ギガビット イーサネット サブインターフェイスの場合も同じです。

c7400(config)# interface gig0/0.1
c7400(config-subif)# service-policy ou
c7400(config-subif)# service-policy output outFE
  CBWFQ : Not supported on subinterfaces

すなわち、親レベルでshape コマンドを使用し、階層化ポリシーを設定する必要があります。 下位レベルでは、CBWFQの場合は bandwidth コマンド、Low Latency Queueing (LLQ; 低遅延キューイング)の場合は priority コマンドを使用します。 クラスベース シェイピングは出力レートを制限するので、(想定では)論理サブインターフェイス上で輻輳ステートが発生しやすくなります。 次に、サブインターフェイスで「バックプレッシャ」が適用され、シェイパで保留されている過剰パケットのキューイングが Cisco IOS により開始されます。

階層型ポリシーの適用

階層化ポリシーを適用する手順は、次のとおりです。

  1. 子レベルまたは下位レベルのポリシーを作成し、キューイング方式を設定します。 次の例では、priority コマンドを使用してLLQを設定し、bandwidth コマンドを使用してCBWFQを設定しています。 詳細については、『輻輳管理の概要』を参照してください。

    policy-map child 
     class voice 
      priority 512
  2. 親レベルまたは上位レベルのポリシーを作成し、クラスベース シェイピングを適用します。 子クラスのアドミッション制御は親クラスのシェイピング レートに基づいて実行されるので、親ポリシーの下のコマンドとして子ポリシーを適用します。

    policy-map parent
     class class-default 
      shape average 2000000 
      service-policy child 
  3. サブインターフェイスに親ポリシーを適用します。

    interface ethernet0/0.1
     service-policy parent 

クラスベース シェーピングの設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

設定

ルータ 2620A
hostname 2620A 
! 
ip cef 
! 
class-map match-any dscp46 
 match ip dscp 46 
class-map match-all telnet_ping_snmp 
 match access-group 150 
class-map match-all http 
 match access-group 154 
class-map match-all pop3_smtp 
 match access-group 153 
! 
! 
policy-map voice_traffic 
 class dscp46 
  shape average 30000 10000 
 class telnet_ping_snmp 
  shape average 20000 15440 
 class pop3_smtp 
  shape average 20000 15440 
 class http 
  shape average 20000 15440 
! 
interface FastEthernet0/0 
 ip address 10.10.247.2 255.255.255.0 
 duplex auto 
 speed auto 
! 
interface FastEthernet0/0.1 
 encapsulation dot1Q 1 native 
 ip address 10.1.1.1 255.255.255.0 
 service-policy output voice_traffic

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、アウトプット インタープリタでサポートされています。このツールを使用すると、show コマンド出力を分析できます。

  • show policy-map {policy name}:指定されたサービス ポリシー マップのすべてのクラスの設定を表示します。

    2620A# show policy-map voice_traffic 
    Policy Map voice_traffic 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000 
    Class telnet_ping_snmp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class pop3_smtp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class http 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    
    2620A# show policy-map voice_traffic class dscp46 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000
  • show policy-map interface fast — 指定したサービス ポリシー マップについて、全クラスのマッチ カウンタを表示します。

    2620A# show policy-map interface fa0/0.1 
    FastEthernet0/0.1 
    Service-policy output: voice_traffic 
    Class-map: dscp46 (match-any) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: ip dscp 46 
    0 packets, 0 bytes 
    5 minute rate 0 bps 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    30000     2500   10000     10000     333       1250      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: telnet_ping_snmp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 150 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: pop3_smtp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 153 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: http (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 154 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: class-default (match-any) 
    926 packets, 88695 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: any

注: クラスベース シェイピングは、インターフェイスおよびサブインターフェイス レベルで動作します。 IOS 12.2(2.5) には、メイン インターフェイスおよびサブインターフェイスのIPアドレスにシェイピングを設定できる機能があります。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 10104