LAN スイッチング : VLAN

Catalyst スイッチでのイーサネット VLAN の作成

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 9 月 23 日) | 英語版 (2015 年 10 月 20 日) | フィードバック


目次


概要

この資料は方法で基本情報を Catalyst OS (CatOS)および Cisco IOS を実行する Catalyst スイッチの VLAN を作成する提供したものですか。 トラブルシューティング」)を参照してください。 各セクションのコマンド例では、それぞれのセクションで、1 台の Catalyst スイッチの設定が使用されています。

前提条件

要件

シスコでは、このセクション内の情報についての知識があることを推奨します。

VLAN は、物理的な距離に関係なく、ネットワーク管理者が単一のスイッチまたは複数のスイッチにまたがる論理的なブロードキャスト ドメインを作成するためのメカニズムです。 この機能は、ブロードキャスト ドメインのサイズを縮小したり、物理的に同じ場所にいる必要がないグループやユーザを論理的にグループ化するのに役立ちます。

VLAN を作成するためには、次の項目の設定方法を決定する必要があります。

  • スイッチ上で、どの VLAN Trunk Protocol ドメイン名と VTP モードを使用するか

  • スイッチのどのポートが、どの VLAN に属するか

  • VLAN 間で通信する必要があるか、または VLAN を互いに切り離すか

    VLAN 間の通信が必要な場合は、外部のシスコ製ルータや内部のルータ モジュールなど、レイヤ 3 のルーティング デバイスを使用する必要があります。 次に例を示します。

    • スーパーバイザ エンジン I およびスーパーバイザ エンジン II を搭載する Catalyst 4500/4000 スイッチ用の WS-X4232-Layer 3 カード

    • Catalyst 5500/5000 スイッチ用の Route Switch Module(RSM; ルート スイッチ モジュール)または Route Switch Feature Card(RSFC; ルート スイッチ フィーチャ カード)

    • Catalyst 6500/6000 スイッチ用の Multilayer Switch Module(MSM; マルチレイヤ スイッチ モジュール)または Multilayer Switch Feature Card(MSFC; マルチレイヤ スイッチ フィーチャ カード)

    一部のスイッチでは、インター VLAN ルーティングを行うためのサポートがソフトウェアとハードウェアに組み込まれています。 インター VLAN ルーティングでは、外部のデバイス、モジュール、またはドーター カードは必要ありません。 そのようなスイッチの例を次に示します。

    • スーパーバイザ エンジン 720 を搭載した Catalyst 3550/3750/6500

    • スーパーバイザ エンジン II+、スーパーバイザ エンジン III、およびスーパーバイザ エンジン IV を搭載する Catalyst 4500/4000

MSFC、RSM、RSFC、または外部ルータにおけるインター VLAN ルーティングの設定についての詳細は、次のドキュメントを参照してください。

このドキュメントでは、コンソールまたは Telnet アクセスを通じて、スイッチへの基本的な接続が確立されていることを前提としています。 スイッチへの基本的な接続を確立する方法の詳細については、次のドキュメントを参照してください。

使用するコンポーネント

このドキュメントの情報は、次のハードウェアとソフトウェアのバージョンに基づくものです。

  • CatOS 5.5(x) ソフトウェアが稼働している Catalyst 6009 スイッチ

  • Cisco IOS ソフトウェア リリース 12.0(5.x)XU が稼働している Catalyst 3524XL スイッチ

  • Cisco IOS ソフトウェア リリース 12.1(13)EW1 が稼働し、スーパーバイザ エンジン IV(WS-X4515)が装着された Catalyst 4507 スイッチ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

関連製品

このドキュメントの情報は、次のスイッチにも適用できます。

  • Catalyst 4500/4000/2948G/2980G/4912G スイッチ

  • Catalyst 5000/2926G シリーズ スイッチ

  • Catalyst 6500/6000 シリーズ スイッチ

  • Catalyst 2900XL/3500XL/2950/3550/3750 スイッチ

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

CatOS と Cisco IOS システム ソフトウェアの違い

スーパーバイザ エンジン上の CatOS と MSFC 上の Cisco IOS ソフトウェア(ハイブリッド): CatOS イメージをシステム ソフトウェアとして使用し、Catalyst 6500/6000 スイッチ上でスーパーバイザ エンジンを稼働させることができます。 オプションの MSFC が取り付けられている場合、MSFC を稼働させるために、別途、Cisco IOS ソフトウェア イメージを使用します。

スーパーバイザ  エンジンおよび MSFC 上の Cisco IOS  ソフトウェア(ネイティブ): 単一の Cisco IOS ソフトウェア イメージをシステム ソフトウェアとして使用し、スーパーバイザ エンジンおよび MSFC を Catalyst 6500/6000 スイッチ上で稼働させることができます。

詳細は、『Cisco Catalyst 6500 シリーズ スイッチのための Cisco Catalyst オペレーティング システムと Cisco IOS オペレーティング システムの比較』を参照してください。

CatOS が稼働する Catalyst スイッチでの VLAN の設定

VLAN とポートの作成

VLAN を作成するには、このセクションの手順を実行します。

VLAN を作成する前に、スイッチを VTP サーバ モードまたは VTP 透過モードにする必要があります。 スイッチが VTP サーバの場合は、VLAN を追加する前に VTP ドメイン名を定義する必要があります。

  1. VTP ドメイン名の定義

    VTP ドメイン名は、次の要件には関係なく定義する必要があります。

    • ネットワーク内のスイッチ数(1 つか複数か)

    • ネットワーク内の他のスイッチへの VLAN 伝播に VTP を使用するか

    スイッチでの、デフォルトの VTP 設定を次に示します。

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    ドメイン名とモードを設定するため、set vtp コマンドを発行します。

    CatosSwitch> (enable)set vtp domain ?
    
      <name>                     Domain name
    
    CatosSwitch> (enable)set vtp domain cisco ?
    
      mode                       Set VTP mode
      passwd                     Set VTP password
      pruning                    Set VTP pruning
      v2                         Set VTP version 2
    
    CatosSwitch> (enable)set vtp domain cisco mode ?
    
      client                     VTP client mode
      server                     VTP server mode
      transparent                VTP transparent mode
    
    CatosSwitch> (enable)set vtp domain cisco mode server
    
    VTP domain cisco modified

    VTP についての詳細は、『VLAN Trunk Protocol(VTP)について』参照してください。

  2. VTP 設定を確認するため、show vtp domain コマンドを発行します。

    CatosSwitch> (enable)show vtp domain
    
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           server      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    5          1023             1               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    0.0.0.0         disabled disabled 2-1000

    ご使用の Cisco デバイスの、show vtp domain コマンドの出力データがあれば、アウトプットインタープリタ登録ユーザ専用)を使用して今後予想される障害と修正を表示できます。

  3. VTP ドメインの設定と確認が済んだら、スイッチでの VLAN の作成を開始します。

    デフォルトでは、すべてのポートに対して VLAN は 1 つだけです。 この VLAN を default と呼びます。 VLAN 1 は名前の変更も削除もできません。

    管理ドメイン内に設定されたすべての VLAN のパラメータを表示するには、show vlan コマンドを発行します。

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/1-48
                                                            4/1-16
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      ibm  -        0      0
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    1    static     disabled
    1002 static     disabled
    1003 static     disabled
    1004 static     disabled
    1005 static     disabled
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
    1003 7       7       off
    1. VLAN を作成するには、set vlan コマンドを発行します。

      CatosSwitch> (enable)set vlan
      
      Usage: set vlan <vlan> <mod/port>
             (An example of mod/port is 1/1,2/1-12,3/1-2,4/1-12)
             set vlan <vlan_num> [name <name>] [type <type>] [state <state>]
                                 [pvlan-type <pvlan_type>]
                                 [said <said>] [mtu <mtu>]
                                 [ring <hex_ring_number>]
                                 [decring <decimal_ring_number>]
                                 [bridge <bridge_number>] [parent <vlan_num>]
                                 [mode <bridge_mode>] [stp <stp_type>]
                                 [translation <vlan_num>] [backupcrf <off|on>]
                                 [aremaxhop <hopcount>] [stemaxhop <hopcount>]
                                 [rspan]
             (name = 1..32 characters, state = (active, suspend)
              type = (ethernet, fddi, fddinet, trcrf, trbrf)
              said = 1..4294967294, mtu = 576..18190
              pvlan-type = (primary,isolated,community,none)
              hex_ring_number = 0x1..0xfff, decimal_ring_number = 1..4095
              bridge_number = 0x1..0xf, parent = 2..1005, mode = (srt, srb)
              stp = (ieee, IBM, auto), translation = 1..1005
              hopcount = 1..13)
      Set vlan commands:
      ----------------------------------------------------------------------------
      set vlan                     Set vlan information
      set vlan mapping             Map an 802.1q vlan to an Ethernet vlan
      
      CatosSwitch> (enable)set vlan 2 name cisco_vlan_2
      
      Vlan 2 configuration successful
    2. VLAN の設定を確認するには、show vlan コマンドを発行します。

      CatosSwitch> (enable)show vlan
      
      VLAN Name                             Status    IfIndex Mod/Ports, Vlans
      ---- -------------------------------- --------- ------- --------------------
      1    default                          active    5       1/1-2
                                                              3/1-48
                                                              4/1-16
      2    cisco_vlan_2                     active    75      
      1002 fddi-default                     active    6       
      1003 token-ring-default               active    9       
      1004 fddinet-default                  active    7       
      1005 trnet-default                    active    8       
      
      
      VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
      ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
      1    enet  100001     1500  -      -      -      -    -        0      0
      2    enet  100002     1500  -      -      -      -    -        0      0
      1002 fddi  101002     1500  -      -      -      -    -        0      0
      1003 trcrf 101003     1500  -      -      -      -    -        0      0
      1004 fdnet 101004     1500  -      -      -      -    -        0      0
      1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
      
      !--- Output suppressed.
      
      
    3. VLAN にポートを追加する場合は、set vlan vlan_number mod/ports コマンドを発行します。

      CatosSwitch> (enable)set vlan 2 3/1-12
      
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      2     3/1-12
            15/1

      1 つのコマンドにすべての情報を指定して、VLAN の作成と VLAN へのポートの追加を一度に行うこともできます。

      たとえば、3 番目の VLAN を作成し、その VLAN に 3/13 から 3/15 のポートを割り当てる場合は、次のコマンドを発行します。

      CatosSwitch> (enable)set vlan 3 3/13-15
      
      Vlan 3 configuration successful
      VLAN 3 modified.
      VLAN 1 modified.
      VLAN  Mod/Ports
      ---- -----------------------
      3     3/13-15
            15/1
  4. VLAN の設定を確認するには、show vlan コマンドを発行します。

    CatosSwitch> (enable)show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    5       1/1-2
                                                            3/16-48
                                                            4/1-16
    2    cisco_vlan_2                     active    75      3/1-12
    3    VLAN0003                         active    76      3/13-15
    1002 fddi-default                     active    6
    1003 token-ring-default               active    9
    1004 fddinet-default                  active    7
    1005 trnet-default                    active    8
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    1    enet  100001     1500  -      -      -      -    -        0      0
    2    enet  100002     1500  -      -      -      -    -        0      0
    3    enet  100003     1500  -      -      -      -    -        0      0
    1002 fddi  101002     1500  -      -      -      -    -        0      0
    1003 trcrf 101003     1500  -      -      -      -    -        0      0
    1004 fdnet 101004     1500  -      -      -      -    -        0      0
    1005 trbrf 101005     1500  -      -      -      IBM  -        0      0
    
    !--- Output suppressed.
    
    

ポートまたは VLAN の削除

VLAN からポートを削除するには、set vlan vlan_number mod/ports コマンドを発行して、そのポートを別の VLAN に設定します。 すべてのポートは初期状態では VLAN 1 に属しているため、ポートを任意の VLAN に割り当てることで実質的に削除されることになります。

VLAN を削除するには、clear vlan コマンドを発行します。 VLAN に属していたポートは VLAN の削除後もその VLAN のメンバのままであり、その VLAN は存在しないため、無効になります。 スイッチに警告が表示されるため、そこで現在の要求を取り消すことができます。

CatosSwitch> (enable)clear vlan 3

This command will deactivate all ports on vlan 3
in the entire management domain.
Do you want to continue(y/n) [n]? y

Vlan 3 deleted

CatosSwitch> (enable)show vlan

VLAN Name                             Status    IfIndex Mod/Ports, Vlans
---- -------------------------------- --------- ------- ------------------------
1    default                          active    5       1/1-2
                                                        3/16-48
                                                        4/1-16
2    cisco_vlan_2                     active    75      3/1-12
1002 fddi-default                     active    6
1003 token-ring-default               active    9
1004 fddinet-default                  active    7
1005 trnet-default                    active    8

VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
1    enet  100001     1500  -      -      -      -    -        0      0
2    enet  100002     1500  -      -      -      -    -        0      0
1002 fddi  101002     1500  -      -      -      -    -        0      0
1003 trcrf 101003     1500  -      -      -      -    -        0      0
1004 fdnet 101004     1500  -      -      -      -    -        0      0
1005 trbrf 101005     1500  -      -      -      IBM  -        0      0

!--- Output suppressed.

ポート 3/13 から 3/15 は VLAN 3 の削除によって無効にされるため、show vlan コマンドの出力にこれらのポートは表示されません。 これらのポートは、別の VLAN に追加し直すまで表示されません。

トラブルシューティングのヒント

このセクションでは、CatOS が稼働する Catalyst スイッチで VLAN を作成するときによく起こる問題について、トラブルシューティングのヒントを紹介しています。

  • VTP ドメイン名が未定義の状態で VLAN を作成すると、次のエラー メッセージが表示されます。

    Cannot add/modify VLANs on a VTP server without a domain name.

    この問題を解決するには、スイッチ上で VTP ドメイン名を作成します。 「VLAN とポートの作成」の項に、この手順が記載されています。

  • VTP クライアント モードのスイッチで VLAN を作成すると、次のエラー メッセージが表示されます。

    Cannot add/modify VLANs on a VTP client.

    VLAN を作成できるのは、VTP サーバ モードまたは VTP 透過モードのスイッチに限られます。 VTP についての詳細は、『VLAN Trunk Protocol(VTP)について』参照してください。

  • show port mod/port コマンドの出力では、ポートは inactive の状態にあります。 この状態は、ポートが元々属していた VLAN が削除されたことを示すもので、通常は VTP が原因です。 この場合は、その VLAN を再作成するか、または VLAN が VTP ドメイン内に再確立されるように VTP 設定を修正します。 show port mod/port コマンド出力例を次に示します。

    CatosSwitch> (enable)show port 3/1
    
    Port  Name               Status     Vlan       Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ----- ------------
     3/1                     inactive   2            auto  auto 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status     InlinePowered     PowerAllocated
                                       Admin Oper   Detected mWatt mA @42V
    ----- ------------- -------------- ----- ------ -------- ----- --------
     3/1  none          none           -     -      -        -     -
    
    !--- Output suppressed.
    
    

    ご使用の Cisco デバイスの、show-tech support コマンドの出力データがあれば、アウトプットインタープリタ登録ユーザ専用)を使用して今後予想される障害と修正を表示できます。

    CatosSwitch> (enable)show vlan 2
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN Type  SAID       MTU   Parent RingNo BrdgNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ ------ ---- -------- ------ ------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN DynCreated  RSPAN
    ---- ---------- --------
    Unable to access VTP Vlan 2 information.
    
    
    VLAN AREHops STEHops Backup CRF 1q VLAN
    ---- ------- ------- ---------- -------
  • ルーティング モジュール(RSM、RSFC、MSM、または MSFC)で作成される VLAN インターフェイスがオンになるのは、対応する VLAN をスイッチで使用できる場合だけです。 VLAN インターフェイスが完全にアクティブになる、つまり VLAN インターフェイスが管理上アップ状態になり回線プロトコルがアップ状態になるには、少なくとも 1 つのポートが VLAN のメンバであり、そのポートにアクティブなデバイスが接続されている必要があります。 設定のガイドラインについては、このドキュメントの「要件」セクションを参照してください。

Catalyst 2900XL、3500XL、2950、2970、および 2940 シリーズ スイッチでの VLAN の設定

VLAN とポートの作成

このセクションに記載するコマンド出力と実際の出力は、一部異なる場合があります。 この違いは、スイッチのモデルによるものです。

VLAN を作成するには、次の手順を実行します。

  1. ネットワークで VTP を使用するかどうかを決定します。

    VTP を使用すると、1 台のスイッチで設定変更を一元的に行い、その変更内容をネットワーク上の他のスイッチすべてに自動的に送信できます。 Catalyst 2900XL、3500XL、2950、2970、および 2940 スイッチのデフォルトの VTP モードはサーバ モードです。 VTP についての詳細は、『VLAN Trunk Protocol(VTP)について』参照してください。

    XL シリーズ スイッチの VTP ステータスを確認するには、show vtp status コマンドを発行します。

    3524XL#show vtp status
    
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 5
    VTP Operating Mode              : Server
    
    !--- This is the default mode.
    
    VTP Domain Name                 : 
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0xBF 0x86 0x94 0x45 0xFC 0xDF 0xB5 0x70 
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
  2. VTP ドメインの設定と確認が済んだら、スイッチでの VLAN の作成を開始します。

    デフォルトでは、すべてのポートに対して VLAN は 1 つだけです。 この VLAN を default と呼びます。 VLAN 1 は名前の変更も削除もできません。

    VLAN の情報を確認するには、show vlan コマンドを発行します。

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

    別の VLAN を作成するには、特権モードで次の一連のコマンドを使用します。

    3524XL#vlan database
    
    !--- You must enter into VLAN database in order to configure any VLAN.
    
    3524XL(vlan)#vtp server
    
    Device mode already VTP SERVER.
    
    !--- You can skip this command if the switch is already in server mode and you
    !--- want the switch to be in server mode.
    
    

    VLAN を作成できるのは、VTP サーバ モードまたは VTP 透過モードのスイッチに限られます。 VTP についての詳細は、『VLAN Trunk Protocol(VTP)について』参照してください。

    524XL(vlan)#vlan ?
    
      <1-1005>  ISL VLAN index
    
    3524XL(vlan)#vlan 2 ?
    
      are        Maximum number of All Route Explorer hops for this VLAN
      backupcrf  Backup CRF mode of the VLAN
      bridge     Bridging characteristics of the VLAN
      media      Media type of the VLAN
      mtu        VLAN Maximum Transmission Unit
      name       Ascii name of the VLAN
      parent     ID number of the Parent VLAN of FDDI or Token Ring type VLANs
      ring       Ring number of FDDI or Token Ring type VLANs
      said       IEEE 802.10 SAID
      state      Operational state of the VLAN
      ste        Maximum number of Spanning Tree Explorer hops for this VLAN
      stp        Spanning tree characteristics of the VLAN
      tb-vlan1   ID number of the first translational VLAN for this VLAN (or zero
                 if none)
      tb-vlan2   ID number of the second translational VLAN for this VLAN (or zero
                 if none)
    
    3524XL(vlan)#vlan 2 name ?
    
      WORD  The ASCII name for the VLAN
    
    3524XL(vlan)#vlan 2 name cisco_vlan_2
    
    VLAN 2 added:
        Name: cisco_vlan_2
    
    3524XL(vlan)#exit
    
    !--- You must exit from the VLAN database in order for the changes 
    !--- to be committed.
    
    APPLY completed.
    Exiting....
    3524XL#

    スイッチで、サポート対象よりも多くの VLAN の学習や転送が試行されると、VTP のモードがクライアント モードから透過モードに変更される場合があります。 クライアントモードで動作するスイッチが、サーバ モードのスイッチが送信するのと同数の VLAN をサポートすることを常に確認してください。

  3. VLAN が作成されたことを確認するには、show vlan コマンドを発行します。

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4,
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8,
                                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12,
                                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16,
                                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20,
                                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24,
                                                    Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1
  4. 新しく作成した VLAN に、ポート(インターフェイス)を追加できます。

    新しい VLAN に追加するインターフェイスごとに、インターフェイス設定モードに入る必要があります。

    レイヤ 2 Catalyst スイッチのポートは複数の VLAN に割り当てられますが、スイッチはアクティブな管理 VLAN インターフェイスを一度に 1 つしかサポートしないため、レイヤ 2 の機能により他の Switched Virtual Interfaces(SVI; スイッチ仮想インターフェイス)は、「up/up」にはなりません。 したがって、スイッチはアクティブな管理用レイヤ 3 アドレスを 1 つしかサポートしません。 レイヤ 2 の Catalyst スイッチでは、新しい SVI でオプションの management コマンドを発行することにより、VLAN 1 を自動的にシャット ダウンして、IP アドレスを新しい VLAN へ転送できます。

    Switch#configure terminal
    
    Switch(config)#interface vlan 2
    
    Switch(config-subif)#management
    
    Switch(config-subif)#^Z
    
    Switch#show ip interface brief
    Interface                  IP-Address      OK? Method Status   Protocol
    VLAN1                      10.0.0.2        YES manual up       down    
    VLAN2                      20.0.0.2        YES manual up       up      
    FastEthernet0/1            unassigned      YES unset  up       up      
    FastEthernet0/2            unassigned      YES unset  up       up
    
    !--- Output suppressed.
    
    

    VLAN で特定のインターフェイスを追加するには、特権モードで次の一連のコマンドを発行します。

    3524XL#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    3524XL(config)#interface fastethernet 0/2
    
    3524XL(config-if)#switchport access ?
    
      vlan  Set VLAN when interface is in access mode
    
    3524XL(config-if)#switchport access vlan ?
    
      <1-1001>  VLAN ID of the VLAN when this port is in access mode
      dynamic   When in access mode, this interfaces VLAN is controlled by VMPS
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/2 to VLAN 2.
    
    3524XL(config-if)#exit
    
    3524XL(config)#interface fastethernet 0/3
    
    3524XL(config-if)#switchport access vlan 2
    
    !--- These commands assign interface Fast Ethernet 0/3 to VLAN 2.
    
    3524XL(config-if)#end
    
    3524XL#
    00:55:26: %SYS-5-CONFIG_I: Configured from console by console
    
    3524XL#write memory
    
    !--- This saves the configuration.
    
    Building configuration...
  5. VLAN の設定を確認するには、show vlan コマンドを発行します。

    3524XL#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    cisco_vlan_2                     active    Fa0/2, Fa0/3
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        1002   1003
    2    enet  100002     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        1      1003
    1003 tr    101003     1500  1005   0      -        -    srb      1      1002
    1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
    1005 trnet 101005     1500  -      -      1        IBM  -        0      0

ポートまたは VLAN の削除

VLAN からポートを削除するには、インターフェイス設定モードで no switchport access vlan vlan_number コマンドを発行します。 VLAN 1(デフォルトの VLAN)以外の VLAN からポートを削除すると、そのポートはデフォルトの VLAN に自動的に追加されます。

たとえば、cisco_vlan_2(VLAN 2)からインターフェイス Fast Ethernet 0/2 を削除する場合は、特権モードで次の一連のコマンドを発行します。

3524XL#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

3524XL(config)#interface fastethernet 0/2

3524XL(config-if)#no switchport access vlan 2

!--- These two commands remove interface Fast Ethernet 0/2 from VLAN 2.

3524XL(config-if)#end

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,

!--- Note: Fast Ethernet 0/2 is added back to the default VLAN.

                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
2    cisco_vlan_2                     active    Fa0/3
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        IBM  -        0      0
1005 trnet 101005     1500  -      -      1        IBM  -        0      0

VLAN を削除するには、VLAN データベースモードで no vlan vlan_number コマンドを発行します。 その VLAN に属していたインターフェイスは VLAN の削除後もその VLAN に属したままで、どの VLAN にも属していないことになるため、無効になります。

たとえば、スイッチから cisco_vlan_2 を削除する場合は、特権モードで次の一連のコマンドを発行します。

3524XL#vlan database

!--- This command enters you into the VLAN database mode.

3524XL(vlan)#no vlan 2

!--- This command removes the VLAN from the database.

Deleting VLAN 2...

3524XL(vlan)#exit

APPLY completed.
Exiting....

3524XL#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5,
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9,
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13,
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17,
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21,
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1,
                                                Gi0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

!--- Output suppressed.

show vlan コマンドの出力には、ポート Fast Ethernet 0/3 が表示されていないことに注意してください。 VLAN 2 を削除することで、このポートは無効になります。 別の VLAN に追加し直すまで、このポートは表示されされず、使用もできません。

3524XL#show interfaces fastethernet 0/3

FastEthernet0/3 is down, line protocol is down

!--- Output suppressed.

インターフェイスを使用可能にするには、それをいずれかの VLAN に所属させる必要があります。 このドキュメントのこのセクションのケースでは、インターフェイス Fast Ethernet 0/3 を使用可能にするには、このインターフェイスをデフォルトの VLAN(VLAN 1)に追加する必要があります。

ご使用の Cisco デバイスの、show-tech support コマンドの出力データがあれば、アウトプットインタープリタ登録ユーザ専用)を使用して今後予想される障害と修正を表示できます。

Catalyst 3550 スイッチでは、インターフェイスを VLAN に追加しなくてもそのインターフェイスを使用できます。 ただし、そのインターフェイスをレイヤ 3 インターフェイスにする必要があります。 Catalyst 3550 スイッチのレイヤ 3 インターフェイスについての詳細は、『インターフェイス特性の設定』の「レイヤ 3 インターフェイスの設定」セクションを参照してください。

Catalyst 2900XL/3500XL でのマルチ VLAN ポートの設定

Catalyst 2900XL/3500XL スイッチのマルチ VLAN ポート機能を使用すると、1 つのポートに対して複数の VLAN を設定できます。 この機能により、インター VLAN ルーティング機能を実装しなくても、異なる VLAN のユーザがサーバやルータにアクセスできます。 マルチ VLAN ポートは、割り当てられたすべての VLAN で正常なスイッチング機能を行います。 マルチ VLAN ポート上の VLAN トラフィックはトランキングされているため、カプセル化されません。

マルチ VLAN ポート機能を実装する際の制限事項を次に示します。

  • スイッチでトランクが設定されている場合は、マルチ VLAN ポートを設定できません。 マルチ VLAN ポートは、ルータまたはサーバのみに接続できます。 マルチ VLAN ポート機能が有効になると、スイッチは自動的に VTP 透過モードに移行し、VTP は無効になります。 VTP 設定は必要ありません。

  • マルチ VLAN ポート機能がサポートされているのは、Catalyst 2900XL/3500XL シリーズ スイッチのみです。 この機能は、Catalyst 4500/4000、5500/5000、6500/6000 シリーズ スイッチや、他の Catalyst スイッチではサポートされていません。

  1. どのポートをマルチ VLAN ポートに設定するかを決定します。

    ここでは、Catalyst 3512XL スイッチに 3 つの VLAN を作成し、スイッチの 1 つのポートを外部ルータに接続します。 この例では、ルータに接続したポートをマルチ VLAN ポートとして設定します。

    6-3512xl#show vlan
    
    VLAN Name                             Status      Ports
    ---- -------------------------------- ---------   -----------------------------
    1    default                          active      Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                      Fa0/8, Fa0/9, Fa0/10, Fa0/11,
                                                      Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active      Fa0/2, Fa0/4
    3    VLAN0003                         active      Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
    6    VLAN0006                         active

    この例では、Fast Ethernet 0/1 が外部ルータに接続されています。 VLAN を作成してポートを VLAN に割り当てる方法の詳細については、このドキュメントの「Catalyst 2900XL、3500XL、2950、2970、および 2940 シリーズ スイッチでの VLAN の設定」の項を参照してください。

  2. Fast Ethernet 0/1 ポートをマルチ VLAN モードに設定し、割り当てられた VLAN をマルチ VLAN ポートに追加します。

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface fastethernet 0/1
    
    6-3512xl(config-if)#switchport mode multi
    
    !--- This command changes the port Fast Ethernet 0/1 mode to multi.
    
    6-3512xl(config-if)#switchport multi vlan ?
    
      LINE    VLAN IDs of VLANs to be used in multi-VLAN mode
      add     add VLANs to the current list
      remove  remove VLANs from the current list
    
    6-3512xl(config-if)#switchport multi vlan 1,2,3
    
    !--- This command assigns VLANs 1, 2, and 3 to multi-VLAN port Fast Ethernet 0/1.
    
    6-3512xl(config-if)#^Z
     
    6-3512xl#
  3. 設定を確認するため、show interface interface_id switchport コマンドと show vlan コマンドを発行します。

    6-3512xl#show interface fastethernet 0/1 switchport
    
    Name: Fa0/1
    Operational Mode: multi
    
    !--- The port is in multi-VLAN mode.
    
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: NONE
    Pruning VLANs Enabled: NONE
    
    Priority for untagged frames: 0
    
    Override vlan tag priority: FALSE
    
    Voice VLAN: none
    
    Appliance trust: none
    
    6-3512xl#show vlan brief
    
    VLAN Name                             Status       Ports
    ---- -------------------------------- ---------    ----------------------------
    1    default                          active       Fa0/1, Fa0/3, Fa0/6, Fa0/7,
                                                       Fa0/8, Fa0/9, Fa0/10, Fa0/1
                                                       Fa0/12, Gi0/1, Gi0/2
    2    VLAN0002                         active       Fa0/1, Fa0/2, Fa0/4
    
    !--- Note: Previously, port Fast Ethernet 0/1 was only in VLAN 1.
    !--- Now the port is assigned to multiple VLANs 1, 2, and 3.
    
    3    VLAN0003                         active       Fa0/1, Fa0/5
    4    VLAN0004                         active
    5    VLAN0005                         active
  4. マルチ VLAN の動作を確認するため、スイッチからルータに ping コマンドを発行します。

    ping コマンドを発行すると、VLAN 1、2、または 3 のいずれかに管理 IP アドレスが割り当てられるたびに、ルータから応答が得られます。

    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#ip address 192.168.1.1 255.255.255.0
    
    !--- The management IP address is assigned to VLAN 1.
    
    6-3512xl(config-if)#^Z
    
    6-3512xl#
    23:56:54: %SYS-5-CONFIG_I: Configured from console by console
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 1.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 1
    
    6-3512xl(config-if)#no ip address
    
    !--- The management IP address is removed from VLAN 1.
    
    6-3512xl(config-if)#shutdown
    
    6-3512xl(config-if)#exit
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shutdown
    
    !--- The management IP address is assigned to VLAN 2.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 2.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1004 ms
    
    6-3512xl#configure terminal
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    6-3512xl(config)#interface vlan 2
    
    6-3512xl(config-subif)#no ip address
    
    !--- The management IP address is removed from VLAN 2.
    
    6-3512xl(config-subif)#shutdown
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#interface vlan 3
    
    6-3512xl(config-subif)#ip address 192.168.1.1 255.255.255.0
    
    6-3512xl(config-subif)#no shut
    
    !--- The management IP address is assigned to VLAN 3.
    
    6-3512xl(config-subif)#exit
    
    6-3512xl(config)#exit
    
    6-3512xl#ping 192.168.1.1
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/3 ms
    
    6-3512xl#ping 192.168.1.2
    
    !--- You can ping the router from VLAN 3.
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/205/1004 ms

Cisco IOS ソフトウェアが稼働する Catalyst 3550、3750、4500/4000、および 6500/6000 スイッチでの VLAN の設定

VLAN とポートの作成

このセクションでは、設定コマンドの例に Catalyst 4500 スイッチを使用しますが、この設定作業はレイヤ 3(または Cisco IOS ソフトウェア)で動作する他のスイッチにも応用できます。 他のスイッチには、Cisco IOS ソフトウェアが稼働する Catalyst 3550、3570、および 6500 シリーズ スイッチが含まれます。 VLAN を作成する前に、スイッチを VTP サーバ モードまたは VTP 透過モードにする必要があります。 スイッチが VTP サーバの場合は、VLAN を追加する前に VTP ドメイン名を定義する必要があります。 VTP ドメイン名は、次の要件には関係なく定義する必要があります。

  • ネットワーク内のスイッチ数(1 つか複数か)

  • ネットワーク内の他のスイッチへの VLAN 伝播に VTP を使用するか

Catalyst 4500/4000 Cisco IOS ソフトウェア ベースのスーパーバイザ エンジン モジュールに VTP を設定する方法についての詳細は、『VTP の説明と設定』を参照してください。 他の Catalyst スイッチ プラットフォームの VTP 設定に関する情報については、対象のスイッチ プラットフォームのソフトウェア設定ガイドを参照してください。 ソフトウェア設定ガイドを検索するには、『LAN 製品に関するサポート ページ』を参照してください。

VLAN の作成は、VLAN データベース モードまたはグローバル設定モードのいずれかで行うことができます。 1005 よりも大きな値で番号指定された VLAN の作成は、グローバル設定モードで行う必要があります。 そのような VLAN を作成するには、VTP モードを透過モードに設定する必要があります。 1005 よりも大きな値で番号指定された VLAN は、VTP ではアドバタイズされません。 さらに、1005 よりも大きな値で番号指定された VLAN は、スイッチのコンフィギュレーション ファイルに保存され、VLAN の .dat ファイルには保存されません。 スーパーバイザ エンジン IV を装着した Catalyst 4000 スイッチでは、VLAN の .dat ファイルのデフォルト ロケーションは、cat4000_flash ディレクトリです。

Switch#dir cat4000_flash:

Directory of cat4000_flash:/

1 -rw- 676 <no date> vlan.dat

524260 bytes total (523584 bytes free)

Cisco IOS ソフトウェアが稼働する Catalyst 6500 スイッチでは、VTP ドメイン名なしで、サーバ モードで VLAN を作成できます。

show vtp status コマンドを実行すると、スイッチの VTP 情報が表示されます。

Switch#show vtp status

VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 8
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xA4 0x18 0x78 0x52 0x5A 0x1B 0x2E 0x14
Configuration last modified by 0.0.0.0 at 5-28-01 05:17:02
Local updater ID is 10.10.10.1 on interface Vl1 (lowest numbered VLAN interface)
  1. VLAN の情報を確認するには、show vlan コマンドを発行します。

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Gi1/1, Gi1/2, Gi3/1, Gi3/2
                                                    Gi3/3, Gi3/4, Gi3/5, Gi3/6
                                                    Gi3/7, Gi3/8, Gi3/9, Gi3/10
                                                    Gi3/11, Gi3/12, Gi3/13, Gi3/14
                                                    Gi3/15, Gi3/16, Gi3/17, Gi3/18
    
    !--- Output suppressed.
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    Primary Secondary Type              Ports 
    ------- --------- ----------------- ------------------------------------------
  2. データベース モードまたはグローバル設定モードのどちらか適切なモードへ入ります。

    VLAN データベース モードに入るには、特権モードで vlan database コマンドを発行します。

    Switch#vlan database
    
    Switch(vlan)#
  3. VLAN を作成するため、vlan vlan_number コマンドを発行します。

    Switch(vlan)#vlan 2
    
    VLAN 2 added:
    Name: VLAN0002
    
    Switch(vlan)#apply
    
    APPLY completed.

    設定を有効にするには、apply コマンドを発行するか、VLAN データベース モードを終了します。 VLAN データベース モードでは、end キーワードや Ctrl+Z による終了方法は使用できません。 VLAN データベース モードを終了するには、exit コマンドを発行してください。

    グローバル設定モードでは、VLAN 設定を実行するため次のコマンドを発行します。

    Switch(config)#vlan 3
    
    Switch(config-vlan)#exit
    
    Switch(config)#
  4. 実行コンフィギュレーションの 1005 よりも大きな値で番号指定された VLAN を表示するには、show run コマンドを発行します。

    Switch#show running-config
    
    Building configuration...
    
    Current configuration : 2975 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    service compress-config
    !
    hostname Switch
    !
    !
    ip subnet-zero
    !
    spanning-tree extend system-id
    !
    redundancy
    mode rpr
    main-cpu
    auto-sync standard
    !
    !
    vlan 2000
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    
    !--- Output suppressed.
    
    

Cisco IOS ソフトウェアでは、CatOS ベースのスイッチと異なり、インターフェイスがデフォルトで shutdown ステートになっています。 CatOS では、物理リンクの存在が検出されると、ポートがアクティブになります。

デフォルトでは、Catalyst 3550、3750、および 4500 シリーズ スイッチでの Cisco IOS ソフトウェアのインターフェイスはレイヤ 2 インターフェイスになっています。 Catalyst 6500/6000 シリーズ スイッチでは、インターフェイスはレイヤ 3 インターフェイスです。 インターフェイス設定モードで switchport コマンドを使用すると、インターフェイスをレイヤ 2 インターフェイスとして設定できます。 インターフェイスがレイヤ 3 モードにあるときは、インターフェイスを VLAN に割り当てる前に、このコマンドを発行する必要があります。 インターフェイスを VLAN に割り当てるコマンドは、switchport access vlan vlan_number です。

インターフェイスがレイヤ 3 インターフェイスとして設定されている場合、つまり no switchport コマンドが設定されている場合は、インターフェイスを VLAN に割り当てることができません。

Cisco IOS ソフトウェアでポートを VLAN に関連付けるには、次のような最低限の設定が必要です。

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport

!--- This command is required if the interface is in Layer 3 mode.

Switch(config-if)#switchport access vlan 2

Switch(config-if)#no shutdown

show interface gigabitethernet module/interface switchport コマンドを発行して、レイヤ 2 インターフェイスのステータスをチェックします。

Switch#show interface gigabitethernet 3/1 switchport

Name: Gi3/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: On
Access Mode VLAN: 2 (VLAN0002)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
Voice VLAN: none (Inactive)
Appliance trust: none

ポートがトランクとして設定されていて、1 つのポートで複数の VLAN を伝搬できる場合は、switchport trunk native vlansコマンドが便利です。 このコマンドは、インターフェイスのネイティブ VLAN がデフォルトから変更されていたり、変更する必要がある場合に便利です。 インターフェイスをレイヤ 2 インターフェイスにする場合、使用されている VLAN がネイティブ VLAN になります。 ネイティブ VLAN を明示的に定義しない場合は、デフォルトとして VLAN 1 がネイティブ VLAN になります。 ネイティブ VLAN 上でデータが送信されるときには、IEEE 802.1Q ヘッダーが付加されないことに注意してください。 また、接続されている両方のデバイスで、トランク ポートのネイティブ VLAN が同じになるようにしてください。 ネイティブ VLAN が異なっていると、特にインター VLAN ルーティングで問題が発生する可能性があります。

2 台のシスコ製スイッチの間でネイティブ VLAN が異なっていると、次のメッセージが表示されます。

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEhernet1/1 (2),
 with D-R3550-9B GigabitEthernet0/1 (1)

この例では、一方のスイッチのネイティブ VLAN は VLAN 2 で、ネイバー スイッチのネイティブ VLAN は VLAN 1 です。

show interfaces module/interface trunk コマンドを発行して、ネイティブ VLAN、カプセル化、VLAN のトランキング情報を確認します。

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 1
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

デフォルトの設定を使用する場合は、ネイティブ VLAN は VLAN 1 に設定されます。トランクが設定されているインターフェイスのネイティブ VLAN を変更するには、switchport trunk native vlan vlan_number コマンドを発行します。

Switch(config)#interface gigabitethernet 3/1

Switch(config-if)#switchport trunk native vlan 2

確認するため、次のコマンドを発行します。

Switch#show interfaces gigabitethernet 3/1 trunk

Port Mode Encapsulation Status Native vlan
Gi3/1 on 802.1q trunking 2
 Port Vlans allowed on trunk
Gi3/1 1-4094
 Port Vlans allowed and active in management domain
Gi3/1 1-4,2000,3000
 Port Vlans in spanning tree forwarding state and not pruned
Gi3/1 none

単一の VLAN への複数ポートの割り当て

スイッチ上の複数のインターフェイスを、単一の VLAN に割り当てられます。 次のコマンドを発行します。

  1. Switch(config)#interface range fastethernet [mod/slot - mod/slot]
    
  2. Switch(config-if-range)#switchport access vlan vlan_number
    
    
  3. Switch(config-if-range)#switchport mode access
    
  4. Switch(config-if-range)#no shut
    

: interface range コマンドは、すべてのソフトウェア リリースでサポートされているわけではありません。 interface range コマンドがサポートされているのは、Cisco IOS ソフトウェア リリース 12.1(13)EW 以降です。

VLAN の削除

VLAN データベースから VLAN を削除するには、VLAN データベース モードまたはグローバル設定モードで no vlan vlan_number コマンドを発行します。 この例では、VLAN データベース モードを使用して VLAN 2 を削除しています。

Switch#vlan database

Switch(vlan)#no vlan 2

Deleting VLAN 2...

Switch(vlan)#apply

APPLY completed.

グローバル設定モードでは、VLAN の削除を示すメッセージがコンソールにログされません。 ただし、show vlan を発行して VLAN の削除を確認できます。

VLAN 名の変更

VLAN データベースの VLAN 名を変更するには、VLAN データベース モードまたはグローバル設定モードで name vlan_name コマンドを発行します。

この例では、VLAN データベース モードを使用して VLAN 3 の名前を変更しています。

Switch#vlan database

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

Switch(vlan)#apply

APPLY completed.

この例では、グローバル設定モードを使用して VLAN 3 の名前を変更しています。

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(vlan)#vlan 3

Switch(vlan)#name CISCO

確認するには、show vlan brief コマンドまたは show vlan-switch brief コマンドを発行します。

switch#show vlan brief

VLAN  Name                             Status    Ports
---- -------------------------------- --------- -----------
 3    CISCO                            active    Fa0/3

VLAN 名を変更するときには、switchport access vlan vlan_number コマンドを使用して、ポートに割り当てられた VLAN を削除する必要はありません。

2 つの VLAN 間の通信を隔離する方法

このセクションではプライベート VLAN については説明していません。 プライベート VLAN では、同じプライベート VLAN(隔離された VLAN)内のポート間またはプライベート VLAN 間(コミュニティ VLAN)でレイヤ 2 の隔離が実現されています。

2 つの VLAN を隔離しようとする場合には、次の 2 つのシナリオがあります。

2 つのレイヤ 2 VLAN 間の隔離

レイヤ 2 VLAN とは、スイッチ内に作成され、interface vlan <vlan_number> コマンドで設定されていない VLAN のことです。 異なるレイヤ 2 VLAN にあるホストは、相互に通信できません。

レイヤ 2 VLAN を作成して、古い VLAN から隔離するには、次の手順を実行します。

  1. 新しい VLAN をデータベースに作成します。 VLAN データベース モードを終了すると、設定変更が適用されます。

    Switch#vlan database
    
    !--- You must enter into VLAN database mode in order to 
    !--- configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#vlan 6
    VLAN 6 added:
        Name: VLAN0006
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. VLAN データベースに VLAN が作成されていることを確認します。 新しい VLAN が show vlan コマンドの出力に表示される必要があります。

  3. 新しく作成された VLAN には IP アドレスを設定しないでください。

  4. 対応する VLAN にクライアントを接続する物理インターフェイスを設定します。

    Switch(config)#interface fastEthernet 2/1
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    
    witch(config)#interface fastEthernet 2/2
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 6
    Switch(config-if)#no shut
    
  5. 固定 IP アドレスとサブネット マスクを各ホストに割り当てます。デフォルト ゲートウェイは設定しないでください。 このようにすれば、ポート fa 2/1 と 2/2 にあるホストは相互に通信しなくなります。 1 つの VLAN に所属するデバイスは、同じ VLAN 内のデバイス以外には到達しません。

3 つのレイヤ 2 VLAN 間の隔離

VLAN を作成して、interface vlan <vlan_number> コマンドで IP アドレスを割り当てると、VLAN がレイヤ 3 VLAN になります。 レイヤ 3 スイッチでは、2 つの VLAN 間のホストは相互に通信できます(ホストのデフォルト ゲートウェイが VLAN インターフェイスの IP アドレスに設定されている場合)。 ACL を使用すれば、VLAN 間の通信を拒否できます。

このセクションでは、新しく作成されたレイヤ 3 VLAN と古い VLAN の間の通信を隔離する方法の例を示します。

この例では、3750 スイッチに 2 つの古い VLAN(VLAN 1 と VLAN 2)があります。 新しく作成された VLAN は VLAN 5 です。VLAN 1、VLAN 2 および VLAN 5 はレイヤ 3 VLAN です。 VLAN 1 と VLAN 2 が VLAN 5 と通信できないようにし、VLAN 5 が VLAN 1 と VLAN 2 のどちらとも通信できないようにするために、トラフィックを拒否する ACL が実装されています。

  • VLAN 1:10.10.10.0 /24

  • VLAN 2:172.16.1.0 /24

  • VLAN 5:192.168.1.0 /24

  1. 新しい VLAN をデータベースに作成します。 この場合、新しい VLAN は VLAN 5 です。 VLAN データベース モードを終了すると、設定変更が適用されます。

    Switch#vlan database
    
    !--- You must enter into VLAN database mode
    !--- in order to configure any VLAN.
    
    Switch(vlan)#vlan 5
    VLAN 5 added:
        Name: VLAN0005
    Switch(vlan)#exit
    APPLY completed.
    Exiting....
  2. VLAN データベースに VLAN が作成されていることを確認します。 show vlan コマンドの出力を調べます。

  3. 新しく作成された VLAN に IP アドレスを設定します。

    Switch(config)#interface vlan 5
    Switch(config-if)#ip address 192.168.1.1 255.255.255.0
    Switch(config)#no shut
    
  4. 対応する VLAN にクライアントを接続する物理インターフェイスを設定します。

    Switch(config)#interface fastEthernet 2/1 
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 5
    Switch(config-if)#no shut
    

    各 VLAN に 1 つずつ、合計 3 つのアクセスリストを設定する必要があります。

    • このアクセス リストでは、VLAN 1 から VLAN 5 へのトラフィックが拒否されます。

      
      !--- Some of the commands in this output are wrapped
      !--- to a second line due to spatial reasons.
      
      Switch#configure terminal
      Switch(config)#access-list 101 deny 
      ip 10.10.10.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 101 permit ip 10.10.10.0 0.0.0.255 any
      
    • このアクセス リストでは、VLAN 2 から VLAN 5 へのトラフィックが拒否されます。

      Switch#configure terminal
      Switch(config)#access-list 102 deny ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
      Switch(config)#access-list 102 permit ip 172.16.1.0 0.0.0.255 any
      
    • このアクセス リストでは、VLAN 5 から VLAN 1 と VLAN 2 へのトラフィックが拒否されます。

      Switch#configure terminal
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 10.10.10.0 0.0.0.255
      Switch(config)#access-list 105 deny ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
      Switch(config)#access-list 105 permit ip 192.168.1.0 0.0.0.255 any
      

    設定が終わったら、インターフェイス VLAN 1、インターフェイス VLAN 2 およびインターフェイス VLAN 5 にアクセス リストを適用します。

    Switch#configure terminal
    Switch(config)#interface vlan 1
    Switch(config-if)#ip access-group 101 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 2
    Switch(config-if)#ip access-group 102 in
    Switch(config-if)#exit
    
    Switch#configure terminal
    Switch(config)#interface vlan 5
    Switch(config-if)#ip access-group 105 in
    Switch(config-if)#end
    

Catalyst 6500 シリーズ スイッチで拡張範囲 VLAN を設定する方法

Cisco IOS が稼働する Catalyst 6500 シリーズ スイッチに拡張 VLAN を設定するには、spanning-tree extend system-id コマンドを入力する必要があります。 次に、vlan database モードではなく、設定モードで拡張 VLAN を作成する必要があります。.

Cisco IOS が稼働する Catalyst 6500 シリーズ スイッチで拡張 VLAN を作成するには、次の手順を実行します。

  1. スイッチにコンソール接続します。

    Switch>enable
    Switch#
  2. 次の設定モードを入力します。

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#
  3. 設定モードで spanning-tree extend system-id コマンドを入力します。

    Switch(config)#spanning-tree extended system-id
    
  4. 設定モードで、vtp mode transparent コマンドを入力します。

    Switch(config)#vtp mode transparent
    
  5. 設定モードで VLAN を作成します。

    Switch(config)#vlan 1311
    Notice
    Switch(config-vlan)#exit
    
  6. 設定モードを終了します。

    Switch(config)#exit
    
  7. VLAN の情報を確認するには、show vlan コマンドを発行します。

    Switch#show vlan
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    
    101  VLAN0101                         active    Gi4/8, Gi4/10
    1002 fddi-default                     act/unsup 
    1003 token-ring-default               act/unsup 
    1004 fddinet-default                  act/unsup 
    1005 trnet-default                    act/unsup 
    1311 VLAN1311                         active    
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0   
    101  enet  100101     1500  -      -      -        -    -        0      0   
    1002 fddi  101002     1500  -      -      -        -    -        0      0   
    1003 tr    101003     1500  -      -      -        -    -        0      0   
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0   
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0   
    1311 enet  101311     1500  -      -      -        -    -        0      0   

トラブルシューティングのヒント

このセクションでは、Cisco IOS ソフトウェアが稼働する Catalyst スイッチで VLAN を作成するときに起こる一般的な問題について、トラブルシューティングのヒントを紹介します。

Cisco IOS ソフトウェアが稼働しているスイッチでは、外部ルータを使用する代わりに、スイッチ自体をインター VLAN ルーティングに使用できます。 SVI を作成する場合、レイヤ 2 データベースには、VLAN は自動的には作成されません。 SVI をアップ状態にするには、VLAN データベース モードか、(新しい Cisco IOS ソフトウェア リリースでは)グローバル設定モードで、VLAN が作成される必要があります。 SVI が完全にアクティブになる、つまり SVI が管理上アップ状態になり回線プロトコルがアップ状態になるには、少なくとも 1 つのポートが VLAN のメンバであり、そのポートにアクティブなデバイスが接続されている必要があります。

同様の問題は、VLAN データベース モードで作成された VLAN を使用して、別のスイッチから設定をコピーしたり、設定を復元する場合にも当てはまります。 VLAN データベース ファイル(vlan.dat)も置き換えるか、このドキュメントの「VLAN とポートの作成」の項で説明した手順で VLAN を再度作成する必要があります。 別のスイッチから設定をコピーしても、VLAN データベースはコピーされません。

スイッチにレイヤ 2 VLAN が作成されていない場合に、設定をスイッチに適用すると、show ip interface brief コマンドの出力に SVI インターフェイスが UP/DOWN と表示されます。 設定をスイッチにコピーした後、VLAN データベース モードまたはグローバル設定モードで作成された以前の VLAN が、すべて存在していることを確認してください。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

IOS スイッチの TLB 値の不整合エラー

CatOS から最近 VTP を受信した Cisco IOS スイッチまたは CatOS から移行した Cisco IOS スイッチに VLAN を作成すると、Translational Bridging(TLB; トランスレーショナル ブリッジング)値の不整合エラーが発生します。 これは、トランスレーション ブリッジ VLAN に対する CatOS と Cisco IOS のデフォルト値が一部異なるためです。 トランスレーショナル VLAN では、Fiber Distributed Data Interface(FDDI)やトークン リングがイーサネットに変換されます。 VLAN 1、1002 および 1003 のトランスレーション ブリッジ(tb)VLAN は CatOS では異なっており、デフォルトでは 0 になります。 Cisco IOS スイッチの工場出荷時デフォルトのトランスレーション ブリッジ VLAN は次のとおりです。

Vlan ID      tb1        tb2
--------     -----     -----
1            1002      1003
1002         1         1003
1003         1         1002

CatOS から最近 VTP を受信した Cisco IOS スイッチまたは CatOS から移行した Cisco IOS スイッチでは、デフォルトの tb 値が上書きされます。 その後に VLAN を作成しようとすると、次のエラー メッセージが表示されます。

VLAN 1002 TLB 1 VLAN 1 has inconsistent TLB values (0 / 0)

この問題の回避するには、VLAN 1、1002 および 1003 の Cisco IOS スイッチの tb デフォルト値を CatOS の値と一致するように変更します。

switch#vlan data
switch(vlan)#no vlan 1002 tb-vlan1 tb-vlan2
switch(vlan)#no vlan 1003 tb-vlan1 tb-vlan2
switch(vlan)#apply
APPLY completed.
switch(vlan)#exit
APPLY completed.Exiting....

IOS スイッチの vlan.dat ファイルの復元

Cisco IOS ソフトウェアが稼働する Cisco Catalyst スイッチの場合、vlan.dat という名前の別のファイルに VLAN 情報があります。 vlan.dat ファイルが誤って削除されて、スイッチがリロードされると、スイッチで使用可能だったすべての VLAN が失われます。 スイッチがリロードされるまで、この VLAN 情報がスイッチに存在することになります。

vlan.dat ファイルを回復するには、次の手順を実行します。

  1. show vlan コマンドを発行して、VLAN 情報が使用可能であることを確認します。

    Switch#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                    Fa0/10, Fa0/11, Fa0/12, Gi0/1
                                                    Gi0/2
    10   VLAN0010                         active
    11   VLAN0011                         active
    20   VLAN0020                         active
    21   VLAN0021                         active
    30   VLAN0030                         active
    31   VLAN0031                         active
    40   VLAN0040                         active
    41   VLAN0041                         active
    50   Vlan50                           active
    100  100thVLAN                        active
  2. スイッチが VTP サーバー モードまたは透過モードの場合は、VLAN データベースを変更します。

    VLAN データベースには、次のいずれの変更でも行えます。

    • VLAN を作成する。

    • 任意の VLAN を削除する。

    • 既存の VLAN のプロパティの変更

    スイッチが VTP クライアント モードの場合、同じドメインの任意の VTP サーバーで VLAN データベースを変更します。

    Switch#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#vlan 50
    
    Switch(config-vlan)#name 50thVLAN
    
    Switch(config-vlan)#end
    Switch#

    いずれかの変更を VLAN データベースで行えば、vlan.dat ファイルがスイッチで自動的に作成されます。

  3. vlan.dat ファイルの作成を確認するには、show flash: コマンドを発行します。

    Switch#show flash:
    
    Directory of flash:/
    
        2  -rwx           5   Mar 01 1993 00:04:47  private-config.text
        3  -rwx     2980487   Mar 02 1993 06:08:14  c2950-i6q4l2-mz.121-19.EA1a.bin
        4  -rwx        1156   Mar 01 1993 01:51:27  vlan.dat
       16  -rwx        1014   Mar 01 1993 00:04:47  config.text
        6  drwx        4096   Mar 02 1993 03:49:26  html
        7  -rwx     3121383   Mar 02 1993 03:47:52  c2950-i6q4l2-mz.121-22.EA9.bin
    
    7741440 bytes total (65536 bytes free)

拡張範囲での VLAN 作成の失敗

エラー 1

% Failed to create VLANs [dec]
VLAN(s) not available in Port Manager.

レイヤ 3 LAN ポート、WAN インターフェイスおよびサブインターフェイス、RSPAN などの一部のソフトウェア機能では、拡張範囲にある内部 VLAN が使用されています。 内部使用のために割り当てられている拡張範囲 VLAN は使用できません。

内部使用されている VLAN を表示するには、show vlan internal usage コマンドを発行します。 昇順の内部 VLAN 割り当て(1006 から上方向)または降順の内部 VLAN 割り当て(4094 から下方向)を設定できます。

Switch(config)#vlan internal allocation policy {ascending | descending}


!--- Enter the ascending keyword to allocate internal VLANs from 1006 and up. 
!--- Enter the descending keyword to allocate internal VLAN from 4094 and down.

Switch(config)#end 
Switch#reload

注意 注意: すぐに reload コマンドを入力する必要はありません。 reload コマンドは、予定されたメンテナンスの時間帯に発行してください。 内部 VLAN の割り当てポリシーが適用されるのは、リロード後になります。

デバイスのリロードを行えないような状況の場合は、回避策として、VLAN トランスレーションを使用できます。. トランク ポートで、1 つの VLAN 番号を別の VLAN 番号に変換できます。この変換により、1 つの VLAN で受信されるすべてのトラフィックがもう 1 つの VLAN に転送されるようになります。 詳細については、『VLAN の設定』の「VLAN トランスレーションの設定」の項を参照してください。

Catalyst 製品ファミリのソフトウェアが稼働するスイッチでは、1006 ~ 1024 の VLAN の設定はサポートされていません。 1006 ~ 1024 の VLAN を設定する場合は、Catalyst 製品ファミリのソフトウェアが稼働するスイッチに VLAN が拡張されないことを確認してください。

エラー 2

%Failed to commit extended VLAN(s) changes

VTP のサーバ モードまたはクライアント モードで拡張 VLAN を作成しようとすると、次のメッセージが表示されることがあります。

拡張範囲 VLAN を作成するときには、デバイス(スイッチまたはルータ)がトランスペアレント モードになっていることを確認してください。 詳細については、『拡張 VLAN ID』の「VLAN Trunking Protocol のガイドライン」の項を参照してください。

Startup-Config からの VLAN 設定の失敗

SW-VLAN-4-BAD-STARTUP-VLAN-CONFIG-FILE: Failed to configure VLAN from 
startup-config. Fallback to use VLAN configuration file from non-volatile memory

このメッセージは、スタートアップ コンフィギュレーション ファイルの VLAN 設定を VLAN ソフトウェアが使用できなかったことを示しています。 VLAN 設定は vlan.dat ファイルに保存されています。 vlan.dat ファイルは不揮発性メモリに保存されています。 スーパーバイザ モジュールが交換されると vlan.dat は空(0)になります。 ブートアップ時には、スタートアップ コンフィギュレーション ファイルと vlan.dat ファイルにある VTP ドメイン名と VTP モードがスイッチで比較されます。 値が一致しないと、vlan.dat ファイルにある設定がスイッチで使用されます。

設定全体をバックアップするには、設定のバックアップに vlan.dat ファイルを含める必要があります。 設定全体をリストアするには、ネットワーク管理者が、vlan.dat ファイルと設定ファイルの両方をアップロードする必要があります。

Cisco IOS スイッチでの vlan.dat のバックアップとリストア

vlan.dat をバックアップするには、次の手順を実行します。

デバイスの NVRAM から TFTP サーバーまたは外部 PCMCIA カードに vlan.dat ファイルをコピーします。

copy const_nvram:vlan.dat tftp:

vlan.dat ファイルが保存されるメモリの場所はデバイスによって異なります。 Cisco Catalyst 6500/6000 シリーズ スイッチでは、const_nvram: です。 同様に、Catalyst 4500/4000 スイッチの場合は、cat4000_flash: です。 copy コマンドを発行する前に、それぞれの製品マニュアルを参照してください。

vlan.dat ファイルをリストアするには、次の手順を実行します。

  1. TFTP サーバーまたは外部 PCMCIA カードからデバイスの NVRAM に vlan.dat ファイルをコピーします。

    copy tftp: const_nvram:
  2. vlan.dat が読み込まれるのはブート処理中だけなので、スイッチをリロードします。

VLAN 1003 parent VLAN missing のエラー メッセージでの VLAN 作成の失敗

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 102
Switch(config-vlan)#name marketing
Switch(config-vlan)#exit
VLAN 1003 parent VLAN missing
APPLY VLAN changes failed.
Switch(config)#end
Switch#

スイッチの設定が間違っていると、VTP の設定更新が失敗します。 ほとんどの場合、VTP サーバー スイッチに作成された新しい VLAN が VTP クライアント スイッチに伝搬しないために、ホスト接続の問題が発生することが問題になります。

この問題の一般的な原因は、VTP ドメイン内のスイッチ間での VTP バージョンの不一致です。 同じ VTP ドメインにあるネットワーク デバイス上で、VTP バージョン 1 と VTP バージョン 2 を相互運用することはできません。 VTP バージョン 2 対応のデバイスで VTP バージョン 2 がディセーブルになっていれば、VTP バージョン 2 対応のネットワーク デバイスは、VTP バージョン 1 が稼働するネットワーク デバイスとともに動作可能です。 デフォルトでは、VTP バージョン 2 はディセーブルになっています。 VTP ドメイン内のすべてのネットワーク デバイスで、同じ VTP バージョンを使用する必要があります。 スイッチで稼働している VTP のバージョンを確認してください。 VTP バージョン 2 がイネーブルになっている場合は、この問題を解決するためにディセーブルにします。

他の VTP パラメータに関しても、スイッチが正しく設定されていることを確認します。

  • VTP アップデートが交換されるのはトランク リンク経由だけなので、トランク リンク経由でスイッチが接続されていることを確認する。

  • 適切なスイッチで、VTP ドメイン名が正確に同じになっていることを確認する。 この名前では大文字と小文字が区別されます。 VTP アップデートは、同じ VTP ドメインにあるスイッチ間だけで交換されます。

  • ドメイン内のすべてのスイッチで、VTP パスワードが正確に同じになっていることを確認する。 パスワードの大文字と小文字は区別されます。 パスワードを設定する場合は、ドメイン内のすべてのスイッチで設定されていて、さらにパスワードが同じである必要があります。

VTP クライアントで VLAN 情報がアップデートされないような VTP コンバージェンスの問題の場合は、ダミー VLAN を作成して VTP コンバージェンスを強制的に行ってから、VTP サーバーでダミー VLAN を削除することによって問題を回避できます。 こうすれば、リビジョン番号が増えるので、すべての VTP クライアントで VLAN データベースが強制的にアップデートされます。


関連情報


Document ID: 10023