ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

4つの T1s を使用する NFAS の設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ISDN Non-Facility Associated Signaling(NFAS)を使用すると、単一の D チャネルで複数の一次群速度インターフェイス(PRI)を制御できます。 プライマリ NFAS D チャネルに障害が発生した場合のバックアップ D チャネルを設定できます。 ISDN PRI 用にチャネル化 T1 コントローラを設定するときに必要なのは、NFAS のプライマリ D チャネルの設定だけです。 この設定は、関連付けられた NFAS グループのすべてのメンバに配信されます。

複数の PRI を制御するために単一の D チャネルを使用することで、各インターフェイスで 1 チャネルを余分にデータ トラフィックの伝送に使用できます。 プライマリ D シグナリング チャネルになんらかのハード障害が起こると、現在接続中のユーザを切り離すことなくバックアップ D チャネルへ速やかに切り替えられます。

注: バックアップの D チャネルを設定できない場合、バックアップの D チャネルが使用できないので、23 個の B チャネルだけがバックアップ T1 コントローラで使用できます。 したがって、プライマリでもバックアップでもないこれらの T1 のみが 24 個の使用可能な B チャネルを持つことができます。 この設定では、T1 コントローラ 4/0 はプライマリで 23 個の使用可能な B チャネルがあり、そして T1 コントローラ 4/1 はバックアップで 23 個の使用可能な B チャネルがあります。 T1 コントローラ 5/0 と 5/1 にはそれぞれ 24 個の使用可能な B チャネルがあります。

前提条件

要件

NFAS の前提条件は次のとおりです。

  • NFAS はチャネライズド T1 コントローラでのみサポートされ、その結果、この T1 コントローラは NFAS を導入する前に ISDN PRI に対しても設定する必要があります。 ISDN の設定に関する詳細については ISDN のサポート ページを参照してください。

  • NFAS 用に設定されたルータは、4ess、dms250、dms100、または国内の ISDN スイッチ タイプに接続する必要があります。

    注: NFAS は、primary-5ess タイプのスイッチではサポートされません。 NFAS がご使用の T1 回線に設定できるかどうかを判断するには、サービス プロバイダーまたは電話会社に問い合わせてください。

  • NFAS は電話会社の ISDN のスイッチに設定する必要があります。

  • Cisco IOS を使用したにちがいありませんか。 ソフトウェア リリース 11.3T または それ 以降。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • 次の設定は、Cisco IOS ソフトウェア リリース 12.0(5) を実行する Cisco 7507 ルータでテストされています。

  • この設定は、同じグループ内に 4 台の NFAS メンバを設定する方法について示しています。 プライマリ NFAS インターフェイスは T1 4/0 でバックアップは T1 4/1 です。 T1 コントローラ 5/0 と 5/1 には、これに使用可能な 24 個の B チャネルがあります。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

NFAS 関連の用語

一般的に使用する NFAS の用語は、次のとおりです。

  • NFAS: 単一の D チャネルでの複数の PRI の制御を可能にする ISDN サービス。 複数の PRI の制御に単一の D チャネルを使用すると、各インターフェイスの 1 個の B チャネルが別のトラフィックを伝送できるようになります。

  • 24 個のチャネル インターフェイス:NFAS の D チャネルを使用しないように設定された PRI のチャネル グループ。 すべての 24 個のチャネルは B チャネルです。 この特定の T1 は、シグナリング用にプライマリ コントローラで設定されている D チャネルを使用します。

  • NFAS グループ:単一の D チャネルの管理下の PRI(インターフェイスのグループ)チャネル。 チャネル グループは、複数の T1 コントローラのすべての ISDN チャネルを含めることができます。

    注: NFAS は、ルータの異なるスロットのメンバで設定できます(たとえば、NFAS メンバが同じスロットまたはモジュールにいるという制限はありません)。 また、単一シャーシ内では、5 つの NFAS グループがサポートされます。 複数のプロバイダーからの T1 が使用される場合は、プロバイダーによってグループ化されます。

  • NFAS メンバ:NFAS のグループでの PRI。 たとえば、T1 コントローラ 1/0、1/1、および 2/0 が単一の NFAS のグループで設定されている場合は NFAS グループにはシリアル インターフェイス 1/0:23、1/1:23 および 2/0:23 が含まれます。 すべての NFAS のメンバを表示するには isdn nfas group privileged EXEC コマンド使用します。

必要なコマンド

注: 通常の ISDN PRI コンフィギュレーション コマンドはこのドキュメントでは扱いません。 ISDN PRI の設定の詳細については、関連情報を参照してください。

pri-group timeslots 1-24 nfas_d function nfas_interface int_number nfas_group group_number

このコントローラ コンフィギュレーション コマンドは NFAS のグループに T1 コントローラを割り当て、グループ内の機能を指定します。 必要に応じて、次の値を指定します。

  • 機能:タイムスロット 24 で実行される機能で、プライマリ、バックアップ、または NONE のいずれかです。 すべての NFAS グループには、必ず 1 つのプライマリが必要です。 ルータではバックアップは必要ではありませんが、ほとんどの NFAS の実装にはバックアップ D チャネルがあります。 NFAS グループにバックアップ D チャネルを設定する必要があるかどうかを判断するために電話会社に問い合わせてください。 残りのコントローラは NONE に設定されている可能性があり、B チャネルとして 24 番目のタイムスロットを指定できます。

    注: 電話会社によって規定されているとおりに、プライマリおよびバックアップ D チャネルを正しく設定してください。 NFAS 構成での一般的なエラーは、どの T1 がプライマリでどの T1 がバックアップなのかを正しく指定しないことです。

  • int_number:サービス プロバイダーによって割り当てられ、PRI を識別するために使用する値。 値の有効な範囲は 0 からルータで使用可能な T1 の最大数から 1 を引いた値までです。 たとえばルータに 10 個の T1 がある場合、NFAS インターフェイスの数は 0 ~ 9 です。 0 インターフェイスをプライマリ D チャネルに、1 インターフェイスをバックアップ D チャネルに割り当てる必要があります。

    注: NFAS 設定でバックアップ D チャネルを使用しない場合の特殊なシナリオでは、キーワードの nfas_interface 1 がバックアップ D チャネル用に予約されているためこのキーワードを使用しないでください。 nfas_interfaces 0、2、3、4 などだけを設定してください。

    注: 複数の NFAS グループを設定する場合、0 インターフェイスはそれぞれのプライマリ D チャネルに、そして 1 インターフェイスはそれぞれのバックアップ D チャネルに割り当てられる必要があり、これらは別の nfas_group で提供されます。

  • group_number:ルータで一義的なグループ ID。 複数の NFAS のグループがルータに存在できます。 各グループはプライマリおよびセカンダリ コントローラで設定する必要があります。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/9584/quadt1_nfas.gif

設定

このドキュメントでは、次の設定を使用します。

Cisco 7507
! 
! 
Last configuration change at 13:07:00 cst Mon Jan 31 2000 
!
version 12.0 
no service pad 
service timestamps debug uptime 
service timestamps log datetime localtime show-timezone 
no service password-encryption 
! 
hostname Router 
! 
enable secret 
! 
ip subnet-zero 
no ip domain-lookup 
ip host west 172.22.173.21
isdn switch-type primary-dms100 

!--- Switchtype must be configured. 
!--- Contact your Telco for more information.
!--- Primary T1 controller.

controller T1 4/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1 

!--- Primary D channel, nfas interface 0 and member of group 1.

controller T1 4/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1 


!--- Backup D channel, nfas interface 1 and member of group 1. 


controller T1 5/0 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 2 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 2 and member of group 1.


controller T1 5/1 
framing esf 
linecode b8zs 
pri-group timeslots 1-24 nfas_d none nfas_int 3 nfas_group 1 

!--- 24th timeslot used as B channel, nfas interface 3 and member of group 1.

process-max-time 200 
! 
interface FastEthernet1/0/0   
 ip address 10.1.1.1 255.255.255.0 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 full-duplex 
! 
interface FastEthernet1/1/0 
 no ip address 
 no ip directed-broadcast 
 no ip route-cache distributed 
 no ip mroute-cache 
 shutdown 

!--- D channel for primary controller.
!--- Note: Other D channels in the group are not seen.
!--- All configuration changes made to the primary D channel propagate 
to all the NFAS group members.


interface Serial4/0:23 
 description primary d channel 
 no ip address 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool-member 1 
 isdn switch-type primary-dms100 
 isdn tei-negotiation first-call 
 ppp authentication chap 
 ppp multilink 
! 
interface Dialer0 
 ip address 192.168.10.1 255.255.255.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer remote-name C3620-EA-BCO 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap 
 ppp multilink 
!
router eigrp 200 
 redistribute static 
 network 10.0.0.0 
 network 192.168.10.0 

! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 10.1.1.2 
! 
dialer-list 1 protocol ip permit 
! 
line con 0 
 transport input none 
line aux 0 
 password
   login
  modem InOut
  stopbits 1
 line vty 0 4
  exec-timeout 60 0
  password 
 login 
! 
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show isdn status:ルータが ISDN スイッチと適切に通信していることを確認します。 出力で、Layer 1 Status が ACTIVE で、Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED と表示されていることを確認します。

  • show isdn nfas group:指定 NFAS グループまたはすべての NFAS のグループのメンバーを表示する特権 EXEC コマンド。

  • show isdn service:各 ISDN チャネルの状態とサービス状態を表示する特権 EXEC コマンド。 D チャネルは予約済みと示されます。 このコマンドは、個々のチャネルがビジー アウトかどうかまたは障害があるかどうかを確認するために使用できます。

  • show controller t1:コントローラのハードウェアに特有のコントローラ状態を表示します。 また、これは物理層およびデータリンク層の問題をトラブルシューティングするための情報も表示します。 通常の動作では、出力はコントローラが稼働中でアラームがないことを示している必要があります。

注: 電話会社によって T1 接続がプライマリとして指定されていて、ご使用のルータ設定で正しいポートに接続されていることを確認してください。 一般的なエラーは、ルータのプライマリ T1 ポートに誤った T1 回線(ケーブル)が接続されているというものです。

show コマンドの出力例

次は NFAS が設定されているルータからの show コマンドの出力です。

debug isdn status コマンドの出力例を次に示します。

Router#show isdn status 
Global ISDN Switchtype = primary-dms100 
ISDN Serial4/0:23 interface
         dsl 0, interface ISDN Switchtype = primary-dms100 : 
Primary D channel of nfas group 1
     Layer 1 Status:
         ACTIVE

!--- Primary D channel is active

    Layer 2 Status: 
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED 

!--- Layer 2 is established correctly

    Layer 3 Status: 
        23 Active Layer 3 Call(s) 
    Activated dsl 0 CCBs = 23 
        CCB:callid=0xA0B, sapi=0x0, ces=0x0, B-chan=1 
        CCB:callid=0xA0C, sapi=0x0, ces=0x0, B-chan=3 
        CCB:callid=0xA0D, sapi=0x0, ces=0x0, B-chan=4 
        CCB:callid=0xA0E, sapi=0x0, ces=0x0, B-chan=2 
        CCB:callid=0xA0F, sapi=0x0, ces=0x0, B-chan=5 
        CCB:callid=0xA10, sapi=0x0, ces=0x0, B-chan=6 
        CCB:callid=0xA11, sapi=0x0, ces=0x0, B-chan=7 
        CCB:callid=0xA12, sapi=0x0, ces=0x0, B-chan=8 
        CCB:callid=0xA13, sapi=0x0, ces=0x0, B-chan=9 
        CCB:callid=0xA14, sapi=0x0, ces=0x0, B-chan=10 
        CCB:callid=0xA15, sapi=0x0, ces=0x0, B-chan=11 
        CCB:callid=0xA16, sapi=0x0, ces=0x0, B-chan=12 
        CCB:callid=0xA17, sapi=0x0, ces=0x0, B-chan=13 
        CCB:callid=0xA18, sapi=0x0, ces=0x0, B-chan=14 
        CCB:callid=0xA1B, sapi=0x0, ces=0x0, B-chan=15 
        CCB:callid=0xA1C, sapi=0x0, ces=0x0, B-chan=16 
        CCB:callid=0xA1D, sapi=0x0, ces=0x0, B-chan=17 
        CCB:callid=0xA1E, sapi=0x0, ces=0x0, B-chan=18 
        CCB:callid=0xA1F, sapi=0x0, ces=0x0, B-chan=19 
        CCB:callid=0xA20, sapi=0x0, ces=0x0, B-chan=20 
        CCB:callid=0xA21, sapi=0x0, ces=0x0, B-chan=21 
        CCB:callid=0xA22, sapi=0x0, ces=0x0, B-chan=22 
        CCB:callid=0xA23, sapi=0x0, ces=0x0, B-chan=23 
    The Free Channel Mask:  0x80000000 
ISDN Serial4/1:23 interface
         dsl 1, interface ISDN Switchtype = primary-dms100 :
 Backup D channel of nfas group 1
     Layer 1 Status:
         DEACTIVATED
     Layer 2 Status:
         TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED 
    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 1 CCBs = 0 
    The Free Channel Mask:  0x7E7FFB 
ISDN Serial5/0:23 interface
         dsl 2, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1
     Layer 1 & 2 Status Not Applicable
 
!--- NFAS member: D channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 2 CCBs = 0 
    The Free Channel Mask:  0x0 
ISDN Serial5/1:23 interface
         dsl 3, interface ISDN Switchtype = primary-dms100 :
 Group member of nfas group 1 
    Layer 1 & 2 Status Not Applicable

!--- NFAS member-channel is used as B channel.

    Layer 3 Status: 
        0 Active Layer 3 Call(s) 
    Activated dsl 3 CCBs = 0 
    The Free Channel Mask:  0x80000000 
    Total Allocated ISDN CCBs = 23

注: show isdn status の出力は、プライマリおよびバックアップ コントローラの D チャネルに関する情報だけを表示します。 また、プライマリ D チャネル(Serial4/0:23)だけが ACTIVE および MULTIPLE FRAME ESTABLISHED を表示します。 バックアップ D チャネルの状態(Serial4/1:23)は DEACTIVATED および TEI_ASSIGNED として表示されます。

24 番目のチャネル(Serial5/0:23 および Serial 5/1:23)が B チャネルとして使用されるため、T1 5/0 および 5/1 のレイヤ 1 およびレイヤ 2 での show isdn status の出力は NOT APPLICABLE となります。

次に、show isdn nfas grou コマンドの出力を示します:

Router#show isdn nfas group 1 
ISDN NFAS GROUP 1 ENTRIES:The primary D is Serial4/0:23.    
The backup D is Serial4/1:23.    
The NFAS member is Serial5/0:23.    
The NFAS member is Serial5/1:23. 
There are 4 total nfas members.    
There are 68 total available B channels. 
The primary D-channel is DSL 0 in state IN SERVICE. 
The backup D-channel is DSL 1 in state OUT OF SERVICE. 
The current active layer 2 DSL is 0.

注: show isdn nfas group の出力は、グループのメンバーを表示します。 この出力はコントローラ 4/0 がプライマリで、4/1 がバックアップであることを示しています。 コントローラ 5/0 と 5/1 はグループのメンバーで、24 個の使用可能な B チャネルがあります。

また、この出力には、NFAS メンバー数と使用可能なチャネルの数が示されています。 プライマリ D チャネルが稼働中であり、バックアップがアウトオブサービスであることも示されています。

次に showisdn service コマンドの出力例を示します:

Router# show isdn service 
PRI Channel Statistics:
 ISDN Se4/0:23, Channel [1-24]
      Configured Isdn Interface (dsl) 0
      Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3
      Service State (0=Inservice 1=Maint 2=Outofservice)
      0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 
 ISDN Se4/1:23, Channel [1-24]
     Configured Isdn Interface (dsl) 1
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)
     2 2 0 2 2 2 2 2 2 2 2 2 2 2 2 0 0 2 2 2 2 2 0 3  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 0 0 0 0 0 0 0  
ISDN Se5/0:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 2 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
ISDN Se5/1:23, Channel [1-24] 
     Configured Isdn Interface (dsl) 3 
     Channel State (0=Idle 1=Propose 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)    
     2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2  
     Service State (0=Inservice 1=Maint 2=Outofservice) 
     0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  
Router#

show isdn service の出力では、プライマリまたはセカンダリが予約済に対応するステート 3 である D チャネルを表示します。 他のメンバの D チャネルは、ビジーおよび B チャネルとして使用中を示すステート 2 です。 0 のチャネル ステートはそのチャネルが使用可能であることを示します。

注: 多くのデバイス(通常、アクセス サーバ)では D チャネルのサービス ステートが、チャネルがアウトオブサービスであることが示す 2 です。 これは表面的な問題であり、接続に影響はありません。 D チャネルが実際にどこで機能しているのかを判断するには、すでに説明したように show isdn status コマンドを使用します。

プライマリまたはバックアップ(5/0 および 5/1)として指定されないコントローラでは、24 番目のチャネルがアイドル状態またはビジー状態であることを確認します。 これは RESERVED 状態ではない必要があります。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug isdn q931:ISDN ネットワーク接続(レイヤ 3)のコールの設定と切断を表示します。

  • debug isdn q921:ルータと ISDN スイッチ間の D チャネル上でのデータ リンク層のメッセージ(レイヤ 2)を表示します。 show isdn status コマンドでレイヤ 1 とレイヤ 2 がアップしていることが表示されない場合は、このデバッグを使用します。

コントローラがシャットダウンしている場合

NFAS グループに属するコントローラがシャットダウンしているとどうなるでしょうか。 シャットダウンしているコントローラのすべてのアクティブ コールが削除され、次のいずれかが適用されます:

  • シャットダウンしているコントローラがプライマリで、バックアップが設定されていない場合、グループ全体のすべてのアクティブ コールが削除されます。

  • シャットダウンしているコントローラがプライマリで、アクティブな(IN SERVICE)D チャネルがプライマリにあり、バックアップが設定されている場合、アクティブな D チャネルはバックアップ コントローラに切り替わります。

  • シャットダウンしているコントローラがプライマリで、アクティブな(IN SERVICE)D チャネルがバックアップにある場合、アクティブな D チャネルはバックアップ コントローラに留まります。

  • シャットダウンしているコントローラがバックアップで、アクティブな D チャネルがバックアップにある場合、アクティブな D チャネルはプライマリ コントローラに変わります。

注: プライマリおよびバックアップ・コントローラ間のアクティブな D チャネルの切り替えはリンクのいずれかに障害が起こると発生し、リンクが接続されたときは発生しません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9584