ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

ISDN を経由した PPP コールバックの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 11 月 12 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、サービス総合デジタル ネットワーク(ISDN)経由のポイントツーポイント プロトコル(PPP)コールバックの設定例を紹介します。 コールバックを使用する目的には、次のようなものがあります。

  • 電話料金請求の整理統合と集中化

  • 市外通話のコスト節減

  • アクセス制御

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 11.0(3) または それ 以降。

  • Cisco IOS ソフトウェア リリース 12.0(5)XK1 がインストールされた Cisco 3640(maui-nas-04)

  • Cisco IOS ソフトウェア リリース 12.0(4)T がインストールされた Cisco 1604(maui-soho-01)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

この設定例では、コールバックで PPP と RFC 1570 leavingcisco.com で規定されたファシリティを使用します。 ISDN PPP コールバックは次の順序で実行されます。

  1. ルータ A がルータ B への回線交換接続を開始します。

  2. ルータ A とルータ B の間で PPP Link Control Protocol(LCP; リンク制御プロトコル)がネゴシエートされます。 ルータ A がコールバックを要求するか、またはルータ B がコールバックを開始します。

  3. ルータ A がルータ B に対して、PPP パスワード認証プロトコル(PAP)またはチャレンジ ハンドシェイク認証プロトコル(CHAP)を使用して自己認証します。 オプションで、ルータ B がルータ A に対して認証することもできます。

  4. 双方のルータが回線交換接続を解除します。

  5. ルータ B がルータ A への回線交換接続を開始します。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: この文書に使用されるコマンドに関するその他の情報を検索するには、Command Lookup ツールを使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/9575/isdn-ppp-callback.gif

設定

このドキュメントでは、次の設定を使用します。

maui-soho-01: コールバック クライアント
version 12.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local

!--- Basic AAA configuration for PPP calls.

!
username maui-nas-04 password 0 happy

!--- Username for remote router (maui-nas-04) and shared secret password.
!--- Shared secret (for CHAP authentication) must be the same on both sides.

username admin password 0 <deleted>
!
ip subnet-zero
!
isdn switch-type basic-ni
!
interface Ethernet0
 ip address 172.22.85.1 255.255.255.0
 no ip directed-broadcast
!
interface BRI0
 ip address 172.22.82.2 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer map ip 172.22.82.1 name maui-nas-04 20007

!--- Dialer map statements for the remote router.
!--- The name must match the name that the remote router uses to identify itself.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 20009
 ppp callback request

!--- Request PPP callback from the server.

 ppp authentication chap

!--- Use CHAP authentication.

!
no ip http server
ip classless
ip route 172.22.80.0 255.255.255.0 172.22.82.1
!
dialer-list 1 protocol ip permit

!--- Interesting traffic definition.
!--- Apply this to BRI0 with dialer-group 1.

line con 0
 transport input none
 stopbits 1
line vty 0 4
!
end

maui-nas-04: コールバック サーバ
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-04
!
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
!
username admin password <deleted>
username maui-soho-01 password happy

!--- Username for remote router (maui-soho-01) and shared secret password.
!--- Shared secret(for CHAP authentication) must be the same on both sides.

!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
process-max-time 200
!
interface Ethernet0/0
 ip address 172.22.80.4 255.255.255.0
 no ip directed-broadcast
!
interface BRI1/1
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer rotary-group 10

!--- Assign BRI 1/1 to the rotary-group 10.
!--- Rotary-group properties are defined in interface Dialer 10.

 isdn switch-type basic-ni
 isdn spid1 20007
!
interface dialer10

!--- Interface for the dialer rotary-group 10 configuration.

 ip address 172.22.82.1 255.255.255.0
 no ip directed-broadcast
 encapsulation ppp
 dialer in-band
 dialer callback-secure 

!--- Disconnect calls that are not properly configured for callback.
!--- Disconnects any unconfigured dial-in users. 

dialer map ip 172.22.82.2 name maui-soho-01 class dial1 20009

!--- Dialer map statements for the callback.
!--- The name must match the name that the remote router uses to identify itself.
!--- Use map-class dialer dial1 for this connection.

 dialer-group 1
 ppp callback accept

!--- Allows the interface to accept a callback request to a remote host.

 ppp authentication chap
!
ip classless
ip route 172.22.85.0 255.255.255.0 172.22.82.2
no ip http server
!
map-class dialer dial1

!--- The dialer map statement uses this map class for the callback.

 dialer callback-server username

!--- Use authenticated username to identify return call dial string.

dialer-list 1 protocol ip permit
!
line con 0
 transport input none
line 65 70
line aux 0
line vty 0 4
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、アウトプット インタープリタでサポートされています。このツールを使用すると、show コマンド出力を分析できます。

  • show dialer interface type number:ダイヤルオンデマンド ルーティング(DDR)用に設定されたインターフェイスの一般的な診断情報を表示します。 ダイヤリングを開始したパケットのソース アドレスと宛先アドレスが、「Dial reason」の行に表示されます。 このコマンドでは、接続タイマーも表示されます。

  • show isdn status:ルータが ISDN スイッチと正常に通信していることを確認します。 出力で、Layer 1 Status が ACTIVE で、Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED と表示されていることを確認します。 このコマンドは、通信中のコールの数も表示します。

  • dialer enable-timeout seconds:コールバック サーバのタイムアウトをイネーブルにして、コール接続解除からコールバック開始までの時間を設定します。

  • dialer hold-queue:接続が確立されるまで、コールバック クライアントとコールバック サーバがリモートの宛先へのパケットを保持できるようにします。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、アウトプット インタープリタでサポートされています。このツールを使用すると、show コマンド出力を分析できます。

注: debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

  • debug ppp [ packet | negotiation | error | authentication ]:PPP を実装するインターネットワークでのトラフィックや交換に関する情報を表示します。

    • packet:送受信される PPP パケットを表示します。 (このコマンドは、下位レベルのパケット ダンプを表示します。)

    • negotiation:PPP の開始時に送信される PPP パケットを表示します。PPP の開始時には PPP オプションがネゴシエートされます。

    • error:PPP 接続のネゴシエーションと操作に関するプロトコル エラーとエラー統計情報を表示します。

    • authentication:チャレンジ ハンドシェイク認証プロトコル(CHAP)パケット交換やパスワード認証プロトコル(PAP)交換などの認証プロトコル メッセージを表示します。

  • debug isdn q931:ISDN ネットワーク接続(レイヤ 3)のコールの設定と切断を表示します。

  • debug isdn q921:ルータと ISDN スイッチ間の D チャネル上のデータ リンク層メッセージ(レイヤ 2)を表示します。 show isdn status コマンドでレイヤ 1 とレイヤ 2 がアクティブと表示されない場合は、この debug コマンドを使用します。

  • debug dialer [ events | packets]:ダイヤラ インターフェイスで受信されたパケットに関する DDR デバッグ情報を表示します。

デバッグの出力例


!--- maui-soho-01 (callback client:172.22.82.2) pings maui-nas-04. 
!--- (Callback server:172.22.80.4 - Ethernet interface).
!--- and starts the callback process.
!--- Debugs are collected on maui-soho-01.



maui-soho-01#debug dialer events 
maui-soho-01#show debugging 
Dial on demand: 
  Dial on demand events debugging is on
maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   *Mar 8 23:13:02.117: BRI0 DDR: Dialing cause ip (s=172.22.82.2, d=172.22.80.4)    
   *Mar 8 23:13:02.117: BRI0 DDR: Attempting to dial 20007 
   *Mar 8 23:13:02.333: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:02.353: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.417: BRI0:1 DDR: Callback negotiated - waiting for
    server disconnect 
   *Mar 8 23:13:02.493: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down.    
   *Mar 8 23:13:02.509: DDR: Callback client for maui-nas-04 20007 created 
   *Mar 8 23:13:02.509: isdn_call_disconnect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:02.513: BRI0:1 DDR: disconnecting call.... 
   Success rate is 0 percent (0/5) 

   
!--- A few seconds later, maui-soho-01 receives the callback from maui-nas-04. 

   
   maui-soho-01# 
   *Mar 8 23:13:17.537: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 8 23:13:17.553: isdn_call_connect: Calling lineaction of BRI0:1 
   *Mar 8 23:13:19.697: BRI0:1 DDR: No callback negotiated 
   *Mar 8 23:13:19.717: BRI0:1 DDR: dialer protocol up 
   *Mar 8 23:13:19.717: BRI0:1 DDR: Callback received from maui-nas-04 20007 
   *Mar 8 23:13:19.721: DDR: Freeing callback to maui-nas-04 20007 
   *Mar 8 23:13:20.697: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, 
       changed state to up 
   *Mar 8 23:13:23.553: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 
       20007 maui-nas-04 
   
!--- Verifies that the connection was successful


maui-soho-01#ping 172.22.80.4 
   Type escape sequence to abort. 
   Sending 5, 100-byte ICMP Echos to 172.22.80.4, timeout is 2 seconds: 
   !!!!! 
   Success rate is 100 percent (5/5), round-trip min/avg/max = 36/36/36 ms

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 9575