アプリケーション ネットワーキング サービス : Cisco 500 シリーズ キャッシュ エンジン

WCCP のリバース透過キャッシングのトラブルシューティング

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Web Cache Communication Protocol(WCCP)を使用してリバース透過キャッシングを実装するときに WCCP をトラブルシューティングする方法について説明します。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • ネイティブモードで設定される Supervisor 1 が付いている Catalyst 6500 および MSFC 1

  • Cisco IOS(R) ソフトウェア リリース 12.1(8a)EX (c6sup11-jsv-mz.121-8a.EX.bin)

  • バージョン 2.51 との Cache Engine 550

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

tshoot_wccp_9251.gif

Cache Engine をインストールするとき、Cisco は WCCP を設定するのに必要なコマンドだけ設定することを推奨します。 ルータおよびクライアント リダイレクション リストに後日認証のようなその他の機能を、追加できます。

Cache Engine で、ルータの IP アドレスを規定 して下さい、使用したいと思う WCCP のバージョン。


wccp router-list 1 192.168.15.1    
   wccp reverse-proxy router-list-num 1    
   wccp version 2

WCCP の IP アドレスおよびバージョンが設定されれば、逆トランスペアレント キャッシングを設定するためにメッセージがルータで警告するサービス 99 アクティブにする必要がある見るかもしれません。 サービス 99 は逆トランスペアレント キャッシングのための WCCP サービス識別子です。 正常なトランスペアレント キャッシングのための識別子は Cisco IOS のワード「web-cache」です。 ルータのサービス 99 (逆トランスペアレント キャッシング)をアクティブにするためにリダイレクションが実行された ポートを規定 するために、グローバル コンフィギュレーション モードのこれらのコマンドを追加すれば:


ip wccp 99
interface Vlan200 
    ip address 10.10.10.120 255.255.255.0 
    ip wccp 99 redirect out 

逆トランスペアレント キャッシングを設定するとき、WCCP サービス 99 を実行するルータは Webサーバに指向される要求を代行受信します。 コマンド IP wccp 99 リダイレクトは Webサーバにパスのクライアント HTTP パケットを代行受信したいと思うインターフェイスで適用されます。 通常、これは Webサーバ VLAN です。 これは普通 Cache Engine がインストールされている VLAN ではないです。

WCCP がアクティブになると、ルータは設定される WCCP リダイレクトがあるすべてのポートで受信します。 存在に信号を送るために、Cache Engine は絶えずここの WCCP を送信 しますによってルータ リストで設定される IP アドレスへパケットである

ルータとキャッシュ間の WCCP 接続は形成されます。 接続 情報を表示するために、show ip wccp コマンドを発行します。

ルータ 識別子はキャッシュ エンジンによって見られるのでルータの IP アドレスです。 この識別子は必ずしもキャッシュに達するのに転送されたトラフィックによって使用されるルータ インターフェイスではないです。 この例のルータ 識別子は 192.168.15.1 です。

Router#show ip wccp 
   Global WCCP information: 
       Router information: 
           Router Identifier:                  192.168.15.1 
           Protocol Version:                   2.0
    Service Identifier: 99 
           Number of Cache Engines:            1 
           Number of routers:                  1 
           Total Packets Redirected:           0 
           Redirect access-list:               -none- 
           Total Packets Denied Redirect:      0 
           Total Packets Unassigned:           0 
           Group access-list:                  -none- 
           Total Messages Denied to Group:     0 
           Total Authentication failures:      0

show ip wccp 99 detail コマンドはキャッシュについての詳細な情報を提供したものです。

Router#show ip wccp 99 detail 
   WCCP Cache-Engine information: 
           IP Address:               192.168.15.2 
           Protocol Version:         2.0 
           State:                    Usable 
           Redirection:              GRE 
           Initial Hash Info:        FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                                     FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF    
           Assigned Hash Info:       FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF 
                                     FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF    
           Hash Allotment:           256 (100.00%) 
           Packets Redirected:       0 
           Connect Time:             00:00:39

Redirection フィールドはルータから Cache Engine にパケットをリダイレクトするのに使用される方式を表します。 この方式は総称ルーティング カプセル化(GRE)またはレイヤ2 です。 GRE を使うと、パケットは GRE パケットでカプセル化されます。 レイヤ2 によって、パケットはキャッシュにまっすぐに送信されます、Cache Engine およびスイッチまたはルータはレイヤ2 リダイレクションのために隣接したレイヤ2 である必要があります。

最初のハッシュ情報および割り当てられたハッシュ Info フィールドの 16 進法で表されるハッシュ割当てはこのキャッシュに割り当てられるハッシュ バケットの数です。 すべての可能性のある ソース インターネット アドレスは 64 の同じサイズの範囲に、範囲毎に 1 個のバケット分けられ、各キャッシュはいくつかのこれらのバケット 送信元アドレス範囲からのトラフィックを割り当てられます。 この量はキャッシュのロードおよびロードの重み付けに従って WCCP によって動的に管理されます。 インストールされる 1 キャッシュだけある場合このキャッシュすべてのバケットは割り当てられるかもしれません。

ルータが Cache Engine にパケットをリダイレクトし始めるとき Total Packets Redirected フィールドの数は増加します。

Total Packets Unassigned フィールドはそれらがあらゆるキャッシュに割り当てられなかったのでパケットの数ですリダイレクトされなかった。 この例では、パケットの数はキャッシュが取除かれるとき 5.パケット キャッシュのまたは小さい間隔のための最初のディスカバリの間に未指定であるかもしれませんです。

Router#show ip wccp 
   Global WCCP information: 
       Router information: 
           Router Identifier:                      192.168.15.1 
           Protocol Version:                       2.0
    Service Identifier: 99 
           Number of Cache Engines:                1 
           Number of routers:                      1 
           Total Packets Redirected:               28 
           Redirect access-list:                   -none- 
           Total Packets Denied Redirect:          0 
           Total Packets Unassigned:               5 
           Group access-list:                      -none- 
           Total Messages Denied to Group:         0 
           Total Authentication failures:          0

キャッシュがルータによって表示されない場合、WCCP アクティビティをデバッグすることは役立つかもしれません。 ルータがここに受け取る時はいつでもキャッシュからのパケットはあります、と会いますパケット答え、これはデバッグで報告されます。 使用できるデバッグ コマンドは debug ip wccp events および debug ip wccp packets です。

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

この出力は標準 WCCP デバッグ メッセージのサンプルを提供したものです:

Router#debug ip wccp event 
   WCCP events debugging is on 
  Router#debug ip wccp packet 
   WCCP packet info debugging is on 
   Router# 
   2d18h: WCCP-EVNT:S00: Built new router view: 0 routers,   
          0 usable web caches, change # 00000001 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to
          192.168.15.2 w/ rcv_id 00000001 
   2d18h: WCCP-EVNT:S00: Redirect_Assignment packet from
          192.168.15.2 fails source check 
   2d18h: %WCCP-5-SERVICEFOUND: Service web-cache
          acquired on Web Cache 192.168.15.2 
   2d18h: WCCP-PKT:S00: Received valid Here_I_Am packet
          from 192.168.15.2 w/rcv_id 00000001 
   2d18h: WCCP-EVNT:S00: Built new router view: 1
          routers, 1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000002 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000002 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000003 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000003 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000004 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000005 
   2d18h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2
          w/ rcv_id 00000006 
   2d18h: WCCP-EVNT:S00: Built new router view: 1 routers,
          1 usable web caches, change # 00000002 
   2d18h: WCCP-PKT:S00: Received valid Redirect_Assignment
          packet from 192.168.15.2 w/rcv_id 00000006

デバッグ レベルを上げるために、ルータが Cache Engine からパケットを受信するかどうか確認するために IPパケット トラフィックをトレースしたいと思うかもしれません。 実稼働環境のルータを過剰にすることを避けるために関連 トラフィックだけ示すために、ソースとしてキャッシュの IP アドレスがあるパケットにだけデバッグを制限するのに ACL を使用し。 サンプル ACL は access-list 130 permit ip ホスト 192.168.15.2 ホスト 192.168.15.1 です。

Router#debug ip wccp event 
   WCCP events debugging is on 
  Router#debug ip wccp packet 
   WCCP packet info debugging is on 
  Router#debug ip packet 130 
   IP packet debugging is on for access list 130    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 0000001B 
   2d19h: datagramsize=174, IP 18390: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001C 
   2d19h: datagramsize=174, IP 18392: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001D 
   2d19h: datagramsize=174, IP 18394: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001E 
   2d19h: datagramsize=378, IP 18398: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 364, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 0000001E 
   2d19h: datagramsize=174, IP 18402: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 0000001F 
   2d19h: datagramsize=174, IP 18404: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000020 
   2d19h: datagramsize=174, IP 18406: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000021 
   2d19h: datagramsize=378, IP 18410: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 364, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-EVNT:S00: Built new router view: 1 routers,  1 usable web caches, 
          change # 00000002 
   2d19h: WCCP-PKT:S00: Received valid Redirect_Assignment  packet from 192.168.15.2 
          w/rcv_id 00000021 
   2d19h: datagramsize=174, IP 18414: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3    
   2d19h: WCCP-PKT:S00: Sending I_See_You packet to 192.168.15.2  w/ rcv_id 00000022 
   2d19h: datagramsize=174, IP 18416: s=192.168.15.2  (Vlan300), d=192.168.15.1
          (Vlan300), totlen 160, fragment 0, fo 0, rcvd 3

キャッシュがルータによって見られないし、WCCP アクティビティが見られなかったら、基本的な接続をチェックして下さい。 ルータからキャッシュへ、またはキャッシュからルータへ、ping を送信してみてください。 PING がはたらく場合、エラーは設定にあるかもしれません。

キャッシュが得られるが、パケットがリダイレクトされない場合、ルータがトラフィックを受信すること、そしてトラフィックが ip wccp 99 redirect out コマンドが適用するインターフェイスに転送されることを確認して下さい。 トラフィックが代行受信され、リダイレクトされる TCPポート 80 に送信されるトラフィックだけであることを覚えていて下さい。

トラフィックがそれでもリダイレクトされなかったらおよび Web コンテンツがサーバからまっすぐに来たら、キャッシュが代行受信すればいいのか正しく何をに関する手順を渡すことを確認して下さい。 この操作を完了するために WCCP のバックグラウンド情報を持たなければなりません。

WCCP はサービスの 2 つの異なる型を認識します: 標準およびダイナミック。 ルータは標準サービスの暗黙のうちに確認します。 すなわち、ポート 80 を使用するためにそうするために既に確認しているのでルータは指示される必要はありません。 正常なトランスペアレント キャッシング(web-cache -標準サービスは 0) 標準サービスです。

他のすべてのケース(代行受信するべきかどのポートをトランスペアレント キャッシングが含まれている)では、ルータは指示されます。 この情報はでここにですパケット渡されます。

パケット自身を検査するために debug ip packet dump コマンドを発行できます。 Cache Engine によって送信されるパケットだけデバッグするために作成される ACL を使用して下さい。

Router#debug ip packet 130 dump 
   2d19h: datagramsize=174, IP 19576: s=192.168.15.2 (Vlan300), d=192.168.15.1 
      (Vlan300), totlen 160, fragment 0, fo 0, 
   rcvd 3 
   072C5120:                       0004 9B294800            ...)H. 

!--- Start IP header.
 
   072C5130: 00500F0D 25360800 450000A0 4C780000  .P..%6..E.. Lx..    
   072C5140: 3F118F81 C0A80F02 C0A80F01 08000800  ?...@(..@(......    
   072C5150: 008CF09E 0000000A 0200007C 00000004  ..p........|.... 

!--- Start WCCP header.

   072C5160: 00000000 00010018 0163E606 00000515  .........cf.....    
   072C5170: 00500000 00000000 00000000 00000000  .P.............. 

!--- Port to intercept (0x50=80).

   072C5180: 0003002C C0A80F02 00000000 FFFFFFFF  ...,@(.......... 

!--- Hash allotment (FFFF...).

   072C5190: FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF  ................ 
   072C51A0: FFFFFFFF FFFFFFFF FFFF0000 00000000  ................ 
   072C51B0: 00050018 00000002 00000001 C0A80F01  ............@(..    
   072C51C0: 0000000C 00000001 C0A80F02 00080008  ........@(......    
   072C51D0: 00010004 00000001 30                 ........0

このコマンドで、ポートが全体の Request For Comments(RFC)を表示する必要なしでアドバタイズされるかどうか判別できます。 ポートがアドバタイズされない場合、問題はキャッシュの設定で可能性が高いです。

詳細についてはleavingcisco.com Web Cache Coordination Protocol V2.0 を参照して下さい。

およびパケットが得られたら、インターネット クライアントがリダイレクトされるがキャッシュがサーバを参照できなかったらキャッシュにインターネットとサーバへの接続があるかどうか確認して下さい。 からインターネットのさまざまな IP アドレスといくつかの内部サーバにキャッシュ ping して下さい。 IP アドレスの代りに完全修飾 ドメイン(URL)を ping する場合、キャッシュ の 設定で使用するために DNSサーバを規定 することを確かめて下さい。

キャッシュは要求を処理するかどうか不確実なら、キャッシュの HTTP アクティビティをデバッグできます。 キャッシュの HTTP アクティビティをデバッグするために、キャッシュを過剰にすることを避けるようにトラフィックを制限して下さい。 ルータで、ACL をテスト用のデバイスとして利用できる作成し、グローバルコマンド IP wccp 99 のオプション redirect-list を使用して下さいインターネットの 1 人のクライアントのソース IP アドレスで。

Router(config)#access-list 50 permit 172.17.241.126
Router(config)#ip wccp 99 redirect-list 50

ACL を作成し、適用したら、これらのステップを完了して下さい:

  1. コマンド デバッグ http とのキャッシュの HTTP デバッグをすべてのすべて(Cisco Cache Engine バージョン 2.x)アクティブにして下さいまたは http をすべてデバッグして下さい(Cisco Cache Engine バージョン 3 および ACNS バージョン 4、5)。

  2. ターミナルモニタリングをアクティブにして下さい(term mon コマンドを発行して下さい)。

  3. ACL で設定したクライアントからのサーバの 1 つを参照することを試みて下さい。

出力の例はここにあります:

irq0#conf tcework_readfirstdata() Start the recv: 0xb820800 len 4096 timeout    
   0x3a98 ms ctx 0xb87d800 
   cework_recvurl() Start the request: 0xb20c800 0xb20c838 0xb20c8e0 
   Http Request headers received from client:    
   GET / HTTP/1.1 
   Host: 10.10.10.152 
   User-Agent: Links (0.92; Linux 2.2.16-22 i686) 
   Accept: */* 
   Accept-Charset: us-ascii, ISO-8859-1, ISO-8859-2, ISO-8859-4, ISO-8895-5,    
      ISO-8859-13, windows-1250, windws-1251, windows-1257, cp437, cp850, cp852,
       cp866, x-cp866-u, x-mac-ce, x-kam-cs, x-koi8-r, x-koi8-u, utf8 
   Connection: Keep-Alive

Protocol dispatch: mode=1 proto=2 
   ValidateCode() Begin: pRequest=0xb20c800 
   Proxy: CACHE_MISS: HealProcessUserRequest 
   cework_teefile() 0xb20c800: Try to connect to server: CheckProxyServerOut():    
      Outgoing proxy is not enable: 0xb20c800 (F) 
   GetServerSocket(): Forwarding to server: pHost = 10.10.10.152, Port = 80    
   HttpServerConnectCallBack : Connect call back socket = 267982944, error    = 0 
   Http request headers sent to server:    

   GET / HTTP/1.1 
   Host: 10.10.10.152 
   User-Agent: Links (0.92; Linux 2.2.16-22 i686) 
   Accept: */* 
   Accept-Charset: us-ascii, ISO-8859-1, ISO-8859-2, ISO-8859-4, ISO-8895-5,    
      ISO-8859-13, windows-1250, windws-1251, windows-1257, cp437, cp850, cp852, 
      cp866, x-cp866-u, x-mac-ce, x-kam-cs, x-koi8-r, x-koi8-u, utf8 
   Connection: keep-alive 
   Via: 1.1 irq0 
   X-Forwarded-For: 172.17.241.126

cework_sendrequest: lBytesRemote = 386, nLength = 386 (0xb20c800)    
   ReadResCharRecvCallback():  lBytesRemote = 1818, nLength = 1432 0xb20c800)    
   IsResponseCacheable() OBJECTSIZE_IS_UNLIMITED, lContentLength = 3194    
   cework_processresponse() : 0xb20c800 is cacheable 
   Http response headers received from server:    
   HTTP/1.1 200 OK 
   Date: Tue, 20 Nov 2001 10:46:14 GMT 
   Server: Apache/1.3.12 (Unix)  (Red Hat/Linux) mod_ssl/2.6.6 OpenSSL/0.9.5a 
      mod_perl/1.24 
   Last-Modified: Fri, 12 Oct 2001 12:55:23 GMT 
   ETag: "5e23-c7a-3bc6e83b" 
   Accept-Ranges: bytes 
   Content-Length: 3194 
   Keep-Alive: timeout=15, max=100 
   Connection: Keep-Alive 
   Content-Type: text/html

GetUpdateCode(): GET request from client, GET request to server. 
   GetUpdateCode(): nRequestType = -1 
   SetTChain() 0xb20c800: CACHE_OBJECT_CLIENT_OBJECT sendobj_and_cache    
   Http response headers sent to client:    
   HTTP/1.1 200 OK 
   Date: Tue, 20 Nov 2001 10:46:14 GMT 
   Server: Apache/1.3.12 (Unix)  (Red Hat/Linux) mod_ssl/2.6.6 OpenSSL/0.9.5a    
      mod_perl/1.24 
   Last-Modified: Fri, 12 Oct 2001 12:55:23 GMT 
   ETag: "5e23-c7a-3bc6e83b" 
   Content-Length: 3194 
   Keep-Alive: timeout=15, max=100 
   Content-Type: text/html 
   Connection: keep-alive

cework_tee_sendheaders() 0xb20c800: sent 323 bytes to client 
   cework_tee_send_zbuf() 0xb20c800: Send 1087 bytes to client (1087)    
   UseContentLength(): Valid Content-Length (T) 
   cework_tee_recv_zbuf() 0xb20c800: Register to recv 2107 bytes timeout 120 sec 
   HttpServerRecvCallBack(): Recv Call Back socket 267982944, err 0, length  2107 
   HttpServerRecvCallBack(): lBytesRemote = 3925, nLength = 2107 (186697728)    
   cework_tee_send_zbuf() 0xb20c800: Send 2107 bytes to client (2107)    
   UseContentLength(): Valid Content-Length (T) 
   cework_setstats(): lBytesLocal = 0, lBytesRemote = 3925 (0xb20c800)    
   cework_readfirstdata() Start the recv: 0xb84a080 len 4096 timeout 0x3a98    
      ms ctx 0xb87d800 
   cework_cleanup_final() End the request: 0xb20c800 0xb20c838 0xb20c8e0

デバッグで見つけるかもしれない関連情報は太字で強調表示されています。

これらは Webページ ページ トランザクションの異なるフェーズです:

  1. クライアントから届く HTTP 要求 ヘッダ。

  2. サーバに送られる HTTP 要求 ヘッダ。

  3. サーバから届く HTTP応答 ヘッダ。

  4. クライアントに送られる HTTP応答 ヘッダ。

参照する Webページが複数のオブジェクトが、この出来事の順序の多数の例 存在 すれば含まれていれば。 デバッグ 出力を減らすのに最も簡単な可能性のある 要求を使用して下さい。

Catalyst 6500 か Cisco 7600 ルータで、機能マネージャはトラブルシューティングの追加された層を提供するために Cisco IOS で設定されるすべての機能を処理します。 どのように定義するレイヤ3 機能がこれらのデバイスで設定されるとき、情報はスイッチまたはルータ(機能マネージャ)のレイヤ2 制御機能に受信フレームを通じます処理しました。 WCCP に関しては、この制御情報はどんなパケットが IOS および WCCP によって代行受信され、透過キャッシュに送信されるか定義します。

提示 fm 機能 コマンドは Cisco IOS で有効に なる 機能を表示するものです。 ポートが代行受信するために Cache Engine によって正しくアドバタイズされるかどうか確認するためにこのコマンドを使用できます。

Router#show fm features 
   Redundancy Status: stand-alone 
   Interface: Vlan200 IP is enabled 
     hw[EGRESS] = 1, hw[INGRESS] = 1 
     hw_force_default[EGRESS] = 0, hw_force_default[INGRESS] = 0    
     mcast = 0 
     priority = 2 
     reflexive = 0 
     vacc_map : 
     outbound label: 5 
           merge_err: 0 
           protocol: ip 
             feature #: 1    
             feature id: FM_IP_WCCP    
             Service ID: 99    
             Service Type: 1

The following are the used labels 
     label 5: 
           swidb: Vlan200 
           Vlous:

The following are the features configured 
     IP WCCP: service_id = 99, service_type = 1, state = ACTIVE 
           outbound users: 
             user_idb: Vlan200    
           WC list: 
             address: 192.168.15.2    
           Service    ports: 
             ports[0]:    80

The following is the ip ACLs port expansion information 
     FM_EXP knob configured: yes

FM mode for WCCP: GRE (flowmask: destination-only)

FM redirect index base: 0x7E00

The following are internal statistics 
     Number of pending tcam inserts: 0 
     Number of merge queue elements: 0

コマンドは fm が int vlan 200 Ternary Content Addressable Memory (TCAM)の正確なコンテンツを表示することを示します

Router#show fm int vlan 200 
 Interface: Vlan200 IP is enabled 
  hw[EGRESS] = 1, hw[INGRESS] = 1 
  hw_force_default[EGRESS] = 0, hw_force_default[INGRESS] = 0    
  mcast = 0 
  priority = 2 
  reflexive = 0 
  vacc_map : 
  outbound label: 5 
   merge_err: 0 
   protocol: ip 
    feature #: 1    
    feature id: FM_IP_WCCP    
    Service ID: 99    
    Service Type: 1    
     (only for IP_PROT) DestAddr SrcAddr          Dpt   Spt  L4OP TOS Est  prot  Rslt 
     vmr IP value #1:   0.0.0.0  192.168.15.2     0     0    0    0   0    6     permit 
     vmr IP mask  #1:   0.0.0.0  255.255.255.255  0     0    0    0   0    FF 
     vmr IP value #2:   0.0.0.0  0.0.0.0          80    0    0    0   0    6     bridge 
     vmr IP mask  #2:   0.0.0.0  0.0.0.0          FFFF  0    0    0   0    FF 
     vmr IP value #3:   0.0.0.0  0.0.0.0          0     0    0    0   0    0     permit 
     vmr IP mask  #3:   0.0.0.0  0.0.0.0          0     0    0    0   0    0

vmr IP 値# 1: 行は Cache Engine から来る帯の途中受信バイパスを定義します。 これなし、リダイレクション ループがあります。 vmr IP 値# 2: 行は宛先としてポート 80 があるすべてのパケットの途中受信を定義します。 ポート 80 が第 2 行で、WCCP がアクティブ表示するがキャッシュがルータによって使用可能であり、なら場合、キャッシュ の 設定に問題があるかもしれません。 のダンプするをここにですパケット ポートがキャッシュによって送信 されるかどうか判別するために集めて下さい。

解決した後問題を解決することができなかったら、Cisco Technical Assistance Center (TAC)に問題を報告して下さい。

Cisco TAC に提供する必要がある基本情報はここにあります。 ルータから、この情報を収集して下さい:

  • show tech コマンドの出力。 show tech 出力のサイズの問題がある場合 show running-config の出力および show version 出力コマンドは代わりにすることができます。

  • show ip wccp コマンドの出力。

  • show ip wccp web-cache detail コマンドの出力。

  • そこにルータと Webキャッシュ間のコミュニケーションに問題のようである場合問題が発生している間 debug ip wccp events および debug ip wccp packets コマンドからの出力を提供して下さい。

Cache Engine (Cisco Cache エンジンだけ)で、show tech コマンドの出力を集めて下さい。

TAC に連絡するとき、これらのステップを完了して下さい:

  1. 問題のクリア説明を提供します。 これらの質問に対する回答を含む必要があります:

    • どのような現象ですか。

    • それはいつもまたはまれに発生しますか。

    • 問題は設定の変更の後で開始しましたか。

    • Cisco かサード パーティ キャッシュは使用されますか。

  2. トポロジーのクリア説明を提供します。 それがそれにより多くのオフをしたらダイアグラムを含んで下さい。

  3. 問題の解決で役立つ考える他のどの情報も提供します。

設定 例の出力はここにあります:

*********************************** Router Configuration *****************************
Router#show running 
   Building configuration...
Current configuration : 4231 bytes 
   ! 
   version 12.1 
   service timestamps debug uptime 
   service timestamps log uptime 
   no service password-encryption 
   ! 
   hostname Router 
   ! 
   boot buffersize 126968 
   boot bootldr bootflash:c6msfc-boot-mz.120-7.XE1    
   ! 
   redundancy 
    main-cpu 
     auto-sync standard 
   ip subnet-zero 
   ip wccp 99 
   ! 
   ! 
   ! 
   interface FastEthernet3/1 
    no ip address 
    switchport 
    switchport access vlan 100 
    switchport mode access 
   ! 
   interface FastEthernet3/2 
    no ip address 
    switchport 
    switchport access vlan 200 
    switchport mode access 
   ! 
   interface FastEthernet3/3 
    no ip address 
    switchport 
    switchport access vlan 300 
    switchport mode access 
   ! 
   interface FastEthernet3/4 
    no ip address 
   ! 
! 
   interface Vlan100 
    ip address 172.17.241.97 255.255.255.0    
   ! 
   interface Vlan200 
    ip address 10.10.10.120 255.255.255.0    
    ip wccp 99 redirect out 
   ! 
   interface Vlan300 
    ip address 192.168.15.1 255.255.255.0    
   ! 
   ip classless 
   ip route 0.0.0.0 0.0.0.0 172.17.241.1    
   no ip http server 
   ! 
   access-list 30 permit 192.168.15.2 
   ! 
   ! 
   line con 0 
    exec-timeout 0 0 
   line vty 0 4 
    login 
    transport input lat pad mop telnet rlogin udptn    nasi 
   ! 
   end
*********************************** Cache Configuration ******************************
Cache#show running
Building configuration... 
   Current configuration: 
   ! 
   ! 
   logging disk /local/syslog.txt debug 
   ! 
   user add admin uid 0  capability admin-access    
   ! 
   ! 
   ! 
   hostname Cache 
   ! 
   interface ethernet 0 
    ip address 192.168.15.2 255.255.255.0    
    ip broadcast-address 192.168.15.255    
    exit 
   ! 
   interface ethernet 1 
    exit 
   ! 
   ip default-gateway 192.168.15.1 
   ip name-server 172.17.247.195 
   ip domain-name cisco.com 
   ip route 0.0.0.0 0.0.0.0 192.168.15.1    
   cron file /local/etc/crontab 
   ! 
   wccp router-list 1 192.168.15.1 
   wccp reverse-proxy router-list-num 1 
   wccp version 2 
   ! 
   authentication login local enable 
   authentication configuration local enable    
   rule no-cache url-regex .*cgi-bin.* 
   rule no-cache url-regex .*aw-cgi.* 
   ! 
   ! 
   end

関連情報


Document ID: 9251