LAN スイッチング : 802.1Q

CatOS と Cisco IOS システム ソフトウェアが稼働している Catalyst スイッチ間での 802.1Q トランキング

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 11 月 5 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

この資料は Cisco IOS を実行する Catalyst OS (CatOS)システム ソフトウェアおよびモジュラ レイヤ3 (L3)スイッチが稼働している Catalyst スイッチの間でトランキングする IEEE 802.1Q に設定 例を提供したものですか。 システム ソフトウェア。か。CatOS が稼働するスイッチには、Catalyst 4500/4000、5500/5000、および 6500/6000 シリーズ スイッチが含まれます。 Cisco IOS ソフトウェアが稼働するモジュラ型 L3 スイッチには、Catalyst 4500/4000 および Catalyst 6500/6000 シリーズ スイッチが含まれます。 設定例では、Catalyst 4000(CatOS)と Catalyst 6500(Cisco IOS ソフトウェア)を使用していますが、上記のスイッチのいずれもを使用しても同じ結果が得られます。

トランキングとは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンクで伝送する方法です。 イーサネット トランキングの実装には次の 2 つの方法があります。

  • スイッチ間リンク プロトコル(ISL)(Cisco 独自のプロトコル)

  • 802.1q(IEEE 規格)

前提条件

要件

Catalyst スイッチでの 802.1Q および ISL に関連するシステム要件、ガイドライン、および制限事項については、 『トランキングを実装するためのシステム要件』を参照してください。

使用するコンポーネント

この文書に記述されている例の作成には、次のスイッチが使用されています。

  • スーパーバイザ エンジン II(WS-X4013)を搭載し、CatOS ソフトウェア バージョン 8.1.3 が稼働している Catalyst 4000

  • Supervisor Engine 2/マルチレイヤ スイッチ フィーチャ カード 2(MSFC2)を搭載し、Supervisor Engine と MSFC2 上で Cisco IOS ソフトウェア リリース 12.1(20)E2 が稼働している Catalyst 6509

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

このドキュメントで紹介しているのは、スイッチのコンフィギュレーション ファイルと、それに関連する show コマンド使用例の出力だけです。 Catalyst スイッチ間で 802.1Q トランクを設定する方法についての詳細は、『LAN 製品に関するサポート ページ』を参照してください。

802.1q トランキングでは、すべての VLAN パケットはネイティブ VLAN を除くトランクリンクで、タグ付けされます。 ネイティブ VLAN パケットは、タグ付けされずにトランク リンク上に送信されます。 したがって、ネイティブ VLAN は、トランク用に設定された両スイッチ上で同じになります。 このようにして、タグのないフレームを受信したときに、そのフレームが属する VLAN を推測することができます。 デフォルトでは、VLAN 1 はすべてのスイッチ上でネイティブ VLAN になります。

  • CatOS では、 set vlan vlan-id mod/port コマンドを発行することよりネイティブ VLAN を変更することができます。ここで、 mod/port はトランク ポートになります。

  • Cisco IOS ソフトウェアの場合、ネイティブ VLAN は、トランク ポートで switchport trunk native vlan vlan-id interface コマンドを実行して変更できます。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントの設定は、外部に接続されていないラボ環境で実装されたものです。 ここでの設定を実践する前に、各設定やコマンドがネットワークにどのように影響するかを理解してください。 各デバイスがデフォルト設定になっていることを保証するため、すべてのデバイスで clear config all コマンドと write erase コマンドを発行して設定をクリアしてあります。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。leavingcisco.com

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/8760/67-a.gif

設定

このドキュメントでは、次の設定を使用します。

注: コメントおよび説明は、青字のイタリック体で示します。

Catalyst 4000 スイッチ
#version 8.1(3)
!
!
#system web interface version(s)
!
#system
set system name  cat4000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp domain cisco

!--- In this example, the VLAN Trunk Protocol (VTP) domain name is the same
!--- on both sides. This is required for the autonegotiation of the trunk
!--- by the Dynamic Trunking Protocol (DTP).


set vtp mode client vlan

!--- In this example, the VTP mode is set to client.
!--- Set the VTP mode according to your network requirements.

!--- For more details, refer to
!--- Understanding and Configuring VLAN Trunk Protocol (VTP).


!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

!--- This is the IP address used for management.

!--- Output suppressed.

!
#module 1 : 2-port 1000BaseX Supervisor
!
#module 2 empty
!
#module 3 empty
!
#module 4 empty
!
#module 5 : 48-port Inline Power Module
set vlan 2    5/13-24

!--- Ports 5/13-24 have been assigned to VLAN 2.



set trunk 5/1  desirable dot1q 1-1005,1025-4094

!--- The trunking mode is set to desirable mode, which means
!--- the port automatically tries to form a trunk with a
!--- neighboring port set to desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the Dynamic Trunking Protocol section of
!--- Best Practices for Catalyst 4500/4000, 5500/5000, and 6500/6000 
Series Switches Running CatOS Configuration and Management.

!--- Output suppressed.


set spantree portfast    5/2-24 enable
set port channel 5/2-24 mode off

!--- The macro command set port host 5/2-24 was used to do three things:
!--- disable trunking, disable port channeling, and enable spantree portfast.

!--- For details on using the set port host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.

!
#module 6 empty
end

Catalyst 6500 スイッチ
Current configuration : 4408 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot system flash sup-bootflash:c6sup22-jsv-mz.121-20.E2
enable password mysecret

!--- This is the privileged mode password used in the example.


!
ip subnet-zero
!
!
!
mls flow ip destination
mls flow ipx destination
!
redundancy
 mode rpr-plus
 main-cpu
  auto-sync running-config
  auto-sync standard
!
!
!
interface GigabitEthernet2/1
 no ip address
 shutdown
!
interface GigabitEthernet2/2
 no ip address
 shutdown
!
interface fastethernet3/1
 switchport

!--- The switchport command must be entered once,  
!--- without any keywords, to configure the interface as a Layer 2 port.
!--- The interface is now automatically configured with the default command
!--- switchport mode dynamic desirable.

!--- This means the interface is ready to autonegotiate trunking
!--- encapsulation and form a trunk link (using DTP) with a neighbor port
!--- in desirable, auto, or on mode.

!--- For recommended trunk mode settings, refer to
!--- the "Dynamic Trunking Protocol" section of
!--- Best Practices for Catalyst 6500/6000 Series and Catalyst 4500/4000 
Series Switches Running Cisco IOS Software.



!
interface FastEthernet3/2
 switchport
 switchport mode access
 spanning-tree portfast


!--- The interface range fastethernet mod/beginport - endport 
!--- command is used to configure interfaces 3/2 - 24 at once.

!--- Next, the switchport command is issued (if this has not been done already).


switchport mode access
 spanning-tree portfast

!--- Next, issue the macro command switchport host 3/2 - 24 to automatically
!--- configure these ports as access ports and to enable spantree portfast.

!--- For details on using the switchport host command, refer to
!--- Using Portfast and Other Commands to Fix Workstation Startup Connectivity Delays.


!
interface FastEthernet3/13
 switchport
 switchport access vlan 2

!--- Interfaces 3/13 - 24 are placed in VLAN 2
!--- using the switchport access vlan 2 command.


 switchport mode access
 spanning-tree portfast


!--- Output suppressed.


!
interface FastEthernet3/24
 shutdown
 switchport
 switchport access vlan 2
 switchport mode access
 spanning-tree portfast


!--- Output suppressed.

!
interface FastEthernet3/48
 no ip address
 shutdown
!
interface vlan 1
 ip address 10.10.10.3 255.255.255.0

!--- This is the IP address used for management.

!
ip classless
no ip http server
!
!
!
line con 0
line vty 0 4
 password mysecret


!--- This is the Telnet password used in the example.


 login
 transport input lat pad mop telnet rlogin udptn nasi
!
!
end

cat6500#

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

show コマンド

特定の show コマンドは、アウトプットインタープリタ(登録ユーザ専用)によってサポートされています。これにより、show コマンド出力の分析を表示できます。leavingcisco.com

CatOS が使われている Catalyst スイッチでは、次のコマンドを使います。

  • show port capabilities module/port

  • show port module/port

  • show trunk module/port

  • show vtp domain

Cisco IOS ソフトウェアが稼働している Catalyst 6000 スイッチでは、次のコマンドを使用します。

  • show interfaces interface-type module/port trunk

  • show vlan

show コマンドの出力例

Catalyst 4000 スイッチ

show port capabilities module/port コマンドは、このポートでトランキングが可能かどうかを確認するために使用します。

cat4000> (enable) show port capabilities 5/1
Model                    WS-X4148-RJ45V
Port                     5/1
Type                     10/100BaseTX
Speed                    auto,10,100
Duplex                   half,full
Trunk encap type         802.1Q
Trunk mode               on,off,desirable,auto,nonegotiate
Channel                  5/1-48
Flow control             no
Security                 yes
Dot1x                    yes
Membership               static,dynamic
Fast start               yes
QOS scheduling           rx-(none),tx-(2q1t)
CoS rewrite              no
ToS rewrite              no
Rewrite                  no
UDLD                     yes
Inline power             auto,off,static
AuxiliaryVlan            1..1000,1025..4094,untagged,none
SPAN                     source,destination,reflector
Link debounce timer      yes
IGMPFilter               yes
Dot1q-all-tagged         no
cat4000> (enable)

show port module/port このコマンドを使用して、あるポートのステータスとそのポートがトランクしているか否かを表示します。

cat4000> (enable) show port status 5/1
Port  Name               Status     Vlan       Level  Duplex Speed Type
----- ------------------ ---------- ---------- ------ ------ ----- ------------
 5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
cat4000> (enable)

show trunk コマンドは、トランキングの状態と設定を確認するために使用します。

cat4000> (enable) show trunk
* - indicates vtp domain mismatch
# - indicates dot1q-all-tagged enabled on the port
Port      Mode         Encapsulation  Status        Native vlan
--------  -----------  -------------  ------------  -----------
 5/1      desirable    dot1q          trunking      1

Port      Vlans allowed on trunk
--------  ---------------------------------------------------------------------
 5/1      1-1005,1025-4094

Port      Vlans allowed and active in management domain
--------  ---------------------------------------------------------------------
 5/1      1-2

Port      Vlans in spanning tree forwarding state and not pruned
--------  ---------------------------------------------------------------------
 5/1      1-2
cat4000> (enable)

show vtp domain コマンドを使用して、VTP 情報をチェックします。

cat4000> (enable) show vtp domain 
Version      : running VTP1 (VTP3 capable)
Domain Name  : cisco                            Password  : not configured
Notifications: disabled                         Updater ID: 10.10.10.3

Feature        Mode           Revision
-------------- -------------- -----------
VLAN           Client         21

Pruning             : disabled
VLANs prune eligible: 2-1000

Catalyst 6500 スイッチ

show interfaces interface-type module/port trunk コマンドは、このポートがトランキングを行っているかどうかを示します。

cat6500# show interfaces fastethernet 3/1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa3/1     desirable    n-802.1q       trunking      1

Port      Vlans allowed on trunk
Fa3/1     1-4094

Port      Vlans allowed and active in management domain
Fa3/1     1-2

Port      Vlans in spanning tree forwarding state and not pruned
Fa3/1     1-2
cat6500#

show vlan コマンドでは、VLAN と特定の VLAN に属しているポートに関する情報が表示されます。

cat6500# show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa3/2, Fa3/3, Fa3/4, Fa3/5
                                                Fa3/6, Fa3/7, Fa3/8, Fa3/9
                                                Fa3/10, Fa3/11, Fa3/12
2    VLAN0002                         active    Fa3/13, Fa3/14, Fa3/15, Fa3/16
                                                Fa3/17, Fa3/18, Fa3/19, Fa3/20
                                                Fa3/21, Fa3/22, Fa3/23, Fa3/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup


!--- Output suppressed.
    
cat6500#

注: レイヤ 2 非トランク ポートとして設定されているポートのみ表示されます。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8760