LAN スイッチング : スイッチ間リンク(ISL)

CatOS と Cisco IOS システム ソフトウェアが稼働している Catalyst スイッチ間での ISL トランキングの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 12 月 30 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

この資料は Cisco Catalyst 5000 スイッチの間でトランキングするスイッチ間リンク(ISL)に設定 例を提供したものです Catalyst OS (CatOS)および Catalyst 6500 スイッチを実行する Cisco IOS を実行するか。 システム ソフトウェア。 このシナリオでは、次のスイッチのどれを使用しても同じ結果が得られます。

  • CatOS が稼働する Catalyst 4500/4000、5500/5000、または 6500/6000 シリーズ スイッチ

  • どの Catalyst 4500/4000 または Catalyst 6500/6000 シリーズでもこと実行 Cisco IOS システム ソフトウェア切り替えます

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Catalyst 5000 スイッチ CatOS 6.1(1) ソフトウェアを実行する

  • Catalyst 6509 スイッチ Cisco IOS ソフトウェア リリース 12.1(4)E1 を実行する

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 ラボ 環境についての詳細については、この資料の Network Diagram セクションを参照して下さい。 それを使用する前にあらゆる設定の潜在的影響を理解するして下さいまたはネットワークでように命じて下さい。 すべてのデバイスのコンフィギュレーションは clear config all および write erase コマンドでデフォルト 設定を確認するために削除されました。

背景理論

トランキングは 2 つのデバイス間のポイント ツー ポイントリンク上の複数の VLAN からのトラフィックを運ぶ方法です。 イーサネット トランキングは、次の 2 つの方法で実装できます。

  • ISL (Cisco 独自 の プロトコル)

  • IEEE 802.1Q (IEEE規格)

このドキュメントで紹介しているのは、スイッチのコンフィギュレーション ファイルと、それに関連する show コマンド使用例の出力だけです。 Catalyst スイッチ間の ISLトランクを設定する方法の詳細についてはこれらの文書を参照して下さい:

重要事項

  • Catalyst 4500/4000 シリーズ スイッチ(Catalyst 2948g および Catalyst 2980g が含まれている)その実行 CatOS 802.1q トランキングだけをサポートします。 これらのスイッチでは ISL トランキングはサポートされていません。

  • Supervisor Engine II+ またはそれ以降の Catalyst 4000 スイッチは Cisco IOSソフトウェアをデフォルトで実行します。 これらのスイッチは WS-X4418-GB および S-X4412-2GB-T モジュールのブロッキング ギガビットポートのを除くすべてのインターフェイスの ISL および 802.1q トランキング モードを両方サポートします。 このような場合、スイッチは 802.1q トランキングだけサポートします。 WS-X4418-GB モジュールのポート 3 ~ 18 はブロッキング ギガビット ポートです。 WS-X4412-2GB-T モジュールのポート 1 ~12 はブロッキング ギガビット ポートです。 バックプレーンへのポート接続がオーバースクライブされていることを条件「ブロッキング状態 の ポート」は意味します。

  • Catalyst 6500/6000 シリーズ スイッチのどのイーサネットポートでも 802.1Q および ISL カプセル化をサポートします。

  • モジュールに基づいて、Catalyst 5000 トランク可能 な ポートは ISL カプセル化だけをサポートするか、または ISL および 802.1Q を両方サポートします。 サポートされているカプセル化タイプを判別する最もよい方法は show port capabilities コマンドを使用することです。 コマンド 出力は明示的にこの例が示すので、幹線容量を示します:

    cat5000> show port capabilities 3
    Model                    WS-X5225R
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q, ISL
    
    !--- This particular port supports both 802.1Q and ISL.
    
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),tx-(none)
    CoS rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  no
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • トランキングモードがトランクリンクを渡って一致することを確かめて下さい。 ISLトランクでリンクの一方を設定する場合、ISL でリンクの反対側を設定して下さい。 802.1Q でリンクの一方を設定すれば同様に、802.1Q でリンクの反対側を設定して下さい。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/8759/66a.gif

設定

このドキュメントでは、次の設定を使用します。

注: この資料はコンフィギュレーション内の青いイタリック体のコメントおよび説明を表示するものです。

Catalyst 5000 スイッチ
#version 6.1(1)
!
set option fddi-user-pri enabled
set password $2$h/BN$i3S54iNvIXknFelh6gOve0
set enablepass $2$DpAu$/mw1ZxL5I8ymR.yn85ovB/
!
#errordetection
set errordetection portcounter enable
!
#system
set system name  cat5000
!
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- In the example, the VLAN Trunk Protocol (VTP) mode is set to be transparent.
!--- Use your network as a basis to set the VTP mode.

set vtp mode transparent

!--- For details on VTP, refer to Configuring VTP.


set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 2
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti
ve mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip

!--- This is the IP address that is used for management.

set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255
 
!
#set boot command
set boot config-register 0x10f
set boot system flash bootflash:cat5000-sup3.6-1-1.bin
!
#mls
set mls nde disable
!
# default port status is enable
!
!
#module 1 : 0-port Supervisor III
!
#module 2 empty
!
#module 3 : 9-port Gigabit Ethernet
!
#module 4 : 24-port 10/100BaseTX Ethernet
!
#module 5 : 24-port 10/100BaseTX Ethernet

!--- Ports 5/13–24 have been assigned to VLAN 2.

set vlan 2 5/13-24


!--- The ISL trunking mode is set to "on".
!--- Use your network and requirements as a basis to set the trunking mode.

set trunk 5/1 on isl 1-1005

!--- For details on different trunking modes, refer to 
!--- Configuring VLAN Trunks on Fast Ethernet and Gigabit Ethernet Ports.


!--- PortFast has been enabled on the ports that are connected to the workstations.

set spantree portfast 5/2-24 enable

!--- For details on why to enable PortFast, refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays.

end

Catalyst 6500 スイッチ
Current configuration : 4207 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6000
!
boot buffersize 126968
boot bootldr bootflash:c6msfc-boot-mz.121-4.E1.bin
no logging console

!--- The example uses the privileged mode password.

enable password mysecret
!
redundancy
 main-cpu
  auto-sync standard
ip subnet-zero
no ip domain-lookup
!
ip cef
cns event-service server
!
!
!
interface gigabitethernet1/1
 no ip address
 shutdown
!
interface gigabitethernet1/2
 no ip address
 shutdown
!
interface fastethernet9/1
 no ip address


!--- Issue the switchport command once, without any keywords, 
!--- in order to configure the interface as a Layer 2 (L2) port for the Catalyst 6500.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 6500).
!--- On a Catalyst 4000 switch that runs Cisco IOS Software, all ports are 
!--- L2 ports by default. If there is no change to the default configuration, 
!--- you do not need to issue the switchport command.
!--- For details, refer to Configuring Layer 2 Ethernet Interfaces (Catalyst 4000).

 switchport

!--- Configure trunk encapsulation as ISL.

 switchport trunk encapsulation isl


!--- Enable trunking on the interface.

 switchport mode trunk
!

!--- Interfaces Fast Ethernet 9/2 through 9/24 are configured to be in access mode.
!--- For details, refer to the "Layer 2 Interface Modes" section of
!--- Configuring Layer 2 Ethernet Interfaces.

interface fastethernet9/2
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/3
 no ip address
 switchport
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/11
 no ip address
 switchport
 switchport mode access
!
interface fastethernet9/12
 no ip address
 switchport
 switchport mode access
!

!--- Interfaces Fast Ethernet 9/13 through 9/24 are placed in VLAN 2.

interface fastethernet9/13
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/14
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!

!--- Output suppressed.

!
interface fastethernet9/23
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/24
 no ip address
 switchport
 switchport access vlan 2
 switchport mode access
!
interface fastethernet9/25
 no ip address
 shutdown
!

!--- Output suppressed.

!
interface fastethernet9/48
 no ip address
 shutdown
!
interface vlan1

!--- This is the IP address that is used for management.

 ip address 10.10.10.3 255.255.255.0
!
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line vty 0 4

!--- This example uses the Telnet password.

 password mysecret
login
!
end

注: 存在しない VLAN にインターフェイスを割り当てると、VLAN データベースにその VLAN を作成するまで、そのインターフェイスはシャットダウンします。 詳細については、『VLAN の設定』の「イーサネット VLAN の作成または変更」のセクションを参照してください。

確認

show コマンド

ここでは、設定が正常に動作していることを確認します。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

Catalyst 5000 または Catalyst 6000 スイッチその実行 CatOS

  • show port capabilities module/port —ポートがトランキングが可能であるかどうか確認するのにこのコマンドを使用して下さい。

    cat5000> (enable) show port capabilities 5/1
    Model                    WS-X5234
    Port                     5/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  5/1-2,5/1-4
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),TX(1q4t)
    COs rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,1025..4094,untagged,dot1p,none
    SPAN                     source,destination
  • show port module/port —このコマンドはトランキングしているかどうか特定のポートのステータスを表示したものです。

    cat5000> (enable) show port 5/1
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     5/1                     connected  trunk      normal a-full a-100 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status
    ----- ------------- --------------
     5/1  none          none          
    
    
    Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
    ----- -------- --------- ------------- -------- -------- -------- -------
     5/1  disabled  shutdown             0        0        1 disabled      66
    
    Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
    ----- -------- ----------------- -------- ----------------- ------------------
     5/1         0                 -        -                 -        -         -
    
    !--- Output suppressed.
    
    
  • show trunk モジュール/port — 使用 幹線ステータスおよび設定を確認するこのコマンド。

    cat5000> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     5/1      on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     5/1      1-1005
     
    Port      Vlans allowed and active in management domain
    --------  ---------------------------------------------------------------------
     5/1      1-2
     
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     5/1      1-2
    
  • show vtp domain — VTP 情報をチェックするのにこのコマンドを使用して下さい。

    cat5000> (enable) show vtp domain
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           Transparent -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    6          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    10.10.10.2      disabled disabled 2-1000

Cisco IOSソフトウェアを実行する Catalyst 4500/4000 スイッチか Catalyst 6500/6000 スイッチ

  • ポートがトランキングしているかどうか show interfaces interface_type モジュール/ポートは trunk —このコマンド告げます。

    cat6000#show interfaces fastethernet 9/1 trunk
     
    Port      Mode         Encapsulation  Status        Native vlan
    Fa9/1     on           isl            trunking      1
     
    Port      Vlans allowed on trunk
    Fa9/1     1-1005
     
    Port      Vlans allowed and active in management domain
    Fa9/1     1-2,1002-1005
     
    Port      Vlans in spanning tree forwarding state and not pruned
    Fa9/1     1-2,1002-1005
  • show vlan — 特定のVLAN に属するポートおよびこのコマンドは VLAN についての情報を提供したものです。

    cat6000#show vlan
     
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa9/2, Fa9/3, Fa9/4, Fa9/5
                                                    Fa9/6, Fa9/7, Fa9/8, Fa9/9
                                                    Fa9/10, Fa9/11, Fa9/12
    2    VLAN0002                         active    Fa9/13, Fa9/14, Fa9/15, Fa9/16
                                                    Fa9/17, Fa9/18, Fa9/19, Fa9/20
                                                    Fa9/21, Fa9/22, Fa9/23, Fa9/24
    1002 fddi-default                     active
    1003 token-ring-default               active
    1004 fddinet-default                  active
    1005 trnet-default                    active
    
    !--- Output suppressed.
    
    

注: L2 非トランク ポートで設定されるそれらのポートだけ表示する。 詳細については、「レイヤ 2 イーサネット インターフェイス」の「レイヤ 2 スイッチングのイーサネット インターフェイスの設定」の項を参照してください。.

トラブルシューティング

ここでは、設定に関するトラブルシューティングについて説明します。

スイッチはポートが Non-802.1Q ポートであるのでトランク ポートのネイティブ VLAN の変更を受け入れません

この問題はトランク ポートが 802.1Q カプセル化をサポートしないので発生します。 ネイティブ VLAN はポートの 802.1Q サポートを必要とします。 ポートに 802.1Q サポートがない場合、スイッチはネイティブ VLAN の変更を可能にしません。

トランキングのための 802.1Q サポートはハードウェアによって異なるファクタです。 802.1Q サポートがあるように確認するために show port capabilities コマンドを発行して下さい。 show port capabilities コマンドの出力のカプセル化オプションはトランキングのための 802.1Q サポートを示します。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8759