LAN スイッチング : 802.1Q

Catalyst レイヤ 2 固定構成スイッチと CatOS スイッチ間の ISL および 802.1Q トランキングの設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 8 月 26 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントでは、Cisco Catalyst 5500 スイッチと Catalyst 3500XL スイッチ間での InterSwitch Link(ISL)プロトコルと IEEE 802.1Q によるトランキングの設定例を紹介しています。 また、各コマンドを実行したときの結果を示しています。 このドキュメントのシナリオでは、次のいずれのスイッチを使用しても同じ結果が得られます。

  • Catalyst OS(CatOS)が稼働する Catalyst 4500/4000 および 6500/6000 シリーズ スイッチ

  • Catalyst 5500/5000 シリーズの他のメンバ

  • 任意の Catalyst レイヤ 2 固定構成スイッチ

    2900/3500XL、2940、2950/2955、および 2970 を含む Catalyst レイヤ 2 固定構成スイッチ

このドキュメントの先に進む前に、『VLAN トランキング プロトコル サポート』を参照してください。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの例を作成するにあたっては、ラボ環境で次のスイッチをクリアな(デフォルト)設定で使用しています。

  • Catalyst 3524XL スイッチ Cisco IOS を実行するか。 ソフトウェア リリース 12.0(5)WC7

  • CatOS 6.4(2) ソフトウェアが稼働している Catalyst 5500 スイッチ

このドキュメントの設定は、外部に接続されていないラボ環境で実装されたものです。 どのような作業についても、ネットワークに対する潜在的な影響について確実に理解しておく必要があります。 すべてのデバイス上の設定は、Catalyst 5500 スイッチでは clear config all コマンド、Catalyst 3524XL スイッチでは write erase コマンドを使用してクリアし、確実にデフォルトの設定になるようにしています。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

トランキングとは、複数の VLAN からのトラフィックを、2 台のデバイス間のポイントツーポイント リンクで伝送する方法です。 イーサネット トランキングは、次の 2 つの方法で実装できます。

  • ISL(Cisco 独自のプロトコル)

  • IEEE 802.1Q 規格

このドキュメントでは、Catalyst 3500 と Catalyst 5500 スイッチ間の単一リンクを経由して 2 つの VLAN からのトラフィックを伝送するトランクを作成しています。 2 つの VLAN 間でのルーティング方法に関する情報は、この文書の範囲外です。

重要事項

Catalyst 2940/2950/2955/2970 スイッチの場合:

Catalyst 2940 および 2950/2955 シリーズのスイッチでサポートされているのは、802.1Q トランキングだけです。 これらのスイッチでは ISL トランキングはサポートされていません。

Catalyst 2970 シリーズのスイッチは、ISL と 802.1Q の両方のトランキングをサポートしています。

Catalyst 2900XL/3500XL スイッチの場合:

Catalyst 2900XL/3500XL スイッチは、Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)をサポートしていません。 トランク リンクの反対側で、switchport trunk コマンドの nonegotiate オプションを使用してください。 nonegotiate オプションを使用すると、XL スイッチが処理できないピアからの DTP フレームの受信を防止できます。

注: 4MB DRAM の Catalyst 2900XL スイッチでは、次のトランキング対応モジュールでだけトランキングがサポートされます。

  • WS-X2914-XL-V

  • WS-X2922-XL-V

  • WS-X2924-XL-V

  • WS-X2931-XL

  • WS-X2932-XL

トランキングをサポートするスイッチ モデルの最新リストについては、次の表を参照してください。

スイッチのモデル ISL トランキングに最低限必要な Cisco IOS ソフトウェア リリース 802.1Q トランキングに最低限必要な Cisco IOS ソフトウェア リリース トランキング(ISL/802.1Q)に必要な現在の Cisco IOS ソフトウェア リリース
WS-C2916M-XL(4 MB スイッチ) Cisco IOS ソフトウェア リリース 11.2(8)SA4, Enterprise Edition Cisco IOS ソフトウェア リリース 11.2(8)SA5, Original Edition Cisco IOS ソフトウェア リリース 11.2(8.6)SA6, Original Edition
WS-C2912-XL WS-C2924-XL WS-C2924C-XL WS-C2924M-XL WS-C2912MF-XL Cisco IOS ソフトウェア リリース 11.2(8)SA4, Enterprise Edition Cisco IOS ソフトウェア リリース 11.2(8)SA5, Original Edition Cisco IOS ソフトウェア リリース 12.0(5)WC(1) 以降
WS-C2924M-XL-DC Cisco IOS ソフトウェア リリース 12.0(5)XU Cisco IOS ソフトウェア リリース 12.0(5)XU Cisco IOS ソフトウェア リリース 12.0(5)WC(1) 以降
WS-C3508G-XL WS-C3512-XL WS-C3524-XL Cisco IOS ソフトウェア リリース 11.2(8)SA4, Enterprise Edition Cisco IOS ソフトウェア リリース 11.2(8)SA5, Original Edition Cisco IOS ソフトウェア リリース 12.0(5)WC(1) 以降
WS-C3548-XL Cisco IOS ソフトウェア リリース 12.0(5)XP, Enterprise Edition Cisco IOS ソフトウェア リリース 12.0(5)XP, Enterprise Edition Cisco IOS ソフトウェア リリース 12.0(5)WC(1) 以降
WS-C3524-PWR-XL WS-C3524-PWR-XL Cisco IOS ソフトウェア リリース 12.0(5)XU Cisco IOS ソフトウェア リリース 12.0(5)XU Cisco IOS ソフトウェア リリース 12.0(5)WC(1) 以降
WS-C2940-8TF-S WS-C2940-8TT-S ISL 非サポート Cisco IOS ソフトウェア リリース 12.1(13)AY 802.1Q のための Cisco IOS ソフトウェア リリース 12.1(13)AY またはそれ以降 ISL のためのサポート無し
WS-C2950-12 WS-C2950-24 WS-C2950C-24 WS-C2950T-24 WS-C2955T-12 WS-C2955C-12 WS-C2955S-12 ISL 非サポート Cisco IOS ソフトウェア リリース 12.0(5)WC(1) 802.1Q のための Cisco IOS ソフトウェア リリース 12.0(5)wc(1) または それ以降 ISL のためのサポート無し
WS-C2970G-24T-E Cisco IOS ソフトウェア リリース 12.1(11)AX Cisco IOS ソフトウェア リリース 12.1(11)AX Cisco IOS ソフトウェア リリース 12.1(11)AX 以降

注: この表では、WS-C2916M-XL だけが 4MB DRAM スイッチです。 リストされているその他のスイッチは、すべて 8MB DRAM スイッチです。 スイッチの DRAM が 4 MB か 8 MB かを判断するには、ユーザレベルの show version コマンドを発行します。 詳細は、『コマンドライン インターフェイスを使用した Catalyst 2900XL および 3500XL スイッチでのソフトウェアのアップグレード』の「コマンドライン インターフェイスを使用したスイッチのメモリ キャパシティを判別する方法」セクションを参照してください。

Catalyst 4500/4000、5500/5000、および 6500/6000 スイッチの場合:

  • Catalyst 4500/4000 シリーズ(Catalyst 2948G および Catalyst 2980G を含む)でサポートされるのは、802.1Q トランキングだけです。 このシリーズでは ISL トランキングはサポートされていません。

  • Catalyst 6500/6000 シリーズ スイッチ上のどのイーサネット ポートでも、802.1Q または ISL のいずれかのカプセル化がサポートされています。

  • Catalyst 5500/5000 のトランク対応ポートでは、ISL カプセル化だけがサポートされている場合と、ISL と 802.1Q のいずれかがサポートされている場合があります。 このサポート シナリオはモジュールによって異なります。 サポートを確認するには、show port capabilities コマンドを発行します。 コマンド出力にトランキング キャパシティが明示的に表示されます。 次に例を示します。

    cat5509 show port capabilities 3
    Model                    WS-X5234
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    
    !--- This port supports both 802.1Q and ISL.
    
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4 
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),tx-(1q4t)
    CoS rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
  • トランク リンクの両側でトランキング モードが一致していることを確認してください。 リンクの片側を ISL トランクとして設定した場合は、リンクの反対側も ISL として設定します。 同様に、リンクの片側を 802.1Q として設定した場合は、リンクの反対側も 802.1Q として設定します。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/8758/43a.gif

設定

このドキュメントでは、次のスイッチ設定を使用します。

このドキュメントでは、次の設定をスイッチに適用しています。

  • VLAN Trunk Protocol(VTP)モードをスイッチで設定します。

  • 第 2 の VLAN(VLAN 2)をスイッチで追加します。

    注: これらの VLAN にポートを追加します。

  • スイッチを相互接続するファースト イーサネット リンク上で ISL または 802.1Q を使用したトランキングを有効にします。

    これにより、このトランクはすべての VLAN のトラフィックを伝送できるようになります。

  • ワークステーションが接続されているポート上でスパニングツリー PortFast を有効にします。

    トポロジに応じて、Catalyst 5500 上のポート 3/2 と 3/3 と、Catalyst 3524XL スイッチ上のポート FastEthernet0/2 と FastEthernet0/3 でスパニング ツリー PortFast を有効にします。

この手順では、トランキングを設定するために必要なコマンドを示しています。 それぞれのステップには、Cisco IOS ソフトウェア コマンドと CatOS コマンドが含まれています。 コマンドの選択は、スイッチで稼働しているソフトウェアに基づいて行います。

  1. 両方のスイッチで VTP を設定します。

    この例では、VTP モードを透過モードに設定します。 スイッチは、クライアントまたはサーバのいずれかとして設定することもできます。 詳細については、『VLAN の作成と保守』を参照してください。

    • Cisco IOS ソフトウェア

      IOSSwitch#vlan database
      3524xl(vlan)#vtp transparent
      Setting device to VTP TRANSPARENT mode.
    • CatOS

      CatOSSwitch> (enable) set vtp mode transparent
      VTP domain modified
  2. 追加の VLAN を作成します。

    この例のように VTP モードが透過モードである場合は、両方のスイッチでこのステップを実行する必要があります。 それ以外のモードの場合、追加 VLAN は、VTP サーバ スイッチだけで定義すれば済みます。

    • Cisco IOS ソフトウェア

      IOSSwitch(vlan)#vlan 2
      VLAN 2 added:
      Name: VLAN0002
      IOSSwitch(vlan)#exit
      APPLY completed.
      Exiting....
    • CatOS

      CatOSSwitch(enable) set vlan 2
      VTP advertisements transmitting temporarily stopped,
      and will resume after the command finishes.
      Vlan 2 configuration successful
  3. いくつかのポートを VLAN に割り当てると同時に、必要な場合はこれらのポートで PortFast を有効にします。

    • Cisco IOS ソフトウェア

      IOSSwitch(config)#interface fastethernet 0/2
      IOSSwitch(config-if)#switchport access vlan 2
      IOSSwitch(config-if)#spanning-tree portfast
      %Warning: portfast enabled on FastEthernet0/2.
      
      !--- Usually, you need to enable PortFast on ports that connect 
      !--- to a single host. When you have enabled PortFast,  
      !--- hubs, concentrators, switches, and bridges that connect to this 
      !--- interface can cause temporary spanning tree loops.
      !--- Use PortFast with CAUTION.
      
      IOSSwitch(config-if)#exit
      
    • CatOS

      CatOSSwitch> (enable) set vlan 2 3/2
      Vlan 2 configuration successful
      VLAN 2 modified.
      VLAN 1 modified.
      VLAN Mod/Ports
      ---- -----------------------
      2     3/2 
      CatOSSwitch> (enable) set spantree portfast 3/2 enable
      
  4. ポートでトランキングを有効にします。

    • Cisco IOS ソフトウェア

      IOSSwitch(config)#interface fastethernet 0/1
      IOSSwitch(config-if)#switchport mode trunk
      
    • CatOS

      このステップは、CatOS スイッチでは省略してください。 ステップ 5 で、ポートをトランクとして指定し、同時にカプセル化を定義します。

  5. トランキングのカプセル化を ISL または 802.1Q(dot1q)のいずれかとして入力します。

    • Cisco IOS ソフトウェア

      IOSSwitch(config-if)#switchport trunk encapsulation isl
      
      OR
      
      IOSSwitch(config-if)#switchport trunk encapsulation dot1q
      

      注: 2940/2950 スイッチの場合、上記の switchport コマンドは使用しないでください。 Catalyst 2940/2950 スイッチでサポートされているのは、802.1Q カプセル化だけです。 switchport mode trunk コマンドを使用してインターフェイスでトランキングを有効にすると、自動的に 802.1Q カプセル化が設定されます。

    • CatOS

      CatOSSwitch> (enable) set trunk 3/1 nonegotiate isl
      Port(s) 3/1 trunk mode set to nonegotiate.
      Port(s) 3/1 trunk type set to Isl.
      
      !--- This switch connects to a 2900XL. 
      !--- Therefore, you must use the nonegotiate option. 
      
      CatOSSwitch> (enable)

      または

      
      !--- If you want to configure 802.1Q trunking instead,
      !--- issue this command:
      
      CatOSSwitch>(enable) set trunk 3/1 nonegotiate dot1q
      

    トランキングモードのための複数のオプションが、あります(以下を参照): 、自動、好ましい、オート、および nonegotiate。 それぞれの詳細は、設定するスイッチ製品に該当する CatOS ソフトウェアの設定のページを参照してください。

    802.1Q の場合は、リンクの両側でネイティブ VLAN が一致することを確認する必要があります。 デフォルトでのネイティブ VLAN は 1、または、ポートに設定されている VLAN になります。 ネットワーク上で VLAN 1 以外をネイティブ VLAN にする必要がある場合は、ネイティブ VLAN を変更できます。 デフォルトのネイティブ VLAN を変更する場合は、リンクの反対側でもネイティブ VLAN を変更する必要があります。 ネイティブ VLAN を変更するには、次のいずれかのコマンドを発行します。

    • Cisco IOS ソフトウェア

      switchport trunk native vlan vlan-ID
      
      
    • CatOS

      set vlan vlan-ID module/port
      
      

      注: このコマンドの module/port はトランク ポートです。

注: この出力は、3524XL スイッチでコマンドを発行した場合の例を示しています。 青字で記されたコメントは、特定のコマンドとステップを説明するためのものです。

Catalyst 3524XL
3524xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3524xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface fastethernet0/1
switchport mode trunk
!

!--- If you have configured 802.1Q, 
!--- you instead see this output 
!--- under interface fastethernet0/1:
!--- interface fastethernet0/1
!--- switchport trunk encapsulation dot1q
!--- switchport mode trunk


!
interface fastethernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface fastethernet0/3
spanning-tree portfast
!
interface fastethernet0/4
!

!--- Output suppressed.
!
interface VLAN1
ip address 10.10.10.2 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
password mysecret
login
line vty 5 15
login
!
end

注: この出力は、5500 スイッチでコマンドを発行した場合の例を示しています。 青字で記されたコメントは、特定のコマンドとステップを説明するためのものです。

Catalyst 5500
cat5509> (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
........

..................

..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
!
set enablepass $2$FNl3$8MSzcpVMg1H2aWfll13aZ.
!
#system
set system name  cat5509
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state 
 active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state 
 active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state 
 active mode srb aremaxhop 7 stemaxhop 7 backupcrf off
!
#ip
set interface sc0 1 10.10.10.3/255.255.255.0 10.10.10.255
!
!
# default port status is enable
!
!
#module 1 : 4-port 10/100BaseTX Supervisor
!
#module 2 : 3-port 1000BaseX Ethernet
!
#module 3 : 24-port 10/100BaseTX Ethernet
set vlan 2  3/2
set trunk 3/1 nonegotiate isl 1-1005

!--- If you have configured 802.1Q trunk, 
!--- this line displays as:
!--- set trunk 3/1 nonegotiate dot1q 1-1005


set spantree portfast 3/2-3 enable
!
#module 4 empty
!
#module 5 empty
!
#module 6 : 24-port 10BaseF Ethernet
!
#module 7 empty
!
#module 8 : 24-port 10/100BaseTX Ethernet
!
#module 9 empty
end
cat5509> (enable)

確認

show コマンド

このセクションでは、設定が正しく動作していることを確認するために使用できる情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

Catalyst 2900XL/3500XL/2950 スイッチの場合:

  • show interfaces {ファーストイーサネット | gigabitethernet}モジュール/ポート スイッチポート

  • show vlan

  • show vtp status

Catalyst 5500/5000 スイッチの場合:

  • show port capabilities module/port

  • show port module/port

  • show trunk module/port

  • show vtp domain

show コマンドの出力例

Catalyst 3500XL スイッチ

  • show interfaces {ファーストイーサネット | gigabitethernet}モジュール/ポート スイッチポート

    このコマンドは、ポートの管理ステータスおよび動作ステータスを確認するために使用します。 また、トランクの両側でネイティブ VLAN が一致していることを確認する場合にも、このコマンドを使用します。 ポートが 802.1Q トランキング モードに設定されている場合、ネイティブ VLAN はタグなしのトラフィックを処理します。 ネイティブ VLAN についての詳細は、『VLAN の作成と保守』を参照してください。

    3524xl#show interfaces fastethernet 0/1 switchport 
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: isl
    Operational Trunking Encapsulation: isl
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No

    注: 802.1q トランキングに関しては、show interfaces {ファーストイーサネットの出力 | gigabitethernet}モジュール/ポート switchport コマンドはこのように変更します:

    3524xl#show interfaces fastethernet 0/1 switchport 
    Name: Fa0/1
    Switchport: Enabled
    Administrative mode: trunk
    Operational Mode: trunk
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: Disabled
    Access Mode VLAN: 0 ((Inactive))
    Trunking Native Mode VLAN: 1 (default)
    Trunking VLANs Enabled: ALL
    Trunking VLANs Active: 1,2
    Pruning VLANs Enabled: 2-1001
    
    Priority for untagged frames: 0
    Override vlan tag priority: FALSE
    Voice VLAN: none
    Appliance trust: none
    Self Loopback: No
  • show vlan

    このコマンドは、インターフェイス(ポート)が正しい VLAN に属していることを確認するために使用します。 この例では、インターフェイスだけ Fa0/2 VLAN 2 に属します。 インターフェイスの他は VLANの構成員 1 です:

    3524xl#show vlan 
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                    Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                    Fa0/11, Fa0/12, Fa0/13, Fa0/14,
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18,
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22,
                                                    Fa0/23, Fa0/24, Gi0/1, Gi0/2
    2    VLAN0002                         active    Fa0/2
    1002 fddi-default                     active    
    1003 token-ring-default               active    
    1004 fddinet-default                  active    
    1005 trnet-default                    active    
    
    !--- Output suppressed.
    
    
  • show vtp status

    このコマンドは、スイッチ上の VTP 設定をチェックするために使用します。 この例では、VTP モードは Transparent です。 正しい VTP モードは、使用しているネットワークのトポロジによって異なります。 VTP についての詳細は、『VLAN の作成と保守』を参照してください。

    3524xl#show vtp status
    VTP Version                     : 2
    Configuration Revision          : 0
    Maximum VLANs supported locally : 254
    Number of existing VLANs        : 6
    VTP Operating Mode              : Transparent
    VTP Domain Name                 : 
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x74 0x79 0xD3 0x08 0xC0 0x82 0x68 0x63 
    Configuration last modified by 10.10.10.2 at 3-1-93 00:05:30

CatOS スイッチ

  • show port capabilities module/port

    このコマンドは、ポートがトランキング対応になっているかどうかをチェックするために使用します。

    cat5509 show port capabilities 3/1
    Model                    WS-X5234
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1Q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  3/1-2,3/1-4 
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off,on)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(none),TX(1q4t)
    COs rewrite              yes
    ToS rewrite              IP-Precedence
    Rewrite                  yes
    UDLD                     yes
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
  • show port module/port

    cat5509> (enable) show port 3/1
    
    Port  Name               Status     Vlan       Level  Duplex Speed Type
    ----- ------------------ ---------- ---------- ------ ------ ----- ------------
     3/1                     connected  trunk      normal a-full a-100 10/100BaseTX
    
    Port  AuxiliaryVlan AuxVlan-Status
    ----- ------------- --------------
     3/1  none          none          
    
    
    Port  Security Violation Shutdown-Time Age-Time Max-Addr Trap     IfIndex
    ----- -------- --------- ------------- -------- -------- -------- -------
     3/1  disabled  shutdown             0        0        1 disabled      12
    
    Port  Num-Addr Secure-Src-Addr   Age-Left Last-Src-Addr     Shutdown/Time-Left
    ----- -------- ----------------- -------- ----------------- ------------------
     3/1         0                 -        -                 -        -         -
    
    !--- Output suppressed.
    
    
  • show trunk module/port

    このコマンドは、トランキングのステータスと設定を確認するために使用します。

    cat5509> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  isl            trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     3/1      1-2
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
    

    注: 802.1Q トランキングの場合、このコマンドの出力は、次のように変わります。

    cat5509> (enable) show trunk
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     3/1      1-2
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
    
  • show vtp domain

    cat5509> (enable) show vtp domain
    DomainName                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
                                     1            2           Transparent -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    6          1023             0               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    10.10.10.3      disabled disabled 2-1000

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8758