IP : 拡張内部ゲートウェイ ルーティング プロトコル(EIGRP)

ルーティング プロトコルの再配送

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2006 年 9 月 7 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次

RIP

概要

他のルーティング プロトコルやスタティック ルート、直接接続されたルートなど、他の何らかの手段によって学習されたルートをアドバタイズするためにルーティング プロトコルを使用することを、再配送といいます。 本来であれば IP インターネットワーク全体にわたって 1 つのルーティング プロトコルを実行することが望ましいのですが、企業の合併、複数のネットワーク管理者によって管理されている複数の部門、マルチベンダー環境などのさまざまな理由により、マルチプロトコル ルーティングの使用は一般的になっています。 多くの場合、ネットワーク設計の一環として、異なるルーティング プロトコルを実行します。 いずれにせよ、マルチプロトコル環境を構築していれば、再配送の必要性が生じてきます。

メトリック、管理距離、クラスフル機能、クラスレス機能などのルーティング プロトコル特性における相違が再配送に影響を与える場合があります。 正常に再配送するには、これらの相違について考慮する必要があります。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) ソフトウェア リリース 12.2(10b)

  • Cisco 2500 シリーズ ルータ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

メトリクス

あるプロトコルから別のプロトコルに再配送するときは、各プロトコルのメトリックが重要な役割を果たします。 各プロトコルは異なるメトリックを使用します。 たとえば、Routing Information Protocol(RIP)のメトリックはホップ カウントに基づいていますが、Interior Gateway Routing Protocol(IGRP)と Enhanced Interior Gateway Routing Protocol(EIGRP)は、帯域幅、遅延、信頼性、負荷、および最大伝送ユニット(MTU)に基づいた複合メトリックを使用しており、帯域幅と遅延のみがデフォルトで使用されます。 経路を再配送するときは、受信側プロトコルにとって理解可能なメトリックを定義する必要があります。 経路を再配送するときのメトリックを定義する方法には、次の 2 通りがあります。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-a.gif

各々の再配送ルートに対して個別にメトリックを定義できます。

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

あるいは、すべての再配送ルートに対してデフォルトと同じメトリックを使用できます(default-metric コマンドを使用すると、再配送ごとに個別にメトリックを定義する必要がなくなるため、手間が省けます)。

router rip
redistribute static
redistribute ospf 1
default-metric 1

アドミニストレーティブ ディスタンス

ルータが複数のルーティング プロトコルを実行していて、両方のルーティング プロトコルを使用して同じ宛先への経路を学習する場合は、どちらの経路が最適経路として選択されるのでしょうか。 各プロトコルは独自のメトリック タイプを使用して最適経路を判断します。 メトリック タイプの異なる経路同士を比較することはできません。 この問題に対処するのが管理距離です。 管理距離は、経路の発信元に割り当てられるので、最も望ましい発信元からの経路が最適経路として選択されます。 管理距離と経路選択の詳細については、「Cisco ルータにおける経路の選択」を参照してください。

管理距離は異なるルーティング プロトコル間での経路選択に役立ちますが、再配送に関する問題を引き起こす場合があります。 ルーティング ループ、コンバージェンスの問題、または非効率なルーティングの形で問題が出てきます。 次にトポロジと起こり得る問題の説明を示します。

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

上記のトポロジで、R1では RIP 、R2 と R5 で RIP と IGRP が稼動していて、ここで R2 と R5 が RIP を IGRP に再配送すると、問題が生じる可能性があります。 R2 と R5 はどちらも RIP を使用して R1 から ネットワーク 192.168.1.0 を学習しています。 この情報は IGRP に再配送されます。 そこで R2 は IGRP を使用して R3 からネットワーク 192.168.1.0 を学習し、R5 は同じく IGRP を使用して R4 からネットワーク 192.168.1.0 を学習してしまいます。 IGRP のアドミニストレーティブ ディスタンスは RIP よりも小さい(IGRP は 100 で RIP は 120)ため、 ルーティング テーブルで使用されるのは、IGRP ルートになります。 これにより、ルーティング ループが発生する可能性があります。 スプリット ホライズンや、ルーティング ループを防止するための機能が対処策として使われ、それが効果を発揮した場合でも、コンバージェンスの問題が残ります。

また、R2 と R5 が IGRP を RIP に再配送していて(相互再配送とも呼ばれる)、なおかつネットワーク 192.168.1.0 が R1 に直接接続されていない場合(R1 が自身よりアップストリームにある別のルータから学習している場合)は、R1 がオリジナルの発信元よりもメトリックが適切なネットワークを R2 または R5 から学習してしまう問題が起こり得ます。

注: ルート再配送のメカニズムは、シスコ ルータ独自のものです。 シスコ ルータでの再配送のルールは、再配送ルートをルーティング テーブル内に格納するように指定します。 ルートがルーティング トポロジまたはデータベース内にあるだけでは不十分です。 アドミニストレーティブ ディスタンス(AD)が低いルートが、常にルーティング テーブルに格納されます。 たとえば、スタティック ルートが R5 の IGRP に再配送され、それに続いて IGRP が同一ルータ(R5)上の RIP に再配送された場合、スタティック ルートは IGRP のルーティング テーブルに格納されることがないため、RIP には再配送されません。 これは、スタティック ルートの AD が 1 で、IGRP ルートの AD が 100 であるため、スタティック ルートはルーティング テーブルに格納されることに起因します。 R5 の IGRP にスタティック ルートを再配送するには、router rip コマンドの下で redistribute static コマンドを使用する必要があります。

RIP、IGRP、および EIGRP のデフォルトの動作は、ルーティング プロトコル下の network 文に接続インターフェイスのサブネットが含まれる場合に、直接接続されたルートをアドバタイズすることです。 接続ルートを取得するには、次の 2 つの方法があります。

  • インターフェイスに IP アドレスとマスクが設定されている場合、これに対応するサブネットが接続ルートであるとみなされます。

  • スタティック ルートに発信インターフェイスだけが設定されており、IP ネクストホップが設定されていない場合、これも接続ルートであるとみなされます。

Router#conf t
   Router(config)#ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)#end

   Router#show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

これらいずれかのタイプの接続ルートを含む(または「カバーする」)EIGRP、RIP、または IGRP で設定された network コマンドには、アドバタイズするためのサブネットが含まれます。

たとえば、インターフェイスのアドレスが 10.0.23.1 で、マスクが 255.255.255.0 の場合、サブネット 10.0.23.0/24 が接続ルートとなり、network 文が次のように設定されると、これらのルーティング プロトコルによってアドバタイズされます。

router rip | igrp # | eigrp #
   network 10.0.0.0

このスタティック ルート 10.0.77.0/24 も、これらのルーティング プロトコルによってアドバタイズされます。これは接続ルートであり、network 文によって「カバー」されているからです。

この問題を回避するためのヒントについては、後の「再配送に起因する問題の回避」の項に記載されています。

再配送の設定の構文と例

IGRP と EIGRP

次の出力は、IGRP/EIGRP ルータがスタティック、Open Shortest Path First(OSPF)、RIP、および Intermediate System-to-Intermediate System(IS-IS)ルートを再配送する場合を示しています。

router igrp/eigrp 1 
network 131.108.0.0 
redistribute static
redistribute ospf 1 
redistribute rip 
redistribute isis 
default-metric 10000 100 255 1 1500

他のプロトコルを再配送する場合には、IGRP および EIGRP でそれぞれ 5 つのメトリック (帯域幅、遅延、信頼性、負荷、MTU)が必要です。 IGRP メトリックの例を次に示します。

メトリック
帯域幅 単位は 1 秒あたりのキロビット。 イーサネットの場合は 10000。
遅延 単位は 10 マイクロ秒。 イーサネットの場合は、100 x 10 マイクロ秒 = 1 ミリ秒
信頼性 信頼性が 100% の場合は 255。
負荷 経路の実効帯域幅。0~255 の数値で表される(255 が 100% の負荷を表す)。
MTU パスの最小 MTU。 通常はイーサネット インターフェイスの最小 MTU(1500 バイト)と同じ

ひとつのルータで複数の IGRP プロセスと EIGRP プロセスを実行し、このプロトコル間で再配送ができます。 たとえば、IGRP1 と IGRP2 を一つのルータで実行できます。 ただし、一つのルータで同じプロトコルのプロセスを 2 つ実行することが必要なケースはまれで、この場合ルータのメモリと CPU が大幅に消費されるおそれがあります。

IGRP/EIGRP を別の IGRP/EIGRP プロセスに再配送するときにはメトリックを変換する必要がないため、再配送時にメトリックの定義や、default-metric コマンドの使用は必要ありません。

再配送されたスタティック ルートは集約ルートよりも優先されます。スタティック ルートのアドミニストレーティブ ディスタンスは 1 ですが、EIGRP 集約ルートのアドミニストレーティブ ディスタンスは 5 であるためです。 この状況は、EIGRP プロセスの下で redistribute static を使用してスタティック ルートを再配送し、EIGRP プロセスにはデフォルトのルートがある場合に発生します。

OSPF

次の出力は、スタティック、RIP、IGRP、EIGRP、IS-IS ルートを再配送する OSPF ルータを示しています。

router ospf 1 
network 131.108.0.0 0.0.255.255 area 0 
redistribute static metric 200 subnets
redistribute rip metric 200 subnets 
redistribute igrp 1 metric 100 subnets 
redistribute eigrp 1 metric 100 subnets 
redistribute isis metric 10 subnets

OSPF メトリックはビット/秒のリンクの 108 帯域幅に基づくコスト値です。 たとえば、イーサネットのOSPFコストは10です: 108/107 = 10

注: メトリックが指定されていない場合、OSPF はどのプロトコルからルートを再配送するときもデフォルト値の 20 を設定します。ただし、Border Gateway Protocol(BGP)ルートだけは例外で、メトリック 1 が与えられます。

再配送するプロトコルのルートに、サブネット化されたメジャー ネットがある場合は必ず、キーワード subnet を使用してそのプロトコルからのルートを OSPF に再配送する必要があります。 このキーワードを指定しなければ、OSPF はルートをサブネット化しないメジャー ネットにしか再配送しません。

同じルータ上で複数の OSPF プロセスを実行することができます。 ただし前述のように、同じプロトコルのプロセスを複数実行する必要があるケースはまれであり、その場合はルータのメモリと CPU が大幅に消費されてしまいます。

ある OSPF プロセスを別の OSPF プロセスに再配送するときには、メトリックを定義したり、default-metric コマンドを使用したりする必要はありません。

RIP

注: この文書の原則は、RIP バージョン I と II に適用されます。

次の出力は、スタティック、IGRP、EIGRP、OSPF、および IS-IS ルートを再配送する RIP ルータを示しています。

router rip 
network 131.108.0.0 
redistribute static
redistribute igrp 1 
redistribute eigrp 1 
redistribute ospf 1 
redistribute isis 
default-metric 1

RIP メトリックはホップ カウントで構成されており、有効な最大メトリックは 15 です。 15 を超える値は無限と見なされます。 RIP で無限メトリックを示すには 16 を使用します。 プロトコルを RIP に再配送する場合、シスコでは 1 などの小さい値を使用することを推奨しています。 10 などの大きい値を使用すると、RIP がさらに制限されます。 再配送ルートに対してメトリック 10 を定義すると、これらのルートは最大 5 個のホップを経由してルータへアドバタイズすることができますが、このポイントではメトリック(ホップ カウント)は 15 を超えています。 メトリック 1 を定義すれば、RIP ドメイン内の最大ホップ数まで経路を伝達できます。 しかし、このようにすると、複数の再配送ポイントがあって、ルータが、より適切なメトリックのネットワークを元の送信元よりも再配送ポイントから学習するような場合、ルーティング ループが発生する可能性が高くなります。これについては、このドキュメントの「アドミニストレーティブ ディスタンス」セクションで説明されています。 したがって、複数の再配送ポイントがある場合は、すべてのルータへのアドバタイズを阻止するような高すぎるメトリックや、ルーティング ループが発生するような低すぎるメトリックの、どちらでもないことを確認する必要があります。

RIP のラスト リゾート ゲートウェイを除いたスタティック ルートをルート マップを使用して再配送する

この設定は、RIP のラスト リゾート ゲートウェイを除いたスタティック ルートを、ルートマップを介して再配送する例を示しています。

この例の初期設定:

router rip

version 2

network 10.0.0.0

default-information originate

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.32.32.3

ip route 10.32.42.211 255.255.255.255 192.192.192.102

ip route 10.98.0.0 255.255.255.0 10.32.32.1

ip route 10.99.0.0 255.255.255.0 10.32.32.1

ip route 10.99.99.0 255.255.255.252 10.32.32.5

ip route 67.129.103.128 255.255.255.240 10.32.31.1

ip route 156.55.231.0 255.255.255.0 10.32.32.5

ip route 172.16.28.0 255.255.252.0 10.32.32.5

ip route 192.168.248.0 255.255.255.0 10.32.32.5

ip route 199.43.0.0 255.255.255.0 10.32.32.5

ip route 204.103.0.0 255.255.255.0 10.32.32.5

次の手順を実行して設定します。

  1. 再配送する必要があるすべてのネットワークを照合するためのアクセス リストを作成します。

    Router#show access-lists 10
    
    Standard IP access list 10
    
        10 permit 10.32.42.211
    
        20 permit 10.98.0.0, wildcard bits 0.0.0.255
    
        30 permit 10.99.0.0, wildcard bits 0.0.0.255
    
        40 permit 67.129.103.128, wildcard bits 0.0.0.15
    
        50 permit 156.55.231.0, wildcard bits 0.0.0.255
    
        60 permit 172.16.28.0, wildcard bits 0.0.3.255
    
        70 permit 192.168.248.0, wildcard bits 0.0.0.255
    
        80 permit 199.43.0.0, wildcard bits 0.0.0.255
    
        90 permit 204.103.0.0, wildcard bits 0.0.0.255
  2. ルート マップのアクセス リストをコールします。

    Route-map TEST
    
     Match ip address 10
  3. route-map を使用して RIP を再配送し、rip プロセスから default information originate コマンドを削除します。

    Router RIP
    
    version 2
    
    network 10.0.0.0
    
    redistribute static route-map TEST
    
    no auto-summary

IS-IS

この出力は、スタティック、RIP、IGRP、EIGRP、OSPF ルートを再配送する IS-IS ルータを示しています。

router isis 
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20 
redistribute igrp 1 metric 20 
redistribute eigrp 1 metric 20 
redistribute ospf 1 metric 20

IS-IS のメトリックは 1 ~ 63 の範囲にしてください。 IS-IS には default-metric オプションがありません。上記の例に示すように、各プロトコルに対してメトリックを定義する必要があります。 IS-IS に再配送されるルートに対してメトリックが指定されていないと、デフォルトの 0 がメトリック値として使用されます。

接続されたルート

一般に、直接接続のネットワークをルーティング プロトコルに再配送することは行われていないため、ここに例は示されていません。 ただし、直接的または間接的にこれを行うことが可能であることを示しておくことは重要です。 接続ルートを直接再配送するには、redistribute connected ルータ設定コマンドを使用します。 この場合は、メトリックも定義する必要があります。 また、下記に示した例のように、接続されたルートを間接的にルーティング プロトコルに再配送することも可能です

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-cnctd.gif

上図の Router B には、2 つの ファースト イーサネット インターフェイスがあります。 FastEthernet 0/0 がネットワーク 10.1.1.0/24 にあり、FastEthernet 0/1 がネットワーク 20.1.1.0/24 にあります。 Router B は Router A に対しては EIGRP を、Router C に対しては OSPF を実行しています。Router B は EIGRP プロセスと OSPF プロセス間で相互に再配送されています。 Router B において、この設定に関する情報を下記に示します。

ルータ B
interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0

interface FastEthernet0/1
 ip address 20.1.1.4 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Router B のルーティングテーブルを見ると、以下のようになっています。

routerB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

上記の設定とルーティング テーブルについて、以下の 3 点に注意してください

  • 要件のネットワークは、Router B のルーティング テーブルに直接接続されたネットワークとして載っています。

  • ネットワーク 10.1.1.0/24 は EIGRP プロセスに属していて、ネットワーク 20.1.1.0/24 は OSPF プロセスに属しています。

  • Router B は、EIGRP と OSPF 間を相互に再配送しています。

次に、Routers A と C のルーティング テーブルを見てみましょう。

routerA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

ルータ A は、EIGRP 経由でネットワーク 20.1.1.0/24 を外部ルートとして学習しています。これは OSPF から EIGRP に再配送されているためです。 ルータ C は、OSPF 経由でネットワーク 10.1.1.0/24 を外部ルートとして学習しています。これは EIGRP から OSPF に再配送されているためです。 ルータ B は接続ネットワークを再配送していませんが、OSPF に再配送されている EIGRP プロセスの一部であるネットワーク 10.1.1.0/24 をアドバタイズしています。 同様に、Router B はネットワーク 20.1.1.0/24 を EIGRP に再配送された OSPF の一部として通知します。

OSPF に再配送される接続ルートの詳細については、『接続ネットワークの OSPF への再配送』を参照してください。

注: デフォルトでは、redistibute bgp コマンドが発行された場合、EBGP で認識された情報のみが IGP に再配送される対象となります。 router bgp コマンドで bgp redistribute-internal コマンドが設定されるまで、IBGP ルートは IGP には再配送されません。 ただし、IBGP ルートが IGP へ再配送される場合に自律システム内でのループを回避するために、注意が必要です。

再配送に起因する問題の回避

前述の「アドミニストレーティブ ディスタンス」の項で、ルーティングの最適化ができなかったり、、ルーティング ループ、コンバージェンスの遅延などの潜在的な問題が、再配送によってどのように引き起こされるのかを見ました。 このようなタイプの問題は、単純な方法で回避できます。ルーティング プロセス X から受け取った情報は、ルーティング プロセス X に逆方向アナウンスしないことです。

例 1

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-b.gif

上記のトポロジで、R2 と R5 は相互再配送を行っています。 次の設定が示すように、RIP は IGRP に再配送され、IGRP は RIP に再配送されています。

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

上記の設定では、前述した問題がいずれも発生する可能性があります。 問題を回避するには、次のようにルーティングアップデートにフィルタを使います。

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1 
 
router rip
network 178.1.0.0

redistribute igrp 7 metric 2 
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

上記のように設定にディストリビュート リストを追加すると、ルータのシリアル 1 インターフェイスに到達した IGRP アップデートがすべてフィルタリング対象となります。 アップデートのルートがアクセス リスト 1 で許可されている場合、ルータはアップデート内でこれらのルートを承認します。 拒否される経路は受け入れません。 この例では、ルータは、シリアル 1 インターフェイスで受信する IGRP アップデートを介してネットワーク 192.168.1.0 を学習するべきではないことが通知されています。 ネットワーク 192.168.1.0 について、これらのルータが保持している情報は、R1 から RIP を通じて得られたものだけです。

この例では、RIP は IGRP よりもアドミニストレーティブ ディスタンスが大きいので、RIP プロセスに対して同じフィルタを使用する必要がない点にも注意してください。 IGRP ドメインを発信元とする経路が RIP を通じて R2 と R5 にフィードバックされたとしても、IGRP 経路が優先されます。

例 2

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-c.gif

上記のトポロジを使用して、再配送問題を回避する別の方法について説明します。場合によっては、この方法を使用するのが望ましいことがあります。 この方法では、route-map を利用して各種経路にタグを設定します。 ルーティング プロセスはタグに基づいて再配送を実行します。 タグに基づいた再配送は、RIP バージョン 1 または IGRP には使用できないことに注意してください。

上記のトポロジで起こり得る問題の 1 つを次に示します。

R1 はネットワーク 192.168.1.0 を R2 にアドバタイズします。 続いて R2 は EIGRP に再配送します。 R5 は EIGRP を通じてネットワーク 192.168.1.0 を学習し、RIPv2 にそれを再配送します。 R5 が RIPv2 ルートに対して設定しているメトリックによっては、R6 はネットワーク 192.168.1.0 に到達するために、R1 ではなく R5 から取得した望ましくないルートを優先する可能性があります。 次の設定では、タグを設定し、そのタグに基づいて再配送を行うことで、この問題を回避しています。

R2:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIP routes that are
 

!--- permitted by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and set the tags
 

!--- according to the eigrp_to_rip route-map



route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag of "88"


!--- from being redistributed into EIGRP
  

!--- Notice the routes tagged with "88" should be the EIGRP
 

!--- routes that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag 


!--- on RIPv2 routes redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a
 

!--- tag of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2
 

!--- routes that are redistributed into EIGRP



route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP
 

!--- routes redistributed into RIPv2 to "88"

R5:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Redistributes RIPv2 routes that are permitted 


!--- by the route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Redistributes EIGRP routes and sets the tags 


!--- according to the eigrp_to_rip route-map




route-map rip_to_eigrp deny 10
match tag 88

!--- Route-map statement to deny any routes that have a tag
 

!--- of "88" from being redistributed into EIGRP


!--- Notice the routes tagged with "88" should be the EIGRP routes
 

!--- that are redistributed into RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Route-map statement to set the tag on rip routes 


!--- redistributed into EIGRP to "77"


route-map eigrp_to_rip deny 10
match tag 77

!--- Route-map statement to deny any routes that have a tag 


!--- of "77" from being redistributed into RIPv2


!--- Notice the routes tagged with "77" should be the RIPv2 routes
 

!--- that are redistributed into EIGRP


route-map eigrp_to_rip permit 20
set tag 88

!--- Route-map statement to set the tag on EIGRP routes 


!--- redistributed into RIPv2 to "88"

上記のように設定すると、ルーティング テーブルに格納された特定の経路を表示することで、タグが設定されていることを確認できます。 次の出力は、R3 および R1 で特定のルートに対して発行した show ip route コマンドから得られたものです。

R3#show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Tag 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1#show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Tag 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

EIGRP は、5 つの変数を使用してメトリックを計算します。 ただし、再配送されたルートにはこれらのパラメータがないため、ルートを一様には設定されません。 この場合のベスト プラクティスは、ルートを再配送するときに default-metric を設定することです。 default-metric を設定すると、EIGRP のパフォーマンスが改善されます。 EIGRP に対して、このコマンドでデフォルト値が入力されます。

Router(config-router)#default-metric 10000 100 255 100 1500

例 3

再配送は、同じルーティング プロトコルの異なるプロセスの間で行うこともできます。 次の設定は、同じルータまたは複数のルータで動作している 2 つの EIGRP プロセスを再配送するための再配送ポリシーの例です。

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 5 into EIGRP 3, setting the tags 


!--- according to the route map "to_eigrp_3"



router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500

!--- Redistributes EIGRP 3 into EIGRP 5


!--- Routes with tag 33 will not be redistributed
 

!--- due to route map "to_eigrp_5"
!--- Though the default-metric command is not required
!--- when redistributing between different EIGRP processes,
!--- you can use it optionally as shown above to advertise 
!--- the routes with specific values for calculating the metric.


route-map to_eigrp_3 deny 10
match tag 55

!--- Route-map statement used to deny any routes that have a tag
 

!--- of "55" from being redistributed into EIGRP 3


!--- Notice the routes tagged with "55" should be the EIGRP 3 routes
 

!--- that are redistributed into EIGRP 5


route-map to_eigrp_3 permit 20
 set tag 33

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 5 to EIGRP 3 to "33"


route-map to_eigrp_5 deny 10
 match tag 33

!--- Route-map statement used to deny any routes that have a tag 


!--- of "33" from being redistributed into EIGRP 5


!--- Notice the routes tagged with "33" should be the EIGRP 5 routes
 

!--- that are redistributed into EIGRP 3


route-map to_eigrp_5 permit 20
set tag 55

!--- Route-map statement used to set the tag on routes
 

!--- redistributed from EIGRP 3 to EIGRP 5 to "55"

ここでは、このドキュメントの目的に対して使用されるフィルタリング方法を数例のみ示しました。 これ以外にも、使用できる有効な方法があります。 詳細については、『IP ルーティング プロトコルに依存しない機能の設定』の「ルーティング情報のフィルタリング」セクションを参照してください。

例 4

たとえば 2 つのルータがあり、1 つは BGP プロトコルを実行しているハイエンド ルータで、もう 1 つは RIP プロトコルを実行しているロー エンド ルータであるとします。 BGP ルートを RIP に再配送する場合、いくつかのパケットの損失が見られることがあります。

BGP を RIP プロトコルへ再配送することは、一般には推奨されません。iBGP、OSPF、EIGRP などのプロトコルはスケーラブルで、さまざまなオプションを使用することができます。

このように、BGP と RIP 間の再配送でいくつかのパケットが損失する場合には、RIP プロセスで次のコマンドを設定しなければならないことがあります。

Router(Config)#router rip

Router(Config-router)# input-queue 1024

注: 高速で送信を行うハイエンド ルータがあり、高速では受信できない可能性のある低速ルータへ送信を行う場合は、input-queue コマンドを使用することを検討してください。 このコマンドを設定すると、ルーティング テーブルからの情報損失を回避するうえで役に立ちます。

例 5

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/8606-redist-d.gif

この例で、RIP ルーティング プロトコルへのスタティック ルートの再配送を示しています。 トポロジごとに、3 つのルータ(R1、R2、R3)があります。 R1 と R2 では、インターフェイス Fast Ethernet 0/0 に RIP が設定されています。 R1 には、ルータ R3 の Lo 0 インターフェイス(IP アドレス 3.3.3.3/32)に到達するためのスタティック ルートがあります。 このスタティック ルートは、RIP ルーティング プロトコルに再配送されます。 ルータ R3 はデフォルト ルート R3# ip route 0.0.0.0 0.0.0.0 FastEthernet 0/0 で設定されています。

R1(config)# ip route 3.3.3.3 255.255.255.255 10.13.13.3
R1(config)# router rip
R1(config-router) redistribute static metric 10

ルータ R2 では、show ip route コマンドを介してルート 3.3.3.3 を確認することができます。

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.12.12.0/24 is directly connected, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
R      3.3.3.3 [120/10] via 192.12.12.1, 00:00:07, FastEthernet0/0

1 つのスタティック ルートを再配送する方法

1 つのスタティック ルートを再配送するには、route-map を使用して、再配送する必要があるスタティック ルートを選択します。

Router(config)#access-list 1 permit <network no> <mask>

Router(config)#route-map <route-map name> permit 10
Router(config-route-map)#match ip address access list number

Router(config)#router eigrp <As number>

Router(config-router)#redistribute static route-map <map-name> metric <value>

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 8606