WAN : ポイントツーポイント プロトコル(PPP)

PPP バックツーバック接続

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2004 年 4 月 14 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、PPP のバックツーバック接続のための設定例について説明しています。 この設定を使用すると、接続とハードウェアが適切に動作していることを確認できます。また、テスト用に IP ルーティングを使用することもできます。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • この設定はすべての Cisco IOS に適当ですか。

  • DCE 側は WAN DCE ケーブルに接続されます。

  • DTE 側は WAN DTE ケーブルに接続されます。

WAN DCE か DTEケーブルに関する詳細については、シリアルケーブル ドキュメントを参照して下さい。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

設定の要約

この設定では、Router1 は V35-MT ケーブルを(Cisco 参照は CAB-V35MT です)使用し、Router2 は V35-FC ケーブルを使用します(Cisco 参照は CAB-V35FC です)。 これは、クロックは Router2 から提供されていることを意味します。 64000 ビット/秒のクロック レートはシリアルの下の clock rate 64000 コマンドの発行によって 0 インターフェイス使用されます。

このコマンドを設定すると、設定には clock rate 64000 と表示されます。 ここでは、2 本のケーブルが互いに接続されています。

イーサネット インターフェイスは、no keepalive コマンドを発行して設定します。 この方法では、イーサネット インターフェイスを起動して稼働状態にするためには、LAN ネットワークへの接続は不要です。 各ルータでのスタティック ルートを使用すると、Router1 のイーサネット インターフェイスの IP アドレスを使用して、Router2 のイーサネット インターフェイスの IP アドレスに ping を送ることができます(その逆も可能)。 当然、これはテスト環境で役立ちます。

ネットワーク図

このドキュメントは、次のコンフィギュレーションに基づいています。

/image/gif/paws/7923/ppp_backtoback.gif

設定

このドキュメントでは、次の設定を使用します。

Router1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.1.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.1 255.255.255.0
 encapsulation ppp
!
ip classless
ip route 10.2.0.0 255.255.255.0 10.0.0.2
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

Router2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
enable password cisco
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 10.2.0.1 255.255.255.0
 no keepalive
!
interface Serial0
 ip address 10.0.0.2 255.255.255.0
 encapsulation ppp
 no fair-queue
 clock rate 64000
!
ip classless
ip route 10.1.0.0 255.255.255.0 10.0.0.1
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 no login
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • ケーブルおよびクロック レートをチェックする show controllers コマンドを発行して下さい:

    show controllers コマンドの出力を次に示します。

    Router1#show controllers serial 0 | i V.35
    buffer size 1524  HD unit 0, V.35 DTE cable
    Router1#
    
  • パケットが送信され、受信されることを確認するために show interfaces serial 0 コマンドを発行して下さい(パケット入力するのをパケット出力5 分入力速度および 5 毎分心拍出量 比率が参照して下さい。 使用されるカプセル化に関する情報に関しては Encapsulation ppp を参照して下さい。

    show interfaces serial 0 コマンドの出力を次に示します。

    Router1#show interfaces serial 0
    Serial0 is up, line protocol is up
      Hardware is HD64570
      Internet address is 10.0.0.1/24
      MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation PPP, loopback not set
      Keepalive set (10 sec)
      LCP Open
      Open: IPCP, CDPCP
      Last input 00:00:00, output 00:00:00, output hang never
      Last clearing of "show interface" counters 00:07:53
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: weighted fair
      Output queue: 0/1000/64/0 (size/max total/threshold/drops)
         Conversations  0/5/256 (active/max active/max total)
         Reserved Conversations 0/0 (allocated/max allocated)
         Available Bandwidth 1158 kilobits/sec
      5 minute input rate 2000 bits/sec, 2 packets/sec
      5 minute output rate 2000 bits/sec, 2 packets/sec
         155 packets input, 55066 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         168 packets output, 60037 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 output buffer failures, 0 output buffers swapped out
         0 carrier transitions
         DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
    Router1#
    
  • IP アドレス 10.2.0.1 を使用して 10.2.0.2 に ping を送るには、次のように ping コマンドを発行します。

    ping コマンドの出力を次に示します。

    Router1#ping
    Protocol [ip]:
    Target IP address: 10.2.0.1
    Repeat count [5]:
    Datagram size [100]:
    Timeout in seconds [2]:
    Extended commands [n]: y
    Source address or interface: 10.1.0.1
    Type of service [0]:
    Set DF bit in IP header? [no]:
    Validate reply data? [no]:
    Data pattern [0xABCD]:
    Loose, Strict, Record, Timestamp, Verbose[none]:
    Sweep range of sizes [n]:
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.0.1, timeout is 2 seconds: Packet sent with a source address of 10.1.0.1 !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms Router1#
    

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show controllers — ケーブルおよびクロック レートを表示する。

  • show interfaces serial 0 —パケットが送信され、受信されることを確認します。

  • ping — デバイスの接続をテストするのに使用しました。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連情報


Document ID: 7923