IP : Open Shortest Path First(OSPF)

OSPF 設計ガイド

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2008 年 2 月 7 日) | 英語版 (2015 年 4 月 27 日) | フィードバック


目次


概要

RFC 2328 で定義されている Open Shortest Path First(OSPF)プロトコルは、単一の自律システム内でルーティング情報の配信に使用される内部ゲートウェイ プロトコルです。leavingcisco.com この用紙は OSPF がどのようにはたらく、そしてどのように大きいおよび複雑なネットワークを設計し、構築するのに使用することができるか検査します。

背景説明

OSPF プロトコルは、TCP/IP プロトコル ファミリとして高機能で非独占的な Internal Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)を導入するというインターネット コミュニティでのニーズに基づいて開発されました。 1988 年に開始したインターネットのためのよくある相互運用可能な IGP の作成の説明は 1991 年まで形式化されて得なかったし。 この時点で OSPF ワーキング グループは、OSPF をドラフトインターネット標準に提案することを要望しました。

OSPFプロトコルは RIP のような従来のインターネットルーティング プロトコルで使用されるアルゴリズムに準拠したベルマン-フォードベクトルからの出発であるリンクステート技術に基づいています。 OSPF はルーティング更新の認証のような新しい概念を、可変長サブネット マスク(VLSM)、経路集約、等導入しました。

これらの章は今日の大きいのおよび複雑なネットワークの設計でプロトコルの OSPF 用語、アルゴリズムおよび賛否両論を論議します。

OSPF 対 RIP

今日のネットワークの急速な発展と拡張によって、RIP はすでに限界に達しています。 RIP に大規模なネットワークで問題を引き起こす場合がある一定の制限があります:

  • RIP では、ホップ カウントが 15 に制限されています。 15 ホップ(15 台のルータ)を超える規模の RIP ネットワークは到達不能と見なされます。

  • RIP は VLSM を処理できません。 IP アドレスの不足や、IP アドレスの効率的な割り当てを可能にする VLSM の柔軟性を考えると、これは重大な欠点と言えます。

  • フルルーティングテーブルの定期的なブロードキャストは多量の帯域幅を消費します。 これは、特に低速リンクと WAN クラウドを含む大規模なネットワークでは大きな問題となります。

  • RIP のコンバージェンスは OSPF より時間がかかります。 大規模なネットワークでは、コンバージェンス時間が分単位になります。 RIP ルータは最近受け取られてしまわなかったホールドダウンの期間をおよび Garbage Collection およびゆっくりタイムアウト情報通過します。 これは、大規模なネットワーク環境には適しておらず、ルーティングの情報の不一致が生じるおそれがあります。

  • RIP には、ネットワーク遅延とリンク コストの概念がありません。 ホップカウントに基づいて、ルートを選択します。 宛先への最低のホップカウントのパスはより長いパスによりよい集合リンク帯域幅およびより少ない遅延があっても常に好まれます。

  • RIP ネットワークは均一のネットワークです。 エリアや境界の概念はありません。 クラスレス ルーティングの導入や、集約とサマライゼーションのインテリジェントな使用の点で、RIP ネットワークは遅れをとっているように見えます。

RIP2 と呼ばれる RIP の新バージョンで、いくつかの改良が加えられました。 RIP2 は、VLSM、認証、およびマルチキャスト ルーティング更新の機能に対応しています。 しかし、今日の大規模ネットワークで最も重大な問題とされるホップ カウントの制限やコンバージェンスの遅さが修正されていないため、RIP(以降 RIP1 と呼ぶ)の問題点が解消されたとは言えません。

OSPF、一方では、以前に示される問題の最もアドレス:

  • OSPF にはホップ カウントの制限はありません。

  • VLSMを活用することで、IPアドレスを有効に利用できます。

  • OSPF は、IP マルチキャストを使用して、リンクステート更新を送信します。 これにより、OSPF パケットを受信しないルータ上での処理が軽減されます。 また、更新は定期的に送信されるのではなく、ルーティングが変更されたときのみ送信されます。 これにより、帯域幅を有効に利用できます。

  • OSPF のコンバージェンスは RIP より高速です。 これは、ルーティングの変更が定期的ではなく即時に伝搬されるためです。

  • OSPF では、RIPより適切なロード バランシングが可能です。

  • OSPF では、ネットワークを論理的に定義して、ルータを複数のエリアに分割できます。 これはネットワーク全体上のリンク状態更新の急激な増加を制限します。 また、経路を集約してサブネット情報の不要な伝搬を削減することも可能です。

  • OSPF では、各種のパスワード認証方式を使用して、ルーティング認証を実装できます。

  • OSPF は、自律システムに再配信された外部経路の転送と外部経路であることを示すタグを付ける機能をサポートしています。 これにより、BGP などの外部プロトコルによって注入された外部経路を常に把握できます。

これは OSPF ネットワークの設定およびトラブルシューティングのより多くの複雑な状況の当然原因となります。 RIP の単純に使用する管理者は OSPF ネットワークに遅れずについていくために学ばなければならない新情報の量と挑戦されます。 また、これはメモリ 割り当ておよび CPU稼働率のオーバーヘッドを導入します。 RIP を実行しているルータによっては、OSPF によって生じるオーバーヘッドを処理するためにアップグレードしなければならない場合があります。

リンクステートとは

OSPF はリンクステート プロトコルです。 シスコでは、リンクをルータ上のインターフェイスと見なしています。 リンクのステート(状態)とは、そのインターフェイスの記述であり、近接ルータとの関係の記述です。 インターフェイスの記述には、たとえば、インターフェイスの IP アドレス、マスク、接続先のネットワークのタイプ、そのネットワークに接続されているルータなどが含まれます。 これらのリンクステートすべてが集まって、リンクステート データベースが形成されています。

最短パス優先アルゴリズム

OSPF はすべての既知 宛先に最短パスを構築し、計算するために最短パス最初アルゴリズムを使用します。最短パスはダイクストラのアルゴリズムの使用と計算されます。 このアルゴリズム自体は非常に複雑です。 これは非常に高いレベル、アルゴリズムのさまざまなステップを検知 する 単純化された方法です:

  1. 初期化にまたはルーティング情報のあらゆる変更が原因で、ルータはリンク状態アドバタイズメントを生成します。 このアドバタイズメントはそのルータのすべてのリンクステートの収集を表します。

  2. すべてのルータはフラッディングによってリンクステートを交換します。 リンクステート更新を受信した各ルータは、自身のリンクステート データベースにコピーを保存してから、その更新を他のルータに伝搬します。

  3. 各ルータのデータベースが完了した後、ルータはすべての宛先に最短パスツリーを計算します。 ルータは最短パスツリーを計算するためにダイクストラのアルゴリズムを使用します。 それらの宛先に到達する宛先、関連コストおよびネクスト ホップは IPルーティングテーブルを形成します。

  4. OSPF ネットワークでリンクのコストやネットワークが追加または削除されるなどの変更がない場合、OSPF は非常に「静か」です。 発生するどの変更でもリンクステート パケットおよびダイクストラのアルゴリズムを通して計算し直されます最短パスを見つけるために伝えられます。

このアルゴリズムは、各ルータをツリーのルートに配置し、各宛先に到達するために必要な累計コストに基づいて宛先への最短パスを計算します。 すべてのルータが同じリンクステート データベースを使用して最短パス ツリーを作成した場合でも、トポロジ ビューは各ルータ固有のものになります。 次の項では、最短パス ツリーの作成に関する事柄について説明します。

OSPF コスト

OSPF におけるインターフェイスのコスト(メトリックとも呼ばれる)とは、特定のインターフェイスを経由してパケットを送信する際に必要なオーバーヘッドを示す指標です。 インターフェイスのコストは、そのインターフェイスの帯域幅に反比例します。 つまり、帯域幅が大きいほどコストは小さくなります。 10M イーサネット回線を経由するよりも、56K シリアル回線を経由する方が、必要なオーバーヘッドが高くなり(コストが大きくなり)、時間の遅延が長くなります。 コストの計算には次の公式が使用されます。

  • コスト = 100,000,000 / 帯域幅(bps)

たとえば、それは 10 EXP8/10 を EXP7 = 10M イーサネット ラインを交差させる 10 要し、10 を EXP8/1544000 = T1 行を交差させる 64 要しました。

デフォルトで、インターフェイスのコストは帯域幅に基づいて計算されます; ip ospf cost <value> インターフェイス subconfiguration モード コマンドでインターフェイスのコストを強制できます。

最短パス ツリー

次のネットワーク ダイアグラムについて考えてみます。ルータの脇の数字はインターフェイスのコストを示します。 RTA の最短パス ツリーを作成するには、RTA をツリーのルートに配置して、各宛先の最小コストを計算する必要があります。

/image/gif/paws/7039/spf1.gif

上記の図は、RTA から見たネットワークのビューです。 コストを計算する際は、矢印の向きに注意してください。 たとえば、RTB のインターフェイスの、ネットワーク 128.213.0.0 へのコストは、192.213.11.0 へのコストを計算する際には関係ありません。 RTA は、RTB を経由してコスト 15(10+5)で 192.213.11.0 に到達できます。 また、RTA が 222.211.10.0 に到達するには、RTC を経由したコスト 20(10+10)の経路と、RTB を経由したコスト 20(10+5+5)の経路があります。 同じ宛先へのコスト パスが等しい場合、シスコの OSPF 実装では、1 つの宛先に対して最大 6 のネクストホップを記録します。

ルータは、最短パス ツリーを作成した後、それに従ってルーティング テーブルの作成を開始します。 直接接続ネットワークにはメトリック(コスト)0 で到達し、それ以外のネットワークには、ツリーで算出されたコストに基づいて到達します。

エリアと境界ルータ

前述したように、OSPF では、ルータ間のリンクステート更新の交換にフラッディングが使用されます。 ルーティング情報が変更されると、ネットワーク内のすべてのルータに対してフラッディングが実行されます。 エリアは、リンクステート更新の爆発的増加に対して境界を設定するために導入された概念です。 ルータでのフラッディングとダイクストラ アルゴリズムの計算は、エリア内の変更のみに限定されます。 エリア内のルータはすべて、まったく同一のリンクステート データベースを保持します。 複数のエリアに属し、そのエリアをバックボーン エリアに接続するルータは、Area Border Router(ABR; エリア境界ルータ)と呼ばれています。 したがって ABR は、バックボーン エリアやその他の接続エリアを記述する情報を維持管理する必要があります。

/image/gif/paws/7039/spf2.gif

エリアはインターフェイスに固有です。 すべてのインターフェイスが同じエリアに属しているルータのことを Internal Router(IR; インターナル ルータ)と呼びます。 複数のエリアへのインターフェイスを備えたルータのことを Area Border Router(ABR; エリア境界ルータ)と呼びます。 OSPF と他のルーティング プロトコル(IGRP、EIGRP、IS-IS、RIP、BGP、スタティック)、あるいは OSPF ルーティング プロセスの他のインスタンス間のゲートウェイとして機能するルータは、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)と呼ばれます。 どのルータでも、ABR または ASBR になることができます。

リンクステート パケット

リンクステート パケットにはさまざまなタイプがあり、それらは通常、OSPF データベースに保存されています(付録 A)。 次の図は、リンクステート パケットの各種タイプを示しています。

spf3.gif

上記の図からわかるように、ルータ リンクには、ある特定のエリアに属するルータ インターフェイスの状態が記述されています。 各ルータは、自身のインターフェイスすべてについてルータ リンクを生成します。 サマリー リンクは ABR によって生成されます; これはネットワーク到達可能性情報がエリアの間でどのように広められるかです。 通常は、バックボーン(エリア 0)にすべての情報が配送され、続いてその情報がバックボーンから他のエリアに渡されます。 ABR は、ASBR の到達可能性情報を伝搬する役割も担っています。 この情報には、各ルータが他の AS 内の外部経路の取得方法をどのように学習すればよいかが記述されています。

ネットワーク リンクは、セグメントの Designated Router(DR; 代表ルータ)によって生成されます(DR については後述します)。 この情報には、イーサネット、トークン リング、FDDI(NBMA も含む)などのある特定のマルチアクセス セグメントに接続されているすべてのルータが含まれています。

外部リンクには、その AS の外部ネットワークが記述されています。 これらのネットワークは、再配送によって OSPF に伝達されます。 ASBRはこれらの経路を自律システムに伝達する役割を果たします。

ルータ上で OSPF を有効にする方法

ルータで OSPF を有効にするには、設定モードで次の 2 つのステップを行います。

  1. router ospf <process-id> コマンドを使用して、OSPF プロセスを有効にする。

  2. network <network または IP address> <mask> <area-id> コマンドを使用して、インターフェイスにエリアを割り当てる。

OSPF process-id は、そのルータでのみ有効なプロセス番号です。 これは、他のルータの process-id と一致する必要はありません。 1 つのルータで複数の OSPF プロセスを実行できますが、複数のデータベース インスタンスが作成されてルータによけいなオーバーヘッドが追加されるため、お勧めできません。

network コマンドによって、特定のエリアにインターフェイスを割り当てることができます。 マスクはショートカットの役割を果たし、これによって、1 つのエリアに 1 行の設定コマンドでインターフェイスのリストを追加できます。 マスクには、0 が一致、1 が「do not care」ビットを示すワイルド カード ビットを指定します。たとえば、0.0.255.255 は、ネットワーク番号の最初の 2 バイトが一致していることを示します。

エリアID はインターフェイスにあってほしいエリア番号です。 area-id には、0~4294967295 の整数を指定するか、IP アドレスのような書式(A.B.C.D)を指定します。

次に例を示します。

/image/gif/paws/7039/spf4.gif

RTA#
interface Ethernet0
ip address 192.213.11.1 255.255.255.0

interface Ethernet1
ip address 192.213.12.2 255.255.255.0

interface Ethernet2
ip address 128.213.1.1 255.255.255.0

router ospf 100
network 192.213.0.0 0.0.255.255 area 0.0.0.0
network 128.213.1.1 0.0.0.0 area 23

最初のネットワークステートメントは同じエリア 0.0.0.0 に E0 および E1 を両方置き、第 2 ネットワークステートメントはエリア 23 に E2 を置きます。 0.0.0.0 のマスクに注意して下さい、IP アドレスの完全一致を示す。 この方法を使用すれば、マスクを適切に表現できない場合でも、インターフェイスを特定のエリアに容易に設定できます。

OSPF 認証

事前定義されたパスワードに基づいてルータがルーティング ドメインに参加できるようにするため、OSPF パケットの認証機能が用意されています。 デフォルトでは、ルータは Null 認証を使用します。これは、ネットワーク上のルーティング交換が認証されないことを意味します。 認証方式には、2 種類があります。 シンプルパスワード認証とメッセージ ダイジェスト認証(MD-5)

シンプルパスワード認証

シンプルパスワード認証では、エリアごとにパスワード(キー)を設定できます。 ルーティング ドメインに参加する同じエリア内のルータには、同じキーを設定する必要があります。 この方式の欠点は、受動的な攻撃を受けやすい点です。 リンク アナライザを使用すれば、だれでも簡単にネットワークからパスワードを取得できます。 パスワード認証を有効にするには、次のコマンドを使用します。

次に例を示します。

interface Ethernet0
ip address 10.10.10.10 255.255.255.0
ip ospf authentication-key mypassword

router ospf 10
network 10.10.0.0 0.0.255.255 area 0
area 0 authentication

メッセージダイジェスト認証

メッセージ ダイジェスト認証は暗号を使用した認証です。 各ルータには、キー(パスワード)と key-id を設定します。 ルータは、OSPF パケット、キー、および key-id に基づいてアルゴリズムを使用し、パケットの最後に付加する「メッセージ ダイジェスト」を生成します。 シンプル認証とは異なり、キーはネットワークを通じて交換されません。 各 OSPF パケットには、メッセージ ダイジェストの再利用による攻撃を防ぐために、減少しないシーケンス番号も含まれています。

また、この方式では、あるキーから別のキーへの連続的な移行が可能です。 これは、通信を中断せずに OSPF パスワードを変更したいと考えている管理者にとって役立ちます。 インターフェイスに新しいキーが設定されると、ルータは、それぞれ異なるキーで認証される、同じパケットの複数コピーを送信します。 すべての近接ルータで新しいキーが採用されたことを検出すると、ルータは複製パケットの送信を停止します。 メッセージ ダイジェスト認証には、次のコマンドを使用します。

次に例を示します。

interface Ethernet0
ip address 10.10.10.10 255.255.255.0
ip ospf message-digest-key 10 md5 mypassword

router ospf 10
network 10.10.0.0 0.0.255.255 area 0
area 0 authentication message-digest 

バックボーンとエリア 0

OSPF で複数のエリアを使用する場合には、特別な制約事項があります。 複数のエリアが設定される場合、これらのエリアの 1 つはエリア 0 であることであることを持っています。 これはバックボーンと呼ばれます。 ネットワークを設計する際は、まずエリア 0 から始めて、その後他のエリアに拡張するのがよい方法です。

バックボーンは必ず他のすべてのエリアの中心に位置します。つまり、すべてのエリアがバックボーンに物理的に接続している必要があります。 この背景には、すべてのエリアからバックボーンにルーティング情報が注入され、続いてその情報がバックボーンから他のエリアに伝搬されるという OSPF の概念があります。 次の図は、OSPF ネットワークにおける情報の流れを示しています。

/image/gif/paws/7039/spf5.gif

上記の図では、すべてのエリアがバックボーンに直接接続されています。 まれに、バックボーンに直接の物理アクセスを持たない新しいエリアを導入するケースがありますが、この場合は仮想リンクを設定する必要があります。 仮想リンクについては、次の項で説明します。 ルーティング情報にはさまざまなタイプがあります。 エリア内部で生成された経路(宛先がそのエリアに属する)は、エリア内経路と呼びます。 通常、これらの経路は、IP ルーティング テーブルでは文字 O によって表されます。 他のエリアから発信された経路は、エリア間経路またはサマリー経路と呼びます。 IP ルーティング テーブルにおけるこれらの経路の表記法は、O IA です。 他のルーティング プロトコル(または別の OSPF プロセス)から発信され、再配送を通じて OSPF に注入された経路は、外部経路と呼びます。 これらの経路は、IP ルーティング テーブルでは O E2 または O E1 によって表されます。 1つの宛先に対して複数の経路がある場合の優先順位は、高い方から次の順になります。 エリア内、エリア間の、外部 E1、外部 E2。 外部タイプ E1 と E2 については後述します。

仮想リンク

仮想リンクは、次の 2 つの目的で使用します。

  • バックボーンに物理的に接続していないエリアをリンクする。

  • エリア 0 への接続が途絶えた場合にバックボーンを一時的に接続する。

エリア 0 に物理的に接続していないエリア

前述したように、エリア 0 は必ず他のすべてのエリアの中心に位置する必要があります。 まれに、新しいエリアがバックボーンに物理的に接続できないケースがありますが、この場合は仮想リンクを使用します。 仮想リンクは、非接続エリアにバックボーンへの論理的なパスを提供します。 仮想リンクは 2 台の ABR の間に確立します。これらの ABR は共通のエリアを持ち、一方の ABR がバックボーンに接続している必要があります。 これを次の例で説明します。

/image/gif/paws/7039/spf6.gif

この例では、エリア 1 にエリア 0 にダイレクト物理接続がありません。 仮想リンクは RTA と RTB の間に確立します。 エリア 2 はトランジットエリアとして使用されるべきで、RTB はエリア 0 にエントリポイントです。 こうすればに RTA およびエリア 1 にバックボーンに論理接続があります。 仮想リンクを設定するには、RTA と RTB の両方で、area <area-id> virtual-link <RID> ルータ OSPF サブコマンドを使用します。area-id にはトランジット エリアを指定します。 上記のダイアグラムでは、これはエリア 2.です。 RID は router-id です。 OSPF ルータ ID は通常ボックスの最も高い IP アドレス、または最も数字の大きいループバックアドレス 存在 する 1 つです。 router-id は、ブート時または OSPF プロセスの再起動時にのみ計算されます。 router-id を確認するには、show ip ospf interface コマンドを使用します。 RTA と RTB の RID がそれぞれ 1.1.1.1 と 2.2.2.2 である場合、両方のルータの OSPF コンフィギュレーションは次のようになります。

RTA#
router ospf 10
area 2 virtual-link 2.2.2.2


RTB#
router ospf 10
area 2 virtual-link 1.1.1.1

バックボーンの分割

OSPF では、バックボーンへのリンクが連続しない部分に対処するため、仮想リンクが用意されています。 場合によっては、異なるエリア 0 にリンクしなければならないことがあります。 これは、たとえば、会社が共通域 0 と 1 つのネットワークに 2 つの別々の OSPF ネットワークをマージすることを試みる場合発生する場合があります。 他の例では、仮想リンクは冗長性のためにルータ失敗がバックボーンを 2 に分割すれば追加されます。 理由が何であれ、仮想リンクは、両側でエリア 0 と接続し、なおかつ共通のエリアを持つ別個の ABR の間で設定できます。 これを次の例で説明します。

/image/gif/paws/7039/spf7.gif

上記の図では、2 つのエリア 0 が仮想リンクを通じてリンクされています。 共通のエリアがない場合は、エリア 3 のような新たなエリアを追加してトランジット エリアにします。

バックボーン以外のエリアが分割されると、バックボーンは仮想リンクを使用せずにその分割を処理します。 分割されたエリアの一方の部分は、エリア内経路ではなく、エリア間経路としてもう一方の部分に学習されます。

隣接ルータ

共通のセグメントを共有しているルータは、そのセグメントの近接ルータになります。 近接ルータは Hello プロトコルを通じて選出されます。 Hello パケットは、IP マルチキャストを使用して各インターフェイスから定期的に送信されます(付録 B)。 近接ルータから受信した Hello パケットに自ルータの情報が含まれていると、両者は近接ルータになります。 このようにして、双方向の通信が保証されます。 近接ルータのネゴシエーションはプライマリ アドレスに対してのみ要求されます。 インターフェイスにはセカンダリ アドレスを設定できますが、プライマリ アドレスと同じエリアに属さなければならないという制約があります。

2 台のルータ間で次のものが一致しなければ、両者は近接ルータになりません。

  • Area-id(エリア ID): 共通 セグメントを持っている 2 人のルータ; インターフェイスはそのセグメントの同じエリアに属さなければなりません。 当然、両インターフェイスは同じサブネットに属し、同じマスクが設定されています。

  • Authentication: OSPF では特定のエリアへのパスワードの設定が可能です。 近接ルータになろうとしているルータは、特定のセグメントで同じパスワードを交換する必要があります。

  • Hello and Dead Intervals(Hello インターバルと Dead インターバル): OSPF は各セグメントで Hello パケットを交換します。 これはセグメントのプロシージャを確認するためにルータが使用する keepaliveの形式 マルチアクセス セグメントの Designated Router (DR)を選ぶためにであり。HELLO間隔は時間いっぱいを、ルータが OSPFインターフェイスを送出す helloパケット間の秒に、規定 します。 ルータからの Hello パケットが受信されないまま、Dead インターバル(秒数)が経過すると、その近接ルータは OSPF ルータのダウンを宣言します。

    OSPF では、これらのインターバルが 2 台の近接ルータ間で正確に一致していることが必要です。 これらのインターバルのいずれかが異なっている場合、両ルータは特定セグメントの近接ルータにはなれません。 これらのタイマーを設定するには、ルータ インターフェイス コマンドを使用します。 ip ospf hello-interval seconds と ip ospf dead-interval seconds.

  • Stub area flag(スタブ エリア フラグ): 2 台のルータがネイバーになるためには、Hello パケット内のスタブ エリア フラグも一致していることが必要です。 スタブ エリアについては後述します。 ここでは、スタブ エリアの定義が近接ルータ選出プロセスに影響を与える点を覚えておいてください。

隣接関係(adjacency)

隣接関係は、近接ルータ選出プロセスの次のステップです。 隣接ルータとは、シンプルな Hello パケットの交換を越えて、データベース交換プロセスに進むルータのことです。 OSPF では、特定セグメントでの情報交換量を最低限に抑えるために、マルチアクセス セグメントごとに DR と Backup Designated Router(BDR; バックアップ代表ルータ)が 1 台ずつ選出されます。 BDR は、DR がダウンした場合のバックアップ メカニズムとして選出されます。 この背景には、各ルータが情報交換のためのコンタクトの中心点を持つという概念があります。 各ルータがセグメント上の他のすべてのルータと更新を交換する代わりに、すべてのルータが DR および BDR と情報を交換します。 DR と BDR は、それらの情報を他のすべてのルータに中継します。 数学的に見れば、これによって情報交換量が O(n*n) から O(n) に削減されます。n は、マルチアクセス セグメント上のルータの数です。 次のルータ モデルは、DR と BDR を表しています。

/image/gif/paws/7039/spf8.gif

上記の図では、すべてのルータが共通のマルチアクセス セグメントを共有しています。 Hello パケットの交換によって、1 台のルータが DR に、別の 1 台のルータが BDR に選出されます。 セグメント上の各ルータ(すでに近接ルータになっている)は、DR および BDR と隣接関係を確立しようとします。

DR の選出

DR と BDR の選出は、Hello プロトコルを通じて行われます。 Hello パケットは、各セグメント上で IP マルチキャスト パケット(付録 B)によって交換されます。 セグメント上で OSPF プライオリティの最も高いルータがそのセグメントの DR になります。 同じプロセスが BDR についても繰り返されます。 プライオリティが同じである場合は、Router-id(RID) の最も大きいルータが選出されます。 インターフェイスの OSPF プライオリティのデフォルトは 1 です。 DR と BDR はマルチアクセス セグメントごとに選出されます。 インターフェイスの OSPF プライオリティを設定するには、ip ospf priority <value> インターフェイス コマンドを使用します。

プライオリティ値 0 は、DR または BDR に選出されないインターフェイスを示します。 プライオリティが 0 のインターフェイスは、状態が DROTHER になります。 次の図は、DR 選出の仕組みを示しています。

/image/gif/paws/7039/spf9.gif

上記の図では、RTA と RTB のインターフェイスのプライオリティは同じですが、RTB の方が大きい RID を持っています。 したがって、RTB がそのセグメントの DR になります。 ところが、RTC には RTB よりも高い優先順位が割り当てられています。 したがって、RTC がそのセグメントの DR になります。

隣接関係の確立

隣接関係確立プロセスは、複数の段階を経た後に有効になります。 隣接関係を確立したルータは、まったく同一のリンクステート データベースを保持します。 次に、別のルータと隣接関係を確立するまでにインターフェイスが経由する状態について簡潔に説明します。

  • Down(ダウン): セグメント上のどのルータからも情報を受信していません。

  • Attempt(試行): フレーム リレーや X.25 などの非ブロードキャスト マルチアクセス クラウドでは、 この状態は、ネイバーから新しい情報が届いていないことを示しています。 近接ルータとコンタクトをとるために、短い PollInterval で Hello パケットが送信されます。

  • Init(初期状態): 近接ルータからインターフェイスに Hello パケットが到達したことが検出されましたが、まだ双方向通信は確立されていません。

  • Two-way(双方向): ネイバーと双方向通信が確立されています。 ルータは、ネイバーから のHello パケット内に自ルータが含まれていることを認識しています。 この段階の最後に、DR と BDR が選出されます。 両ルータは、2-way 段階の最後に、隣接関係の確立ステップに進むかどうかを決定します。 この決定は、「いずれかのルータが DR または BDR であるか」、「リンクがポイントツーポイントであるか」、「リンクが仮想リンクであるか」といった基準に従って行われます。

  • Exstart: ルータは、情報交換パケットで使用する最初のシーケンス番号の確立を試行しています。 このシーケンス番号によって、ルータが常に最新の情報を受信していることが保証されます。 一方のルータがプライマリ、もう一方のルータがセカンダリになります。 プライマリ ルータが情報交換のためにセカンダリ ルータをポーリングします。

  • Exchange(交換): ルータはデータベース記述パケットを送信することにより、リンクステート データベース全体を記述します。 この状態で、ルータの他のインターフェイスにパケットをフラッディングできます。

  • Loading(ロード): この状態では、ルータは情報交換の確定作業を行っています。 ルータはすでにリンクステート要求リストとリンクステート再送リストを作成しています。 不完全な情報や期限切れの情報は要求リストに配置されます。 送信済みの更新は、確認応答が得られるまで再送リストに配置されます。

  • Full(完全隣接関係): この状態では、隣接関係は確立されています。 近接ルータは完全に隣接関係になります。 隣接ルータは、まったく同一のリンクステート データベースを保持します。

次に例を示します。

/image/gif/paws/7039/spf10.gif

RTA、RTB、RTD、および RTF は、エリア 0.0.0.0 で共通セグメント(E0)を共有しています。 RTA と RTF の設定を次に示します。 RTB と RTD の設定は RTF とほぼ同じであるため、省略します。

RTA#
hostname RTA 


interface Loopback0
 ip address 203.250.13.41 255.255.255.0


interface Ethernet0
 ip address 203.250.14.1 255.255.255.0


router ospf 10
 network 203.250.13.41 0.0.0.0 area 1
 network 203.250.0.0 0.0.255.255 area 0.0.0.0


RTF#
hostname RTF
interface Ethernet0
 ip address 203.250.14.2 255.255.255.0


router ospf 10
 network 203.250.0.0 0.0.255.255 area 0.0.0.0 

上記は、OSPF ネットワークのデバッグに役立ついくつかのコマンドを説明するための簡単な例です。

このコマンドはインターフェイスすべてがあるはずのエリアに属するかどうか見る素早いチェックです。 OSPF ネットワーク コマンドがリストされる順序は非常に重要です。 RTA の設定では、「ネットワーク 203.250.0.0 0.0.255.255 エリア 0.0.0.0」文が「ネットワーク 203.250.13.41 0.0.0.0 エリア 1" 文の前に置かれたら、インターフェイスすべては不正確のエリア 0 にループバックがエリア 1.にあるのであります。 RTA、RTF、RTB、および RTD でのこのコマンドの出力を次に示します。

RTA#show ip ospf interface e0
Ethernet0 is up, line protocol is up 
  Internet Address 203.250.14.1 255.255.255.0, Area 0.0.0.0 
  Process ID 10, Router ID 203.250.13.41, Network Type BROADCAST, Cost: 
10
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 203.250.15.1, Interface address 203.250.14.2
  Backup Designated router (ID) 203.250.13.41, Interface address 
203.250.14.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 0:00:02
  Neighbor Count is 3, Adjacent neighbor count is 3
    Adjacent with neighbor 203.250.15.1  (Designated Router)
Loopback0 is up, line protocol is up 
  Internet Address 203.250.13.41 255.255.255.255, Area 1 
  Process ID 10, Router ID 203.250.13.41, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host


RTF#show ip ospf interface e0
Ethernet0 is up, line protocol is up 
  Internet Address 203.250.14.2 255.255.255.0, Area 0.0.0.0
  Process ID 10, Router ID 203.250.15.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 203.250.15.1, Interface address 203.250.14.2
  Backup Designated router (ID) 203.250.13.41, Interface address 
203.250.14.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 0:00:08
  Neighbor Count is 3, Adjacent neighbor count is 3 
    Adjacent with neighbor 203.250.13.41  (Backup Designated Router)


RTD#show ip ospf interface e0
Ethernet0 is up, line protocol is up 
  Internet Address 203.250.14.4 255.255.255.0, Area 0.0.0.0 
  Process ID 10, Router ID 192.208.10.174, Network Type BROADCAST, Cost: 
10
  Transmit Delay is 1 sec, State DROTHER, Priority 1 
  Designated Router (ID) 203.250.15.1, Interface address 203.250.14.2
  Backup Designated router (ID) 203.250.13.41, Interface address 
203.250.14.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 0:00:03
  Neighbor Count is 3, Adjacent neighbor count is 2 
    Adjacent with neighbor 203.250.15.1  (Designated Router)
    Adjacent with neighbor 203.250.13.41  (Backup Designated Router)


RTB#show ip ospf interface e0
Ethernet0 is up, line protocol is up 
  Internet Address 203.250.14.3 255.255.255.0, Area 0.0.0.0
  Process ID 10, Router ID 203.250.12.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DROTHER, Priority 1 
  Designated Router (ID) 203.250.15.1, Interface address 203.250.14.2
  Backup Designated router (ID) 203.250.13.41, Interface address 
203.250.14.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 0:00:03
  Neighbor Count is 3, Adjacent neighbor count is 2
    Adjacent with neighbor 203.250.15.1  (Designated Router)
    Adjacent with neighbor 203.250.13.41  (Backup Designated Router)

上記の出力は非常に重要な情報を示しています。 RTA の出力を見てみましょう。 Ethernet0 は エリア 0.0.0.0 に属しています。 プロセス ID は 10(router ospf 10)で、ルータ ID は 203.250.13.41 です。 RID はボックス内で最も大きい IP アドレスか、またはループバック インターフェイスで、ブート時または OSPF プロセスの再起動時に計算されることを思い出してください。 インターフェイスの状態は BDR です。 Ethernet 0 上のルータがすべて同じ OSPF プライオリティを持っていて(デフォルトは 1)、RTF の RID が最も大きいことから、RTF のインターフェイスが DR として選出されています。 同様に、RTA が BDR として選出されています。 RTD と RTB は DR と BDR のいずれでもなく、状態は DROTHER です。

近接ルータ数(Neighbor Count)と隣接ルータ数(Adjacent Count)にも注目してください。 RTD は 3 台の近接ルータを持ち、そのうちの 2 台(DR と BDR)と隣接関係にあります。 RTF は 3 台の近接ルータを持ち、それらすべてのルータと隣接関係にあります。これは、RTF が DR であるためです。

ネットワーク タイプに関する情報も重要で、これによってインターフェイスの状態が決まります。 イーサネットなどのブロードキャスト ネットワークでは、DR と BDR の選出はエンド ユーザとは無関係です。 どのルータが DR または BDR になろうとも、まったく重要ではありません。 その他のケース、たとえばフレームリレーや X.25 などの NBMA メディアでは、OSPF が正常に機能する上で、DR と BDR の選出が非常に重要になります。 ただし幸いにも、ポイントツーポイント サブインターフェイスとポイントツーマルチポイント サブインターフェイスの導入により、DR の選出はもはや問題ではありません。 NBMA 上での OSPF については、次の項で説明します。

もう 1 つ見ておく必要があるコマンドは、次のコマンドです。

RTD の出力を次に示します。

RTD#show ip ospf neighbor
  
Neighbor ID    Pri State         Dead Time  Address      Interface
 
203.250.12.1    1  2WAY/DROTHER  0:00:37   203.250.14.3  Ethernet0
203.250.15.1    1  FULL/DR       0:00:36   203.250.14.2  Ethernet0
203.250.13.41   1  FULL/BDR      0:00:34   203.250.14.1  Ethernet0

show ip ospf neighbor コマンドは、特定のセグメント上にあるすべての近接ルータの状態を示します。 「Neighbor ID」が現在表示しているセグメントに属していなくても、気にする必要はありません。 この例では、203.250.12.1 と 203.250.15.1 が Ethernet0 上にありませんが、これは正常です。 「Neighbor ID」とは実際は RID であり、RID には、通常、ボックス内の任意の IP アドレスが設定されるためです。 RTD と RTB は単なる近接ルータなので、状態は 2WAY/DROTHER になっています。 RTD と RTA および RTF は隣接関係にあるため、状態は FULL/DR および FULL/BDR になっています。

ポイントツーポイント インターフェイスでの隣接関係

OSPF は、ポイントツーポイント インターフェイス(ポイントツーポイント シリアル回線など)の相手側にある近接ルータと常に隣接関係を確立します。 DR と BDR の概念はありません。 シリアル インターフェイスの状態はポイントツーポイントです。

Non-Broadcast Multi-Access(NBMA)ネットワークでの隣接関係

フレームリレー、X.25、ATM などのブロードキャストに対応していないマルチアクセス メディア上で OSPF を設定する際は、特別な注意が必要です。 OSPF は、これらのメディアをイーサネットなどのブロードキャスト メディアと同様に取り扱います。 通常、NBMA クラウドはハブアンドスポーク トポロジで構成されています。 PVC と SVC は部分メッシュ状に配置されており、その物理トポロジは、OSPF で想定されているようなマルチアクセスを提供しません。 DR と BDR はそのクラウドに存在するすべてのルータと完全に物理的に接続している必要があるため、DR の選出が問題になります。 また、ブロードキャスト機能がないため、DR と BDR はクラウドに接続している他のすべてのルータの静的なリストを持つ必要があります。 これは「IP アドレス」および「優先順位」がネイバーに与えられる IP アドレスおよび OSPF プライオリティである neighbor ip-address [priority number] [poll-interval seconds] コマンドを使用して実現します。 プライオリティが 0 の近接ルータは、DR として選出される資格がないと見なされます。 「poll-interval」は、ダウンしている可能性がある近接ルータに NBMA インターフェイスがポーリング(Hello の送信)するまでの時間間隔です。 この neighbor コマンドは、DR または BDR になる資格のある(インターフェイス プライオリティが 0 でない)ルータに対して使用します。 次のネットワーク ダイアグラムは、DR 選出が非常に重要となる例を示しています。

/image/gif/paws/7039/spf11.gif

上記のダイアグラムでは、RTA のインターフェイスが DR と選ばれることはクラウドに必要です。 これは RTA が他のルータにフル接続がある唯一のルータであるという理由によります。 DR の選出は、インターフェイスの OSPF プライオリティを設定することで制御できます。 DR または BDR になる必要がないルータにはプライオリティ 0 を設定し、他のルータには低いプライオリティを設定します。

neighbor コマンドの使用については、このドキュメントでは詳細に説明しません。使用する基本物理メディアの種類にかかわらず、インターフェイスの Network Type を自由に設定する新しい手段が導入されたため、このコマンドは使用されなくなっているためです。 このことについては、次のセクションで説明します。

NBMA での DR と neighbor コマンドの回避

スタティック近隣ルータの設定や、非ブロードキャスト クラウド上での DR や BDR となる特定のルータの使用など、複雑な問題を回避するためにさまざまな方法を利用できます。 どの方法を利用するのかは、ネットワークを新規に設計するのか、またはすでに存在するネットワークの設計を修正するのかによって変わります。

ポイントツーポイント サブインターフェイス

サブインターフェイスは、インターフェイスを論理的に定義する方法です。 同じ物理インターフェイスを複数の論理インターフェイスに分割でき、各サブインターフェイスをポイントツーポイントに定義できます。 この方法は、当初は NBMA 上のスプリット ホライズンが原因で生じる問題やベクトル ベースのルーティング プロトコルをより適切に対処するために作られました。

ポイントツーポイント サブインターフェイスには、物理的なポイントツーポイント インターフェイスの属性があります。 OSPF に関する限り、隣接関係は常にポイントツーポイント インターフェイス上で作られ、DR や BDR は選定されません。 次の図は、ポイントツーポイントのサブインターフェイスを示しています。

/image/gif/paws/7039/spf12.gif

上記のダイアグラムでは、RTA で、2 つのポイントツーポイント サブインターフェイスに S0.1 および S0.2 シリアル 0 を分割できます。 こうすればは 1 つのマルチアクセス ネットワークよりもむしろとして、OSPF クラウドをポイント ツー ポイントリンクのセットと考慮します。 ポイントツーポイントの唯一の欠点は、各セグメントが別々のサブネットに属するということです。 ネットワークの管理方法により、すでに 1 つの IP サブネットをクラウド全体に割り当てているためにこの方法が受け入れられない場合があります。

別の回避策は、IP アドレス非指定インターフェイスをクラウド上で使用することです。 この方法を使用しても、シリアル回線の IP アドレスをベースにした WAN を管理する一部のネットワーク管理者にとっては問題があります。 次は、RTA と RTB の標準的な設定です。

RTA#

interface Serial 0
 no ip address
 encapsulation frame-relay

interface Serial0.1 point-to-point
 ip address 128.213.63.6 255.255.252.0
 frame-relay interface-dlci 20

interface Serial0.2 point-to-point
 ip address 128.213.64.6 255.255.252.0
 frame-relay interface-dlci 30

router ospf 10
network 128.213.0.0 0.0.255.255 area 1

RTB#

interface Serial 0
 no ip address
 encapsulation frame-relay

interface Serial0.1 point-to-point
 ip address 128.213.63.5 255.255.252.0
 frame-relay interface-dlci 40

interface Serial1
 ip address 123.212.1.1 255.255.255.0

router ospf 10
network 128.213.0.0 0.0.255.255 area 1
network 123.212.0.0 0.0.255.255 area 0

インターフェイスネットワークタイプの選択

OSPF インターフェイスのネットワーク タイプを設定するために使用するコマンドは、次のようになります。

ip ospf network {broadcast | non-broadcast | point-to-multipoint}

ポイントツーマルチポイント インターフェイス

OSPF ポイントツーマルチポイント インターフェイスは、1 つ以上の近隣ルータのある番号付きポイントツーポイント インターフェイスとして定義されています。 この概念は、前に説明したポイントツーポイントの概念を 1 歩進めたものです。 ネットワーク管理者は、各ポイントツーポイント リンクに複数のサブネットを作ることについて心配する必要はありません。 クラウドは、1 つのサブネットとして設定されます。 これは、クラウドの IP アドレッシングを変更しないまま、ポイントツーポイント概念に移行する場合に適しています。 また、DR や近隣ルータ文について心配する必要もありません。 OSPF ポイントツーマルチポイントは、追加のリンク状態アップデートを交換することにより機能しますが、これには近接ルータへの接続性を記述した多数の情報要素が含まれます。

spf13.gif

RTA#

interface Loopback0
 ip address 200.200.10.1 255.255.255.0

interface Serial0
 ip address 128.213.10.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint

router ospf 10
network 128.213.0.0 0.0.255.255 area 1

RTB#

interface Serial0
 ip address 128.213.10.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint

interface Serial1
 ip address 123.212.1.1 255.255.255.0

router ospf 10
network 128.213.0.0 0.0.255.255 area 1
network 123.212.0.0 0.0.255.255 area 0

静的フレームリレーマップ文が設定されなかったことに注目して下さい; これは Inverse ARP が IPアドレスマッピングに DLCI 処理するという理由によります。 show ip ospf interface と show ip ospf route の出力結果の一部を見てみましょう。

RTA#show ip ospf interface s0
Serial0 is up, line protocol is up
  Internet Address 128.213.10.1 255.255.255.0, Area 0
  Process ID 10, Router ID 200.200.10.1, Network Type
POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 0:00:04
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 195.211.10.174
    Adjacent with neighbor 128.213.63.130

RTA#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
128.213.10.3      1   FULL/  -        0:01:35     128.213.10.3    Serial0
128.213.10.2      1   FULL/  -        0:01:44     128.213.10.2    Serial0

RTB#show ip ospf interface s0

Serial0 is up, line protocol is up
  Internet Address 128.213.10.2 255.255.255.0, Area 0
  Process ID 10, Router ID 128.213.10.2, Network Type
POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 0:00:14
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 200.200.10.1

RTB#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
200.200.10.1      1   FULL/  -        0:01:52     128.213.10.1    Serial0

ポイントツーマルチポイントの唯一の欠点は、複数のホストルート(マスクが 255.255.255.255 であるルート)をすべての近隣ルータに生成することです。 下記の RTB の IP ルーティング テーブル内のホストルートに注目してください。

RTB#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      200.200.10.0 255.255.255.255 is subnetted, 1 subnets
 O       200.200.10.1 [110/65] via 128.213.10.1,  Serial0
         128.213.0.0 is variably subnetted, 3 subnets, 2 masks
 O    128.213.10.3 255.255.255.255
            [110/128] via 128.213.10.1, 00:00:00, Serial0
 O    128.213.10.1 255.255.255.255
            [110/64] via 128.213.10.1, 00:00:00, Serial0
 C       128.213.10.0 255.255.255.0 is directly connected, Serial0
      123.0.0.0 255.255.255.0 is subnetted, 1 subnets
 C       123.212.1.0 is directly connected, Serial1

 RTC#show ip route

      200.200.10.0 255.255.255.255 is subnetted, 1 subnets
 O       200.200.10.1 [110/65] via 128.213.10.1, Serial1
      128.213.0.0 is variably subnetted, 4 subnets, 2 masks
 O       128.213.10.2 255.255.255.255 [110/128] via 128.213.10.1,Serial1
 O       128.213.10.1 255.255.255.255 [110/64] via 128.213.10.1, Serial1
 C       128.213.10.0 255.255.255.0 is directly connected, Serial1
      123.0.0.0 255.255.255.0 is subnetted, 1 subnets
 O       123.212.1.0 [110/192] via 128.213.10.1, 00:14:29, Serial1

RTC の IP ルーティング テーブルの中で、ネットワーク 123.212.1.0 はネクストホップ 128.213.10.1 を経由して到達可能ですが、128.213.10.2 は経由しないことに注目してください。これは同じサブネットを共有するフレームリレー クラウド上で通常表示されるものと同じです。 これはポイントツーマルチポイント設定の利点の 1 つです。なぜなら、ネクストホップ 128.213.10.2 に到達するために RTC 上のスタティックマッピングに頼る必要がないからです。

ブロードキャスト インターフェイス

このアプローチは、「neighbor」コマンドを使用した場合に既存の近隣ルータをすべてスタティックにリストしてしまうことへの回避策です。 インターフェイスは論理的にブロードキャストに設定され、あたかもルータが LAN に接続されたかのように振舞います。 それでも DR と BDR の選定は行われるため、特に注意を払ってフルメッシュ トポロジと DR のスタティック選択のどちらもインターフェイスの優先順位に基づくようにします。 インターフェイスをブロードキャストに設定するコマンドは、次のとおりです。


ip ospf network broadcast

OSPF とルート集約

集約とは、複数のルートを 1 つのアドバタイズメントに統合することです。 これは通常、Area Border Routers(ABR; エリア境界ルータ)の境界で行われます。 集約は任意の 2 つのエリア間に設定できますが、バックボーンの方向に集約することをお勧めします。 このようにバックボーンはすべての集約アドレスを受信してから、すでに集約されたこれらのアドレスを別のエリアに挿入します。 集約には 2 つのタイプがあります。

  • エリア間ルート集約

  • 外部ルート集約

エリア間ルート集約

エリア間ルート集約は ABR 上で行われ、AS 内からのルートに適用されます。 これは再配布を経由して OSPF に挿入された外部ルートには適用されません。 集約を利用するために、エリア内のネットワーク番号を隣接して割り当てて、これらのアドレスを 1 つの範囲にまとめられるようにする必要があります。 アドレス範囲を指定するには、次のタスクをルータ設定モードで実行します。

area area-id range address mask

ここで、「area-id」は、集約するネットワークを含むエリアです。 「address」と「mask」は、1 つの範囲に集約するアドレスの範囲を指定します。 次に、集約の例を示します。

/image/gif/paws/7039/spf14.gif

上の図で、RTB は 128.213.64.0 から 128.213.95.0 までのサブネットの範囲を 1 つの範囲である 128.213.64.0 255.255.224.0 に集約しています。 128.213.64.0 255.255.224.0。 このために、 64 ビット中、左から 3 ビットが 255.255.224.0 のマスクを使用して、マスクされています。 同じように、RTC はバックボーンへのサマリー アドレス 128.213.96.0 255.255.224.0 を生成しています。 この集約が成功したのは、64-95 と 96-127 の 2 つの異なるサブネットの範囲があるためであることに注目してください。

エリア 1 とエリア 2 の間のサブネットがオーバーラップした場合、集約は困難になっていたでしょう。 バックボーン エリアはオーバーラップするサマリー エリアを受信でき、中央のルータはサマリー アドレスに基づいてトラフィックをどこに送信するかを検知できません。

次に、RTB に関連する設定を示します。

RTB#
 router ospf 100
 area 1 range 128.213.64.0 255.255.224.0

Cisco IOS 前か。 ソフトウェア リリース 12.1(6)、可能性のある ルーティングループを防ぐために、ABR で、サマリー アドレスのための破棄された静的ルートを手動で設定することを推奨しました。 上記のサマリー ルートに対して、次のコマンドを使用できます。

ip route 128.213.64.0 255.255.224.0 null0

IOS 12.1(6) 以上では、廃棄ルートはデフォルトで自動的に生成されます。 何らかの理由によりこの廃棄ルートを使用しない場合、次のコマンドを router ospf の下に設定できます。

[no] discard-route internal

または

[no] discard-route external

サマリー アドレス メトリック計算に関して: RFC 1583 はleavingcisco.com コンポーネント パスの最小のメトリックに基づいてサマリールートのためのメトリックの計算を利用可能求めました。

RFC 2178(RFC 2328)によって、サマリーの構成要素のうちで、もっとも大きなコストをサマリールートのメトリックとして計算する方式に変更されています。leavingcisco.com leavingcisco.com

IOS 12.0 より以前のバージョンでは、シスコはその当時の RFC 1583 に準拠していました。leavingcisco.com IOS 12.0 の時点で、シスコでは OSPF の動作を変更して、新しい標準である RFC 2328 に準拠しています。leavingcisco.com こうした状況により、エリア内のすべての ABR が新しいコードに同時にアップグレードされなかった場合、最適なルーティングではなくなる可能性が生まれました。 この潜在的な問題に対処するために、RFC 2328 との互換性を選択的にディセーブルにできるコマンドが、Cisco IOS の OSPF 設定に追加されました。leavingcisco.com 新しい設定コマンドは router ospf の下に記述され、構文は次のようになります。

[no] compatible rfc1583 

デフォルト設定は、RFC 1583 と互換性があります。leavingcisco.com このコマンドは、IOS の次のバージョンで使用できます。

  • 12.1(03)DC

  • 12.1(03)DB

  • 12.001(001.003) - 12.1 Mainline

  • 12.1(01.03)T - 12.1 T-Train

  • 12.000(010.004) - 12.0 Mainline

  • 12.1(01.03)E - 12.1 E-Train

  • 12.1(01.03)EC

  • 12.0(10.05)W05(18.00.10)

  • 12.0(10.05)SC

外部ルート集約

外部ルート集約は、外部ルートに固有の集約であり、再配布を経由して OSPF に挿入されています。 また、集約されている外部範囲が隣接していることを確認してください。 異なる 2 台のルータからの範囲がオーバーラップしている集約は、パケットが誤った送信先へ送られる原因になります。 集約は、次の router ospf サブコマンドによって行われます。


summary-address ip-address mask

このコマンドは、OSPF への再配布を行う ASBR 上だけで有効です。

/image/gif/paws/7039/spf15.gif

上の図において、RTA と RTD は再配布により外部ルートを OSPF に挿入しています。 RTA は範囲 128.213.64-95 のサブネットをインジェクトして、RTD は範囲 128.213.96-127 のサブネットをインジェクトしています。 各ルータでサブネットを 1 つの範囲に集約するために、次のことを実行できます。

RTA#
 router ospf 100
 summary-address 128.213.64.0 255.255.224.0
 redistribute bgp 50 metric 1000 subnets

 RTD#
 router ospf 100
 summary-address 128.213.96.0 255.255.224.0
 redistribute bgp 20 metric 1000 subnets

これにより RTA は 1 つの外部ルート 128.213.64.0 255.255.224.0 を生成することになり、RTD は 128.213.96.0 255.255.224.0 を生成することになります。

summary-address コマンドは RTB で使用する場合には効果がないことに注意してください。それは RTB が OSPF へ再配布を行っていないためです。

スタブ エリア

OSPF では、あるエリアをスタブ エリアとして設定することができます。 外部ネットワークは、たとえば別のプロトコルから OSPF へ再配布されるような場合、スタブ エリアへの直接的な再配布は行いません。 これらのエリアから外部ネットワークへのルートは、デフォルト ルートを使います。 スタブ エリアを設定することによりエリア内のトポロジ用データベース サイズを小さくすることができ、このエリア内のルータのメモリ要件を少なくすることができます。

エリアに 1 つの出口がある場合や、エリア外部へのルーティングが最適なパスを使用する必要がない場合、このエリアをスタブとみなすことができます。 後者の記述では、複数の出口があるスタブ エリアには、デフォルトをこのエリアに挿入する 1 つ以上のエリア境界ルータがあることを示しています。 外部ネットワークへのルーティングは送信先に達する上で最適でないパスを使用することがあります。これは、エリアから外へ出る際に経由する出力点から送信先への距離が、他の出口からの距離より遠い場合に起こります。

その他のスタブ エリアの制約事項として、スタブ エリアを仮想リンクの通過エリアとして使用できないことがあります。 また、スタブ エリアの内部にはASBRを設置できません。 これらの制約事項が作られた理由は、スタブ エリアを設定している主な目的が外部ルートを運ばないようにするためで、上記のあらゆる状況は、外部リンクをこのエリアに挿入してしまうためです。 当然バックボーンは、スタブとして設定できません。

スタブ エリア内のすべての OSPF ルータはスタブ ルータとして設定する必要があります。 これは、あるエリアをスタブとして設定すると、このエリアに属するすべてのインターフェイスが Hello パケットを、インターフェイスがスタブであることを示すフラグとともに交換し始めるためです。 実際にはこれはその Helloパケット(E ビット)にちょうど少し 0 に設定 される gets です。 共通 セグメントをそのフラグに一致しなければならないために備えているすべてのルータ。 一致しない場合、これらは近隣ルータにはならずルーティングは実行されません。

スタブ エリアの拡張機能は、「トータルスタブエリア」と呼ばれます。 シスコではこれを示すために、"no-summary" キーワードをスタブ エリア設定に追加しています。 トータルスタブエリアは、外部ルートとサマリー ルート(エリア間ルート)がエリア内に入るのを防御するエリアです。 このようにして、このエリアに挿入されるルートは、エリア内ルートとデフォルトの 0.0.0.0 だけになります。

エリアをスタブとして設定するコマンドを次に示します。


area <area-id> stub [no-summary]

デフォルト コストをエリア内に設定するコマンドは、次のようになります。


area area-id default-cost cost


コストが上のコマンドを使用して設定されていない場合、1 のコストが ABR によってアドバタイズされます。

/image/gif/paws/7039/spf16.gif

エリア 2 をスタブ エリアとして設定することと仮定します。 次の例は、エリア 2 をスタブに設定する前と後の RTE のルーティング テーブルを示します。

RTC#

 interface Ethernet 0
  ip address 203.250.14.1 255.255.255.0

 interface Serial1
  ip address 203.250.15.1 255.255.255.252

 router ospf 10
  network 203.250.15.0 0.0.0.255 area 2
  network 203.250.14.0 0.0.0.255 area 0
 RTE#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      203.250.15.0 255.255.255.252 is subnetted, 1 subnets
 C       203.250.15.0 is directly connected, Serial0
 O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:06:31, Serial0
      128.213.0.0 is variably subnetted, 2 subnets, 2 masks
 O E2    128.213.64.0 255.255.192.0
            [110/10] via 203.250.15.1, 00:00:29, Serial0
 O IA    128.213.63.0 255.255.255.252
            [110/84] via 203.250.15.1, 00:03:57, Serial0
      131.108.0.0 255.255.255.240 is subnetted, 1 subnets
 O       131.108.79.208 [110/74] via 203.250.15.1, 00:00:10, Serial0

RTE はエリア間ルート(O IA)203.250.14.0 と 128.213.63.0 をラーニングし、エリア内ルート(O)131.108.79.208 と外部ルート(O E2)128.213.64.0 を学習しました。

エリア 2 をスタブに設定する場合、次のことを実行する必要があります。

RTC#

 interface Ethernet 0
  ip address 203.250.14.1 255.255.255.0

 interface Serial1
  ip address 203.250.15.1 255.255.255.252

 router ospf 10
  network 203.250.15.0 0.0.0.255 area 2
  network 203.250.14.0 0.0.0.255 area 0
  area 2 stub

 RTE#

 interface Serial1
  ip address 203.250.15.2 255.255.255.252
 router ospf 10
 network 203.250.15.0 0.0.0.255 area 2
  area 2 stub

<:P>スタブ コマンドが RTE にも設定されていることに注意してください。設定されていない場合、 RTE は RTC の近隣ルータにはなりません。 デフォルト コストは設定されていないため、RTC は 0.0.0.0 を RTE に 1 のメトリックでアドバタイズします。

RTE#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is 203.250.15.1 to network 0.0.0.0

      203.250.15.0 255.255.255.252 is subnetted, 1 subnets
 C       203.250.15.0 is directly connected, Serial0
 O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:26:58, Serial0
      128.213.0.0 255.255.255.252 is subnetted, 1 subnets
 O IA    128.213.63.0 [110/84] via 203.250.15.1, 00:26:59, Serial0
      131.108.0.0 255.255.255.240 is subnetted, 1 subnets
 O       131.108.79.208 [110/74] via 203.250.15.1, 00:26:59, Serial0
 O*IA 0.0.0.0 0.0.0.0 [110/65] via 203.250.15.1, 00:26:59, Serial0

すべてのルートが表示されることに注目してください。ただし 0.0.0.0 のデフォルトルートに置き換えられた外部ルートは表示されません。 ルートのコストは偶然 65 になっています(T1 回線の 64 + RTC がアドバタイズした 1)。

ここでは、エリア 2 がトータルスタブになるように設定し、0.0.0.0 のデフォルト コストを 10 に変更することにします。

RTC#

 interface Ethernet 0
  ip address 203.250.14.1 255.255.255.0

 interface Serial1
  ip address 203.250.15.1 255.255.255.252

 router ospf 10
  network 203.250.15.0 0.0.0.255 area 2
  network 203.250.14.0 0.0.0.255 area 0
  area 2 stub no-summary
  area 2 default cost 10


 RTE#show ip route

 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      203.250.15.0 255.255.255.252 is subnetted, 1 subnets
 C       203.250.15.0 is directly connected, Serial0
      131.108.0.0 255.255.255.240 is subnetted, 1 subnets
 O       131.108.79.208 [110/74] via 203.250.15.1, 00:31:27, Serial0
 O*IA 0.0.0.0 0.0.0.0 [110/74] via 203.250.15.1, 00:00:00, Serial0

表示される唯一のルートは、エリア内ルート(O)とデフォルトルート 0.0.0.0 であることに注目してください。 外部ルートとエリア間ルートはブロックされています。 デフォルトルートのコストは現在 74 です(T1 回線の 64 + RTC がアドバタイズした 10)。 このケースでは、RTE に設定は必要ありません。 エリアはすでにスタブになっており、no-summary コマンドは stub コマンドとは違い、Hello パケットにはまったく影響を与えません。

OSPF へのルートの再配布

ルートを他のルーティング プロトコルやスタティックルートから OSPF へ再配布することにより、これらのルートは OSPF 外部ルートになります。 ルートを OSPF に再配布するには、次のコマンドをルータ設定モードで使用します。


redistribute protocol [process-id] [metric value] 
[metric-type value] [route-map map-tag] [subnets]

注: 上記のコマンドは、1 回線で行う必要があります。

プロトコルとプロセス ID は、現在ここで OSPF に挿入しているプロトコルと、そのプロセス ID(存在する場合)になります。 メトリックは、わたしたちが外部ルートに割り当てているコストです。 メトリックが規定 されない場合、OSPF はすべてのプロトコルからのルートを再配布するとき 20 のデフォルト値を除外します 1.のメトリックを得る BGPルートを置きます。 メトリックタイプは、次のパラグラフで説明します。

ルートマップは、ルーティング ドメイン間でルートの再配布を制御するために使用する方式です。 ルート マップの形式は次のようになります。


route-map map-tag [[permit | deny] | [sequence-number]]

ルートを OSPF に再配布するとき、subnets キーワードを指定しなければ、サブネットでないルートだけが再配布されます。

E1対E2 外部ルート

外部ルートは 2 つのカテゴリー、外部タイプ 1 および外部タイプ 2 以下落ちます。 2 間の違いはルートのコスト(メトリック)が計算されている方法であります。 タイプ 2 ルートのコストは常に外部コストであり、このルートに到達するための内部コストとは無関係です。 タイプ 1 コストは、そのルートに達するために使用する外部コストと内部コストの和です。 送信先が同じ場合、常にタイプ 1 ルートがタイプ 2 ルートより選択されます。 これを次の図で示します。

/image/gif/paws/7039/spf17.gif

上の図で示すように、RTA は 2 つの外部ルートを OSPF に再配布しています。 N1 と N2 の外部コストはともに、x です。 唯一の違いは N1 が metric-type タイプ 1 の OSPF に再配布され、N2 が metric-type タイプ 2 と再配布されることです。 それらがエリア 1 からエリア 0 にフローすると同時にルーティングに続けば、RTB か RTC から見られるように N2 に達するコストは x.常にです 途中の内部コストは考慮されません。 一方、N1 に達するコストは、内部コストの分だけ増加しています。 コストは RTB から見ると x+y で RTC から見ると x+y+z です。

外部ルートが両方ともタイプ 2 ルートで送信先ネットワークへの外部コストが等しい場合、ASBR へのコストが低い方のパスが最適なパスとして選択されます。

特に指定されない限り、外部ルートに付与されるデフォルトの外部タイプはタイプ 2 です。

/image/gif/paws/7039/spf18.gif

RTC 上の E0 を指している次の 2 本のスタティック ルートを追加したと仮定します。 16.16.16.0 255.255.255.0(/24 表記は、左端から始まる 24 ビットのマスクを意味します)と 128.213.0.0 255.255.0.0。 次に RTC で redistribute コマンドに異なるパラメータを使用した場合の動作の違いを示します。

RTC#
 interface Ethernet0
  ip address 203.250.14.2 255.255.255.0

 interface Serial1
  ip address 203.250.15.1 255.255.255.252

 router ospf 10
  redistribute static
  network 203.250.15.0 0.0.0.255 area 2
  network 203.250.14.0 0.0.0.255 area 0

 ip route 16.16.16.0 255.255.255.0 Ethernet0
 ip route 128.213.0.0 255.255.0.0 Ethernet0

 RTE#

 interface Serial0
  ip address 203.250.15.2 255.255.255.252

 router ospf 10
 network 203.250.15.0 0.0.0.255 area 2

次に、RTE での show ip route の出力結果を示します。

RTE#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      203.250.15.0 255.255.255.252 is subnetted, 1 subnets
 C       203.250.15.0 is directly connected, Serial0
 O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:02:31, Serial0
 O E2 128.213.0.0 [110/20] via 203.250.15.1, 00:02:32, Serial0

subnet キーワードを使用しなかったため、表示された外部ルートは唯一 128.213.0.0 であることに注目してください。 subnet キーワードを使用しなければ、サブネットでないルートだけが再配布されることに注意してください。 この場合では、16.16.16.0 はサブネット化されたクラス A ルートであり、再配布されていません。 metric キーワードが使用されていないため(またはルータ OSPF の下の default-metric 文)、外部ルートに割り当てられたコストは 20 です(BGPの場合のデフォルトのコストは 1)。 次のコマンドを使用すると、下記のようになります。

redistribute static metric 50 subnets

RTE#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M
- mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      16.0.0.0 255.255.255.0 is subnetted, 1 subnets
 O E2    16.16.16.0 [110/50] via 203.250.15.1, 00:00:02, Serial0
      203.250.15.0 255.255.255.252 is subnetted, 1 subnets
 C       203.250.15.0 is directly connected, Serial0
 O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:00:02, Serial0
 O E2 128.213.0.0 [110/50] via 203.250.15.1, 00:00:02, Serial0

16.16.16.0 が今出て来、外部ルートへのコストが 50 であることに注目して下さい。 外部ルートがタイプ 2 (E2)であるので、内部コストは追加されませんでした。 ここで、タイプを E1 に変更します。

redistribute static metric 50 metric-type 1 subnets

RTE#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      16.0.0.0 255.255.255.0 is subnetted, 1 subnets
 O E1    16.16.16.0 [110/114] via 203.250.15.1, 00:04:20, Serial0
      203.250.15.0 255.255.255.252 is subnetted, 1 subnets
 C       203.250.15.0 is directly connected, Serial0
 O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:09:41, Serial0
 O E1 128.213.0.0 [110/114] via 203.250.15.1, 00:04:21, Serial0

タイプは E1 に変わり、コストは S0 の内部コスト分、64 だけ増加し、合計コストは 64+50=114 になっていることに注目してください。

ルート マップを RTC の設定に加えるとすると、次の結果が得られます。

RTC#
 interface Ethernet0
  ip address 203.250.14.2 255.255.255.0

 interface Serial1
  ip address 203.250.15.1 255.255.255.252

 router ospf 10
 redistribute static metric 50 metric-type 1 subnets route-map STOPUPDATE
  network 203.250.15.0 0.0.0.255 area 2
  network 203.250.14.0 0.0.0.255 area 0

 ip route 16.16.16.0 255.255.255.0 Ethernet0
 ip route 128.213.0.0 255.255.0.0 Ethernet0

 access-list 1 permit 128.213.0.0 0.0.255.255

 route-map STOPUPDATE permit 10
  match ip address 1

上のルート マップでは、128.213.0.0 が OSPF に再配布されることだけを許可し、他は拒否します。 これが、16.16.16.0 が RTE のルーティング テーブルで表示されない理由です。

RTE#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      203.250.15.0 255.255.255.252 is subnetted, 1 subnets
 C       203.250.15.0 is directly connected, Serial0
 O IA 203.250.14.0 [110/74] via 203.250.15.1, 00:00:04, Serial0
 O E1 128.213.0.0 [110/114] via 203.250.15.1, 00:00:05, Serial0

他のプロトコルへの OSPF の再配布

有効なメトリックの使用

OSPF を別のプロトコルへ再配布するときは、常にこれらのプロトコルのルールを考慮する必要があります。 特に、適用されるメトリックはこのプロトコルが使用するメトリックと一致する必要があります。 たとえば RIP メトリックは範囲が 1 から 16 までのホップ カウントで、この場合 1 はネットワークが 1 ホップ先にあることを示し、16 はネットワークが到達不能なことを示しています。 一方 IGRP と EIGRP は、次の形式のメトリックを必要とします。


default-metric 
bandwidth delay reliability loading mtu

VLSM

考慮するもう 1 つの問題は、VLSM(Variable Length Subnet Guide)(付録 C)です。 OSPF は同一主要ネットの複数のサブネット情報を伝えることができますが、RIP や IGRP など他のプロトコル(EIGRP は VLSM では可能)はできません。 同一主要ネットが OSPF と RIP ドメインの境界を超える場合、RIP や IGRP に再配布された VLSM 情報は紛失し、スタティックルートを RIP または IGRP ドメインで設定する必要があります。 次の例では、この問題を説明します。

/image/gif/paws/7039/spf19.gif

上の図で、RTE は OSPF を実行し RTA は RIP を実行しています。 RTC は、2 つのプロトコル間で再配布を行います。 問題はクラス C ネットワーク 203.250.15.0 が変動的なサブネットであり、255.255.255.252 と 255.255.255.192 の 2 つの異なるマスクを持っていることです。 RTE と RTA の設定とルーティング テーブルを見てみましょう。

RTA#
 interface Ethernet0
  ip address 203.250.15.68 255.255.255.192
 router rip
  network 203.250.15.0
 RTC#
 interface Ethernet0
  ip address 203.250.15.67 255.255.255.192

 interface Serial1
  ip address 203.250.15.1 255.255.255.252
 router ospf 10
 redistribute rip metric 10 subnets
  network 203.250.15.0 0.0.0.255 area 0
 router rip
  redistribute ospf 10 metric 2
  network 203.250.15.0

 RTE#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      203.250.15.0 is variably subnetted, 2 subnets, 2 masks
 C       203.250.15.0 255.255.255.252 is directly connected, Serial0
 O       203.250.15.64 255.255.255.192
            [110/74] via 203.250.15.1, 00:15:55, Serial0
 RTA#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is not set

      203.250.15.0 255.255.255.192 is subnetted, 1 subnets
 C       203.250.15.64 is directly connected, Ethernet0

RTE は 203.250.15.0 には 2 つのサブネットがあると認識しているのに対して、RTA は 203.250.15.0 には 1 つのサブネット(インターフェイス上で設定されている 1 つ)しかないと考えていることに注目してください。 サブネット 203.250.15.0 255.255.255.252 に関する情報は、RIP ドメインの中で失われています。 このサブネットに到達するためには、スタティックルートを RTA で構成する必要があります。

RTA#
 interface Ethernet0
  ip address 203.250.15.68 255.255.255.192
 router rip
  network 203.250.15.0

ip route 203.250.15.0 255.255.255.0 203.250.15.67

このようにして、RTA は別のサブネットへ到達できるようになります。

相互再配布

プロトコル間の相互再配布は、十分な注意を施し管理された手法で行う必要があります。 設定に誤りがあるとルーティング情報のループが生じる可能性があります。 相互再配布のための経験則は、プロトコルからラーニングされた情報が同じプロトコルに再び挿入されないようにすることです。 受動インターフェイスと再配布リストを再配布ルータに適用する必要があります。 OSPF などのリンク ステート プロトコルでの情報のフィルタリングは、注意を要する作業です。 Distribute-list out は ASBR 上で動作して、再配布されたルートを他のプロトコルにフィルタリングします。 Distribute-list in はあらゆるルータ上で動作してルートがルーティング テーブルに入れられるのを防ぎますが、リンクステート パケットが伝搬されるのを防ぐことはなく、下流ルータにはまだルートが維持されます。 フィルタを他のプロトコルに適用してループを防ぐことができる場合は、OSPF フィルタリングはできるだけ避けた方がよいでしょう。

/image/gif/paws/7039/spf20.gif

説明のため、RTA、RTC、および RTE が RIP を実行していると想定してください。 RTC と RTA は、OSPF も実行しています。 RTC と RTA はいずれも、RIP と OSPF の間で再配布を実行しています。 RTE から着信する RIP を OSPF ドメインに挿入させたくないと仮定して、RIP の受動インターフェイスを RTC の E0 に置きます。 ただし、RTA から着信する RIP が OSPF に挿入されるのは許可しています。 次に出力結果を示します。

注: 次の設定は使用しないでください。

RTE#
 interface Ethernet0
  ip address 203.250.15.130 255.255.255.192
 
 interface Serial0
  ip address 203.250.15.2 255.255.255.192
 
 router rip
  network 203.250.15.0
 
 
RTC#
 interface Ethernet0
  ip address 203.250.15.67 255.255.255.192
 
 interface Serial1
  ip address 203.250.15.1 255.255.255.192
 
 router ospf 10
  redistribute rip metric 10 subnets
  network 203.250.15.0 0.0.0.255 area 0
 
 router rip
  redistribute ospf 10 metric 2
  passive-interface Ethernet0
  network 203.250.15.0
 



RTA#
interface Ethernet0
 ip address 203.250.15.68 255.255.255.192
 
router ospf 10
 redistribute rip metric 10 subnets
 network 203.250.15.0 0.0.0.255 area 0


router rip
 redistribute ospf 10 metric 1
 network 203.250.15.0


 
RTC#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
  
 Gateway of last resort is not set
 
      203.250.15.0 255.255.255.192 is subnetted, 4 subnets
 C       203.250.15.0 is directly connected, Serial1
 C       203.250.15.64 is directly connected, Ethernet0
 R       203.250.15.128 [120/1] via 203.250.15.68, 00:01:08, Ethernet0
                        [120/1] via 203.250.15.2, 00:00:11, Serial1
 O       203.250.15.192 [110/20] via 203.250.15.68, 00:21:41, Ethernet0

RTCには、203.250.15.128サブネットに到達する2つのパスがあることに注目して下さい: シリアル 1 と Ethernet 0 です(E0 は明らかに適切でないパスです)。 これは、RTC がこのエントリを OSPF を介して RTA に送り、RTA はそれを RIP を介してラーニングしなかったために RIP を介して戻しているからです。 これはきわめて小規模なループの例であり、これは設定が正しくないために発生します。 大規模なネットワークでは、この状況はさらに悪化します。

この例で生じている状況を修正するために、RTA のイーサネット 0 で受動インターフェイスを介して RIP が送信されるのを止めることができます。 これは、イーサネット上に RIP 専用のルータがある場合は適切な方法ではありません。 この場合、RTC がイーサネットの RIP を送信 するようにする可能性があります; 分割された地平線が消えている場合)こうすれば RTA は分割地平線が理由でネットワークでそれを送返しません(これはで NBMA メディア動作しないかもしれません。 スプリット ホライズンはアップデートが、同じラーニング元であるインターフェイス(同じプロトコルを介して)で送り返されるのを許可しません。 もう 1 つの方法は、配布リストを RTA に適用して、OSPF を介してラーニングされたサブネットが、イーサネットで RIP に戻されるのを拒否することです。 後者の方法は、これから使用する方法です。

RTA#
  interface Ethernet0
  ip address 203.250.15.68 255.255.255.192
 
 router ospf 10
  redistribute rip metric 10 subnets
  network 203.250.15.0 0.0.0.255 area 0
 
 router rip
  redistribute ospf 10 metric 1
  network 203.250.15.0
  distribute-list 1 out ospf 10

RTC のルーティング テーブルの出力結果は、次のようになります。

RTF#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
  
 Gateway of last resort is not set
  
      203.250.15.0 255.255.255.192 is subnetted, 4 subnets
 C       203.250.15.0 is directly connected, Serial1
 C       203.250.15.64 is directly connected, Ethernet0
 R       203.250.15.128 [120/1] via 203.250.15.2, 00:00:19, Serial1
 O       203.250.15.192 [110/20] via 203.250.15.68, 00:21:41, Ethernet0

OSPF にデフォルト値を入れる方法

Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)に、OSPF ドメインへのデフォルトルートを強制的に生成させることができます。 すでに説明したように、ルートが OSPF ドメインに再配布されると、ルータは ASBR になります。 しかし ASBR はデフォルトでは、OSPF ルーティング ドメインへのデフォルトルートを生成しません。

OSPF にデフォルトルートを生成させるために、次のコマンドを使用します。


default-information originate [always] [metric metric-value] 
[metric-type type-value] [route-map map-name]

注: 上記のコマンドは、1 回線で行う必要があります。

デフォルトを生成するには、2 つの方法があります。 1 つめはドメイン内部で 0.0.0.0 をアドバタイズすることですが、これは ASBR 自体にすでにデフォルトルートがある場合です。 2 つめの方法では、ASBR に デフォルトルートがあるかないかにかかわらず 0.0.0.0 をアドバタイズします。 2 番めの方法は、キーワード always を追加すると設定できます。 always キーワードを使用するときは注意する必要があります。 使用しているルータがドメイン内でデフォルト(0.0.0.0)をアドバタイズしながらデフォルト自体がなかったり送信先へ到達するパスがなかったりした場合、ルーティングは中断します。

メトリックとメトリック タイプは、デフォルトルートに割り当てられたコストとタイプ(E1 または E2)です。 ルート マップは、デフォルトの生成に必要な条件のセットを指定します。

/image/gif/paws/7039/spf21.gif

RTE はデフォルトルート 0.0.0.0 を RIP に挿入していると仮定します。 RTC には、最後の手段として 203.250.15.2 のゲートウェイがあります。 RTC を default-information originate コマンドで設定するまで、RTC はデフォルトを RTA に伝搬しません。

RTC#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
  
 Gateway of last resort is 203.250.15.2 to network 0.0.0.0
  
      203.250.15.0 255.255.255.192 is subnetted, 4 subnets
 C       203.250.15.0 is directly connected, Serial1
 C       203.250.15.64 is directly connected, Ethernet0
 R       203.250.15.128 [120/1] via 203.250.15.2, 00:00:17, Serial1
 O       203.250.15.192 [110/20] via 203.250.15.68, 2d23, Ethernet0
 R*   0.0.0.0 0.0.0.0 [120/1] via 203.250.15.2, 00:00:17, Serial1
             [120/1] via 203.250.15.68, 00:00:32, Ethernet0
 RTC#
 
 interface Ethernet0
  ip address 203.250.15.67 255.255.255.192
 
 interface Serial1
  ip address 203.250.15.1 255.255.255.192
 
 router ospf 10
  redistribute rip metric 10 subnets
  network 203.250.15.0 0.0.0.255 area 0
  default-information originate metric 10
 
 
 router rip
  redistribute ospf 10 metric 2
  passive-interface Ethernet0
  network 203.250.15.0

RTA#show ip route
 
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
  
 Gateway of last resort is 203.250.15.67 to network 0.0.0.0
  
      203.250.15.0 255.255.255.192 is subnetted, 4 subnets
 O       203.250.15.0 [110/74] via 203.250.15.67, 2d23, Ethernet0
 C       203.250.15.64 is directly connected, Ethernet0
 O E2    203.250.15.128 [110/10] via 203.250.15.67, 2d23, Ethernet0
 C       203.250.15.192 is directly connected, Ethernet1
 O*E2 0.0.0.0 0.0.0.0 [110/10] via 203.250.15.67, 00:00:17, Ethernet0

RTA がメトリック 10.の外部ルートとして 0.0.0.0 を学んだことに注目して下さい。 最後の手段のゲートウェイは、予想どおり 203.250.15.67 に設定されます。

OSPF 設計のヒント

OSPF の RFC(1583)では、エリア内のルータの数やセグメント当たりの近隣ルータの数、またはネットワークを構築する最良の方法についてガイドラインを指定していません。 さまざまな人たちが、さまざまなアプローチで OSPF ネットワークを設計しています。 忘れてはならない重要なことは、あらゆるプロトコルは負荷がかかると失敗することがあるということです。 発想としてはプロトコルに無理を強いることでなく、最適な動作を得るために連携することです。 次に、検討する事項のリストを示します。

エリアあたりのルータの数

エリア当たりのルータの最大数は、次のようなさまざまな要素によって決まります。

  • どのような種類のエリアがあるか

  • そのエリアの CPU の能力はどの位か

  • どのような種類のメディアがあるか

  • OSPF を NBMA モードで実行するか

  • NBMA ネットワークはメッシュされているか

  • ネットワーク内に多数の外部 LSA があるか

  • 他のエリアは、充分に集約されているか

このような理由により、エリア当たりのルータの最大数を指定することは簡単なことではありません。 特定のネットワーク設計の支援については、販売店やシステム エンジニアにお問い合せください。

隣接ルータの数

同一 LAN に接続されているルータの数も重要です。 各 LAN には、他のあらゆるルータと隣接関係をつくる DR と BDR があります。 LAN に存在する近隣ルータの数が少ないほど、DR や BDR が構築する隣接関係の数も小さくなります。 これは、使用しているルータにどれだけの能力があるかによって決まります。 DR を選択するために OSPF プライオリティを常に変更する可能性があります。 またもし可能なら、です複数のセグメントの DR 同一ルータを持っていることを避けることを試みて下さい。 DR の選択が 1 番上の RID に基づく場合、偶然にある 1 つのルータが、接続されているすべてのセグメント上での DR になる可能性があります。 このルータは、他のルータがアイドル状態の間も余分に稼動することになります。

spf22.gif

ABR 当たりのエリアの数

ABR は、サービスを提供する全エリアのデータベースのコピーを保持します。 たとえばルータが 5 つのエリアに接続されると、5 つのデータベースのリストを保持する必要があります。 ABR 当たりのエリアの数は多数の要素に依存しており、エリアのタイプ(ノーマル、スタブ、NSSA)、ABR CPU の能力、エリア当たりのルータの数、エリア当たりの外部ルータの数などによって決まります。 このため、ABR ごとに特定のエリア数を使用することはお勧めしません。 もちろん、常にエリアを他のルータへ広げられる場合は ABR をオーバーロードしないほうがよいでしょう。 次の図は、1 つの ABR が 5 つの異なるデータベースを維持する場合(エリア 0 を含む)と 2 つの ABR がそれぞれ 3 つのデータベースを維持する場合の違いです。 繰り返しますが、これらは単なるガイドラインに過ぎず、ABR ごとに設定するエリアが増えればパフォーマンスは低下します。 状況によっては、パフォーマンスの低下も許容されます。

/image/gif/paws/7039/spf23.gif

フルメッシュ対部分メッシュ

フレームリレーや X.25 などの Non Broadcast Multi-Access(NBMA)クラウドでは、常に困難が生じます。 帯域幅の低下とリンク ステートの増加が重なることにより、障害が発生しやすくなります。 部分メッシュ トポロジは、フルメッシュより動作が優れていることが分かりました。 入念に配置されたポイントツーポイントまたはポイントツーマルチポイント ネットワークの機能は、DR 問題の対処が必要なマルチポイント ネットワークよりはるかに優れています。

/image/gif/paws/7039/spf24.gif

メモリの問題

特定の OSPF 構成に必要なメモリを見積もるのは容易なことではありません。 メモリの問題は、通常は非常に多数の外部ルートが OSPF ドメインに挿入される場合に生じます。 バックボーン エリアのルータの数が 40 で外部ネットワークへのデフォルトルートが 1 つの場合、ルータ数が 4 つで 33,000 の外部ルートが OSPF に挿入されるバックボーン エリアに比べるとメモリ上の問題は少なくなります。

メモリは、優れた OSPF 設計を使用することによっても節約できます。 エリア境界ルータにおける集約とスタブエリアの使用により、交換されるルートの数はさらに削減可能です。

OSPF が使用するメモリ総量は、ルーティング テーブルで使用されるメモリ(show ip route summary)とリンクステート データベースで使用されるメモリの合計です。 次の数は、だいたいの目安による見積です。 ルーティング テーブルの各エントリの消費量は、約 200 ~ 280 バイトおよびパスを追加するごとに 44 バイトです。 各 LSA の消費量は 100 バイトのオーバーヘッドおよび実際の Link State Advertisement(LSA; リンク状態アドバタイズメント)のサイズです。各LSA はおそらく 60 ~ 100 バイトになります(ルータ リンクの場合、これはルータのインターフェイスの数によって決まります)。 さらに、他の処理と IOS そのものが使用するメモリに追加されるはずです。 厳密な数字が知りたい場合は、show memory を OSPF をオンにした状態としない状態で実行してください。 使用されるプロセッサ メモリの差異が答になります(configs のバックアップ コピーを保存します)。

通常、500K バイト未満のルーティング テーブルは 4 MB RAM への 2 と取り扱うことができます; 500K を超える大規模ネットワークには 8 ~ 16 MB が必要であり、すべてのルートがインターネットから挿入されている場合は 32 ~ 64 MB が必要になります。

要約

RFC 1583 で定義されている OSPF プロトコルは、高機能なオープン プロトコルを装備しているため、これにより複数ベンダーのネットワークが TCP/IP プロトコル ファミリを使用して通信することが可能になります。 OSPF の利点としては、ファースト コンバージェンス、VLSM、認証、階層的セグメント化、ルート集約、および集約性があり、これらは大規模で複雑なネットワークの処理に必要なものです。

付録 A: リンクステート データベースの同期

/image/gif/paws/7039/spf25.gif

上記の図では、同じセグメントのルータ同士が隣接関係を確立するまでの状態変化を表しています。 隣接ルータと Designated Router(DR; 代表ルータ)の選出は、Hello プロトコルを通じて行われます。 ルータは、隣接ルータからの Hello パケットに自ルータの情報を検出すると、「Two-Way(双方向)」状態に移行します。 マルチアクセス セグメント上では、この時点で DR および BDR の選出が実行されます。 2 台のルータのどちらかが既に DR または BDR であるか、または 2 台のルータがポイントツーポイントまたは仮想リンクで接続されている場合、ルータは隣接ルータとの隣接関係の確立を続行します。

Exstart 状態では、2 台のルータがマスター/スレーブ関係を確立し、初期シーケンス番号を一致させます。 シーケンス番号は、古いまたは重複した Link-State Advertisement(LSA; リンクステート アドバタイズメント)を検出するために使用されます。

Exchange 状態では、Database Description(DD)パケットが交換されます。 このパケットは、リンクステート アドバタイズメントがリンクステート ヘッダーの形式に短縮されたものです。 このヘッダーはリンクを識別するために十分な情報を提供します。 マスター ノードが DD パケットを送信すると、このパケットはスレーブ ノードからの DD パケットによって確認応答されます。 Exchange 以降の状態にある隣接関係はすべて、フラッディング手順によって使用されます。 これらの状態の隣接関係では、すべてのタイプの OSPF ルーティング プロトコル パケットの送受信を完全に行うことができます。

Loading 状態では、検出されているものの、まだ受信されていない新しいアドバタイズメントを要求するために、隣接ルータにリンクステート要求パケットが送信されます。 各ルータは要求された LSA のリストを作成し、隣接関係を最新の状態に更新します。 すべての LSA の確認応答が到達したことを確認するために、再送リストが維持されます。 隣接関係に対するリンクステート アドバタイズメントの再送間隔(秒)を指定するには、次のコマンドを使用します。


ip ospf retransmit-interval 
seconds

要求パケットに対する応答として、リンクステート アップデート パケットが送信されます。 リンクステート アップデート パケットは、すべての隣接ルータにフラッディングされます。

Full 状態では、隣接ルータ同士は完全に隣接関係になります。 共通のエリアのデータベースは、隣接ルータ間で正確に一致します。

各 LSA には age フィールドがあり、LSA がデータベース内にある間、またはエリア全体にフラッディングされる過程で、このフィールドが定期的に増加します。 どの隣接ルータの再送リストにもない LSA が Maxage に達すると、この LSA はデータベースからフラッシュ(消去)されます。

リンクステート アドバタイズメント

/image/gif/paws/7039/spf26.gif

リンクステート アドバタイズメントは、5 つのタイプに分けられます。 Router Link(RL; ルータ リンク)は、すべてのルータによって生成されます。 このリンクは、特定のエリア内にあるルータ インターフェイスの状態を記述します。 このリンクは、ルータのエリア内でのみフラッディングされます。 Network Links (NL)は特定のセグメントの DR によって生成されます; これらはそのセグメントに接続されるルータの示す値です。 Summary Links (SL)はエリア間 リンク(3)型です; これらのリンクは他のエリアの中のネットワーク 自律システムにまだ所属をリストします。 サマリー リンクは、Area Border Router (ABR; エリア境界ルータ) によってバックボーンから他のエリアに、また他のエリアからバックボーンに注入されます。 このリンクは、エリア間の集約のために使用されます。 サマリー リンクには、他に Autonomous System Border Router(ASBR; 自律システム境界ルータ)サマリー リンクというタイプもあります。 これは、ASBR へのルートを示すタイプ 4 リンクです。 これは、すべてのルータがその Autonomous System (AS; 自律システム)から外部に出る経路を確実に認識するためのものです。 最後のタイプはタイプ 5、External Link(EL; 外部リンク)です。EL は、ASBR によってドメインに注入されます。

上記の図は、それぞれのリンク タイプを示しています。 RTA は Area 1 内に RL を生成します。また、RTA はこのセグメントの DR でもあるため、NL も生成します。 RTB は ABR であり、エリア 1 に RL を生成し、エリア 0。RTB はまたエリア 1 およびエリア 0 にサマリー リンクを生成します。 これらのリンクは、2 つのエリア間で交換されるネットワークのリストです。 ASBR サマリー リンクはまたエリア 1.に RTB によってインジェクトされます。 これは RTD のプロシージャの示す値、自律システム境界ルータ(ASBR)です。 同様に、もう一つの ABR である RTC は Area 0 と Area 2 に対して RL を生成し、Area 2 には SL(3)を(ASBR がアナウンスされていないため)、RTD をアナウンスしている Area 0 には SL(3,4)を生成します。 RTD は Area 2 に対して RL を生成し、また BGP を通じて学習した外部経路の EL を生成します。 この外部経路は、ドメイン内全体にフラッディングされます。

次の表に、リンクステート アドバタイズメントの要約を示します。

LS Type アドバタイズメントの説明
1 ルータ リンク アドバタイズメント。 各ルータにより、そのルータが所属するエリアに対して生成されます。 ルータ上に存在する、そのエリアへのリンクの状態を記述します。 特定のエリア内でのみフラッディングされます。
2 ネットワーク リンク アドバタイズメント。 DR によって生成されます。 特定のネットワークに接続している一連のルータを記述します。 そのネットワークを含むエリア内でフラッディングされます。
3 または 4 サマリー リンク アドバタイズメント。 ABR によって生成されます。 エリア間経路を記述します。 タイプ 3 はネットワークへの経路を記述します。また、経路を集約するためにも使用されます。 タイプ 4 は ASBR への経路について記述します。
5 AS 外部リンク アドバタイズメント。 ASBR によって発信されます。 AS の外部の宛先への経路を記述します。 スタブ エリアを除くすべてのエリアにフラッデングされます。

show ip ospf database 詳細を使用して詳しく検知 すれば、OSPFデータベースをリンクデータのような異なるキーワードが、リンク ID およびリンクステートID 表示されます。 これらの用語はそれぞれの値がリンク状態型およびリンクタイプによって決まると同時に複雑になります。 次にこの用語について説明し、ルータから見た OSPF データベースに関する詳細な例を示します。

Link State ID は基本的に、LS タイプに応じたリンクステートの識別情報を定義します。 ルータ リンクは、アドバタイズメントを発信したルータの Router ID(RID; ルータ ID)によって識別されます。 ネットワークリンクは DR の相対的 な IP アドレスによって識別されます。 これはネットワークリンクが代表ルータによって起きるので理にかなっています。 サマリー リンク(タイプ 3)は、指し示す宛先の IP ネットワーク番号によって識別されます。 ASBR サマリー リンク(サマリー リンク タイプ 4)は、ASBR の RID によって識別されます。 最後に、外部リンクは、指し示す外部の宛先の IP ネットワーク番号によって識別されます。 次の表に要約を示します。

LS Type Link State ID(ルータからデータベースを参照する時は Link ID と表記)
1 発信側ルータの Router ID(RID)
2 ネットワークの DR の IP インターフェイス アドレス
3 宛先ネットワーク番号
4 記述された ASBR の RID
5 外部ネットワーク番号

次に、利用可能なさまざまなリンクについて説明します。

スタブ ネットワーク リンク: この用語はスタブ エリアとは無関係です。 スタブ セグメントとは、ルータが 1 台だけ接続されているセグメントです。 1 台のルータが接続されたイーサネットまたはトークン リング セグメントは、スタブ ネットワークへのリンクと見なされます。 ループバック インターフェイスも、255.255.255.255 のマスク(ホスト ルート)を持つスタブ ネットワークへのリンクと見なされます。

ポイントツーポイント リンク: 物理的または論理的な(サブインターフェイス)ポイントツーポイント シリアル リンク接続です。 番号が割り当てられる(IP アドレスがリンク上で設定される)場合と、割り当てられない場合があります。

トランジット リンク: 複数のルータが接続されているネットワークに接続されたインターフェイスです。そのため、「トランジット(輸送)」と呼ばれます。

仮想リンク: バックボーンへの物理的な接続を持たないエリアを接続するための論理リンクです。 仮想リンクは、番号を割り当てられたポイントツーポイント リンクとして扱われます。

Link ID はリンク自体の識別情報です。 これはリンクのタイプごとに異なります。 トランジット リンクは、そのリンク上の DR の IP アドレスによって識別されます。 番号を割り当てられたポイントツーポイント リンクは、そのポイントツーポイント リンク上の隣接ルータの RID によって識別されます。 仮想リンクはポイントツーポイント リンクと同じです。 最後に、スタブ ネットワークへのリンクは、そのスタブ ネットワークへのインターフェイスの IP アドレスによって識別されます。 次の表に要約を示します。

リンク タイプ Link ID(これは個々のリンクに適用される)
ポイントツーポイント 近接ルータのルータ ID
トランジット ネットワークへのリンク DR のインターフェイス アドレス
スタブ ネットワークへのリンク(ループバック マスクが 255.255.255.255 の場合) ネットワーク/サブネット番号
仮想リンク 近接ルータのルータ ID

Link Data とは、そのリンクの IP アドレスです。ただし、スタブ ネットワークの場合に限り、リンク データとはネットワーク マスクです。

リンク タイプ Link Data
スタブ ネットワーク ネットワーク マスク
その他のネットワーク(ルータ リンクにのみ適用) ルータに関連付けられた IP インターフェイス アドレス

最後に、アドバタイジング ルータ とは、LSA を送信したルータの RID です。

OSPF データベースの例

spf27.gif

上記のネットワーク ダイアグラム、下記の設定、および IP ルートティングテーブルに基づいて、さまざまな角度から OSPF データベースの理解を試みます。

RTA#
 interface Loopback0
  ip address 203.250.13.41 255.255.255.255

 interface Ethernet0
  ip address 203.250.15.68 255.255.255.192

 interface Ethernet1
  ip address 203.250.15.193 255.255.255.192

 router ospf 10
  network 203.250.0.0 0.0.255.255 area 0

 RTA#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is 203.250.15.67 to network 0.0.0.0

      203.250.16.0 255.255.255.192 is subnetted, 1 subnets
 O E2    203.250.16.128 [110/10] via 203.250.15.67, 00:00:50, Ethernet0
      203.250.13.0 255.255.255.255 is subnetted, 1 subnets
 C       203.250.13.41 is directly connected, Loopback0
      203.250.15.0 255.255.255.192 is subnetted, 3 subnets
 O IA    203.250.15.0 [110/74] via 203.250.15.67, 00:00:50, Ethernet0
 C       203.250.15.64 is directly connected, Ethernet0
 C       203.250.15.192 is directly connected, Ethernet1
 O*E2 0.0.0.0 0.0.0.0 [110/10] via 203.250.15.67, 00:00:50, Ethernet0

 RTE#
 ip subnet-zero

 interface Ethernet0
  ip address 203.250.16.130 255.255.255.192

 interface Serial0
  ip address 203.250.15.2 255.255.255.192

 router ospf 10
  redistribute rip metric 10 subnets
  network 203.250.15.0 0.0.0.63 area 1
  default-information originate metric 10

 router rip
  network 203.250.16.0

 ip route 0.0.0.0 0.0.0.0 Ethernet0

RTE#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is 0.0.0.0 to network 0.0.0.0

      203.250.16.0 255.255.255.192 is subnetted, 1 subnets
 C       203.250.16.128 is directly connected, Ethernet0
      203.250.13.0 is variably subnetted, 2 subnets, 2 masks
 O IA    203.250.13.41 255.255.255.255
            [110/75] via 203.250.15.1, 00:16:31, Serial0
      203.250.15.0 255.255.255.192 is subnetted, 3 subnets
 C       203.250.15.0 is directly connected, Serial0
 O IA    203.250.15.64 [110/74] via 203.250.15.1, 00:16:31, Serial0
 O IA    203.250.15.192 [110/84] via 203.250.15.1, 00:16:31, Serial0
 S*   0.0.0.0 0.0.0.0 is directly connected, Ethernet0

 RTC#
 ip subnet-zero

 interface Ethernet0
  ip address 203.250.15.67 255.255.255.192

 interface Serial1
  ip address 203.250.15.1 255.255.255.192

 router ospf 10
  network 203.250.15.64 0.0.0.63 area 0
  network 203.250.15.0 0.0.0.63 area 1

RTF#show ip route
 Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

 Gateway of last resort is 203.250.15.2 to network 0.0.0.0

      203.250.16.0 255.255.255.192 is subnetted, 1 subnets
 O E2    203.250.16.128 [110/10] via 203.250.15.2, 04:49:05, Serial1
      203.250.13.0 255.255.255.255 is subnetted, 1 subnets
 O       203.250.13.41 [110/11] via 203.250.15.68, 04:49:06, Ethernet0
      203.250.15.0 255.255.255.192 is subnetted, 3 subnets
 C       203.250.15.0 is directly connected, Serial1
 C       203.250.15.64 is directly connected, Ethernet0
 O       203.250.15.192 [110/20] via 203.250.15.68, 04:49:06, Ethernet0
 O*E2 0.0.0.0 0.0.0.0 [110/10] via 203.250.15.2, 04:49:06, Serial1

データベースの概要

RTC#show ip ospf database

       OSPF Router with ID (203.250.15.67) (Process ID 10)

                Router Link States (Area 1)

Link ID         ADV Router      Age    Seq#       Checksum Link count
203.250.15.67   203.250.15.67   48     0x80000008 0xB112   2
203.250.16.130  203.250.16.130  212    0x80000006 0x3F44   2

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age    Seq#       Checksum
203.250.13.41   203.250.15.67   602    0x80000002 0x90AA
203.250.15.64   203.250.15.67   620    0x800000E9 0x3E3C
203.250.15.192  203.250.15.67   638    0x800000E5 0xA54E

                Router Link States (Area 0)

Link ID         ADV Router      Age    Seq#       Checksum Link count
203.250.13.41   203.250.13.41   179    0x80000029 0x9ADA   3
203.250.15.67   203.250.15.67   675    0x800001E2 0xDD23   1

                Net Link States (Area 0)

Link ID         ADV Router      Age    Seq#       Checksum
203.250.15.68   203.250.13.41   334    0x80000001 0xB6B5

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age    Seq#       Checksum
203.250.15.0    203.250.15.67   792    0x80000002 0xAEBD

                Summary ASB Link States (Area 0)

Link ID         ADV Router      Age    Seq#       Checksum
203.250.16.130  203.250.15.67   579    0x80000001 0xF9AF

                AS External Link States

Link ID         ADV Router      Age    Seq#       Checksum Tag
0.0.0.0         203.250.16.130  1787   0x80000001 0x98CE   10
203.250.16.128  203.250.16.130  5      0x80000002 0x93C4   0

これは、OSPF データベースの概要を示したものです。 データベースは、エリアに従ってリストされています。 この出力は、ABR である RTC のデータベースであり、Area 1 と Area 0 の両方のデータベースがリストされています。 Area 1 はルータ リンクとサマリー リンクから構成されています。 Area 1 内のどのセグメントにも DR は存在しないため、ネットワーク リンクは存在しません。 ネットワークリンクはのでエリア 1.のセグメントの何れかで存在 する DR ありません。 サマリー ASBR リンクはエリア 1 に全体にわたってあふれると同時に唯一の ASBR があらゆる特定のエリアに属さないエリア 0。外部リンクにあることを起こるのでありません。 すべてのリンクが、エリア内のすべてのルータから収集された累積リンクである点に注意してください。

エリア 0 のデータベースに主に集中します。 ここに示されるリンク ID は実際にリンクステートID です。 これはルータ全体の表示、ない特定のリンクです。 誤解しやすいのですが、この高レベルの Link ID(本来は Link State ID)は、リンクではなくルータ全体を表す点は忘れないでください。

ルータ リンク

Router Link States (Area 0)

 Link ID         ADV Router      Age    Seq#       Checksum Link count
 203.250.13.41   203.250.13.41   179    0x80000029 0x9ADA   3
 203.250.15.67   203.250.15.67   675    0x800001E2 0xDD23   1

最初にルータ リンクを見ます。 203.250.13.41 のためにリストされている 2 つのエントリがあり、203.250.15.67 は、これらエリア 0 の 2 人のルータの RID です。 各ルータのためのエリア 0 のリンクの数はまた示されます。 RTA には Area 0 に対して 3 つのリンクがあり、RTC には 1 つのリンクがあります。 次に、RTC のルータ リンクの詳細を示します。

RTC#show ip ospf database router 203.250.15.67 

     OSPF Router with ID (203.250.15.67) (Process ID 10)

                Router Link States (Area 1)

  LS age: 1169
  Options: (No TOS-capability)
  LS Type: Router Links
  Link State ID: 203.250.15.67
  Advertising Router: 203.250.15.67
  LS Seq Number: 80000008
  Checksum: 0xB112
  Length: 48
  Area Border Router
   Number of Links: 2

    Link connected to: another Router (point-to-point)
     (Link ID) Neighboring Router ID: 203.250.16.130
     (Link Data) Router Interface address: 203.250.15.1
      Number of TOS metrics: 0
       TOS 0 Metrics: 64
 
    Link connected to: a Stub Network
     (Link ID) Network/subnet number: 203.250.15.0
     (Link Data) Network Mask: 255.255.255.192
      Number of TOS metrics: 0
       TOS 0 Metrics: 64

ここでは、OSPF がポイントツーポイント インターフェイスごとに追加のスタブ リンクを生成する点に注意してください。 物理インターフェイスの数よりもリンク カウントが多い場合もありますが、混乱しないでください。

Router Link States (Area 0)

  LS age: 1227
  Options: (No TOS-capability)
  LS Type: Router Links
  Link State ID: 203.250.15.67
  Advertising Router: 203.250.15.67
  LS Seq Number: 80000003
  Checksum: 0xA041
  Length: 36
  Area Border Router
   Number of Links: 1

    Link connected to: a Transit Network
     (Link ID) Designated Router address: 203.250.15.68
     (Link Data) Router Interface address: 203.250.15.67
      Number of TOS metrics: 0
       TOS 0 Metrics: 10

リンク ID が接続された DR の IP アドレス(ない RID)と等しいことに注目して下さい; この場合それは 203.250.15.68 です。 Link Data は、RTC 自身の IP アドレスです。

ネットワーク リンク

Net Link States (Area 0)

Link ID         ADV Router      Age    Seq#       Checksum
203.250.15.68   203.250.13.41   334    0x80000001 0xB6B5

1 つのネットワーク リンクが、DR のインターフェイス IP アドレス(RID ではなく)によって示されます。このケースでは、203.250.15.68 です。 次に、このエントリの詳細を示します。

RTC#show ip ospf database network

       OSPF Router with ID (203.250.15.67) (Process ID 10)

                Net Link States (Area 0)

  Routing Bit Set on this LSA
  LS age: 1549
  Options: (No TOS-capability)
  LS Type: Network Links
  Link State ID: 203.250.15.68 (address of Designated Router)
  Advertising Router: 203.250.13.41
  LS Seq Number: 80000002
  Checksum: 0xB4B6
  Length: 32
  Network Mask: 255.255.255.192

        Attached Router: 203.250.13.41
        Attached Router: 203.250.15.67

ネットワークリンクがトランジットネットワークに接続されるルータの RID をリストすることに注目して下さい; このケースでは、RTA と RTC の RID がリストされます。

サマリー リンク

Summary Net Link States (Area 0)

Link ID         ADV Router      Age    Seq#       Checksum
203.250.15.0    203.250.15.67   792    0x80000002 0xAEBD
Area 0 has one summary link represented by the IP network address of the
link 203.250.15.0. This link was injected by the ABR RTC from area 1 into
area 0. A detailed view of this summary link follows, summary links for
area 1 are not listed here:

RTC#show ip ospf database summary (area 1 is not listed)

              Summary Net Link States (Area 0)

  LS age: 615
  Options: (No TOS-capability)
  LS Type: Summary Links(Network)
  Link State ID: 203.250.15.0 (summary Network Number)
  Advertising Router: 203.250.15.67
  LS Seq Number: 80000003
  Checksum: 0xACBE
  Length: 28
  Network Mask: 255.255.255.192 TOS: 0  Metric: 64

サマリー ASBR リンク

Summary ASB Link States (Area 0)

Link ID         ADV Router      Age    Seq#       Checksum
203.250.16.130  203.250.15.67   579    0x80000001 0xF9AF

これは、どのルータが ASBR であるかを示しています。 このケースでは、ASBR は RTE であり、RID 203.250.16.130 によって表されています。 この Area 0 へのエントリのアドバタイジング ルータは RTC(RID 203.250.15.67)です。 次に、このサマリー ASBR エントリの詳細を示します。

RTC#show ip ospf database asbr-summary

        OSPF Router with ID (203.250.15.67) (Process ID 10)

                 Summary ASB Link States (Area 0)

   LS age: 802
   Options: (No TOS-capability)
   LS Type: Summary Links(AS Boundary Router)
   Link State ID: 203.250.16.130 (AS Boundary Router address)
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000003
   Checksum: 0xF5B1
   Length: 28
   Network Mask: 0.0.0.0 TOS: 0  Metric: 64

外部リンク

AS External Link States

Link ID         ADV Router      Age    Seq#       Checksum Tag
0.0.0.0         203.250.16.130  1787   0x80000001 0x98CE   10
203.250.16.128  203.250.16.130  5      0x80000002 0x93C4   0

2 つの外部リンクが存在します。最初のエントリは default-information originate コマンドによって OSPF に挿入された 0.0.0.0 です。 もう 1 つのエントリは、再配信によって OSPF に注入された 203.250.16.12 8 ネットワークです。 これらのネットワークをアドバタイズするルータは、203.250.16.130(RTE の RID)です。 次に、この外部経路の詳細を示します。

RTC#show ip ospf database external

        OSPF Router with ID (203.250.15.67) (Process ID 10)

                 AS External Link States

   Routing Bit Set on this LSA
   LS age: 208
   Options: (No TOS-capability)
   LS Type: AS External Link
   Link State ID: 0.0.0.0 (External Network Number )
   Advertising Router: 203.250.16.130
   LS Seq Number: 80000002
   Checksum: 0x96CF
   Length: 36
   Network Mask: 0.0.0.0
         Metric Type: 2 (Larger than any link state path)
         TOS: 0
         Metric: 10 
         Forward Address: 0.0.0.0
         External Route Tag: 10

  Routing Bit Set on this LSA
   LS age: 226
   Options: (No TOS-capability)
   LS Type: AS External Link
   Link State ID: 203.250.16.128 (External Network Number)
   Advertising Router: 203.250.16.130
   LS Seq Number: 80000002
   Checksum: 0x93C4
   Length: 36
   Network Mask: 255.255.255.192
         Metric Type: 2 (Larger than any link state path)
         TOS: 0
         Metric: 10
         Forward Address: 0.0.0.0
         External Route Tag: 0

Forward Address に注意してください。 このアドレスが外部ルートはアドバタイズ ルータで到達可能であることを示す 0.0.0.0 である時はいつでも、この場合 203。 250.16.130。 ASBR の識別情報が、ABR によって ASBR サマリー リンクを使用して他のエリアに注入されるのは、このためです。

この Forward Address は必ずしも 0.0.0.0 ではありません。 場合によっては、同じセグメント上にある別のルータの IP アドレスになることもあります。 次の図は、この状況を示しています。

/image/gif/paws/7039/spf28.gif

上記の状況では、RTB と RTA の間で BGP が動作し、RTB とドメイン内の他のルータとの間で OSPF が動作しています。 RTA では OSPF は動作していません。 RTB は OSPF に BGP 経路を再配送しています。 OSPF から見ると、RTB は外部経路をアドバタイズしている ASBR です。 125.211.1.1 とないアドバタイズ ルータ(0.0.0.0) RT B.へのフォーワーディングアドレスはこの場合設定 されます。 これは追加ホップを作る必要がないので理にかなっています。 これは、追加のホップを通過する必要がなくなるという利点があります。重要な点は、外部経路が IP ルーティング テーブルにインストールされるためには、OSPF ドメイン内のルータが OSPF 経由で Forwarding Address に到達できる必要があることです。 Forwarding Address が他のプロトコルを通じて到達される場合、または Forwarding Address に到達できない場合、外部経路はデータベースにインストールされても IP ルーティング テーブルにはインストールされません。

RTB と RTC がともに ASBR である場合は、状況が変わります(RTC と RTA の間でも BGP が動作しているとします)。 この状況では、重複を避けるため、2 台のルータうちの 1 台は外部経路をアドバタイズしません(フラッシュします)。 RID の大きい方のルータが選出され、そのルータがアドバタイズします。

データベース全体

最後に、練習としてデータベース全体のリストを示します。 ここまで読んできた方であれば、それぞれのエントリを調べてどのような状況にあるのかを説明できるはずです。

RTC#show ip ospf database router

         OSPF Router with ID (203.250.15.67) (Process ID 10)

                 Router Link States (Area 1)

   LS age: 926
   Options: (No TOS-capability)
   LS Type: Router Links
   Link State ID: 203.250.15.67
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000035
   Checksum: 0x573F
   Length: 48
   Area Border Router
    Number of Links: 2
     Link connected to: another Router (point-to-point)
      (Link ID) Neighboring Router ID: 203.250.16.130
      (Link Data) Router Interface address: 203.250.15.1
       Number of TOS metrics: 0
        TOS 0 Metrics: 64

     Link connected to: a Stub Network
      (Link ID) Network/subnet number: 203.250.15.0
      (Link Data) Network Mask: 255.255.255.192
       Number of TOS metrics: 0
        TOS 0 Metrics: 64

   Routing Bit Set on this LSA
   LS age: 958
   Options: (No TOS-capability)
   LS Type: Router Links
   Link State ID: 203.250.16.130
   Advertising Router: 203.250.16.130
   LS Seq Number: 80000038
   Checksum: 0xDA76
   Length: 48
   AS Boundary Router
    Number of Links: 2

     Link connected to: another Router (point-to-point)
      (Link ID) Neighboring Router ID: 203.250.15.67
      (Link Data) Router Interface address: 203.250.15.2
       Number of TOS metrics: 0
        TOS 0 Metrics: 64

     Link connected to: a Stub Network
      (Link ID) Network/subnet number: 203.250.15.0
      (Link Data) Network Mask: 255.255.255.192
       Number of TOS metrics: 0
        TOS 0 Metrics: 64

                 Router Link States (Area 0)

   Routing Bit Set on this LSA
   LS age: 1107
   Options: (No TOS-capability)
   LS Type: Router Links
   Link State ID: 203.250.13.41
   Advertising Router: 203.250.13.41
   LS Seq Number: 8000002A
   Checksum: 0xC0B0
   Length: 60
   AS Boundary Router
    Number of Links: 3

     Link connected to: a Stub Network
      (Link ID) Network/subnet number: 203.250.13.41
      (Link Data) Network Mask: 255.255.255.255
       Number of TOS metrics: 0
        TOS 0 Metrics: 1

     Link connected to: a Stub Network
      (Link ID) Network/subnet number: 203.250.15.192
      (Link Data) Network Mask: 255.255.255.192
       Number of TOS metrics: 0
        TOS 0 Metrics: 10

     Link connected to: a Transit Network
      (Link ID) Designated Router address: 203.250.15.68
      (Link Data) Router Interface address: 203.250.15.68
       Number of TOS metrics: 0
        TOS 0 Metrics: 10

   LS age: 1575
   Options: (No TOS-capability)
   LS Type: Router Links
   Link State ID: 203.250.15.67
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000028
   Checksum: 0x5666
   Length: 36
   Area Border Router
    Number of Links: 1

     Link connected to: a Transit Network
      (Link ID) Designated Router address: 203.250.15.68
      (Link Data) Router Interface address: 203.250.15.67
       Number of TOS metrics: 0
        TOS 0 Metrics: 10
 
 RTC#show ip ospf database network

        OSPF Router with ID (203.250.15.67) (Process ID 10)

                 Net Link States (Area 0)

   Routing Bit Set on this LSA
   LS age: 1725
   Options: (No TOS-capability)
   LS Type: Network Links
   Link State ID: 203.250.15.68 (address of Designated Router)
   Advertising Router: 203.250.13.41
   LS Seq Number: 80000026
   Checksum: 0x6CDA
   Length: 32
   Network Mask: 255.255.255.192
         Attached Router: 203.250.13.41
         Attached Router: 203.250.15.67
  
 RTC#show ip ospf database summary

        OSPF Router with ID (203.250.15.67) (Process ID 10)

                 Summary Net Link States (Area 1)

   LS age: 8
   Options: (No TOS-capability)
   LS Type: Summary Links(Network)
   Link State ID: 203.250.13.41 (summary Network Number)
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000029
   Checksum: 0x42D1
   Length: 28
   Network Mask: 255.255.255.255 TOS: 0  Metric: 11

   LS age: 26
   Options: (No TOS-capability)
   LS Type: Summary Links(Network)
   Link State ID: 203.250.15.64 (summary Network Number)
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000030
   Checksum: 0xB182
   Length: 28
   Network Mask: 255.255.255.192 TOS: 0  Metric: 10

   LS age: 47
   Options: (No TOS-capability)
   LS Type: Summary Links(Network)
   Link State ID: 203.250.15.192 (summary Network Number)
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000029
   Checksum: 0x1F91
   Length: 28
   Network Mask: 255.255.255.192 TOS: 0  Metric: 20

                 Summary Net Link States (Area 0)

   LS age: 66
   Options: (No TOS-capability)
   LS Type: Summary Links(Network)
   Link State ID: 203.250.15.0 (summary Network Number)
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000025
   Checksum: 0x68E0
   Length: 28
   Network Mask: 255.255.255.192 TOS: 0  Metric: 64
 
 RTC#show ip ospf asbr-summary

        OSPF Router with ID (203.250.15.67) (Process ID 10)

                 Summary ASB Link States (Area 0)

   LS age: 576
   Options: (No TOS-capability)
   LS Type: Summary Links(AS Boundary Router)
   Link State ID: 203.250.16.130 (AS Boundary Router address)
   Advertising Router: 203.250.15.67
   LS Seq Number: 80000024
   Checksum: 0xB3D2
   Length: 28
   Network Mask: 0.0.0.0 TOS: 0  Metric: 64

 
 RTC#show ip ospf database external

       OSPF Router with ID (203.250.15.67) (Process ID 10)

                 AS External Link States

   Routing Bit Set on this LSA
   LS age: 305
   Options: (No TOS-capability)
   LS Type: AS External Link
   Link State ID: 0.0.0.0 (External Network Number)
   Advertising Router: 203.250.16.130
   LS Seq Number: 80000001
   Checksum: 0x98CE
   Length: 36
   Network Mask: 0.0.0.0
         Metric Type: 2 (Larger than any link state path)
         TOS: 0
         Metric: 10
         Forward Address: 0.0.0.0
         External Route Tag: 10

   Routing Bit Set on this LSA
   LS age: 653
   Options: (No TOS-capability)
   LS Type: AS External Link
   Link State ID: 203.250.16.128 (External Network Number)
   Advertising Router: 203.250.16.130
   LS Seq Number: 80000024
   Checksum: 0x4FE6
   Length: 36
   Network Mask: 255.255.255.192
         Metric Type: 2 (Larger than any link state path)
         TOS: 0
         Metric: 10
         Forward Address: 0.0.0.0
         External Route Tag: 0

付録 B: OSPF と IP マルチキャスト アドレッシング

OSPF では、Hello パケットおよびリンクステート アップデートの交換に IP マルチキャストを使用します。 IP マルチキャスト アドレスは、クラス D アドレスを使用して実装されます。 クラス D アドレスとは、224.0.0.0 〜 239.255.255.255 の範囲のアドレスです。

/image/gif/paws/7039/spf29.gif

次の IP マルチキャスト アドレスは、OSPF 用に特別に予約されています。

  • 224.0.0.5: 224.0.0.5:OSPF ルータはすべて、このアドレスへの送受信ができます。

  • 224.0.0.6: 224.0.0.6:DR および BDR ルータはすべて、このアドレスへの送受信ができます。

IP マルチキャスト アドレスと MAC アドレスの間のマッピングには、次の規則があります。

マルチキャストをサポートするマルチアクセス ネットワークについては、IP アドレスの下位 23 ビットは MAC マルチキャスト アドレス 01-00-5E-00-00-00 の下位ビットとして使用されます。. 次に、例を示します。

  • 224.0.0.5 は 01-00-5E-00-00-05 にマップされます。

  • 224.0.0.6 は 01-00-5E-00-00-06 にマッピングされます。

OSPF では、トークン リング ネットワーク上でブロードキャストが使用されます。

付録 C: 可変長サブネット マスク(VLSM)

次に、2 進数/10 進数の変換表を示します。

  0000   0001   0010   0011   0100   0101   0110   0111
0 0000 16 0000 32 0000 48 0000 64 0000 80 0000 96 0000 112 0000
1 0001 17 0001 33 0001 49 0001 65 0001 81 0001 97 0001 113 0001
2 0010 18 0010 34 0010 50 0010 66 0010 82 0010 98 0010 114 0010
3 0011 19 0011 35 0011 51 0011 67 0011 83 0011 99 0011 115 0011
4 0100 20 0100 36 0100 52 0100 68 0100 84 0100 100 0100 116 0100
5 0101 21 0101 37 0101 53 0101 69 0101 85 0101 101 0101 117 0101
6 0110 22 0110 38 0110 54 0110 70 0110 86 0110 102 0110 118 0110
7 0111 23 0111 39 0111 55 0111 71 0111 87 0111 103 0111 119 0111
8 1000 24 1000 40 1000 56 1000 72 1000 88 1000 104 1000 120 1000
9 1001 25 1001 41 1001 57 1001 73 1001 89 1001 105 1001 121 1001
10 1010 26 1010 42 1010 58 1010 74 1010 90 1010 106 1010 122 1010
11 1011 27 1011 43 1011 59 1011 75 1011 91 1011 107 1011 123 1011
12 1100 28 1100 44 1100 60 1100 76 1100 92 1100 108 1100 124 1100
13 1101 29 1101 45 1101 61 1101 77 1101 93 1101 109 1101 125 1101
14 1110 30 1110 46 1110 62 1110 78 1110 94 1110 110 1110 126 1110
15 1111 31 1111 47 1111 63 1111 79 1111 95 1111 111 1111 127 1111
  1000   1001   1010   1011   1100   1101   1110   1111
128 0000 144 0000 160 0000 176 0000 192 0000 208 0000 224 0000 240 0000
129 0001 145 0001 161 0001 177 0001 193 0001 209 0001 225 0001 241 0001
130 0010 146 0010 162 0010 178 0010 194 0010 210 0010 226 0010 242 0010
131 0011 147 0011 163 0011 179 0011 195 0011 211 0011 227 0011 243 0011
132 0100 148 0100 164 0100 180 0100 196 0100 212 0100 228 0100 244 0100
133 0101 149 0101 165 0101 181 0101 197 0101 213 0101 229 0101 245 0101
134 0110 150 0110 166 0110 182 0110 198 0110 214 0110 230 0110 246 0110
135 0111 151 0111 167 0111 183 0111 199 0111 215 0111 231 0111 247 0111
136 1000 152 1000 168 1000 184 1000 200 1000 216 1000 232 1000 248 1000
137 1001 153 1001 169 1001 185 1001 201 1001 217 1001 233 1001 249 1001
138 1010 154 1010 170 1010 186 1010 202 1010 218 1010 234 1010 250 1010
139 1011 155 1011 171 1011 187 1011 203 1011 219 1011 235 1011 251 1011
140 1100 156 1100 172 1100 188 1100 204 1100 220 1100 236 1100 252 1100
141 1101 157 1101 173 1101 189 1101 205 1101 221 1101 237 1101 253 1101
142 1110 158 1110 174 1110 190 1110 206 1110 222 1110 238 1110 254 1110
143 1111 159 1111 175 1111 191 1111 207 1111 223 1111 239 1111 255 1111

可変長サブネット マスクが使われるようになった背景にあるのは、より柔軟にメジャー ネットを複数のサブネットに分割して、各サブネットに十分な数のホストを確保するという考え方です。 VLSM を使用しなければ、1 つのサブネット マスクは 1 つのメジャー ネットワークにしか割り当てることができません。 これが必要なサブネットの数があるホストの数を制限します。 十分なサブネットがあることマスクをそのような物選べば、各サブネットの十分なホストを割り当てられません。 同じはホストにあてはまます; 十分な数のホストを確保できるマスクでは、十分なサブネット スペースを提供できなくなります。

たとえばクラスCネットワーク 192.214.11.0 が割り当てられた 1 サブネットの 100 つのホストおよび残りのサブネットのそれぞれのための 50 のホストとの 3 つのサブネットにことネットワーク分かれる必要があることを、仮定すれば。 両端制限 0 および 255 を無視すれば、あなたに論理上利用可能 256 アドレス(192.214.11.0 が- 192.214.11.255)あります。 しかしこれは、VLSM を使用しなければ達成できません。

/image/gif/paws/7039/spf30.gif

使用できる一握りのサブネット マスクがあります; マスクは左から開始し、ビットの他によってがすべての 0s である物の隣接 する数があるはずであることに注目して下さい。

-252 (1111 1100) The address space is divided into 64.
 -248 (1111 1000) The address space is divided into 32.
 -240 (1111 0000) The address space is divided into 16.
 -224 (1110 0000) The address space is divided into 8.
 -192 (1100 0000) The address space is divided into 4.
 -128 (1000 0000) The address space is divided into 2.

VLSM なしでマスク 255.255.255.128 を使用する選択があり、アドレスを 128 の 2 つのサブネットに分けるためにそれぞれまたは使用 255.255.255.192 をホストし、64 の 4 つのサブネットに領域をホストしますそれぞれを分けます。 これは要件を満たしません。 複数のマスクを使用する場合、マスク 192 とマスク 128 およびより数字の大きなサブネットをアドレスの第 2 チャンク使用できます。 アドレス スペースをどのようにそれに応じて分けたかこの表に示されています。

spf31.gif

ここで、各マスクへの IP アドレスの割り当てに注意してください。 ルータまたはホストに IP アドレスを割り当てれば、そのセグメントのためにサブネット全体を使い果しました。 たとえば、E2 に 192.214.11.10 255.255.255.128 を割り当てると、192.214.11.0 から 192.214.11.127 までのアドレス範囲全体が E2 によって消費されます。 同様に、E2 に 192.214.11.160 255.255.255.128 を割り当てると、192.214.11.128 から 192.214.11.255 までのアドレス範囲全体が E2 セグメントによって消費されます。

これはルータがこれらのアドレスをどのようにの解読するか実例です。 組み合せ IP アドレスおよびマスクがサブネット0 という結果に終る場合サブネット化したら、ルータ不平を言う使用するナチュラルマスクと別のマスクをたとえばことを覚えていて下さい。 この問題を解決するためにルータの ip subnet-zero コマンドを使用して下さい。

RTA#
 ip subnet-zero
 interface Ethernet2
  ip address 192.214.11.10 255.255.255.128
 interface Ethernet3
  ip address 192.214.11.160 255.255.255.192
 interface Ethernet4
  ip address 192.214.11.226 255.255.255.192

 RTA#show ip route connected
      192.214.11.0 is variably subnetted, 3 subnets, 2 masks
 C       192.214.11.0 255.255.255.128 is directly connected, Ethernet2
 C       192.214.11.128 255.255.255.192 is directly connected, Ethernet3
 C       192.214.11.192 255.255.255.192 is directly connected, Ethernet4

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 7039