非同期転送モード(ATM) : 相手先固定接続(PVC)と相手先選択接続(SVC)

Cisco ルータのループバック モードについて

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 10 月 28 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ループバックはトラブルシューティングの重要な部分です; (特に回線がダウンしているとき)それらがエラーおよびエンド ツー エンド回路を隔離するのに使用されています。 この文書では、シスコ ルータの ATM インターフェイスでの、2 種類のループバックを詳細に説明します。

  • ループバック診断 - インターフェイスが正しく動作しているかどうかを判断するのに役立ちます。

  • loopback line - サービス プロバイダーに問題があるかどうかを判断するのに役立ちます。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • この文書の例は、特定のソフトウェアのバージョンに限定されません。 AIP はループバック診断をサポートし、PA-A1、PA-A2 および PA-A3 は両方のモードをサポートしています。 LANE モジュールは loopback line をサポートし、その他のシスコ ルータは両方のモードをサポートしています。

  • この文書の情報は、メイン インターフェイスにのみ適用され、サブインターフェイスには適用されません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

ネットワーク構成図

ループバック モードの説明には、次のネットワークを使用します。

/image/gif/paws/6337/loopback1.jpg

ループバック診断

シスコ ルータの ATM インターフェイスで loopback diagnostic コマンドを使用すると、インターフェイスから送信されるトラフィックがルータに戻ってきます。 図 1 と例 1 でそのプロセスを説明します。 非 ATM インターフェイスのループバック情報を参照するには、ここをクリックして、「Special Serial Line Tests」の項まで下方向にスクロールします。

loopback2.jpg

注: Tx は出力インターフェイスで、Rx は受信インターフェイスです。

注: 適切なクロッキングを確認するために、クロック ソースとしてルータを設定 して下さい。 ルータをクロック ソースとして設定するには、メイン インターフェイス設定で、ATM のclock internal 設定を指定します。

例 1

インターフェイスでループバック診断を設定する前に

LT-7507b
 lt7507b# show running-configg
 Building configuration...

 Current configuration:
  !
  version 12.0
  !
  hostname lt-7507b
  !
  ip subnet-zero
  no ip domain-lookup
  !
  interface ATM1/0
   no ip address
   no ip directed-broadcast
   no ip mroute-cache
   no atm ilmi-keepalive
  !
  interface ATM1/0.1 multipoint
   ip address 10.1.1.2 255.255.255.0
   no ip directed-broadcast
   pvc 0/85 
    protocol ip 10.1.1.1
    encapsulation aal5snap
   !
  ip classless
  no ip http server
  !
  line con 0
  transport input none
  line aux 0
  line vty 0 4
  login
  !
  end

lt-7507b# show interface atm 1/0
     ATM1/0 is up, line protocol is up
     Hardware is cxBus ATM
     MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
     reliability 255/255, txload 1/255, rxload 1/255
     Encapsulation ATM, loopback not set
     Keepalive not supported
     Encapsulation(s): AAL5, PVC mode
     256 TX buffers, 256 RX buffers,
     2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
     VC idle disconnect time: 300 seconds
     Last input 00:01:55, output 00:01:55, output hang never
     Last clearing of "show interface" counters never
     Queueing strategy: fifo
     Output queue 0/40, 0 drops; input queue 0/75, 0 drops
     5 minute input rate 0 bits/sec, 0 packets/sec
     5 minute output rate 0 bits/sec, 0 packets/sec
     163861 packets input, 3164940 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     33 input errors, 33 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     144191 packets output, 2138298 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out

注: PVC の ATM セルを送信できることをループバック メカニズムを説明するために、示します。 ループバックが設定されていない場合は、これらのセルはループバックされません。 もう一方のルータ lt-7200b で、ATM インターフェイスをシャットダウンします。

lt-7507b#debug atm packet interface 
     a1/0.1 vc 0/85
     ATM packets debugging is on
     Displaying packets on interface ATM1/0 VPI 0, VCI 85 only

      
     lt-7507b#ping
     Protocol [ip]:
     Target IP address: 10.1.1.1
     Repeat count [5]: 2
     Datagram size [100]:
     Timeout in seconds [2]:
     Extended commands [n]:
     Sweep range of sizes [n]:
     Type escape sequence to abort.
     Sending 2, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

ping が失敗し、ATM デバッグはトラフィックが送信されても、戻ってこないことを示します。

1w1d: ATM1/0.1(O):
     VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     1w1d: 4500 0064 001C 0000 FF01 B778 0A01 0102 0A01 0101 0800 9994 
     0E58 068B 0000
     1w1d: 0000 2D42 A290 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD
     1w1d: .
     1w1d: ATM1/0.1(O):
     VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     1w1d: 4500 0064 001D 0000 FF01 B777 0A01 0102 0A01 0101 0800 91C3 
     0E59 068B 0000
     1w1d: 0000 2D42 AA60 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD
     1w1d: .
     Success rate is 0 percent (0/2)

ここでループバック診断を追加し、show interface を使用して、ループバックが設定されていることを表示します。

lt-7507b#configure terminal
     Enter configuration commands, one per line. End with CNTL/Z.
     lt-7507b(config)#int a1/0
     lt-7507b(config-if)#loopback diagnostic
     lt-7507b(config-if)#atm clock internal

注: loopback コマンドは、サブインターフェイスではなく、メイン インターフェイスで設定する必要があります。

lt-7507b# show interface a1/0
     ATM1/0 is up, line protocol is up
     Hardware is cxBus ATM
     MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
     reliability 255/255, txload 1/255, rxload 1/255
     Encapsulation ATM, loopback set
     Keepalive not supported
     Encapsulation(s): AAL5, PVC mode
     256 TX buffers, 256 RX buffers,
     2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
     VC idle disconnect time: 300 seconds
     Last input 00:03:16, output 00:03:16, output hang never
     Last clearing of "show interface" counters never
     Queueing strategy: fifo
     Output queue 0/40, 0 drops; input queue 0/75, 0 drops
     5 minute input rate 0 bits/sec, 0 packets/sec
     5 minute output rate 0 bits/sec, 0 packets/sec
     163861 packets input, 3164940 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     33 input errors, 33 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     144191 packets output, 2138298 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 output buffer failures, 0 output buffers swapped out

ping が失敗しますが、ATM デバッグは、トラフィックが送信され(O)、戻ってくる(I)ことを示します。

lt-7507b#ping
     Protocol [ip]:
     Target IP address: 10.1.1.1
     Repeat count [5]: 2
     Datagram size [100]:
     Timeout in seconds [2]:
     Extended commands [n]:
     Sweep range of sizes [n]:
     Type escape sequence to abort.
     Sending 2, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

      
     1w1d: ATM1/0.1(O):
     VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     1w1d: 4500 0064 001A 0000 FF01 B77A 0A01 0102 0A01 0101 0800 119A 
     13A2 07C5 0000
     1w1d: 0000 2D41 2408 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD
     1w1d:
     1w1d: ATM1/0.1(I):
     VCD:0x5 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     1w1d: 4500 0064 001A 0000 0101 B57B 0A01 0102 0A01 0101 0800 119A 
     13A2 07C5 0000
     1w1d: 0000 2D41 2408 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD
     1w1d: .
     1w1d: ATM1/0.1(O):
     VCD:0x5 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     1w1d: 4500 0064 001B 0000 FF01 B779 0A01 0102 0A01 0101 0800 09C9 
     13A3 07C5 0000
     1w1d: 0000 2D41 2BD8 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD
     1w1d:
     1w1d: ATM1/0.1(I):
     VCD:0x5 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     1w1d: 4500 0064 001B 0000 0101 B57A 0A01 0102 0A01 0101 0800 09C9 
     13A3 07C5 0000
     1w1d: 0000 2D41 2BD8 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     1w1d: ABCD ABCD ABCD ABCD ABCD
     1w1d: .
     Success rate is 0 percent (0/2)

ループバック回線

シスコ ルータの ATM インターフェイスで loopback line コマンドを使用すると、着信トラフィックがネットワークに送り返されます。 以下の図 2 と例 2 を参照してください。

/image/gif/paws/6337/loopback3.jpg

例 2

ルータ lt-7200b の設定

LT-7200b
lt-7200b# show running-configg
  Building configuration...

 Current configuration:
  !
  version 12.0
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname lt-7200b
  !
  interface ATM2/0
   no ip address
   no ip directed-broadcast
   no atm ilmi-keepalive
  !
  interface ATM2/0.1 multipoint
   ip address 10.1.1.1 255.255.255.0
   no ip directed-broadcast
   pvc 0/85 
    protocol ip 10.1.1.2
    encapsulation aal5snap
   !
  !
  ip classless
  no ip http server
  !
  line con 0
  transport input none
  line aux 0
  line vty 0 4
  login
  !
  end

インターフェイスでループバック回線を設定する前に

lt-7200b# show interface atm 2/0
     ATM2/0 is up, line protocol is up
     Hardware is TI1570 ATM
     MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
     reliability 255/255, txload 1/255, rxload 1/255
     Encapsulation ATM, loopback not set
     Keepalive not supported
     Encapsulation(s): AAL5, PVC mode
     2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
     VC idle disconnect time: 300 seconds
     Last input 00:00:43, output 00:00:43, output hang never
     Last clearing of "show interface" counters never
     Queueing strategy: fifo
     Output queue 0/40, 0 drops; input queue 0/75, 0 drops
     5 minute input rate 0 bits/sec, 0 packets/sec
     5 minute output rate 0 bits/sec, 0 packets/sec
     94912 packets input, 1637823 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     102893 packets output, 2042225 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 output buffer failures, 0 output buffers swapped out

注: ATM パケット デバッグはルータ lt-7507b からのルータ lt-7200b に PING オンになり。 テストは(最初のループバックを削除した)7500 から再度実行されることが確認できます。 ループバック回線 により Telco のネットワークが正常に動作しているかどうかを確認できるため、これが通常の動作です。

lt-7507b#debug atm packet
     ATM packets debugging is on
     Displaying all ATM packets
     lt-7507b#debug atm packet sh debug

      
     lt-7507b#ping 10.1.1.1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 1/2/4 ms

ping が成功し、ATM デバッグはトラフィックが送信され、戻ってくることを示します。

00:45:14: ATM1/0.1(O):
     VCD:0x1 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     00:45:14: 4500 0064 0005 0000 FF01 B78F 0A01 0102 0A01 0101 0800 028C 
     02D4 0C51 0000
     00:45:14: 0000 0029 6C70 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:45:14: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:45:14: ABCD ABCD ABCD ABCD ABCD
     00:45:14:
     00:45:14: ATM1/0.1(I):
     VCD:0x1 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     00:45:14: 4500 0064 0005 0000 FE01 B88F 0A01 0101 0A01 0102 0000 0A8C 
     02D4 0C51 0000
     00:45:14: 0000 0029 6C70 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:45:14: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:45:14: ABCD ABCD ABCD ABCD ABCD

     
    Success rate is 100 percent (1/1)

ルータ lt-7200b の ATM インターフェイスでループバック回線を設定します。

lt-7200b#configure terminal
     Enter configuration commands, one per line. End with CNTL/Z.
     lt-7200b(config)#int a2/0
     lt-7200b(config-if)#loopback line
     lt-7200b(config-if)#^Z
     lt-7200b#config show interface a2/0
     ATM2/0 is up, line protocol is up
     Hardware is TI1570 ATM
     MTU 4470 bytes, sub MTU 4470, BW 155520 Kbit, DLY 80 usec,
     reliability 255/255, txload 1/255, rxload 1/255
     Encapsulation ATM,loopback set
     Keepalive not supported
     Encapsulation(s): AAL5, PVC mode
     2048 maximum active VCs, 1024 VCs per VP, 1 current VCCs
     VC idle disconnect time: 300 seconds
     Last input 00:02:45, output 00:02:45, output hang never
     Last clearing of "show interface" counters never
     Queueing strategy: fifo
     Output queue 0/40, 0 drops; input queue 0/75, 0 drops
     5 minute input rate 0 bits/sec, 0 packets/sec
     5 minute output rate 0 bits/sec, 0 packets/sec
     94917 packets input, 1638383 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     102898 packets output, 2042785 bytes, 0 underruns
     0 output errors, 0 collisions, 5 interface resets
     0 output buffer failures, 0 output buffers swapped out

注:  ルータ lt-7507b から ping を実行します。 予想通り ping は失敗しますが、トラフィックはネットワークからルータ lt-7507b に向けてループバックされ、ATM デバッグではトラフィックが送信され(O)、戻ってくる(I)ことが示されます。

lt-7507b#ping 10.1.1.1

      
     Type escape sequence to abort.
     Sending 2, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
        ..
     Success rate is 0 percent (0/2)

      
     00:52:00: ATM1/0.1(O):
     VCD:0x1 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     00:52:00: 4500 0064 000F 0000 FF01 B785 0A01 0102 0A01 0101 0800 CE44 1
     21D 0009 0000
     00:52:00: 0000 002F 9DB0 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:00: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:00: ABCD ABCD ABCD ABCD ABCD
     00:52:00:
     00:52:00: ATM1/0.1(I):
     VCD:0x1 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     00:52:00: 4500 0064 000F 0000 0101 B586 0A01 0102 0A01 0101 0800 CE44 
     121D 0009 0000
     00:52:00: 0000 002F 9DB0 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:00: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:00: ABCD ABCD ABCD ABCD ABCD
     00:52:00: .
     00:52:02: ATM1/0.1(O):
     VCD:0x1 VPI:0x0 VCI:0x55 DM:0x100 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     00:52:02: 4500 0064 0010 0000 FF01 B784 0A01 0102 0A01 0101 0800 C673 
     121E 0009 0000
     00:52:02: 0000 002F A580 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:02: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:02: ABCD ABCD ABCD ABCD ABCD
     00:52:02:
     00:52:02: ATM1/0.1(I):
     VCD:0x1 VPI:0x0 VCI:0x55 Type:0x0 SAP:AAAA CTL:03 OUI:000000 
     TYPE:0800 Length:0x70
     00:52:02: 4500 0064 0010 0000 0101 B585 0A01 0102 0A01 0101 0800 C673 
     121E 0009 0000
     00:52:02: 0000 002F A580 ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:02: ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD ABCD 
     ABCD ABCD ABCD
     00:52:02: ABCD ABCD ABCD ABCD ABCD
     Success rate is 0 percent (0/2)

結論

ループバックは、障害が発生した回線のトラブルシューティングに便利なツールです。 ループバックには、次の機能があります。

  • 物理インターフェイスの問題の判別。

  • ATM サービス プロバイダーのトラブルシューティング。

通常の方法のこの資料のテストを実行しました: 反対側の ping。 適切なマッピングを使用している場合、またはポイントツーポイント サブインターフェイスを使用している場合は、ユーザは自分自身の IP アドレスに ping を実行できます。 これにより、インターフェイスで ICMP エコーが確実に送信され、ルータによって応答を受けます。 つまり、実際の環境では、デバッグを無効にして同じテストを実行できます。 単に自分自身の IP アドレスに ping を実行して、テストが成功するかどうかを確認できます。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 6337