WAN : ポイントツーポイント プロトコル(PPP)

アクセス・サーバ・ダイヤルインIP/PPP 専用V.120 PPP 設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、V.120 PPP 専用のアクセス サーバ ダイヤルイン IP/PPP の設定例を説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS(R) 仮想非同期インターフェイスとの V.120 のためのソフトウェア リリース 11.2 または それ 以降。

  • バーチャル テンプレートの V.120 のための Cisco IOS ソフトウェア リリース 11.3 またはそれ以降。

  • 5 つ以上の VTY 行を設定するための Cisco IOS Enterprise イメージ。

どの Cisco IOSソフトウェア機能セットが V.120 機能性をサポートするか判別するのに Software Advisor ツール登録ユーザのみ)を使用して下さい。 ツールの中では、次の機能を選択して下さい: Protocol Translation のための V.120 対応、Protocol Translation およびバーチャル テンプレート。 追加機能を必要とする場合、それらを要求に応じて選択して下さい。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

国際電気通信連合電気通信 標準化セクタ (ITU-T) 推奨事項 V.120、同期の高信頼性 転送を可能に、非同期、または ISDN Bチャネル上のビット トランスペアレント データ。

V.120 接続は PPP か非PPPモードにある場合もあります。 これは V.120 多くのターミナル アダプタがモデムに類似したであるという理由により、いくつかの AT コマンド セットをサポートします。 非PPPモードが V.120 セットアップがクライアントおよびルータで正しいかどうか確かめるのに使用することができます。 PPP はそのリンクでそれから設定することができます。 詳細については非PPPモード セクションの確認 V.120 を参照して下さい。

V.120 を設定する 2 つの基本的な方法があります:

  • 仮想非同期インターフェイス

    Cisco IOSソフトウェアを使用する、非同期プロトコル機能を、VTY 行の PPP および SLIP のような、設定できます。 PPP および SLIP は非同期インターフェイスでだけ、ない VTY 行で普通機能します。 非同期プロトコル機能をサポートするために VTY 行を設定するとき VTY 行の仮想非同期インターフェイスを作成しています。 仮想非同期インターフェイス(別名 vty-async)は非物理的インターフェイスを通してルータを入力するサポート呼出しに作成されます。 たとえば、非同期 文字 ストリーム呼び出しは、または非物理的インターフェイスの土地終わります。 仮想非同期インターフェイスは設定可能なユーザではないです; むしろ、それらは動的に作成され、オンデマンド式で中断 されます。

  • 仮想テンプレート

    バーチャル テンプレート 実装はツー ステップ Protocol Translation を使用して PPP のトンネリングを、サポートします。 V.120 ユーザが仮想端末ラインを通ってダイヤルインするとき、ルータは仮想アクセスインターフェイスを作成します。 仮想アクセスインターフェイスはバーチャルインターフェイステンプレートで規定 される 非同期プロトコル 設定をサポートする一時インターフェイスです。 そのインターフェイスは設定の仮想テンプレートインターフェイスをクローンとして作ることによって動的に作成されます。 この仮想アクセスインターフェイスは接続が失敗するとすぐの上で解放されます。 バーチャル テンプレートは限られた仮想非同期 実装よりより多くの設定 オプションがあるので、より適用範囲が広いです。

V.120 がルータパフォーマンスに及ぼす影響

Cisco は V.120 処理が非常に CPU 集中型であるので Micamodem の V.120 上の PPP を実行することを推奨しません。 Cisco AS5200 は V.120 多くの同時にアクティブになる PPP 接続を処理できません。 他の AS5xxx ルータは V.120 より同時にアクティブになる PPP 接続を処理できます。 代替として、Cisco は接続が V.120 の代りに正常な同期化 PPP としてネットワーク アクセス サーバ(NAS)に入って来るように「同期から非同期の PPP 変換」をするためにクライアント ISDNターミナルアダプタ(TA)を設定することを推奨します。

ただし、Nextportモデムとモデム デジタル信号プロセッサ(DSP)に V.120 呼び出しをオフロードするために、新しい 機能は、追加されました。 Cisco IOS ソフトウェア リリース 12.2 XB (および 12.2(11)T およびそれ以降を)使用すれば、CPU の代りに NextPort DSP の V.120 コールを終了することは可能性のあるです。 詳細については、NextPort DSP の V.120 セッションの終了を参照して下さい。

PPP over V.120 を実装する理由

V.120 上の PPP は CPU 集中型です。 従って、Cisco は広汎なインプリメンテーションを落胆させます。 ただし次の原因で V.120 上の PPP を実行したいと思う場合もあります:

  • 非同期データ 端末装置(DTE)に接続される使用して、同期から非同期の PPP 変換をすることができません Terminal Adapter (TA)を。 この場合、V.120 を使用して下さい。

  • TA のデフォルト 設定は V.120 であり、インターネットサービスプロバイダー (ISP)の支援なしで TA を再構成することができません。

  • アプリケーションは(たとえば、特別なワンタイムパスワード チャレンジおよび応答) PPP セッションをキャラクタ セル ターミナル ダイアログと始めてもらいたいと思います、従って純粋な同期化 PPP セッションがほしいと思いません。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

このセクションはまた vty-async およびバーチャル テンプレートのための implementaion を記述します。

注: これらのステップは NAS が基本 ISDN か非同期ダイヤルイン アクセスのために正しく設定されると、そしてクライアントが V.120 上の PPP のために正しく設定されると仮定します。

仮想非同期インタフェース(vty-async)

vty-async を設定するために、これらのステップを完了して下さい:

  1. vty-async グローバル 設定 コマンドを使用して仮想非同期インターフェイスを作成して下さい。

  2. vty-async 接続のための認証を設定して下さい。 vty-async ppp を authen 使用して下さい{chap | pap}コマンド。

  3. 他の vty-async パラメータをのような、キープアライブ タイマー、MTU サイズ、セットアップ用のヘッダー圧縮、等、要求に応じて、設定して下さい。 詳細については Protocol Translation および Virtual asynchronous device コマンドを参照して下さい。

  4. 自動検出カプセル化 v120 ppp コマンドを使用して V.120 カプセル化の自動 検出を設定して下さい。 このコマンドは着信コールの物理インターフェイスに適用する必要があります(たとえば、interface bri 0、インターフェイス シリアル 1:23)。 ただし、呼出す V.120 TA が正しく Q.931 によって設定される低レベル Compatibility フィールドの V.120 に信号を送れば、自動検出カプセル化は必要ではないです。 残念ながら、多くの TA はこれをしません。

  5. VTY ラインコンフィギュレーションの下でユーザ名 および パスワード プロンプトをディセーブルにして下さい。 VTY ラインコンフィギュレーションモードのログオンおよびパスワードの設定なによってこれをすることができます。 AAA を使用している場合、方式がどれもない定義し、次に VTY インターフェイスに加えて下さいリストを。 次に、例を示します。

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. VTY ラインコンフィギュレーションモードの autocommand ppp default コマンドを設定して下さい。 ログイン認証および autocommand ppp 無し、V.120 接続が入るとすぐ VTY 開始 PPP。 これは V.120 ピアがスクリプトを実行しないで PPPネゴシエーションを、またはターミナル ウィンドウで入力しますユーザ名 および パスワードをすぐに開始するようにします。 autoselect コマンドは VTY でサポートされません。

    注: 接続が確立されるとすぐ VTY が PPP を実行し始めるので、NAS の telnet コマンドを管理上の目的で発行できません。 この制約事項を回避し、V.120 PPP 接続に使用する VTY の transport input v120 コマンドを適用し管理telnet に使用するそれらの transport input telnet コマンドを適用するため。

仮想テンプレート

バーチャル テンプレートを設定するために、これらのステップを完了して下さい:

  1. interface virtual-template コマンドの使用によってバーチャルインターフェイステンプレートを作成し、設定して下さい。 ちょうど規則的な非同期シリアルインターフェイスを設定するのでこの仮想インターフェイスを設定して下さい。 ちょうど非同期インターフェイスでそれを設定するので、これを行うために、バーチャルインターフェイステンプレートにアクティブインターフェイスの IP アドレスを(ip unnumbered interface コマンドを使用して)割り当て、アドレッシングを設定して下さい。 またインターフェイス設定モードで TCP ヘッダを圧縮するか、または PPP のための Challenge Handshake Authentication Protocol (CHAP) 認証を設定するコマンドを入力できます。 次に、例を示します。

    interface Virtual-Template1
      ip unnumbered Ethernet0
      no ip directed-broadcast
      ip tcp header-compression passive
      peer default ip address pool IPaddressPool
      ppp authentication chap
  2. vty-async グローバル 設定 コマンドを使用して仮想非同期インターフェイスを作成して下さい。

  3. バーチャルインターフェイステンプレートの定義に基づいて非同期プロトコル 機能を、サポートするために仮想端末ラインを設定して下さい。 グローバル コンフィギュレーション モードの vty-async virtual-template number コマンドを使用してこれをすることができます。 次に、例を示します。

    vty-async
    vty-async Virtual-Template 1
  4. 自動検出カプセル化 v120 ppp コマンドを使用して V.120 カプセル化の自動 検出を設定して下さい。 着信コールの物理インターフェイスにこのコマンドを適用して下さい(たとえば、interface bri 0、インターフェイス シリアル 1:23)。 ただし、呼出す V.120 TA が正しく Q.931 によって設定される低レベル Compatibility フィールドの V.120 に信号を送れば、自動検出カプセル化が必要となりません。 残念ながら、多くの TA はこれをしません。

  5. VTY ラインコンフィギュレーションの下でユーザ名 および パスワード プロンプトをディセーブルにして下さい。 VTY ラインコンフィギュレーションモードのログオンおよびパスワードの設定なによってこれをして下さい。 AAA を使用している場合、方式がどれもない定義し、次に VTY インターフェイスに加えて下さいリストを。 次に、例を示します。

    maui-soho-01(config)#aaa new-model
    maui-soho-01(config)#aaa authentication login NO_AUTHEN none
    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login authentication NO_AUTHEN
    
  6. VTY ラインコンフィギュレーションモードの autocommand ppp default コマンドを設定して下さい。 ログイン認証および autocommand ppp 無し、V.120 接続が入るとすぐ VTY initaites PPP。 これは V.120 ピアがスクリプトを実行するか、またはターミナル ウィンドウでユーザ名 および パスワードを入力しないで PPPネゴシエーションを、すぐに開始するようにします。 autoselect コマンドが VTY でサポートされないことに注目して下さい。

    注: 接続が確立されるとすぐ VTY が PPP を実行し始めるので、NAS の telnet コマンドを管理上の目的で発行できません。 この制約事項を回避し、V.120 PPP 接続に使用する VTY の transport input v120 コマンドを適用し管理telnet に使用するそれらの transport input telnet コマンドを適用するため。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

/image/gif/paws/6306/28a.gif

設定

このドキュメントでは次の設定を使用しています。

  • Cisco AS5200 ダイヤルイン IP か同期 ISDN PPP (ないマルチリンク)、非同期 PPP および V.120 PPP のための PPP クライアントをサポートする。

この設定は上述されている仮想非同期インターフェイス(vty-async)方式を使用します。

仮想非同期インターフェイスとの V.120 (PPP)
aaa new-model
aaa authentication login default local
aaa authentication login NOAUTH none             

!--- The aaa list NOAUTH has no authentication.
!--- This list will be applied to the vty interface.

! 
username fred password FLINTSTONE
!
ip local pool default 10.1.1.2 10.1.1.47

!--- Define local IP address pool.


vty-async                                        

!--- Configures all virtual terminal lines on a router to 
!--- support asynchronous protocol features.
!--- The vty-async parameters are required for Async V.120. 

vty-async keepalive 0       

!--- Disable PPP keepalives.

vty-async ppp authen chap pap 

!--- Async  V.120 PPP authentication methods.

!
interface Ethernet0
  ip address 10.1.1.1 255.255.255.0
!
interface serial0:23

!--- ISDN D-channel configuration for T1 0.

  no ip address
  encapsulation ppp
  isdn incoming-voice modem

!--- Analog calls are forwarded to the internal digital modem.

  ppp authentication chap pap
  dialer rotary-group 1

!--- Member of rotary group 1. 


!--- The rotary group configuration is interface Dialer 1.

  autodetect encapsulation v120 ppp  

!--- Automatic detection of encapsulation type on the specified interface. 
!--- This interface will automatically detect whether the call is normal PPP or V.120
!--- If the calling V.120 TA correctly signals V.120 in the Q.931 
!--- SETUP low-level compatibility field, autodetect encapsulation is 
!--- not needed. Unfortunately, many TAs fail to do this.   
   
!
interface Dialer1

!--- Rotary group 1 logical interface.

  description Dialer interface for sync ISDN calls
  ip unnumbered Ethernet0
  encapsulation ppp
  peer default ip address pool
  dialer-group 1
  dialer idle-timeout 300                      
  no cdp enable
  ppp authentication chap pap 
!
interface Group-Async1
  description Interface for async modem calls
  async mode dedicated                           

!--- PPP only, no exec dial-ins (or Teminal window after dial).
 
  ip unnumbered Ethernet0
  encapsulation ppp
  ip tcp header-compression
  peer default ip address pool default
  dialer-group 1
  dialer idle-timeout 300                        
  no cdp enable
  ppp authentication chap pap
!
dialer-list 1 protocol ip permit
!
line con 0
  login authentication NOAUTH
line 1 48

!--- Modems used for normal async calls.

  no exec
  modem inout
!                                                
line vty 0 45

!--- V.120 call will be terminated on vty 0 45.
!--- If your router does not support more than five vtys refer 
!--- to the Components Used section.

  login authentication NOAUTH    

!--- Use the AAA list NOAUTH (which specified no authentication) 
!--- configured previously with this method. There will be no 
!--- Username/password exec prompt. Use the no login command
!--- if this NAS does not do AAA.

  autocommand ppp default

!--- This command is ONLY required for V.120 with PPP.

  session-timeout 5 output                       

!--- Timeout of 5 minutes.

  transport input v120                           

!--- Allow only V.120 connections into these VTYs.

line vty 46 50

!--- These vtys will be used for normal telnets into the router.

  login authentication default

!--- Use AAA list "default" for vty 46-50. 
!--- This method uses local authentication (configured previously).

  exec-timeout 30
  transport input telnet

!--- Permit only incoming telnet connections to use vty 46-50.


確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip route — IPルーティングテーブル エントリを表示する。

  • show users — ライン番号、接続名およびターミナル位置を含むネットワークサーバのアクティブ回線についての情報を、表示する。

V.120 接続を確認して下さい

V.120 接続を確認するために、これらのステップを完了して下さい:

  1. debug v120 を使用し、V.120 着信 コールを生成して下さい。 NAS のこのデバッグ 出力を見るはずです:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4

    このメッセージが現れない場合、着信コールはおそらく V.120 ではなかったし、それ故にルータはそれをそのように検出する。

  2. vty-async インターフェイスがアップするかどうか確かめて下さい。 設定がバーチャル テンプレートによって V.120 を使用する場合、仮想アクセスインターフェイスが作成されるかどうか確認して下さい。 次のコンソール ログ出力では、vty-async 32 インターフェイスは稼働しています:

    19:25:17: %LINK-3-UPDOWN: Interface VTY-Async32, 
    changed state to up
  3. debug ppp negotiation および debug ppp authentication を使用して下さい。 PPP パラメータがきちんとネゴシエートされるようにするため。 Pppデバッグに関する詳細については、ダイヤルアップ技術を参照して下さい: Troubleshooting Techniques」

  4. V.120 コールがきちんと確立されることを確認するために show ip route および show users を行って下さい。

次の例は V.120 バーチャル テンプレートを持っていないセットアップからの出力です:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.68.0.0/32 is subnetted, 1 subnets
S       172.68.186.41 [1/0] via 172.18.120.1
     172.18.0.0/24 is subnetted, 1 subnets
S       172.18.120.0 [1/0] via 10.92.1.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.92.1.0 is directly connected, FastEthernet0
C    192.168.1.0/24 is directly connected, Loopback0
     172.0.0.0/32 is subnetted, 1 subnets
C       172.22.53.1 is directly connected, VTY-Async32

注: コールはインターフェイス VTY-Async 32 で接続され、クライアントへルートがあります。

注: リンクの NAS 側の IP アドレスはバーチャルテンプレートの設定 オプションを非使用するとき NAS のイーサネットかファーストイーサネット インターフェイスのそれです。 それ故にイーサネットかファーストイーサネット インターフェイスがアップ、ping することができるかどうか確かめて下さい。

DSL4-5300A#show users
  Line          User       Host(s)              Idle     Location
*0 con 0                   idle                 00:00:00
 32 vty 0     wan-2520-5  VTY-Async32           00:01:37 Serial0:18
Interface        User      Mode                 Idle     Peer Address
  VT32         wan-2520-5 Async PPP             00:01:14 172.22.53.1

注: コールはインターフェイス VTY-Async 32 で接続され、ピアIP アドレスは規定 されます。

V.120 とバーチャル テンプレート オプションを使用すれば show ip route および show user 出力はこれのように現われます:

DSL4-5300A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.199.0/32 is subnetted, 1 subnets
C       192.168.199.5 is directly connected, Virtual-Access1
     172.22.0.0/32 is subnetted, 1 subnets
S       172.22.186.41 [1/0] via 172.18.120.1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.20.20.0 is directly connected, Virtual-Access1
.........

注: コールはインターフェイス 仮想 アクセス 1 で接続され、クライアントへルートがあります。

DSL4-5300A#show users
    Line       User       Host(s)              Idle       Location
*  0 con 0                idle                 00:00:00
  32 vty 0     wan-2520-5 Virtual-Access1      00:00:05 Serial0:18

注: コールはインターフェイス 仮想 アクセス 1.で接続されます。

非PPPモードの V.120 を確認して下さい

V.120 多くのターミナル アダプタはモデムに類似したで、いくつかの AT コマンド セットをサポートします。 それ故に、クライアントで設定される V.120 およびルータが正しいかどうか確かめるのに非PPPモードを使用できます。 それからそのリンクの conffigure PPP できます。 V.120 をテストすることはそれ自体私達を PPP の複雑な状況を追加しないで V.120 関連問題を解決する認めます。

非PPPモードの V.120 接続をテストするために、これらのステップを完了して下さい:

  1. VTY ラインコンフィギュレーションの下でユーザ名 および パスワード プロンプトを有効に して下さい。 ログインを有効に する login コマンドを使用して下さい。 回線パスワードを設定 する password password コマンドを使用して下さい。 AAA を使用している場合、VTY の下でログイン認証 list コマンドを削除して下さい。

  2. VTY ラインコンフィギュレーションモードの autocommand ppp default コマンドを削除して下さい。 次に、例を示します。

    maui-soho-01(config)#line vty 0 4
    maui-soho-01(config-line)#login
    maui-soho-01(config-line)#password letmein
    maui-soho-01(config-line)#no autocommand ppp default
    
  3. debug v120 をつけ、クライアントからのコールを開始して下さい。 ルータはこれを表示する必要があります:

    19:25:16: V120: Autodetect trying to detect V120 mode on Se0:18
    19:25:16: V120 sampled pkt:  3 bytes:  8 1 7F
    19:25:16: Se0:18-v120 started - Setting default V.120 parameters
    19:25:16: V120extablished handle = 4       
  4. V.120 設定の他を続けて下さい。 設定セクションに説明があるステップを完了して下さい。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティング コマンド (オプション)

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを発行する前に、詳細については Debug コマンドの重要な情報を参照して下さい。

  • debug v120 — V.120 示します処理が、およびインターフェイスそれ動作している開始するか、または終わるとき。

  • リンク制御プロトコル (LCP)を含む PPP コンポーネント、認証および NCP をネゴシエートしている間 debug ppp negotiation — PPP トラフィックおよび交換の情報を表示する。 成功した PPP ネゴシエーションが最初に LCP ステートを開いて認証し、最後に NCP(通常 IPCP)をネゴシエートします。

  • debug ppp authentication — CHAP パケット交換および Password Authentication Protocol (PAP)交換を含む PPP認証 プロトコルメッセージを、表示する。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 6306