ダイヤルとアクセス : 非同期接続

アクセス サーバでの WINS、DNS、および DHCP の設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2004 年 9 月 6 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

特定のダイヤルイン クライアントがネットワークに適切に接続するためには Windows Internet Naming Service(WINS)、またはドメイン ネーム システム(DNS)サーバ情報が必要です。 さらに、アクセス サーバでのダイヤルイン クライアントへの IP アドレスの割り当てには、いくつかの異なる方法があります。

前提条件

要件

この設定を行う前に、次の要件が満たされていることを確認します。

  • ルータが着信非同期コールと ISDN コールを受信できるように設定し、それを確認します。 詳細については、「着信の非同期コールおよび ISDN コールについて、PRI(一次群速度インターフェイス)の備わったアクセス サーバの設定」で説明されている設定手順を参照してください。

  • DHCP、DNS、および WINS サーバが正しく設定されていることを確認します。 詳細については、システム管理者にお問い合わせください。

    注: この設定では、WINS、DNS、および DHCP サーバが、別々のサーバであると仮定しています。 実際には、これらを 1 台のサーバ上で実行することもできます。また、1 台のサーバ上で WINS と DNS を実行して、DHCP は他のサーバ上で実行するなど、3 つの機能をさまざまな組み合わせで実行できます。

使用するコンポーネント

この設定は、次の機器やデバイスを使用して開発され、テストされました。

  • T1 PRI 回路を搭載した Cisco AS5200

  • DNS サーバ

  • WINS サーバ

  • クライアントに IP アドレスを割り当てる DHCP サーバ

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

関連製品

DNS、DHCP、および WINS の設定コマンドは、PPP コールの着信をサポートするあらゆるルータで使用できます。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景理論

クライアントに IP アドレスを割り当てるには、次のようないくつかの方法があります。

  • アクセス サーバ上のローカル IP プールからアドレスを割り当てる。

  • 外部のダイナミック ホスト制御プロトコル(DHCP)サーバを使用する。

  • Remote Authentication Dial-in User Service(RADIUS)または Terminal Access Controller Access Control System(TACACS+)を使用する。

この文書では、WINS および DNS サーバの情報を、アクセス サーバ経由でダイヤルイン クライアントに渡すための手順について説明します。 アクセス サーバは、外部 DHCP サーバから返された IP アドレスを、さらにダイヤルイン クライアントに渡すことになります。

詳細については、このドキュメントの「関連情報」のセクションを参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ネットワーク構成図

この文書では、次のダイヤグラムに示すネットワーク設定を使用します。

/image/gif/paws/6303/winsdhcp.gif

設定

AS5200 アクセス サーバには、2 基の Primary Rate Interface(PRI; 一次群速度インターフェイス)が搭載されており、非同期および ISDN ユーザの着信を許可しています。 ダイナミック ダイヤラ マップは ISDN ユーザに作成されます。 ダイヤルイン アクセスを必要とする各ユーザには、TACACS+ または RADIUS 設定を行わずに、ユーザ名とパスワードを割り当てる必要があります。 すべての IP アドレスは、DHCP サーバによってクライアントに渡されます。 アクセス サーバでは、PPP IP Control Protocol(IPCP)ネゴシエーションの際に、DNS サーバと WINS サーバの IP アドレスをクライアントに渡します。

AS5200 アクセス サーバ
version 11.1
!
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service udp-small-servers
no service tcp-small-servers
!
hostname as5200
!
enable password letmein
!
username Jason password foo
username Laura password bar
username Russ password fake
username Syed password pseudo
username Tito password knockknock
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 framing esf
 clock source line secondary
 linecode b8zs
 pri-group timeslots 1-24
!
interface Loopback0
 ip address 172.16.209.65 255.255.255.192
!
interface Loopback1
 ip address 172.16.209.129 255.255.255.192
!
interface Ethernet0
 ip address 172.16.162.4 255.255.255.0

!
interface Serial0
 no ip address 
!
interface Serial1
 no ip address
!
interface Serial0:23
 no ip address
 isdn incoming-voice modem
 dialer rotary-group 1
 encapsulation ppp
 no fair-queue
!
interface Serial1:23
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 isdn incoming-voice modem
 no fair-queue
!
interface Group-Async1
 ip unnumbered Ethernet0
 encapsulation ppp
 async mode interactive
 peer default ip address dhcp

! -- Async dialup users will be assigned ip addresses from 
! -- the dhcp server. The dhcp server is specified with the
! -- ip dhcp-server command shown below.
! -- Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast 
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below.
! -- Refer to the section Command Summary for more information.

 ppp authentication chap
 group-range 1 48
!
interface Dialer1
 ip unnumbered Ethernet0
 encapsulation ppp
 peer default ip address dhcp

! -- ISDN dialup users will be assigned ip addresses from the dhcp server.
! -- The dhcp server specified with the ip dhcp-server command shown 
! -- below. Refer to the section Command Summary for more information.

 ip helper-address 172.16.162.10

! -- The ip helper address command enables BOOTP broadcast  
! -- forwarding for a set of clients. The helper address specifies
! -- the address of the DHCP server configured below. 
! -- Refer to the section Command Summary for more information.

 dialer in-band
 dialer idle-timeout 300
 dialer-group 1
 no fair-queue
 ppp multilink
 ppp authentication chap
!
router eigrp 222
 redistribute connected
 network 172.16.0.0
!
dialer-list 1 protocol ip permit
!
async-bootp dns-server 172.16.224.100 172.16.154.101

! -- Specifies the primary and secondary DNS servers.
! -- The first IP address belongs to the primary DNS server.
! -- If you only have one DNS server you do not need to specify 
! -- a secondary DNS server.
! -- Refer to the section Command Summary for more information.

async-bootp nbns-server 172.16.224.10 172.16.4.2 

! -- Specifies the primary and secondary WINS  servers.
! -- The first IP address belongs to the primary WINS server.
! -- If you only have one WINS server you do not need to specify 
! -- a secondary WINS server.
! -- Refer to the section Command Summary for more information.

ip dhcp-server 172.16.162.10

! -- Specifies the dhcp server ip address. This command is required
! -- if the IP address for dialin clients is obtained from the server.
! -- Note: The dhcp server need not be on the same subnet as the 
! -- Ethernet interface. 
! -- It can be more than one hop away as long has it is reachable.

!
line con 0
 login 
line 1 48
modem InOut
transport input telnet
 autoselect during-login
 autoselect ppp
 flowcontrol hardware
line aux 0
line vty 0 4
 password secret
 login 
!
end

コマンドの概要

次に、アクセス サーバ上の DHCP、DNS、および WINS に関連するコマンドを説明します。

  • ip helper-address アドレス - DHCP プロトコルの情報は、BOOTP パケットによって伝達されます。 ip helper address コマンドは、一連のクライアントに対して BOOTP ブロードキャスト転送を有効にします。 ヘルパー アドレスには、DHCP サーバのアドレスを指定します。また、クライアントに最も近いインターフェイス(この場合は、group-async および dialer インターフェイス)に対して設定する必要があります。 複数のサーバがある場合、各サーバに 1 つのヘルパー アドレスを設定できます。 ヘルパー アドレスは、RFC 1531 で定義されています leavingcisco.comDHCP プールでは複数のドメイン名を設定できません。

  • peer default ip address dhcp - DHCP 方式によるアドレスに、このインターフェイスに接続するリモート ピアに返されるように指定します。 このことは、このインターフェイスに接続するクライアントには、DHCP サーバから取得した IP アドレスが割り当てられることを意味します。 また、ip dhcp server コマンドを使用して、クライアントの IP アドレスを取得する DHCP サーバの IP アドレスを指定することもできます。

  • async-bootp dns-server アドレス - RFC1877 を実装する PPP クライアントを扱う際に NAS が応答する DNS サーバのアドレスを設定します。 leavingcisco.comこの DNS サーバの IP アドレスは、IPCP ネゴシエーションの際にダイヤルイン クライアントに渡されます。

  • async-bootp nbns-server アドレス - Windows Name Service(WINS)サーバの IP アドレスを指定します。 この WINS サーバの IP アドレスは、IPCP ネゴシエーションの際にダイヤルイン クライアントに渡されます。

確認

クライアントがアクセス サーバから適切なパラメータを正しく受け取っているかどうかを確認するには、クライアントからテストを行う必要があります。

たとえば、クライアントから、www.cisco.com のような DNS で解決可能なアドレスを ping します。 DNS サーバがアドレスを解決した場合は、設定が正しく動作しています。 WINS サーバの割り当てをテストするには、Windows ネットワークを使用してネットワークを参照します。

ダイナミック ダイヤラ マップが作成されているかどうかを調べるには、ISDN 接続が構築された後で、show dialer map コマンドを実行します。 これがないと、ルーティングを行うことができません。 ピアに割り当てられたアドレスを確認してください(このアドレスは、DHCP サーバから得られたものです)。 これによって、DHCP アドレスの割り当てが正しく行われたことを検証できます。

Output Interpreter Tool(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。 OIT を使用して、show コマンド出力の解析を表示できます。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

この文書では、ISDN のレイヤ 1、2、3 が正しく機能していると仮定します。 ISDN の下位レイヤに問題がある問題があります。 詳細については、『show isdn status コマンドを使用した BRI のトラブルシューティング』というドキュメントを参照してください。

注: debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

  • debug ppp 認証 - クライアントが認証を渡しているかどうかを確認するためのものです。 Cisco IOS 以前のバージョンを使用していればか。 ソフトウェア リリース 11.2 は、debug ppp chap コマンドを代りに使用します。

  • debug ppp 認証 - クライアントが PPP ネゴシエーションを渡しているどうかを確認するためのものです。 this is when you check for address negotiation. IPCP ネゴシエーションは、クライアントに渡されている DNS サーバと WINS サーバの情報を示します。

  • debug ppp エラー - PPP の接続ネゴシエーションや動作に関連するプロトコル エラーおよびエラーの統計を表示。

DNS サーバと WINS サーバの割り当ては、PPP ネゴシエーションの IPCP フェーズで行われています。 出力例を次に示します。

debug 出力例

この debug ppp negotiation コマンドの出力(非同期ダイヤルイン コールに対して)では、クライアントの IPCP ネゴシエーションが示されます。 この例では、プライマリ DNS サーバだけが指定されました。 WINS サーバはクライアントに渡されていません。

Sep 26 12:50:47.227: As97 CHAP: O CHALLENGE id 1 len 32 
from "maui-nas-02"
Sep 26 12:50:47.355: As97 CHAP: I RESPONSE id 1 len 31 
from "async_user"
Sep 26 12:50:47.355: As97 AUTH: Started process 0 pid 56
Sep 26 12:50:47.355: As97 CHAP: O SUCCESS id 1 len 4
Sep 26 12:50:47.359: As97 PPP: Phase is UP [0 sess, 0 load]

! -- IPCP negotiation begins

Sep 26 12:50:47.359: As97 IPCP: O CONFREQ [Closed] id 1 len 10
Sep 26 12:50:47.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:47.467: As97 IPCP: I CONFREQ [REQsent] id 1 len 40
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:47.467: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2

! -- The IP address for the client is assigned.

Sep 26 12:50:47.467: As97 IPCP: O CONFREJ [REQsent] id 1 len 28
Sep 26 12:50:47.467: As97 IPCP:    CompressType VJ 15 slots 
CompressSlotID 
(0x0206002D0F01)
Sep 26 12:50:47.467: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:47.467: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:47.483: As97 CCP: I CONFREQ [Not negotiated] 
id 1 len 15
Sep 26 12:50:47.483: As97 CCP:    MS-PPC supported bits 
0x00000001 
(0x120600000001)
Sep 26 12:50:47.483: As97 CCP:    Stacker history 1 check mode 
EXTENDED 
(0x1105000104)
Sep 26 12:50:47.483: As97 LCP: O PROTREJ [Open] id 4 len 21 
protocol CCP
Sep 26 12:50:47.483: As97 LCP:  (0x80FD0101000F12060000000111050001)
Sep 26 12:50:47.483: As97 LCP:  (0x04)
Sep 26 12:50:47.499: As97 IPCP: I CONFACK [REQsent] id 1 len 10
Sep 26 12:50:47.499: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.359: As97 IPCP: TIMEout: State ACKrcvd
Sep 26 12:50:49.359: As97 IPCP: O CONFREQ [ACKrcvd] id 2 len 10
Sep 26 12:50:49.359: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:49.467: As97 IPCP: I CONFACK [REQsent] id 2 len 10
Sep 26 12:50:49.467: As97 IPCP:    Address 172.22.53.140 
(0x0306AC16358C)
Sep 26 12:50:50.459: As97 IPCP: I CONFREQ [ACKrcvd] id 2 len 34
Sep 26 12:50:50.459: As97 IPCP:    Address 0.0.0.0 (0x030600000000)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.459: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.459: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.459: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.463: As97 IPCP: O CONFREJ [ACKrcvd] id 2 len 22
Sep 26 12:50:50.463: As97 IPCP:    PrimaryWINS 0.0.0.0 
(0x820600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryDNS 0.0.0.0 
(0x830600000000)
Sep 26 12:50:50.463: As97 IPCP:    SecondaryWINS 0.0.0.0 
(0x840600000000)
Sep 26 12:50:50.571: As97 IPCP: I CONFREQ [ACKrcvd] id 3 len 16
Sep 26 12:50:50.571: As97 IPCP:    Address 0.0.0.0 
(0x030600000000)
Sep 26 12:50:50.571: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Start.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 AAA/AUTHOR/IPCP: Done.  
Her address 0.0.0.0, we want 172.22.60.2
Sep 26 12:50:50.571: As97 IPCP: O CONFNAK [ACKrcvd] id 3 len 10
Sep 26 12:50:50.571: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP: I CONFREQ [ACKrcvd] id 4 len 16
Sep 26 12:50:50.683: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.683: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Start.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.683: As97 AAA/AUTHOR/IPCP: Reject 172.22.60.2, 
using 172.22.60.2
Sep 26 12:50:50.687: As97 AAA/AUTHOR/IPCP: Done.  
Her address 172.22.60.2, we want 172.22.60.2
Sep 26 12:50:50.687: As97 IPCP: O CONFACK [ACKrcvd] id 4 len 16
Sep 26 12:50:50.687: As97 IPCP:    Address 172.22.60.2 
(0x0306AC163C02)
Sep 26 12:50:50.687: As97 IPCP:    PrimaryDNS 172.22.53.210 
(0x8106AC1635D2)

! -- The IP address of the client and Primary DNS server's 
! -- IP address are negotiated.

Sep 26 12:50:50.687: As97 IPCP: State is Open

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 6303