Cisco インターフェイスとモジュール : ???????/????????

Catalyst 4500/4000 ファミリー(WS-X4232-L3)用のルータモジュールの設定および外観

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 3 月 1 日) | 英語版 (2015 年 10 月 7 日) | フィードバック


目次


概要

このドキュメントでは、Cisco Catalyst 4500/4000 シリーズ スイッチの WS-X4232-L3 ルータ モジュールについて説明します。 また、WS-X4232-L3 のアーキテクチャと設定の説明に加え、このドキュメントでは Catalyst 4500/4000 シリーズ スイッチとルータ モジュールを使用する設定例も紹介します。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco Catalyst OS (CatOS)リリース 5.5(1) またはそれ以降

  • Cisco IOS(R) ソフトウェア リリース 12.0(7)W5(15d)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

WS-X4232-L3 の Cisco IOSソフトウェアイメージ ファイル名は "cat4232-" から始まります。 LANスイッチングソフトウェアのためのダウンロード ソフトウェア エリア登録ユーザのみ)の Catalyst 4232 セクションでファイルを見つけることができます。

Supervisor Engine 1 および Supervisor Engine 2 と共にそれを使用するときルータモジュールのためのサポートがあります。 ただし Supervisor Engine 2+ と共にそれを使用するとき、ルータモジュールのためのサポートが、3、4、か 5.ありません。

ルータモジュール(WS-X4232-L3)のサポートがあるソフトウェア機能に関する詳細については Catalyst 4000 レイヤ3 サービス モジュールに関するインストールおよび設定に関する注意書きFeatures セクションを参照して下さい。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

アーキテクチャ概要

WS-X4232-L3 モジュールは 32 のファーストイーサネットポートおよび 2 ギガビットイーサネットポートを備えています。

これら二つのギガビットイーサネットポートはインターフェイス ギガビット 1 およびルータコンフィギュレーションのギガビット 2 に対応します。 これらのギガビット イーサネット ポートは、ルーティングされるポートです。

内部的には、モジュールは 2 つのギガビット イーサネットインターフェイス(スイッチ バックプレーンにルータを接続するギガビット 3 および 4) ギガビットを備えています。 スイッチのバックプレーンからルータ モジュールへの接続には、スロット上の最初の 2 個のポートが使用されます。 スロット 3 で WS-X4232-L3 モジュールを挿入するとき、ギガビット イーサネットインターフェイス 3 および 4 はバックプレーン ポート 3/1 および 3/2 に接続されます。 ポート 3/1 および 3/2 はスイッチ Supervisor Engine の設定のレイヤ2 ポートです。 ギガビット イーサネットインターフェイス 3 および 4 はルータモジュールの設定のレイヤ3 ポートです。

ルータ モジュールには 32 個のファースト イーサネット ポートがあります。 これらのポートはレイヤ2 ポートで、レイヤ3 機能を行いません。 ポートにルータモジュールの物理的な位置があるが、スイッチ Supervisor Engine のポートを設定して下さい。

このダイアグラムはアーキテクチャの視覚説明を提供します。 このセットアップに関しては、Catalyst スイッチのスロット 2 にルータモジュールをインストールして下さい。

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-a.gif

WS-X4232-L3 の設定

スーパバイザ エンジン

show port コマンドは第 1 〜 34 を用いる 2 つのギガビットポートおよび 32 の 10/100 Mbps ポートを表示する。

Supervisor Engine から見る 2 つのギガビットポートはフロントパネルで見る 2 つのポートではないです。 Supervisor Engine から見るポートはルートにエンジンを接続する 2 つのスイッチドポートです。 スイッチポートで物理ポートを設定する必要があります。 この設定は Catalyst 6500/6000 シリーズ スイッチのマルチレイヤ スイッチ モジュール (MSM)の設定に類似したです。 より多くのこれらのポートのための一般的 な 設定は Gigabit EtherChannel (GEC)およびトランキングとしてそれらを設定 することです。 こうすれば、ルータのすべての VLAN の間でルーティングできます。

: セッション module# コマンドを発行する場合 Supervisor Engine からルータモジュールにアクセスできます。 このアクションは Catalyst 5500/5000 シリーズ スイッチのルートスイッチモジュール(RSM)のアクセスするために類似したです。

ルータ

ルータプロンプトが表示される場合、1 から 4 まで数が付いている 4 つのギガビット イーサネットインターフェイスを探して下さい(4) ギガビット 1、ギガビット 2、ギガビット 3、およびギガビットおよびファースト イーサネット アウトオブバンド インターフェイス。

これはデフォルト 設定です:

Router#show run 
Building configuration...  

Current configuration:  
!  
version 12.0  
service config  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname Router  
!  
!  
ip subnet-zero  
!  
!  
!  
interface FastEthernet1  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface gigabitEthernet1  
 no ip address  
 no ip directed-broadcast 

!--- Output suppressed.

この設定では、ギガビット 3 およびギガビット 4 は接続ですバックプレーンに行く。 ギガビット 1 およびギガビット 2 はフロントパネル(ルーテッドポート)のユーザポートです。 ほとんどの場合、MSM でように、同じの一部インターフェイスであるためにポート 3 およびポート 4 をポート チャネル設定します。 また、そのチャネルのサブインターフェイスを設定します(Inter-Switch Link Protocol [ISL]または IEEE 802.1Q カプセル化と)。 MSM でように、ギガビット 3 およびルータモジュールのギガビット 4 の設定はスイッチ側のポートのコンフィギュレーション slot/1 および slot/2 に一貫する必要があります。 show interface port-channelshow interface gigabitethernet コマンドを発行する場合ルータとスイッチ間のトラフィックをチェックできます。

WS-X4232-L3 のアクセス リスト サポート

WS-X4232-L3 ルータモジュールのアクセス コントロール リスト(ACL)のためのサポートがありますが、この資料が説明する設定 例は ACL をサポートしません。 WS-X4232-L3 モジュールのためのサポートの ACL コンフィギュレーションに関する詳細については Catalyst 4000 ファミリ用 WS-X4232-L3 ルータ モジュールの ACL の設定を参照して下さい。

設定例

設定 例はこのリストで要素が含まれています。 (ネットワークダイアグラムを参照して下さい。)

  • 強打—スロット 3.のルータモジュールが付いている Catalyst 4500/4000 シリーズ スイッチ。

  • Liki —ルータモジュールのギガビット イーサネット 1 に接続するルータ。

  • ドナルド—強打のポート 3/3 の VLAN 2 で接続するルータ。 ポート 3/3 はルータモジュールのレイヤ2 ポートの 1 つです。

  • Daniella —強打のポート 2/3 の VLAN 3 で接続するルータ。

この設定はルータモジュールと Catalyst 4500/4000 シリーズ スイッチ間の GEC 接続が含まれています。 複数 の VLAN が VLAN 間ルーティングのためのルータに通じるように GEC のトランキングを設定します。 この GEC 設定は標準の設定です。 このセットアップに特有なすべてのコマンドは、ポートチャネルのサブインターフェイスに移動されます。

ネイティブ VLAN のルータに達するレイヤ3 モジュールを使用するとき、すべてのトラフィックがソフトウェアでルーティングされることを覚えて下さい。 この状況は、スイッチのパフォーマンスに悪影響を及ぼします。 WS-X4232-L3 のマイクロコードは、タグなしでネイティブ VLAN に入る 802.1Q パケットを処理しません。 その代わりにこれらのパケットは CPU に入り、CPU によりパケットが処理されます。 その結果、CPU がネイティブ VLAN サブインターフェイスでタグなしのパケットを高頻度で受信する場合に、CPU 使用率が高くなります。 このため、ネイティブ VLAN としてダミー VLAN(ユーザ トラフィックを含まない)を作成します。 この設定例(ネットワークダイアグラム)では、VLAN 99 はネイティブ VLAN として動作します。 ルータとスイッチ間の GEC のネイティブ VLAN だけ設定して下さい。 このダミーの VLAN のスイッチの他のどのポートも設定しないで下さい。

ダミー VLAN を、ルータとスイッチの間のトランク リンクのネイティブ VLAN として作成します。 CPU は、ネイティブ VLAN 上で送信されるすべてのトラフィックを、ソフトウェアでルーティングしますが、これはスイッチのパフォーマンスに悪影響を与えます。 ネットワーク上で追加の VLAN を作成し、この VLAN をルータとスイッチの間のトランク リンクのネイティブ VLAN にします(この VLAN はそれ以外の目的では使用しません)。

ネットワーク図

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-4000-series-switches/6198-28-b.gif

これのスイッチ Supervisor Engine 設定およびルータモジュール設定セクションはいくつかの show コマンドの現在のコンフィギュレーションおよび出力を文書化します。 コンフィギュレーションは Catalyst 4500/4000 シリーズ スイッチおよびルータモジュールの Supervisor Engine にあります。 これはルータ 3 つのサブネット(VLAN 1、VLAN 2 およびギガビット イーサネットに 1)接続するの間でルーティングすることを割り当てます。

Supervisor Engine 設定を切り替えて下さい

ルータスイッチカードは show module コマンドで 34 のポートを示します。 この 34 のポートはフロントパネルおよび 2 つのギガビットスイッチポートにルータポートの 2 に直接接続する 32 のスイッチドポートが含まれています。 サンプルはここにあります:

bang> (enable) show module
Mod Slot Ports Module-Type                Model                Sub Status  
--- ---- ----- ------------------------- ------------------- ---  --------  
1   1    0     Switching  Supervisor      WS-X4012             no  ok  
2   2    34    10/100/1000  Ethernet      WS-X4232             no  ok  
3   3    34    Router Switch  Card        WS-X4232-L3          no  ok

Mod Module-Name         Serial-Num  
--- ------------------- --------------------  
1                        JAB02380AYG  
2                        JAB03210B6Y  
3                        JAB0417055S  

Mod MAC-Address(es)                         Hw     Fw          Sw  
--- -------------------------------------- ------ ---------- -----------------  
1   00-50-73-2a-f3-00 to 00-50-73-2a-f6-ff 1.0     4.5(1)     5.5(1)  
2   00-50-73-42-a9-68 to 00-50-73-42-a9-89 1.6  
3   00-01-42-06-73-a8 to 00-01-42-06-73-c9 1.0     12.0(7)W5( 12.0(7)W5(14.90

Catalyst 4000 側で追加される唯一の設定はルータモジュールに GEC トランクにこのサンプルが示すので、関連しています:

bang> (enable) show config

# ***** NON-DEFAULT CONFIGURATION *****  
!  
! 
!  
!  
!  
set port channel all distribution mac both  
!  
#ip  
set interface sl0 down  
set interface me1 down  
!  
#set boot command  
set boot config-register 0x102  
set boot system flash bootflash:cat4000.5-5-1.bin  
!  
#port channel  
set port channel 3/1-2 156  
!  
#module 1 : 0-port Switching Supervisor  
!  
#module 2 : 34-port 10/100/1000 Ethernet  

set VLAN 3    2/3

!  
#module 3 : 34-port Router Switch Card  
set VLAN 2    3/3
set VLAN 99   3/1-2

!--- This interface has a configuration for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the 
!--- router switch must match the one that you have configured on the router.
!--- VLAN 99 is a dummy native VLAN. For more information, 
!--- see the note in the Sample Configurations section.


set trunk 3/1  nonegotiate dot1q 1-1005


!--- Note: Trunk mode needs to be in no-negotiate status
!--- because the router module does not support Dynamic Trunking Protocol (DTP).


set trunk 3/2  nonegotiate dot1q 1-1005
set port channel 3/1-2 mode on


!--- Note: You need to force the channel mode to on because
!--- the router module does not support Port Aggregation Protocol (PAgP).
  
end

スイッチで、show cdp neighbor コマンドはモジュールがギガビットポート 3/1 および 3/2 の GEC トランクによって接続する外部ルータだったようにルータモジュールを表示する。 サンプルはここにあります:

bang> (enable) show cdp neighbor
* - indicates vlan mismatch.  
# - indicates duplex mismatch.  
Port     Device-ID                        Port-ID                    Platform  
-------- ------------------------------- -------------------------  ------------  
 2/3     daniella                         Ethernet0                  cisco 2500  
                                         
                                         
                                          
 3/3     donald                           Ethernet0                  cisco 2500

bang> (enable) show trunk 
* - indicates vtp domain mismatch  
Port      Mode          Encapsulation  Status        Native  vlan  
--------  -----------  -------------  ------------   -----------  
 3/1      nonegotiate  dot1q           trunking      99  
 3/2      nonegotiate  dot1q           trunking      99

Port      Vlans allowed on trunk  
--------  ---------------------------------------------------------------------  
 3/1      1-1005  
 3/2      1-1005

Port      Vlans allowed and active in management  domain  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Port      Vlans in spanning tree forwarding  state and not pruned  
--------  ---------------------------------------------------------------------  
 3/1      1-3, 99
 3/2      1-3, 99

Ciscoデバイスからの show trunk コマンドの出力がある場合、潜在的な問題および修正を 表示するのに Output Interpreter ツール登録ユーザのみ)を使用できます。

bang> (enable) show port channel
Port  Status     Channel               Admin Ch  
                  Mode                  Group Id  
----- ---------- -------------------- ----- -----  
 3/1  connected  on                      156   833  
 3/2  connected  on                      156   833  
----- ---------- -------------------- ----- -----

Port  Device-ID                        Port-ID                    Platform  
----- ------------------------------- -------------------------  ----------------  
 3/1  bang-rp                          GigabitEthernet3           cisco Cat4232  
 3/2   Not directly connected to switch  
----- ------------------------------- -------------------------  ----------------

Ciscoデバイスからの show port channel コマンドの出力がある場合、潜在的な問題および修正を 表示するのに Output Interpreter ツール登録ユーザのみ)を使用できます。

ルータ モジュールの設定

bang-rp#show verify
Cisco Internetwork Operating System Software  
IOS (tm) L3 Switch/Router Software (CAT4232-IN-M), Version 12.0(7)W5(14.90)   INTERIM 
TEST SOFTWARE  
Copyright (c) 1986-2000 by cisco Systems, Inc.  
Compiled Fri 26-May-00 15:26 by integ  
Image text-base: 0x60010928, data-base: 0x605C8000  

ROM: System Bootstrap, Version 12.0(7)W5(15b) RELEASE SOFTWARE  

bang-rp uptime is 1 day, 22 hours, 7 minutes  
System restarted by power-on  
System image file is "bootflash:cat4232-in-mz.120-7.W5.14.90"  

cisco Cat4232 (R5000) processor with 57344K/8192K bytes of memory.  
R5000 processor, Implementation 35, Revision 2.1  
Last reset from power-on  
1 FastEthernet/IEEE 802.3 interface(s)  
4 Gigabit Ethernet/IEEE 802.3z interface(s)  
123K bytes of non-volatile configuration memory. 

16384K bytes of Flash internal SIMM (Sector size 256K).  
Configuration register is 0x1

bang-rp#show run
Building configuration...
Current Configuration:
!  
version 12.0  
no service pad  
service timestamps debug uptime  
service timestamps log uptime  
no service password-encryption  
!  
hostname bang-rp  
!  
!  
ip subnet-zero  
!  
!  
!  
interface Port-channel1                    
 no ip redirects  
 no ip directed-broadcast  
 hold-queue 300 in  
!  
interface Port-channel1.2 


!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 2 tag.


encapsulation dot1Q 2
ip address 2.2.2.2 255.255.255.0
no ip redirects
no ip directed-broadcast    
!  
interface Port-channel1.3

!--- The configuration of this interface is for 802.1Q routing.
!--- The interface uses a VLAN 3 tag.

encapsulation dot1Q 3  
ip address 1.1.1.2 255.255.255.0  
no ip redirects  
no ip directed-broadcast  
!
interface Port-channel1.99

!--- The configuration of this interface is for 802.1Q routing. 
!--- The interface uses VLAN 99 as the native VLAN. The native VLAN on the router 
!--- must match the one that you have configured on the switch. VLAN 99 is a dummy
!--- native VLAN. For more information, see the note
!--- in the Sample Configurations section.


encapsulation dot1Q 99 native
no ip address
no ip redirects
no ip directed-broadcast
!
interface FastEthernet1                  

!--- You can use this out-of-band interface for management.
  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet1  
 ip address 3.3.3.2 255.255.255.0  
 no ip directed-broadcast  
!  
interface GigabitEthernet2  
 no ip address  
 no ip directed-broadcast  
 shutdown  
!  
interface GigabitEthernet3  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                         

!--- Both  Gigabit Ethernet 3 and Gigabit Ethernet 4 
!--- are part of channel group 1.
  
!  
interface GigabitEthernet4  
 no ip address  
 no ip directed-broadcast  
 no negotiation auto  
 channel-group 1                          

!--- Both Gigabit Ethernet 3 and Gigabit Ethernet 4  
!--- are part of channel group 1.
  
!  
router eigrp 1  
 passive-interface FastEthernet1  
 network 1.0.0.0  
 network 2.0.0.0  
 network 3.0.0.0  
!  
ip classless  
!  
arp 127.0.0.2 0050.732a.f300 ARPA  
!  
line con 0  
 transport input none  
line aux 0  
line vty 0 4  
 login  
!  
end  
bang-rp#show cdp neighbor  
Capability Codes: R - Router, T - Trans Bridge, B - Source Route  Bridge  
                   S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce      Holdtme    Capability Platform  Port ID  
liki              Gig 1               
160         T S      
WS-C3508G-Gig 0/1                           

!--- Liki connects to gigabit 1 on the router. 
!--- You can only see Liki from the router; you cannot 
!--- see Liki from the Supervisor Engine.
  
JAB02380AYG(bang)Port-channel1      148          T S       WS-C4003  3/2  
JAB02380AYG(bang)Port-channel1      147          T S       WS-C4003  3/1

トラブルシューティング

スーパバイザからの 4232-L3 モジュールへのセッションはしばらくのために動作した後はたらきません

スイッチがしばらくのために動作した後、スーパバイザからの 4232-L3 モジュールへのセッションはこのエラーメッセージと失敗します:

4006> (enable) session 2
Trying IntlgLineCard-2...
session: Unable to tunnel to IntlgLineCard-2 (57)

これのためのほとんどの推定 原因は 4232-L3 モジュール インバンド MAC アドレスのための監視プログラムモジュール アドレス解決プロトコル (ARP) 表で形成される不正確な隣接関係が原因です。

この問題は Cisco バグ ID CSCdx30617登録ユーザのみ)から影響を受けない CatOS バージョンへのシステム ソフトウェアのアップグレードと解決することができます。

システム ソフトウェアのアップグレードが可能性のあるではない場合、これらの回避策を試みることができます:

  • モジュールへ sessioning かわりに、それで設定される IP アドレスの何れかへの telnet。

  • 4232-L3 モジュールのリセットは問題を一時的に回復できます。

  • 別の VLAN への sc0 インターフェイスの移動はまたこの問題を解決できます。

4232-L3 からの TFTP 定期的な要求

4232-L3 モジュールは絶えずネットワークから設定をロードすることを試み、このエラーメッセージを表示する:

%Error opening tftp://255.255.255.255/network-config (Timed out)

L3 モジュールは service config コマンドを発行するとき自動的に TFTPサーバからコンフィギュレーション ファイルをダウンロードするために設定することができます。 起動している間コンフィギュレーション ファイルを TFTPサーバで保存し、ダウンロードして下さい。 これはコンフィギュレーション ファイルのサイズがデバイスの NVRAM のサイズより大きいとき役立ちます。

L3 モジュールは service config コマンドで設定されるとき、TFTPサーバから設定をダウンロードする TFTP 要求を生成します。

IPS/IDS が使用されるシナリオでは、ルータが絶えず tftp ブロードキャストを送信 することを観察するかもしれません。 これはソースの IP アドレスによって確認され、宛先は 255.255.255.255、トラフィックです UDP 69 (TFTP)です。

ログメッセージを生成から停止するために、これらのコマンドを発行して下さい:

Router#config terminal
Router(config)#no service config
Router(config)#exit
Router#copy running-config startup-config

まとめとヒント

Catalyst 4500/4000 のルーティングモジュールを設定するときこれらのキーポイントを覚えていて下さい:

  • フロントパネルで参照するギガビットインターフェイスは参照するギガビットインターフェイスと Supervisor Engine からの show port コマンドを発行するとき同じではないです。 フロントパネルのインターフェイスは名前ギガビット 1 およびルータのギガビット 2 のインターフェイスです。

  • スイッチとルータ間のトランクのネイティブ VLAN がダミーの VLAN であることを確かめて下さい。 ネイティブ VLAN にある CPU はソフトウェアですべてのトラフィックをルーティングします。 従って、他の所で使用しないし、スイッチとルータ間のリンクでその VLAN にネイティブ VLAN を作る 1 つの追加 VLAN を作成して下さい。


関連情報


Document ID: 6198