音声 : H.323

Polycom ビデオ ユニットのための Video over IP の設定方法

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書は、Video over IP アプリケーションを使用するために、Cisco ルータを使用して Polycom ViewStation128(ビデオ会議ユニット)の基本的なネットワークのセットアップと設定を行う方法について説明しています。 また、QoS の追加と、LAN および WAN メディアを経由したリアルタイムでのビデオ品質に関するトラブルシューティングについても説明しています。

Polycom ViewStation はキャプチャされるビデオおよびオーディオのディスプレイのための TV にインターフェイスします; それはまた IP を圧縮されたビデオ パケットを渡す LAN に接続できます。 Polycom 製品は他のゲートウェイとまったく同様の H323 エンドポイントです。 Video over IP は次のプロトコルを使用します。

  • H.225(コール制御信号方式のメッセージング)

  • H.245(メディア ストリーム チャネルのオープンおよびクローズ)

  • H.263 および H.261(ピクチャー形式によるビデオ コーデック)

  • G.723(オーディオ コーデック、5.3 kpbs または 6.3 kpbs モード)

Polycom ViewStation128 用のソフトウェアは最新のものが必要です。これは LAN 経由で Polycom の Web サイトからダウンロードできます。 この資料のパブリケーションの時に利用可能 な最新版ファームウェアは 7.0.1 でした。 http://www.polycom.com/home/ leavingcisco.com

ViewStation は、圧縮されたビデオおよびオーディオのコールを、128 k、256 k、384 k、512 k、576 k、または 768 k の速度で送信できます。 この圧縮速度には、追加される IP ヘッダーおよび LAN/WAN ヘッダーは含まれていません。このため、QoS で帯域幅を予約するときはそのオーバーヘッド分を考慮してください。 たとえば、オーディオ(64 kbps)+ビデオ(704 kbps)+ IP(25 % のオーバーヘッド)= 960 kbps となります。

ビデオアプリケ− ションのための最適遅延は音声に類似したです: 最適結果のための 125-150msec ラウンドトリップ時間。 追加の待ち時間は許容されますが、Polycom への Telnet 時に Polycom でエラーとして報告されます。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

セットアップは下記の Cisco IOS が付いているラボでテストされましたか。 Cisco 7200 ルータのソフトウェア リリース 12.1(5)T および 12.2(1a)。 Polycom ViewStation 128 にはファームウェア リリース 7.0.1 を搭載しました。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。 各 Polycom は半二重および 10 Mbps でハードコーディングされています。 この例の 2900XL では、すべてのポートで auto/auto がハードコーディングされています。そのため、Cisco 7200 FE(ファースト イーサネット インターフェイス)では変更は不要で、100/Full に設定されます。 Polycom をルータまたは Catalyst スイッチに直接接続する場合は、それに応じてデュプレックス/速度が一致するようにポートを設定する必要があります。

/image/gif/paws/6172/polycom_video_over_ip1.gif

Polycom ViewStation の設定とセットアップ

ViewStation のための H.323 コールの設定

System Info、Admin Setup の下で、次の設定を行います。

  1. LAN/H.323、および LAN/Intranet の下で、Polycom の IP アドレスとデフォルト ゲートウェイを設定します。

  2. LAN/H.323、および H323 の下で、この ViewStation の H323 名を設定します。必要であれば E164 ID も設定します。

  3. (オプション)LAN/H.323、および H323 の下で、特定の UDP ポートまたは TCP ポートに対して QoS を指定できます。 ビデオ トラフィックの場合、固定 TCP ポートの範囲は 3230~3231、固定 UDP ポートの範囲は 3230~3235 です。 ここでは、パケットに対して IP 優先順位をクリティカルに設定することもできます。

  4. General Setup の下で、システム名、自動応答、自動ダイヤル、言語などの標準オプションを設定します。

ViewStation からの H.323 コールの発信

ここのすべての呼び出しはリモートIPアドレスを使用してなされます; ゲートキーパーを使用してビデオ コールを発信している場合は、E.164 番号も使用できます。 メインスクリーンの下で、リモート Polycom のための IP アドレスを打ち込み、そして圧縮速度を選択して下さい; この圧縮速度は、リモート側でデフォルトとして設定した速度に合わせる必要があります。

ビデオ用の QoS を使用したルータの設定

WAN 経由の VideoOverIP で最も効果的な QoS 方式の 1 つとして、Low Latency Queuing(LLQ; 低遅延キューイング)が挙げられます。 後で説明するように、ポリシー マップはいくつかの異なるパラメータをベースとすることができます。 LLQ を使用することで、必要な帯域幅を専用のものとし、他の Video over IP アプリケーションに優先順位を付けることができます。 また、ビデオ品質を向上させるため、ATM リンクは VBR-NRT または CBR にしてください。

7206 VXR の設定

Cisco 7206VXR
!
class-map match-all video
  match access-group 101

!--- Class map used to associate access-list 101 to the LLQ class video.

!
policy-map video-police

!--- Definition of the policy map for the LLQ Configuration
 
  class video
    priority 900

!--- This is the priority class/queue assigned for video traffic.
!--- It reserves 900 Kbps for video traffic
  
  class class-default
   fair-queue 64

!-- All other non-video traffic uses fair-queuing policing.
 
!
interface FastEthernet0/0
 description Polycom-192.168.3.90
 ip address 192.168.3.100 255.255.255.0
 duplex half
 no cdp enable

!--- This is the LAN interface that connects to the Polycom ViewStation
!--- No QoS (LLQ) was applied here.
 

!
interface ATM6/0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
 ip address 10.1.105.1 255.255.255.0
 pvc 1/138

!--- atm pvc defined 

  class-vc VBR-NRT
  encapsulation aal5snap

!--- Layer 2 encapsulation type for atm packets

  service-policy out video-police

!--- Applies LLQ (defined above) to the subinterface for 
!--- layer 3 (Video over IP)traffic shaping and priotization

!
vc-class atm VBR-NRT

!--- atm traffic shaping class defined

  vbr-nrt 1500 1400 100

!--- Maximum bandwidth at 1500Kbps and nominal at 1400Kbps with 100Kbps burst

!
access-list 101 permit tcp any any range 3230 3231
access-list 101 permit udp any any range 3230 3235

!--- These access-lists are used by the LLQ class-map.
!--- These access-lists are based on the fixed UDP (3230-3235) 
!--- and TCP (3230-3231) ports for the ViewStation VideoOverIP


また、次のアクセスリスト設定は使用されたかもしれません。

  • ViewStation ユニットの送信元/宛先IPアドレスに基づく:

    access-list 101 permit ip ホスト 192.168.3.90 ホスト 192.168.1.90

    access-list 101 permit ip ホスト 192.168.1.90 ホスト 192.168.3.90

  • IP 優先順位 5 に基づく:

    access-list 101 permit ip any any 優位 5

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

コールが確立されると、Polycom はすべてのビデオ パケットを追跡します。 この詳細は、Polycom に Telnet することで監視できます。 Polycom は、H323 パケットに関する待ち時間と、失われたビデオ パケットまたはオーディオ パケットを報告します。 Polycom デバッグはビデオ画面でそれらに注意することは困難かもしれないとき読解可能で、問題を示唆します。

フリーズなど、ビデオで最もよく見られる問題のいくつかは、イーサネットのデュプレックスまたは速度のミスマッチに原因があります。 イーサネット カウンタが大きな値の CRC/フレーム/遅延パケットを示す場合は、ビデオ品質がかなり低下します。そこで、最初のチェックポイントとして、すべての LAN インターフェイスがエラーなしで動作していることを確認します。

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

Polycom の設定は初期情報画面でチェックできます。 すべてのアクションに対してオンに設定されている情報デバッグがあります。 ビデオ コールを行うと、Polycom はパケットごとの計算された待ち時間を自動的に報告します: 失われたすべてのパケットと、失われたパケットの結果再シーケンスされたパケットを報告します。

MS-7206VXR-12A#telnet 192.168.3.90

!--- Action: Telnetting to the Polycom ViewStation unit to capture information 
!--- and debug output. 
!--- When a call is established, the Polycom unit keeps track of video packets. 
!--- The Polycom reports h323 packet latency and lost video and voice packets.


Trying 10.122.3.90 ... Open

Hi, my name is :     Polycom166-regnl
Here is what I know about myself:
Serial Number:       011B12
Brand:               Polycom
Software Version:    Release 7.0.1 - 16 Jun 2001
Model:               VS
Network Interface:   ISDN_UNKNOWN
MP Enabled:          No
H323 Enabled:        Yes
IP Address:          192.168.3.90
Time In Last Call:   0:08:41
Total Time In Calls: 44:20:06
Total Calls:         171
Switch Type:         Nortel DMS-100
Country Code:        1
Area Code:           919
ISDN 1 a is:         9913293
ISDN 2 a is:         9913294

QoS が適用した前に、ビデオおよびデータが同時に動作したときに、Polycom への telnet 結果は次を報告します; これは明らかにネットワークの問題を示しており、ビデオ品質にも影響します。

RTP: Video Packet Lost
RTP: Reseting last_seq_num from 23397 to 23398
RTP: Send FastVideoPicture_MSG
RTP: last eBit 6 plus new sBit 0 not equal 8! (instance 0)
...VideoFastUpdatePictureHandler() time 469850
RTP: Max. video packets stored = 4
RTP: Minimum/MaximumThreshold = 4 0/256, 4 0/256
UI:UI msg from VidDec: S VD1 ReceivedFreezeRelease 0
Received a Picture Fast Update request from the other side
Audio Packet(s) lost - last_seq_num = 15147, new_seq_num = 15149
Transfer 1 duplicate packets
Received a Picture Fast Update request from the other side
RTP: Max. video packets stored = 1
RTP: Minimum/MaximumThreshold = 4 0/256, 4 255/256

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

次の出力は Cisco IOS ルータで取得されたもので、LLQ が ATM インターフェイスに適用された後、ビデオ コール中に大量の ping が送られたために輻輳が発生しました。 帯域幅のためのコンテンションがあるとき、LLQ は動的にビデオトラフィックに優先順位をつけます。

MS-7206VXR-12A#show queue atm 6/0.1

  Interface ATM6/0.1 VC 1/138 
  Queuing strategy: weighted fair
  Total output drops per VC: 22863
  Output queue: 66/512/64/22863 (size/max total/threshold/drops)
     Conversations  3/4/64 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 0 kilobits/sec

  (depth/weight/total drops/no-buffer drops/interleaves) 1/4626/0/0/0
  Conversation 1, linktype: ip, length: 54
  source: 10.122.3.100, destination: 10.1.105.2, id: 0x002B, ttl: 255,
  TOS: 192 prot: 6, source port 23, destination port 11032

  (depth/weight/total drops/no-buffer drops/interleaves) 1/5397/0/0/0
  Conversation 51, linktype: ip, length: 308
  source: 10.122.3.90, destination: 10.122.1.90, id: 0x51AB, ttl: 59,
  TOS: 160 prot: 17, source port 49206, destination port 3232

次の出力から、ビデオ クラスでは廃棄されたパケットは 1 つもないことがわかります。

MS-7206VXR-12A#show policy-map int atm 6/0.1
 ATM6/0.1: VC 1/138 -

  Service-policy output: video-police

    Class-map: video (match-all)
      0 packets, 0 bytes
      30 second offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      Weighted Fair Queueing
        Strict Priority
        Output Queue: Conversation 72 
       Bandwidth 900 (kbps) Burst 22500 (Bytes)
        (pkts matched/bytes matched) 0/0
        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)
      290307 packets, 252480609 bytes
      30 second offered rate 2951000 bps, drop rate 2341000 bps
      Match: any 
      Weighted Fair Queuing
        Flow Based Fair Queuing
        Maximum Number of Hashed Queues 64 
        (total queued/total drops/no-buffer drops) 67/35584/0

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 6172