ダイヤルとアクセス : 非同期接続

Cisco 3640 ルータとV.110 モードでのリモートユーザ間のコールバック

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 12 月 1 日) | 英語版 (2015 年 11 月 9 日) | フィードバック


目次


概要

この文書では、リモート ユーザが次の方法のいずれかを使用してコールを行うための設定例を示します。 いずれの場合も、コールバックは V.110 コールを使用して行います。

  • ユーザが GSM 経由で 3640 に接続し、コールバックを要求する。

  • ユーザがモデム経由で 3640 に接続し、コールバックを要求する。

  • ユーザが ISDN(データ)経由で 3640 に接続し、コールバックを要求する。

認証、許可、およびアカウンティング(AAA)は、デフォルトではルータで設定されます。 ログインするユーザも作成する必要があります。

この例では、コールインおよびコールアウト用に PPP 認証も設定しています。 ここでは常にスクリプトを変更して V.110 用にモデムを設定し、ユーザが方式(モデムまたは GSM)を選択できるようにしています。 選択した方式に応じてユーザか行う必要がある処理は次のとおりです。

  • コールバック番号に ZDTxxx を使用する(モデムの場合)。

  • コールバック番号に DIxxxx を使用する(GSM の場合)。

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • V.110 コールバック機能はローザ IOS で利用できますか。か。 ソフトウェアリリース 12.2(5.2)T およびそれ以上。

  • モデム ソフトウェア バージョン 2.7.3.0。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次の図で示されるネットワーク構成を使用しています。

/image/gif/paws/6153/callback_6153.gif

設定

このドキュメントでは次の設定を使用しています。

  • スザンヌ

スザンヌ
suzanne#show running-config
! 
version 12.2 
service internal
!
hostname suzanne
!
aaa new-model
!
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default local 
aaa session-id common 
!
username ww password 0 
username alainisdn password 0 
username alaingsm callback-dialstring "" password 0
username alainmod callback-dialstring "" password 0 
!
modem country mica belgium 
! 
isdn switch-type primary-net5
isdn voice-call-failure 0
chat-script offhook "" "ATH1" OK
chat-script callback ABORT ERROR ABORT BUSY "" "AT&F" 
OK "ATX3DT \T" TIMEOUT 90 \c
chat-script callback1analog ABORT ERROR ABORT BUSY "" "AT&F" 
OK "ATDT \T" TIMEOUT 90 CONNECT \c
chat-script callback2gsm ABORT ERROR ABORT BUSY "" "AT&F" 
OK "ATS29=8" OK "AT \T" TIMEOUT 90 CONNECT \c
!
controller E1 1/0
pri-group timeslots 1-31
!
interface Ethernet0/0
ip address 172.17.243.105 255.255.255.0
!
interface Serial1/0:15
description E1 0451/39920
no ip address
encapsulation ppp
dialer rotary-group 1
isdn switch-type primary-net5
isdn incoming-voice modem
isdn outgoing-voice info-transfer-capability 3.1kHz-audio
no cdp enable
ppp authentication chap callin 
!
interface BRI3/1
description belgacom 027202094
no ip address
encapsulation ppp
isdn switch-type basic-net3
isdn incoming-voice modem
no cdp enable
! 
interface Group-Async1
ip unnumbered Dialer1
encapsulation ppp
dialer in-band
dialer callback-secure
dialer-group 1
async dynamic routing
async mode interactive
peer default ip address pool pool
ppp callback accept
ppp authentication pap
group-range 65 94
!
interface Dialer1
description Dial-In User
ip address 172.31.1.1 255.255.0.0
ip helper-address 90.100.48.38
ip helper-address 90.100.60.202
encapsulation ppp
dialer in-band
dialer callback-secure
dialer map ip 172.31.1.2 name alainisdn class callback 6136
peer default ip address pool pool
no cdp enable
ppp callback accept
ppp authentication chap callin 
!
map-class dialer callback
dialer callback-server username
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 0 0
password
line 65 94
script dialer callback2gsm
script callback callback2gsm
modem InOut
transport input telnet
transport output pad v120 lapb-ta telnet rlogin udptn
autoselect during-login
autoselect ppp
stopbits 1
flowcontrol hardware
line aux 0
password
line vty 0 4
exec-timeout 0 0
password 
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip route か。か。か。IPルーティングテーブルのコンテンツを表示する

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

: debug コマンドを発行する前に、Debug コマンドの重要な情報を参照して下さい。

  • debug modem — アクセス サーバのモデム回線 の アクティビティを観察するため。

  • debug dialer events — ダイヤラーインターフェイスで受信されるパケットについてのデバッグ情報を表示する。

  • debug ppp authentication — Challenge Authentication Protocol (CHAP)パケット交換および Password Authentication Protocol (PAP)交換を含む認証プロトコルメッセージを、表示する。

  • debug ppp cbcp — Microsoft Callback Control Protocol (MSCB)を使用して PPP 接続ネゴシエーションと関連付けられるプロトコルエラーおよび統計情報を表示する。

  • debug isdn q931 — ISDNネットワーク接続(ローカルルータ(ユーザサイド)とネットワークのコール セットアップ および 中断についての情報を間の 3) 層 表示する。

  • チャット スクリプトが適切に機能していることを debug chat —確認します。

  • debug callback —ルータがモデムおよびチャット スクリプトをターミナルラインで呼出すのに使用しているときコールバックイベントを表示する。

デバッグの出力例

V.110 を使用したGSM コールバック

suzanne#
01:03:00: ISDN BR3/1: RX <- SETUP pd = 8 callref = 0x2F
01:03:00: Sending Complete
01:03:00: Bearer Capability i = 0x9090A3
01:03:00: Channel ID i = 0x89
01:03:00: Calling Party Number i = 0x21, 0x83, '478681006', Plan:ISDN, 
Type:National
01:03:00: Called Party Number i = 0xA1, '27202094', Plan:ISDN, Type:National
01:03:00: ISDN BR3/1: Event: Received a VOICE call from 478681006 on B1 at 64 Kb/s
01:03:00: ISDN BR3/1: Event: Accepting the call id 0x19
01:03:00: %ISDN-6-LAYER2UP: Layer 2 for Interface BR3/1, TEI 70 changed to up
01:03:00: ISDN BR3/1: TX -> CALL_PROC pd = 8 callref = 0xAF
01:03:00: Channel ID i = 0x89
01:03:00: ISDN BR3/1: TX -> ALERTING pd = 8 callref = 0xAF
01:03:00: ISDN BR3/1: TX -> CONNECT pd = 8 callref = 0xAF
01:03:01: ISDN BR3/1: RX <- CONNECT_ACK pd = 8 callref = 0x2F
01:03:01: Modem 2/12 Mica: configured for Answer mode, 
with Null signaling,0x0 tone detection.
01:03:01: Modem 2/12 Mica: in modem state CALL_SETUP
01:03:02: Modem 2/12 Mica: in modem state CONNECT
01:03:06: Modem 2/12 Mica: in modem state LINK
01:03:07: %ISDN-6-CONNECT: Interface BRI3/1:1 is now connected to 478681006    
01:03:15: Modem 2/12 Mica: in modem state TRAINUP
01:03:17: Modem 2/12 Mica: in modem state EC_NEGOTIATING
01:03:18: Modem 2/12 Mica: in modem state STEADY
01:03:18: Modem 2/12 Mica: CONNECT at 31200/31200 (Tx/Rx), V34+, LAPM, None
01:03:19: TTY77: DSR came up
01:03:19: tty77: Modem: IDLE->(unknown)
01:03:19: TTY77: EXEC creation
01:03:19: TTY77: set timer type 10, 30 seconds
01:03:19: TTY77: Autoselect(2) sample 7E
01:03:19: TTY77: Autoselect(2) sample 7EFF
01:03:19: TTY77: Autoselect(2) sample 7EFF7D
01:03:19: TTY77: Autoselect(2) sample 7EFF7D23
01:03:19: TTY77 Autoselect cmd: ppp negotiate
01:03:19: TTY77: EXEC creation
01:03:19: TTY77: create timer type 1, 600 seconds
01:03:19: TTY77: destroy timer type 1
01:03:19: TTY77: no timer type 0 to destroy
01:03:19: As77 DDR: Dialer received incoming call from <unknown>
01:03:21: %LINK-3-UPDOWN: Interface Async77, changed state to up
01:03:21: As77 DDR: Dialer statechange to up
01:03:21: As77 DDR: Dialer received incoming call from <unknown>
01:03:21: As77 PPP: Treating connection as a callin
01:03:21: As77 PPP: Authorization required
01:03:22: Modem 2/12 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:03:22: As77 PPP: Authorization required
01:03:27: Modem 2/12 Mica: PPP escape_map: Tx map = A0000, Rx map = 0
01:03:27: As77 MCB: Initialize
01:03:27: MCB: Flush
01:03:27: Modem 2/12 Mica: Bad RX Frame: control = 0xE007, length = 0xD, 
buffer = 0x3BC6E54
01:03:30: As77 PAP: I AUTH-REQ id 2 len 16 from "alaingsm"
01:03:30: As77 PAP: Authenticating peer alaingsm
01:03:30: As77 PPP: Sent PAP LOGIN Request to AAA
01:03:30: As77 PPP: Received LOGIN Response from AAA = PASS
01:03:30: As77 DDR: Remote name for alaingsm
01:03:30: As77 DDR: Authenticated host alaingsm with no matching dialer map
01:03:30: As77 PAP: O AUTH-ACK id 2 len 5
01:03:30: As77 MCB: Start
01:03:30: As77 MCB: User alaingsm Callback Number - Client ANY
01:03:30: As77 MCB: Newstate 0-INIT -> 2-WAIT_RESPONSE
01:03:30: As77 MCB: O Request Id 1 Callback Type Client-Num delay 0
01:03:32: As77 MCB: Timeout in state WAIT_RESPONSE sending new Request 2
01:03:32: As77 MCB: O Request Id 2 Callback Type Client-Num delay 0
01:03:34: As77 MCB: Timeout in state WAIT_RESPONSE sending new Request 3
01:03:34: As77 MCB: O Request Id 3 Callback Type Client-Num delay 0
01:03:35: Async77 PPP: I MCB Response(2) id 1 len 22
01:03:35: Async77 MCB: 
I 2 1 0 16 2 12 F 1 44 49 30 30 34 37 38 36 38 31 30 30 36 0 
01:03:35: As77 MCB: Received response
01:03:35: As77 MCB: Resp ignored. ID Expected 3, got id 1
01:03:36: As77 MCB: Timeout in state WAIT_RESPONSE sending new Request 4
01:03:36: As77 MCB: O Request Id 4 Callback Type Client-Num delay 0
01:03:36: Async77 PPP: I MCB Response(2) id 4 len 22
01:03:36: Async77 MCB: 
I 2 4 0 16 2 12 F 1 44 49 30 30 34 37 38 36 38 31 30 30 36 0 
01:03:36: As77 MCB: Received response   


!--- You can see here that "DI00478681006" was entered at the user PC.
  
01:03:36: As77 MCB: Response CBK-Client-Num 2 18 15, addr 1-DI00478681006
01:03:36: As77 MCB: O Ack Id 5 Callback Type Client-Num delay 15
01:03:36: As77 MCB: Negotiated MCB with peer
01:03:36: As77 MCB: Newstate 2-WAIT_RESPONSE -> 3-WAIT_TERMINATE
01:03:37: As77 MCB: Peer terminating the link
01:03:37: As77 MCB: Newstate 3-WAIT_TERMINATE -> 5-WAIT_LINKDOWN
01:03:37: As77 MCB: Link terminated by peer, Callback Needed
01:03:37: As77 MCB: Newstate 5-WAIT_LINKDOWN -> 6-CALLING
01:03:37: As77 MCB: Initiate Callback for ^->o`iB@ at DI00478681006 
using Async DDR
01:03:37: As77 DDR: PPP callback Callback server starting to alaingsm 
DI00478681006
01:03:37: As77 MCB: Dialer callback started

  
!--- Call is disconnected.


01:03:38: Modem 2/12 Mica: in modem state SS_RETRAINING
01:03:38: ISDN BR3/1: RX <- DISCONNECT pd = 8 callref = 0x2F
01:03:38: Cause i = 0x8090 - Normal call clearing
01:03:38: Progress Ind i = 0x8088 - In-band info or appropriate now available    
01:03:38: %ISDN-6-DISCONNECT: Interface BRI3/1:1 disconnected from 478681006, 
call lasted 37 seconds
01:03:38: ISDN BR3/1: TX -> RELEASE pd = 8 callref = 0xAF
01:03:38: Cause i = 0x8090 - Normal call clearing
01:03:38: Modem 2/12 Mica: in modem state TERMINATING
01:03:38: ISDN BR3/1: RX <- RELEASE_COMP pd = 8 callref = 0x2F
01:03:39: TTY77: Async Int reset: Dropping DTR
01:03:39: Modem 2/12 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:03:39: As77 PPP: Authorization required
01:03:40: Modem 2/12 Mica: in modem state IDLE
01:03:40: Modem 2/12 Mica: DISCONNECT after 00:00:38, due to reason (0xDF00) 
Host Disconnect.
01:03:40: TTY77: DSR was dropped
01:03:40: tty77: Modem: READY->(unknown)
01:03:41: TTY77: dropping DTR, hanging up
01:03:41: tty77: Modem: HANGUP->(unknown)
01:03:41: %LINK-5-CHANGED: Interface Async77, changed state to reset
01:03:42: TTY77: cleanup pending. Delaying DTR
01:03:43: TTY77: cleanup pending. Delaying DTR
01:03:44: TTY77: cleanup pending. Delaying DTR
01:03:44: TTY77: no timer type 0 to destroy
01:03:44: TTY77: no timer type 1 to destroy
01:03:44: TTY77: no timer type 3 to destroy
01:03:44: TTY77: no timer type 4 to destroy
01:03:44: TTY77: no timer type 2 to destroy
01:03:44: Async77: allowing modem_process to continue hangup
01:03:45: TTY77: restoring DTR
01:03:46: %LINK-3-UPDOWN: Interface Async77, changed state to down
01:03:53: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR3/1, TEI 70 
changed to down

!--- Callback is started.

01:03:56: As77 DDR: re-enable timeout
01:03:56: DDR: callback triggered by dialer_timers
01:03:56: As77 DDR: beginning callback to alaingsm DI00478681006
01:03:56: As77 DDR: Attempting to dial DI00478681006
01:03:56: CHAT77: Attempting async line dialer script
01:03:56: CHAT77: Dialing using Modem script: callback2gsm & System script: 
none
01:03:56: CHAT77: process started
01:03:56: CHAT77: Asserting DTR
01:03:56: CHAT77: Chat script callback2gsm started
01:03:56: CHAT77: Sending string: AT&F
01:03:56: CHAT77: Expecting string: OK
01:03:56: CHAT77: Completed match for expect: OK
01:03:56: CHAT77: Sending string: ATS29=8
01:03:56: CHAT77: Expecting string: OK 
01:03:56: CHAT77: Completed match for expect: OK

!--- We send DI00478681006

01:03:56: CHAT77: Sending string: AT \T<DI00478681006>
01:03:56: CHAT77: Expecting string: CONNECT
01:03:56: Modem 2/12 Mica: configured for Originate mode, with Null signaling, 
0x1 tone detection.
01:03:56: Modem 2/12 Mica: received dialstring 00478681006
01:03:56: ISDN Se1/0:15: TX -> SETUP pd = 8 callref = 0x000E
01:03:56: Bearer Capability i = 0x8890214846BB
01:03:56: Channel ID i = 0xA9839F
01:03:56: Called Party Number i = 0x81, '00478681006', Plan:ISDN, Type:Unknown
01:03:56: Low Layer Compat i = 0x8890214846BB
01:03:56: ISDN Se1/0:15: RX <- CALL_PROC pd = 8 callref = 0x800E
01:03:56: Channel ID i = 0xA9839F
01:03:56: Modem 2/12 Mica: in modem state CALL_SETUP
01:04:02: ISDN Se1/0:15: RX <- ALERTING pd = 8 callref = 0x800E
01:04:03: ISDN Se1/0:15: RX <- CONNECT pd = 8 callref = 0x800E
01:04:03: ISDN Se1/0:15: TX -> CONNECT_ACK pd = 8 callref = 0x000E
01:04:03: Modem 2/12 Mica: in modem state CONNECT
01:04:03: Modem 2/12 Mica: in modem state LINK
01:04:03: Modem 2/12 Mica: in modem state TRAINUP
01:04:03: Modem 2/12 Mica: in modem state EC_NEGOTIATING
01:04:03: Modem 2/12 Mica: in modem state STEADY
01:04:03: CHAT77: Completed match for expect: CONNECT
01:04:03: CHAT77: Sending string: \c
01:04:03: CHAT77: Chat script callback2gsm finished, status = Success
01:04:03: TTY77: no timer type 1 to destroy
01:04:03: TTY77: no timer type 0 to destroy
01:04:03: Modem 2/12 Mica: CONNECT at 9600/9600 (Tx/Rx), V110, V.110, None
01:04:04: As77 PPP: Treating connection as a callout
01:04:04: Modem 2/12 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:04:04: As77 PPP: Authorization required
01:04:04: %LINK-3-UPDOWN: Interface Async77, changed state to up
01:04:04: As77 DDR: Dialer statechange to up
01:04:04: As77 DDR: Copying MS callback dialstring DI00478681006 to ddb
01:04:04: DDR: Freeing callback to alaingsm DI00478681006
01:04:04: As77 DDR: Dialer call has been placed
01:04:08: Modem 2/12 Mica: PPP escape_map: Tx map = A0000, Rx map = 0
01:04:08: As77 MCB: Initialize
01:04:08: Modem 2/12 Mica: Bad RX Frame: control = 0xE007, length = 0xD, 
buffer = 0x3BC6E54
01:04:09: %ISDN-6-CONNECT: Interface Serial1/0:30 is now connected to 00478681006    
01:04:11: As77 PAP: I AUTH-REQ id 2 len 16 from "alaingsm"
01:04:11: As77 PAP: Authenticating peer alaingsm
01:04:11: As77 PPP: Sent PAP LOGIN Request to AAA
01:04:11: As77 PPP: Received LOGIN Response from AAA = PASS
01:04:11: As77 DDR: Remote name for alaingsm
01:04:11: As77 DDR: Authenticated host alaingsm with no matching dialer map
01:04:11: As77 PAP: O AUTH-ACK id 2 len 5
01:04:13: As77 DDR: dialer protocol up
   
suzanne#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, 
E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
   
Gateway of last resort is 172.17.243.1 to network 0.0.0.0

172.17.0.0/24 is subnetted, 1 subnets
C 172.17.243.0 is directly connected, Ethernet0/0
172.31.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.31.1.28/32 is directly connected, Async77
C 172.31.0.0/16 is directly connected, Dialer1
S* 0.0.0.0/0 [1/0] via 172.17.243.1

   
suzanne#ping 172.31.1.28
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.31.1.28, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 784/858/880 ms

   
suzanne#
01:04:49: ISDN Se1/0:15: RX <- DISCONNECT pd = 8 callref = 0x800E
01:04:49: Cause i = 0x8090 - Normal call clearing
01:04:49: %ISDN-6-DISCONNECT: Interface Serial1/0:30 disconnected from 
00478681006, call lasted 46 seconds
01:04:49: ISDN Se1/0:15: TX -> RELEASE pd = 8 callref = 0x000E
01:04:49: Modem 2/12 Mica: in modem state TERMINATING
01:04:49: ISDN Se1/0:15: RX <- RELEASE_COMP pd = 8 callref = 0x800E
01:04:49: Modem 2/12 Mica: in modem state IDLE
01:04:49: Modem 2/12 Mica: DISCONNECT after 00:00:46, 
due to reason (0xDF00) Host Disconnect.
01:04:50: TTY77: DSR was dropped
01:04:50: tty77: Modem: READY->(unknown)
01:04:51: TTY77: Async Int reset: Dropping DTR
01:04:51: Modem 2/12 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:04:51: As77 PPP: Authorization required
01:04:51: TTY77: dropping DTR, hanging up
01:04:51: tty77: Modem: HANGUP->(unknown)
01:04:52: TTY77: cleanup pending. Delaying DTR
01:04:53: %LINK-5-CHANGED: Interface Async77, changed state to reset
01:04:53: TTY77: cleanup pending. Delaying DTR
01:04:54: TTY77: cleanup pending. Delaying DTR
01:04:55: TTY77: cleanup pending. Delaying DTR
01:04:56: TTY77: no timer type 0 to destroy
01:04:56: TTY77: no timer type 1 to destroy
01:04:56: TTY77: no timer type 3 to destroy
01:04:56: TTY77: no timer type 4 to destroy
01:04:56: TTY77: no timer type 2 to destroy
01:04:56: Async77: allowing modem_process to continue hangup
01:04:56: TTY77: restoring DTR
01:04:58: %LINK-3-UPDOWN: Interface Async77, changed state to down
01:05:08: As77 DDR: re-enable timeout

V.110 を使用したモデム コールバック


!--- Modem callback using default of MICA (modem dialing US robotics).


suzanne#
01:06:21: ISDN Se1/0:15: RX <- SETUP pd = 8 callref = 0x6D73
01:06:21: Sending Complete
01:06:21: Bearer Capability i = 0x9090A3
01:06:21: Channel ID i = 0xA18387
01:06:21: Progress Ind i = 0x8183 - Origination address is non-ISDN 
01:06:21: Calling Party Number i = 0xA1, '6020', Plan:ISDN, Type:National
01:06:21: Called Party Number i = 0x81, '214', Plan:ISDN, Type:Unknown
01:06:21: ISDN Se1/0:15: TX -> CALL_PROC pd = 8 callref = 0xED73
01:06:21: Channel ID i = 0xA98387
01:06:21: ISDN Se1/0:15: TX -> ALERTING pd = 8 callref = 0xED73
01:06:21: ISDN Se1/0:15: TX -> CONNECT pd = 8 callref = 0xED73
01:06:21: ISDN Se1/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x6D73
01:06:21: ISDN Se1/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x1A, bchan 6, dsl 0
01:06:21: Modem 2/13 Mica: configured for Answer mode, with Null signaling, 
0x0 tone detection.
01:06:21: Modem 2/13 Mica: in modem state CALL_SETUP
01:06:22: Modem 2/13 Mica: in modem state CONNECT
01:06:26: Modem 2/13 Mica: in modem state LINK
01:06:27: %ISDN-6-CONNECT: Interface Serial1/0:6 is now connected to 6020 
01:06:34: Modem 2/13 Mica: in modem state TRAINUP
01:06:36: Modem 2/13 Mica: in modem state EC_NEGOTIATING
01:06:36: Modem 2/13 Mica: in modem state STEADY
01:06:36: Modem 2/13 Mica: CONNECT at 9600/9600 (Tx/Rx), V34+, LAPM, None
01:06:37: TTY78: DSR came up
01:06:37: tty78: Modem: IDLE->(unknown)
01:06:37: TTY78: EXEC creation
01:06:37: TTY78: set timer type 10, 30 seconds
01:06:40: TTY78: Autoselect(2) sample 7E
01:06:40: TTY78: Autoselect(2) sample 7EFF
01:06:40: TTY78: Autoselect(2) sample 7EFF7D
01:06:40: TTY78: Autoselect(2) sample 7EFF7D23
01:06:40: TTY78 Autoselect cmd: ppp negotiate
01:06:40: TTY78: EXEC creation
01:06:40: TTY78: create timer type 1, 600 seconds
01:06:40: TTY78: destroy timer type 1
01:06:40: TTY78: no timer type 0 to destroy
01:06:40: As78 DDR: Dialer received incoming call from <unknown>
01:06:42: %LINK-3-UPDOWN: Interface Async78, changed state to up
01:06:42: As78 DDR: Dialer statechange to up
01:06:42: As78 DDR: Dialer received incoming call from <unknown>
01:06:42: As78 PPP: Treating connection as a callin
01:06:42: As78 PPP: Authorization required
01:06:43: Modem 2/13 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:06:43: As78 PPP: Authorization required
01:06:47: Modem 2/13 Mica: PPP escape_map: Tx map = A0000, Rx map = 0
01:06:47: As78 MCB: Initialize   01:06:47: MCB: Flush
01:06:47: Modem 2/13 Mica: Bad RX Frame: control = 0xE007, length = 0xE, buffer = 0x3BC9014
01:06:50: As78 PAP: I AUTH-REQ id 2 len 16 from "alainmod"
01:06:50: As78 PAP: Authenticating peer alainmod
01:06:50: As78 PPP: Sent PAP LOGIN Request to AAA
01:06:50: As78 PPP: Received LOGIN Response from AAA = PASS
01:06:50: As78 DDR: Remote name for alainmod
01:06:50: As78 DDR: Authenticated host alainmod with no matching dialer map
01:06:50: As78 PAP: O AUTH-ACK id 2 len 5
01:06:50: As78 MCB: Start
01:06:50: As78 MCB: User alainmod Callback Number - Client ANY
01:06:50: As78 MCB: Newstate 0-INIT -> 2-WAIT_RESPONSE
01:06:50: As78 MCB: O Request Id 1 Callback Type Client-Num delay 0
01:06:52: As78 MCB: Timeout in state WAIT_RESPONSE sending new Request 2
01:06:52: As78 MCB: O Request Id 2 Callback Type Client-Num delay 0
01:06:54: As78 MCB: Timeout in state WAIT_RESPONSE sending new Request 3
01:06:54: As78 MCB: O Request Id 3 Callback Type Client-Num delay 0
01:06:54: Async78 PPP: I MCB Response(2) id 1 len 17
01:06:54: Async78 MCB: I 2 1 0 11 2 D F 1 5A 44 54 20 36 30 32 30 0 
01:06:54: As78 MCB: Received response
01:06:54: As78 MCB: Resp ignored. ID Expected 3, got id 1
01:06:56: As78 MCB: Timeout in state WAIT_RESPONSE sending new Request 4
01:06:56: As78 MCB: O Request Id 4 Callback Type Client-Num delay 0
01:06:56: Async78 PPP: I MCB Response(2) id 4 len 17
01:06:56: Async78 MCB: I 2 4 0 11 2 D F 1 5A 44 54 20 36 30 32 30 0 
01:06:56: As78 MCB: Received response
01:06:56: As78 MCB: Response CBK-Client-Num 2 13 15, addr 1-ZDT 6020
01:06:56: As78 MCB: O Ack Id 5 Callback Type Client-Num delay 15
01:06:56: As78 MCB: Negotiated MCB with peer
01:06:56: As78 MCB: Newstate 2-WAIT_RESPONSE -> 3-WAIT_TERMINATE
01:06:56: As78 MCB: Peer terminating the link
01:06:56: As78 MCB: Newstate 3-WAIT_TERMINATE -> 5-WAIT_LINKDOWN
01:06:56: As78 MCB: Link terminated by peer, Callback Needed
01:06:56: As78 MCB: Newstate 5-WAIT_LINKDOWN -> 6-CALLING
01:06:56: As78 MCB: Initiate Callback for ^->o`iB@ at ZDT 6020 using Async DDR
01:06:56: As78 DDR: PPP callback Callback server starting to alainmod ZDT 6020
01:06:56: As78 MCB: Dialer callback started
01:06:57: Modem 2/13 Mica: in modem state TERMINATING
01:06:57: Modem 2/13 Mica: in modem state IDLE
01:06:57: %ISDN-6-DISCONNECT: Interface Serial1/0:6 disconnected from 6020, 
call lasted 36 seconds
01:06:57: ISDN Se1/0:15: TX -> DISCONNECT pd = 8 callref = 0xED73
01:06:57: Cause i = 0x8090 - Normal call clearing
01:06:57: Modem 2/13 Mica: DISCONNECT after 00:00:35, due to reason (0x8220) 
EC rcvd DISC frame. 
01:06:57: TTY78: DSR was dropped
01:06:57: tty78: Modem: READY->(unknown)
01:06:57: ISDN Se1/0:15: RX <- RELEASE pd = 8 callref = 0x6D73
01:06:57: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8 callref = 0xED73
01:06:58: TTY78: dropping DTR, hanging up
01:06:58: TTY78: Async Int reset: Dropping DTR
01:06:58: tty78: Modem: HANGUP->(unknown)
01:06:59: TTY78: cleanup pending. Delaying DTR
01:06:59: Modem 2/13 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:06:59: As78 PPP: Authorization required
01:07:00: %LINK-5-CHANGED: Interface Async78, changed state to reset
01:07:00: TTY78: cleanup pending. Delaying DTR
01:07:01: TTY78: cleanup pending. Delaying DTR
01:07:02: TTY78: cleanup pending. Delaying DTR
01:07:03: TTY78: no timer type 0 to destroy
01:07:03: TTY78: no timer type 1 to destroy
01:07:03: TTY78: no timer type 3 to destroy
01:07:03: TTY78: no timer type 4 to destroy
01:07:03: TTY78: no timer type 2 to destroy
01:07:03: Async78: allowing modem_process to continue hangup
01:07:03: TTY78: restoring DTR
01:07:05: %LINK-3-UPDOWN: Interface Async78, changed state to down
01:07:15: As78 DDR: re-enable timeout


!--- Callback start.


01:07:15: DDR: callback triggered by dialer_timers
01:07:15: As78 DDR: beginning callback to alainmod ZDT 6020
01:07:15: As78 DDR: Attempting to dial ZDT 6020
01:07:15: CHAT78: Attempting async line dialer script
01:07:15: CHAT78: Dialing using Modem script: callback2gsm 
& System script: none
01:07:15: CHAT78: process started
01:07:15: CHAT78: Asserting DTR
01:07:15: CHAT78: Chat script callback2gsm started
01:07:15: CHAT78: Sending string: AT&F
01:07:15: CHAT78: Expecting string: OK
01:07:15: CHAT78: Completed match for expect: OK
01:07:15: CHAT78: Sending string: ATS29=8
01:07:15: CHAT78: Expecting string: OK
01:07:15: CHAT78: Completed match for expect: OK 


!--- The user entered "ZDT 6020". This is what we send:


01:07:15: CHAT78: Sending string: AT \T<ZDT 6020> 
01:07:15: CHAT78: Expecting string: CONNECT
01:07:15: Modem 2/13 Mica: configured for Originate mode, with Null signaling, 
0x1 tone detection.
01:07:15: Modem 2/13 Mica: received dialstring 6020
01:07:15: ISDN Se1/0:15: TX -> SETUP pd = 8 callref = 0x000F
01:07:15: Bearer Capability i = 0x9090A3
01:07:15: Channel ID i = 0xA9839F
01:07:15: Called Party Number i = 0x81, '6020', Plan:ISDN, Type:Unknown
01:07:15: ISDN Se1/0:15: RX <- CALL_PROC pd = 8 callref = 0x800F
01:07:15: Channel ID i = 0xA9839F
01:07:15: ISDN Se1/0:15: RX <- ALERTING pd = 8 callref = 0x800F
01:07:15: Modem 2/13 Mica: in modem state CALL_SETUP
01:07:16: Modem 2/13 Mica: Detected Dial tone
01:07:17: ISDN Se1/0:15: RX <- CONNECT pd = 8 callref = 0x800F
01:07:17: Progress Ind i = 0x8182 - Destination address is non-ISDN 
01:07:17: Connected Number i = 0xA136303230
01:07:17: ISDN Se1/0:15: TX -> CONNECT_ACK pd = 8 callref = 0x000F
01:07:17: Modem 2/13 Mica: in modem state CONNECT
01:07:19: Modem 2/13 Mica: in modem state LINK
01:07:23: %ISDN-6-CONNECT: Interface Serial1/0:30 is now connected to 6020 
01:07:26: Modem 2/13 Mica: in modem state TRAINUP
01:07:28: Modem 2/13 Mica: in modem state EC_NEGOTIATING
01:07:28: Modem 2/13 Mica: in modem state STEADY
01:07:28: CHAT78: Completed match for expect: CONNECT
01:07:28: CHAT78: Sending string: \c
01:07:28: CHAT78: Chat script callback2gsm finished, status = Success
01:07:28: TTY78: no timer type 1 to destroy
01:07:28: TTY78: no timer type 0 to destroy
01:07:28: Modem 2/13 Mica: CONNECT at 33600/31200 (Tx/Rx), V34+, LAPM, None
01:07:28: As78 PPP: Treating connection as a callout
01:07:28: Modem 2/13 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:07:28: As78 PPP: Authorization required
01:07:28: %LINK-3-UPDOWN: Interface Async78, changed state to up
01:07:28: As78 DDR: Dialer statechange to up
01:07:28: As78 DDR: Copying MS callback dialstring ZDT 6020 to ddb
01:07:28: DDR: Freeing callback to alainmod ZDT 6020
01:07:28: As78 DDR: Dialer call has been placed
01:07:29: Modem 2/13 Mica: PPP escape_map: Tx map = A0000, Rx map = 0
01:07:29: As78 MCB: Initialize
01:07:29: As78 PAP: I AUTH-REQ id 1 len 16 from "alainmod"
01:07:29: As78 PAP: Authenticating peer alainmod
01:07:29: As78 PPP: Sent PAP LOGIN Request to AAA
01:07:29: As78 PPP: Received LOGIN Response from AAA = PASS
01:07:29: As78 DDR: Remote name for alainmod
01:07:29: As78 DDR: Authenticated host alainmod with no matching dialer map
01:07:29: As78 PAP: O AUTH-ACK id 1 len 5
01:07:29: As78 DDR: dialer protocol up
01:07:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async78, 
changed state to up
   
suzanne#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 172.17.243.1 to network 0.0.0.0
172.17.0.0/24 is subnetted, 1 subnets
C 172.17.243.0 is directly connected, Ethernet0/0
172.31.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.31.1.19/32 is directly connected, Async78
C 172.31.0.0/16 is directly connected, Dialer1
S* 0.0.0.0/0 [1/0] via 172.17.243.1
 
suzanne#ping 172.31.1.19

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.31.1.19, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 356/372/396 ms
   
suzanne#
01:08:08: Modem 2/13 Mica: in modem state TERMINATING
01:08:08: Modem 2/13 Mica: in modem state IDLE
01:08:08: Modem 2/13 Mica: DISCONNECT after 00:00:51, due to reason (0x8220) 
EC rcvd DISC frame.
01:08:08: %ISDN-6-DISCONNECT: Interface Serial1/0:30 disconnected from 6020, 
call lasted 51 seconds
01:08:08: ISDN Se1/0:15: TX -> DISCONNECT pd = 8 callref = 0x000F
01:08:08: Cause i = 0x8090 - Normal call clearing
01:08:08: ISDN Se1/0:15: RX <- RELEASE pd = 8 callref = 0x800F
01:08:08: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8 callref = 0x000F
01:08:09: TTY78: DSR was dropped
01:08:09: tty78: Modem: READY->(unknown)
01:08:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async78, 
changed state to down
01:08:10: TTY78: dropping DTR, hanging up
01:08:10: TTY78: Async Int reset: Dropping DTR
01:08:10: tty78: Modem: HANGUP->(unknown)
01:08:10: Modem 2/13 Mica: PPP escape_map: Tx map = FFFFFFFF, Rx map = 0
01:08:10: As78 PPP: Authorization required
01:08:11: TTY78: cleanup pending. Delaying DTR
01:08:12: %LINK-5-CHANGED: Interface Async78, changed state to reset
01:08:12: TTY78: cleanup pending. Delaying DTR
01:08:13: TTY78: cleanup pending. Delaying DTR
01:08:14: TTY78: cleanup pending. Delaying DTR
01:08:15: TTY78: no timer type 0 to destroy
01:08:15: TTY78: no timer type 1 to destroy
01:08:15: TTY78: no timer type 3 to destroy
01:08:15: TTY78: no timer type 4 to destroy
01:08:15: TTY78: no timer type 2 to destroy
01:08:15: Async78: allowing modem_process to continue hangup
01:08:15: TTY78: restoring DTR
01:08:17: %LINK-3-UPDOWN: Interface Async78, changed state to down
01:08:27: As78 DDR: re-enable timeout

V.110 を使用した ISDN コールバック


!--- Receive call.

suzanne#
01:09:00: ISDN Se1/0:15: RX <- SETUP pd = 8 callref = 0x6F28
01:09:00: Sending Complete
01:09:00: Bearer Capability i = 0x8890
01:09:00: Channel ID i = 0xA18388
01:09:00: Calling Party Number i = 0xA1, '6136', Plan:ISDN, Type:National
01:09:00: Called Party Number i = 0x81, '214', Plan:ISDN, Type:Unknown
01:09:00: %LINK-3-UPDOWN: Interface Serial1/0:7, changed state to up
01:09:00: ISDN Se1/0:15: TX -> CALL_PROC pd = 8 callref = 0xEF28
01:09:00: Channel ID i = 0xA98388
01:09:00: ISDN Se1/0:15: TX -> CONNECT pd = 8 callref = 0xEF28
01:09:00: Channel ID i = 0xA98388
01:09:00: Se1/0:7 PPP: Treating connection as a callin
01:09:00: Se1/0:7 PPP: Authorization required
01:09:00: ISDN Se1/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x6F28
01:09:00: ISDN Se1/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x1B, 
bchan 7, dsl 0
01:09:01: Se1/0:7 PPP: Authorization required
01:09:01: Se1/0:7 MCB: Initialize
01:09:01: Se1/0:7 CHAP: O CHALLENGE id 1 len 28 from "suzanne"
01:09:01: Se1/0:7 CHAP: I RESPONSE id 1 len 30 from "alainisdn"
01:09:01: Se1/0:7 PPP: Sent CHAP LOGIN Request to AAA
01:09:01: Se1/0:7 PPP: Received LOGIN Response from AAA = PASS
01:09:01: Se1/0:7 DDR: Remote name for alainisdn
01:09:01: Se1/0:7 CHAP: O SUCCESS id 1 len 4
01:09:01: Se1/0:7 DDR: PPP callback Callback server starting to 
alainisdn 6136
01:09:01: Se1/0:7 DDR: disconnecting call
01:09:01: %ISDN-6-CONNECT: Interface Serial1/0:7 is now connected to 
6136 alainisdn
01:09:01: ISDN Se1/0:15: TX -> DISCONNECT pd = 8 callref = 0xEF28
01:09:01: Cause i = 0x8090 - Normal call clearing
01:09:01: ISDN Se1/0:15: RX <- RELEASE pd = 8 callref = 0x6F28
01:09:01: %LINK-3-UPDOWN: Interface Serial1/0:7, changed state to down
01:09:01: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8 callref = 0xEF28
01:09:01: Se1/0:7 DDR: disconnecting call
01:09:02: ISDN Se1/0:15: RX <- SETUP pd = 8 callref = 0x70DF
01:09:02: Sending Complete
01:09:02: Bearer Capability i = 0x8890
01:09:02: Channel ID i = 0xA18389
01:09:02: Calling Party Number i = 0xA1, '6136', Plan:ISDN, Type:National
01:09:02: Called Party Number i = 0x81, '214', Plan:ISDN, Type:Unknown
01:09:02: %LINK-3-UPDOWN: Interface Serial1/0:8, changed state to up
01:09:02: ISDN Se1/0:15: TX -> CALL_PROC pd = 8 callref = 0xF0DF
01:09:02: Channel ID i = 0xA98389
01:09:02: ISDN Se1/0:15: TX -> CONNECT pd = 8 callref = 0xF0DF
01:09:02: Channel ID i = 0xA98389
01:09:02: Se1/0:8 PPP: Treating connection as a callin
01:09:02: Se1/0:8 PPP: Authorization required
01:09:02: ISDN Se1/0:15: RX <- CONNECT_ACK pd = 8 callref = 0x70DF
01:09:02: ISDN Se1/0:15: CALL_PROGRESS: CALL_CONNECTED call id 0x1C, 
bchan 8, dsl 0
01:09:02: Se1/0:8 PPP: Authorization required
01:09:03: Se1/0:8 MCB: Initialize
01:09:03: Se1/0:8 CHAP: O CHALLENGE id 1 len 28 from "suzanne"
01:09:03: Se1/0:8 CHAP: I RESPONSE id 1 len 30 from "alainisdn"
01:09:03: Se1/0:8 PPP: Sent CHAP LOGIN Request to AAA
01:09:03: Se1/0:8 PPP: Received LOGIN Response from AAA = PASS
01:09:03: Se1/0:8 DDR: Remote name for alainisdn
01:09:03: Se1/0:8 CHAP: O SUCCESS id 1 len 4
01:09:03: Se1/0:8 DDR: callback to alainisdn already started
01:09:03: Se1/0:8 DDR: disconnecting call
01:09:03: %ISDN-6-CONNECT: Interface Serial1/0:8 is now connected 
to 6136 alainisdn
01:09:03: ISDN Se1/0:15: TX -> DISCONNECT pd = 8 callref = 0xF0DF
01:09:03: Cause i = 0x8090 - Normal call clearing
01:09:03: ISDN Se1/0:15: RX <- RELEASE pd = 8 callref = 0x70DF
01:09:03: %LINK-3-UPDOWN: Interface Serial1/0:8, changed state to down
01:09:03: ISDN Se1/0:15: TX -> RELEASE_COMP pd = 8 callref = 0xF0DF
01:09:03: Se1/0:8 DDR: disconnecting call


!---  Callback Start 


01:09:16: DDR: Callback timer expired
01:09:16: Di1 DDR: beginning callback to alainisdn 6136
01:09:16: Se1/0:15 DDR: rotor dialout [priority]
01:09:16: Se1/0:15 DDR: Attempting to dial 6136
01:09:16: ISDN Se1/0:15: TX -> SETUP pd = 8 callref = 0x0010
01:09:16: Bearer Capability i = 0x8890
01:09:16: Channel ID i = 0xA9839F
01:09:16: Called Party Number i = 0x81, '6136', Plan:ISDN, Type:Unknown
01:09:16: ISDN Se1/0:15: RX <- CALL_PROC pd = 8 callref = 0x8010
01:09:16: Channel ID i = 0xA9839F
01:09:16: ISDN Se1/0:15: RX <- ALERTING pd = 8 callref = 0x8010
01:09:16: ISDN Se1/0:15: RX <- CONNECT pd = 8 callref = 0x8010
01:09:16: Connected Number i = 0xA136313336
01:09:16: %LINK-3-UPDOWN: Interface Serial1/0:30, changed state to up
01:09:16: DDR: Freeing callback to alainisdn 6136
01:09:16: ISDN Se1/0:15: TX -> CONNECT_ACK pd = 8 callref = 0x0010
01:09:16: Se1/0:30 PPP: Treating connection as a callout
01:09:16: Se1/0:30 PPP: Authorization required
01:09:16: Se1/0:30 MCB: Initialize
01:09:16: Se1/0:30 CHAP: I CHALLENGE id 7 len 30 from "alainisdn"
01:09:16: Se1/0:30 PPP: Sent CHAP SENDAUTH Request to AAA
01:09:16: Se1/0:30 PPP: Received SENDAUTH Response from AAA = PASS
01:09:16: Se1/0:30 CHAP: O RESPONSE id 7 len 28 from "suzanne"
01:09:16: Se1/0:30 CHAP: I SUCCESS id 7 len 4
01:09:16: Se1/0:30 PPP: Sent LCP AUTHOR Request to AAA
01:09:16: Se1/0:30 PPP: Sent IPCP AUTHOR Request to AAA
01:09:16: Se1/0:30 LCP: Received AAA AUTHOR Response = PASS
01:09:16: Se1/0:30 IPCP: Received AAA AUTHOR Response = PASS
01:09:16: Se1/0:30 DDR: dialer protocol up
01:09:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0:30, 
changed state to up
01:09:22: %ISDN-6-CONNECT: Interface Serial1/0:30 is now connected to 
6136 alainisdn
suzanne#
   
suzanne#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 172.17.243.1 to network 0.0.0.0

  172.17.0.0/24 is subnetted, 1 subnets
C 172.17.243.0 is directly connected, Ethernet0/0
  172.31.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.31.1.2/32 is directly connected, Dialer1
C 172.31.0.0/16 is directly connected, Dialer1
S* 0.0.0.0/0 [1/0] via 172.17.243.1
   
suzanne#ping 172.31.1.2

  Type escape sequence to abort. 
  Sending 5, 100-byte ICMP Echos to 172.31.1.2, timeout is 2 seconds:
  !!!!!
  Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/36 ms  
  suzanne#

関連情報


Document ID: 6153