ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

ダイヤラ プロファイルを使用した BRI バックアップ インターフェイスの設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書では、専用回線、WAN、またはシリアル接続をバックアップする ISDN 基本速度インターフェイス(BRI)回線の使用方法について説明します。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景理論

backup interface コマンドは、プライマリ インターフェイスがダウンするまでの時間、インターフェイスをスタンドバイ モードにします。 バックアップ インターフェイス機能についての詳細な情報は、DDR バックアップ インターフェイス、フローティング スタティック ルート、およびダイヤラ ウォッチの比較を参照してください。

この例では、バックアップ インターフェイス機能を用いたダイヤラ プロファイルを使用します。 backup interface コマンドを使用すると、設定済みの物理インターフェイスまたは論理インターフェイスがスタンドバイ モードになります。 ダイヤラ プロファイルを使用すると、論理インターフェイス(ダイヤラ インターフェイス)だけが待機モードになり、物理インターフェイス(BRI)は他のプールのメンバーにすることで別の接続で使用できます。 ダイヤラ プロファイルについての詳細な情報は、ダイヤラ プロファイルを使用した ISDN DDR の設定を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

DDR バックアップを設定するには、次の手順にそれぞれ従います。

  1. DDR を設定する。 レガシー DDR(ダイヤラ マップ)またはダイヤラ プロファイルのいずれかを使用します。 この設定では、ダイヤラ プロファイルを採用します。 DDR 接続が正常に機能することを確認してから、バックアップ設定を実装します。 これにより、バックアップを設定する前に、ダイヤル方式の使用、ポイントツーポイント プロトコル(PPP)ネゴシエーション、および認証が正しいかを検証できます。 ダイヤラマップに関しては基づいてバックアップコンフィギュレーションは BRI および Backup interface コマンドを使用して、資料 DDR バックアップを示します。

  2. プライマリ リンクが失敗した場合に DDR 接続を開始するルータを 1 つ設定する。 この設定は、ダイヤルアウトをトリガーするために backup interface コマンドを使用します。

  3. プライマリ リンクが失敗した場合にバックアップ接続をトリガーする対象トラフィックを定義する。

詳細については DDR バックアップの設定とトラブルシューティングの文書を参照することを推奨します。

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/5721/bri-to-bri-backup.gif

設定

この設定では、シリアル リンクをバックアップするために BRI 回線を使用します。 2 つのルータの間に Open Shortest Path First(OSPF)ルーティング プロトコルを使用します。 バックアップ接続が有効になると、ルーティング テーブルが新しいバックアップ リンクを使用するように更新されていることを確認する必要があります。 一方(maui-soho-01)だけがダイヤルアウトするように設定されます。 もう一方(maui-nas-05)は、コールを受け入れるように設定されます。

この設定では、Cisco 1604 ルータをシリアル接続を使用して Cisco 3640 ルータに接続します。 両方のルータにもバックアップ リンクに使用する BRI インターフェイスが装備されています。 Cisco 1604 は Cisco IOS を実行していますか。 ソフトウェア リリース 12.1(5)T および Cisco 3640 は Cisco IOS 12.1(2)を使用しています。

backup interface および backup delay コマンドを設定する前に、DDR 接続(BRI0 のダイヤラ 1)が正常に動作しているか設定および確認を行います。 これで、バックアップを設定する前に、ダイヤラ プロファイル、ISDN、ポイントツーポイント プロトコル(PPP)および認証発行のトラブルシューティングを効果的に管理できます。

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1687 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret(used for
!--- CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary Interface

 backup delay 10 30

!--- Backup link will be activated 10 seconds after primary link goes down.
!--- Backup link will be deactivated 30 seconds after primary link is restored.

 backup interface Dialer1

!--- Interface Dialer 1 will provide backup. Dialer 1 will be placed in Standby
!--- until the primary link goes down.

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 no fair-queue
 clockrate 64000
 ppp authentication chap
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 10

!--- Assign BRI0 as member of dialer pool 10.
!--- Dialer pool 10 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112
 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- This interface will be in standby until the primary link is down.

 ip address 172.20.10.2 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer pool 10

!--- Defines Dialer pool 10.
!--- BRI 0 is a member of this pool.

 dialer remote-name maui-nas-05

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- The link will be disconnected if there is no interesting traffic for 900 secs.
!--- Since OSPF hellos are interesting traffic, this will reset the idle timeout
!--- and cause the link to stay up until the primary link is restored and the dialer
!--- returns to standby mode.

 dialer string 5552222

!--- Defines the destination routers phone number.

 dialer load-threshold 80 outbound

!--- This sets the outbound load level for traffic at which 
!--- additional connections will be added to the MP bundle load level.
!--- Values range from 1 (unloaded) to 255 (fully loaded). The threshold
!--- in this case is 80/255=32%.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use PPP CHAP authentication.

 ppp multilink
!
router ospf 5

!--- OSPF configuration. You can use any routing protocol here without any other
!--- changes to the configuration.

 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.
!--- OSPF hello packets will trigger the dial.

!
line con 0
 exec-timeout 0 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!
end

maui-soho-01 の設定の次のポイントに注意して下さい:

  • The backup link uses dialer profiles. This allows the backup interface (Dialer 1) to be in standby mode while the physical interface (BRI 0) is not. これはプライマリ リンクがアクティブな間、1 つが物理インターフェイスを使用するようにします(別のダイヤラプールのそれにメンバーをすることによって)。 For more information on dialer profiles, refer to the document Configuring and Troubleshooting Dialer Profiles.

  • maui-nas-05 (3640) 同様に他のどのルーティング プロトコルも(たとえば、RIP、EIGRP)ここでは使用できます。 適切なルーティングプロトコルコンフィギュレーション ガイド IPC を参照して下さい: パート 2: IP Routing Protocols. Make sure that you include the primary interface network and backup interface network in the routing protocol configuration so that information can be propagated by the routing protocol. ルーティング プロトコルの代りにスタティック・ルートを使用したい場合リモート BRI インターフェイス(シナリオによってそれにフローティング スタティック ルートをしなければならないことができます)であるネクスト ホップでスタティック ルートを作成して下さい。

  • どの IP トラフィックでも dial(dialer-list 1 と dialer-group 1 に基づく)をトリガーします。 これはバックアップインターフェイス DDR バックアップ 環境でプライマリがとにかく稼働しているときバックアップリンクがスタンバイ モードにダイヤルされることが不可能あるのでうまく作動し。 Since the backup link requires interesting traffic to dial the backup link, verify that you do have a traffic source generating interesting traffic. In this example, OSPF hello packets will trigger the dial. ルーティング プロトコルを使用していない場合は、ICMP ping を使用してバックアップ リンクにダイヤルできます。 Adjust the interesting traffic depending on your needs.

maui-nas-05(3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- Basic AAA configuration for ppp calls.

enable secret 5 <deleted>
!
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret
!---(used for CHAP authentication).
!--- Shared secret must be the same on both sides.

ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0

!--- The loopback address will be used by OSPF for the router ID.

!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0
 ip unnumbered Loopback0

!--- Unnumbered to the Loopback 0 address.

 encapsulation ppp
 dialer pool-member 20

!--- Assign BRI0 as member of dialer pool 20.
!--- Dialer pool 20 is specified in interface Dialer 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223
 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!

! <<-- Unused interface configurations have been removed.

!
interface Serial2/0

!--- Primary interface.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 no fair-queue
 ppp authentication chap
!

! <<--Unused interface configurations have been removed.

!
interface Dialer1

!--- Dialer 1 provides backup for the serial link.
!--- Notice that there is no dialer string on this router. This prevents the NAS
!--- from attempting to dialout using the backup circuit when the primary is up.

 ip address 172.20.10.1 255.255.255.0

!--- Address for the dialer interface. 
!--- The remote side dialer interface is in the same subnet.

 encapsulation ppp
 dialer remote-name maui-soho-01

!--- Specifies remote router name. 
!--- This name must match that used by the remote router to authenticate itself.

 dialer pool 20

!--- Defines dialer pool 20.

 dialer idle-timeout 900

!--- Idle timeout is set to 900 seconds (15 minutes).
!--- This is equal to the idle timeout set on maui-soho-01.

 dialer max-call 4096
 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.

 ppp authentication chap

!--- Use ppp chap authentication.

 ppp multilink
!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate

!--- Transmit ospf default information. 
!--- This may be required for remote router to use the BRI DDR link.

!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- All IP traffic is designated as interesting.
!--- This is applied to Interface Dialer 1 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

すべての IP トラフィックが対象として指定されました。

  • 設定はあらゆるダイヤルイン設定に類似したです。 NAS に関する限りではバックアップリンクはありふれた着信コールです。

  • The dialer interface does not have a dialer string, hence cannot dialout.

  • All traffic is interesting. Since the backup link cannot dialout anyway (see previous bullet) this is acceptable. 関連 トラフィックを(たとえば、ルーティング プロトコルは不要です)制限すれば、NAS がリンクを渡る関連 トラフィック コールを切断する可能性がないという可能性があります。 In backup scenarios it is best to let one side (either the dialout or dialin side) control the backup link to avoid link instability.

バックアップリンクのテスト

バックアップインターフェイスはバックアップインターフェイスがスタンバイ モードの引き出される前にプライマリインターフェイス プロトコルがダウンしていることを必要とします。 Hence, it is not possible to test the backup link without physically brining the primary link down. このオプションは次のいずれかです。

  • プライマリインターフェイスを消す shutdownコマンドを使用して下さい。 ただし、設定される backup interface コマンドでルータの shutdownコマンドを使用しないで下さい。 これにより Cisco IOSソフトウェアはバックアップリンクにダイヤルしません。 バックアップをアクティブにするには、backup interface コマンドが設定されていないルータのプライマリ インターフェイスをシャットダウンします。 このシナリオでは、バックアップ インターフェイス コマンドは maui-soho-01(1600)に設定されています。 従って、maui-nas-05 (3640)のプライマリインターフェイスの shutdownコマンドを実行することはバックアップリンクをアクティブにします。

  • 物理的にケーブルか同等な方法 始動のプラグを抜くことによってプライマリ接続をバックアップインターフェイス ダウンさせて下さい。

show コマンド

特定の show コマンドは、アウトプット インタープリタでサポートされています。このツールを使用すると、show コマンド出力を分析できます。

  • show isdn status:ルータが ISDN スイッチと適切に通信していることを確認します。 出力で、レイヤ 1 ステータスが ACTIVE、レイヤ 2 ステータスが state = MULTIPLE_FRAME_ESTABLISHED となっていることを検証します。 このコマンドは、通信中のコールの数も表示します。

  • show ip interface brief:ダイヤラ 1(maui-soho-01 の)をスタンドバイ モードで表示する。 ダイヤラ 1 をバックアップ インターフェイスとして使用すると、物理インターフェイス(BRI0)はバックアップ専用ではないということになります。 したがって、BRI 0 は、プライマリ リンクがアップしている間は、標準 DDR として使用できます。

show コマンドの出力例

クライアント側のルーティング テーブルを以下に示します。 出力は下記のプライマリ リンク アクティブのルーティング テーブルを示したものです。

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
O       172.20.10.0 [110/1849] via 192.168.10.1, 00:00:10, Serial0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 00:00:11, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 00:00:11, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 00:00:11, Serial0

show ip route の出力は(上に示されている)プライマリ リンク(0)シリアルを使用してピアから学習される OSPF ルーティングを表示するものです。 この場合プライマリ リンクをダウンさせ、バックアップリンクをアクティブにする。

バックアップリンクがアクティブになった後、OSPF テーブルは交換され、バックアップリンクを使用して新しいルーティングはインストールされています。 トラフィックはバックアップリンクを渡って今フローします。

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, Dialer1
C       172.20.10.1/32 is directly connected, Dialer1
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:00:01, Dialer1
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:00:02, Dialer1
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:00:02, Dialer1

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

debug コマンド

debug コマンドを発行する前に、『debug コマンドの重要な情報』を参照してください。

  • debug dialer:ダイヤラ インターフェイスで受信したパケットについての DDR 情報を表示するために使用する。

  • debug isdn events:ISDN インターフェイスのユーザ側で発生している ISDN アクティビティを表示するために使用する。

  • debug isdn q931:ルータと ISDN スイッチ間の ISDN ネットワーク接続(レイヤ 3)のコール設定および切断を表示する。

  • debug ppp negotiation:PPP トラフィックに関する情報と、Link Control Protocol(LCP; リンク コントロール プロトコル)、認証、および NCP などの PPP コンポーネントのネゴシエーションの際に交換される情報を表示します。 PPP ネゴシエーションが正常に行われると、最初に LCP 状態が開放され、次に認証、最後に NCP をネゴシエートします。

  • debug ppp authentication:Challenge Authentication Protocol(CHAP)パケット交換や Password Authentication Protocol(PAP; パスワード認証プロトコル)交換など、PPP の認証プロトコル メッセージを表示します。 失敗が観測された場合は、CHAP ユーザ名とパスワードが正しく設定されているか検証します。

  • debug ppp error:PPP 接続ネゴシエーションとオペレーションに関連したプロトコル エラーとエラー統計を表示するために使用する。

DDR バックアップのトラブルシューティング

backup interface および backup delay コマンドを設定する前に、DDR 接続(ダイヤラ 1 および BRI0)が正常に動作するように設定および確認を行います。 これにより、バックアップを設定する前にダイヤラ プロファイル、ISDN、PPP、および認証が正常に機能しているか確認することができます。 DDRリンクのトラブルシューティングを実行するために、ダイヤルアップ技術を参照して下さい: トラブルシューティング テクニック』を参照してください。

これで、DDR 接続が正常に動作していることが確認されたので、次のトラブルシューティングの手順に進みます。下記で概要を説明します。

  • プライマリ リンクを停止します。 バックアップ インターフェイス コマンドを設定したルータに shutdown コマンドを使用しないでください。 これによって、Cisco IOS がバックアップ リンクにダイヤルすることはありません。 バックアップをアクティブにするには、backup interface コマンドが設定されていないルータのプライマリ インターフェイスをシャットダウンします。 このシナリオでは、バックアップ インターフェイス コマンドは maui-soho-01(1600)に設定されています。 したがって、maui-nas-05(3640)のプライマリ インターフェイスで shutdown コマンドを行うと、バックアップ リンクが有効になります。 また、プラグを抜くなどの方法で物理的にプライマリ接続を停止すると、バックアップ インターフェイスを始動できます。

  • バックアップ インターフェイス(インターフェイス ダイヤラ 1)がアップになっていることを示すコンソール メッセージを確認することが必要です。 このメッセージは、backup delay コマンドによって指定されたインターバル時間が経過したあとにだけ表示されます。 この設定では、バックアップのアクティベーションは 10 秒遅れます。 このコンソール メッセージが表示されない場合は、backup delay タイマーを検査します。

    *Mar  1 03:37:31.788: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
    *Mar  1 03:37:42.719: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
    
  • show ip route コマンドを使用してプライマリ リンクがダウンしている状態でルーティング テーブルを表示します。 ダイヤラ 1 に直接接続されたルートを確認する必要があります。リモート ルータのダイヤラ インターフェイス(インターフェイス ダイヤラ 1 と同じサブネットにある)の IP アドレスを PING します。 リンク ダイヤルを見つけて接続します。

    • リンクがダイヤルしない場合は、対象トラフィック定義が ICMP(PING)を許可しているか検証します。

    • リンクが始動した場合は、そのサブネットを送信先とするトラフィックがなかったために問題が発生したという結論になります。 ただし、PING に基づいて特定のホストにバックアップ リンクがダイヤルするように強制することは現実的ではありません。 この問題を回避するには、デフォルト トラフィックにフローティングスタティック ルートを設定します。

      maui-soho-01(config)#ip route 0.0.0.0 0.0.0.0 172.20.10.1 200 
      

      上記のデフォルト ルートはリモートルータの 200 のダイヤラーインターフェイスおよびアドミニストレーティブ ディスタンスのネクストホップ アドレスを備えています。 この変動的ルートはよりよいデフォルト ルートが(すなわち、より低い管理距離と)ない場合ルータがダイヤラーインターフェイスにパケットをルーティングするようにします。 ダイヤラ インターフェイスにルーティングされたパケットが、リンクにダイヤルさせる原因となることは以前に検証しました。

  • ルータがダイヤルするがリンクに、接続しなければもはや DDR バックアップ問題ではないし、ダイヤルアップ技術を参照する必要があります: トラブルシューティング テクニック」を参照してください。

トラブルシューティング情報詳細については DDR バックアップの設定とトラブルシューティングの文書のバックアップインターフェイスのトラブルシューティングを実行するセクションを参照して下さい。

debug 出力例

次のデバッグ出力(クライアントからの)は、プライマリ リンクが故障してバックアップ リンクが有効になっていることを表示します。

紙面の都合上、一部のデバッグ出力は複数行に分かれて記述されています。

maui-soho-01#show debug

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#debug isdn q931
ISDN Q931 packets debugging is on
maui-soho-01#debug ppp negotiation
PPP protocol negotiation debugging is on
maui-soho-01#debug ppp authentication 
PPP authentication debugging is on
maui-soho-01#
*Mar  1 01:09:24.872: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary link is unplugged.
!--- Refer to the section Testing the Backup Link for the appropriate procedure.

*Mar  1 01:09:24.880: Se0 IPCP: State is Closed
*Mar  1 01:09:24.884: Se0 CDPCP: State is Closed
*Mar  1 01:09:24.888: Se0 PPP: Phase is TERMINATING [0 sess, 0 load]
*Mar  1 01:09:24.892: Se0 LCP: State is Closed
*Mar  1 01:09:24.892: Se0 PPP: Phase is DOWN [0 sess, 0 load]
*Mar  1 01:09:24.908: Se0 IPCP: Remove route to 192.168.10.1
*Mar  1 01:09:24.916: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on Serial0
 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 01:09:25.864: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
 changed state to down

!--- Primary interface line protocol is down. This must happen before the backup
!--- interface is brought out of standby.

*Mar  1 01:09:34.824: Di1 DDR is shutdown, could not clear interface.
*Mar  1 01:09:34.840: BR0 DDR: rotor dialout [priority]

!--- Note: The backup interface was activated 10 seconds after the primary
!--- link went down. This interval was defined with the backup delay command
!--- in maui-soho-01 (1600).

*Mar  1 01:09:34.848: BR0 DDR: Dialing cause ip (s=172.20.10.2, d=224.0.0.5)

!--- OSPF hellos cause the router to dial.

*Mar  1 01:09:34.852: BR0 DDR: Attempting to dial 5552222

!--- Phone number of the remote router that is dialed.

*Mar  1 01:09:34.876: ISDN BR0: TX ->  SETUP pd = 8  callref = 0x0A
*Mar  1 01:09:34.888:         Bearer Capability i = 0x8890
*Mar  1 01:09:34.895:         Channel ID i = 0x83
*Mar  1 01:09:34.903:         Keypad Facility i = '5552222'
*Mar  1 01:09:35.169: ISDN BR0: RX <-  CALL_PROC pd = 8  callref = 0x8A
*Mar  1 01:09:35.177:         Channel ID i = 0x89
*Mar  1 01:09:35.415: ISDN BR0: RX <-  CONNECT pd = 8  callref = 0x8A

!--- Call is connected.

*Mar  1 01:09:35.439: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
*Mar  1 01:09:35.447: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1
*Mar  1 01:09:35.463: BR0:1 PPP: Treating connection as a callout

!--- PPP negotiation begins.

*Mar  1 01:09:35.467: BR0:1 PPP: Phase is ESTABLISHING, Active Open
 [0 sess, 0 load]
*Mar  1 01:09:35.479: BR0:1 LCP: O CONFREQ [Closed] id 14 len 34
*Mar  1 01:09:35.483: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.487: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.491: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.495: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.511: ISDN BR0: TX ->  CONNECT_ACK pd = 8  callref = 0x0A
*Mar  1 01:09:35.566: BR0:1 LCP: I CONFREQ [REQsent] id 6 Len 33
*Mar  1 01:09:35.570: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.574: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.578: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.582: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.590: BR0:1 LCP: O CONFACK [REQsent] id 6 Len 33
*Mar  1 01:09:35.598: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.602: BR0:1 LCP:    MagicNumber 0x30D37ABB (0x050630D37ABB)
*Mar  1 01:09:35.606: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.610: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130E016D6175692D6E61732D3035)
*Mar  1 01:09:35.618: BR0:1 LCP: I CONFACK [ACKsent] id 14 Len 34
*Mar  1 01:09:35.622: BR0:1 LCP:    AuthProto CHAP (0x0305C22305)
*Mar  1 01:09:35.626: BR0:1 LCP:    MagicNumber 0x10BC0680 (0x050610BC0680)
*Mar  1 01:09:35.630: BR0:1 LCP:    MRRU 1524 (0x110405F4)
*Mar  1 01:09:35.637: BR0:1 LCP:    EndpointDisc 1 Local
 (0x130F016D6175692D736F686F2D3031)
*Mar  1 01:09:35.641: BR0:1 LCP: State is Open
*Mar  1 01:09:35.645: BR0:1 PPP: Phase is AUTHENTICATING, by both
 [0 sess, 1 load]

!--- PPP authentication begins.

*Mar  1 01:09:35.649: BR0:1 CHAP: O CHALLENGE id 6 Len 33 from "maui-soho-01"

!--- This is the username used for outgoing CHAP challenge. The remote router
!--- must have this username configured along with shared secret.

*Mar  1 01:09:35.657: BR0:1 CHAP: I CHALLENGE id 6 Len 32 from "maui-nas-05"

!--- This is the username for incoming CHAP challenge.
!--- This username must be locally configured.

*Mar  1 01:09:35.760: BR0:1 CHAP: O RESPONSE id 6 Len 33 from "maui-soho-01"
*Mar  1 01:09:35.804: BR0:1 CHAP: I SUCCESS id 6 Len 4
*Mar  1 01:09:35.808: BR0:1 CHAP: I RESPONSE id 6 Len 32 from "maui-nas-05"
*Mar  1 01:09:35.820: BR0:1 CHAP: O SUCCESS id 6 Len 4

!--- CHAP authentication is successful.

*Mar  1 01:09:35.828: BR0:1 PPP: Phase is VIRTUALIZED [0 sess, 1 load]
*Mar  1 01:09:35.844: Di1 DDR: Authenticated host maui-nas-05 with no matching
 dialer map
*Mar  1 01:09:35.848: Di1 PPP: Phase is UP [0 sess, 1 load]
*Mar  1 01:09:35.856: Di1 IPCP: O CONFREQ [Closed] id 6 Len 10
*Mar  1 01:09:35.860: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.872: Di1 CDPCP: O CONFREQ [Closed] id 6 Len 4
*Mar  1 01:09:35.876: BR0:1 MLP: maui-nas-05, multilink up, first link
*Mar  1 01:09:35.884: BR0:1 IPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.887: BR0:1 IPCP: Redirect packet to Di1
*Mar  1 01:09:35.891: Di1 IPCP: I CONFREQ [REQsent] id 6 Len 10
*Mar  1 01:09:35.895: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.903: Di1 IPCP: O CONFACK [REQsent] id 6 Len 10
*Mar  1 01:09:35.907: Di1 IPCP:    Address 172.20.10.1 (0x0306AC140A01)
*Mar  1 01:09:35.911: BR0:1 CDPCP: MLP bundle interface is built,
 process packets now 
*Mar  1 01:09:35.915: BR0:1 CDPCP: Redirect packet to Di1
*Mar  1 01:09:35.919: Di1 CDPCP: I CONFREQ [REQsent] id 6 Len 4
*Mar  1 01:09:35.927: Di1 CDPCP: O CONFACK [REQsent] id 6 Len 4
*Mar  1 01:09:35.931: Di1 IPCP: I CONFACK [ACKsent] id 6 Len 10
*Mar  1 01:09:35.935: Di1 IPCP:    Address 172.20.10.2 (0x0306AC140A02)
*Mar  1 01:09:35.939: Di1 IPCP: State is Open

!--- IPCP state is open and route will be installed.

*Mar  1 01:09:35.951: Di1 CDPCP: I CONFACK [ACKsent] id 6 Len 4
*Mar  1 01:09:35.955: Di1 CDPCP: State is Open
*Mar  1 01:09:35.959: Di1 DDR: dialer protocol up
*Mar  1 01:09:35.971: Di1 IPCP: Install route to 172.20.10.1

!--- Route to remote side is installed.

*Mar  1 01:09:36.840: %LINK-3-UPDOWN: Interface Dialer1, changed state to up
*Mar  1 01:09:36.844: Di1 LCP: Not allowed on a Dialer Profile
*Mar  1 01:09:36.848: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
 changed state to up
*Mar  1 01:09:41.411: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5552222
 maui-nas-05

!--- Connection is up.

*Mar  1 01:09:44.931: %OSPF-5-ADJCHG: Process 5, Nbr 172.22.1.1 on
 Dialer1 from LOADING to FULL, Loading Done

!--- OSPF database exchange is complete.


関連情報


Document ID: 5721