ダイヤルとアクセス : 総合デジタル通信網(ISDN)、個別線信号方式(CAS)

BRI とダイヤラ ウォッチを使用した DDR バックアップの設定

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2002 年 6 月 1 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

この文書は、ダイヤラ ウォッチ機能を使用して専用回線、WAN、またはシリアル接続をバックアップするための ISDN Basic Rate Interface(BRI; 基本インターフェイス)の使用について説明しています。 ダイヤラ ウォッチの機能の詳細については、「DDR バックアップ インターフェイス、フローティング スタティック ルート、およびダイヤラ ウォッチの比較」を参照してください。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco IOS を実行する 1 BRI U インターフェイスの Cisco 1604 か。 ソフトウェア リリース 12.1(5)T。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

背景理論

この例ではレガシー Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)を使用しています。レガシー DDR では BRI 接続のために dialer map コマンドを使用します。 レガシー DDR(ダイヤラ マップ)の代わりにダイヤラ プロファイルも使用できます。 ダイヤラ プロファイルの詳細については、「ダイヤラ プロファイルを使用した ISDN DDR の設定」を参照してください。

DDR バックアップの設定では、2 つの異なる手順を行います。

  1. DDR を、レガシー DDR とダイヤラ プロファイルのどちらかを使用して設定します。 DDR 接続が正常に機能することを確認してから、バックアップ設定を実装します。 その後、Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)ネゴシエーションなど使用するダイヤル方式、認証が正常であることを検証してからバックアップを設定します。

  2. プライマリ リンクに障害が発生したときにバックアップ DDR 接続を開始するようルータを設定します。 この設定ではダイヤラ ウォッチ機能を使用してダイヤルアウトします。

バックアップの設定に必要な手順の詳細については、文書「DDR バックアップの設定とトラブルシューティング」を参照してください。

ダイヤラ ウォッチの動作

ダイヤラ ウォッチを使用すると、ルータは指定された経路の存在を監視し、この経路が存在しない場合は、バックアップ リンクのダイヤル呼び出しを開始します。 他のバックアップ方式(バックアップ インターフェイスやフローティング スタティック ルート)と異なり、ダイヤラ ウォッチ はダイヤルを起動する対象トラフィックを必要としません。 ダイヤラ ウォッチが使用するプロセスを、次に説明します。

  • ある監視経路が削除されると、ダイヤラ ウォッチ は監視している ネットワークへの有効な経路をチェックします。

    • 有効な経路がない場合、プライマリ回線は停止しており使用不可と見なされます。

      • 続いてダイヤラ ウォッチはコールを開始し、ルータ同士が接続してルーティング情報を交換します。 リモート ネットワークのすべてのトラフィックは、これでバックアップ リンクを使用できるようになります。

    • 定義された監視 IP ネットワークの少なくとも 1 つに有効な経路があり、その経路がダイヤラ ウォッチに設定されたバックアップ インターフェイス以外のインターフェイスを経由している場合、プライマリは稼動していると見なされ、ダイヤラ ウォッチ はバックアップ リンクを開始しません。

  • バックアップ リンクの稼動後、プライマリリンクはアイドル タイムアウトが切れた時点で再度チェックされます。 プライマリリンクが停止したままの場合、アイドル タイマーはリセットされます。 ルータはプライマリ リンクが再確立されたかどうかを定期的にチェックする必要があるため、ダイヤラのアイドル タイムアウトには小さい値を設定します。 プライマリ リンクが再確立されると、ルーティング プロトコルによってルーティング テーブルが更新され、すべてのトラフィックが再びプライマリ リンク上を通過します。 トラフィックはこの後、バックアップ リンクを通過しないため、アイドル タイムアウトになり、ルータはバックアップ リンクを非アクティブにします。

    注: 対象トラフィックを定義するときは、定期的な hello によるアイドル タイムアウトのリセットを防ぐために、ルーティング プロトコル トラフィックを拒否してください。

  • プライマリ リンクが再びアクティブになると、セカンダリ バックアップ リンクが接続解除されます。 ただし、プライマリ リンクが回復した後、バックアップ リンクが解除される前に遅延が生じるように、ディセーブル タイマーを実装できます。 この遅延タイマーはアイドル タイマーが終了すると始動し、プライマリ経路が稼動するまでの時間を提供します。 この遅延タイマーにより、特にフラッピング インターフェイスや経路が頻繁に変更されるインターフェイスの安定性が確保されます。

ダイヤラ ウォッチの機能の詳細については、「DDR バックアップ インターフェイス、フローティング スタティック ルート、およびダイヤラ ウォッチの比較」を参照してください。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

ネットワーク構成図

このドキュメントでは次の図に示すネットワーク構成を使用しています。

/image/gif/paws/5600/bri-backup-map-watch.gif

設定

この設定では BRI 回線を使用してシリアル リンクをバックアップしています。 また、この設定では 2 台のルータ間で Open Shortest Path First(OSPF)ルーティング プロトコルを使用しています。 バックアップ接続がアクティブになったら、新しいバックアップ経路を使用するようにルーティング テーブルが更新されることを確かめる必要があります。

コマンドの表記法の詳細は、「シスコ テクニカル ティップスの表記法」を参照してください。

maui-soho-01 (1600)
maui-soho-01#show running-config 
Building configuration...

Current configuration : 1546 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-soho-01
!
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for ppp calls.

enable secret 5 <deleted>!
username maui-nas-05 password 0 cisco

!--- Username for remote router (maui-nas-05) and shared secret.
!--- Shared secret (used for CHAP) must be the same on both sides.

ip subnet-zero
no ip finger
!
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.17.1.1 255.255.255.0
!
interface Ethernet0
 ip address 172.16.1.1 255.255.255.0
!
interface Serial0

!--- Primary link

 ip address 192.168.10.2 255.255.255.252
 encapsulation ppp
 ppp authentication chap
!
interface BRI0
 ip address 172.20.10.2 255.255.255.0

!--- IP address for the BRI interface (backup link)

 encapsulation ppp
 dialer idle-timeout 30

!--- Idle timeout (in seconds) for this backup link.
!--- Dialer watch checks the status of the primary link every time the
!--- idle-timeout expires.

 dialer watch-disable 15

!--- Delays disconnecting the backup interface for 15 seconds after the
!--- primary interface is found to be up, that is 15 seconds after the idle 
!--- timeout expired after the primary link came UP.

 dialer load-threshold 1 outbound

!--- This sets the load level for traffic at which additional connections
!--- will be added to the Multilink PPP bundle.
!--- Load level values range from 1 (unloaded) to 255 (fully loaded).

 dialer map ip 172.20.10.1 name maui-nas-05 broadcast 5551111

!--- Dialer map for the BRI interface of the remote router.

 dialer map ip 172.22.53.0 name maui-nas-05 broadcast 5551111

!--- Map statement for the route/network being watched by the
!--- dialer watch-list command
!--- This address must exactly match the network configured with the
!--- dialer watch-list command.
!--- When the watched route disappears, this dials the specified
!--- phone number.  

 dialer watch-group 8

!--- Enable dialer watch on this backup interface.
!--- Watch the route specified with dialer watch-list 8.

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255522220101 5552222
 isdn spid2 51255522230101 5552223

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required. 
!--- In such cases, omit the above two commands.

 ppp authentication chap

!--- Use CHAP authentication.

 ppp multilink

!--- Enable Multilink.

!
router ospf 5
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.17.1.0 0.0.0.255 area 0
 network 172.20.10.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
!
ip classless
no ip http server
!
dialer watch-list 8 ip 172.22.53.0 255.255.255.0

!--- This defines the route(s) to be watched.
!--- This exact route (including subnet mask) must exist in the 
!--- routing table. Use the dialer watch-group 8 command to apply this
!--- list to the backup interface.

access-list 101 remark Define Interesting Traffic
access-list 101 deny   ospf any any

!--- Mark OSPF as uninteresting.
!--- This will prevent OSPF hellos from keeping the link up.

access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

!--- Interesting traffic is defined by access-list 101.
!--- This is applied to BRI0 using dialer-group 1.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line vty 0 4
!         
end

maui-nas-05(3640)
maui-nas-05#show running-config 
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname maui-nas-05
!
aaa new-model
aaa authentication login default local
aaa authentication login NO_AUTHEN none
aaa authentication ppp default local

!--- This is the basic AAA configuration for PPP calls.

enable secret 5 <deleted> !
username maui-soho-01 password 0 cisco

!--- Username for remote router (maui-soho-01) and shared secret.
!--- Shared secret(used for CHAP authentication) must be the same on
!--- both sides.

!
ip subnet-zero
!         
isdn switch-type basic-ni
!
interface Loopback0
 ip address 172.22.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 172.22.53.105 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface BRI1/0

!--- Interface for backup link.

 ip address 172.20.10.1 255.255.255.0
 encapsulation ppp
 dialer map ip 172.20.10.2 name maui-soho-01 broadcast

!--- This is the dialer map with IP address and authenticated username
!--- for the remote destination. The name should match the authentication
!--- username provided by the remote side. The dialer map statement is
!--- used even though this router is not dialing out
!--- (that is, the phone number is not specified).

 dialer-group 1

!--- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-ni
 isdn spid1 51255511110101 5551111
 isdn spid2 51255511120101 5551112

!--- SPID information. Contact your telco for the SPID format.
!--- In many parts of the world, SPIDs are not required.
!--- In such cases, omit the above two commands.

 ppp authentication chap
 ppp multilink
!

!--- Output removed.

!
interface Serial2/0

!--- Primary link.

 ip address 192.168.10.1 255.255.255.252
 encapsulation ppp
 clockrate 64000
 ppp authentication chap
!

!--- Output removed.

!
router ospf 5
 network 172.20.10.0 0.0.0.255 area 0
 network 172.22.1.0 0.0.0.255 area 0
 network 172.22.53.0 0.0.0.255 area 0
 network 192.168.10.0 0.0.0.3 area 0
 default-information originate
!
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0/0
no ip http server
!
dialer-list 1 protocol ip permit

!--- This defines all IP traffic as interesting. OSPF does not need 
!--- to be marked uninteresting since this link does not dial out.
!--- Adjust the interesting traffic definition depending on your needs.

!
line con 0
 login authentication NO_AUTHEN
 transport input none
line 97 102
line aux 0
line vty 0 4
!
end

注: maui-nas-05 の設定は関連するバックアップが含まれていません コマンド。 maui-nas-05 の視点から、バックアップリンクはちょうどあります 他のダイヤルイン クライアント。 これはセントラルサイトの設定を簡約化できます 多くのデバイスが同じ本部にバックアップリンクを確立する状況 サイトをご覧ください。 バックアップシナリオでは、ただ一方開始を持っていることが理想的ダイヤルです、 もう一方が呼び出しを受け入れるだけにする間。

ダイヤラ ウォッチ コマンド

ダイヤラ ウォッチで使用できるコマンドの一覧を次に示します。 いくつかのこれらのコマンドは上記の設定にが含まれていました 他は参照用に提供されます。

  • dialer watch-list グループ番号 IP IP アドレス アドレス マスク の部分は次のとおりです。 IP を定義します 監視されるべきアドレスかネットワーク。 アドレスかネットワーク(正しいのと マスク)ルーティング テーブルで存在 する必要がある設定される。 また視聴できます dialer watch-list コマンドを用いるいくつものルート。 次に例を示します。

    dialer watch-list 1 ip 10.1.1.0 255.255.255.0
    dialer watch-list 1 ip 10.1.2.0 255.255.255.0
    dialer watch-list 1 ip 10.1.3.0 255.255.255.0       
    
    
  • dialer watch-group グループ番号 の部分は次のとおりです。 のイネーブル ダイヤラ ウォッチ バックアップ インターフェイス。 これらのモジュールでの グループ 数値 ここでは使用される一致します グループ番号 ダイヤラの 監視されるべきルーティングを定義する視聴リスト コマンド。 ダイヤラ 特定のグループ数との視聴グループ コマンドはあるただ場合もあります 1 つのインターフェイスで設定される。 これはルータが倍数を使用できないことを意味します 特定ルートにバックアップを提供するインターフェイス。 ただし、1 つのインターフェイスはできます マルチプルダイヤラ視聴グループ コマンドを、と持って下さい 異なるグループ番号。 従って、1 つのインターフェイスがバックアップを提供するのに使用することができます いくつものルートのため。

  • dialer watch-disable の部分は次のとおりです。 ディセーブル 遅延時間をに適用して下さい します。 プライマリインターフェイスが回復 した後、この遅延は防ぎます 特定の期間のためのバックアップインターフェイスの接続解除。 この遅延 タイマーはアイドルタイマーが切れる、プライマリのステータスとき開始し ルートは稼働するためにチェックされ、あります。 この遅延は安定性を確保できます 特に頻繁なルートを経験するフラップ インターフェイスかインターフェイスのために 設定を保存します。

  • dialer watch-list グループ番号 delay route-check initial : これは、 コマンドはプライマリ ルートがの後に稼働しているかどうか確認することをルータが可能にします ルータの初期スタートアップは完了した、タイマーは(秒で)切れます。 このコマンドなしで、ダイヤラ ウォッチはプライマリ ルートがあるときだけ引き起こされます ルーティング テーブルから取除かれる。 プライマリ リンクがの間にアップに失敗すれば ルータの初期スタートアップはルーティング テーブルに、ルート決して追加されません そしてそれ故に監視することができません。 従って、このコマンドで、ダイヤラ ウォッチは 頭文字の間にプライマリリンク失敗の場合にバックアップリンクにダイヤルして下さい ルータの開始して下さい。

確認

詳細については、 「GUI を使用した BRI のための show isdn status コマンド を参照してください。

このセクションは確認するのに使用できる情報を提供します 設定はきちんと機能しています。

ある種のshowコマンドはによってサポートされます アウトプットインタープリタは奪取 しました、分析を表示することを許可する showコマンド出力

  • show dialer [interface 型 数] -一般的な診断情報をのための表示する DDR のために設定されるインターフェイスはタイマーの設定を表示し、 接続時間の前の時間。 次のメッセージを確認してください。

    • "Dialer state is data link layer up" - ダイヤラが正常にアップしました。

      • 「Physical layer up」-行プロトコルは、ネットワーク起動しました 制御プロトコル(NCP)は。

    • 「Dial reason」はこれ送信元 および 宛先アドレスをの表示します パケット ダイヤルを始める。

  • show isdn status -それにルータを確認して下さい ISDNスイッチと正しく交信しています。 このコマンドはまた表示するものです アクティブ コールの数次 の メッセージを確認する必要があります:

    • "Layer 1 Status is ACTIVE",

    • "Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED"

Show コマンドの出力例

クライアントのルーティング テーブル、プライマリの maui-soho-01 (1600)、 リンク機能は下記のように示されています:

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - ISIS level-1, L2 - ISIS level-2, ia - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

     192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.10.0/30 is directly connected, Serial0
C       192.168.10.1/32 is directly connected, Serial0
     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/24 is subnetted, 1 subnets
C       172.20.10.0 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/74] via 192.168.10.1, 02:48:10, Serial0
O       172.22.1.1/32 [110/65] via 192.168.10.1, 02:48:10, Serial0
O*E2 0.0.0.0/0 [110/1] via 192.168.10.1, 02:48:10, Serial0

上に示されている show ip route の出力 プライマリ リンク(シリアルを使用して同位から学習される OSPF ルーティングを表示する 0)。 ことに視聴されるルート注意して下さい(255.255.255.0) マスクの 172.22.53.0 ルーティング テーブルの存在。 これはダイヤラ ウォッチが機能することができるように確認する必要があります 正しく。

この場合プライマリ リンクをダウンさせ、バックアップリンクをアクティブにします。 After バックアップリンクはアクティブになります、OSPF テーブルは新しいルーティング交換され、 バックアップリンクを使用するインストールされています。 トラフィックはバックアップリンクを渡って今渡ります。

次に例を示します。

maui-soho-01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - ISIS level-1, L2 - ISIS level-2, IA - ISIS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.20.10.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.1.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet0
     172.20.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.20.10.0/24 is directly connected, BRI0
C       172.20.10.1/32 is directly connected, BRI0
     172.22.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       172.22.53.0/24 [110/1572] via 172.20.10.1, 00:01:26, BRI0
O       172.22.1.1/32 [110/1563] via 172.20.10.1, 00:01:27, BRI0
O*E2 0.0.0.0/0 [110/1] via 172.20.10.1, 00:01:27, BRI0

上記の出力はルーティング テーブルがすべてアップデートされたことを示したものです、 トラフィックは使用しますバックアップリンク(BRI0)を

show dialer コマンドはに使用することができます DDRインターフェイスがきちんとアップしたことを確認して下さい。 ことに BRI インターフェイス注意して下さい 監視されたルートは失われたことルータが検出するのでダイヤルされました。

maui-soho-01#  show dialer

BRI0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
5551111                 10          0    00:01:49       successful
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on watched route loss
Time until disconnect 11 secs
Connected to 5551111 (maui-nas-05)

BRI0:2 - dialer type = ISDN
Idle timer (30 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

トラブルシューティング

ダイヤラ ウォッチのトラブルシューティング

設定し、DDR接続が前にきちんとはたらいていることを確認して下さい ダイヤラ ウォッチを設定します。 これは DDR を隔離し、解決するのを助けます バックアップ関連問題に取り組む前に問題。 ダイヤラ ウォッチを設定した場合 Cisco IOS を使用することが再開されますか。 ソフトウェア リリース 12.1(7) または それ 以上。 ここでは、いくつかの問題と、考えられる解決方法について説明します。

問題: ルータはバックアップリンクに時ダイヤルしません プライマリ リンクはダウン状態になります。

可能 な 解決策 #1: 提示 IP を使用して下さい ルートが存在を視聴していることを確認する route コマンド ルーティング テーブル。 ダイヤラ ウォッチのために設定されるルートは完全に一致する必要があります ルーティング テーブルの 1 つ。 これはそれを確認することがネットワーク、また含まれています マスクは同一です。 たとえば、ルーティング テーブルが 10.0.0.0/8 を示す場合 dialer watch-list を 1 IP 10.0.0.0 使用します 255.255.255.0 (10.0.0.0/24 である)、ダイヤラウォッチ機能 10.0.0.0/8 がルーティング テーブルにもはやないこと検出する。

可能 な 解決策 #2: 2 ダイヤラマップがあることを確認して下さい バックアップインターフェイスの文。

  • 規定 される ルート/ネットワークのための 1 つのマップ ステートメントがあるはずです dialer watch-list コマンド

  • 遠隔の IP アドレスのための 1 つのマップ ステートメントがあるはずです ルータのインターフェイス。

考えられる解決方法 3: コマンドを設定して下さい dialer watch-list グループ番号遅延 route-check 最初のが原因です。 詳細については、 section dialer watch コマンドのための 詳細。

問題: バックアップリンクはルーティング確立されません 情報はバックアップリンクを渡って送信されます。

考えられる解決方法 1: ことをバックアップインターフェイス IP 確認して下さい ネットワークはルーティングプロトコルコンフィギュレーションに含まれています

問題: バックアップリンクは時無効になりません プライマリ リンクは回復 します。

注: ダイヤラ ウォッチによって制御するのに、関連 トラフィックがただ使用されています それから間隔を制御するアイドルタイムアウトはのステータスをポーリングするのが常でありました プライマリ ルート。

可能 な 解決策 #1: ダイヤラを下げて下さい アイドルタイムアウト。 デフォルトは 120 秒です、しかしに希望する場合もあります 必要によってこの値を下げて下さい。

可能 な 解決策 #2: 提示を使用して下さい アイドルタイムアウトを確認する dialer コマンドはリセットされていません。

関連 トラフィック (interesting traffic) 定義を変更して下さい(で設定される より制限する dialer-list コマンド)。 ルーティング プロトコル トラフィックはマークされた不要であるはずです。

最終的な解決策として、不要ようにすべての IP トラフィックを設定できます コマンド dialer-list 1 protocol ip deny の使用。 この関連 トラフィック (interesting traffic) 定義によって、アイドルタイムアウトは決してリセットされません、 そしてルータは規定 されたでプライマリ リンクのステータスをチェックします 間隔。

考えられる解決方法 3: ことを確認して下さい バックアップリンクはの観点からプライマリ リンクよりより少なく好ましいです 使用中のルーティング プロトコル。 これはプライマリ リンクが回復 するときように、あります ダイナミック ルーティング プロトコルはにおよびないプライマリをバックアップリンク好みます 2 つのリンクを渡るロード バランス。 これをする失敗によりバックアップリンクを引き起こす場合があります あくまでアップ状態に留まるため。 show ip route をに使用して下さい ルータがルーティングするのに両方のプライマリ および バックアップ リンクを使用していたかどうか確認して下さい ルータ間のトラフィック。 このような場合ルータは同一保存します 二重ルート; プライマリのための 1 つおよび使用できるバックアップリンクのための 1 バックアップリンクがより少しであることを確認するメソッド次のいずれか ルーティング プロトコルの観点から好ましい: 帯域幅遅延、または Distance。 Cisco IOSソフトウェアコマンドを参照して下さい 参照詳細については。

一般的なISDNレイヤ 1,2 および解決する 3 に関しては資料を参照して下さい show isdn status の使用 BRI トラブルシューティングのためのコマンド

トラブルシューティングのためのコマンド

ある種のshowコマンドはによってサポートされます 分析を表示することを許可する Output Interpreter ツール、 showコマンド出力

注: debug コマンドを発行する前に、参照して下さい 重要な情報 Debug コマンド

  • debug dialer -これが DDR を表示するのに使用されています ダイヤラーインターフェイスで受信されるパケットについての情報。

  • debug isdn q931 -これはコールセットアップを表示します そして ISDNネットワーク接続(ルータ間の 3) 層の中断 して下さい ISDNスイッチ。

  • debug ppp negotiation -これディスプレイ PPP コンポーネントをネゴシエートしている間 PPP トラフィックおよび交換の情報 リンク制御プロトコル (LCP)、認証および NCP を含んで。 成功したの PPPネゴシエーションは最初に LCP 状態、そして認証するを、および最終的に開きます NCP をネゴシエートして下さい。

  • debug ppp authentication -これディスプレイ チャレンジ ハンドシェイクを含む PPP認証 プロトコルメッセージ、 認証プロトコル(CHAP)パケット交換およびパスワード認証 プロトコル(PAP)交換。 確認するために失敗をことを chap 観察すれば ユーザ名 および パスワードは正しく設定されます。

  • debug ppp error -これはプロトコルを表示する エラーおよび PPP 接続ネゴシエーションと関連付けられるエラー統計情報 オペレーション。

debug 出力例

debug dialer 出力は下記の示したものです 失われたルートを認識するプライマリ リンク失敗およびダイヤラ ウォッチ。 指定された更新日になると、 それからバックアップリンクを始めます。 後アイドルタイムアウトが期限切れになるたびに、 プライマリ リンクがダウンしているかどうかルータ チェック。 プライマリ リンクがにあれば 、ダイヤラ ウォッチ切断しますディセーブル タイマーの後でバックアップリンクを稼働して下さい 切れます。 デバッグでは、それらとして各メッセージのタイムスタンプに注目して下さい あるアイドルタイムアウトおよびさまざまなタイマーで情報を提供できます アクティブ。

maui-soho-01#debug dialer
Dial on demand events debugging is on
maui-soho-01#
03:47:07: %LINK-3-UPDOWN: Interface Serial0, changed state to down

!--- Primary Link is brought down

03:47:07: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from FULL to DOWN,
 Neighbor Down: Interface down or detached
03:47:07: DDR: Dialer Watch: watch-group = 8

!--- Use dialer watch-group 8. 

03:47:07: DDR:    network 172.22.53.0/255.255.255.0 DOWN,
03:47:07: DDR:    primary DOWN

!--- The primary network is down.

03:47:07: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

!--- Dialing Reason is that the primary route is down.

03:47:07: DDR: Dialer Watch: watch-group = 8, 
03:47:07: DDR:    dialing secondary by dialer map 172.22.53.0 on BR0

!--- Indicates which dialer map statement is used for the dialout.

03:47:07: BR0 DDR: Attempting to dial 5551111
03:47:08: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
03:47:08: BR0:1 DDR: Dialer Watch: resetting call in progress
03:47:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to down
03:47:08: BR0:1 DDR: dialer protocol up
03:47:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state
 to up
03:47:14: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 5551111 maui-nas-05

!--- BRI link is connected.

03:47:17: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on BRI0 from LOADING to FULL,
 Loading Done
03:47:38: BR0:1 DDR: idle timeout

!--- Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:47:38: DDR: Dialer Watch: watch-group = 8
03:47:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:47:38: DDR:    primary DOWN

!--- The primary network is still down.

03:48:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:48:08: DDR: Dialer Watch: watch-group = 8
03:48:08: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:48:08: DDR:    primary DOWN

!--- The primary network is still down.

...
...
...
03:50:38: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.
!--- The router will check to see if the primary link has come up.

03:50:38: DDR: Dialer Watch: watch-group = 8
03:50:38: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists (due to the active backup link).

03:50:38: DDR:    primary DOWN

!--- The primary network is still down.

03:50:44: %LINK-3-UPDOWN: Interface Serial0, changed state to up

!--- Primary link is re-established.

03:50:45: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state
 to up
03:50:54: %OSPF-5-ADJCHG: Process 5, Nbr 192.168.10.1 on Serial0 from LOADING
 to FULL, Loading Done
03:51:08: BR0:1 DDR: idle timeout

!--- Next Idle Timeout (30 seconds) expires.


!--- The router will check to see if the primary link has come up.

03:51:08: DDR: Dialer Watch: watch-group = 8
03:51:08: DDR:    network 172.22.53.0/255.255.255.0 UP,

!--- A route for the watched network exists. 

03:51:08: DDR:    primary UP

!--- The primary network is UP. Dialer watch will initiate a disconnect of


!--- the backup link.

03:51:08: BR0:1 DDR: starting watch disable timer

!--- Delays disconnecting the backup interface after the primary interface recovers.
!--- This timer is 15 seconds as configured with the dialer watch-disable 15 command

03:51:23: BR0:1 DDR: watch disable timeout

!--- 15 second disconnect delay expires. The link will be brought down.

03:51:23: BR0:1 DDR: disconnecting call

!--- Backup link is disconnected.

03:51:23: BR0:1 DDR: Dialer Watch: resetting call in progress
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP

!--- The primary network is UP.

03:51:23: %ISDN-6-DISCONNECT: Interface BRI0:1  disconnected from 5551111
 maui-nas-05, call lasted 255 seconds
03:51:23: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
03:51:23: BR0:1 DDR: disconnecting call
03:51:23: DDR: Dialer Watch: watch-group = 8
03:51:23: DDR:    network 172.22.53.0/255.255.255.0 UP,
03:51:23: DDR:    primary UP
03:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
  changed state to down
maui-soho-01#

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 5600