ダイヤルとアクセス : 非同期接続

ターミナル/コミュニケーション サーバの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2009 年 1 月 14 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

ターミナル サーバまたはコミュニケーション サーバは、通常、複数のデバイスにアウトオブバンド アクセスを提供します。 ターミナル サーバは低速の非同期ポートを複数備えたルータで、モデムや、ルータまたはスイッチのコンソール ポートなど、他のシリアル デバイスに接続します。

ターミナル サーバを使用すると、多数のデバイスのコンソール ポートに 1 箇所からアクセスできます。 また、各デバイスの補助ポートにモデムを取り付けるなどのバックアップのシナリオを設定する必要がなくなります。 さらに、ターミナル サーバの補助ポートに 1 台のモデムを構成して、ネットワーク接続の障害が発生したときに他のデバイスへのダイヤルアップ サービスを提供できます。

このドキュメントでは、リバース Telnet を使用して他のルータのコンソール ポートにのみアクセスするターミナル サーバの設定方法について説明しています。 リバース Telnet を使用すると、Telnet 元のデバイスから別のインターフェイスを介して外部に Telnet 接続を確立できます。 逆 Telnet に関する詳細については Telnetセッションを管理すること参照して下さい。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

配線

Cisco 2509~2512 シリーズ ルータは、68 ピン コネクタとブレークアウト ケーブルを使用します。 このケーブル(CAB-OCTAL-ASYNC)によって、各 68 ピン コネクタで 8 つの RJ-45 ロール型ケーブル非同期ポートが提供されます。 各 RJ-45 ロール型ケーブルの非同期ポートを、デバイスのコンソール ポートに接続できます。 2511 ルータでは、最大 16 台のデバイスにリモートからアクセスできます。 また、Cisco 2600 および 3600 シリーズ ルータでは、これと同じ機能を実現するため、NM-16A または NM-32A 高密度非同期ネットワーク モジュールが使用できます。 ケーブル接続に関する詳細については接続しよう参照して下さい: コンソール および AUX ポートのためのシリアルケーブルガイドおよびケーブリング ガイド

注: 68 ピン コネクタを接続する非同期ポートは、Data Terminal Equipment(DTE; データ端末装置)デバイスです。 DTE デバイスと DTE デバイス間ではロール型(ヌル モデム)ケーブルが必要であり、DTE デバイスと Data Circuit-Terminating Equipment(DCE; データ回線終端装置)デバイス間ではストレート型ケーブルが必要です。 CAB-OCTAL-ASYNC ケーブルはロール型です。 このため、各ケーブルを RJ-45 インターフェイス付きデバイスのコンソール ポートに直接接続できます。 ただし、接続するデバイスのコンソール ポートが 25 ピン インターフェイス(DCE)である場合は、「Modem」(反転させる場合は「roll」)とマークされている RJ-45 から 25 ピンへのアダプタを使用して接続を行います。

Cisco ルータおよびスイッチのコンソールと補助ポートのポート タイプを次の表に示します。

インターフェイス タイプ DB25 インターフェイス RJ-45 インターフェイス
コンソール DCE DTE
AUX DTE DTE

設計戦略

どこからでもターミナル サーバにアクセスできるように、ターミナル サーバを設定します。 ターミナル サーバにアクセスできるようにするには、登録されたパブリックのインターネット アドレスを割り当て、ターミナル サーバをファイアウォールの外側に配置します。 このようにすると、ファイアウォールに問題が発生しても接続が遮断されません。 常に、ターミナル サーバへの接続を維持し、接続されたデバイスにアクセスできます。 セキュリティが心配な場合は、ターミナル サーバにアクセスできるアドレスを特定のアドレスのみに制限するよう、アクセス リストを設定できます。 また、セキュリティ ソリューションの堅牢性を高めるために、RADIUS や TACACS+ などのサーバベースの Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)を設定することも可能です。 AAA に関する詳細については、認証、許可、アカウンティング(AAA)を参照して下さい。

(インターネットを経由した)プライマリ接続がダウンした場合に備えて、ターミナル サーバの AUX ポートにダイヤル バックアップ用のモデムを構成できます。 このようなモデムによって、デバイスごとにダイヤル バックアップを設定する必要がなくなります。 ターミナル サーバは、非同期ポート経由で他のデバイスのコンソール ポートに接続されます。 補助ポートにモデムを接続する方法については、『モデム - ルータ間接続ガイド』を参照してください。

ip default gateway 文を使用してインターネット上のネクストホップ ルータをポイントします。 このコマンドにより、ルーティングが有効でない場合でも、インターネットを介してターミナル サーバへ接続されます。 たとえば、停電後のリブート障害によって、ターミナル サーバが ROM モニタ(ROMMON)モードになった場合などです。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク構成図

このドキュメントでは、次のネットワーク構成を使用しています。

http://www.cisco.com/c/dam/en/us/support/docs/dial-access/asynchronous-connections/5466-Com-Srv.gif

設定

このドキュメントでは次の設定を使用しています。

  • Cisco 2511

Cisco 2511
aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- The host 3600-3 is connected to port 14 of the comm server.


!--- Ensure that the IP address is that of an interface on the comm server.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- This address is used in the IP host commands.


!--- Work with loopback interfaces, which are virtual and always available.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Use a public IP address to ensure connectivity. 

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- This is the default gateway when routing is disabled.


!--- For example, if the router is in boot ROM mode.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Set the default route for the external network.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- The session times out after 20 minutes of inactivity. 

no exec

!--- Unwanted signals from the attached device do not launch.
 

!--- An EXEC session ensures that the line never becomes unavailable 


!--- due to a rogue EXEC process.

 exec-timeout 0 0

!--- This disables exec timeout transport input all.


!--- Allow all protocols to use the line.


!--- Configure lines 1 - 16 with at least transport input Telnet.

line aux 0

!--- Auxiliary port can provide dial backup to the network.


!--- Note: This configuration does not implement modem on AUX port modem InOut. 


!--- Allow auxiliary port to support dialout and dialin connections.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted> 
login
!
end

注: 3600 をアクセス サーバとして使用する場合、回線番号についての詳細は『Cisco 3600 シリーズ ルータにおける非同期回線の番号設定』を参照してください。

コマンドの概要

ip host — ホスト キャッシュの静的ホストの name-to-address マッピングを定義するのにこのコマンドを使用して下さい。 name-to-address マッピングを削除するために、このコマンドの no 形式を使用して下さい。

  • ip host name [tcp-port-number] address1 [address2...address8]

    • name:このフィールドはホストの名前を示します。 接続先ルータの実際の名前と一致する必要はありません。 ただし、リバース Telnet で使用する名前を入力します。 このコマンドと name フィールドを使用すると、リモート デバイスの実際のポート番号を把握しておく必要がなくなります。

    • tcp-port-number:EXEC connect または telnet コマンドとともに定義済みのホスト名を使用する場合に、接続先となる TCP ポート番号です。 上記の設定例では、リバース Telnet を使用するために、ポート番号はすべて 2000 + 回線番号になっています。

    • address1:関係付けられた IP アドレスです。 上記の設定例では、ループバック IP アドレスを使用しています。

transport input:ルータの特定の回線に接続する場合に使用するプロトコルを定義します。

  • トランスポート入力{すべて | lat | mop | NASI | なし | パッド | rlogin | telnet | v120}

    • すべては『all protocols』 を選択 します。

    • none:回線でプロトコルが選択されることを禁止します。 この場合、ポートは着信接続に使用できなくなります。

    注:  今回の設定例の場合、非同期回線では transport input telnet の最低限の設定を使用しています。 このため、非同期回線のデバイスに Telnet 接続できます。

telnet:この EXEC コマンドを使用して、Telnet 対応のホストにログインします。

  • telnet host [port] [keyword]

    • host:ホスト名または IP アドレスです。 ip host コマンドで定義した各種 name フィールドのいずれかになります。

    • port:10 進数で表した TCP ポート番号です。 TCP ポート番号のデフォルトは、ホストの Telnet ルータ ポート(10 進数の 23)です。 リバース Telnet では、ポート番号は 2000 + 回線番号にする必要があります。 上記の設定例では、回線番号は 1 ~ 16 です。 使用可能な回線を表示するには、show line EXEC コマンドを使います。

アクティブ セッション間の切り替え

アクティブ セッションを切り替えるには、次の手順を実行します。

  1. 現在のセッションを終了するには、エスケープ シーケンス Ctrl+Shift+6 を押してから x を押します。

  2. オープンな接続をすべて表示するには、show sessions コマンドを使用します。

    aus-comm-server#show sessions 
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    注: アスタリスク(*)は、現在のターミナル セッションを意味します。

  3. セッション(CONN)番号を入力すると、対応するデバイスに接続されます。 たとえば、2511-1 に接続するには、接続番号である 1 を入力します。 ただし、Return キーを押すと、現在のターミナル セッション(この例ではルータ 2511-3)に接続されます。

アクティブ セッションの終了

特定の Telnet セッションを終了するには、次の手順を実行します。

  1. 現在の Telnet セッションを終了するには、エスケープ シーケンス Ctrl+Shift+6 を押してから x を押します。

    注: Telnet セッションを停止させるエスケープ シーケンスが確実に実行できることを確認してください。 ターミナル エミュレータ パッケージの中には、正しいシーケンス Ctrl-Shift-6 とそれに続く x を送信できないものもあります。

  2. オープンな接続をすべて表示するには、show sessions コマンドを発行します。

  3. 必要なセッションを接続解除するには、disconnect [connection] コマンドを発行します。

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • show ip interface brief:Telnet セッションに使用するインターフェイスが up であるかどうかを示します。

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティング手順

設定をトラブルシューティングするには、次の手順を実行します。

ip host コマンドで設定した名前を使用して選択したルータに接続できない場合は、次の点をチェックしてください。

  1. ポートのアドレスが正しく設定されているかどうかを確認します。

  2. リバース Telnet に使用するアドレス(インターフェイス)が up/up であるかどうかを確認します。 この情報は、show ip interface brief コマンドの出力で提供されます。 常に up になっているので、ループバックを使用することを推奨いたします。

  3. 配線タイプが適切であることを確認します。 たとえば、クロスケーブルを使用してケーブルを延長しないでください。 詳細は、「配線」セクションを参照してください。

  4. 直接接続をテストするには、IP アドレス ポートへの Telnet 接続を確立します。 外部デバイスとターミナル サーバの両方から Telnet を実行する必要があります。 たとえば、telnet 172.21.1.1 2003 を実行します。

  5. ターゲット デバイスの行の下に、transport input telnet コマンドが記述されていることを確認します。 ターゲット デバイスは、ターミナル サーバに接続されているデバイスです。

  6. ターゲット ルータのコンソールに直接接続するには、PC/ダム ターミナルを使用します。 ターゲット ルータは、ターミナル サーバに接続されているデバイスです。 この手順を実行すると、ポートに問題があるかどうかがわかります。

  7. 接続解除された場合は、タイムアウトをチェックします。 タイムアウトを削除するか、または調整できます。

    注: 認証エラーが発生する場合は、第 1 認証(設定されている場合)がターミナル サーバによって実行されるもので、第 2 認証(設定されている場合)が接続先のデバイスによって実行されるものであることに留意してください。 ターミナル サーバと接続デバイスの両方で、AAA が適切に設定されているかどうかを確認してください。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 5466