Cisco インターフェイスとモジュール : Cisco コンテンツ スイッチング モジュール

コンテンツ スイッチング モジュールでのセキュア(ルータ)モードの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 1 月 15 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Content Switching Module(CSM; コンテント スイッチ モジュール)では、ネットワーク ユーザとサーバ ファーム間での高パフォーマンスの接続を、レイヤ 4 から 7 の情報に基づいて実現します。 実サーバのグループ(サーバ ファーム)を 1 つのサーバのインスタンス(仮想サーバ)として表現し、サーバのロード バランシング方法のいずれかを選択してサーバ ファームへのトラフィックのバランスを取り、個々のサーバ(スティッキ接続)やサーバ ファーム(ポリシー)へのトラフィックを制限します。 この設定例では、Catalyst 6000 ファミリの CSM におけるサーバ ロード バランシング(SLB)の設定方法について説明します。

Cisco IOS を実行できませんか。 同じの SLB ソフトウェアは CSM として切り替えます。 設定前に ip slb mode [csm | rp] コマンドを発行して、CSM モードを設定する必要があります。 ip slb mode コマンドでは、rp 引数はデフォルトです。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • MSFC1 を搭載したスーパバイザ エンジン 1 用(c6sup11-jsv-mz.121-8.EX) Catalyst 6000 ファミリ スーパーバイザ IOS ソフトウェア リリース 12.1(8)EX

  • Catalyst 6000 ファミリ CSM ソフトウェア リリース 2.1(0)(c6slb-apc.2-1-1.bin)

CSM は、Cisco IOS リリース 12.1(6)E 以降で動作します。 スーパーバイザ エンジン 2 を使用している場合は、Cisco IOS リリース 12.1(8a)E 以降を使用する必要があります。

操作モード

CSM を介したクライアントとサーバの接続では、レイヤ 2 またはレイヤ 3 スイッチングを使用できます。 クライアントは、クライアント側の VLAN に接続し、サーバはサーバ側の VLAN に接続します。 サーバとクライアントは異なるサブネット上にあります。 サーバを 2 ホップ以上離して配置し、ルータを経由してサーバ側の VLAN に接続することもできます。 この場合、サーバのデフォルト ゲートウェイと、サーバから CSM サーバ側の VLAN へのネットワークを介したルーティングは、サーバから CSM を介してすべてのロード バランスされたトラフィックを送り出すか、サーバ ファームのクライアント NAT を、サーバ ファーム内のサーバ宛のすべてのトラフィック用に CSM で設定する必要があります。 クライアントは VIP アドレスに要求を送信 します、か。 そして CSM は要求を満たすことができるサーバに要求を転送します。 サーバは CSM に応答を転送し、さらに CSM がこの応答をクライアントに転送します。

クライアント側とサーバ側の VLAN が異なるサブネット上にある場合は、CSM をセキュア(ルータ)モードに設定できます。 この設定例では、セキュア(ルータ)モード設定を中心に説明します。 クライアント側とサーバ側の VLAN が同じサブネット上にある場合は、CSM をシングル サブネット(ブリッジ)モードで動作するように設定できます。 詳細については、次の設定例を参照してください。

ネットワーク構成図

クライアント側とサーバ側の VLAN は、セキュア(ルータ)モードの異なるサブネット上にあります。 このダイアグラムでは、セキュア(ルータ)モードの設定の設定方法を示しています。

csm_router.gif

設定

セキュア(複数サブネット)モードの CSM を設定するには、次の手順を実行します。

  1. CSM モードを選択します。

    cat(config)# ip slb mode csm
    
  2. クライアントとサーバの VLAN をデータベース内に作成します。 VLAN データベース モードを終了すると、設定変更が適用されます。

    cat# vlan database 
    cat(vlan)# vlan 100 
    VLAN 100 added: Name: VLAN0100 
    cat(vlan)# vlan 200 
    VLAN 200 added: Name: VLAN0200 
    cat(vlan)# exit 
    APPLY completed. 
    Exiting....
  3. 対応する VLAN にクライアント(アップリンク)を接続する物理インターフェイスを設定します。

    cat(config)# inter fastEthernet 2/1 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 100 
    cat(config-if)# no shut
    
  4. 対応する VLAN にサーバを接続する物理インターフェイスを設定します。

    cat(config)# inter fastEthernet 2/3 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown 
    cat(config)# inter fastEthernet 2/4 
    cat(config-if)# switchport 
    cat(config-if)# switchport access vlan 200 
    cat(config-if)# no shutdown
    
  5. クライアント側の VLAN とゲートウェイを作成します。

    cat(config)# ip slb vlan 100 client 
    cat(config-slb-vlan-client)# ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)# gateway 172.17.63.210
    
  6. サーバ側の VLAN を作成します。

    cat(config)# ip slb vlan 200 server 
    cat(config-slb-vlan-server)# ip address 10.1.1.251 255.255.255.0 
    cat(config-slb-vlan-server)# alias 10.1.1.250 255.255.255.0
    
  7. serverfarm を作成します。

    cat(config)# ip slb serverfarm WWWFARM 
    cat(config-slb-sfarm)# real 10.1.1.3 
    cat(config-slb-real)# inservice 
    cat(config-slb-real)# real 10.1.1.5 
    cat(config-slb-real)# inservice
    
  8. vserver を作成して serverfarm に関連付けます。

    cat(config)# ip slb vserver SERVER 
    cat(config-slb-vserver)# virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)# serverfarm WWWFARM 
    cat(config-slb-vserver)# inservice
    

Cisco Catalyst 6500 と CSM を使用したサーバのロード バランシングの設定例を次に示します。

CSM(WS-X6066-SLB-APC)実行コンフィギュレーション
Current configuration : 3791 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot buffersize 126968 
boot system flash slot0:c6sup11-jsv-mz.121-8.EX.bin 
! 
redundancy 
?main-cpu 
? auto-sync standard 
ip subnet-zero 
! 


!--- SLB mode. 

ip slb mode csm 
! 


!--- Client side VLAN configuration.? 
!--- Important: Gateway address pointing to interface VLAN 100.
 
ip slb vlan 100 client 
?ip address 172.17.63.217 255.255.255.192 
?gateway 172.17.63.210 
! 


!--- Server side VLAN configuration.?
 
ip slb vlan 200 server 
?ip address 10.1.1.251 255.255.255.0 
?alias 10.1.1.250 255.255.255.0 
! 


!--- Serverfarm configuration.
 
ip slb serverfarm WWWFARM 
?nat server? 
?no nat client 
real 10.1.1.3 
? inservice 
?real 10.1.1.5 
? inservice 
! 


!--- Vserver configuration.?
 
ip slb vserver SERVER 
?virtual 172.17.63.241 tcp www 
?serverfarm WWWFARM 
?inservice 
! 
interface GigabitEthernet1/1 
?no ip address 
?shutdown 
! 
interface GigabitEthernet1/2 
?no ip address 
?shutdown 
! 


!--- Client (uplink) connected to FastEthernet 2/1. 

interface FastEthernet2/1 
?no ip address 
?switchport 
?switchport access vlan 100 
?switchport mode access 
! 
interface FastEthernet2/2 
?no ip address 
?shutdown 
! 


!--- Servers connected to FastEthernet 2/3 and 2/4.
? 
interface FastEthernet2/3 
?no ip address 
?switchport 
?switchport access vlan 200 
?switchport mode access 
! 
interface FastEthernet2/4 
?no ip address 
?switchport 
?switchport access vlan 200 
?switchport mode access ... 
interface FastEthernet2/48 
?no ip address 
?shutdown 
! 
interface Vlan1 
?no ip address 
?shutdown 
! 
interface Vlan100 
?ip address 172.17.63.210 255.255.255.192 
! 
ip default-gateway 172.17.63.193 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
line con 0 
line vty 0 4 
?login 
! 
end

show コマンド

注: 特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

show ip slb status コマンド

show ip slb status コマンドでは、SLB モジュールのステータスが表示されます。 モジュールはオンライン状態でなければなりません。

cat6#show ip slb status?
SLB Module is online in slot 3.?
Configuration Download state: COMPLETE, SUCCESS

show ip slb vserver コマンド

show ip slb vserver コマンドでは、仮想サーバの情報が表示されます。 仮想サーバの状態と接続数も確認できます。

cat6#show ip slb vserver
slb vserver?? prot??? virtual????????????? vlan?? state???????? conns??????????
---------------------------------------------------------------------------
SERVER??????? TCP???? 172.17.63.241/32:80? ALL??? OPERATIONAL?? 0

show ip slb reals コマンド

show ip slb reals コマンドでは、それぞれの実サーバの情報が表示されます。表示には、それぞれのサーバが位置するサーバ ファームやサーバの状態、しきい値、および接続の情報などが含まれます。

cat6#show ip slb reals
real????????????????? server farm????? weight? state????????? conns
-------------------------------------------------------------------
10.1.1.5????????????? WWWFARM????????? 8?????? OPERATIONAL??? 0????????
10.1.1.3????????????? WWWFARM????????? 8?????? OPERATIONAL??? 0

show ip slb serverfarms コマンド

show ip slb serverfarms コマンドでは、サーバ ファームの情報が表示されます。 このコマンドでは、ロード バランシングに使用されているプレディクタが表示されます。 この例では、デフォルトのラウンド ロビンが使用されています。

cat6#show ip slb serverfarm
server farm??? predictor??? nat?? reals?? redirect? bind id
-------------------------------------------------------------
WWWFARM??????? RoundRobin?? S???? 2?????? 0???????? 0

show ip slb vlan コマンド

show ip slb vlan コマンドでは、クライアントとサーバに関する VLAN 情報が表示されます。

cat6# show ip slb vlan
vlan?? IP address?????? IP mask??????????? type??
---------------------------------------------------
100??? 172.17.63.217??? 255.255.255.192??? CLIENT
200??? 10.1.1.251?????? 255.255.255.0????? SERVER

トラブルシューティング

次に示すように ping slb コマンドを使用して、Catalyst 6500 から実サーバのみを ping できます。

cat6#ping slb 10.1.1.3?
IP address?????? Reachable?
--------------------------?
10.1.1.3???????? Yes

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 5448