IP : ボーダー ゲートウェイ プロトコル(BGP)

BGPへのOSPF ルートの再配送の理解

2014 年 9 月 6 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2005 年 8 月 10 日) | 英語版 (2014 年 8 月 12 日) | フィードバック


目次


概要

このテクニカル ノートでは、Open Shortest Path First(OSPF)から Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)への再配布が Cisco ルータ上でどのように動作するかについて説明しています。 OSPF から BGP への再配布の動作については、RFC 1403 に概要が説明されています。leavingcisco.com

OSPF ルートには次の数種類があります。

  • エリア内— multiarea OSPFネットワークでは、エリアの内で起きるルーティングはイントラエリア ルートと同じエリアのルータによって知られています。 show ip route コマンドの出力では、これらのルートには O というフラグが付いています。

  • エリア間—ルートが OSPF領域 ボーダールータ(ABR)を交差させる時、ルートは OSPF エリア間 ルートとして知られています。 show ip route コマンドの出力では、これらのルートには O IA というフラグが付いています。

    エリア内ルートとエリア間ルートは両方とも、インターフェイスが OSPF の network コマンドの処理対象になる場合に OSPF 自身によって生成されるので、OSPF 内部ルートとも呼ばれます。

  • 外部タイプ 2 または外部タイプ 1 — OSPF に、スタティック接続されるのような、か他のルーティング プロトコル再配布されたルーティングは外部タイプ 2 または外部タイプ 1 として、知られています。 これらのルートは O E2 か show ip route コマンド出力の O E1 としてフラグが付けられます。

  • NSSA 外部タイプ 2 か NSSA 外部タイプ 1 —エリアがないそうスタブ エリア(NSSA)で設定される、およびルーティングは OSPF に再配布されます時、ルーティングは NSSA 外部タイプ 2 または NSSA 外部タイプ 1 として知られています。 これらのルートは show ip route コマンド出力の O N2 か O N1 としてフラグが付けられます。

    外部間の違いをおよび NSSA タイプ 2 または 1 記述することはこの資料の範囲を超えてあります—詳細については OSPF設計ガイドを参照して下さい。

デフォルトでは、OSPF から BGP へのルートの再配布は行われません。 再配布を設定する必要があります。 route-map コマンドを使用すると、OSPF から BGP への再配布の際にルートのフィルタリングが可能です。 再配布時には、それぞれのルートを再配布するために internal、external、nssa-external などの特定のキーワードが必要です。

前提条件

要件

このドキュメントを使用する前に、OSPF のルート タイプについて理解しておく必要があります。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

ネットワーク構成

次に、OSPF ルートを BGP に再配布する 4 つのケースについて説明します。 次のネットワーク ダイアグラムは、最初の 3 つのケースに当てはまります。 4 番目のケースのダイアグラムと設定については、「OSPF NSSA 外部ルートの BGP への再配布」セクションを参照してください。

/image/gif/paws/5242/bgp-ospf-redis1.jpg

OSPF 内部 (Intra- および Inter-エリア) ルートだけをBGP へ再配布する方法

キーワードなしで BGP に OSPF の再配布を設定する場合、エリア内 OSPF だけおよびエリア間 ルートが BGP に再配布されます、デフォルトで。 OSPF のエリア内ルートとエリア間ルートを再配布するには、router bgp で redistribute コマンドと共に internal キーワードを使用します。

次の設定は、エリア内ルート(131.108.2.0/24)とエリア間ルート(131.108.1.0/24)だけを BGP に再配布するルータ B の新しい設定で、OSPF の内部(エリア内およびエリア間)ルートだけが BGP に再配布されます。

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.3 255.255.255.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1


!-- This redistributes only OSPF intra- and inter-area routes into BGP.


 neighbor 3.3.3.2 remote-as 200
!
end

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O E2 200.1.1.0/24 [110/20] via 2.2.2.2, 00:16:17, Ethernet0/0
O E1 200.2.2.0/24 [110/104] via 2.2.2.2, 00:00:41, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:16:17, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:16:17, Ethernet0/0
RTB#

次の場合、ルータ B が再配布するのは OSPF の内部ルートだけです。

RTB# show ip bgp
BGP table version is 10, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
RTB#

次の場合、ルータ C は BGP からこれらのルートを学習しています。

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:11:19
C    3.0.0.0/8 is directly connected, Serial0/0
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:03:56
B       131.108.1.0 [20/84] via 3.3.3.1, 00:03:28
RTC#

OSPF 外部(タイプ1 および2) ルートだけをBGP へ再配布する方法

OSPF の外部ルートを BGP に再配布するには、router bgp で redistribute コマンドに external キーワードを使用します。 external キーワードを使用する場合、次の 3 つの選択肢があります。

  • 外部タイプ 1 とタイプ 2 の両方を再配布する(デフォルト)

  • タイプ 1 を再配布する

  • タイプ 2 を再配布する

コンフィギュレーション モードで次のようにコマンドを入力します。

RTB(config-router)# router bgp 100
RTB(config-router)# redistribute ospf 1 match external

ルータ B の次の設定では、OSPF の外部ルートだけが再配布されますが、再配布されるのはタイプ 1 とタイプ 2 の両方です。

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match external 1 external 2


!--- This redistributes ONLY OSPF External routes, 
!--- but both type-1 and type-2.


 neighbor 3.3.3.3 remote-as 200
!
end

注: 設定には match external 1 external 2 と指定されていますが、入力したコマンドは redistribute ospf 1 match external でした。 OSPF では、設定にある「external 1 external 2」が自動的に末尾に追加されるので、通常はこのようにします。 OSPF の external 1 と external 2 の両方のルートに一致し、両方のルートが BGP に再配布されます。

次の場合、ルータ B が再配布するのは OSPF の外部ルートだけです。

RTB# show ip bgp
BGP table version is 21, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

次の場合、ルータ C はこれら 2 つの OSPF の外部ルートに関して BGP から学習します。

RTC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:43
B    200.2.2.0/24 [20/0] via 3.3.3.1, 00:01:43
C    3.0.0.0/8 is directly connected, Serial0/0

OSPF 外部タイプ 1 およびタイプ 2 ルートのみの BGP への再配布

ルータ B の router bgp 100 で次のコマンドを入力すれば、OSPF 外部タイプ 1 のルートだけを再配布できます。

router bgp 100
 redistribute ospf 1 match external 1

ルータ B の BGP テーブルには、外部タイプ 1 のルートだけが BGP に再配布されており、他のすべての OSPF ルートは BGP に再配布されていないことが示されています。

RTB# show ip bgp
BGP table version is 24, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

同様に、ルータ B の router bgp 100 で次のコマンドを入力すれば、OSPF 外部タイプ 2 のルートだけを再配布できます。

router bgp 100
 redistribute ospf 1 match external 2

BGP へのOSPF 内部及び外部ルートの再配布

この場合は、internal と external の両方のキーワードを使用することにより、すべての OSPF ルートが BGP に再配布されます。この場合のルータ B の設定を次に示します。

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1
!
router bgp 100
 redistribute ospf 1 match internal external 1 external 2


!--- This redistributes all OSPF routes into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

ここでも、設定で external が external 1 external 2 に置き換えられています。 どちらか特定の外部ルートを BGP に再配布する必要がない限り、通常はこのようにします。 設定変更を実行すると、ルータ B はすべての OSPF ルートを再配布し、ルータ C は BGP からすべてのルートの学習を開始します。

RTB# show ip bgp
BGP table version is 30, local router ID is 192.168.1.7
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.0/24       0.0.0.0                  0         32768 ?
*> 131.108.1.0/24   2.2.2.2                 84         32768 ?
*> 131.108.2.0/24   2.2.2.2                 74         32768 ?
*> 200.1.1.0        2.2.2.2                 20         32768 ?
*> 200.2.2.0        2.2.2.2                104         32768 ?
RTB#

RTC# sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
B       2.2.2.0 [20/0] via 3.3.3.1, 00:01:24
C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/20] via 3.3.3.1, 00:01:24
B    200.2.2.0/24 [20/104] via 3.3.3.1, 00:01:24
     131.108.0.0/24 is subnetted, 2 subnets
B       131.108.2.0 [20/74] via 3.3.3.1, 00:01:24
B       131.108.1.0 [20/84] via 3.3.3.1, 00:01:24
RTC#

BGP へのOSPF NSSA 外部ルートの再配布

このケースは、Not-So-Stubby Area(NSSA)のルートだけが BGP に再配布される特別なケースです。 このケースは、「OSPF 外部(タイプ 1 および 2)ルートのみの BGP への再配布」セクションに説明されているケースと非常によく似ています。 唯一の違いは、単に外部ルートではなく、NSSA 外部ルートとのマッチングを BGP が行うようになっていることだけです。 次に示すルータ B のルーティング テーブルには、それらの OSPF NSSA 外部ルートが示されています。

RTB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O N2 200.1.1.0/24 [110/20] via 2.2.2.1, 00:22:53, Ethernet0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O IA 131.108.1.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
O 131.108.2.0/24 [110/20] via 2.2.2.2, 00:22:53, Ethernet0
C    2.0.0.0/8 is directly connected, Ethernet0
C    3.0.0.0/8 is directly connected, Serial1

このケースで使用されているのは次のネットワーク ダイアグラムです。

/image/gif/paws/5242/bgp-ospf-redis2.jpg

このネットワーク ダイアグラムには、ルータ B が OSPF N1 と N2 の両方のルートを受信することが示されています。 nssa-external キーワードだけが使用されていると、デフォルトでは N1 と N2 の両方が再配布されます。 次のようにルータ B を設定すると、OSPF N1(200.1.1.0/24)と OSPF N2(200.2.2.0/24)のルートを BGP に再配布できるようになります。

RTB
hostname RTB
!
interface Ethernet0/0
 ip address 2.2.2.1 255.0.0.0
!
interface Serial1/0
 ip address 3.3.3.1 255.0.0.0
!
router ospf 1
 network 2.0.0.0 0.255.255.255 area 1 
nssa

!
router bgp 100
 redistribute ospf 1 match nssa-external 1 nssa-external 2


!--- This redistributes only OSPF NSSA-external routes 
!--- Type-1 and Type-2 into BGP.


 neighbor 3.3.3.3 remote-as 200
!
end

注: OSPF の外部設定の場合と同様に、上記の設定には match nssa-external 1 nssa-external 2 と指定されていますが、入力したコマンドは redistribute ospf 1 match external でした。 OSPF では、設定にある「nssa-external 1 nssa-external 2」が自動的に末尾に追加されるので、通常はこのようにします。 これにより、OSPF N1 と OSPF N2 の両方のルートに一致し、両方のルートが BGP に再配布されます。

ルータ B の設定を変更すると、ルータ B は OSPF NSSA 外部ルートを再配布し、ルータ C は BGP から OSPF NSSA 外部ルートの学習を開始します。

RTB# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Ethernet0/0
C    3.0.0.0/8 is directly connected, Serial1/0
O N2 200.1.1.0/24 [110/94] via 2.2.2.1, 00:11:12, Ethernet0/0
O N1 200.2.2.0/24 [110/20] via 2.2.2.2, 00:12:23, Ethernet0/0
     131.108.0.0/24 is subnetted, 2 subnets
O       131.108.2.0 [110/74] via 2.2.2.2, 00:12:23, Ethernet0/0
O IA    131.108.1.0 [110/84] via 2.2.2.2, 00:12:11, Ethernet0/0
RTB#

RTB# show ip bgp 
BGP table version is 21, local router ID is 3.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 200.1.1.0        2.2.2.2                 94         32768 ?
*> 200.2.2.0        2.2.2.1                 20         32768 ?
RTB#

RTC# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    3.0.0.0/8 is directly connected, Serial0/0
B    200.1.1.0/24 [20/94] via 3.3.3.1, 00:02:06
B    200.2.2.0/24 [20/20] via 3.3.3.1, 00:02:06
RTC#

OSPF の外部ルートの場合と同様に、OSPF N1 ルートだけを再配布するには、ルータ B の router BGP 100 で次のコマンドを入力します。

router bgp 100
 redistribute ospf 1 match nssa-external 1

!--- This redistributes only OSPF NSSA-external 
!--- Type-1 routes into BGP.

OSPF N2 ルートだけを再配布するには、ルータ B の router BGP 100 で次のコマンドを入力します。

router bgp 100
 redistribute ospf 1 match nssa-external 2

!--- This redistributes only OSPF NSSA-external 
!--- Type-2 routes into BGP.

注: Route-maps も BGP に OSPF 型 1/2 を再配布するのに使用することができます。 再配布します詳細については BGP の OSPF E2 ルーティングを参照して下さい。

OSPF の再配布オプションの変更

連続して設定を変更すると設定がどのように変わるかを理解しておくことが重要です。 match オプションを指定した新しいコマンドは以前のコマンドを上書きするのではなく、以前のコマンドに追加されます。 次の例では、再配布なしの状態から始めて、設定コマンドのシーケンスがどのように再配布に影響するかを示します。

R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match internal
R4(config-router)# ^Z

!--- Initially, we redistribute internal OSPF routes into BGP 100.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal
R4# conf t
R4(config)# router bgp 100
R4(config-router)# redistribute ospf 1 match external
R4(config-router)# ^Z

!--- With this second command, we tell BGP 
!--- to also redistribute external OSPF routes.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1 external 2
R4#
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match external 2
R4(config-router)# ^Z

!--- With this no command, we only disable the 
!--- redistribution of external type 2 into BGP. 
!--- All other types of routes previously configured remain.


R4# sh run | i redistribute ospf
 redistribute ospf 1 match internal external 1
 
!--- As you can see, internal and external type 1 remain.

R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 match internal external 1
R4(config-router)# ^Z 

!--- Now, with this no command, which includes all configured 
!--- keywords, it is important to note that we 
!--- still do not disable the redistribution fully.
!--- We only removed the keyword. After this, 
!--- the IOS still acts as default—redistributing
!--- internal routes only.


R4# sh run | i redistribute ospf
 redistribute ospf 1
R4# conf t
R4(config)# router bgp 100
R4(config-router)# no redistribute ospf 1 

!--- Always use this command in order to completely
!--- disable redistribution.

R4(config-router)# ^Z
R4# sh run | i redistribute ospf
R4#

iBGP を再配布することが不可能 EIGRP のような IGP にルーティングを、OSPF 学習しました

経路再配送が別のルーティング プロトコルに 1 プロトコルの使用と、学習されるルーティングを伝搬するのに使用されています。 BGP が IGP に再配布される時、eBGP 学習したルートだけが再配布されます。 ルータで知られている IBGP学習ルートは IGP にルーティングループが形成されることを防ぐためにもたらされません。

デフォルトでは、IGP への iBGP の再配布は無効になっています。 IGP への iBGP ルートの再配布を有効にするには、bgp redistribute-internal コマンドを発行します。 対策は IGP にルート マップを使用して特定のルーティングを再配布するために奪取 される必要があります。

OSPF への iBGPルートを再配布するための設定 例はここに示されています:

router bgp 65345 
bgp redistribute-internal
!
router ospf 100
redistribute bgp 65345 subnets

注: Interior Gateway Protocol への内部ボーダーゲートウェイプロトコル(iBGP)ルーティングの再配布により自律 システム (AS)内のルーティングループを引き起こす場合があります。 これは推奨されません。 ルートフィルタは情報を制御するために設定 される必要があります IGP にインポートされる。

BGP に OSPF デフォルト・ ルートを再配布して下さい

デフォルト・ ルートを BGP に再配布するために、ネットワークステートメントおよび default-information originate を使用して下さい。 例では、OSPF デフォルト・ ルートは BGP に再配布されます。 これはルート マップの作成および標準 ACL によって許可されるデフォルトネットワークのディストリビューションとされます。

!
route-map map_default_only permit 10

 match ip address acl_default_only

!

ip access-list standard acl_default_only

 permit 0.0.0.0

!

router bgp 64601

network 0.0.0.0

 redistribute ospf 1 route-map map_default_only

 default-information originate

!--- distributes the default route in bgp

!

設定の後で、clear ip bgp * コマンドで BGPセッションを解決して下さい。

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 5242