Cisco インターフェイスとモジュール : Cisco コンテンツ スイッチング モジュール

CSM でのシングル サブネット(ブリッジ)モードの設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | ライター翻訳版 (2003 年 4 月 9 日) | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

Content Switching Module(CSM; コンテント スイッチ モジュール)では、ネットワーク デバイスとサーバ ファーム間での高性能の Server Load Balancing(SLB; サーバ ロード バランシング)を、レイヤ 4 から 7 の情報パケットに基づいて実現します。 サーバ ファームは仮想サーバとして表現され、ネットワークに対する拡張性とサービスのアベイラビリティが向上します。 新しいサーバの追加や、障害を起こしたサーバ、あるいは既存のサーバの取り外しは、仮想サーバのアベイラビリティに影響を与えることなく、いつでも行えます。

クライアントからは、仮想サーバの virtual IP(VIP; 仮想 IP)アドレスを指定することで CSM に接続できます。 クライアントが仮想サーバへの接続を開始すると、CSM によって、設定されているロード バランシング アルゴリズムとポリシー(アクセス ルール)に基づいて実サーバ(サーバ ファームに割り当てられている物理デバイス)が選択されます。 ポリシーでは、クライアントからの情報に対する要求をどこに送信するかを定義して、トラフィックを管理します。

はじめに

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

この設定は CSM をサポートするあらゆるソフトウェア および ハードウェア バージョンと使用することができます。

背景理論

クライアント および サーバはレイヤ2 かレイヤ3 を使用して CSM によって通信しますか。 特定の VLAN構成のテクノロジー。 クライアントは、クライアント側の VLAN に接続し、サーバはサーバ側の VLAN に接続します。 サーバとクライアントは異なるサブネット上にあります。 サーバは、1ホップ以上離れた場所に位置しており、ルータを経由してサーバ側の VLAN に接続することもできます。 クライアントは、いずれかのモジュールの VIP アドレスに対して要求を送信します。 CSM では、要求に応答できるサーバに、この要求を自動転送します。 その後、サーバは CSM に応答を自動転送し、さらに CSM がこの応答をクライアントに自動転送します。

クライアント側とサーバ側の VLAN が同じサブネット上にある場合は、CSM をシングル サブネット(ブリッジ)モードで設定できます。 この資料は単一 の サブネット(ブリッジ)モードを記述したものです。

クライアント側とサーバ側の VLAN が異なるサブネット上にある場合は、CSM をセキュア(ルータ)モードで動作するように設定できます。 詳細については、CSM のセキュア(ルータ)モードの設定を参照して下さい。

設定

ネットワーク構成図

次のダイアグラムでは、異なる VLAN と異なるサブネットを表しています。

csmbridge.gif

設定

次の手順を実行します。

  1. クライアントとサーバの VLAN を MSFC に作成します。

    cat#conf t 
    cat(config)#vlan 100 
    cat(config-vlan)#exit 
    cat(config)#vlan 200 
    cat(config-vlan)#
  2. クライアントに接続する物理インターフェイス(アップリンク)を対応する VLAN に対して設定します。

    cat(config)#inter fastEthernet 2/1 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 100 
    cat(config-if)#no shut
    
  3. サーバに接続する物理インターフェイスを対応する VLAN に対して設定します。

    cat(config)#inter fastEthernet 2/3 
    cat(config-if)#switchport
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown 
    cat(config)#inter fastEthernet 2/4 
    cat(config-if)#switchport 
    cat(config-if)#switchport access vlan 200 
    cat(config-if)#no shutdown
    
  4. CSM を設定して下さい。

    cat(config)#module csm 3 
    cat(config-module-csm)#
  5. クライアントサイドのVLAN およびゲートウェイを作成して下さい。

    cat(config-module-csm)#vlan 100 client 
    cat(config-slb-vlan-client)#ip address 172.17.63.217 255.255.255.192 
    cat(config-slb-vlan-client)#gateway 172.17.63.214  
    cat(config-slb-vlan-client)#
  6. サーバ側の VLAN を作成して下さい。

    cat(config-module-csm)#vlan 200 server 
    cat(config-slb-vlan-server)#ip address 172.17.63.217 255.255.255.192
    
  7. サーバファームを作成して下さい。

    cat(config-module-csm)#serverfarm wwwfarm
    cat(config-slb-sfarm)#real 172.17.63.215 
    cat(config-slb-real)#inservice 
    cat(config-slb-real)#real 172.17.63.216 
    cat(config-slb-real)#inservice
    
  8. Vserver を作成し、サーバファームを関連付けて下さい。

    cat(config-module-csm)#vserver server 
    cat(config-slb-vserver)#virtual 172.17.63.241 tcp www 
    cat(config-slb-vserver)#serverfarm wwwfarm 
    cat(config-slb-vserver)#inservice
    

これは Cisco Catalyst 6500 および CSM を使用して SLB の設定 例です。

CSM (WS-X6066-SLB-APC) の実行設定
Building configuration... 

Current configuration : 3863 bytes 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname cat 
! 
boot system flash sup-bootflash:c6sup11-jsv-mz.121-11b.E 
! 
redundancy 
?main-cpu 
? auto-sync standard 
ip subnet-zero 
! 
mls qos statistics-export interval 300 
mls qos statistics-export delimiter | 
! 

!--- CSM located in slot 3. Module running as Active.?
 
! 
module ContentSwitchingModule 3? 
! 


!--- Client side CSM VLAN 100 
!--- Gateway pointing to the MSFC.

! 
?vlan 100 client 
? ip address 172.17.63.217 255.255.255.192 
? gateway 172.17.63.214 
! 

!--- Server side CSM VLAN 200.

! 
?vlan 200 server 
? ip address 172.17.63.217 255.255.255.192 
! 

!--- Server farm configuration.
 
! 
?serverfarm WWWFARM 
? nat server? 
? no nat client 
? real 172.17.63.215 
?? inservice 
? real 172.17.63.216 
?? inservice 
! 

!--- VServer configuration. 

! 
?vserver SERVER 
? virtual 172.17.63.241 tcp www 
? serverfarm WWWFARM 
? persistent rebalance 
? inservice 
! 
interface GigabitEthernet1/1 
?no ip address 
?shutdown 
! 
interface GigabitEthernet1/2 
?no ip address 
?shutdown 
! 

!--- Connection to upstream device.

! 
interface FastEthernet2/1 
?switchport 
?switchport access vlan 100 
?switchport mode access 
?no ip address 
! 
interface FastEthernet2/2 
?no ip address 
?shutdown 
! 

!--- Connection to Web servers.

! 
interface FastEthernet2/3 
?switchport 
?switchport access vlan 200 
?switchport mode access 
?no ip address 
! 
interface FastEthernet2/4 
?switchport 
?switchport access vlan 200 
?switchport mode access 
?no ip address 
! 
interface FastEthernet2/5 
?no ip address 
?shutdown 
! 

!--- MSFC VLAN 100.

! 
interface Vlan100 
?ip address 172.17.63.214 255.255.255.192 
! 
ip classless 
ip route 0.0.0.0 0.0.0.0 172.17.63.193 
no ip http server 
! 
! 
line con 0 
line vty 0 4 
?login 
! 
end

検証(show コマンド)

show module csm # status コマンド

show module csm # status コマンドでは、SLB モジュールのステータスが表示されます。 モジュールはオンライン状態であることが必要です。

cat#show module csm 3 status
SLB Module is online in slot 3.
Configuration Download state: COMPLETE, SUCCESS

show module csm # vserver name word detail コマンド

show module csm # vservers name word detail コマンドでは、仮想サーバの詳細な情報が表示されます。 そこの何接続があるかまた仮想サーバの状態を参照し。 このコマンドは、仮想サーバの情報を得るのに最も適しています。

cat#show module csm 3 vservers name server detail?
SERVER, state = OPERATIONAL, v_index = 10
? virtual = 172.17.63.241/32:80, TCP, service = NONE, advertise = FALSE
? idle = 3600, replicate csrp = none, vlan = ALL, pending = 30
? max parse len = 600, persist rebalance = TRUE
? conns = 0, total conns = 4
? Default policy:
??? server farm = WWWFARM
??? sticky: timer = 0, subnet = 0.0.0.0, group id = 0
? Policy?????????? Tot Conn???? Client pkts? Server pkts
? ------------------------------------------------------
? (default)??????? 4??????????? 56?????????? 56

show module csm # real detail コマンド

show module csm # real detail コマンドでは、それぞれの実サーバの情報が表示されます。表示される情報には、それぞれのサーバが位置するサーバ ファーム、サーバの状態、しきい値、および接続などが含まれます。

cat#show module csm 3 real detail
172.17.63.215, WWWFARM, state = OPERATIONAL
? conns = 0, maxconns = 4294967295, minconns = 0
? weight = 8, weight(admin) = 8, metric = 0, remainder = 0
? total conns established = 2, total conn failures = 2
172.17.63.216, WWWFARM, state = OPERATIONAL
? conns = 0, maxconns = 4294967295, minconns = 0
? weight = 8, weight(admin) = 8, metric = 0, remainder = 0
? total conns established = 2, total conn failures = 2
cat#show module csm 3 real detail

show module csm # serverfarm name word detail コマンド

show module csm # serverfarms name word detail コマンドでは、サーバ ファームの情報が表示されます。 このコマンドでは、ロード バランシングに使用されているプレディクタが表示されます。 この例では、デフォルトであるラウンドロビンは使用されています。

cat#show module csm 3 serverfarms name wwwfarm detail?
WWWFARM, predictor = RoundRobin, nat = SERVER
? virtuals inservice: 1, reals = 2, bind id = 0, fail action = none
? inband health config: <none>
? retcode map = <none>
? Real servers:
??? 172.17.63.215, weight = 8, OPERATIONAL, conns = 0
??? 172.17.63.216, weight = 8, OPERATIONAL, conns = 0
? Total connections = 0

show module csm # vlan detail コマンド

show module csm # vlan detail コマンドでは、クライアントとサーバに関する VLAN 情報が表示されます。

cat#show module csm 3 vlan detail?
vlan?? IP address?????? IP mask????????? type??????
---------------------------------------------------
100??? 172.17.63.217??? 255.255.255.192? CLIENT
? GATEWAYS
? 172.17.63.214????
200??? 172.17.63.217??? 255.255.255.192? SERVER
cat#

トラブルシューティング

実サーバおよび CSM ゲートウェイを Catalyst 6500 から PING の実行によって ping するか、またはモジュールを ping csm # reals コマンドできるはずです。

cat#ping module csm 3 reals
IP address?????? Reachable
--------------------------
172.17.63.215??? Yes
172.17.63.216??? Yes
cat#ping module csm 3 gateway?????????????????????????
IP address?????? Reachable
--------------------------
172.17.63.214??? Yes

もう一つのよいトラブルシューティング コマンドは show module csm # arp です。 CSM ではこのアドレスを学習します。 ゲートウェイおよび reals が表示アップであることを確かめて下さい。

cat#show module csm 3 arp?
Internet Address? Physical Interface? VLAN????? Type?????? Status
--------------------------------------------------------------------
?172.17.63.210??? 00-E0-B6-01-FA-49?? 100?????? LEARNED??? up(0 misses)
?172.17.63.214??? 00-04-C0-C0-68-00?? 100?????? GATEWAY??? up(0 misses)
?172.17.63.215??? 00-60-B0-87-DC-1A?? 200?????? REAL?????? up(0 misses)
?172.17.63.216??? 00-50-DA-BF-A1-7F?? 200?????? REAL?????? up(0 misses)
?172.17.63.217??? 00-30-F2-71-5D-2E?? 100/200?? --SLB--??? local
?172.17.63.222??? 00-02-B9-45-A2-91?? 100?????? LEARNED??? up(0 misses)
?172.17.63.241??? 00-30-F2-71-5D-2D?? 0???????? VSERVER??? local

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 5217