音声とユニファイド コミュニケーション : Cisco AS5400 シリーズ ユニバーサル ゲートウェイ

着信非同期および ISDN コールのためのAS5350/AS5400 設定

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

多くの環境では、非同期ユーザと ISDN ユーザの両方からの着信コールを受け入れるようにアクセス サーバを設定する必要があります。 このような環境において、ユーザは物理的に存在するかのようにシームレスにネットワークに接続できるようになります。 とまた Small Office-Home Office (SOHO) サイトにネットワーク接続を旅し、在宅勤務をするユーザ提供するためにそれ故に、このセットアップは広く使われています。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • 2 Dial Feature Cards (DFC)の Cisco AS5400、216 の Nextportモデムおよび T1 8 カードを提供します。

  • Cisco IOS(R) ソフトウェア リリース 12.3 メインライン。

  • 1 アクティブ T1 PRI。

  • ローカル認証、許可および会計(AAA)。 AAA RADIUS か TACACS+ サーバがある場合、着信コールに AAA を提供するのにそのサーバを使用できます。

この設定は基本的 な アナログおよび ISDN ダイヤルインのためだけです。 従って、AS5350 および AS5400 でサポートされるどの Cisco IOS ソフトウェア バージョンでも十分です。 追加機能を実行するために、適切な必要に Cisco IOSバージョンおよび機能セットを選択するために Software Advisor ツール登録ユーザのみ)を参照して下さい。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 対象のネットワークが実稼働中である場合には、どのような作業についても、その潜在的な影響について確実に理解しておく必要があります。

関連製品

この設定はまた AS5350 か AS5400 アクセス サーバに適用することができます。

注:  この設定はまた E1 PRI ポートと使用されるために修正することができます

注:  Telco によって供給されるライン コーディング、フレーム作成および他の物理的 特性で E1 コントローラを設定して下さい。 D チャネルの設定(E1 コントローラに対してインターフェイス シリアル x:15 を使用)は、ここで説明した設定と類似しています。

この設定はダイヤルイン アクセスのための AS5200 か AS5300 設定に非常に類似したです。 AS5200 か AS5300 を設定する方法に関する詳細については PRI でアクセス サーバを着信 非同期および ISDNコールについては設定することを参照して下さい。 2 間の唯一の主な違いは AS5350 または AS5400 の T1 クロック 優先順位を割り当てるのに使用される dial-tdm-clock プライオリティ番号 t1_slot/port コマンドです。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

背景説明

この資料は ISDN T1 PRI 回線の着信 非同期および ISDNコールを受け入れるために AS5350 または AS5400 シリーズ アクセス サーバを設定する方法を取り扱っています。 この設定には、Network Access Server(NAS; ネットワーク アクセス サーバ)がコールを受信するのに最低限必要なものだけが実装されています。 必要に基づいてこの設定に機能を追加できます。

設定

この項では、このドキュメントで説明する機能の設定に必要な情報を提供します。

注: このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

設定

このドキュメントでは次の設定を使用しています。

  • 5400-NAS (5400)

5400-NAS (5400)
5400-NAS#show running-config
Building configuration...

Current configuration : 3209 bytes
!
version 12.3
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 5400-NAS
!
no boot startup-test
logging rate-limit console 10 except errors
aaa new-model
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default local

!--- PPP authentication and network authorization are local.
!--- Replace local with radius or tacacs if you use a AAA server.

enable secret 5 <deleted>
!
username admin password 7 <deleted>
username dude password 7 <deleted>
username cisco password 7 <deleted>

!--- Usernames for local authentication of the call. The client presents 
!--- the username or password, and the NAS authenticates the peer.

!
resource-pool disable
dial-tdm-clock  priority 1 7/1

!--- T1 port 7/1 is the primary clock source.
!--- This is indicated by priority 1 in the dial-tdm-clock command.
!--- Note: On the AS5200/AS5300 you can set the primary clock source with 
!--- the clock source line primary command.

calltracker enable
calltracker history max-size 30
calltracker call-record verbose

!--- Calltracker is used for enhanced active call monitoring.
!--- For more information, see Call Tracker plus ISDN and AAA Enhancements.

spe call-record modem

!--- Enable modem call records for NextPort Universal Ports.
!--- This is equivalent to modem call-record terse used on MICA modem platforms.

!
voice-fastpath enable
ds0 busyout-threshold 12
ip subnet-zero
no ip source-route
no ip finger
ip domain-name cisco.com

!--- his instructs the NAS how to qualify DNS lookups. 
!--- In this example, cisco.com is appended to the end of each name looked up.

ip name-server 172.22.70.10

!--- Specifies the primary name server.

ip name-server 172.22.10.70

!--- Specifies the secondary name server.

!
isdn switch-type primary-ni

!--- Switch-type for this NAS. Obtain this information from the Telco.

!
mta receive maximum-recipients 0
!
controller T1 7/0

!--- This T1 is unused.

 shutdown
!
controller T1 7/1

!--- T1 PRI physical controller configuration.

 framing esf

!--- Framing for this T1 is Extended Super Frame (ESF). 
!--- Obtain this information from the telco.

 linecode b8zs

!--- Line coding for this T1. Obtain this information from the telco.

 pri-group timeslots 1-24

!--- For T1 PRI scenarios, all 24 T1 timeslots are assigned as ISDN PRI channels.
!--- The router now automatically creates the corresponding D-channel: 
!--- interface Serial 1:23


!

!--- The configuration for unused T1 controllers is omitted to save space.
!--- Unused T1s can be shutdown as with controller t1 7/0.

!
interface Loopback0

!--- The IP pool for dialin async and ISDN users is in this subnet.
!--- This way, the routes for all clients are summarized and 
!--- propagated to the backbone instead of 254 routes.

 ip address 10.1.1.1 255.255.255.0
 no ip mroute-cache
!
interface FastEthernet0/0
 ip address 172.22.186.55 255.255.255.240
 no ip mroute-cache
 duplex auto
 speed 10
!
interface FastEthernet0/1
 ip address 192.168.1.1 255.255.255.0
 no ip mroute-cache
 duplex auto
 speed auto
!

!--- Unused interface configuration is omitted.

!
interface Serial7/1:23

!--- D-channel configuration for T1 7/1.

 no ip address
 encapsulation ppp

!--- PPP encapsulation on this interface.

 dialer rotary-group 1

!--- T1 0 is a member of rotary group 1.
!--- The rotary group configuration is in interface Dialer 1.

 isdn switch-type primary-ni
 isdn incoming-voice modem

!--- All incoming voice calls on this T1 are sent to the modems.
!--- This command is required if this T1 is to accept async calls.

 no fair-queue
 no cdp enable
!
interface Group-Async0

!--- This group-async interface is the configuration template for all modems.
!--- Individual async interfaces do not have to be configured since they can 
!--- be cloned from one managed copy.

 ip unnumbered Loopback0

!--- A Loopback interface is always up/up. For stability, you can unnumber to it. 


 encapsulation ppp
 no ip mroute-cache
 async mode interactive

!--- Users can dial in and get to a shell(Exec) or PPP session on that line.  
!--- This command can be used in conjunction with autoselect ppp 
!--- under the line configuration to auto detect the connection type.
!--- Use this command only if the async interface is to answer different 
!--- connection types(exec,PPP,slip etc). 
!--- If all users connect with PPP use the async mode dedicated command instead.

 peer default ip address pool pool_dialup

!--- Clients are assigned addresses from the IP address pool named pool_dialup.

 ppp authentication chap pap callin
 group-range 1/00 2/107

!--- Modems 1/00 through 2/107 are members of this group async interface.

!
interface Dialer1

!--- Configuration for rotary group 1.
!--- The Dialer interface number (1) must exactly match the rotary group number
!--- configured on the physical interfaces (interface Serial 7/1:23).

 ip unnumbered Loopback0

!--- A Loopback interface is always up/up. For stability, unnumber to it. 


 encapsulation ppp
 no ip mroute-cache
 dialer in-band

!--- Enable this dialer interface to be a DDR interface.
!--- This is required if you want to enforce the idle-timeout.

 dialer idle-timeout 300

!--- Idle timeout for incoming calls is 300 seconds (5 minutes).
!--- Users who are idle for more than 300 seconds are dropped.
!--- If dialer in-band is used and a dialer idle-timeout is not defined, 
!--- the default idle-timeout of 120 seconds (2 minutes) is applied.

 dialer-group 1

!--- Apply interesting traffic definition from dialer-list 1.
!--- Note: The specified dialer-group number must be the same as the 
!--- dialer-list number; in this example, defined as "1". 
!--- See the Define Interesting Traffic and Idle Timeout for details.

 peer default ip address pool pool_dialup

!--- Clients are assigned addresses from the IP address pool named pool_dialup.

 no fair-queue
 no cdp enable
 ppp authentication chap pap callin
 ppp multilink
!
ip local pool pool_dialup 10.1.1.2 10.1.1.254

!--- IP address pools for dialin clients.

ip classless
ip route 0.0.0.0 0.0.0.0 172.22.186.49
no ip http server
!
dialer-list 1 protocol ip permit

!--- Interesting traffic is defined by dialer-list 1.
!--- This is applied to interface Dialer 1 through dialer-group 1.
!--- Note: The specified dialer-list number must be the same as 
!--- the dialer-group number. In this example, it is defined as "1". 
!--- Interesting traffic is used to define what packets will reset the idle timer.

!
voice-port 7/1:D
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password 7 <deleted>
line 1/00 2/107

!--- Line configuration for modems 1/00 through 2/107.
!--- This is the same modem range configured with the group-range command 
!--- in interface Group-Async0.

 no flush-at-activation

!--- Prevents the router from flushing the first few packets on a connection.
!--- This command is used to prevent PPP timeout issues, and can be used to 
!--- avoid PPP startup issues.
!--- This is not required unless you encounter modem PPP call failures.

 autoselect during-login

!--- Displays the username:password prompt after modems connect (during exec login).
!--- This command is not neccessary if you use async mode dedicated under the 
!--- group-async interface. 

 autoselect ppp

!--- Automatically launches PPP if the router detects incoming PPP packets.
!--- Without this command, the dialin client will need to manually 
!--- launch PPP (from Exec mode). This command is not neccessary if you use
!---  async mode dedicated under the group-async interface. 

 modem InOut

!--- Support incoming and outgoing modem calls.

 transport input all
!
scheduler allocate 10000 400
end

関連 トラフィックおよびアイドルタイムアウトを定義して下さい

NAS は着信コールだけを扱いが、アウトバウンドコールを作りません、まだ関連 トラフィックを定義します。 関連 トラフィック (interesting traffic) 定義に非同期ユーザおよび ISDNユーザ向けの異なる目的があります。

ISDNユーザ向け(1) Interface dialer に相当して:

dialer-group コマンドおよび dialer-list コマンドは、アイドル タイムアウトを適用するかどうかに関係なく、ダイヤラ インターフェイス上では必要となります。 dialer-group コマンドおよび dialer-list コマンドは、カプセル化障害を防ぐためにダイヤラ インターフェイス上では必要となります。 この要件は ISDNユーザだけとない非同期ユーザおよびグループ 非同期インターフェイスのためです。

アイドルタイムアウトを実施するために、dialer in-band および dialer idle-timeout コマンドを追加して下さい。 帯域内ダイヤラが設定されればが、ダイヤラアイドルタイムアウトがなければ、アイドルタイムアウトは ISDNユーザ向けの 2 分にデフォルトで設定されます。

切ることを選択するまで ISDNユーザに接続されてとどまれればほしければ dialer idle-timeout 0 を使用するため。 「ゼロ"は Cisco IOS ソフトウェア リリース 12.1(3)T でダイヤラアイドルタイムアウトのためのオプションもたらされました。 それは無期限のタイムアウトを設定 します。

非同期ユーザ向け(Interface Group-Async 0 に相当して):

アイドル タイムアウトを非同期ユーザに適用するには、グループ非同期インターフェイスで次のコマンドを設定します。 dialer in-band, dialer idle-timeout,および dialer-group。 対応する dialer-list も必要となります。 dialer-group コマンドおよび dialer-list コマンドを使用して、グループ非同期インターフェイスの対象トラフィックを指定します。

非同期ユーザでは、対象トラフィックは、アイドル タイムアウトをリセットする場合にだけ使用されます。 関連 トラフィックが定義されない場合、ユーザはリンクのトラフィックを通過させているかどうかに関係なくダイヤラアイドルタイムアウト(デフォルト 120 秒)が期限切れになった後切断されています。 関連 トラフィック (interesting traffic) 定義によって、NAS はそれらのパケットを認識し、アイドルタイムアウトをリセットします。 こうすればは、NAS 実際にアイドル リンクがあるときだけユーザをログオフします。

対象トラフィックを修正して、たとえば HTTP(Web)トラフィックだけを対象にすることができます。 ユーザが 300 秒のための Web をブラウズしなければそのような状況では、(または特定のダイヤラアイドルタイムアウトのために)ユーザは切断されています。 ユーザのトラフィックパターンに基づいて関連 トラフィックを設定して下さい。

切ることを選択するまで非同期ユーザに接続されてとどまれればほしかったら Group-Asyncインターフェイスからこれらのコマンドを削除して下さい: 設定に示すように dialer in-band, dialer idle-timeout,および dialer-group。 また dialer idle-timeout 0 の助けによって無限大にアイドルタイムアウトを設定できます。 「ゼロ"は Cisco IOS ソフトウェア リリース 12.1(3)T でダイヤラアイドルタイムアウトのためのオプションもたらされ、無期限のタイムアウトを設定 します。

確認

このセクションでは、設定が正常に動作しているかどうかを確認する際に役立つ情報を提供しています。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

  • ルータが ISDNスイッチと正しく交信するように show isdn status —します。 出力で、Layer 1 Status が ACTIVE で、Layer 2 Status state = MULTIPLE_FRAME_ESTABLISHED と表示されていることを確認します。 このコマンドは、通信中のコールの数も表示します。

  • show ppp multilink —アクティブであるマルチリンクバンドルの情報を表示する。 マルチリンク接続を確認するのにこのコマンドを使用して下さい。

  • show dialer [interface type number] — DDR のために設定されるインターフェイスのための一般的な診断情報を表示する。 ダイヤラがきちんと起動した場合、Dialer state is data link layer up メッセージが現れる必要があります。 physical layer up が現われる場合、行プロトコルが起動したが、Network Control Protocol (NCP)は起動しませんでしたことを意味します。 ダイヤリングを開始したパケットの送信元アドレスと宛先アドレスが、Dial reason 行に表示されます。 この表示コマンドはまた接続時間の前にタイマーの設定、および期間を表示する。

  • show caller user username detail —、PPP 割り当てられるおよび PPP バンドルパラメータ IP アドレスのような特定のユーザ向けのパラメータを等表示します。 ご使用の Cisco IOS ソフトウェア バージョンでこのコマンドがサポートされていない場合には、show user コマンドを使用します。

  • show dialer map — ディスプレイはダイナミックおよび静的なダイヤラ マップを設定しました。 このコマンドは、ダイナミック ダイヤラ マップが作成済みかどうかを確認するときに使用できます。 ダイヤラ マップがない場合、パケットのルート付けができません。

成功コールのためのいくつかの showコマンド出力はここにあります。 太字フォントのセクションへの、および出力サンプルで記載されているコメントを注意して下さい。 ここに示される結果と得る出力を比較して下さい。

5400-NAS#show caller
                                                Active    Idle
  Line         User               Service       Time      Time
  con 0        -                  TTY           00:55:45  00:00:00
  tty 232      cisco              Async         00:00:33  00:00:03
  As1/16       cisco              PPP           00:00:29  00:00:03

!--- User cisco (the dialin client) uses interface Async 1/16.



5400-NAS#show caller ip
  Line         User       IP Address      Local Number    Remote Number   <->
  As1/16       cisco      10.1.1.3        4085556170      -               in

5400-NAS#show caller user cisco

  User: cisco, line tty 232, service Async

!--- Shows hardware level settings for user cisco.

        Active time 00:01:14, Idle time 00:00:43
  Timeouts:            Absolute  Idle      Idle
                                 Session   Exec
      Limits:          -         -         00:10:00
      Disconnect in:   -         -         -
  TTY: Line 1/16, running PPP on As1/16

!--- The call is terminated on interface Async 1/16. 
!--- This interface is included in the group-async configuration.

  Location: PPP: 10.1.1.3

!--- IP address for the peer. 
!--- This address was obtained from the IP pool pool_dialup.

  DS0: (slot/unit/channel)=7/1/0

!--- T1 channel on which the call arrived. The call arrived on channel 0 in T1 1.

  Line: Baud rate (TX/RX) is 115200/115200, no parity, 1 stopbits, 8 databits
  Status: Ready, Active, No Exit Banner, Async Interface Active
  Capabilities: No Flush-at-Activation, Hardware Flowcontrol In
                Hardware Flowcontrol Out, Modem Callout, Modem RI is CD
                Line usable as async interface, Integrated Modem
  Modem State: Ready

  User: cisco, line As1/16, service PPP

!--- PPP setting for user cisco. Note that the call was terminated on int As1/16.

        Active time 00:01:10, Idle time 00:00:44
  Timeouts:            Absolute  Idle
      Limits:          -         -
      Disconnect in:   -         -
  PPP: LCP Open, CHAP (<- AAA), IPCP

!--- LCP and IPCP states are OPEN. If LCP and IPCP states are not OPEN, 
!--- use the debug ppp negotiation command to isolate LCP issues.

  IP: Local 10.1.1.1, remote 10.1.1.3

!--- NAS IP address as well as the IP address assigned to the peer.

  Counts: 12 packets input, 654 bytes, 0 no buffer
          0 input errors, 0 CRC, 0 frame, 0 overrun
          14 packets output, 694 bytes, 0 underruns
          0 output errors, 0 collisions, 0 interface resets

!--- Packets are passing through the connection.


5400-NAS#show ip route connected
     172.22.0.0/28 is subnetted, 1 subnets
C       172.22.186.48 is directly connected, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.1.1.3/32 is directly connected, Async1/16

!--- Directly connected route to the client. 
!--- Note that the next hop is int Async 1/16, which is the async interface
!--- assigned to the client

C       10.1.1.0/24 is directly connected, Loopback0 

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

トラブルシューティングのためのコマンド

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

注: debug コマンドを使用する前に、『debug コマンドに関する重要な情報』を参照してください。

  • debug dialer —ダイヤラーインターフェイスで受信されるパケットについての DDRデバッギング情報を表示する。 この情報により、ダイヤラ インターフェイスを使用できる対象トラフィックが存在することを確認できます。

  • debug isdn q931:ISDN ネットワーク接続(レイヤ 3)のコールの設定と切断を表示します。

  • debug modem — アクセス サーバのモデム回線 の アクティビティを表示する。 出力はモデム回線が状態を変更すると示します。

  • debug csm modem —内蔵デジタルモデムでルータのコールスイッチングモジュール(CSM)問題を解決することを可能にします。 このコマンドを使用すると、着信および発信のコールのスイッチングについて、完全なシーケンスをトレースできます。

    注: これは AS5200/AS5300 の debug modem csm と同等です。 このデバッグは Cisco IOS ソフトウェア リリース 12.0(4)xl でもたらされました。

  • debug ppp negotiation — リンク制御プロトコル (LCP)、認証および Network Control Protocol (NCP)のネゴシエーションの間に PPP トラフィックの情報および交換を表示する。 PPP ネゴシエーションが正常に行われると、最初に LCP 状態が開放され、次に認証、最後に NCP をネゴシエートします。 Maximum Receive Reconstructed Unit(MRRU)などのマルチリンク パラメータは、LCP ネゴシエーションの間に確立されます。

  • debug ppp authentication — Challenge Handshake Authentication Protocol (CHAP) パケット交換および Password Authentication Protocol (PAP)交換を含む PPP認証 プロトコルメッセージを、表示する。

  • debug ppp error:PPP 接続のネゴシエーションと接続操作に関するプロトコル エラーとエラー統計情報を表示します。

debug 出力例

成功コールのためのいくつかのデバッグ 出力はここにあります。 太字のセクション、および出力サンプルで記載されているコメントに注目して下さい。 ここに示される結果と得る出力を比較して下さい。

アナログコールに関しては:

5400-NAS#debug isdn q931
ISDN Q931 packets debugging is on
5400-NAS#debug modem
Modem control/process activation debugging is on
5400-NAS#debug csm modem
Modem Management Call Switching Module debugging is on
5400-NAS#debug ppp negotiation
PPP protocol negotiation debugging is on
5400-NAS#debug ppp authentication
PPP authentication debugging is on
5400-NAS#debug ip peer
IP peer address activity debugging is on
5400-NAS#debug aaa authentication
AAA Authentication debugging is on
5400-NAS#debug aaa authorization
AAA Authorization debugging is on
5400-NAS#
5400-NAS#show debug
General OS:
  Modem control/process activation debugging is on
  AAA Authentication debugging is on
  AAA Authorization debugging is on
CSM Modem:
  Modem Management Call Switching Module debugging is on
Generic IP:
  IP peer address activity debugging is on
PPP:
  PPP authentication debugging is on
  PPP protocol negotiation debugging is on
ISDN:
  ISDN Q931 packets debugging is on
  ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)
  DSL  0 --> 31
  - 1 - - - - - -  - - - - - - - -  - - - - - - - -  - - - - - - - -

5400-NAS#
5400-NAS#
*Jan  1 00:58:26.179: ISDN Se7/1:23: RX <-  SETUP pd = 8  callref = 0x0006

!--- Incoming Q.931 SETUP message. Indicates an incoming call.
!--- For more information on Q.931 refer to the document
!--- Troubleshooting ISDN Layer 3 using debug isdn q931.

*Jan  1 00:58:26.179:         Bearer Capability i = 0x8090A2
*Jan  1 00:58:26.179:         Channel ID i = 0xA98381
*Jan  1 00:58:26.179:         Calling Party Number i = 0x80, Plan:Unknown, 
Type:Unknown
*Jan  1 00:58:26.179:         Called Party Number i = 0xA1, '4085556170', 
Plan:ISDN, Type:National
*Jan  1 00:58:26.183: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:26.183: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:26.183: VDEV_ALLOCATE: 1/16 is allocated

!--- The Call Switch Module (CSM) is informed of the call. 
!--- The CSM allocates modem 1/16 to the incoming call.

*Jan  1 00:58:26.183: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:26.183: EVENT_FROM_ISDN::dchan_idb=0x63B915AC, call_id=0x6, 
ces=0x1 bchan=0x0, event=0x1, cause=0x0
*Jan  1 00:58:26.183:  dev in call to isdn : set dnis_collected & fap_notify
*Jan  1 00:58:26.183: EVENT_FROM_ISDN:(0006): DEV_INCALL at slot 1 and port 16
*Jan  1 00:58:26.183:  EVENT_FROM_ISDN: decode:calling 0ct3 0x80, called oct3 0xA1, 
oct3a 0x0,mask 0x25
*Jan  1 00:58:26.183:  EVENT_FROM_ISDN: csm_call_info:calling 0ct3 0x80, called oct3 
0xA1, oct3a 0x0,mask 0x25
*Jan  1 00:58:26.183: CSM_PROC_IDLE: CSM_EVENT_ISDN_CALL at slot 1, port 16
*Jan  1 00:58:26.183: CSM DSPLIB(1/16): np_dsplib_prepare_modem
*Jan  1 00:58:26.183: csm_connect_pri_vdev: TS allocated at bp_stream 0, bp_Ch 3,
vdev_common 0x627DDCC8
*Jan  1 00:58:26.183: ISDN Se7/1:23: TX ->  CALL_PROC pd = 8  callref = 0x8006
*Jan  1 00:58:26.183:         Channel ID i = 0xA98381

!--- Transmits CALL PROCEEDING. This means that the NAS is processing the call.

*Jan  1 00:58:26.183: ISDN Se7/1:23: TX ->  ALERTING pd = 8  callref = 0x8006

!--- Transmits ALERTING. The modem now goes offhook and accepts the call.

*Jan  1 00:58:26.191: CSM DSPLIB(1/16):DSPLIB_MODEM_INIT: 
Modem session transition to IDLE
*Jan  1 00:58:26.191: CSM DSPLIB(1/16): Modem went offhook

!--- Modem informs the CSM that it went offhook.

*Jan  1 00:58:26.191: CSM_PROC_IC2_RING: CSM_EVENT_MODEM_OFFHOOK at slot 1, port 16
*Jan  1 00:58:26.191: ISDN Se7/1:23: TX ->  CONNECT pd = 8  callref = 0x8006

!--- D-channel transmits a CONNECT.

*Jan  1 00:58:26.203: ISDN Se7/1:23: RX <-  CONNECT_ACK pd = 8  callref = 0x0006

!--- Received the Q.931 CONNECT_ACK.

*Jan  1 00:58:26.203: ISDN Se7/1:23: CALL_PROGRESS: CALL_CONNECTED call id 0x6, 
bchan 0, dsl 1
*Jan  1 00:58:26.203: EVENT_FROM_ISDN::dchan_idb=0x63B915AC, call_id=0x6, 
ces=0x1 bchan=0x0, event=0x4, cause=0x0
*Jan  1 00:58:26.203: EVENT_FROM_ISDN:(0006): DEV_CONNECTED at slot 1 and port 16
*Jan  1 00:58:26.203: CSM_PROC_IC6_WAIT_FOR_CONNECT: 
CSM_EVENT_ISDN_CONNECTED at slot 1, port 16
*Jan  1 00:58:26.203: CSM DSPLIB(1/16): np_dsplib_call_accept
*Jan  1 00:58:26.203: %ISDN-6-CONNECT: 
Interface Serial7/1:0 is now connected to N/A N/A

!--- Call is connected at the ISDN layer.

*Jan  1 00:58:26.207: CSM DSPLIB(1/16):DSPLIB_MODEM_WAIT_ACTIVE: 
Modem session transition to ACTIVE
*Jan  1 00:58:26.207: CSM DSPLIB(1/16): Modem state changed to (CONNECT_STATE)
*Jan  1 00:58:32.379: CSM DSPLIB(1/16): Modem state changed to (LINK_STATE)
*Jan  1 00:58:35.655: CSM DSPLIB(1/16): Modem state changed to (TRAINUP_STATE)
*Jan  1 00:58:43.775: CSM DSPLIB(1/16): Modem state changed to (EC_NEGOTIATING_STATE)
*Jan  1 00:58:44.107: CSM DSPLIB(1/16): Modem state changed to (STEADY_STATE)

!--- Modem transitions to Steady State.

*Jan  1 00:58:44.975: TTY1/16: DSR came up

!--- Indicates that the modem trainup is complete.

*Jan  1 00:58:44.975: tty1/16: Modem: IDLE->(unknown)
*Jan  1 00:58:44.975: TTY1/16: EXEC creation
*Jan  1 00:58:44.975: AAA: parse name=tty1/16 idb type=10 tty=232
*Jan  1 00:58:44.975: AAA: name=tty1/16 flags=0x11 type=4 shelf=0 
slot=0 adapter=0 port=232 channel=0
*Jan  1 00:58:44.975: AAA: parse name=Serial7/1:0 idb type=12 tty=-1
*Jan  1 00:58:44.975: AAA: name=Serial7/1:0 flags=0x55 type=1 shelf=0 
slot=7 adapter=0 port=1 channel=0
*Jan  1 00:58:44.975: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, 
ds0=117444608
*Jan  1 00:58:44.975: AAA/MEMORY: create_user (0x63CBD608) user='NULL' 
ruser='NULL' port='tty1/16' rem_addr='async/4085556170' authen_type=ASCII 
service=LOGIN priv=1
*Jan  1 00:58:44.975: AAA/AUTHEN/START (1231800673): port='tty1/16' list='' 
action=LOGIN service=LOGIN
*Jan  1 00:58:44.975: AAA/AUTHEN/START (1231800673): using "default" list
*Jan  1 00:58:44.975: AAA/AUTHEN/START (1231800673): Method=LOCAL
*Jan  1 00:58:44.975: AAA/AUTHEN (1231800673): status = GETUSER
*Jan  1 00:58:44.975: TTY1/16: set timer type 10, 30 seconds
*Jan  1 00:58:46.215: TTY1/16: Autoselect(2) sample 7E

!--- Beginning of a PPP Frame. 

*Jan  1 00:58:46.215: TTY1/16: Autoselect(2) sample 7EFF
*Jan  1 00:58:46.215: TTY1/16: Autoselect(2) sample 7EFF7D
*Jan  1 00:58:46.215: TTY1/16: Autoselect(2) sample 7EFF7D23
*Jan  1 00:58:46.215: TTY1/16 Autoselect cmd:  ppp negotiate

!--- The NAS detects PPP frames (indicated by 7EFF7D23) and 
!--- automatically launches PPP. The command autoselect ppp under the 
!--- line configuration and async mode interactive under the group-async
!--- allowed the NAS to detect PPP frames and switch to PPP mode.
!--- If the NAS does not detect PPP frames then the call will remain in exec mode.

*Jan  1 00:58:46.215: AAA/AUTHEN/ABORT: (1231800673) because Autoselected.
*Jan  1 00:58:46.215: AAA/AUTHEN/ABORT: (1231800673) because Autoselected.
*Jan  1 00:58:46.215: AAA/MEMORY: free_user (0x63CBD608) user='NULL' ruser='NULL' 
port='tty1/16' rem_addr='async/4085556170' authen_type=ASCII service=LOGIN priv=1
*Jan  1 00:58:46.215: TTY1/16: EXEC creation
*Jan  1 00:58:46.215: TTY1/16: create timer type 1, 600 seconds
*Jan  1 00:58:46.215: As1/16: ip_get_pool using pool pool_dialup
*Jan  1 00:58:46.215: As1/16: Pools to search : pool_dialup
*Jan  1 00:58:46.215: As1/16: Pool pool_dialup returned address = 10.1.1.3
*Jan  1 00:58:46.215: TTY1/16: destroy timer type 1
*Jan  1 00:58:46.215: TTY1/16: no timer type 0 to destroy
*Jan  1 00:58:46.215: As1/16 LCP: I CONFREQ [Closed] id 3 len 20

!--- Incoming LCP CONFREQ.
!--- For more information on interpreting PPP debugs refer to the document 
!--- Dialup Technology: Troubleshooting Techniques.

*Jan  1 00:58:46.215: As1/16 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan  1 00:58:46.215: As1/16 LCP:    MagicNumber 0x552722A5 (0x0506552722A5)
*Jan  1 00:58:46.215: As1/16 LCP:    PFC (0x0702)
*Jan  1 00:58:46.215: As1/16 LCP:    ACFC (0x0802)
*Jan  1 00:58:46.215: As1/16 LCP: Lower layer not up, Fast Starting
*Jan  1 00:58:46.215: As1/16 PPP: Treating connection as a dedicated line
*Jan  1 00:58:46.215: As1/16 PPP: Phase is ESTABLISHING, Active Open 
[0 sess, 0 load]
*Jan  1 00:58:46.219: As1/16 AAA/AUTHOR/FSM: (0): LCP succeeds trivially
*Jan  1 00:58:46.219: As1/16 LCP: O CONFREQ [Closed] id 1 len 25
*Jan  1 00:58:46.219: As1/16 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan  1 00:58:46.219: As1/16 LCP:    AuthProto CHAP (0x0305C22305)
*Jan  1 00:58:46.219: As1/16 LCP:    MagicNumber 0x30CCCD68 (0x050630CCCD68)
*Jan  1 00:58:46.219: As1/16 LCP:    PFC (0x0702)
*Jan  1 00:58:46.219: As1/16 LCP:    ACFC (0x0802)
*Jan  1 00:58:46.219: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:46.219: As1/16 LCP: O CONFACK [REQsent] id 3 len 20
*Jan  1 00:58:46.219: As1/16 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan  1 00:58:46.219: As1/16 LCP:    MagicNumber 0x552722A5 (0x0506552722A5)
*Jan  1 00:58:46.219: As1/16 LCP:    PFC (0x0702)
*Jan  1 00:58:46.219: As1/16 LCP:    ACFC (0x0802)
*Jan  1 00:58:46.219: %LINK-3-UPDOWN: Interface Async1/16, changed state to up
*Jan  1 00:58:48.215: As1/16 LCP: I CONFREQ [ACKsent] id 4 len 20
*Jan  1 00:58:48.215: As1/16 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan  1 00:58:48.215: As1/16 LCP:    MagicNumber 0x552722A5 (0x0506552722A5)
*Jan  1 00:58:48.215: As1/16 LCP:    PFC (0x0702)
*Jan  1 00:58:48.215: As1/16 LCP:    ACFC (0x0802)
*Jan  1 00:58:48.215: As1/16 LCP: O CONFACK [ACKsent] id 4 len 20
*Jan  1 00:58:48.215: As1/16 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan  1 00:58:48.215: As1/16 LCP:    MagicNumber 0x552722A5 (0x0506552722A5)
*Jan  1 00:58:48.215: As1/16 LCP:    PFC (0x0702)
*Jan  1 00:58:48.215: As1/16 LCP:    ACFC (0x0802)
*Jan  1 00:58:48.219: As1/16 LCP: TIMEout: State ACKsent
*Jan  1 00:58:48.219: As1/16 LCP: O CONFREQ [ACKsent] id 2 len 25
*Jan  1 00:58:48.219: As1/16 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan  1 00:58:48.219: As1/16 LCP:    AuthProto CHAP (0x0305C22305)
*Jan  1 00:58:48.219: As1/16 LCP:    MagicNumber 0x30CCCD68 (0x050630CCCD68)
*Jan  1 00:58:48.219: As1/16 LCP:    PFC (0x0702)
*Jan  1 00:58:48.219: As1/16 LCP:    ACFC (0x0802)
*Jan  1 00:58:48.367: As1/16 LCP: I CONFACK [ACKsent] id 2 len 25
*Jan  1 00:58:48.367: As1/16 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jan  1 00:58:48.367: As1/16 LCP:    AuthProto CHAP (0x0305C22305)
*Jan  1 00:58:48.367: As1/16 LCP:    MagicNumber 0x30CCCD68 (0x050630CCCD68)
*Jan  1 00:58:48.367: As1/16 LCP:    PFC (0x0702)
*Jan  1 00:58:48.367: As1/16 LCP:    ACFC (0x0802)
*Jan  1 00:58:48.367: As1/16 LCP: State is Open

!--- LCP negotiation is complete.

*Jan  1 00:58:48.367: As1/16 PPP: Phase is AUTHENTICATING, 
by this end [0 sess, 0 load]
*Jan  1 00:58:48.367: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, 
ds0=117444608
*Jan  1 00:58:48.367: As1/16 CHAP: O CHALLENGE id 1 len 29 from "5400-NAS"
*Jan  1 00:58:48.495: As1/16 CHAP: I RESPONSE id 1 len 26 from "cisco"

!--- Incoming CHAP response.

*Jan  1 00:58:48.495: AAA: parse name=Async1/16 idb type=10 tty=232
*Jan  1 00:58:48.495: AAA: name=Async1/16 flags=0x11 type=4 shelf=0 
slot=0 adapter=0 port=232 channel=0
*Jan  1 00:58:48.495: AAA: parse name=Serial7/1:0 idb type=12 tty=-1
*Jan  1 00:58:48.495: AAA: name=Serial7/1:0 flags=0x55 type=1 shelf=0 
slot=7 adapter=0 port=1 channel=0
*Jan  1 00:58:48.495: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:48.495: AAA/MEMORY: create_user (0x63CBD608) user='cisco' 
ruser='NULL' port='Async1/16' rem_addr='async/4085556170' authen_type=CHAP 
service=PPP priv=1
*Jan  1 00:58:48.495: AAA/AUTHEN/START (2776021080): port='Async1/16' list='' 
action=LOGIN service=PPP
*Jan  1 00:58:48.495: AAA/AUTHEN/START (2776021080): using "default" list
*Jan  1 00:58:48.495: AAA/AUTHEN/START (2776021080): Method=LOCAL
*Jan  1 00:58:48.495: AAA/AUTHEN (2776021080): status = PASS
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP: Authorize LCP
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP (3070946770): Port='Async1/16' 
list='' service=NET
*Jan  1 00:58:48.495: AAA/AUTHOR/LCP: As1/16 (3070946770) user='cisco'
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP (3070946770): send AV service=ppp
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP (3070946770): send AV protocol=lcp
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP (3070946770): found list "default"
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP (3070946770): Method=LOCAL
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR (3070946770): Post authorization 
status = PASS_REPL
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP: Processing AV service=ppp
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/LCP: Processing AV protocol=lcp
*Jan  1 00:58:48.495: As1/16 CHAP: O SUCCESS id 1 len 4

!--- Authentication is successful.

*Jan  1 00:58:48.495: As1/16 PPP: Phase is UP [0 sess, 0 load]
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/FSM: (0): Can we start IPCP?
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/FSM (3087015830): Port='Async1/16' 
list='' service=NET
*Jan  1 00:58:48.495: AAA/AUTHOR/FSM: As1/16 (3087015830) user='cisco'
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/FSM (3087015830): send AV service=ppp
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/FSM (3087015830): send AV protocol=ip
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/FSM (3087015830): found list "default"
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/FSM (3087015830): Method=LOCAL
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR (3087015830): Post authorization 
status = PASS_REPL
*Jan  1 00:58:48.495: As1/16 AAA/AUTHOR/FSM: We can start IPCP
*Jan  1 00:58:48.495: As1/16 IPCP: O CONFREQ [Closed] id 1 len 10

!--- IPCP negotiation begins.

*Jan  1 00:58:48.495: As1/16 IPCP:    Address 10.1.1.1 (0x03060A010101)
*Jan  1 00:58:48.619: As1/16 IPCP: I CONFREQ [REQsent] id 3 len 10
*Jan  1 00:58:48.619: As1/16 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jan  1 00:58:48.619: As1/16 AAA/AUTHOR/IPCP: Start.  Her address 0.0.0.0, 
we want 10.1.1.3

!--- Address obtained from the Address Pool named pool_dialup.

*Jan  1 00:58:48.619: As1/16 AAA/AUTHOR/IPCP: Processing AV service=ppp
*Jan  1 00:58:48.619: As1/16 AAA/AUTHOR/IPCP: Processing AV protocol=ip
*Jan  1 00:58:48.619: As1/16 AAA/AUTHOR/IPCP: Authorization succeeded
*Jan  1 00:58:48.619: As1/16 AAA/AUTHOR/IPCP: Done.  Her address 0.0.0.0, 
we want 10.1.1.3
*Jan  1 00:58:48.619: As1/16 IPCP: O CONFNAK [REQsent] id 3 len 10
*Jan  1 00:58:48.619: As1/16 IPCP:    Address 10.1.1.3 (0x03060A010103)
*Jan  1 00:58:48.623: As1/16 IPCP: I CONFACK [REQsent] id 1 len 10
*Jan  1 00:58:48.623: As1/16 IPCP:    Address 10.1.1.1 (0x03060A010101)
*Jan  1 00:58:48.731: As1/16 IPCP: I CONFREQ [ACKrcvd] id 4 len 10
*Jan  1 00:58:48.731: As1/16 IPCP:    Address 10.1.1.3 (0x03060A010103)
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP: Start.  Her address 10.1.1.3, 
we want 10.1.1.3
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP (3141581943): Port='Async1/16' 
list='' service=NET
*Jan  1 00:58:48.731: AAA/AUTHOR/IPCP: As1/16 (3141581943) user='cisco'
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP (3141581943): send AV service=ppp
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP (3141581943): send AV protocol=ip
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP (3141581943): send AV addr*10.1.1.3
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP (3141581943): found list "default"
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP (3141581943): Method=LOCAL
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR (3141581943): 
Post authorization status = PASS_REPL
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP: Reject 10.1.1.3, using 10.1.1.3
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP: Processing AV service=ppp
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP: Processing AV protocol=ip
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP: Processing AV addr*10.1.1.3
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP: Authorization succeeded
*Jan  1 00:58:48.731: As1/16 AAA/AUTHOR/IPCP: Done.  
Her address 10.1.1.3, we want 10.1.1.3
*Jan  1 00:58:48.731: As1/16 IPCP: O CONFACK [ACKrcvd] id 4 len 10
*Jan  1 00:58:48.731: As1/16 IPCP:    Address 10.1.1.3 (0x03060A010103)
*Jan  1 00:58:48.731: As1/16 IPCP: State is Open

!--- IPCP negotiation is complete. The user is now connected.

*Jan  1 00:58:48.731: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:48.731: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:48.731: AAA/ACCT/DS0: channel=0, ds1=1, t3=0, slot=7, ds0=117444608
*Jan  1 00:58:48.731: As1/16 IPCP: Install route to 10.1.1.3

!--- A route to the client is installed in the routing table. 
!--- You can verify this with the show ip route command.

*Jan  1 00:58:49.495: %LINEPROTO-5-UPDOWN: 
Line protocol on Interface Async1/16, changed state to up

!--- Interface Async 1/16 is up. 

トラブルシューティング リソース

これらのトラブルシューティングリソースを要求に応じて使用して下さい:

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 5142