アプリケーション ネットワーキング サービス : Cisco 500 シリーズ コンテンツ エンジン

ACNS ソフトウェア4.x を使用したトランスペアレンとトプロキシ・メディア・リダイレクション設定

2016 年 10 月 28 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


目次


概要

このドキュメントでは、Web Cache Coordination Protocol(WCCP)バージョン 2 を使用した透過的およびプロキシ メディア キャッシング用に Cisco Cache および Content Engine を設定する方法について説明します。Cisco ACNS リリース 4.x では、RealNetworks, Inc. の RealProxy がオプションとして含まれており、リアルタイム ストリーミング プロトコル(RTSP)ベースのストリーミングおよび他の Real PNM(RealNetworks メタファイル)形式の両方で、ストリーム分割(ライブ フィードの配布)およびメディア キャッシングのストリーミングの両方がサポートされます。leavingcisco.com

Content Engine は透過的に WCCP ルータからリダイレクトされる RTSP 要求、また RealPlayer クライアントソフトウェアからの従来のプロキシスタイル RTSP 要求を受け入れるために設定することができます。 ストリーミング メディア キャッシュは、要件なしで後続のユーザーに起源 サーバに接続するのに動作することができる延長にユーザが既にキャッシュされたストリーミング メディア ファイルを表示していたらコンテンツをオンデマンド式で提供します。 ブロードキャストがキャッシュすることができないことに注意して下さい。

Content Engine を RTSP トラフィックを受け入れるために設定するためにこれらのステップを完了して下さい:

  1. IP アドレス、ポートおよび Content Engine の RealProxy で使用されるライセンスを入力するグローバル コンフィギュレーション モードの rtsp proxy コマンドを発行して下さい。

  2. あらゆる WCCP 対応 ルータとの Content Engine を登録する wccp media-cache global configuration コマンドを発行して下さい。

ストリーミング メディア オブジェクトはメディア ファイル システム(mediafs)ディスク の パーティションで RealProxyソフトウェアがソフトウェアファイル システム(swfs)パーティションにインストール手順の一部としてコピーされる間、キャッシュされます。 mediafs 配分を作成する disk コマンドを発行して下さい; これらの配分を維持する mediafs コマンドを発行して下さい(ハードディスク磁気ディスク装置のディスク の パーティションのさらに詳しい詳細については管理を参照して下さい)。 RealProxyソフトウェアは RealAdministrator GUI と管理することができますか。 (このページにアクセスするため、デフォルトユーザ名/パスワードは admin/ダイヤモンドです)。

WCCP 対応 ルータを設定するために、wccp サービス グループ 80 コマンドを発行する必要があります。 コマンド 出力は Configurations セクションで示されています。

はじめに

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

前提条件

このドキュメントに関する固有の要件はありません。

要件

このドキュメントの読者は次のトピックについて理解している必要があります。

  • ACNS ソフトウェア リリース 4.x または それ 以降を実行する Content Engine

  • マウントされる mediafs パーティションによってインストールされる RealProxyソフトウェア

キャッシュソフトウェアの RealProxy 機能をアクティブにするためにライセンスキーを購入して下さい。 Cisco.com の発注に関しては、発注を参照して下さい。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • Cisco Content Engine 590 クリアされたコンフィギュレーションを用いるラボ 環境の実行 Cisco ACNS ソフトウェア リリース 4.x または それ 以降

  • Cisco IOS ソフトウェア リリース 12.0.18(S) を実行する Cisco 7513 ルータ

設定

このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

/image/gif/paws/4717/media_redir.jpg

設定

Cisco Cache Engine 560 (Cisco か。 ACNS ソフトウェア リリース 4.x)
hostname disaster

!

ip domain-name cisco.com

!

interface FastEthernet 0/0

ip address 172.17.241.108 255.255.255.0

exit

interface FastEthernet 0/1

shutdown

exit

!

ip default-gateway 172.17.241.45

!

ip name-server 144.254.6.77

!

!

wccp router-list 1 172.17.241.29 172.17.241.31 172.17.241.45

wccp web-cache router-list-num 1

wccp media-cache router-list-num 1

wccp version 2

!

!

rtsp proxy media-real license-key <removed>

rtsp proxy media-real ip-address 172.17.241.108

rtsp proxy media-real enable?

rtsp proxy incoming 554?

rtsp proxy l4-switch enable

!

!

username admin password 1 Gn1nQzm/arxcI

username admin privilege 15

username cisco password 1 714DWnzYTRHC.

username cisco privilege 15

!

!
Building configuration...

Current configuration : 3071 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

no service single-slot-reload-enable

!

hostname lsd

!

ip subnet-zero

ip wccp web-cache

ip wccp 80

ip cef

no ip domain-lookup

ip domain-name cisco.com.

ip name-server 144.254.6.77

!

interface Ethernet5/0

?ip address 172.17.241.45 255.255.255.0

?no ip directed-broadcast

?ip wccp 80 redirect out

!

interface Ethernet5/1

?ip address 10.10.10.1 255.255.255.0

?no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.241.1

!

line con 0

?exec-timeout 0 0

line aux 0

line vty 0 4

?password <removed>

?login

!

end

debug コマンドと show コマンド

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

特定の show コマンドは、Output Interpreter Tool登録ユーザ専用)によってサポートされています。このツールを使用すると、show コマンド出力の分析を表示できます。

disaster#show mediafs volumes

disk00/03 :    mounted  size: 10669934

disk01/00 :    mounted  size: 14226579

disk01/02 :   formatted  size: 7113289
disaster#show statistics mediacache real requests

                  Media Cache Statistics - Requests

                                                Total             % of Requests

                            ---------------------------------------------------

     Total Received Requests:                       5                         -

            Demand Cache Hit:                       3                      60.0

           Demand Cache Miss:                       2                      40.0

         Demand Pass-Through:                       0                       0.0

                  Live Split:                       0                       0.0

           Live Pass-Through:                       0                       0.0

disaster#show statistics mediacache real savings

             Media Cache Statistics - Savings

                        Requests                          Bytes

         -----------------------------------------------------------

  Total:                       5                       14617438

   Hits:                       3                        6458830

   Miss:                       2                        8158608

Savings:                    60.0 %                         44.2 %

disaster#show rtsp all

Media Types:

  Servicing Real Media

Real Proxy License Key:

  Installed

Media Specific Info:

  Real Proxy IP address: 172.17.241.108

Incoming Proxy-Mode:

  Servicing Proxy mode RTSP connections on port: 554

RTSP Transparent Proxy (WCCP):

  Configured for port: 554

RTSP Transparent Proxy (L4 Switch):

  Configured for port: 554
disaster#show wccp 80 detail



Service Details for Media Cache Service

        Service Enabled                    : Yes

        Service Priority                   : 200

        Service Protocol                   : 6

        Application                        : Streaming

        Service Flags (in Hex)             : 512

        Service Ports                      :    554     0     0     0

                                           :      0     0     0     0

        Security Enabled for Service       : No

        Multicast Enabled for Service      : No

        Weight for this Web-CE: 0
lsd#show ip wccp 80 detail

WCCP Cache-Engine information:

        IP Address:            172.17.241.108

        Protocol Version:      2.0

        State:                 Usable

        Redirection:           GRE

        Initial Hash Info:     00000000000000000000000000000000

                               00000000000000000000000000000000

        Assigned Hash Info:    FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

                               FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF

        Hash Allotment:        256 (100.00%)

        Packets Redirected:    35

        Connect Time:          23:41:34
lsd#show ip wccp

Global WCCP information:

    Router information:

        Router Identifier:                   172.17.241.45

        Protocol Version:                    2.0



    Service Identifier: web-cache

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            0

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        0

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none



    Service Identifier: 80

        Number of Cache Engines:             1

        Number of routers:                   1

        Total Packets Redirected:            35

        Total Packets Fast Redirected:       0

        Total Packets CEF Redirected:        35

        Total Packets DCEF Redirected:       0

        Redirect access-list:                -none-

        Packets Denied Redirect (ACL):       0

        Packets Denied Redirect (Policy):    0

        Total Packets Unassigned:            0

        Group access-list:                   -none-

        Total Messages Denied to Group:      0

        Total Authentication failures:       0

        Policy Tag:                          0

        Policy Type:                         none

Cache Engine show コマンド

show コマンド 説明
show wccp content-engines WCCP Content Engine 情報を表示する。
show wccp flows media-cache メディア キャッシングサービス パケットフローを表示する。
show wccp routers WCCP ルータ リストを表示する。
show wccp services 設定される WCCP サービスを表示する。
show wccp slowstart WCCP 遅い開始するを表示する。
show wccp status ステータスを実行する WCCP を表示する。
show statistics mediacache real savings セーブ統計量を表示する。
show statistics mediacache real requests 要求統計情報を表示する。
show rtsp all すべての RTSP 設定を表示します。
show rtsp proxy プロキシ モード の 設定を表示します。
show mediafs volumes mediafs 音量を表示する。

Cache Engine debug コマンド

debug コマンド 説明
debug wccp all すべてのデバッグをつける有効 WCCP。
debug wccp events 有効 WCCP イベント。
debug wccp packets 有効 WCCP パケット関連の情報。

Router show コマンド

show コマンド 説明
show ip wccp 80 detail 特定のサービスグループのための Cache Engine および WCCP ルータ統計情報を表示する。
show ip wccp 80 view サービス グループ意見情報を表示する

Router debugコマンド

debug コマンド 説明
debug ip wccp events :重要な WCCP イベントの情報を表示します。 WCCP イベントを表示する。
debug ip wccp packets WCCP パケット関連の情報を表示する。

コマンドの概要

これらの Cache engine コマンドはこの設定で使用されました:

  • wccp バージョン {1 | 2}

  • wccp router-list number ip-address

  • wccp メディア キャッシュ router-list-num 番号

  • rtsp プロキシ メディア実質ライセンスキー キー

  • rtsp proxy media-real ip-address ip-address

  • rtsp プロキシ メディア実質イネーブル

  • rtsp プロキシ 着信ポート

この設定では、次のルータのコマンドが使用されています。

  • IP wccp {web-cache | サービス番号}

  • IP wccp {web-cache | サービス番号}リダイレクト


関連情報


Document ID: 4717