アプリケーション ネットワーキング サービス : Cisco LocalDirector 400 シリーズ

プロキシ FTP サービスを使用しないで LocalDirector で FTP サーバのロード バランシングを行う

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック


Cisco は Cisco LocalDirector のための終りの販売をアナウンスしました。 詳細については、LocalDirector 400 シリーズ 廃止および終りの販売注意および製品速報参照して下さい。


目次


概要

このドキュメントでは、プロキシ FTP サービスを使用しないで LocalDirector によりファイル転送プロトコル(FTP)サーバをロード バランシングする方法について説明します。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

表記法

ドキュメントの表記法の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

問題およびソリューション

LocalDirector のようなデバイスを通した FTP を管理する主要な問題は Dチャネルが大抵原因です。 以下は 2 つの可能 な シナリオです:

  1. ポート FTP: 別名アクティブな FTP。 データ接続は制御通信路を Port コマンドによって渡されるクライアントのポートへのサーバ ポート 20 によって開きます。

  2. PASS FTP: データ接続はクライアントによって開始されます。 サーバは IP アドレスを送信 し、ポートはクライアント 制御通信路上のが付いている接続を開かなければなりません。

シナリオ 1

シナリオ第 1 の問題は、ポート FTP、内部サーバの初期化されたトラフィックのためのフロー エントリを作成するように LocalDirector が指示されなければならないことです。

通常、このシナリオのソリューションは static コマンドを発行することです。 しかし FTP トラフィックに関しては LocalDirector はそれを自動的に適用します。

シナリオ 2

シナリオ第 2 に 2 つの問題が、PASS FTP あります。 最初の問題はロードつりあい機がクライアントからの仮想サーバで設定される物と異なっている宛先TCP ポートへの接続を期待するように指示されなければならないことです。

この問題のソリューションは 172.17.241.254:0:0:tcp のような非ポート基盤 設定を作成することです。 ポート基盤 ソリューションの使用なによって、LocalDirector は仮想 IP アドレスを見つける各レイヤ4 (L4)プロトコルのためのフローを受け入れ、作成します。 しかし LocalDirector の FTP によってこれは 172.17.241.254:21:0:tcp のようなポート基盤 設定で必要、ではないです。

LocalDirector は受動データ転送を引き起こすコマンドを代行受信するために FTP 制御 セッションに検知 し続けます。

第 2 問題は LocalDirector が PASS FTP モードのクライアントにサーバによって送信 される IP アドレスの変換処理しなければならないことです。

これは FTP プロキシサービスなしで、自動的にされます。 コマンドがデータ接続発行される時はいつでも引き起こす クライアントが接続しなければならないポート FTPセッションの間に下記に示されているようにおよび IP アドレスは、示されています。

> 227 Entering Passive Mode (172,17,241,254,95,57) 

返されるアドレスが外部 VIP およびない内部 実 アドレスであることがわかります。 これは LocalDirector が制御接続のパケットのペイロードを視聴し続けることを意味します。 詳細については下記の図を参照して下さい。

lb_ftp_servers.gif

サンプルコマンド出力は下記に提供されます。

[OK] 
localdirector# sho conf 
: Saved 
: LocalDirector 420 Version 4.2.2 
: Uptime is 0 weeks, 0 days, 3 hours, 0 minutes, 35 seconds 
syslog output 20.3 
no syslog console 
enable password 000000000000000000000000000000 encrypted 
hostname localdirector 
no shutdown ethernet 0 
no shutdown ethernet 1 
shutdown ethernet 2 
shutdown ethernet 3 
interface ethernet 0 10baset 
interface ethernet 1 10baset 
interface ethernet 2 100basetx 
interface ethernet 3 100basetx 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure? 0 
no secure? 1 
no secure? 2 
no secure? 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
no ping-allow 3 
ip address 172.17.241.11 255.255.255.0 
arp timeout 30 
no rip passive 
rip version 1 
failover ip address 172.17.241.27 
no failover 
failover hellotime 30 
password dfeaf10390e560aea745ccba53e044ed encrypted 
snmp-server enable traps 
snmp-server community public 
no snmp-server contact 
no snmp-server location 
virtual 172.17.241.254:21:0:tcp is 
real 172.17.241.126:21:0:tcp is 
bind 172.17.241.254:21:0:tcp 172.17.241.126:21:0:tcp 

FTPセッションのログは下記にあります。

smarsill@bru-cse-126% ftp 172.17.241.254 
Connected to 172.17.241.254. 
220 CISCO FTP server (Version wu-2.6.1(1) Wed Aug 9 05:54:50 EDT 2000) ready. 
Name (172.17.241.254:smarsill): cisco 
331 Password required for cisco. 
Password: 
230 User cisco logged in. 
Remote system type is UNIX. 
Using binary mode to transfer files. 
ftp> ls 
227 Entering Passive Mode (172,17,241,254,95,57) 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> pass 
Passive mode off. 
ftp> ls 
200 PORT command successful. 
150 Opening ASCII mode data connection for /bin/ls. 
total 24 
-rw-------??? 1 cisco??? cisco??????? 4088 Sep? 3 11:55 .bash_history 
-rw-r--r--??? 1 cisco??? cisco????????? 24 Feb 16? 2001 .bash_logout 
-rw-r--r--??? 1 cisco??? cisco???????? 230 Feb 16? 2001 .bash_profile 
-rw-r--r--??? 1 cisco??? cisco???????? 124 Feb 16? 2001 .bashrc 
-rw-r--r--??? 1 cisco??? cisco???????? 688 Feb 16? 2001 .emacs 
-rw-r--r--??? 1 cisco??? cisco??????? 3651 Feb 16? 2001 .screenrc 
226 Transfer complete. 
ftp> 

最後のコマンドが発行された後 netstat - n コマンドの出力は下記にあります。

cisco@localhost cisco]$ netstat -n 
Active Internet connections (w/o servers) 
Proto Recv-Q Send-Q Local Address?????????? Foreign Address???????? State 
tcp??????? 0????? 0 172.17.241.126:20?????? 144.254.3.201:40411???? TIME_WAIT?? 

!--- Data Active expired.
 
tcp??????? 0????? 0 172.17.241.126:24377??? 144.254.3.201:40410???? TIME_WAIT?? 

!--- Data Passive expired.

tcp??????? 0????? 0 172.17.241.126:21?????? 144.254.3.201:40408???? ESTABLISHED 

!--- Control.

tcp??????? 0??? 126 172.17.241.126:23?????? 144.254.3.201:40220???? ESTABLISHED 

!--- Telnet session. 

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 4068