交换机 : Cisco Catalyst 6500 系列交换机

Catalyst 6500系列交换机使用VPLS配置示例

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 12 月 19 日) | 反馈


目录


简介

本文为虚拟专用LAN服务(VPLS)提供一配置示例在Cisco Catalyst 6500系列交换机为了enable (event)企业由他们的服务提供商通过一起连接他们的从多个站点的基于以太网的LAN。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • Cisco Catalyst 6500 系列交换机的配置基础知识

  • 有VPLS基础知识

使用的组件

本文中的信息基于 Cisco Catalyst 6500 系列交换机。

有SIP-600/SUP3B的Catalyst 6500交换机支持VPLS或以后用Cisco IOS�软件版本12.2(33)SXH或以上。交换机要求使用SIP卡执行VPLS功能。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

从企业方面, VPLS使用服务提供商的公共网络作为连接多个站点CE设备,看上去连接到一逻辑网桥在IP/MPLS网络被管理的一个巨型以太网LAN。

VPLS简化LAN/WAN边界并且提交作为以太网接口,不管位置,看来在同样LAN。

首先请创建一个虚拟转发实例(VFI)在每台Catalyst 6500交换机为了设置VPLS。VFI指定VPLS域的VPN ID,其它设备地址在域的和通道信令每对等设备的种类和封装机制。套VFIs由设备的互连形成了呼叫VPLS实例,形成在分组交换网络的逻辑网桥。

信息包转发决定做,当您寻找Layer2虚拟转发实例时(VFI)。为了避免循环在供应商核心的数据包的问题,设备强制执行模拟的VC的水平分割原理。

在您配置VPLS前,请配置在核心的MPLS,以便标签交换路径(LSP)存在设备之间。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/113563-vpls-6500-config-01.gif

配置

本文档使用以下配置:

Catalyst 6500 交换机 1
switch6500_1#configure terminal


!--- Enable the Layer 2 VFI manual configuration mode.

switch6500_1(config)#l2 vfi VPLS-A manual

!--- Configure a VPN ID for a VPLS domain.

switch6500_1(config-vfi)#vpn id 500

!--- Specify the remote peering router ID 
!--- and the tunnel encapsulation type or the pseudo-wire 
!--- property to be used to set up the emulated VC.

switch6500_1(config-vfi)#neighbor 10.7.1.3 encapsulation mpls
switch6500_1(config-vfi)#exit

switch6500_1(config)#interface Loopback 0
switch6500_1(config-if)#ip address 10.7.1.2 255.255.255.255

switch6500_1(config)#interface GigabitEthernet 6/3
switch6500_1(config-if)#switchport

!--- Set the interface as an 802.1Q tunnel port. 

switch6500_1(config-if)#switchport mode dot1qtunnel

!--- Set the VLAN when the interface is in Access mode.

switch6500_1(config-if)#switchport access vlan 500


!--- Create a dynamic switched virtual interface (SVI).

switch6500_1(config)#interface Vlan 500

!--- Disable IP processing.

switch6500_1(config-if)#no ip address

!--- Specify the Layer 2 VFI that you are binding to the VLAN port.

switch6500_1(config-if)#xconnect vfi VPLS-A
switch6500_1(config-if)#exit

switch6500_1(config)#vlan 500
switch6500_1(config-vlan)#state active
switch6500_1(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_1(config)#copy running-config startup-config
switch6500_1(config)#exit

Catalyst 6500 交换机 2
switch6500_2#configure terminal

switch6500_2(config)#l2 vfi VPLS-B manual
switch6500_2(config-vfi)#vpn id 500
switch6500_2(config-vfi)#neighbor 10.7.1.2 encapsulation mpls
switch6500_2(config-vfi)#exit

switch6500_2(config)#interface Loopback 0
switch6500_2(config-if)#ip address 10.7.1.3 255.255.255.255

switch6500_2(config)#interface GigabitEthernet 3/3
switch6500_2(config-if)#switchport
switch6500_2(config-if)#switchport mode dot1qtunnel
switch6500_2(config-if)#switchport access vlan 500

switch6500_2(config)#interface Vlan 500
switch6500_2(config-if)#no ip address
switch6500_2(config-if)#xconnect vfi VPLS-B
switch6500_2(config-if)#exit

switch6500_2(config)#interface vlan 500
switch6500_2(config-vlan)#state active
switch6500_2(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_2(config)#copy running-config startup-config
switch6500_2(config)#exit

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 113563