交换机 : Cisco Nexus 5000 系列交换机

在VIC适配器在UCS货架服务器和连结5500交换机之间的FCoE配置

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈

简介

本文描述如何配置在以太网(FCoE)连接的光纤信道虚拟接口在思科统一计算系统(UCS)货架服务器安装的界面卡(VIC)适配器和思科连结之间5500台(连结5K)系列交换机。两拓扑示例包括思科结构扩展器(FEX)设备,并且一拓扑示例不。

贡献用帕德马纳班, Cisco TAC工程师。

先决条件

要求

Cisco 建议您了解以下主题:

  • Cisco连结5500系列交换机
  • 思科UCS货架服务器-思科集成管理控制器(CIMC)配置
  • FCoE基本的了解

此配置在环境存在:

  • 存储区域网络(SAN)阵列配置为了为虚拟主机总线适配器(vHBAs)提供存取对于逻辑单元编号(LUN)在思科VIC卡。
  • Cisco连结版本5.1(3)N1(1a)或以上在Cisco连结5K交换机安装。
  • 必要的许可证在连结5K交换机安装。

参考每个特定的硬件设备配置指南限制和兼容性信息。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 有VIC的1225思科UCS C220 M3服务器
  • CIMC 1.5.4固件套件
  • 与版本6.0(2)N2(1)的连结5548UP
  • FEX型号-连结2232PP

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

概述

这是配置过程的概述:

  1. 对于一个新的设置,请执行在连结5K交换机的基本配置。如果添加一个服务器到现有的网络,您能跳到此步骤。
  2. 配置在UCS服务器的VIC适配器。
  3. 配置根据您的拓扑的连结5K交换机。

服务器可以在这三拓扑之一中部署:

  • 拓扑1 -在连结5K交换机(vPC)配置的虚拟端口信道和融合网络适配器(CNA)端口直接地连接对连结5K交换机
  • 拓扑2 - FEX连接对在直通模式的一连结5K交换机和CNA连接对FEX端口
  • 拓扑3 - FEX连接对在增强版vPC模式的一连结5K交换机和CNA连接对FEX端口

本文为每拓扑的FCoE连接提供配置示例。

注意

使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

命令输出解释程序工具仅限注册用户)支持某些 show 命令。请使用Output Interpreter Tool为了查看show命令输出分析。

步骤 1:配置新的设置

即使本文着重在VIC适配器和连结5K交换机的FCoE配置,也包括需要的基本配置在vPC和完整性的FCoE功能。

在本例中的拓扑使用虚拟存储区域网络(VSAN) 100和VSAN 200作为两个SAN结构。这些VSAN在A侧和连结5K交换机的B端创建和被映射对FCoE VLAN 100和200,分别。

对于一个新的设置,此步骤描述如何执行在连结5K交换机的基本配置:

  1. 启用必需的功能(链路层发现协议[LLDP]、链路汇聚控制协议[LACP], FCoE, FEX, vPC)在连结5K交换机。请参阅必需的功能配置关于此步骤示例。
  2. 完成基本vPC配置:
    1. 创建vpc domain。
    2. 创建vPC对等体保活链路。
    3. 配置vPC对等体链路。请参阅基本vPC配置关于示例如何执行步骤1-3和如何启用在两连结5K交换机的vPC。
    4. 创建vPC或者重新使用端口通道。
    5. 验证vPC。
  3. 配置VSAN。请参阅VSAN配置关于此步骤示例。

注意:如果添加一个服务器到现有的网络,您能跳到这些步骤;继续对步骤2:配置UCS服务器和VIC适配器

必需的功能配置

5548-switch# configure terminal
5548-switch(config)# feature lldp
5548-switch(config)# feature lacp
5548-switch(config)# feature fcoe
5548-switch(config)# feature fex
5548-switch(config)# feature vpc
5548-switch(config)# end

基本vPC配置

5548-switch# configure terminal
5548-switch(config)# vpc domain 150
5548-switch (config-vpc-domain)# peer-keepalive destination <peer-switch-ip>
source <source-ip> vrf management
5548-switch(config-vpc-domain)# interface port-channel 150
5548-switch(config-if)# switchport mode trunk
5548-switch(config-if)# vpc peer-link
5548-switch(config-if)# no shut

VSAN配置

5548-switch-A # configure terminal
5548-switch-A(config)# vsan database
5548-switch-A(config-vsan-db)#vsan 100
5548-switch-A(config)#exit

5548-switch-A(config)#vlan 100
5548-switch-A(config-vlan)#fcoe vsan 100

5548-switch-B # configure terminal
5548-switch-B(config)#vsan database
5548-switch-B(config-vsan-db)#vsan 200
5548-switch-B(config)#exit

5548-switch-B(config)#vlan 200
5548-switch-B(config-vlan)#fcoe vsan 200

步骤 2:配置UCS服务器和VIC适配器

配置在UCS服务器的VIC适配器。此步骤描述如何适用于此配置所有思科VIC (P81E或VIC 1225或VIC 1225T)适配器:

  1. 请使用主机更新工具为了更新服务器硬件硬件元件的固件到新版本。请务必更新VIC固件。
  2. 默认情况下, VIC适配器在古典以太网(CE)模式运行和配置与两个虚拟网络网络界面控制器(vNICs)和两vHBAs。这些vNICs中的每一和vHBAs被别住对上行链路DCE物理接口;即fc0被别住uplink端口DCE端口0,并且fc1被别住uplink端口适配器的DCE端口1 :

    117280-config-fcoe-01.png
  3. 启动服务器,并且注意VIC适配器详细信息在库存部分填充。
  4. 点击vHBAs选项卡,并且选择vHBA接口(fc0或fc1)。
  5. 点击属性,然后配置在VIC适配器的FCoE属性。请务必定义FCoE VLAN ID在默认VLAN文本字段:

    117280-config-fcoe-02.png

    如果计划从SAN启动,检查FC SAN引导程序复选框和添加目标WWPN到引导程序表:

    117280-config-fcoe-03.png
  6. 重新启动配置更改的服务器能生效。

步骤 3:配置不同的拓扑的连结5K交换机

服务器可以在三拓扑之一中部署。此部分描述如何配置根据您的拓扑的连结5K交换机。

所有三拓扑的常见配置指南是:

  1. 虚拟光纤信道(VFC)接口一定到成员端口(以太网接口)端口通道。
  2. 连接孔在中继模式,并且FCoE VLAN配置作为非本土VLAN。
  3. 交换机端口的生成树类型配置,因此他们连接到服务器,当边缘中继。

本文为结构A提供配置示例;您应该执行在另一交换机的一相似的配置结构的B。

拓扑1 :CNA端口直接地连接对连结5K交换机

概述

在此方案中,连结5K交换机在vPC,并且服务器CNA端口直接地连接到两连结5K交换机。此步骤描述此拓扑的配置:

  1. 关联以太网接口对新的端口信道接口。
  2. 配置端口通道作为有FCoE的VLAN一中继被标记的,并且连结端口通道与vPC ID。
  3. 创建VFC接口,并且绑定它到Port-Channel成员(以太网接口)。
  4. 关联VFC接口对对应的VSAN ID。请参阅在连结5K交换机的旁拉的配置示例关于步骤示例1-4。
  5. 重复步骤1-4为了配置连结5K交换机的B端。
  6. 验证配置。

117280-config-fcoe-04.png

在连结5K交换机的旁拉的配置示例

N5548UP-A(config)# int eth 1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A# configure terminal
N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)# switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exitN5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

验证

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 1
interface Ethernet1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet1/1
switchport trunk allowed vsan 100
no shutdown

拓扑2 :FEX连接对连结5K在直通模式的交换机,并且CNA连接到FEX端口

概述

在此方案中, FEX连接到在直通模式的连结5K交换机,并且CNA连接到FEX端口。此步骤描述此拓扑的配置:

直通FEX配置

  1. 分配FEX ID。
  2. 关联与新的端口信道接口ID的以太网接口,并且配置有FEX结构参数的新的端口通道。请参阅配置示例关于步骤示例1-2。

    主机vPC配置

  3. 连结FEX主机接口(HIF)与新的端口信道接口ID,并且配置Port-Channel参数。
  4. 关联HIF端口通道对vPC接口。
  5. 创建VFC接口,并且绑定它到主机端口信道的成员(以太网)端口。请参阅主机vPC配置关于步骤示例3-5。
  6. 验证配置。

重复步骤1-4在连结5K交换机的B端,并且请使用同一个vPC接口号在HIF端口通道下。

117280-config-fcoe-05.png

配置示例

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 210
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 210
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

主机vPC配置

<---Create HIF port-channel-->

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Configure port-channel parameters-->

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 10
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Create vfc interfvace and bind to port-channel (Ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

验证

N5548UP-A# show run int port-channel 210 membership

interface port-channel210
switchport mode fex-fabric
fex associate 101

interface Ethernet1/5
switchport mode fex-fabric
fex associate 101
channel-group 210

interface Ethernet1/6
switchport mode fex-fabric
fex associate 101
channel-group 210

N5548UP-A# show int fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/5 Active 1 N2K-C2232PP-10GE SSI142602QN
101 Eth1/6 Active 2 N2K-C2232PP-10GE SSI142602QN

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 10

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet101/1/1
switchport trunk allowed vsan 100
no shutdown

拓扑3 :FEX连接对连结5K在增强版vPC模式的交换机,并且CNA连接到FEX端口

概述

在此方案中, FEX连接到在增强版vPC模式的连结5K交换机,并且CNA连接到FEX端口。

SAN结构A流量(FCoE VLAN 100)关联与连结5K交换机的FEX 101/A侧。SAN结构B流量(FCoE VLAN 200)关联与连结5K交换机的FEX 102/B端。

对于一个两个成员主机端口信道,您必须配置两个FEX设备的HIF端口在两连结5K交换机;即总共四HIF端口配置要求。

此步骤描述此拓扑的配置:

Active-Active FEX配置

  1. 分配FEX ID。
  2. 添加‘fcoe’关键字在每连结5K交换机的单个FEX下为了启用SAN结构隔离。
  3. 创建FEX结构端口通道。
  4. 重复另一个FEX的步骤1和3在同一连结5K交换机。
  5. 重复步骤1-4在连结5K交换机的B端。请参阅Active-Active FEX配置FCoE关键字在FEX 102在连结5K交换机B端关于示例。

    主机vPC配置

  6. 创建端口信道接口,并且配置必要的VLAN。
  7. 配置HIF端口(FEX接口连接对CNA)两的FEXs,并且允许FCoE VLAN和以太网VLAN,然后连结HIF端口与在步骤创建的主机Port-Channel ID 6。
  8. 创建VFC接口,并且绑定它到主机端口信道的成员(以太网)端口。
  9. 重复步骤6-8在连结5K交换机的B端,并且请使用同一个主机端口信道接口ID。请参阅主机vPC配置关于示例。

    VFC接口配置

  10. 创建VC接口,并且绑定它到Port-Channel成员(HIF)端口。
  11. 分配VFC接口到适当的VSAN。
  12. 重复步骤10-11在连结5K交换机的B端。请参阅VFC配置关于示例。
  13. 验证配置。

117280-config-fcoe-06.png

Active-Active FEX配置

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# fcoe
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/3 - 4
N5548UP-A(config-if-range)# channel-group 201
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit
N5548UP-A(config)# interface port-channel 201
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)# vpc 201
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

N5548UP-A# configure terminal
N5548UP-A(config)# fex 102
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 202
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 202
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 102
N5548UP-A(config-if)# vpc 202
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

在FEX 102的FCoE关键字在连结5K交换机B端

N5548UP-B# configure terminal 
N5548UP-B(config)# fex 102
N5548UP-B(config-fex)# fcoe
N5548UP-B(config-fex)# exit

主机vPC配置

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface ethernet 102/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

VFC配置

<---Create vfc interface and bind to port-channel member (ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

验证

N5548UP-A# show fex
FEX FEX FEX FEX
Number Description State Model Serial
------------------------------------------------------------------------
101 FEX0101 Online N2K-C2232PP-10GE SSI142602QN
102 FEX0102 Online N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show interface fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/3 Active 2 N2K-C2232PP-10GE SSI142602QN
102 Eth1/4 Active 1 N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show fex 101 detail
FEX: 101 Description: FEX0101 state: Online
FEX version: 6.0(2)N2(1) [Switch version: 6.0(2)N2(1)]
FEX Interim version: 6.0(2)N2(1)
Switch Interim version: 6.0(2)N2(1)
Extender Serial: SSI142602QN
FCoE Admin: true
FCoE Oper: true
FCoE FEX AA Configured: true

N5548UP-A# show run interface port-channel 1 membership

interface port-channel1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000

interface Ethernet102/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

N5548UP-A# show int vfc 1
vfc1 is trunking
Bound interface is Ethernet101/1/1
Port WWN is 20:00:54:7f:ee:e1:6a:bf
Admin port mode is F, trunk mode is on
Port mode is TF
Port vsan is 100
Trunk vsans (admin allowed and active) (100)
Trunk vsans (up) (100)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()

N5548UP-A# show run int port-channel 201 membership

interface port-channel201
switchport mode fex-fabric
fex associate 101
vpc 201

interface Ethernet1/3
switchport mode fex-fabric
fex associate 101
channel-group 201

interface Ethernet1/4
switchport mode fex-fabric
fex associate 101
channel-group 201

N5548UP-A# show run int port-channel 202 membership

interface port-channel202
switchport mode fex-fabric
fex associate 102
vpc 202

interface Ethernet1/5
switchport mode fex-fabric
fex associate 102
channel-group 202

interface Ethernet1/6
switchport mode fex-fabric
fex associate 102
channel-group 202

当VIC固件顺利地检测LUN并且更新引导程序表,从服务器启动顺序的此屏幕画面验证交换机配置:

117280-config-fcoe-07.png

验证

验证程序在配置示例内包括。

故障排除

本部分提供了可用于对配置进行故障排除的信息。

执行这些检查为了确定VFC是否出现:

  1. 验证电缆正确地连接在适配器端口之间被映射对vHBA,并且连结5K交换机端口有必要的VSAN。
  2. 确保不管理性被关闭的接口。
  3. 验证FCoE VLAN在VFC跳起的以太网接口配置。

请使用这些命令为了验证配置:

  • show run fcoe
  • 显示vsan
  • show VLAN fcoe
  • show interface vfc ID
  • 显示vpc
  • show flogi database

相关信息



Document ID: 117280