路由器 : Cisco Nexus 7000 10-槽交换机

连结7000 FAQ

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


问题


简介

本文讨论用Cisco Nexus 7000系列交换机(FAQ)关联的多数常见问题。

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

Q. 什么是命令使用验证“HSRP活动状态”连结7000系列交换机的?

A. 命令是show hsrp活跃show hsrp摘要

Nexux_7K# show hsrp br
                   P indicates configured to preempt.
                   |
Interface Grp Prio P State    Active addr   Standby addr   Group addr
Vlan132   32  90   P Standby  10.101.32.253 local          10.101.32.254  (conf)
Vlan194   94  90   P Standby  10.101.94.253 local          10.101.94.254  (conf)
Vlan2061  61  110  P Active   local         10.100.101.253 10.100.101.254 (conf)

Nexus_7K# show hsrp standb br
                     P indicates configured to preempt.
                     |
Interface  Grp Prio  P State    Active addr    Standby addr Group addr
Vlan132    32  90    P Standby  10.101.32.253  local        10.101.32.254 (conf)
Vlan194    94  90    P Standby  10.101.94.253  local        10.101.94.254 (conf)
Vlan196    96  90    P Standby  10.101.96.253  local        10.101.96.254 (conf)

Q. 在连结7018,当尝试执行‘no shut’在Ethernet1/3, ERROR:时Ethernet1/3 :配置不允许,和首先波尔特GRP的端口投入的错误消息接收。

A. 设备认为波尔特GRP的第一个端口在专用的模式而不是共享模式。当波尔特GRP的第一个端口在专用的模式时,不可能使用波尔特GRP的其他端口。

Q. 什么是vPC,并且什么是其好处?

A. 虚拟PortChannel (vPC)是对两不同物理交换机扩大链路聚合的端口信道概念。

vPC的好处包括:

  • 使用所有可用的上行链路带宽

  • 允许根据链路聚合的能适应Layer2拓扑的创建

  • 排除生成树协议依赖因素在Layer2访问分布层的

  • Enable (event)透明服务器移动性和服务器高可用性(HA)集群

  • 扩展可用的Layer2带宽

  • 简化网络设计

  • 双重归属服务器在主动-主动模式能运行

  • 在链路故障的快速收敛

  • 当单个设备出故障时,改进收敛时间

  • 减少capex和opex

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-10-slot-switch/113010-nexus-7k-faq-01.gif

Q. vPC为什么不阻塞vPC uplink端口?

A. 连结7000有降低横断对等体链路的流量的一个环路预防方法(注定为vPC对等体链路),当没有失败的vPC端口或链路时。规则简单:如果数据包流过vPC对等体链路,可能不出去vPC的任何端口,即使该vPC没有原始VLAN。

Q. 如何创建VDC的对等体链路和每个VDC的Keepalive链路?

A. 配置vPC Keepalive林克和消息

此示例展示如何配置目的地、源IP地址和VRF VPC对等体Keepalive链路的:

switch# configure terminal 
switch(config)# feature vpc
switch(config)# vpc domain 100
switch(config-vpc-domain)# peer-keepalive destination 172.168.1.2 source 
172.168.1.1 vrf vpc-keepalive

创建vPC对等体林克

此示例展示如何配置vPC对等体链路:

switch# configure terminal 
switch(config)# interface port-channel 20
switch(config-if)# vpc peer-link
switch(config-vpc-domain)# 

Q. 什么执行%EEM_ACTION-6-INFORM :被丢弃的数据包由于IDS一致检查的长度在模块消息平均值?

A. Cisco NX-OS支持验证IP信息包保证适当的格式化的入侵检测系统(IDS)检查。这是在5.x的一增强开始处。EEM消息被记录,因为数据包由以太网帧大小比预计长度短包括IP数据包长度加上以太网报头的交换机接收。数据包由硬件丢弃由于此情况。

为了验证IDS丢包从最后交换机重新启动发生了,请发出show hardware forwarding ip verify模块[-]“。

Q. 如何验证在有NX-OS的4.2连结7000系列交换机启用的功能?

A. 发出显示功能命令为了验证。

switch-N7K# show feature
Feature Name          Instance  State
--------------------  --------  --------
tacacs                1         enabled
scheduler             1         enabled
isis                  2         disabled
isis                  3         disabled
isis                  4         disabled
ospf                  1         enabled
ospf                  2         disabled
ospf                  3         disabled


switch-N7K# show run | I feature
feature vrrp
feature tacacs+
feature scheduler
feature ospf
feature bgp
feature pim
feature pim6
feature eigrp
feature pbr
feature private-vlan
feature udld
feature interface-vlan
feature netflow
feature hsrp
feature lacp
feature dhcp
feature tunnel

Q. 有没有配置转换的工具联机在Cisco 6500系列对连结平台?

A. Cisco开发快速配置转换的IOS-NXOS迁移工具在Cisco 6500系列对连结系列OS。

Q. 多少个系统日志服务器可以被添加到连结7000系列交换机?

A. 配置的系统日志服务器最大是3。

Q. 连结是否是7010vPC功能(启用的LACP)与思科ASA EtherChannel功能和与ACE 4710 EtherChannel兼容?

A. 关于vPC,运行LACP (是标准)的所有设备,是与包括ASA/ACE的连结7000兼容。

Q. 什么是孤立的端口?

A. 孤立的端口是没有通过vPC连接的单个连接的设备,但是仍然运载vPC VLAN。在对等体林克关闭或恢复的实例,一个孤立的端口连接性可能一定到vPC失败或恢复过程。发出显示vpc孤立行端口命令为了识别被影响的VLAN。

Q. 多少个OSPF进程可以在虚拟设备上下文(VDC)运行?

A. 可以有OSPFv2四(4)实例在VDC的。

Q. 哪连结7000个模块支持在以太网(FCoE)的光纤信道?

A. Cisco连结7000系列32端口1和万兆以太网模块技术支持FCoE。产品的部件号是N7K-F132XP-15。

Q. 什么是要求的最低的NX-OS版本支持在连结7000系列交换机的FCoE ?

A. 运行Cisco NX-OS版本5.2或以上的Cisco连结7000系列系统支持FCoE。

Q. 在连结,不metric-type关键字是否是可用的在“default-information originate”命令?

A. 使用default-information originate总是一样metric-type [�]命令,在连结,请以metric-type集合条款使用一route-map命令选择[�]为了有功能和在IOS。

例如:

switch(config)#route-map STAT-OSPF, permit, sequence 10
switch(config-route-map)#match interface ethernet 1/2
switch(config-route-map)#set metric-type {external | internal | type-1 | type-2}

Q. 如何再分布已连接路由到在连结7010的OSPF实例与定义量度?

A. 在NX-OS, route-map总是要求,当再分布路由到OSPF实例时,并且您也将使用此route-map设置量度。默认情况下进一步,子网再分配是,因此您不必须添加子网关键字。

例如:

switch(config)#access-list 101 permit ip <connected network> <wildcard> any
switch(config)#access-list 101 permit ip <connected network> <wildcard> any
switch(config)#access-list 101 permit ip <connected network> <wildcard> any
switch(config)#access-list 101 deny any
!
Router(config)# route-map direct2ospf permit 10
Router(config-route-map)# match ip address 101
Router(config-route-map)# set metric <100>

Router(config-route-map)# set metric-type type-1
!
switch(config)#router ospf 1
switch(config-router)#redistribute direct route-map direct2ospf

Q. 什么是ios命令“的ip multicast-routing的”等同的NX-OS命令,并且连结是否7000支持PIM稀疏模式?

A. 命令是功能pim。在NX-OS,组播在启用在每个路由器的PIM或PIM6功能然后启用PIM或PIM6在您希望参加组播的每个接口的稀疏模式之后启用。

例如:

switch(config)#feature pim
switch(config)#interface Vlan[536]
switch(config-if)#ip pim sparse-mode

请参阅Cisco连结7000系列NX-OS组播路由配置指南,版本5.x关于完整的配置指南。

Q. 当我发出“show ip route bgp”命令时,我看到通过OSPF和BGP了解的我的路由。如何能验证在NX-OS哪个永远将使用,并且哪个是备份?

A. 这是什么接收:

Nexus_7010#show ip route bgp
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]

172.20.62.0/23, ubest/mbest: 1/0
    *via 10.194.160.2, [20/0], 18:53:35, bgp-[AS-Number], internal, tag [Number]
     via 10.194.16.5, Vlan116, [110/1043], 18:43:51, ospf-1, intra
172.20.122.0/23, ubest/mbest: 1/0
    *via 10.194.160.2, [20/0], 18:53:35, bgp-[AS-Number], internal, tag [Number]
     via 10.194.16.5, Vlan116, [110/1041], 18:43:51, ospf-1, intra

默认情况下, BGP选择仅单个最佳路径,并且不执行负载均衡。结果,标记用*永远将使用路由,除非断开,到时剩余的路由将变为首选路径。

Q. 我如何避免接收“失败的处理kickstart镜像。当升级在连结7000系列交换机时的镜像升级前检查失败”错误消息?

A. 如果指定的文件名不正确,接收的此错误消息一个潜在原因是。

例如:

switch#install all kickstart bootflash:n7000-sl-kickstart.5.1.1a.bin system
    bootflash:n7000-sl-dk9.5.1.1a.bin

在本例中,文件名包含“sl” (而不是"s1" (第1)的小写字母l)。

Q. 当启用“交换端口模式fex结构”时,如何能避免接收“配置不匹配端口功能”错误消息?

A. 因为端口不是有能力的FEX此错误消息生成:

N7K-2(config)#interface ethernet 9/5
N7K-2(config-if)#switchport mode fex-fabric
ERROR: Ethernet9/5: Configuration does not match the port capability

通过使用show interface ethernet命令,为了解决此问题,请检查端口功能。

例如:

N7K-2#show interface ethernet 9/5 capabilities
Ethernet9/5
  Model:                 N7K-M132XP-12
  Type (SFP capable):    10Gbase-(unknown)
  Speed:                 10000
  Duplex:                full
  Trunk encap. type:     802.1Q
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off/on),tx-(off/on)
  Rate mode:             shared
  QOS scheduling:        rx-(8q2t),tx-(1p7q4t)
  CoS rewrite:           yes
  ToS rewrite:           yes
  SPAN:                  yes
  UDLD:                  yes
  Link Debounce:         yes
  Link Debounce Time:    yes
  MDIX:                  no
  Pvlan Trunk capable:   no
  Port Group Members:    1,3,5,7
  TDR capable:           no
  FabricPath capable:    no
  Port mode:             Routed,Switched
  FEX Fabric:            no
  dot1Q-tunnel mode:     yes

capabilities命令的show interface ethernet 9/5的此输出,您能看到FEX结构:否。这验证端口不是有能力的FEX。为了解决此问题,请升级EPLD镜像对Cisco NX-OS版本5.1(1)或以后。

Q. 当我发出“时错误”发出命令的show interface计数器,我看到一个接口一致张贴错误。什么是fcs-err,并且Rcv-Err在“show interface计数器错误的”输出中发出命令?

A. 这是什么接收:

Nexus-7000#show interface counters errors

----------------------------------------------------------------------------
Port      Align-Err    FCS-Err   Xmit-Err    Rcv-Err  UnderSize OutDiscards
----------------------------------------------------------------------------
Eth1/1            0         26          0         26          0           0

使用fcs-err和Rcv-Err,它通常是暗示您接收坏包。

Q. 如何启用/禁用记录日志链接状态每个在连结7000系列交换机的逐个端口?

A. 所有接口链接状态(up/down)默认情况下消息被记录。链接状态事件可以配置全局或每个接口。一个特定接口的interface命令enable (event)链接状态日志消息。

例如:

N7k(config)#interface ethernet x/x
N7k(config-if)#logging event port link-status

Q. 在连结7000运行的NX-OS 5.1(3), DECNet能桥接在VLAN ?

A. 连结平台支持通过DECNet帧的所有到设备从第2层方面。然而,没有路由的DECNet支持在连结。

Q. 如何检查在连结7000系列交换机的网络时间协议(NTP)状态?

A. 为了显示NTP对等体的状态,请发出显示ntp对等体状态命令:

switch#show ntp peer-status

Total peers : 1

* - selected for sync, + -  peer mode(active),

- - peer mode(passive), = - polled in client mode

    remote               local                 st   poll   reach delay   vrf

-------------------------------------------------------------------------------

*10.1.10.5              0.0.0.0                 1   64     377   0.00134 default

Q. 如何获取show tech-support详细信息的输出?

A. 发出TAC PAC bootflash:// <filename>命令为了重定向输出show tech命令到文件,然后gzip文件。

例如:

switch#tac-pac bootflash://showtech.switch1

发出复制bootflash://showtech.switch1 tftp:// <server IP/<path>命令为了复制从Bootflash的文件到TFTP server。

例如:

switch#copy bootflash://showtech.switch1 tftp://<server IP/<path>

Q. 连结7000可以是DHCP服务器,并且能传递DHCP请求到不同的DHCP服务器每个VLAN ?

A. 连结7000不支持DHCP服务器,但是支持DHCP中继。对于中继,请使用interface命令ip dhcp relay address的x.x.x.x

请参阅Cisco连结7000系列NX-OS安全配置指南,版本5.x关于在Cisco NX-OS设备的动态主机配置协议(DHCP)的更多信息。

Q. 如果XL模式在连结7000设备,启用如何验证?

A. 可扩展功能许可证是启用支持M系列递增表大小L模块的新的连结7000系统许可证。没有许可证,系统在标准模式将运行,含义更加大的表大小都不会可访问。非XL和XL模块在系统支持有,但是对于系统运行在XL模式所有模块需要是有能力的XL,并且可扩展功能许可证需要安装。混合模块支持,当系统运行在非XL模式。如果模块在同一个系统,整个系统落回到普通的最小的值。使用VDCs,如果XL和非XL隔离,则每个VDC认为一个分开的系统,并且可以运行用不同的模式。

为了确认连结7000是否有启用的XL选项,您首先需要检查可扩展功能许可证是否安装。并且,非XL和XL模块在系统支持有,但是为了系统能运行在XL模式,所有模块需要是有能力的XL。

Q. 如何实现在VLAN手工配置的连结7000系列交换机的VTP ?

A. 思科在数据中心不推荐运行VTP。如果某人附加交换机对网络用更高的修订版号,无需更改从服务器的VTP模式,将改写在交换机的VLAN配置。

Q. 有没有Port-Channel负载均衡的最佳实践在连结1000V系列和连结7000系列交换机之间?

A. 没有负载平衡的建议的最佳实践在连结1000V系列和连结7000系列交换机之间。您能根据网络要求选择一个基于流的或一个基于来源的型号。

Q. 在从5.2.1的连结7010升级期间到5.2.3代码,在插槽4的X柱状图模块继续将断电。%MODULE-2-XBAR_DIAG_FAIL :Xbar 4报告的失败由于模块asic报告的同步损耗(DevErr是LinkNum)。尝试对在设备88 (设备错误0x0)错误消息的再同时接收。

A. 此错误消息对应于模块的2.诊断失败。它可能是对X柱状图的连接不好从线路卡,是导致无法的线路卡同步。典型地与这些错误,第一步将重新安装模块。如果那不解决问题,请单个重新安装结构以及模块。

Q. 什么执行%OC_USD-SLOT18-2-RF_CRC :OC2有CRC错误的收到的信息包从MOD 6通过XBAR slot 5/inst 1错误消息平均值?

A. 这些错误表明失败CRC错误错误检查的章鱼引擎收到的帧。这可以由多个原因造成。例如:

  • 硬件故障:

    • Bad链路

    • 背板问题

    • 同步损耗

    • 装置的问题

  • 软件问题:

    • 旧有FPGA

    • 帧转发对LC无法了解

Q. 如何验证在连结7000交换机的丢包?

A. 验证从show interface的输出{/}show hardware内部错误模块module-命令的Rx暂停尾部丢弃字段模块的用这些端口。

例如:

Nexus7K#show interface e7/25
Ethernet7/25 is up

  
!--- Output suppressed


    input rate 1.54 Kbps, 2 pps; output rate 6.29 Mbps, 3.66 Kpps
  RX
    156464190 unicast packets  0 multicast packets  585 broadcast packets
    156464775 input packets  11172338513 bytes
    0 jumbo packets  0 storm suppression packets
    0 runts  0 giants  0 CRC  0 no buffer
    0 input error  0 short frame  0 overrun   0 underrun  0 ignored
    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
    0 input with dribble  0 input discard
    7798999 Rx pause
  TX
    6365127464 unicast packets  6240536 multicast packets  2290164 broadcast packets
    6373658164 output packets  8294188005962 bytes
    0 jumbo packets
    0 output error  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble
    0 Tx pause

在e7/25的暂停表明服务器有跟上流量总量的困难发送对它。

Nexus7k#show hardware internal erroe module 2 | include 
   r2d2_tx_taildrop_drop_ctr_q3
37936 r2d2_tx_taildrop_drop_ctr_q3                  0000000199022704   2 -
37938 r2d2_tx_taildrop_drop_ctr_q3                  0000000199942292   4 -
37941 r2d2_tx_taildrop_drop_ctr_q3                  0000000199002223   5 -
37941 r2d2_tx_taildrop_drop_ctr_q3                  0000000174798985   17 -

这表明流量总量发送对这些设备是太多为传送的接口。因为每个接口配置,因为中继允许所有VLAN的和组播/广播数据流计数器低,看起来那里是可能导致这些接口的丢包的很多单播泛洪。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 113010