统一计算 : Cisco UCS Manager

UCS上行端口信道配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述如何配置在思科UCS服务器的一个上行端口信道。

贡献由Joe LeBlanc和安德鲁凯利, Cisco TAC工程师。

先决条件

要求

思科建议您有端口通道知识,在您尝试此配置前。

使用的组件

本文档中的信息根据思科统一计算系统(UCS)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

配置

UCS端口信道配置静态设置为链路汇聚控制协议(LACP)模式激活。不可能修改此配置;因此,所有上行端口信道配置必须遵守LACP模式激活。或者,您能配置LACP模式被动的上行连接孔。

CLI 配置

这是不可能修改UCS接口配置的示例:

UCS1-B(nxos)# show run interface eth1/19

!Command: show running-config interface Ethernet1/19
!Time: Fri Oct 12 20:25:59 2012

version 5.0(3)N2(2.11)

interface Ethernet1/19
description U: Uplink
pinning border
switchport mode trunk
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
channel-group 100 mode active
no shutdown

这是端口信道接口配置:

UCS1-B(nxos)# show run interface po100

!Command: show running-config interface port-channel100
!Time: Fri Oct 12 20:21:19 2012

version 5.0(3)N2(2.11)

interface port-channel100
description U: Uplink
switchport mode trunk
pinning border
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
speed 10000

您能运行show interface命令在端口通道为了显示Port-Channel成员:

UCS1-B(nxos)# show interface po100
port-channel100 is up
Hardware: Port-Channel, address: 000d.eccd.665a (bia 000d.eccd.665a)
Description: U: Uplink
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth1/19, Eth1/20

上行端口信道必须是匹配UCS配置的LACP。其他配置可以存在,但是(在最低)您应该看到此配置:

5k# show run int eth1/3

!Command: show running-config interface Ethernet1/3
!Time: Sat Oct 13 00:30:51 2012

version 5.1(3)N2(1)

interface Ethernet1/3
switchport mode trunk
spanning-tree port type edge trunk
channel-group 100 mode active

公告在NXOS设备的spanning-tree port type edge中继。此配置保证,如果链路摆动,端口立即恢复。在故障情况下,重要的是上行交换机端口不通过STP状态移动,延长停机时间。关于此命令的更多信息,参考spanning-tree port type edge

此命令Cisco IOS等同是生成树Portfast中继

有关详细信息,请参阅以下文档:

注意:使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

GUI 配置

  1. 创建端口通道接口。

    116095-configure-ucs-upstream-port-channel-01.jpg

  2. 选择端口并且单击双箭头添加他们到端口通道。

  3. 在您点击芬通社后,端口通道出现作为下来,当LACP用上行交换机时协商。

    116095-configure-ucs-upstream-port-channel-02.jpg

如果上行交换机适当地配置,总体状态移动向UP状态。

故障排除

  • 如果速度是不同的在两边,端口信道不会出来。这是一个常见的错误配置。
  • 您也许需要单个启动所有链路首先和验证相邻端口。请使用show cdp neighbor验证相邻端口。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 116095