IP : 第二层隧道协议(L2TP)

L2在L3网络配置示例间的桥接

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈

简介

本文描述如何桥接在间第3层(L3)网络的Layer2 (L2)网络。

贡献用Atri巴苏,杰伊新泰勒和玛尼Ganesan, Cisco TAC工程师。

先决条件

要求

Cisco 建议您了解以下主题:

  • 第2层隧道协议版本3 (L2TPv3)
  • 通用路由封装 (GRE)

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

在许多情况下,您要求解决方案为了聚集从热点的WiFi流量到中央位置。在这类情况下,解决方案需要允许用户预定设备(CPE)设备桥接从终端主机的以太网流量,并且通过以太网流量封装包对终端。

如果使用聚合服务路由器(ASR),要执行此的简单的方法是使用在软的GRE的以太网。然而,对于集成服务路由器(ISR)和其他CPE设备,这不是选项。在更旧的Cisco IOS版本中,通过桥接与GRE隧道接口的物理接口建立隧道在GRE的L2是可能的。虽然正常桥接从流入数据包剥离VLAN报头,使用在路由器的集成路由和桥接(IRB)能路由和桥接在同一个接口的同一个网络层协议和仍然允许路由器维护从一个接口的VLAN报头到另一个。

注意:当您配置隧道接口的网桥群组在更旧的Cisco IOS版本时, IOS报道命令未发行和不支持的,但是仍然接受命令。在更多最新版本中,此命令是完全过时和错误消息显示。

思科不支持上一个解决方案。桥接的L2网络支持的解决方案将使用L2TPv3正如本文所描述。L2TPv3多种L2协议传输的提供支持类似以太网, 802.1q (VLAN),帧中继、高级数据链路控制(HDLC)和点对点协议(PPP)。本文焦点是以太网分机。

配置

此设置非常基本。路由器r101和r201担当在同一网络的主机,而r100和r202有一个L3接口和一个L2接口。目标将设置L2TPv3连接这样没有所有路由的需求, r101和r201能互相ping。

网络图

隧道配置

L2TP隧道配置包括三个步骤:

  1. 配置L2TP-class (可选)

    此类用于为了定义某验证,并且L2TP的控制参数建立隧道。如果使用它,二末端必须互相反映。
    l2tp-class test
    hostname stanford
    password 7 082E5C4B071F091805

  2. 配置Pseudowire中集集团

    当名称建议,此部分用于为了配置实际通道或“pseudowire”在两个终端之间。定义包含pseudowire封装、终端和控制通道协议的模板。
    pseudowire-class test
    encapsulation l2tpv3
    ip local interface Loopback0
    ip pmtu

  3. 请使用Xconnect为了提供隧道目的地

    绑定L2TP pseudowire到附件电路(往本地L2侧的接口)并且定义其目的地。 

注释的点:

  • 附件电路没有配置的IP地址。
  • 隧道源配置与Ip local interface在pseudowire中集集团部分。
  • 隧道目的地用xconnect命令定义。

考虑事项

  • 如同GRE隧道解决方案,终止L2通道仍然不允许第2层协议在通道间将转发的数据单元的使用路由器(PDU)消息。没有建立隧道适当的第2层协议,此设备不支持,这些消息由L2接口消耗。

  • 建立隧道的第2层协议的支持(Cisco发现协议、生成树协议、VLAN中继协议和链路层发现协议)要求设备是交换机。此交换机需要是意识的L3为了能对隧道流量和限制可能的选择。

  • L3隧道封装取决于执行隧道的设备:
    1. Cisco 7301支持L2TPv3封装。
    2. 思科65xx不支持L2分机用L2TPv3通道。然而, L2可以在与所有传输的一个MLPS核心间被扩展在MPLS (原子)选项。
    3. Cisco4500交换机不支持L2TP通道。

  • 仅单个xconnect隧道接口在物理接口或sub-interface可以配置。独立接口为每个pseudowire终端是需要的。您不能配置与xconnect的多个接口与同样PW中集集团和同样L2TP ID。

  • L2TP通道的最大有效负载最大传输单元(MTU)大小通常是在标准以太网移动的流量的1460个字节。一旦在用户数据报协议(UDP)的L2TP,开销是IP报头(20个字节), UDP报头(8个字节)和L2TP报头(12个字节)的结果。

配置示例

路由器r101配置

interface Ethernet0/0
ip address 172.16.1.100 255.255.255.0

路由器r100配置

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 198.51.100.100 255.255.255.0
!
interface FastEthernet0/1
description LAN
no ip address
speed 100
full-duplex
xconnect 203.0.113.102 1 encapsulation l2tpv3 manual pw-class test
l2tp id 1 2
!
ip route 0.0.0.0 0.0.0.0 198.51.100.1

路由器r202配置

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 203.0.113.102 255.255.255.255

interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 198.51.100.100 1 encapsulation l2tpv3 manual pw-class test
l2tp id 2 1

路由器r201配置

interface Ethernet0/0
ip address 172.16.1.201 255.255.255.0

注意:使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

验证

为了显示关于设置到所有L2TP会话的其他L2TP-enabled设备路由器的L2TP控制通道的详细信息,请使用show l2tun tunnel all命令

为了验证L2TPv3封装适当地运作,请在应该在同样VLAN的远程站点ping主机。如果ping是成功的,您能使用此命令为了确认您的配置适当地工作。命令输出解释程序工具仅限注册用户)支持某些 show 命令。请使用Output Interpreter Tool为了查看show命令输出分析。

  • show arp命令显示地址解析服务(ARP)缓存。

故障排除

目前没有针对此配置的故障排除信息。



Document ID: 116266