IP : 边界网关协议(BGP)

了解BGP MED属性

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文目的将提供一更加好了解边界网关协议(BGP)多出口分辨器(MED)属性,当交叉在自治系统(AS)边界时通过在不同情况下实现它。

当有该AS的时,多个条目入口点MED提供一个动态方法影响另一个AS就象到达一些路由。BGP遵从选择的最佳路径一个系统程序。有被采取在考虑MED属性前认为的其他重要的属性例如权重,本地首选,产生路由和AS路径。因此,如果这些标准中的任一个配比, MED属性不会考虑。

注意: 当其他要素是相等的时,有最低MED的出口点更喜欢。

先决条件

要求

思科建议您有BGP基础知识。

使用的组件

本文档不限于特定的软件和硬件版本。在本文讨论的方案使用这些硬件和软件版本:

  • 情形 1:在Cisco IOS�软件版本12.4或以上的Cisco 2600路由器

  • 方案 2:在Cisco IOS软件版本12.4或以上的Cisco 2600路由器

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

案例研究

场景 1

当BGP扬声器学习从对等体时的一个路由,路由的MED通过给其他内部BGP (iBGP)对等体,但是不对外部BGP (eBGP)并列。

考虑此网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-01.gif

这里,路由器R1和路由器R2在同一样考虑,例如AS#100和路由器R3属于AS#101。对于容易规则,使用在/24块的IP地址。

路由器R1和R2配置如下:

路由器 1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 10.10.10.10
(Config-router)#bgp log-neighbor-changes
(Config-router)#network 10.10.10.10 mask 255.255.255.255 route-map ATTACH_MED
(Config-router)#neighbor 192.1.12.2 remote-as 100
(Config-router)#no auto-summary
(Config)#access-list 10 permit 10.10.10.10
(Config)#route-map ATTACH_MED permit 10
(Config)#match ip address 10
(Config)#set metric 100

路由器 2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.12.1 remote-as 100
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#no auto-summary

路由器R3配置给此处:

路由器 3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)#no synchronization
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

在此设置, R1和R2有iBGP运行。所以,当更新输入与某一量度时的AS,该量度用于做出决策在AS里面。show ip bgp命令,当检查从R2显示您10.10.10.10的度量值,通过iBGP邻居192.1.12.1倾斜,并且有MED值为100。

从R2的输出显示此处:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-02.gif

在R2和R3之间的eBGP运行,因为这些在不同的AS。当同一次更新通过对第三个AS,例如AS#101,量度返回到0。show ip bgp命令,当检查从R3将有其删除的量度,因为10.10.10.10交叉AS boundary(101)。

从R3的输出显示此处:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-03.gif

从此方案是明显的MED属性能影响从相邻的自治系统的流入的数据流。MED属性不能影响更多远程自治系统路由决策。当BGP扬声器学习从对等体时的一个路由,能通过路由的MED对所有iBGP对等体,但是不到eBGP并列。结果, MED有仅相关性在相邻的自治系统之间。

场景 2

如果路由被注入BGP (或者使用网络redistribute命令)来自IGP (RIP或EIGRP或者OSPF), MED从IGP量度派生,并且路由通告给有此MED的一个EBGP邻居。

此方案使用此网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-04.gif

在此网络中, R1在RIP网络配置运行。路由器R2和R3运行BGP, R2配置与AS 100,当R3是AS 101时。

路由器R1配置如下:

路由器 R1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router rip
(Config-router)#network 10.0.0.0
(Config-router)#network 192.1.12.0
(Config-router)#no auto-summary

路由器R2和R3为BGP配置,再分配在R2完成为了注入RIP网络到BGP。

路由器 R2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router rip
(Config-router)# network 192.1.12.0
(Config-router)#no auto-summary
(Config-router)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#redistribute rip metric 1
 Config-router)#no auto-summary

路由器 R3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)# no synchronization
(Config-router)#bgp router-id 33.33.33.33
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

在R2运行的RIP和BGP。使用show ip bgp命令,如果检查,您能看到前缀10.0.0.0网络以量度1表示,从RIP派生。

从R2的输出显示此处:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-05.gif

然而,在eBGP运行的R3,网络通过考虑MED值通告从IGP得到。在这种情况下它是RIP。前缀10.0.0.0通告与IGP MED值,是RIP的量度1。

这在此输出中能被看到:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-06.gif

从此方案MED的行为,一旦redistribute命令的网络被注入对BGP路由器通过网络或,清楚看见实际MED值用那IGP量度的地方替换。现在,在的情况下此属性是提示给关于路径首选的外部邻居到AS。如陈述前,总是没有考虑是否有确定其他更多的重要的属性最佳路由。为了有与一个更加确定的属性的同样效果,请使用set as-path prepend命令在路由映射下。如果加在前面某些路由的AS路径,将继续由其他AS看到。关于As-path prepend的更多信息使用情况,参考的使用设置aspath加在前面命令

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 112965